Page 1 of 1

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 10:15 am
by ErfanDL
RB951Ui after some minutes Bandwidth test crashing and reboot

Image

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 11:04 am
by snix
mrz

Here is an example from RB1100AHx2:
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1bond                          ether            1500  1598       9498 12:34:56:78:90:18
 1  RS ether2bond                          ether            1500  1598       9498 12:34:56:78:90:19
 2  R  bond                                bond             1500                  12:34:56:78:90:18
 3  R  vlan                                vlan             1500                  12:34:56:78:90:18
 
My questions now are:
- Why isn't L2MTU visible on the physical interface on the CHR ? Probably driver doesn't support it? Why is L2MTU visible on the bonded interface than?
- Why isn't L2MTU visible on the bond interface on the RB1100AHx2 ?
- Why can a VLAN be configured with 1500 MTU directly on a physical interface but not on a bonded interface on the CHR?
- Why can a VLAN be configured with 1500 MTU on a bonded interface on the RB1100AHx2?

Thank you again for your response.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 12:18 pm
by mrz
1. Interface does not support l2mtu
2.Probably because on RB1100 you have an old version, shows l2mtu on mine:

[admin@rack1_b6] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE ACTUAL-MTU L2MTU MAX-L2MTU MAC-ADDRESS
..
5 RS ether6 ether 1500 1598 9498 4C:5E:0C:48:B1:2A
6 RS ether7 ether 1500 1598 9498 4C:5E:0C:48:B1:2B
..
13 R bonding1 bond 1500 1598

3.,4. because L2MTU supports more than 1500.

Re: v6.37.1 [current] is released!

Posted: Sun Oct 30, 2016 7:32 pm
by BlackVS
Had working config on RB951G, v.6.34
After upgrade to 6.37.1 found issue with wrong masquerade behavior:

I have PPTP server on one side (CCR) and PPTP client (RB951G) on other side.
Behind CCR we have a lot of work networks.
Behind RB951 we have home network.
Due to I don't want add routes on CCR for home network I did masquerade for forwarded via PPTP packets from home network (i.e hid home network).
Before upgrade source address during masquerade was changed to the client's PPTP address. It is correct.
After upgrade router uses WAN address as new masquerade source address for packets forwarded from LAN via PPTP tunnel. It is wrong.
Bug?

To correct this I changed from masquerade to src-nat rule and set manually needed ip for forwarded packets.

Re: v6.37.1 [current] is released!

Posted: Sun Oct 30, 2016 11:27 pm
by Aug
Well THAT didn't go well... Upgraded a RB750G from v6.35.2 to v6.37.1 and:

- CPU usage spiked after the update and remained high on a router that normally never goes above 5% CPU load
- Firewall filter rules based on ConnTracking connection state lost that setting. Rather than connection-state=invalid or connection-state=established it showed connection-state=""

I promptly unplugged the external connection, downgraded to v6.34.6 restored my config from backup, and triple checked everything.

Same problem with firewall rules. They used to be correct. All on RB411's.

With 5.26 it's
add chain=forward comment="allow established connections" connection-state=established
add chain=forward comment="allow related connections" connection-state=related
add action=drop chain=forward comment="drop invalid connections" connection-state=invalid


With 6.37.1 it's this.
add action=accept chain=forward comment="allow established connections" connection-state=""
add action=accept chain=forward comment="allow related connections" connection-state=""
add action=drop chain=forward comment="drop invalid connections" connection-state=""

Re: v6.37.1 [current] is released!

Posted: Mon Oct 31, 2016 6:45 am
by BlackVS
With 6.37.1 it's this.
add action=accept chain=forward comment="allow established connections" connection-state=""
add action=accept chain=forward comment="allow related connections" connection-state=""
add action=drop chain=forward comment="drop invalid connections" connection-state=""
Thanks, now I understand why these checkboxes were cleared on one of my routers too...
Now I have to recheck all routers for this.
Damn.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 11:36 am
by omidkosari
Since upgrade fro 6.34.6 to 6.37.1 , most of schedules doesn't run !! Same behavior on 5 different routers with different schedules and scripts .
Note1: Running that script manually works .
Note2: Few schedules work and i am investigating the difference between them .

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 2:41 pm
by darkprocess
Hello same behaviour here, i had to recreate the schedules to make it work

Envoyé de mon SM-G925F en utilisant Tapatalk

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:06 pm
by omidkosari
Found the bug and solution.
Any simple schedule for running need at least these permissions.

policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:29 pm
by mrz
If your script has more permissions that scheduler then scheduler will not be able to execute the script.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:37 pm
by omidkosari
If your script has more permissions that scheduler then scheduler will not be able to execute the script.
Before upgrade to this version your sentence was correct but now it is not correct anymore .
Now any schedule SIMPLE script need those permissions to run . It is a bug

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 4:28 pm
by MrcS
Hello there, this is my first post in this forum. Well, I'm facing an issue with IPv6 since the first time my ISP offered it, a few months ago.

My problem is this: I have a link with two RBs, one RB750 as modem client and one RB433 as last mile in my home.
The ISP offers me a /64 and an IPv6 address as usual.
The /64 I send to a pool and that pool is used by the DHCPv6 Server in the RB750.
It goes fine with the RB433 getting the block with DHCPv6 Client and the route is created ok in the RB750. OK till here!

BUT if the RB750 gets rebooted by any reason, it's DHCPv6 Server generates a dynamic route to my /64 pointing to nothing.
And thus, my valid route loses preference and my /64 becomes unreachable until I manually delete that single dynamic route (the other is correct).

Image

Edit: I'm posting this here as It still hasn't been fixed and affects this version too.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 5:11 pm
by strods
Aug - This issue will be fixed in next rc release.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 5:46 pm
by morze
Hello everyone! Using CHR 10Gbit on ESXi 6.5 with 5 vmxnet adapters, I was very surprised with this update! First after update it did not boot. А hour search for a solution let me to think that too little RAM (128 MiB!). After setting RAM to 512 MB it's started and worked, I have used it for two weaks and there was very strange hangs with google and youtube sites (some time normal after reboot and again and again). Have downgraded to 6.36.4 and all working fine now and memory usage is 75 MiB (was >200 with this update).

Image

To be honest, I did not understand this "update". Nothing personal, it's better to remove it from official releases, Sorry for poor English, hope this helps to do RouterOS better! :)

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:09 pm
by morze
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
I think the "fix" is to set more RAM (>300 MiB) and may be some more disk space for VM, but it's better do not upgrade. At least this time, something went wrong... =)

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:18 pm
by mrz
If your script has more permissions that scheduler then scheduler will not be able to execute the script.
Before upgrade to this version your sentence was correct but now it is not correct anymore .
Now any schedule SIMPLE script need those permissions to run . It is a bug
No it does not require such policies to run a script, unless script itself require such policies.

[admin@rack1_hexv3_up] /system script> print
Flags: I - invalid
0 name="script3" owner="admin" policy=write last-started=nov/01/2016 16:11:39
run-count=12 source=:log info "ptest3"
[admin@rack1_hexv3_up] /system scheduler> print detail
Flags: X - disabled
0 name="schedule3" start-date=nov/01/2016 start-time=16:10:19 interval=10s
on-event=script3 owner="admin" policy=write run-count=10 next-run=16:12:19


Such scheduler executes a script with only "write" policy, so your statement is wrong.
Now if I change script policies to "write,test", then scheduler with only "write" policy will not be able to execute the script.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:52 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
I think the "fix" is to set more RAM (>300 MiB) and may be some more disk space for VM, but it's better do not upgrade. At least this time, something went wrong... =)
It has 1 GB of RAM and 1 GB of disk. The problem according to guesses is the use of synthetic network cards. Waiting fot fix still.

Re: v6.37.1 [current] is released!

Posted: Wed Nov 02, 2016 4:30 pm
by Chupaka
- Why can a VLAN be configured with 1500 MTU directly on a physical interface but not on a bonded interface on the CHR?
- Why can a VLAN be configured with 1500 MTU on a bonded interface on the RB1100AHx2?
I faced that weird behaviour this night after upgrading one of our x86 routers: VLAN interface is here on bonding, but it's not working, and after disabling it it was impossible to enable it back ("error enabling VLAN - cannot set mtu" or something like that). The solution was just "/interface set bonding1 l2-mtu=1504". The bad thing is that you cannot change L2-MTU via WinBox (so it was not obvious that it IS changeable), and you cannot change l2-mtu via, for example, "/interface bond set" menu - you need to use exactly "/interface set"

Re: v6.37.1 [current] is released!

Posted: Thu Nov 03, 2016 4:04 pm
by ste
The AP selection mechanism has changed.

All our APs have the same SSID. We direct the CPEs to APs using Accesslists. So all CPEs are forbidden by default and only allowed on one sector we want them to connect.

With new wireless package not all available APs are tested. The cpe tries only to connect to 2 of them and if not allowed at this 2 it does not connect to an available third AP. We see "wlan1: failed to connect, not allowed" with 2 different frequencies. So after updating some CPEs never reconnect.

Not mentioned in changelog and not easy to see in lab :-(.

Re: v6.37.1 [current] is released!

Posted: Sun Nov 06, 2016 9:36 pm
by Chupaka
okay, VLANs on Bonding are completely unusable in this version. the router rebooted, l2-mtu is back to 1500 and now I can't even change it:
[admin@Beta] > /interface 
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
[admin@Beta] /interface> set 0 l2mtu=1504                
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
this evening was a bit painful...

UPD: l2-mtu of bonding is unchangeable now on any actual version: 6.36.4, 6.37.1, 6.38rc24 :shock:

Rolled back to 6.33. VLAN is working...

Re: v6.37.1 [current] is released!

Posted: Sun Nov 06, 2016 10:32 pm
by msatter
I am on a new RB750Gr3 and have a problem that the IPv6 is not getting bound when using "renew". I have now to do the following before I gets bound correctly:

interface pppoe-client set pppoe-xs4all-inet max-mtu=1480;
interface pppoe-client set pppoe-xs4all-inet max-mtu=1500;
ipv6 dhcp-client release 0;

Config:
/ipv6 address
add address=2001:x:x:0:1::2 interface=pppoe-xs4all-inet
add address=2001:x:x:0:2::1 advertise=no comment="Advertise off so clients won't get an external IPv6 automatic. interface=2-uplink-switch-master
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-xs4all-inet pool-name=xs4all-v6prefix pool-prefix-length=48 request=prefix use-peer-dns=no
/ipv6 nd - set [ find default=yes ] hop-limit=64 ra-lifetime=2h
/ipv6 settings - set max-neighbor-entries=1024

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 10:37 am
by jobo
Looks like IPv6 is gone in CCR 1072 after upgrading. CCR1016 still got IPv6 with 6.37.1 tho.

IPv6 is gone after disabling wireless package?

Image

Image

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 3:30 pm
by strods
jobo - Please use "Tool/Clear Cache" in Winbox loader before you connect to device. Then it should be back.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 3:48 pm
by Cha0s
okay, VLANs on Bonding are completely unusable in this version. the router rebooted, l2-mtu is back to 1500 and now I can't even change it:
[admin@Beta] > /interface 
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
[admin@Beta] /interface> set 0 l2mtu=1504                
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
this evening was a bit painful...

UPD: l2-mtu of bonding is unchangeable now on any actual version: 6.36.4, 6.37.1, 6.38rc24 :shock:

Rolled back to 6.33. VLAN is working...
I have multiple vlans under bonding and even under vrrp under bonding and I don't have the issue you describe with 6.37.1.

L2MTU on the bonding interface is 1598
L2MTU on the VRRP interface is 1598
L2MTU on the VLAN interfaces is 1594

MTU is 1500 on all interfaces.

Both routers where I have this configuration have over 14days uptime.

I don't recall when L2MTU stopped being 'editable'. I've never had to change it tbh.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 4:27 pm
by SamSpade
I am running Dude as a CHR on HyperV. I imported database from old version of Dude and everything seems ok except I got no custom pictures of devices I set-up on previous instalation.
Second thing: legend field is empty on all link graphs (see picture)
Image

Does anybody knows solution to this problems?

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 4:39 pm
by jobo
jobo - Please use "Tool/Clear Cache" in Winbox loader before you connect to device. Then it should be back.
OK this helped thanks!

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 11:58 pm
by Chupaka
I have multiple vlans under bonding and even under vrrp under bonding and I don't have the issue you describe with 6.37.1.

L2MTU on the bonding interface is 1598
L2MTU on the VRRP interface is 1598
L2MTU on the VLAN interfaces is 1594

MTU is 1500 on all interfaces.

I don't recall when L2MTU stopped being 'editable'. I've never had to change it tbh.
please check l2-mtu of ethernets in bonding. mine are empty - looks like it can be the reason:
[admin@TestPlace] > interface print where name~"(bonding1|ether6|ether7)" 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether6              ether            1500                  00:50:56:BE:1F:E4
 1  RS ether7              ether            1500                  00:50:56:BE:08:9C
 2  R  bonding1            bond             1500  1500            00:50:56:BE:1F:E4
[admin@TestPlace] > 
this is from ESXi VM, but on hardware router I have the same behaviour

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 12:03 am
by Cha0s
[cha0s@****] > interface print where name~"(bonding1|ether1-|ether2)" 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1-switch1-port1                ether            1500  1598       4074 D4:CA:6D:**:**:**
 1  RS ether2-switch2-port1                ether            1500  1598       4074 D4:CA:6D:**:**:**
 2  R  bonding1                            bond             1500  1598            D4:CA:6D:**:**:**
These are from an RB2011UiAS-RM.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 12:24 am
by Cha0s
I confirm that on an esxi VM L2MTU is empty on 6.37.1
[cha0s@MikroTik] > interface print where name~"(ether1|ether2)"           
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  R  ether1-public                       ether            1500                  00:50:56:84:58:2E
 1  R  ether2-lan                          ether            1500                  00:50:56:84:78:D9
I checked arm, mipsbe, ppc, tile and all show L2MTU properly. Probably an x86-only bug?

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 1:14 am
by Chupaka
I checked arm, mipsbe, ppc, tile and all show L2MTU properly. Probably an x86-only bug?
it's driver-dependent. here's my router in subject:
[x@y] > int print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  RS ether1                              ether            1500
 1  RS ether2                              ether            1500
 2  R  ether3                              ether            1500
 3  R  ether4                              ether            1500
 4     ether5                              ether            1500  9014
 5  R  Core                                vlan             1500
 6  R  bonding1                            bond             1500
ether5 has l2-mtu for some reason :) it's Intel 82574L, and ether1-4 are 82576

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 1:55 am
by SpartanX
I'm just reporting an odd glitch I had when I upgraded to this release on Sunday morning. It might not be important, but...

I upgraded at about 8:10am Sunday. Today, I became aware of some UDP packet loss with an online application I use; averaging around 4% loss. As a first step I rebooted my FTTC modem and 850Gx2 router via the web interfaces. Nothing changed. I went through a load of troubleshooting including even replacing my NIC.

Then I remembered I use a ping-recording service, so I checked that and saw packet loss there, from the moment I upgraded the firmware. The router answers the pings. Graphs are attached below.

After checking more things and rebooting (via the web interface) again with no change, it occurred to me to properly power-cycle the router by remote. It's on an APC remote PDU.

That immediately stopped the packet loss. It was definitely what fixed it. In the graphs (which you can see better if you click on them) it is apparent when the packet loss started on the first graph. The time correlates with the router's log showing the upgrade. The second graph shows when I power cycled the router and the packet loss stopping.

Image

Image

Moral of the story: don't trust a software restart!

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 7:25 am
by BlackVS
One more strange thing happened on one router (CCR1016) with 6.37.1.
It has two WANs with loadbalancing/backup and few days ago one channel down.
I thought that it is provider related problem (due to I couldn't ping gate, physical link was ok) and even started to contact with him but looked at log and saw a lot of fcs erors on this port (broken checksums).
Hm... I just disabled/enabled port and all channel up again.
I'm not sure is it provider related problem or router/firmware.
It was first time such channel down.
I reverted to the stable 6.36.4 - no problem...

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 7:15 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
Ok now I know that this is related to Network Adapters in Hyper-V on Windows Server 2012 R2 and possible older versions.
If I test with Legacy Network Adapters everything works except that performance takes a bit hit.
Running on Windows 10 Hyper-V works with these Network Adapters so this is related to 2012 R2 or older.
Still waiting for a fix.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 1:17 pm
by amtisrac
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
I'm try downgrade to 6.36.4, same results.
Latest stable version is 6.36.3 (on my hyper-v 2012 r2)
On the 6.36.4 changelog I see two thing, probably these are the reasons:
*) ethernet - added support for LAN9514 ethernet dongle;
*) ethernet - allow to force mtu value when actual-mtu is already the same;

Image
Image

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 2:26 pm
by pikpik
  status: radar-detecting
                channel: 5640/20-eC/an/DP (3440)
            noise-floor: -111dBm
  authenticated-clients: 0
      current-tx-powers: 6Mbps:19(19/22),9Mbps:19(19/22),12Mbps:19(19/22),18Mbps:19(19/22),24Mbps:19(19/22),36Mbps:16(16/19),48Mbps:14(14/17),
                         54Mbps:13(13/16),HT20-0:19(19/22),HT20-1:18(18/21),HT20-2:17(17/20),HT20-3:17(17/20),HT20-4:16(16/19),HT20-5:14(14/17),
                         HT20-6:13(13/16),HT20-7:12(12/15),HT40-0:18(18/21),HT40-1:17(17/20),HT40-2:16(16/19),HT40-3:16(16/19),HT40-4:15(15/18),
                         HT40-5:13(13/16),HT40-6:12(12/15),HT40-7:11(11/14)
    notify-external-fdb: no
Why i can connect only on 3 channels from all ? Country poland.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 6:38 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
I'm try downgrade to 6.36.4, same results.
Latest stable version is 6.36.3 (on my hyper-v 2012 r2)
On the 6.36.4 changelog I see two thing, probably these are the reasons:
*) ethernet - added support for LAN9514 ethernet dongle;
*) ethernet - allow to force mtu value when actual-mtu is already the same;

Image
Image
This is related to using Network Adapters in Hyper-V on server 2012 R2. Tested on Windows 10 and that works with same setup.
If you switch the network cards to Legacy Network adapters it will work on 2012 R2 Hyper-v but performance turns to shit.
I have noted this to Mikrotik who have only tested on Windows 10 which is a different version of Hyper-V.
Will update when I get response from support.

Re: v6.37.1 [current] is released!

Posted: Sun Nov 13, 2016 8:48 pm
by akarag
Hello,

I have some issues with version 6.37.1 on a hex v3. I upgraded one from 6.36.3 to 6.37.1 and noticed two issues

1. On the ethernet interfaces, the information concerning the master port, TX/RX and switch port are missing. This was extremely useful in order to quickly check the settings of the interfaces (swict port)

2. The log window is not automatically scrolled in the occurrence of new events. I need to close the log window and reopen it in order to see the last events in the log list.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 14, 2016 10:53 pm
by stroebs
Unable to run scripts by referring to their names in 6.37.1...
This happens when called from other scripts or from terminal.

Image

Re: v6.37.1 [current] is released!

Posted: Tue Nov 15, 2016 11:51 am
by mrz
Script that you are trying to run tries to access something that does not exist in current configuration.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 17, 2016 8:55 am
by alext8409
Still terrible behavior of the vpn server since v6.34. L2tp ipsec server is up, remote client connects successfully, then after a while it just hangs up and terminating the session. Another great thing happens on v6.38 - the client connects and stays connected as long as you need until you start to transfer data via the tunnel, 1-2 minutes of copying (direction doesn't matter) ang hungup again! I just can't get it how such a vital and useful function of a router can behavior this way. I would probably leave the v.6.34, where the vpn connection is stable as a rock, but there is another bug - when you change proposal settings, the dynamic peer just dissapears and you have to restore from the backup! Fix this please!

Re: v6.37.1 [current] is released!

Posted: Sun Nov 20, 2016 9:49 am
by Temches
Device: hAp lite

Problem with old legacy wireless devices (for example Intel(R) PRO/Wireless 2200BG) still persist in 6.37.1 and 6.38rc7 ... can`t connect to network with WPA or WPA2 encryption. without - all fine.

Always getting "extensive data loss".

After downgrading to 6.34.6 - all fine, wireless-cm2 package works perfecty!
This is a major issue for me as well! Please consider creating a 6.36.4 as bugfix-version because it is the lastest version supporting wireless-cm2.I have >50 devices with Intel(R) PRO/Wireless 2200BG and >40 older wireless IP-Cams which do not work wir current wireless-package. I'm also running a big camtsite-installation where the clients have thousands of different devices. I worry that some clients cannot use our wifi.
Same problem, my old smartphone philips w732 could not connect to wifi router. On 6.36.4 works just fine. Is any fixes for this?

Re: v6.37.1 [current] is released!

Posted: Mon Nov 21, 2016 9:43 am
by notToNew
Same problem, my old smartphone philips w732 could not connect to wifi router. On 6.36.4 works just fine. Is any fixes for this?
Yes, this is the new "feature". If you use unencrypted wifi (clear the WPA-encryption), it works. (Thats why I moved to 6.36.4, and i'm happy that they support 6.36 as the last version with the old workung packet in the bugfix-branch. I hope they create a kind of an LTS-Version of this branch.)

Re: v6.37.1 [current] is released!

Posted: Mon Nov 21, 2016 8:00 pm
by novelty22
edit: Sorry, wrong thread

Re: v6.37.1 [current] is released!

Posted: Tue Nov 22, 2016 12:21 am
by 105547111
6.37.2 is released, where's the announcement?

Re: v6.37.1 [current] is released!

Posted: Tue Nov 22, 2016 9:15 am
by strods
6.37.2 has been released. Please read changelog before upgrade:
http://forum.mikrotik.com/viewtopic.php?f=21&t=114926