Page 1 of 1

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 12:11 pm
by strods
notToNew - In Winbox go to Settings/Inline Comments

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 12:19 pm
by miharoot
and again100% cpu load without any real load, management and snmp:
Image
its not good.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 1:22 pm
by bonz
wAP AC wireless or system problem.

I use it in CPE mode!
5Ghz mode i use for wan connection, connecting pefectly - ping google (fine) (i think in pseudobridge mode, by default anyway)
I use it as bridge device in bridge mode (ewerything is fine)! trough Lan I get trafic from outside to my devices, send and get IPs - ewerything wokrk perfect with hi speed.
when I try to repeat 2.4Ghz from same router, with same ssd, same password it crashes! (different mac adreses for both 2,4 and 5Ghz wan's)
but when try repeat from other device in same way - WORKS WELL :(
used metod for repepeat (in wireless/repeater. Copy mac from wlan device i wan't to reapeat, copy ssid, same pasword and paste it)

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 1:25 pm
by dgcapel
I had the problem of add a new static DNS entry and then all connection (web, email, etc) redirect to the address.
This generate a big problem in a company with computers DNS cache's.

/ip dns
set allow-remote-requests=yes cache-size=10240KiB servers=\
8.8.8.8,8.8.4.4

add address=192.168.x.88 name=lala.lala.com

Thanks.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 1:41 pm
by notToNew
notToNew - In Winbox go to Settings/Inline Comments
This is my default setting, and ich rechecked it, but i still cannot see this comment.
Scee screenshot below. The comment collumn is present in most other windows, but missing in this one.

Image

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 4:45 pm
by ryz
notToNew:

Winbox SETTINGS / INLINE COMMENTS (above Safe Mode on your screen)

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 4:52 pm
by notToNew
notToNew:
Winbox SETTINGS / INLINE COMMENTS (above Safe Mode on your screen)
As i mentioned, I have this checked(activated) but still cannot see the comments in this window, other windows show the comments just as expected!

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 6:33 pm
by dominicbatty
I am seeing the loss of a remote CRS224 switch, which is linked to the network via a fibre SFP module. If I take the unit back to 6.36.3 it works fine, upgrade to either 6.37.1 or 6.38rc10 and it does not appear to allow traffic over the SFP module link. If I connect to the remote switch directly it seems to be working fine it's just something has changed which is stopping my link working, even through the SFP module says its up. Logged in with support this evening, awaiting their response. Cheers, Dominic.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 07, 2016 10:50 pm
by eddieb
I had the problem of add a new static DNS entry and then all connection (web, email, etc) redirect to the address.
This generate a big problem in a company with computers DNS cache's.

/ip dns
set allow-remote-requests=yes cache-size=10240KiB servers=\
8.8.8.8,8.8.4.4

add address=192.168.x.88 name=lala.lala.com

Thanks.
I had exactly this problem !!!
RB2011
modification to config made with winbox
added 1 static IP for 192.168.0.184
after that, all dns requests received 192.168.0.184 as answer !!!!
so google.com got 192.168.0.184 ...

had to remove this IP from static dns table and reboot to solve the problem for now !

Eddie

Re: v6.37.1 [current] is released!

Posted: Sun Oct 09, 2016 5:21 am
by ch36mikrot
Thanks ,strods

However, I managed to downgrade to 6.36.4 and re-import the certificates (CA and Server)
it worked as usual (SSTPVPN) normally, and then I upgraded to 6.37.1 , it also worked normally till now.

I found it strange that the CA cannot import private key. (The status just T, not KT)
Image

I remembered it should be imported originally(Both KT), and I can ensure that both(CA and Server) status were KT before re-importing.
Is there and policy changed regarding the certificate?


ch36mikrot - Most likely it was working all the time incorrectly. You might need to generate new, proper certificate:
!) ssl - fixed peer address/dns verification from certificate (affects sstp, fetch, capsman);

ik3umt - As it has been also with others, most likely FastTrack was not working in past. For example, you have PPPoE + FastTrack. You live happily and think that it is working but it is not because PPPoE does not support FastTrack. Now MikroTik adds support for PPPoE FastTrack, you upgrade device and think that everything is broken. It simply is what FastTrack does - skips firewall, queues, etc...

http://wiki.mikrotik.com/index.php?titl ... edirect=no

Re: v6.37.1 [current] is released!

Posted: Tue Oct 11, 2016 10:43 am
by notToNew
However, I managed to downgrade to 6.36.4 ...
Does this version exist? I know 6.36.3. I would be interested in this aswell, as i cann't upgrade to 6.37 because of wireless-issues.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 11, 2016 11:32 am
by makstex
Image

Re: v6.37.1 [current] is released!

Posted: Tue Oct 11, 2016 12:20 pm
by strods
makstex - Please send supout.rif file from your device to support@mikrotik.com

Re: v6.37.1 [current] is released!

Posted: Tue Oct 11, 2016 1:45 pm
by mercury13
Hello!!!

After upgrade from 6.34.6 to 6.37.1 all routers after any time loose default route received from dhcp-client and routes from ospf... Main interface (ether1) don't TX, but RX. Problem fix disable/enable ether1 or restart dhcp-client, but if one router is down or reboot situation is repeat. Downgrade all routers to 6.34.6 fix problem.

Any idea how to upgrades to current version without clear configuration on all routers?

Tnx!

Re: v6.37.1 [current] is released!

Posted: Tue Oct 11, 2016 7:06 pm
by nacer
Hi,

For information.

I had an issues with this version with RB2011UiAS-2HnD-IN
It was running for 5 days with no problem but this morning there was no internet connection. I have bridge connection with VDSL modem.
Winbox can see the router but can not connect with IP or macid.
After lots of try with different pc's I reset router from touch panel. With default configuration I can access router from mac id but can not with IP.
Restored backup and same thing happened again. Winbox can see router but can not connect.
Than I re-reset router from touch panel, with default config. upgrade to latest RC, and restored my backup.
It worked.

Re: v6.37.1 [current] is released!

Posted: Thu Oct 13, 2016 4:25 pm
by Hotz1
We just started upgrading some of our equipment from 6.36.3 to 6.37.1, and found an undocumented change:

Empty SSIDs are now forbidden in AP mode. I find no mention of this in the change log.

We often configure single-radio APs with a dozen VirtualAPs or more. When we do this, we set the physical interface with a hidden, blank SSID. Now we have to put some arbitrary string in the 'ssid' field--which we are going to hide, and don't want anyone to connect to anyway!

I'm not sure what precipitated this change, but as with early versions of Winbox 3 no longer remembering passwords: when a few people suggest that something should work differently, and it isn't an outright bug, it's a good idea to run it by the rest of the user community first, in case even more people want it to stay as it is! For me, this "feature" represents a loss of functionality that I intentionally use.

Re: v6.37.1 [current] is released!

Posted: Thu Oct 13, 2016 6:29 pm
by miharoot
Old (2.3.6) android smart cannot connect via wifi, connect\disconnect in one second.
Often CPU load100% but no really load.
I am fed and downgraded to 6.34.6

Re: v6.37.1 [current] is released!

Posted: Thu Oct 13, 2016 6:33 pm
by notToNew
Old (2.3.6) android smart cannot connect via wifi, connect\disconnect in one second.
This is a known problem with new wireless-package. only old wireless-cm2 works with some legacy-devices.

Re: v6.37.1 [current] is released!

Posted: Thu Oct 13, 2016 6:52 pm
by kristaps
@miharoot and if you disable security profiles WPA2 for test does phone connect, and stay stable ?

Re: v6.37.1 [current] is released!

Posted: Fri Oct 14, 2016 2:55 pm
by ErfanDL
Spectral Scan in hAP Lite make crashing router and hanging please fix

Re: v6.37.1 [current] is released!

Posted: Fri Oct 14, 2016 5:34 pm
by zap71
I just upgraded from 6.34.2 to 6.37.1 and ended up with all my WLANs (I have three of them) broken.

The steps to reactivate them were:
1. Enable the wlan interface again
2. I got my last backup dump of the configuration and copy/pasted the configuration of the wlan1 interface to the console
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n default-authentication=no \
    default-forwarding=no disabled=no distance=indoors frequency=2442 mode=\
    ap-bridge name=<INTERFACENAME> ssid="<SSSID>"
The ssid parameter was empty in the backup and as soon as I set it to something everything started working again.

Re: v6.37.1 [current] is released!

Posted: Sat Oct 15, 2016 3:57 pm
by spindlow2016
Where can I configure LLDP, I cant find anything related to it in "/ip neighbor" or anywhere else.

Re: v6.37.1 [current] is released!

Posted: Sat Oct 15, 2016 10:02 pm
by tjc
Well THAT didn't go well... Upgraded a RB750G from v6.35.2 to v6.37.1 and:

- CPU usage spiked after the update and remained high on a router that normally never goes above 5% CPU load
- Firewall filter rules based on ConnTracking connection state lost that setting. Rather than connection-state=invalid or connection-state=established it showed connection-state=""

I promptly unplugged the external connection, downgraded to v6.34.6 restored my config from backup, and triple checked everything.

Re: v6.37.1 [current] is released!

Posted: Sun Oct 16, 2016 10:24 am
by dvl
Hello.
In my case something goes wrong.
When package "wireless" enabled WLAN interface is disabled. When I try to enable it after few minutes router goes to reboot. I have disabled package "wireless" and for now it work stable.

model: RouterBOARD 941-2nD
serial-number: 5B3205016146
firmware-type: qca9531L
factory-firmware: 3.22
current-firmware: 3.33
upgrade-firmware: 3.33

Re: v6.37.1 [current] is released!

Posted: Sun Oct 16, 2016 3:52 pm
by okrug
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...

Re: v6.37.1 [current] is released!

Posted: Mon Oct 17, 2016 12:50 am
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
I did get a reply from support and they said they are aware of the problem and will be fixed. For the moment the solution is 6.36.3 :)
I do however test every RC release and will update if I manage to get it to start on a RC.

Re: v6.37.1 [current] is released!

Posted: Mon Oct 17, 2016 2:55 pm
by lz1dsb
I upgraded all of my Routerboard devices from 6.36.3 to 6.37.1 with no issues, no additional restart was necessary. Here are the models:
RB951G, RB951Ui, hAP ac, wAP, wAP ac


Boyan

Re: v6.37.1 [current] is released!

Posted: Mon Oct 17, 2016 8:37 pm
by daimosship
Hi.
I have trouble with L2TP with IPSec VPN server configuration.
I have Cisco ASA 5505 as a router and MikroTik CCR1036 behind NAT (RouterOS 6.37.1)
I configured L2TP server, IPSec policies, peers (port 500UDp and 4500UDP), proposals, PPP secrets on MikroTik.
Also i configured ACL - esp, tcp, udp and NAT Rules on Cisco - ports udp 500, 1701 and 4500.
I can connect from local PC to MikroTik VPN L2TP Server, but i cant`t connect to MikroTik VPN L2TP Server form Internet through Cisco.
In log i see packets from internet to VPN server.
I tried to deploy Microsoft RRAS with L2TP VPN server and I could connect to it from Internet through. So, i configured Cisco correctly.
May be exist some additional parameters for this configuration?

I found on page http://wiki.mikrotik.com/wiki/Manual:IP ... behind_NAT that " Warning: Only one L2TP/IpSec connection can be established through the NAT. Which means that only one client can connect to the sever located behind the same router."

Maybe it's ever fixed?

Thank.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 18, 2016 9:31 am
by notToNew
After upgrade from 6.36.3 to 3.37.1 ui lost my WIFI-Configuration.
It just created the two main wifi-interfaces and lost all virtual interfaces.
I reverted back to 6.36.3, but even restoring the backup-file does not bring back my wifi-configuration.
I do have a export compact, so i manually _can_ restore the config,
but somehow I lost some trust in normal backup-files....

I checked the other config as well: only wifi is missing.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 18, 2016 9:51 am
by MartijnVdS
After upgrade from 6.36.3 to 3.37.1 ui lost my WIFI-Configuration.
It just created the two main wifi-interfaces and lost all virtual interfaces.
I reverted back to 6.36.3, but even restoring the backup-file does not bring back my wifi-configuration.
I do have a export compact, so i manually _can_ restore the config,
but somehow I lost some trust in normal backup-files....

I checked the other config as well: only wifi is missing.
Did you have an empty SSID on one of the AP interfaces? The new wifi package can't handle those.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 18, 2016 12:39 pm
by notToNew
Did you have an empty SSID on one of the AP interfaces? The new wifi package can't handle those.
I checked it: no, all ssid's are set.
But even then, i think after reverting to the SAME firmware, I think a backup should be possible to be restored.

It was possible to just copy any paste most missing code to the "export-compact" backup, especially the part
in "/interface wireless".

in "/interface wireless connect-list" the interfaces were missing.
I had to add
interface=wlan1_wan
to every single item.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 18, 2016 7:28 pm
by valmis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]

I tested the 6.37.1 in CCR1036, RB2011, RB951G, RBwAP2 and x86 with XenServer, all good!, if you can try XenServer

Re: v6.37.1 [current] is released!

Posted: Tue Oct 18, 2016 11:44 pm
by LogicalNZ
We are having all kinds of NAT issues with 3.37.1

We have a VoIP server behind a 1016 running 3.37.1 and have a Dest NAT rule from the public IP address to the VoIP servers IP address.

The Phones can register with no issue. But when you look in the VoIP server it say the phones are registering from the LAN address of the 1016 rather than the Public IP address of wherever the phones are connected.

We are also seeing this behavior with other types of traffic (Not just VoIP)

Has anyone else seen these issues?

Re: v6.37.1 [current] is released!

Posted: Wed Oct 19, 2016 1:54 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]

I tested the 6.37.1 in CCR1036, RB2011, RB951G, RBwAP2 and x86 with XenServer, all good!, if you can try XenServer
I will wait for a version that works. Move to a diffrent hypervisor just for this do not seem to be a good idea if you ask me :-)
My 493G is running 6.37.1 and there are no problems there.

Re: v6.37.1 [current] is released!

Posted: Wed Oct 19, 2016 2:10 pm
by Chupaka
We are having all kinds of NAT issues with 3.37.1

We have a VoIP server behind a 1016 running 3.37.1 and have a Dest NAT rule from the public IP address to the VoIP servers IP address.

The Phones can register with no issue. But when you look in the VoIP server it say the phones are registering from the LAN address of the 1016 rather than the Public IP address of wherever the phones are connected.

We are also seeing this behavior with other types of traffic (Not just VoIP)

Has anyone else seen these issues?
the issue is not with DstNAT but with SrcNAT. check other NAT rules (with action=masquerade, probably)

Re: v6.37.1 [current] is released!

Posted: Wed Oct 19, 2016 3:21 pm
by bratislav
Where can I configure LLDP, I cant find anything related to it in "/ip neighbor" or anywhere else.
It seams still unimplemented
http://forum.mikrotik.com/viewtopic.php ... 0&start=50
They have already changed the documentation so we can only hope that it will "magically appear" soon enough ...

Re: v6.37.1 [current] is released!

Posted: Fri Oct 21, 2016 10:37 pm
by docmarius
There is clearly something wrong in showing BGP advertisments (console and winbox).

1-st case (OmniTik, LHG5):
- instance with a specific routing table
- Add a network to BGP: advertisments are sent to peers and show as expected
- Create an empty bridge, add previous advertised address as bridge address: advertisments are sent to peers and work, but are not shown under BGP advertisments. 'routing bgp advertisments print' shows up empty in console.
- remove address from bridge: advertisments show up again as expected

2-nd case (RB1100AHx2):
I have 3 instances, which advertises a total of 44 advertisments on 4 peers
BGP Advertisment states there are to many to show.
Clicking to see them all show them for some 3 seconds, then the window is cleared and the message is displayed again.
Even if I select only a specific peer (in my case holding only 9 advertisments) it still clears the screen after a few seconds and states it is too much to display.
Console print is ok.
If I remove one of the peers, reducing the count to 34, everything is ok.

BTW: What is the limit of "to many" BGP advertisments to be shown? Just 40?

Re: v6.37.1 [current] is released!

Posted: Sun Oct 23, 2016 1:23 am
by Chupaka
BTW: What is the limit of "to many" BGP advertisments to be shown? Just 40?
19 for me, but this was even on 10, IIRC

Re: v6.37.1 [current] is released!

Posted: Mon Oct 24, 2016 11:22 am
by Zorro
as for excessive CPU consumption by "management" package/part of ROS - sometimes that impact of bruteforcing attempts into you devices.

Re: v6.37.1 [current] is released!

Posted: Mon Oct 24, 2016 6:14 pm
by baumie
Hi
On my Basebox5 The DFS on the WLAN does'nt show so I can't disable DFS And everytime I reboot it would detect radar for an eternity before it starts running in AP mode If I downgrade to 6.36.3 its allright

Re: v6.37.1 [current] is released!

Posted: Mon Oct 24, 2016 6:24 pm
by jarda
Not an error. This is a feature.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 25, 2016 1:15 am
by myke1124
!) winbox - now Winbox 3.6 is the minimum version that can connect to RouterOS;
dude version 6.37.1
Launching winbox from inside the dude launches a version 2 of winbox that is built into the dude application. I am hoping this is a simple over site to the winbox > 3.6 requirement. When is the new version of winbox making it into the dude?

Re: v6.37.1 [current] is released!

Posted: Tue Oct 25, 2016 9:42 am
by RonPLS
Hi,
I have RouterBOARD 941-2nD, configuration my RouterBOARD is two 2 wlan (homeWLAN and guestWLAN). In homeWLAN work about 3-5 devices, but if guestWLAN more 12-15 devices CPU load 100%, and don't connect to any wlan interface. If disable homeWLAN CPU load down to 1-3% (it is good), then enable homeWLAN work norm until then sum all device on wlan interface will not exceed about 15 devices.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 25, 2016 3:11 pm
by visalink
Not an error. This is a feature.
The DFS is a feature that does not work as it should.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 25, 2016 5:25 pm
by jarda
True. Even it works as designed we are not obliged to honour it.

Re: v6.37.1 [current] is released!

Posted: Tue Oct 25, 2016 10:08 pm
by dominicbatty
Further to my previous post, my CRS226 is definitely struggling to maintain an "up" status for my fibre SFP module for any version after 6.36.3. If I downgrade back to 6.36.3 it works great and is extremely stable and has been for some time, if I push it to 6.37.1 it's all over the place. The fibre link is via a local patch lead., It's logged with MikroTik and I have made the device available to them to investigate, awaiting feedback and will update forum.

Re: v6.37.1 [current] is released!

Posted: Wed Oct 26, 2016 10:49 pm
by friday635
Would I be safe upgrading from v6.6?

Re: v6.37.1 [current] is released!

Posted: Thu Oct 27, 2016 5:42 pm
by snix
I think I found a bug in this version. I am using a CHR version.
I am unable to create VLAN interafce with MTU size 1500 on a bonded interface. Both interfaces are passed-through from the host (pci devices exposed to the guest)

Working example on a physical interface:
[admin@MikroTik] > /interface vlan add name=vlan interface=ether1bond vlan-id=100
[admin@MikroTik] > /interface print                                              
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  R  ether1bond                          ether            1500                  12:34:56:78:90:77
 1  R  ether2bond                          ether            1500                  12:34:56:78:90:79
 2  R  vlan                                vlan             1500                  12:34:56:78:90:77
[admin@MikroTik] > 
Not working example on a bonded interface:
[admin@MikroTik] > /interface bonding add lacp-rate=1sec mode=802.3ad name=bond slaves=ether1bond,ether2bond transmit-hash-policy=layer-3-and-4
[admin@MikroTik] > /interface vlan add name=vlan interface=bond vlan-id=100
failure: could not set mtu
[admin@MikroTik] > /interface print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1bond                          ether            1500                  12:34:56:78:90:77
 1  RS ether2bond                          ether            1500                  12:34:56:78:90:79
 2  R  bond                                bond             1500  1500            12:34:56:78:90:77
 3     vlan9                               vlan                                   12:34:56:78:90:77
[admin@MikroTik] >
 
Another working example with a mtu size 1496:
[admin@MikroTik] > /interface vlan add name=vlan interface=bond vlan-id=100 mtu=1496
[admin@MikroTik] > /interface print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1bond                          ether            1500                  F0:4D:A2:09:E9:77
 1  RS ether2bond                          ether            1500                  F0:4D:A2:09:E9:79
 2  R  bond                                bond             1500  1500            F0:4D:A2:09:E9:77
 3  R  vlan                                vlan             1496  1496            F0:4D:A2:09:E9:77

Re: v6.37.1 [current] is released!

Posted: Thu Oct 27, 2016 6:13 pm
by mrz
So where is the bug? vlan header is 4 bytes so obviously you cannot fit 1504byte packet over physical link that supports only 1500bytes L2MTU.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 9:06 am
by snix
Thanks. I didn't know L2MTU plays a role here...

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 10:15 am
by ErfanDL
RB951Ui after some minutes Bandwidth test crashing and reboot

Image

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 11:04 am
by snix
mrz

Here is an example from RB1100AHx2:
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1bond                          ether            1500  1598       9498 12:34:56:78:90:18
 1  RS ether2bond                          ether            1500  1598       9498 12:34:56:78:90:19
 2  R  bond                                bond             1500                  12:34:56:78:90:18
 3  R  vlan                                vlan             1500                  12:34:56:78:90:18
 
My questions now are:
- Why isn't L2MTU visible on the physical interface on the CHR ? Probably driver doesn't support it? Why is L2MTU visible on the bonded interface than?
- Why isn't L2MTU visible on the bond interface on the RB1100AHx2 ?
- Why can a VLAN be configured with 1500 MTU directly on a physical interface but not on a bonded interface on the CHR?
- Why can a VLAN be configured with 1500 MTU on a bonded interface on the RB1100AHx2?

Thank you again for your response.

Re: v6.37.1 [current] is released!

Posted: Fri Oct 28, 2016 12:18 pm
by mrz
1. Interface does not support l2mtu
2.Probably because on RB1100 you have an old version, shows l2mtu on mine:

[admin@rack1_b6] /interface> print
Flags: D - dynamic, X - disabled, R - running, S - slave
# NAME TYPE ACTUAL-MTU L2MTU MAX-L2MTU MAC-ADDRESS
..
5 RS ether6 ether 1500 1598 9498 4C:5E:0C:48:B1:2A
6 RS ether7 ether 1500 1598 9498 4C:5E:0C:48:B1:2B
..
13 R bonding1 bond 1500 1598

3.,4. because L2MTU supports more than 1500.

Re: v6.37.1 [current] is released!

Posted: Sun Oct 30, 2016 7:32 pm
by BlackVS
Had working config on RB951G, v.6.34
After upgrade to 6.37.1 found issue with wrong masquerade behavior:

I have PPTP server on one side (CCR) and PPTP client (RB951G) on other side.
Behind CCR we have a lot of work networks.
Behind RB951 we have home network.
Due to I don't want add routes on CCR for home network I did masquerade for forwarded via PPTP packets from home network (i.e hid home network).
Before upgrade source address during masquerade was changed to the client's PPTP address. It is correct.
After upgrade router uses WAN address as new masquerade source address for packets forwarded from LAN via PPTP tunnel. It is wrong.
Bug?

To correct this I changed from masquerade to src-nat rule and set manually needed ip for forwarded packets.

Re: v6.37.1 [current] is released!

Posted: Sun Oct 30, 2016 11:27 pm
by Aug
Well THAT didn't go well... Upgraded a RB750G from v6.35.2 to v6.37.1 and:

- CPU usage spiked after the update and remained high on a router that normally never goes above 5% CPU load
- Firewall filter rules based on ConnTracking connection state lost that setting. Rather than connection-state=invalid or connection-state=established it showed connection-state=""

I promptly unplugged the external connection, downgraded to v6.34.6 restored my config from backup, and triple checked everything.

Same problem with firewall rules. They used to be correct. All on RB411's.

With 5.26 it's
add chain=forward comment="allow established connections" connection-state=established
add chain=forward comment="allow related connections" connection-state=related
add action=drop chain=forward comment="drop invalid connections" connection-state=invalid


With 6.37.1 it's this.
add action=accept chain=forward comment="allow established connections" connection-state=""
add action=accept chain=forward comment="allow related connections" connection-state=""
add action=drop chain=forward comment="drop invalid connections" connection-state=""

Re: v6.37.1 [current] is released!

Posted: Mon Oct 31, 2016 6:45 am
by BlackVS
With 6.37.1 it's this.
add action=accept chain=forward comment="allow established connections" connection-state=""
add action=accept chain=forward comment="allow related connections" connection-state=""
add action=drop chain=forward comment="drop invalid connections" connection-state=""
Thanks, now I understand why these checkboxes were cleared on one of my routers too...
Now I have to recheck all routers for this.
Damn.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 11:36 am
by omidkosari
Since upgrade fro 6.34.6 to 6.37.1 , most of schedules doesn't run !! Same behavior on 5 different routers with different schedules and scripts .
Note1: Running that script manually works .
Note2: Few schedules work and i am investigating the difference between them .

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 2:41 pm
by darkprocess
Hello same behaviour here, i had to recreate the schedules to make it work

Envoyé de mon SM-G925F en utilisant Tapatalk

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:06 pm
by omidkosari
Found the bug and solution.
Any simple schedule for running need at least these permissions.

policy=ftp,reboot,read,write,policy,test,password,sniff,sensitive

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:29 pm
by mrz
If your script has more permissions that scheduler then scheduler will not be able to execute the script.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 3:37 pm
by omidkosari
If your script has more permissions that scheduler then scheduler will not be able to execute the script.
Before upgrade to this version your sentence was correct but now it is not correct anymore .
Now any schedule SIMPLE script need those permissions to run . It is a bug

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 4:28 pm
by MrcS
Hello there, this is my first post in this forum. Well, I'm facing an issue with IPv6 since the first time my ISP offered it, a few months ago.

My problem is this: I have a link with two RBs, one RB750 as modem client and one RB433 as last mile in my home.
The ISP offers me a /64 and an IPv6 address as usual.
The /64 I send to a pool and that pool is used by the DHCPv6 Server in the RB750.
It goes fine with the RB433 getting the block with DHCPv6 Client and the route is created ok in the RB750. OK till here!

BUT if the RB750 gets rebooted by any reason, it's DHCPv6 Server generates a dynamic route to my /64 pointing to nothing.
And thus, my valid route loses preference and my /64 becomes unreachable until I manually delete that single dynamic route (the other is correct).

Image

Edit: I'm posting this here as It still hasn't been fixed and affects this version too.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 5:11 pm
by strods
Aug - This issue will be fixed in next rc release.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 5:46 pm
by morze
Hello everyone! Using CHR 10Gbit on ESXi 6.5 with 5 vmxnet adapters, I was very surprised with this update! First after update it did not boot. А hour search for a solution let me to think that too little RAM (128 MiB!). After setting RAM to 512 MB it's started and worked, I have used it for two weaks and there was very strange hangs with google and youtube sites (some time normal after reboot and again and again). Have downgraded to 6.36.4 and all working fine now and memory usage is 75 MiB (was >200 with this update).

Image

To be honest, I did not understand this "update". Nothing personal, it's better to remove it from official releases, Sorry for poor English, hope this helps to do RouterOS better! :)

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:09 pm
by morze
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
I think the "fix" is to set more RAM (>300 MiB) and may be some more disk space for VM, but it's better do not upgrade. At least this time, something went wrong... =)

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:18 pm
by mrz
If your script has more permissions that scheduler then scheduler will not be able to execute the script.
Before upgrade to this version your sentence was correct but now it is not correct anymore .
Now any schedule SIMPLE script need those permissions to run . It is a bug
No it does not require such policies to run a script, unless script itself require such policies.

[admin@rack1_hexv3_up] /system script> print
Flags: I - invalid
0 name="script3" owner="admin" policy=write last-started=nov/01/2016 16:11:39
run-count=12 source=:log info "ptest3"
[admin@rack1_hexv3_up] /system scheduler> print detail
Flags: X - disabled
0 name="schedule3" start-date=nov/01/2016 start-time=16:10:19 interval=10s
on-event=script3 owner="admin" policy=write run-count=10 next-run=16:12:19


Such scheduler executes a script with only "write" policy, so your statement is wrong.
Now if I change script policies to "write,test", then scheduler with only "write" policy will not be able to execute the script.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 01, 2016 6:52 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
I think the "fix" is to set more RAM (>300 MiB) and may be some more disk space for VM, but it's better do not upgrade. At least this time, something went wrong... =)
It has 1 GB of RAM and 1 GB of disk. The problem according to guesses is the use of synthetic network cards. Waiting fot fix still.

Re: v6.37.1 [current] is released!

Posted: Wed Nov 02, 2016 4:30 pm
by Chupaka
- Why can a VLAN be configured with 1500 MTU directly on a physical interface but not on a bonded interface on the CHR?
- Why can a VLAN be configured with 1500 MTU on a bonded interface on the RB1100AHx2?
I faced that weird behaviour this night after upgrading one of our x86 routers: VLAN interface is here on bonding, but it's not working, and after disabling it it was impossible to enable it back ("error enabling VLAN - cannot set mtu" or something like that). The solution was just "/interface set bonding1 l2-mtu=1504". The bad thing is that you cannot change L2-MTU via WinBox (so it was not obvious that it IS changeable), and you cannot change l2-mtu via, for example, "/interface bond set" menu - you need to use exactly "/interface set"

Re: v6.37.1 [current] is released!

Posted: Thu Nov 03, 2016 4:04 pm
by ste
The AP selection mechanism has changed.

All our APs have the same SSID. We direct the CPEs to APs using Accesslists. So all CPEs are forbidden by default and only allowed on one sector we want them to connect.

With new wireless package not all available APs are tested. The cpe tries only to connect to 2 of them and if not allowed at this 2 it does not connect to an available third AP. We see "wlan1: failed to connect, not allowed" with 2 different frequencies. So after updating some CPEs never reconnect.

Not mentioned in changelog and not easy to see in lab :-(.

Re: v6.37.1 [current] is released!

Posted: Sun Nov 06, 2016 9:36 pm
by Chupaka
okay, VLANs on Bonding are completely unusable in this version. the router rebooted, l2-mtu is back to 1500 and now I can't even change it:
[admin@Beta] > /interface 
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
[admin@Beta] /interface> set 0 l2mtu=1504                
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
this evening was a bit painful...

UPD: l2-mtu of bonding is unchangeable now on any actual version: 6.36.4, 6.37.1, 6.38rc24 :shock:

Rolled back to 6.33. VLAN is working...

Re: v6.37.1 [current] is released!

Posted: Sun Nov 06, 2016 10:32 pm
by msatter
I am on a new RB750Gr3 and have a problem that the IPv6 is not getting bound when using "renew". I have now to do the following before I gets bound correctly:

interface pppoe-client set pppoe-xs4all-inet max-mtu=1480;
interface pppoe-client set pppoe-xs4all-inet max-mtu=1500;
ipv6 dhcp-client release 0;

Config:
/ipv6 address
add address=2001:x:x:0:1::2 interface=pppoe-xs4all-inet
add address=2001:x:x:0:2::1 advertise=no comment="Advertise off so clients won't get an external IPv6 automatic. interface=2-uplink-switch-master
/ipv6 dhcp-client
add add-default-route=yes interface=pppoe-xs4all-inet pool-name=xs4all-v6prefix pool-prefix-length=48 request=prefix use-peer-dns=no
/ipv6 nd - set [ find default=yes ] hop-limit=64 ra-lifetime=2h
/ipv6 settings - set max-neighbor-entries=1024

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 10:37 am
by jobo
Looks like IPv6 is gone in CCR 1072 after upgrading. CCR1016 still got IPv6 with 6.37.1 tho.

IPv6 is gone after disabling wireless package?

Image

Image

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 3:30 pm
by strods
jobo - Please use "Tool/Clear Cache" in Winbox loader before you connect to device. Then it should be back.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 3:48 pm
by Cha0s
okay, VLANs on Bonding are completely unusable in this version. the router rebooted, l2-mtu is back to 1500 and now I can't even change it:
[admin@Beta] > /interface 
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
[admin@Beta] /interface> set 0 l2mtu=1504                
[admin@Beta] /interface> print where name=bonding1
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  R  bonding1                            bond             1500  1500
this evening was a bit painful...

UPD: l2-mtu of bonding is unchangeable now on any actual version: 6.36.4, 6.37.1, 6.38rc24 :shock:

Rolled back to 6.33. VLAN is working...
I have multiple vlans under bonding and even under vrrp under bonding and I don't have the issue you describe with 6.37.1.

L2MTU on the bonding interface is 1598
L2MTU on the VRRP interface is 1598
L2MTU on the VLAN interfaces is 1594

MTU is 1500 on all interfaces.

Both routers where I have this configuration have over 14days uptime.

I don't recall when L2MTU stopped being 'editable'. I've never had to change it tbh.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 4:27 pm
by SamSpade
I am running Dude as a CHR on HyperV. I imported database from old version of Dude and everything seems ok except I got no custom pictures of devices I set-up on previous instalation.
Second thing: legend field is empty on all link graphs (see picture)
Image

Does anybody knows solution to this problems?

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 4:39 pm
by jobo
jobo - Please use "Tool/Clear Cache" in Winbox loader before you connect to device. Then it should be back.
OK this helped thanks!

Re: v6.37.1 [current] is released!

Posted: Mon Nov 07, 2016 11:58 pm
by Chupaka
I have multiple vlans under bonding and even under vrrp under bonding and I don't have the issue you describe with 6.37.1.

L2MTU on the bonding interface is 1598
L2MTU on the VRRP interface is 1598
L2MTU on the VLAN interfaces is 1594

MTU is 1500 on all interfaces.

I don't recall when L2MTU stopped being 'editable'. I've never had to change it tbh.
please check l2-mtu of ethernets in bonding. mine are empty - looks like it can be the reason:
[admin@TestPlace] > interface print where name~"(bonding1|ether6|ether7)" 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether6              ether            1500                  00:50:56:BE:1F:E4
 1  RS ether7              ether            1500                  00:50:56:BE:08:9C
 2  R  bonding1            bond             1500  1500            00:50:56:BE:1F:E4
[admin@TestPlace] > 
this is from ESXi VM, but on hardware router I have the same behaviour

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 12:03 am
by Cha0s
[cha0s@****] > interface print where name~"(bonding1|ether1-|ether2)" 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  RS ether1-switch1-port1                ether            1500  1598       4074 D4:CA:6D:**:**:**
 1  RS ether2-switch2-port1                ether            1500  1598       4074 D4:CA:6D:**:**:**
 2  R  bonding1                            bond             1500  1598            D4:CA:6D:**:**:**
These are from an RB2011UiAS-RM.

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 12:24 am
by Cha0s
I confirm that on an esxi VM L2MTU is empty on 6.37.1
[cha0s@MikroTik] > interface print where name~"(ether1|ether2)"           
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  R  ether1-public                       ether            1500                  00:50:56:84:58:2E
 1  R  ether2-lan                          ether            1500                  00:50:56:84:78:D9
I checked arm, mipsbe, ppc, tile and all show L2MTU properly. Probably an x86-only bug?

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 1:14 am
by Chupaka
I checked arm, mipsbe, ppc, tile and all show L2MTU properly. Probably an x86-only bug?
it's driver-dependent. here's my router in subject:
[x@y] > int print 
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU
 0  RS ether1                              ether            1500
 1  RS ether2                              ether            1500
 2  R  ether3                              ether            1500
 3  R  ether4                              ether            1500
 4     ether5                              ether            1500  9014
 5  R  Core                                vlan             1500
 6  R  bonding1                            bond             1500
ether5 has l2-mtu for some reason :) it's Intel 82574L, and ether1-4 are 82576

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 1:55 am
by SpartanX
I'm just reporting an odd glitch I had when I upgraded to this release on Sunday morning. It might not be important, but...

I upgraded at about 8:10am Sunday. Today, I became aware of some UDP packet loss with an online application I use; averaging around 4% loss. As a first step I rebooted my FTTC modem and 850Gx2 router via the web interfaces. Nothing changed. I went through a load of troubleshooting including even replacing my NIC.

Then I remembered I use a ping-recording service, so I checked that and saw packet loss there, from the moment I upgraded the firmware. The router answers the pings. Graphs are attached below.

After checking more things and rebooting (via the web interface) again with no change, it occurred to me to properly power-cycle the router by remote. It's on an APC remote PDU.

That immediately stopped the packet loss. It was definitely what fixed it. In the graphs (which you can see better if you click on them) it is apparent when the packet loss started on the first graph. The time correlates with the router's log showing the upgrade. The second graph shows when I power cycled the router and the packet loss stopping.

Image

Image

Moral of the story: don't trust a software restart!

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 7:25 am
by BlackVS
One more strange thing happened on one router (CCR1016) with 6.37.1.
It has two WANs with loadbalancing/backup and few days ago one channel down.
I thought that it is provider related problem (due to I couldn't ping gate, physical link was ok) and even started to contact with him but looked at log and saw a lot of fcs erors on this port (broken checksums).
Hm... I just disabled/enabled port and all channel up again.
I'm not sure is it provider related problem or router/firmware.
It was first time such channel down.
I reverted to the stable 6.36.4 - no problem...

Re: v6.37.1 [current] is released!

Posted: Tue Nov 08, 2016 7:15 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
Did you find a fix? I have same Issue in different versions of hyper-v 2012r2 and 2016... Also tried upgrade and clear install...
Ok now I know that this is related to Network Adapters in Hyper-V on Windows Server 2012 R2 and possible older versions.
If I test with Legacy Network Adapters everything works except that performance takes a bit hit.
Running on Windows 10 Hyper-V works with these Network Adapters so this is related to 2012 R2 or older.
Still waiting for a fix.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 1:17 pm
by amtisrac
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
I'm try downgrade to 6.36.4, same results.
Latest stable version is 6.36.3 (on my hyper-v 2012 r2)
On the 6.36.4 changelog I see two thing, probably these are the reasons:
*) ethernet - added support for LAN9514 ethernet dongle;
*) ethernet - allow to force mtu value when actual-mtu is already the same;

Image
Image

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 2:26 pm
by pikpik
  status: radar-detecting
                channel: 5640/20-eC/an/DP (3440)
            noise-floor: -111dBm
  authenticated-clients: 0
      current-tx-powers: 6Mbps:19(19/22),9Mbps:19(19/22),12Mbps:19(19/22),18Mbps:19(19/22),24Mbps:19(19/22),36Mbps:16(16/19),48Mbps:14(14/17),
                         54Mbps:13(13/16),HT20-0:19(19/22),HT20-1:18(18/21),HT20-2:17(17/20),HT20-3:17(17/20),HT20-4:16(16/19),HT20-5:14(14/17),
                         HT20-6:13(13/16),HT20-7:12(12/15),HT40-0:18(18/21),HT40-1:17(17/20),HT40-2:16(16/19),HT40-3:16(16/19),HT40-4:15(15/18),
                         HT40-5:13(13/16),HT40-6:12(12/15),HT40-7:11(11/14)
    notify-external-fdb: no
Why i can connect only on 3 channels from all ? Country poland.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 10, 2016 6:38 pm
by Kindis
Killed my CHR at home. Unable to communicate with the router via IP. Cloud logon via console (hyper-v) but unable to list interfaces. Service timeout and the same thing with trying to create a supout.rif. Thank god for snapshots :-) Rollback via snapshot took 10 seconds!

Tested again and if I do not logon I get this in Hyper-V console: Mikrotik Login: Info failed: std failure timeout (13)

Still unable to get a supout.rif. I can however export the entire machine and send it to support (after an upgrade). If imported to the a Windows Server 2012 R2 Hyper-V you can access the .vhdx file and read everything you like.
I'm going to e-mail support.

Edit:
[Ticket#2016100322001305]
I'm try downgrade to 6.36.4, same results.
Latest stable version is 6.36.3 (on my hyper-v 2012 r2)
On the 6.36.4 changelog I see two thing, probably these are the reasons:
*) ethernet - added support for LAN9514 ethernet dongle;
*) ethernet - allow to force mtu value when actual-mtu is already the same;

Image
Image
This is related to using Network Adapters in Hyper-V on server 2012 R2. Tested on Windows 10 and that works with same setup.
If you switch the network cards to Legacy Network adapters it will work on 2012 R2 Hyper-v but performance turns to shit.
I have noted this to Mikrotik who have only tested on Windows 10 which is a different version of Hyper-V.
Will update when I get response from support.

Re: v6.37.1 [current] is released!

Posted: Sun Nov 13, 2016 8:48 pm
by akarag
Hello,

I have some issues with version 6.37.1 on a hex v3. I upgraded one from 6.36.3 to 6.37.1 and noticed two issues

1. On the ethernet interfaces, the information concerning the master port, TX/RX and switch port are missing. This was extremely useful in order to quickly check the settings of the interfaces (swict port)

2. The log window is not automatically scrolled in the occurrence of new events. I need to close the log window and reopen it in order to see the last events in the log list.

Re: v6.37.1 [current] is released!

Posted: Mon Nov 14, 2016 10:53 pm
by stroebs
Unable to run scripts by referring to their names in 6.37.1...
This happens when called from other scripts or from terminal.

Image

Re: v6.37.1 [current] is released!

Posted: Tue Nov 15, 2016 11:51 am
by mrz
Script that you are trying to run tries to access something that does not exist in current configuration.

Re: v6.37.1 [current] is released!

Posted: Thu Nov 17, 2016 8:55 am
by alext8409
Still terrible behavior of the vpn server since v6.34. L2tp ipsec server is up, remote client connects successfully, then after a while it just hangs up and terminating the session. Another great thing happens on v6.38 - the client connects and stays connected as long as you need until you start to transfer data via the tunnel, 1-2 minutes of copying (direction doesn't matter) ang hungup again! I just can't get it how such a vital and useful function of a router can behavior this way. I would probably leave the v.6.34, where the vpn connection is stable as a rock, but there is another bug - when you change proposal settings, the dynamic peer just dissapears and you have to restore from the backup! Fix this please!

Re: v6.37.1 [current] is released!

Posted: Sun Nov 20, 2016 9:49 am
by Temches
Device: hAp lite

Problem with old legacy wireless devices (for example Intel(R) PRO/Wireless 2200BG) still persist in 6.37.1 and 6.38rc7 ... can`t connect to network with WPA or WPA2 encryption. without - all fine.

Always getting "extensive data loss".

After downgrading to 6.34.6 - all fine, wireless-cm2 package works perfecty!
This is a major issue for me as well! Please consider creating a 6.36.4 as bugfix-version because it is the lastest version supporting wireless-cm2.I have >50 devices with Intel(R) PRO/Wireless 2200BG and >40 older wireless IP-Cams which do not work wir current wireless-package. I'm also running a big camtsite-installation where the clients have thousands of different devices. I worry that some clients cannot use our wifi.
Same problem, my old smartphone philips w732 could not connect to wifi router. On 6.36.4 works just fine. Is any fixes for this?

Re: v6.37.1 [current] is released!

Posted: Mon Nov 21, 2016 9:43 am
by notToNew
Same problem, my old smartphone philips w732 could not connect to wifi router. On 6.36.4 works just fine. Is any fixes for this?
Yes, this is the new "feature". If you use unencrypted wifi (clear the WPA-encryption), it works. (Thats why I moved to 6.36.4, and i'm happy that they support 6.36 as the last version with the old workung packet in the bugfix-branch. I hope they create a kind of an LTS-Version of this branch.)

Re: v6.37.1 [current] is released!

Posted: Mon Nov 21, 2016 8:00 pm
by novelty22
edit: Sorry, wrong thread

Re: v6.37.1 [current] is released!

Posted: Tue Nov 22, 2016 12:21 am
by 105547111
6.37.2 is released, where's the announcement?

Re: v6.37.1 [current] is released!

Posted: Tue Nov 22, 2016 9:15 am
by strods
6.37.2 has been released. Please read changelog before upgrade:
http://forum.mikrotik.com/viewtopic.php?f=21&t=114926