Community discussions

  • 1
  • 2
  • 3
  • 4
  • 5
  • 8
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.39rc [release candidate] is released

Mon Jan 02, 2017 4:51 pm

What's new in 6.39rc4 (2016-Dec-30 07:16):

!) ppp - completely rewritten internal fragmentation algorithm (when MRRU is used), optimized for multicore;
*) capsman - added CAP discovery interface list support;
*) ethernet - renamed "rx-lose" to "rx-loss" in ethernet statistics;
*) health - report fan speed for RB800 and RB1100 when 3-pin fan is being used;
*) led - show warning on print when "modem-signal-threshold" is not available;
*) lte - added error handling for remote AT execute;
*) wAP ac - improved 2.4GHz wireless performance;
*) wireless - added "station-roaming" setting (cli only);
*) wireless - show comment on "security-profile" if it is set (cli only);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
lekozs
newbie
Posts: 45
Joined: Wed Aug 30, 2006 12:49 pm

Re: v6.39rc [release candidate] is released

Mon Jan 02, 2017 5:21 pm

Would you be so kind and shed some light on this line in the changelog:

*) wireless - added "station-roaming" setting (cli only);
 
uldis
MikroTik Support
MikroTik Support
Posts: 3423
Joined: Mon May 31, 2004 2:55 pm

Re: v6.39rc [release candidate] is released

Mon Jan 02, 2017 7:25 pm

Would you be so kind and shed some light on this line in the changelog:

*) wireless - added "station-roaming" setting (cli only);
Here is information about this station-roaming:
http://wiki.mikrotik.com/wiki/Manual:In ... on_Roaming

Now you can disable station-roaming if you do not want it or, for example, if you have P2P using 802.11 protocol were you don't have another AP to connect to.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1807
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.39rc [release candidate] is released

Tue Jan 03, 2017 11:12 am

Hi Guys,

Can I please have more info on *) wAP ac - improved 2.4GHz wireless performance;

e.g. under what situations is performance "improved" ?

I ask as we have had issues with the wAP AC's 2.4Ghz radios and performance to Samsung android devices, as well as WPA group-key issues..
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.39rc [release candidate] is released

Tue Jan 03, 2017 3:32 pm

When I installed the firmware 6.39 rc4 was my ovpn connection interrupted.
After back downgrade to 6:36 bugfix everything was ok.
This somehow seems like a bug
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.39rc [release candidate] is released

Tue Jan 03, 2017 10:25 pm

"ppp optimized for multicore" - on all platforms?
 
plisken
Forum Guru
Forum Guru
Posts: 2388
Joined: Sun May 15, 2011 12:24 am
Location: Belgium
Contact:

Re: v6.39rc [release candidate] is released

Tue Jan 03, 2017 10:37 pm

I forgot to mention that the firmware proved a rb3011.
Mikrotik will have to resolve this isseu. This is a bug.
 
coylh
Member Candidate
Member Candidate
Posts: 160
Joined: Tue Jul 12, 2011 12:11 am

Re: v6.39rc [release candidate] is released

Wed Jan 04, 2017 2:15 am

I hope this one: http://forum.mikrotik.com/viewtopic.php?f=7&t=115180

I'll try the RC and see if it helps.

Hi Guys,

Can I please have more info on *) wAP ac - improved 2.4GHz wireless performance;

e.g. under what situations is performance "improved" ?

I ask as we have had issues with the wAP AC's 2.4Ghz radios and performance to Samsung android devices, as well as WPA group-key issues..
 
timtasse
just joined
Posts: 9
Joined: Tue Jun 22, 2010 11:52 am

Re: v6.39rc [release candidate] is released

Wed Jan 04, 2017 11:56 pm

are there plans to add NAT for IPv6 ?
at home i have dynamic ipv6 from the provider and a static ipv6 net with no flatrate at tunnelprovider.
the simplest solution is to NAT unknown networks und known networks without NAT for static firewall config.
 
sakirozkan
newbie
Posts: 38
Joined: Sat Jun 14, 2014 12:19 pm

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 10:30 am

Station Roaming feature is available only for 802.11 wireless protocol. when we use background scan on nv2 and use station roaming. is there any work for nv2.
 
deathmagicmedia
just joined
Posts: 4
Joined: Fri Jul 22, 2016 5:14 pm
Location: Cape Town, South Africa
Contact:

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 11:46 am

Please add HTTP POST and HTTP GET to the Dude's notification feature.
This will allow integration into 3rd-party applications such as Telegram (https://core.telegram.org/bots/api).
Quite important to allow toggling between secure and non-secure connections.
MikroTik Certified Network Associate (MTCNA)
Ubiquiti Broadband Wireless Specialist (UBWS)
Ubiquiti Broadband Wireless Admin (UBWAv2)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 11:50 am

Station Roaming feature is available only for 802.11 wireless protocol. when we use background scan on nv2 and use station roaming. is there any work for nv2.
It is clarified in the manual: http://wiki.mikrotik.com/wiki/Manual:In ... on_Roaming
No answer to your question? How to write posts
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 4:14 pm

Version 6.39rc7 has been released.
Changes since previous rc:
*) bridge - fixed MAC address learning from switch master-port;
*) capsman - support for communicating frame priority between CAP and CAPsMAN;
*) dhcpv6-client - fixed dhcpv6 rebind on startup;
*) dns - fixed typo in regexp error message;
*) dude - (changes discussed here: http://forum.mikrotik.com/viewtopic.php?f=21&t=116471);
*) firewall - nat action "netmap" now requires to-addresses to be specified;
*) ike2 - allow empty selectors to reach policy handler;
*) ike2 - fixed error packet from initiator on responder reply;
*) ike2 - fixed ph1 initial-contact rare desync;
*) ike2 - fixed traffic selector prefix calculation;
*) ike2 - show peer identity of connected peers;
*) ike2 - update also local port when peer changes port;
*) ipsec - fixed flush speed and SAs on startup;
*) ipsec - fixed peer port export;
*) ipsec - port is used only for initiators;
*) leds - added lte modem access technology trigger;
*) log - added warning when winbox/dude sessions was denied;
*) log - improved firewall log messages when NAT has changed only connection ports;
*) mmips - improved general stability;
*) ovpn - fixed address acquisition when ovpn-in interface becomes slave;
*) proxy - fixed "max-cache-object-size" export;
*) proxy - speed-up almost empty disk cache clean-up;
*) rb1100ahx2 - fixed random counter resets for ether12,13;
*) ssh - fixed high memory consumption when transferring file over ssh tunnel;
*) wireless - fixed issue when wireless interfaces might not show up in CAP mode;
*) wireless - fixed occasional crash on interface disabling;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 875
Joined: Tue Oct 11, 2005 4:53 pm

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 4:30 pm

are there plans to add NAT for IPv6 ?
at home i have dynamic ipv6 from the provider and a static ipv6 net with no flatrate at tunnelprovider.
the simplest solution is to NAT unknown networks und known networks without NAT for static firewall config.
I've requested this 2 years ago but the NAT Nazis say "it's wrong". Because some IPv6/end2end connectivity ideologists said so.
Those 'No-NAT-on-IPv6' people are becoming worse than Apple fanboys :P
http://forum.mikrotik.com/viewtopic.php?f=19&t=90564

And a more comprehensive post about NAT usefulness in IPv6 by ZeroByte http://forum.mikrotik.com/viewtopic.php?f=1&t=110925
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 4:52 pm

Please do not hijack versoin topic with questions which are not related to release itself.

timtasse, deathmagicmedia - You should create new topic with your request and/or write to support.
 
Kalpar
just joined
Posts: 7
Joined: Fri Feb 13, 2015 4:12 pm

Re: v6.39rc [release candidate] is released

Thu Jan 05, 2017 6:19 pm

Hello
!) ppp - completely rewritten internal fragmentation algorithm (when MRRU is used), optimized for multicore;
Can you clarify if this adds any new features for PPP / MRRU? Does this mean that you have added (or will add) PPP Fragmentation reordering / buffering to fix the case where MRRU fragments come in our of order?

--Greg
 
benoga
just joined
Posts: 13
Joined: Wed Mar 09, 2016 7:50 am

Re: v6.39rc [release candidate] is released

Fri Jan 06, 2017 9:24 am

LED off is only for "Currently "RB cAP 2n" and "RB cAP 2nD" ?

I've got the Error on my HAP AC (mipsbe):
[benoga@HAP_AC] > /system leds setting set all-leds-off=immediate
missing values (5)
When HAP AC not support this, then please disable the Setting in CLI and Winbox :)
greez
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.39rc [release candidate] is released

Fri Jan 06, 2017 10:41 am

Kalpar - Yes, that is exactly what was done! MRRU works in same way as it did before, but it is now adjusted/updated to multi core age
 
JHV
just joined
Posts: 11
Joined: Mon Feb 01, 2016 8:27 pm

Issue with DHCPv6 partially solved

Sat Jan 07, 2017 1:22 pm

Version 6.39rc7 has been released.
Changes since previous rc:
*) dhcpv6-client - fixed dhcpv6 rebind on startup;
Rebinding or renewing? And only on startup?
However, the new version solves my problem at least partially.

As I have already described in this thread, DHCPv6 is broken for me since v6.34, If the connection is lost, renewing and rebinding takes 20 minutes. Since v6.39rc this time has been reduced to 10 minutes.

Before v6.34:
PPPoE connected ---> status: bound

After v6.34:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting ---> status: renewing ---> 10 Minutes waiting ---> status: bound

After v6.39rc:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting --- status: bound
 
msatter
Forum Guru
Forum Guru
Posts: 1118
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Issue with DHCPv6 partially solved

Sat Jan 07, 2017 11:34 pm

Version 6.39rc7 has been released.
Changes since previous rc:
*) dhcpv6-client - fixed dhcpv6 rebind on startup;
Rebinding or renewing? And only on startup?
However, the new version solves my problem at least partially.

As I have already described in this thread, DHCPv6 is broken for me since v6.34, If the connection is lost, renewing and rebinding takes 20 minutes. Since v6.39rc this time has been reduced to 10 minutes.

Before v6.34:
PPPoE connected ---> status: bound

After v6.34:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting ---> status: renewing ---> 10 Minutes waiting ---> status: bound

After v6.39rc:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting --- status: bound
http://forum.mikrotik.com/viewtopic.php ... 16#p575316

I used this command when I scheduled a PPPoE reconnect: ipv6 dhcp-client release 0;
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
kujo
Member Candidate
Member Candidate
Posts: 158
Joined: Sat Jun 18, 2016 10:17 am
Location: Ukraine

Re: v6.39rc [release candidate] is released

Sat Jan 07, 2017 11:51 pm

Kalpar - Yes, that is exactly what was done! MRRU works in same way as it did before, but it is now adjusted/updated to multi core age
Can we use L2TP + MRRU over one WAN link of PPPoE provider 1492 MTU/MRU?


Sent from my iPhone using Tapatalk
 
qiet72
just joined
Posts: 24
Joined: Thu Oct 09, 2014 10:23 am

Re: v6.39rc [release candidate] is released

Sun Jan 08, 2017 2:59 pm

Hi

I have just tried 6.39rc7 on a RB2011UiAS-2HnD-IN. A lot of client equipment seem to connect fine with or without encryption. Unfortunately, an old Intel 2200BG client cannot connect to it no matter if I use WPA2 encryption on it or not. To confirm that the Intel 2200BG card worked, I tested it up against a Broadcom based access point and it connected fine with or without encryption.
I have debug logs turned on. The logs say "disconnected, extensive data loss" when I try with wpa2 encryption. If I use no encryption, the logs say "disconnected, received disassoc: unspecified (1)".

Qiet72
 
JHV
just joined
Posts: 11
Joined: Mon Feb 01, 2016 8:27 pm

Re: Issue with DHCPv6 partially solved

Sun Jan 08, 2017 4:16 pm

Version 6.39rc7 has been released.
Changes since previous rc:
*) dhcpv6-client - fixed dhcpv6 rebind on startup;
Rebinding or renewing? And only on startup?
However, the new version solves my problem at least partially.

As I have already described in this thread, DHCPv6 is broken for me since v6.34, If the connection is lost, renewing and rebinding takes 20 minutes. Since v6.39rc this time has been reduced to 10 minutes.

Before v6.34:
PPPoE connected ---> status: bound

After v6.34:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting ---> status: renewing ---> 10 Minutes waiting ---> status: bound

After v6.39rc:
PPPoE connected ---> status: rebinding ---> 10 minutes waiting --- status: bound
http://forum.mikrotik.com/viewtopic.php ... 16#p575316

I used this command when I scheduled a PPPoE reconnect: ipv6 dhcp-client release 0;
Thank you for your advice. It works indeed, but needs a delay between enabling PPPoE and dhcp-client release.
Therefore I have altered my script as follows:
/interface pppoe-client disable [find name="pppoe-out1"];
/ipv6 dhcp-client disable [find interface="pppoe-out1"];
/interface pppoe-client enable [find name="pppoe-out1"];
/ipv6 dhcp-client enable [find interface="pppoe-out1"];
This script lacks elegance, but at least it works.
 
AlexHam
just joined
Posts: 2
Joined: Sat Jan 07, 2017 5:45 pm

Re: v6.39rc [release candidate] is released

Mon Jan 09, 2017 12:58 am

Doesn't work VLANS between two devices on this firmware.
First device RB1100AHx2 (ppc)
Second device RB750UPr2 (mipsbe).
I installed v6.39rc on both devices.
on both devices I make configure:
RB750UPr2:
/interface bridge
add name=LAN
add name=TRUNC
/interface vlan
add interface=TRUNC name=vlan4 vlan-id=4
/interface bridge port
add bridge=TRUNC interface=ether1
add bridge=LAN interface=ether2
add bridge=LAN interface=vlan4
/ip address
add address=192.168.77.1/24 interface=LAN network=192.168.77.0

RB1100AHx2:
/interface bridge
add name=LAN
add name=TRUNC
/interface vlan
add interface=TRUNC name=vlan4 vlan-id=4
/interface bridge port
add bridge=LAN interface=vlan4
add bridge=TRUNC interface=ether1
/ip address
add address=192.168.77.2/24 interface=LAN network=192.168.77.0

Connect Routers by eth1 ports.
Connect laptop to RB750UPr2 to eht2 port.
I can connect to RB750UPr2. But cannot connect to RB1100AHx2.

This configuration successfully work on 6.37 firmware.

This bug only between RB750UPr2 and RB1100AHx2.
If I use, example, RB750UPr2 and RB Metal 2SHPn, this configuration is work.
 
irico
newbie
Posts: 47
Joined: Thu Nov 10, 2016 5:35 pm

Re: v6.39rc [release candidate] is released

Mon Jan 09, 2017 7:10 pm

On a new CHR machine (v6.39rc7 vhdx image), I have an error creating new IPSec Peer from Winbox (v3.7):
- Could not add new IPsec peer - Property not supported (6)

The problem is in the NAT-T property. If winbox is set to "false" the error occurs. It would be good to hide this property for IKE2.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Mon Jan 09, 2017 8:30 pm

Please add another release channel between "bugfix" and "current", e.g. named "previous".
This should be set to the previous "current" version whenever the latest "release candidate" is released as "current".
Often just after release, a lot of new bugs get noticed because people now first run the new "current", and there is
no easy way to install the previous and usually more stable "current" version without going all the way back to "bugfix".
Another option would be to add a "custom" channel with an input field where a certain base version, e.g. 6.37, can be
entered or selected from a reasonable list, and the channel will track the latest minor version within that.
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1209
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.39rc [release candidate] is released

Mon Jan 09, 2017 9:07 pm

Now this is a good idea.
I had to downgrade to 6.36.4 instead of 6.37.3, since manual downgrade and reinstalling additional packages is not quite trivial and fast on a running system.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Mon Jan 09, 2017 10:06 pm

I had to downgrade to 6.36.4 instead of 6.37.3, since manual downgrade and reinstalling additional packages is not quite trivial and fast on a running system.
And on the new-style "only 16MB flash" models it is even more difficult...
 
msatter
Forum Guru
Forum Guru
Posts: 1118
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Issue with DHCPv6 partially solved

Tue Jan 10, 2017 3:56 pm

Version 6.39rc7 has been released.
Changes since previous rc:
/interface pppoe-client disable [find name="pppoe-out1"];
/ipv6 dhcp-client disable [find interface="pppoe-out1"];
/interface pppoe-client enable [find name="pppoe-out1"];
/ipv6 dhcp-client enable [find interface="pppoe-out1"];
This script lacks elegance, but at least it works.
I checked how long it took to reconnect. I disconnected my PPPoE and stopped the DHCPv6 Client. Started my DHCPv6 Client and then again the PPPoE and the client got bound within two seconds. I have added a while ago the Prefix hint in the DHCPv6 and you can end it with "::" with /subnet then check what the reconnect time is.
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Tue Jan 10, 2017 6:03 pm

XS4ALL? It is a bug at their side.
You can work around it by setting up a tool->netwatch of some internet IP (e.g. the nexthop you get for the default route)
and putting this in the "UP script":
/ipv6 dhcp-client release [find status=bound]

This makes the client release and then request the IPv6 prefix when the interface comes up (within a minute).
 
Dude2048
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Thu Sep 01, 2016 4:04 pm

Re: v6.39rc [release candidate] is released

Tue Jan 10, 2017 11:16 pm

Maybe I overlooked it but what do you mean with : capsman - added CAP discovery interface list support? (Release notes)
 
mariuslazar
just joined
Posts: 7
Joined: Wed Oct 12, 2016 4:06 pm

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 10:18 am

Broken:
DHCP over EOIP (no encription)
Some devices don't get IP's even directly connected - Panasonic VOIP phone. Works fine in 3.37.3
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 10:50 am

The packet sniffer in WebFig always shows status "unknown" in the top left instead of "running" or "stopped".
 
uldis
MikroTik Support
MikroTik Support
Posts: 3423
Joined: Mon May 31, 2004 2:55 pm

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 12:32 pm

Broken:
DHCP over EOIP (no encription)
Some devices don't get IP's even directly connected - Panasonic VOIP phone. Works fine in 3.37.3
Please make support output file and send it to support@mikrotik.com so we could see your configuration and reproduce this problem
 
msatter
Forum Guru
Forum Guru
Posts: 1118
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 9:12 pm

XS4ALL? It is a bug at their side.
You can work around it by setting up a tool->netwatch of some internet IP (e.g. the nexthop you get for the default route)
and putting this in the "UP script":
/ipv6 dhcp-client release [find status=bound]

This makes the client release and then request the IPv6 prefix when the interface comes up (within a minute).
If you have more information we could ask Mike to look i to it if it can be changed on their side to make it more compatible besides the AVM routers.
Last edited by msatter on Wed Jan 11, 2017 10:20 pm, edited 1 time in total.
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 9:17 pm

If you have more information we could ask Mike to look i to it if it can be changed on their side to make it more compatible besides the AVM routers.
Mike says it cannot be changed, and he thinks it is a bug in the router that it keeps the lease when the PPPoE goes down and does
not request a new release immediately when it comes back up. But this is only "common practice", it is not written in the standard.
My workaround with netwatch works, but I would prefer when MikroTik adds a specific "script run when interface comes up" feature.
 
msatter
Forum Guru
Forum Guru
Posts: 1118
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.39rc [release candidate] is released

Wed Jan 11, 2017 10:39 pm

If you have more information we could ask Mike to look i to it if it can be changed on their side to make it more compatible besides the AVM routers.
Mike says it cannot be changed, and he thinks it is a bug in the router that it keeps the lease when the PPPoE goes down and does
not request a new release immediately when it comes back up. But this is only "common practice", it is not written in the standard.
My workaround with netwatch works, but I would prefer when MikroTik adds a specific "script run when interface comes up" feature.
Thanks and I have now added the Netwatch and I found that only this one worked for me: /ipv6 dhcp-client release [find status=rebinding...]

When I down and up the PPPoE the "bound" will change directly in "rebinding..." and I have set a 5 second check.

This also works: /ipv6 dhcp-client release [find status!=bound]
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Thu Jan 12, 2017 12:31 am

It may be that the required command is different for 6.39rc because changes were made to try to fix it.
Maybe it is better to select on some other value as there usually will be only one entry and that is the one to be released.
 
msatter
Forum Guru
Forum Guru
Posts: 1118
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.39rc [release candidate] is released

Thu Jan 12, 2017 1:10 am

It may be that the required command is different for 6.39rc because changes were made to try to fix it.
Maybe it is better to select on some other value as there usually will be only one entry and that is the one to be released.
So the behaviour (6.39RC7) is now to renew and if necessary to rebind and that is a I think the normal way. Then as an exception on this there could be a option to choose for release when renew does not fetch the address. Or to renew-->rebind-->release-->renew-->rebind-->release-->etc. as default fetch.

I did see the communication with Mike on this and many thanks for that!
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5358
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.39rc [release candidate] is released

Thu Jan 12, 2017 10:33 am

I now use this command:
/ipv6 dhcp-client release [find interface=pppoe-xs4all]
it now is independent of the state. Of course the interface name has to be adjusted to the locally used name.
(default is pppoe-out1)
 
efka
just joined
Posts: 2
Joined: Thu Jan 12, 2017 10:36 am

Re: v6.39rc [release candidate] is released

Thu Jan 12, 2017 10:41 am

Hi,

hAP ac .6.39rc7. Winbox 3.7.

Couldn't change LED settings:

<Coldn't change LED Settings - action failed (5)>
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.39rc [release candidate] is released

Fri Jan 13, 2017 1:26 pm

6.39rc12 has been released.
Changes since previous version:

!) quickset - configuration changes are now applied only on "OK" and "Apply" (not on mode change);
!) winbox - minimal required version is v3.8 (because of new quickset);
*) bridge - disallow manual removal of dynamic bridge ports;
*) bridge - fixed access loss to device through bridge if master port had a loop (introduced in v6.38);
*) bridge - fixed rare conflicts between hardware and software STP (introduced in v6.38);
*) certificate - added year cap (invalid-after date will not exceed year 2039);
*) certificate - allow CRL address to be specified as DNS name;
*) certificate - fixed fail on import from CAPs when both key and name already exist;
*) dhcpv6-server - fixed server removal crash if static binding was present;
*) dude - (changes discussed here: http://forum.mikrotik.com/viewtopic.php?f=21&t=116471);
*) fan - improved RPM monitor on CCR1009;
*) firewall - fixed import of exported configuration that had updated "limit" setting;
*) graphs - fixed graph disappearance after power outage;
*) ike1 - fixed ph1 rekey in setups with mode-cfg;
*) ike2 - auto-negotiate split nets;
*) ike2 - default to tunnel mode in setups without policy;
*) ike2 - fixed initiator TS updating;
*) ike2 - fixed policy setting for /0 selector with different address families;
*) ike2 - fixed split policy active flag;
*) ike2 - fixed xauth add check;
*) ike2 - include identity in peer address info;
*) ike2 - log empty TS payload;
*) ike2 - minor logging update;
*) ike2 - traffic selector improvements;
*) ike2 - use first split net for empty TS;
*) ike2 - use standard retransmission timers for DPD;
*) ike2 - xauth like auth method with user support;
*) ipsec - added ability to kill particular remote-peer;
*) ipv6 - added warning about having interface MTU less than minimal IPv6 packet fragment (1280);
*) leds - added LTE modem access technology trigger;
*) leds - do not update single LED state when it is not changed;
*) license - fixed demo license expiration after installation on x86;
*) logs - work on false CPU/RAM overclocked alarms;
*) mpls - fixed crash on active tunnel loss in MPLS TE setups;
*) ppp - fixed rare kernel failure on PPP client connection;
*) pppoe - make default keepalive 10s for PPPoE clients;
*) profile - classify ethernet driver activity properly in ARM architecture;
*) quickset - various small changes;
*) rb751u - fixed ethernet LEDs (broken since 6.38rc16);
*) tr069-client - added connection request authentication;
*) tr069-client - added parameters for DNS client management support;
*) tr069-client - generate random connection request target path;
*) webfig - allow shorten bytes to k,M,G in firewall "connection-bytes" and "connection-rates";
*) webfig - show properly large BGP AS numbers;
*) winbox - added "add-relay-info" and "relay-info-remote-id" to DHCP relay;
*) winbox - added "group-key-update" to CAPsMAN security settings;
*) winbox - added "make-static" to IPv6 DHCP server bindings;
*) winbox - added "prefix-pool" to DHCPv6 server binding;
*) winbox - added IPsec to radius services;
*) winbox - added upstream flag to IGMP proxy interfaces;
*) winbox - allow shorten bytes to k,M,G in bridge firewall just like in "/ip firewall";
*) winbox - allow shorten bytes to k,M,G in firewall "connection-bytes" and "connection-rates";
*) winbox - allow to change user password to empty one;
*) winbox - allow to specify "connection-bytes" & "connection-rate" for any protocol in "/ip firewall" rules;
*) winbox - allow to specify "sip-timeout" under ip firewall service-ports;
*) winbox - allow to specify certificate type when exporting it;
*) winbox - allow to specify interfaces that CAPsMAN can use for management;
*) winbox - do not create empty rates.vht-basic/supported-mcs if not specified in CAPsMAN;
*) winbox - do not create time field when copying CAPsMAN access list entry;
*) winbox - do not try to disable dynamic items from firewall tables;
*) winbox - fixed typo in "/system resources pci" list;
*) winbox - hide "nat-traversal" setting in IPsec peer if IKEv2 is selected;
*) winbox - removed "sfp-rate-select" setting from ethernet interface;
*) winbox - show dynamic IPv6 pools properly;
*) winbox - show errors on IPv6 addresses ;
*) winbox - specify metric for "/ip dns cache-used" setting;
*) winbox - updated fan management menu;
*) wireless - added "station-roaming" setting;
*) wireless - fixed rare wireless ac interface lockup;
*) wireless - show comment on "security-profile" if it is set;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
Valexus
just joined
Posts: 18
Joined: Wed Aug 12, 2015 5:11 pm

Re: v6.39rc [release candidate] is released

Fri Jan 13, 2017 1:56 pm

*) wireless - fixed rare wireless ac interface lockup;
Please tell me that this is the problem on the "hap AC" when the wireless interface is running but not visible or flapping?
 
amokkatmt
newbie
Posts: 30
Joined: Mon Oct 24, 2011 3:31 pm

Re: v6.39rc [release candidate] is released

Fri Jan 13, 2017 3:45 pm

Can anyone confirm this viewtopic.php?f=21&t=116821&p=577546 ?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.39rc [release candidate] is released

Fri Jan 13, 2017 4:16 pm

Can anyone confirm this viewtopic.php?f=21&t=116821&p=577546 ?
yep, WinBox 3.8 doesn't allow to edit src/dst-port even on previous versions of ROS
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1807
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.39rc [release candidate] is released

Sat Jan 14, 2017 12:27 am

Wow that's a massive changelog for a RC.


Some awesome stuff in there.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
cheeze
Member Candidate
Member Candidate
Posts: 146
Joined: Tue Jul 31, 2012 7:44 am

Re: v6.39rc [release candidate] is released

Sat Jan 14, 2017 1:18 am

mpls - fixed crash on active tunnel loss in MPLS TE setups;

Can we ask what this entails?
 
liamalxd
just joined
Posts: 7
Joined: Sun Jul 10, 2016 1:51 pm

Re: v6.39rc [release candidate] is released

Sat Jan 14, 2017 8:47 pm

*) fan - improved RPM monitor on CCR1009;

woo :) very happy about this.
 
LynxChaus
just joined
Posts: 24
Joined: Tue Jul 08, 2014 2:24 pm

Re: v6.39rc [release candidate] is released

Mon Jan 16, 2017 5:35 pm

wireless still broken. my old phone Lenovo A660 can't connect to AP after 6.37 migration anymore.
 
notToNew
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Feb 19, 2016 3:15 pm

Re: v6.39rc [release candidate] is released

Mon Jan 16, 2017 5:44 pm

wireless still broken. my old phone Lenovo A660 can't connect to AP after 6.37 migration anymore.
Stay at 6.36.4 or disable encryption in newer releases as workaround ;-)
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
  • 1
  • 2
  • 3
  • 4
  • 5
  • 8

Who is online

Users browsing this forum: No registered users and 10 guests