Community discussions

 
MarkoB
just joined
Posts: 4
Joined: Sun Dec 12, 2010 1:10 am

Re: v6.39.1 [current]

Fri May 26, 2017 12:46 pm

We use mikrotiks for are customers and seem to be having issues on PS4 at the moment
I seem to be having an issue on PS4's with the dns.
The error code that pops up is
Cannot connect to playstation network. Dns error (NW-31253-4).
They suggest many things all of which i have tried. Just for reference though the the web browser on the ps4 works just fine.
port forwards
dns switched to google or open dns
updating ps4
static the ip
upnp... nothing works
I'm left at possibly the latest update to 3.39.1
"dns - made loading thousands of static entries faster;"
May be breaking something and preventing connection to it.
I'm kind of at a loss I even attempted to call Mikrotik experts from LinkTechs to review settings and find out what the problem is.
PS4 does not support EDNS
change Max UDP Packet Size in DNS options from 4096 to 512
 
voytec
just joined
Posts: 2
Joined: Mon Feb 06, 2017 10:39 am

Re: v6.39.1 [current]

Mon May 29, 2017 11:59 pm

Updated CCR1009-7G-1C-1S+ from v6.38.5 to v6.39.1 - everything OK.
 
User avatar
ploquets
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Nov 17, 2015 12:49 pm
Location: Uruguaiana, RS, Brazil
Contact:

Re: v6.39.1 [current]

Tue May 30, 2017 4:03 am

I'm still trying to figure it out this changelog from 6.39
!) ppp - implemented internal algorithm for "change-mss", no mangle rules necessary;

viewtopic.php?t=122019

Please help
 
jmay
Member
Member
Posts: 325
Joined: Tue Jun 23, 2009 8:26 pm

Re: v6.39.1 [current]

Wed May 31, 2017 11:58 pm

Anyone seeing problems with ping timeouts? Every MT I have is losing about 5% of pings. I can even ping a MT from a computer with a direct cable plugged into it and lose packets.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.39.1 [current]

Fri Jun 02, 2017 5:25 pm

I just bought a pair of cap lite's and I un-boxed them but found the default configuration to be buggy at best.

They came with 6.37.4 and the default configuration came with the standard 192.168.88.1 on a bridge interface and a default SSID broadcasted. Sadly no DHCP server or pool are setup so you can't configure the device without setting a static IP on your device and then connect to either Ethernet or wireless. Not the worst but it did prevent me from using the TikApp to try and configure these little units. In summary, the default configuration for these units in 6.37.4 provides a very poor customer experience and doesn't match the documentation provided with the product.

After some mucking around with them I got them online and updated them to 6.39.1 to see if their were improvements in the default configuration. There definitely was but still not enough to get the unit setup in a fashion suggested by the documentation, connect to the SSID and type http://192.168.88.1 into the browser.

The difference comes down to a DHCP client being placed on the bridge interface. A WLAN is still configured and broadcast that you won't be able to connect to unless you have plugged the device into an Ethernet segment running one. Arguably better but still doesn't match the documentation.

Suggestion

Either adapt the products documentation to match the configuration supplied in 6.39.1 or alter the default configuration. The alteration would simply be to make it function as the documentation says it would. Plug it into power, connect to the default SSID and use the TikApp, WebFig, WinBox or SSH to configure the device at 192.168.88.1.

To play devils advocate, a device like the cap lite is probably not going to be used like a typical router so I could see some proponents of the cap lite's default behavior in 6.39.1. You could match the MAC to an IP and login into it after plugging it into a network device. For some and especially in larger deployments I could see the benefit of this. It definitely matches other products in the access point market. If that's the case and the intention from MikroTik it should be noted in the documentation of the product and displayed prominently on the devices information page. An example could be bold print indicating this device has received an update to how it is configured.

Reference

6.37.4 Default Configuration
  script: :global ssid;
          #| WISP Bridge:
          #|  * wireless and LAN interfaces are bridged;
          #|  * IP address 192.168.88.1/24 is set on bridge
          #| wlan1 Configuration:
          #|     mode:          ap-bridge;
          #|     band:          2ghz-b/g/n;
          #|     ht-chains:     0,1;
          #|     ht-extension:  20/40mhz-Ce;
          #| LAN Configuration:


          :log info Starting_defconf_script_;
          :global action;
          #-------------------------------------------------------------------------------
          # Apply configuration.
          # these commands are executed after installation or configuration reset
          #-------------------------------------------------------------------------------
          :if ($action = "apply") do={
          # wait for interfaces
          :local count 0;
          :while ([/interface ethernet find] = "") do={
          :if ($count = 30) do={
          :log warning "DefConf: Unable to find ethernet interfaces";
          /quit;
          }
          :delay 1s; :set count ($count +1);
          };

            :local count 0;
            :while ([/interface wireless print count-only] < 1) do={
              :set count ($count +1);
              :if ($count = 30) do={
                :log warning "DefConf: Unable to find wireless interface(s)";
                /ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
                /quit
              }
              :delay 1s;
            };
            /interface wireless {
              set wlan1 mode=ap-bridge band=2ghz-b/g/n tx-chains=0,1 rx-chains=0,1 \
                disabled=no wireless-protocol=802.11 distance=indoors
              :local wlanMac  [/interface wireless get wlan1 mac-address];
              :set ssid "MikroTik-$[:pick $wlanMac 9 11]$[:pick $wlanMac 12 14]$[:pick $wlanMac 15 17]"
              set wlan1 ssid=$ssid
              set wlan1 frequency=auto
              set wlan1 channel-width=20/40mhz-Ce ;
            }
           /interface bridge
             add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
           :local bMACIsSet 0;
           :foreach k in=[/interface find where !(slave=yes  || name~"bridge")] do={
             :log info "k: $k"
             :local tmpPortName [/interface get $k name];
             :log info "port: $tmpPortName"
             :if ($bMACIsSet = 0) do={
               :if ([/interface get $k type] = "ether") do={
                 /interface bridge set "bridge" auto-mac=no admin-mac=[/interface ethernet get $tmpPortName mac-address];
                 :set bMACIsSet 1;
               }
             }
             /interface bridge port
               add bridge=bridge interface=$tmpPortName comment=defconf;
           }
            /ip address add address=192.168.88.1/24 interface=bridge comment="defconf";
          }
          #-------------------------------------------------------------------------------
          # Revert configuration.
          # these commands are executed if user requests to remove default configuration
          #-------------------------------------------------------------------------------
          :if ($action = "revert") do={
          # remove wan port protection
           /ip firewall filter remove [find comment~"defconf"]
           /ip firewall nat remove [find comment~"defconf"]
           /tool mac-server remove [find interface!=all]
           /tool mac-server set [find] disabled=no
           /tool mac-server mac-winbox remove [find interface!=all]
           /tool mac-server mac-winbox set [find] disabled=no
           /ip neighbor discovery set [find ] discover=yes
             :local o [/ip dhcp-server network find comment="defconf"]
             :if ([:len $o] != 0) do={ /ip dhcp-server network remove $o }
             :local o [/ip dhcp-server find name="defconf" !disabled]
             :if ([:len $o] != 0) do={ /ip dhcp-server remove $o }
             /ip pool {
               :local o [find name="default-dhcp" ranges=192.168.88.10-192.168.88.254]
               :if ([:len $o] != 0) do={ remove $o }
             }
             :local o [/ip dhcp-client find comment="defconf"]
             :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
           /ip dns {
             set allow-remote-requests=no
             :local o [static find name=router address=192.168.88.1]
             :if ([:len $o] != 0) do={ static remove $o }
           }
           /ip address {
             :local o [find comment="defconf"]
             :if ([:len $o] != 0) do={ remove $o }
           }
           :foreach iface in=[/interface ethernet find] do={
             /interface ethernet set $iface name=[get $iface default-name]
           }
           /interface bridge port remove [find comment="defconf"]
           /interface bridge remove [find comment="defconf"]
           /interface wireless reset-configuration wlan1
          }
          :log info Defconf_script_finished;
6.39.1 Default Configuration
  script: :global ssid;
          #| WISP Bridge:
          #|  * wireless and LAN interfaces are bridged;

          #| wlan1 Configuration:
          #|     mode:          ap-bridge;
          #|     band:          2ghz-b/g/n;
          #|     ht-chains:     0,1;
          #|     ht-extension:  20/40mhz-Ce;
          #| LAN Configuration:
          #|     DHCP Client: enabled on LAN port;

          :log info Starting_defconf_script_;
          :global action;
          #-------------------------------------------------------------------------------
          # Apply configuration.
          # these commands are executed after installation or configuration reset
          #-------------------------------------------------------------------------------
          :if ($action = "apply") do={
          # wait for interfaces
          :local count 0;
          :while ([/interface ethernet find] = "") do={
          :if ($count = 30) do={
          :log warning "DefConf: Unable to find ethernet interfaces";
          /quit;
          }
          :delay 1s; :set count ($count +1);
          };

            :local count 0;
            :while ([/interface wireless print count-only] < 1) do={
              :set count ($count +1);
              :if ($count = 30) do={
                :log warning "DefConf: Unable to find wireless interface(s)";
                /ip address add address=192.168.88.1/24 interface=ether1 comment="defconf";
                /quit
              }
              :delay 1s;
            };
            /interface wireless {
              set wlan1 mode=ap-bridge band=2ghz-b/g/n tx-chains=0,1 rx-chains=0,1 \
                disabled=no wireless-protocol=802.11 distance=indoors
              :local wlanMac  [/interface wireless get wlan1 mac-address];
              :set ssid "MikroTik-$[:pick $wlanMac 9 11]$[:pick $wlanMac 12 14]$[:pick $wlanMac 15 17]"
              set wlan1 ssid=$ssid
              set wlan1 frequency=auto
              set wlan1 channel-width=20/40mhz-Ce ;
            }
           /interface bridge
             add name=bridge disabled=no auto-mac=yes protocol-mode=rstp comment=defconf;
           :local bMACIsSet 0;
           :foreach k in=[/interface find where !(slave=yes  || name~"bridge")] do={
             :log info "k: $k"
             :local tmpPortName [/interface get $k name];
             :log info "port: $tmpPortName"
             :if ($bMACIsSet = 0) do={
               :if ([/interface get $k type] = "ether") do={
                 /interface bridge set "bridge" auto-mac=no admin-mac=[/interface ethernet get $tmpPortName mac-address];
                 :set bMACIsSet 1;
               }
             }
             /interface bridge port
               add bridge=bridge interface=$tmpPortName comment=defconf;
           }
            /ip dhcp-client add interface=bridge disabled=no comment="defconf";
          }
          #-------------------------------------------------------------------------------
          # Revert configuration.
          # these commands are executed if user requests to remove default configuration
          #-------------------------------------------------------------------------------
          :if ($action = "revert") do={
          # remove wan port protection
           /ip firewall filter remove [find comment~"defconf"]
           /ip firewall nat remove [find comment~"defconf"]
           /tool mac-server remove [find interface!=all]
           /tool mac-server set [find] disabled=no
           /tool mac-server mac-winbox remove [find interface!=all]
           /tool mac-server mac-winbox set [find] disabled=no
           /ip neighbor discovery set [find ] discover=yes
             :local o [/ip dhcp-server network find comment="defconf"]
             :if ([:len $o] != 0) do={ /ip dhcp-server network remove $o }
             :local o [/ip dhcp-server find name="defconf" !disabled]
             :if ([:len $o] != 0) do={ /ip dhcp-server remove $o }
             /ip pool {
               :local o [find name="default-dhcp" ranges=192.168.88.10-192.168.88.254]
               :if ([:len $o] != 0) do={ remove $o }
             }
             :local o [/ip dhcp-client find comment="defconf"]
             :if ([:len $o] != 0) do={ /ip dhcp-client remove $o }
           /ip dns {
             set allow-remote-requests=no
             :local o [static find name=router address=192.168.88.1]
             :if ([:len $o] != 0) do={ static remove $o }
           }
           /ip address {
             :local o [find comment="defconf"]
             :if ([:len $o] != 0) do={ remove $o }
           }
           :foreach iface in=[/interface ethernet find] do={
             /interface ethernet set $iface name=[get $iface default-name]
           }
           /interface bridge port remove [find comment="defconf"]
           /interface bridge remove [find comment="defconf"]
           /interface wireless reset-configuration wlan1
          }
          :log info Defconf_script_finished;
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.39.1 [current]

Sat Jun 03, 2017 7:42 pm

You do not need to care about the out of the box config. Just plug the wire, connect with winbox by mac, wipe out the config and enjoy clear device prepaired for whatever configuration you can imagine.
 
HeadCraft
just joined
Posts: 16
Joined: Tue Mar 05, 2013 11:11 am

Re: v6.39.1 [current]

Mon Jun 05, 2017 11:12 am

Upgraded from 6.38.5 to 6.39.1
Wireless clients (Honeywell Dolphin 6000) can't connect to wi-fi, while all other devices can (included dolphin 6500, notebooks, smartphones, etc)
I have CAPsMAN configured on mikrotik 1100AHx2 and CAP clients on mikrotik hAP ac lite and RB912UAG-2HPnD.
Log on CAPsMAN writes:
...disconnected, extensive data loss
...disconnected, 4-way handshake timeout
...connected
...disconnected, extensive data loss
...connected
...disconnected, received deauth: class 3 frame received (7)
...disconnected, registered to other interface
and so on.

It seems like wireless clients can't even authenticate on wi-fi. Downgraded to 6.38.5 on CAP clients, while CAPsMAN is still 6.39.1, and all start working again.
 
mariro
just joined
Posts: 1
Joined: Fri Jan 11, 2008 9:36 pm

Re: v6.39.1 [current]

Mon Jun 05, 2017 11:22 am

Upgrade RB 1100 AH and RB 1100 AHX4 to version 6.39, 10 % loss packet on the any ports in RB. When dowgrade on system version 6.38, los packet is correct.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.39.1 [current]

Tue Jun 06, 2017 2:05 pm

Version 6.39.2 has been released:
viewtopic.php?f=21&t=122322

Who is online

Users browsing this forum: No registered users and 6 guests