Community discussions

  • 1
  • 2
  • 3
  • 4
  • 5
  • 12
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.41rc [release candidate] is released! New bridge implementation!

Wed Jul 26, 2017 2:36 pm

What's new in 6.41rc3 (2017-Jul-26 09:32):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering
!) switch - "master-port" conversion into a bridge with hardware offload "hw" option (CLI only);
https://wiki.mikrotik.com/wiki/Manual:S ... Offloading
!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) CRS3xx - switch VLAN configuration integrated within bridge VLAN configuration with hw-offload;
*) arp - fixed invalid static ARP entries after reboot on interfaces without IP address;
*) bonding - improved relialibility on bonding interface removal;
*) bridge - fixed ARP setting (introduced in v6.40rc36);
*) bridge - fixed multicast forwarding (introduced in v6.40rc36);
*) bridge - implemented dynamic entries for active MST port overrides;
*) bridge - implemented software based "igmp-snooping" (CLI only);
*) bridge - implemented software based MSTP (CLI only);
*) bridge - removed "frame-types" and "ingress-filtering" for bridge interfaces (introduced in v6.40rc36);
*) certificate - show "Expired" flag when initial CRL fetch fails;
*) e-mail - do not show errors when sending e-mail from script;
*) firewall - properly remove "address-list" entry after timeout ends;
*) hotspot - improved user statistics collection process;
*) interface - improved interface state change handling when multiple interfaces are affected at the same time;
*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
*) lte - allow to specify the MAC address for passthrough mode;
*) ppp - added client support for Sierra MC7750;
*) rb2011 - fixed possible LCD blinking along with Ethernet LED;
*) rb922 - restored missing wireless interface on some boards;
*) sftp - added functionality which imports ".auto.rsc" file or reboots router on ".auto.npk" upload;
*) trafficgen - fixed "lost-ratio" showing incorrect statistics after multiple sequences;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
raffav
Member Candidate
Member Candidate
Posts: 278
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Jul 26, 2017 2:52 pm

Hello everyone
I'm confused on the crs 125 series what is the best way,
Use the new vlan on bridge or stay using the switch menu?
Thanks.

Enviado de meu XT1580 usando Tapatalk
 
49er
Member
Member
Posts: 401
Joined: Tue Sep 27, 2011 7:55 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Jul 26, 2017 3:19 pm

raffav,

I Understand you.
I have the same.
VLAN on Mikrotik is very confussing
 
raymondr15
Member Candidate
Member Candidate
Posts: 118
Joined: Fri Sep 05, 2014 1:11 am
Location: East London, South Africa
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Jul 26, 2017 4:38 pm

Hi,

I am sitting in my office at work and have just update my RB2011UiAS-RM remotely, after rebooting the router am not able to access my router from the WAN side, my internet service provider is a WISP so I logged into my CPE and tried to SSH my router, I am able to login to the router but as soon as I login, the router stops responding for a few minutes and then comes back, same thing keeps happening when trying to SSH to the router. Will have to check the router when I get home.

Folks, don't upgrade your router if it is on a remote location 8)
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Jul 26, 2017 7:44 pm

New bridge is back!!!!!!! Super excited to test IPv6 pool prefix hinting assignments too. Might not be until next week though.
 
User avatar
boldsuck
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sun Sep 01, 2013 1:07 am
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 1:09 am

RB2011UAS v6.41rc3
Bridge hardware offload is fine. :D
IPv6 address assignment is broken :-( State is 'invalid'

/ipv6 address
add address=::1/64 from-pool=netdsl-ipv6 interface=bridge-local advertise=yes
[admin@migo] /ipv6 address> print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local 
 #    ADDRESS                                     FROM-POOL INTERFACE                                                                                                    ADVERTISE
 0 IG ::1/64                                      netdsl... bridge-local                                                                                                 yes      
 1 DL fe80::d6ca:6dff:fea0:ff93/64                          bridge-local                                                                                                 no       
 2 DL fe80::d/64                                            pppoe-out1                                                                                                   no       
 3 DL fe80::d6ca:6dff:fea0:ff92/64                          ether1-gateway                                                                                               no       
DHCPv6 prefix delegation from ISP is OK.
[admin@migo] /ipv6> dhcp-client print
Flags: D - dynamic, X - disabled, I - invalid 
 #    INTERFACE         STATUS        REQUEST        PREFIX                                                           ADDRESS                                                     
 0    pppoe-out1        bound         prefix         2001:4dd2:8c78::/48, 1d1h47m23s                                 
Supout file was sent.
Last edited by boldsuck on Sun Jul 30, 2017 12:45 am, edited 1 time in total.
╰_╯ Ciao Marco!
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 1:53 am

Hello everyone
I'm confused on the crs 125 series what is the best way,
Use the new vlan on bridge or stay using the switch menu?
Thanks.

Enviado de meu XT1580 usando Tapatalk
My understanding from the 6.40rc36 and 38 releases was that the switch chip menu was to not be used for ports not in a new bridge and ideally all configurations should move to the new VLAN aware hw-offload bridges.

I do recall a conflicting post from a MikroTik poster so clarification from own of the MikroTik folks would be great.
 
raffav
Member Candidate
Member Candidate
Posts: 278
Joined: Wed Oct 24, 2012 4:40 am

Re: RE: Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 2:04 am

Hello everyone
I'm confused on the crs 125 series what is the best way,
Use the new vlan on bridge or stay using the switch menu?
Thanks.

Enviado de meu XT1580 usando Tapatalk
My understanding from the 6.40rc36 and 38 releases was that the switch chip menu was to not be used for ports not in a new bridge and ideally all configurations should move to the new VLAN aware hw-offload bridges.

I do recall a conflicting post from a MikroTik poster so clarification from own of the MikroTik folks would be great.
I asked this because on here on wiki


https://wiki.mikrotik.com/wiki/Manual%3 ... Offloading

If you see the table of crs 1xx/2xx series
It have a - on bridge vlan filter



Enviado de meu XT1580 usando Tapatalk
 
romihg
just joined
Posts: 22
Joined: Tue Jun 24, 2014 9:07 am
Location: SLOVENIA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 3:43 am

Upgrade from 6.40 last rc to 6.41.3 my 2011UiAS-2HnD all leds on active interfaces are off, Except led on eth10 is on witch is POE Out and is active. Is this normal or something wrong with this.
 
romihg
just joined
Posts: 22
Joined: Tue Jun 24, 2014 9:07 am
Location: SLOVENIA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 4:05 am

Upgrade from 6.40 last rc to 6.41.3 my 2011UiAS-2HnD all leds on active interfaces are off, Except led on eth10 is on witch is POE Out and is active. Is this normal or something wrong with this.
Leds work on boot. But after router come in working state they switch off.
 
proximus
Member Candidate
Member Candidate
Posts: 107
Joined: Tue Oct 04, 2011 1:46 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 4:43 am

Upgrade from 6.40 last rc to 6.41.3 my 2011UiAS-2HnD all leds on active interfaces are off,
Same here, LED's are dead (RB2011UiAS).
 
becs
MikroTik Support
MikroTik Support
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 9:18 am

Hello, we are aware that Ethernet LEDs do not work on RouterBoards with AR8327/QCA8337 switch chips in v6.41rc3 and look forward to fix it soon.
 
becs
MikroTik Support
MikroTik Support
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 9:31 am

My understanding from the 6.40rc36 and 38 releases was that the switch chip menu was to not be used for ports not in a new bridge and ideally all configurations should move to the new VLAN aware hw-offload bridges.
Currently, it is implemented only for CRS3xx series switches.
If you see the table of crs 1xx/2xx series
It have a - on bridge vlan filter
On CRS125 VLANs still have to be configured in "/interface ethernet switch" menu to keep hw-offload working. If they are configured in "/interface bridge vlan", the hw-offload will turn off.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 12:12 pm

My understanding from the 6.40rc36 and 38 releases was that the switch chip menu was to not be used for ports not in a new bridge and ideally all configurations should move to the new VLAN aware hw-offload bridges.
Currently, it is implemented only for CRS3xx series switches.
If you see the table of crs 1xx/2xx series
It have a - on bridge vlan filter
On CRS125 VLANs still have to be configured in "/interface ethernet switch" menu to keep hw-offload working. If they are configured in "/interface bridge vlan", the hw-offload will turn off.
Becs, thanks for the clarification! While we're chatting. How do we mere mortals edit the wiki?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Jul 27, 2017 1:02 pm

Only staff can edit the wiki
No answer to your question? How to write posts
 
User avatar
eworm
Member
Member
Posts: 358
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Jul 28, 2017 12:06 pm

Successfully updated a CRS109-8G-1S-2HnD. Looks great, can't wait for this to be released in current! :D
!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering
Before changing my configuration... Does MAC-based-VLAN work with this implementation?
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
Grickos
newbie
Posts: 32
Joined: Thu Aug 06, 2015 2:57 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Jul 28, 2017 5:52 pm

The VLAN does not work on the Atheros 8327 chip switch.
I create Bridge1 and add Ethernet1 and Ethernet2.
I'm creating VLAN20 on Bridge1 - there's still ok.
But when I add VLAN20 to Bridge2, RB is unavailable on these two ports.

Sorry about my English.
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Jul 28, 2017 6:53 pm

Shouldn't VLAN be created on Ethernet port, not the bridge ...
Or you are trying Bridge VLAN Filtering and vlan-ids ...
I'm creating VLAN20 on Bridge1 - there's still ok.
But when I add VLAN20 to Bridge2, RB is unavailable on these two ports.
 
Grickos
newbie
Posts: 32
Joined: Thu Aug 06, 2015 2:57 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Jul 28, 2017 8:54 pm

Shouldn't VLAN be created on Ethernet port, not the bridge ...
Or you are trying Bridge VLAN Filtering and vlan-ids ...
I'm creating VLAN20 on Bridge1 - there's still ok.
But when I add VLAN20 to Bridge2, RB is unavailable on these two ports.
It does not work even if I put my vlan on ether1 or 2.
I want to get the old way tagged vlan20 on ports ether1,2,3 ... n (before master port1 and slave ether2,3, ... n)
Bridge strip Taging. I have DHCP server for vlan20.

It works great on chip switch Atheros 8227.
Simplified Example:
/interface bridge
add name=bridge1
add name=bridge2
add name=bridge3
/interface vlan
add interface=bridge1 name=vlan20 vlan-id=20
add interface=bridge1 name=vlan30 vlan-id=30
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether2
add bridge=bridge2 interface=vlan20
add bridge=bridge3 interface=vlan30
 
JanezFord
Member Candidate
Member Candidate
Posts: 262
Joined: Wed May 23, 2012 10:58 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Jul 28, 2017 10:55 pm

If you see the table of crs 1xx/2xx series
It have a - on bridge vlan filter
On CRS125 VLANs still have to be configured in "/interface ethernet switch" menu to keep hw-offload working. If they are configured in "/interface bridge vlan", the hw-offload will turn off.
Will there be shift to new syntax also for CRS125 series? It is a bit confusing to have to use different syntax for each product to get things done ...

JF.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 2:55 am

If you see the table of crs 1xx/2xx series
It have a - on bridge vlan filter
On CRS125 VLANs still have to be configured in "/interface ethernet switch" menu to keep hw-offload working. If they are configured in "/interface bridge vlan", the hw-offload will turn off.
Will there be shift to new syntax also for CRS125 series? It is a bit confusing to have to use different syntax for each product to get things done ...

JF.
+1, one would hope it continues to move towards a singular syntax for VLAN configuration and let MikroTik ninja's translate that as needed in middleware into any fidgety model specific configuration options.
 
raffav
Member Candidate
Member Candidate
Posts: 278
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 5:33 am

+1
Agree, need to be more simple, no offense but the Cisco way it very simple
Switch port mode trunk/access
Switch port access vlan x
Switch port trunk allow vlan x,y,z



Enviado do meu iPad usando Tapatalk
 
Safic
just joined
Posts: 4
Joined: Sun Jun 19, 2016 10:26 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 8:32 am

Shouldn't VLAN be created on Ethernet port, not the bridge ...
Or you are trying Bridge VLAN Filtering and vlan-ids ...
I'm creating VLAN20 on Bridge1 - there's still ok.
But when I add VLAN20 to Bridge2, RB is unavailable on these two ports.
It does not work even if I put my vlan on ether1 or 2.
I want to get the old way tagged vlan20 on ports ether1,2,3 ... n (before master port1 and slave ether2,3, ... n)
Bridge strip Taging. I have DHCP server for vlan20.
Grickos, just put your vlan interfaces at bridge1 and add bridge1 to tagged ports in
/interface bridge vlan
Last edited by Safic on Sat Jul 29, 2017 9:49 am, edited 1 time in total.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1235
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 9:43 am

+1
Agree, need to be more simple, no offense but the Cisco way it very simple
Switch port mode trunk/access
Switch port access vlan x
Switch port trunk allow vlan x,y,z
+1

I have worked with HP: very simple vlan setup, Cisco: simple VLAN and others
On Mikrotik I have still not used VLAN, since I have problem to understand how it works.
Its way to complicated.
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 1:21 pm

Vlan is Hard to understand IF you used HP as they use the term tag/untagged (Their Ports are all hybrid and can't be trunk or access from the cisco perpspective.)

AccessPort = A port that is only accepting untaged frames on ingress and only output untaged frames on egress. All other frametypes is silently droped
TrunkPort = A port that only accepts tagged frames, all untaged frames is silently droped. it only egress taged frames.

Other have then invented shortcuts of that:

Hybrid = A port that accept both taged and untaged frames on ingress, untaged frames are assumed to belong to a native vlan. the same vlan can even recieve frames taged as beloning to it. Egres a hybrid port outputs as a trunk on all vlans and as an access port on the native vlan.

HP's implementation of only hybrid have stirred quit a few it guys in the field. The cisco way is cleaner and less error prone.

This is a Mikrotik forum and I who claims to understand .1q or qinq or qinqinqinq for one loves the freedom in mikrotik bridge being software layer, switch being hardware layer or at least I assume. Here i'm am currently not sure due to 6.41rc work.... but that will clear when it's done.
 
User avatar
boldsuck
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sun Sep 01, 2013 1:07 am
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 1:32 pm

- ipv6 - fixed IPv6 address request from pool (introduced in 6.41rc1);
RB2011UAS v6.41rc1 - rc20
IPv6 address assignment is broken :-( State is 'invalid'
Just for INFO:
MikroTik have managed to reproduce the problem. The error only occurs with me and a few others. MikroTik are working on it. But I fear this will remain an eternal bug.
:wink: I can live with the router not to reboot.

Since 6.41rc13 the DHCPv6 client has no more prefix. The IPv6 address could therefore not be assigned manually. Since 6.41rc20 gets the DHCPv6 client again a prefix which I then manually assigned.

I can not test the feature with the dynamic subprefix.
- Ippool6 - try to assign the requested prefix for client if prefix is not being already used;

Edit:
Damn, I'm stupid! I wanted to answer, do not edit. The forum is unfortunately not in the wayback machine so I can reverse that again. Sorry.
Last edited by boldsuck on Wed Aug 30, 2017 1:28 pm, edited 2 times in total.
╰_╯ Ciao Marco!
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 2:13 pm

It does not work even if I put my vlan on ether1 or 2.
It should be like this ... (if your vlans 20 and 30 are on ether2):
/interface bridge
add name=bridge1
add name=bridge2
add name=bridge3
/interface vlan
add interface=ether2 name=vlan20 vlan-id=20
add interface=ether2 name=vlan30 vlan-id=30
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether3
add bridge=bridge2 interface=vlan20
add bridge=bridge3 interface=vlan30
Check https://wiki.mikrotik.com/wiki/Manual:Interface/VLAN ...
 
Eduardo
newbie
Posts: 45
Joined: Thu Aug 18, 2016 12:20 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Jul 29, 2017 5:52 pm

On CRS125 VLANs still have to be configured in "/interface ethernet switch" menu to keep hw-offload working. If they are configured in "/interface bridge vlan", the hw-offload will turn off.
Beginners question: I am not using VLANs on CRS125, but was using masterport. Can I still use this masterport functionality? Or I need to go via VLANs now, to get hardware switching?!

Thanks.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Jul 30, 2017 6:05 am

Vlan is Hard to understand IF you used HP as they use the term tag/untagged (Their Ports are all hybrid and can't be trunk or access from the cisco perpspective.)

AccessPort = A port that is only accepting untaged frames on ingress and only output untaged frames on egress. All other frametypes is silently droped
TrunkPort = A port that only accepts tagged frames, all untaged frames is silently droped. it only egress taged frames.

Other have then invented shortcuts of that:

Hybrid = A port that accept both taged and untaged frames on ingress, untaged frames are assumed to belong to a native vlan. the same vlan can even recieve frames taged as beloning to it. Egres a hybrid port outputs as a trunk on all vlans and as an access port on the native vlan.

HP's implementation of only hybrid have stirred quit a few it guys in the field. The cisco way is cleaner and less error prone.

This is a Mikrotik forum and I who claims to understand .1q or qinq or qinqinqinq for one loves the freedom in mikrotik bridge being software layer, switch being hardware layer or at least I assume. Here i'm am currently not sure due to 6.41rc work.... but that will clear when it's done.
JimmyNyholm, a Cisco trunk port will pass both tagged or untagged traffic depending on the allowed VLAN list assigned to the trunk port (by default all VLANs are allowed). This is the "hybrid" behavior you're describing. Leaving the native VLAN routable on trunks is what exposes people to double tagging VLAN hop methods for what it's worth.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Jul 30, 2017 6:07 am

The VLAN does not work on the Atheros 8327 chip switch.
I create Bridge1 and add Ethernet1 and Ethernet2.
I'm creating VLAN20 on Bridge1 - there's still ok.
But when I add VLAN20 to Bridge2, RB is unavailable on these two ports.

Sorry about my English.
Grickos, I've not used VLANs in that fashion in any configurations. Looking at the new bridges I have been creating a single bridge and I add the interfaces as bridge ports. I also add all VLANs to this central bridge and adjust ports for tagged or an untagged VLAN as needed. I wouldn't expect two bridges to share information regarding the same VLAN without another bridge to glue them together.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Jul 30, 2017 8:22 am

Running the command:
/export
Hardware I tested against:
  • RouterBOARD 750G r3
  • RouterBOARD wAP G-5HacT2HnD
  • RouterBOARD cAP L-2nD
The result I see in the print-out:
#error exporting /system routerboard mode-button
I'm pretty sure it's benign but just thought I'd post it.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Jul 30, 2017 6:58 pm

JimmyNyholm, a Cisco trunk port will pass both tagged or untagged traffic depending on the allowed VLAN list assigned to the trunk port (by default all VLANs are allowed). This is the "hybrid" behavior you're describing. Leaving the native VLAN routable on trunks is what exposes people to double tagging VLAN hop methods for what it's worth.
Idlemind: you are right when talking to later 802.1q adaptations from cisco side. switchport mode trunk will still only accept taged frames on ingress (leaning back from the isl days before 802.q was ratified). You have to tell it to process untagged frames as well and that command is only available after certain version of the ios. We do agree upon that this will make even ciscos implementation leaning to hybrid.
My writing was to open up peoples mind to the idea of what is happening ingress and egress of a switchport, and to set some acronyms. To many techs think vlan is difficult when it's actually not just with the right mindset.

never connect vlan 0 from different vendors, never use spanning tree. Allways know what you are doing. ;-)
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Jul 30, 2017 8:47 pm

JimmyNyholm, a Cisco trunk port will pass both tagged or untagged traffic depending on the allowed VLAN list assigned to the trunk port (by default all VLANs are allowed). This is the "hybrid" behavior you're describing. Leaving the native VLAN routable on trunks is what exposes people to double tagging VLAN hop methods for what it's worth.
Idlemind: you are right when talking to later 802.1q adaptations from cisco side. switchport mode trunk will still only accept taged frames on ingress (leaning back from the isl days before 802.q was ratified). You have to tell it to process untagged frames as well and that command is only available after certain version of the ios. We do agree upon that this will make even ciscos implementation leaning to hybrid.
My writing was to open up peoples mind to the idea of what is happening ingress and egress of a switchport, and to set some acronyms. To many techs think vlan is difficult when it's actually not just with the right mindset.

never connect vlan 0 from different vendors, never use spanning tree. Allways know what you are doing. ;-)
Ahh, ISL has been removed in the newer IOS XE based switching lines and you no longer have to express which encapsulation method you want to use.

I would disagree with you. I haven't been bit by the spanning-tree devil and am a firm proponent in it's use. It's definitely a best practice to use spanning-tree in switched networks. It will layer appropriately on top of other redundancy technologies like port-channels as well as protect you from loops.

Like you finished with though, knowing how to use the tool is critical. Spanning-tree with it's many variants and implementations can be difficult to master but it's absolutely essential for any portion of a network that's switched. I'll take slow (fast honestly with RSTP/MSTP) automated failover of my links any day of the week.
 
vacari
just joined
Posts: 7
Joined: Fri Mar 04, 2016 2:56 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Jul 31, 2017 3:52 am

Hello,
I have a RouterBOARD 3011UiAS
Firmware 3.35 version 6.41rc3
The activity led was disabled.

Thanks a lot.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Jul 31, 2017 9:54 am

What's new in 6.41rc4 (2017-Jul-28 06:48):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering
!) switch - "master-port" conversion into a bridge with hardware offload "hw" option (CLI only);
https://wiki.mikrotik.com/wiki/Manual:S ... Offloading
!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) bridge - show "admin-mac" only if "auto-mac=no";
*) rb922 - restored missing wireless interface on some boards;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Jul 31, 2017 7:28 pm

What's new in 6.41rc3 (2017-Jul-26 09:32):
*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
Strods, this is implemented in the IPv6 pool code now but it doesn't seem to be implemented in the address assignment code yet, correct?
[admin@rtr1] > ipv6 address add    
address  advertise  comment  copy-from  disabled  eui-64  from-pool  no-dad  interface
I'm hoping we'll be getting an option to like "pref-prefix" where we can hint what prefix we'd like. Think a prefix of 11 for VLAN11 when getting a /56 assignment from the ISP for that networks /64. Ensuring devices remain some semblance of consistent IPs and keep us administrators sane.
 
bruins0437
just joined
Posts: 10
Joined: Thu Jul 13, 2017 4:30 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 01, 2017 6:05 am

Running the command:
/export
Hardware I tested against:
  • RouterBOARD 750G r3
  • RouterBOARD wAP G-5HacT2HnD
  • RouterBOARD cAP L-2nD
The result I see in the print-out:
#error exporting /system routerboard mode-button
I'm pretty sure it's benign but just thought I'd post it.

Same issue on RouterBoard 2011. Also "Run After" appears to be broken too,it will not load exported .rsc file. Mikrotik ends up rebooting with no config at all.


-Eric
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 01, 2017 3:07 pm

What's new in 6.41rc6 (2017-Aug-01 11:30):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) btest - improved reliability on Bandwidth Test when device`s RAM is almost full;
*) dhcpv6-client - do not run DHCPv6 client when IPv6 package is disabled;
*) ipv6 - fixed IPv6 address request from pool (introduced in 6.41rc1);
*) lte - fixed LTE not passing any traffic while in running state;
*) ppp - added support for Sierra MC7750, Verizon USB730L;
*) torch - fixed Torch on PPP tunnels (introduced in 6.40);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
slimmerwifi
just joined
Posts: 13
Joined: Tue Aug 01, 2017 6:05 pm
Location: Netherlands

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 01, 2017 6:16 pm

We have tested a freshly configured Hap AC with 6.41rc4 and getting large amounts of Radar detect in Regulatory domain.

Accespoint is only usable in super channel mode.

We are in a bank building so no actual radar here ;-)

Available for debugging.
We manage 50+ corporate wifi networks in the Netherlands using Mikrotik & Cloudcore equipment.
 
User avatar
boldsuck
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sun Sep 01, 2013 1:07 am
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 01, 2017 8:08 pm

*) ipv6 - fixed IPv6 address request from pool (introduced in 6.41rc1);
To the half it goes. ;-)
[admin@migo] /ipv6 address> add address=::1/64 from-pool=netdsl-ipv6 interface=bridge-local advertise=yes
[admin@migo] /ipv6 address> print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local 
 #    ADDRESS                                     FROM-POOL INTERFACE                                                                                                                                                                                                ADVERTISE
 0 DL fe80::d6ca:6dff:fea0:ff93/64                          bridge-local                                                                                                                                                                                             no       
 1 DL fe80::d6ca:6dff:fea0:ff92/64                          ether1-gateway                                                                                                                                                                                           no       
 2 DL fe80::d/64                                            pppoe-out1                                                                                                                                                                                               no       
 3  G 2001:4dd2:a7c1::1/64                        netdsl... bridge-local                                                                                                                                                                                             yes      
It works :-D ...but...
[admin@migo] /system> reboot
...
[admin@migo] /ipv6 address> print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local 
 #    ADDRESS                                     FROM-POOL INTERFACE                                                                                                                                                                                                ADVERTISE
 0 IG 2001:4dd2:a7c1::1/64                        netdsl... bridge-local                                                                                                                                                                                             yes      
 1 DL fe80::d6ca:6dff:fea0:ff93/64                          bridge-local                                                                                                                                                                                             no       
 2 DL fe80::d/64                                            pppoe-out1                                                                                                                                                                                               no       
 3 DL fe80::d6ca:6dff:fea0:ff92/64                          ether1-gateway                                                                                                                                                                                         no       
Damn it! After reboot again invalid. :cry: :evil:
[admin@migo] /ipv6 address> remove
numbers: 0
[admin@migo] /ipv6 address> add address=::1/64 from-pool=netdsl-ipv6 interface=bridge-local advertise=yes
[admin@migo] /ipv6 address> print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local 
 #    ADDRESS                                     FROM-POOL INTERFACE                                                                                                                                                                                                ADVERTISE
 0 DL fe80::d6ca:6dff:fea0:ff93/64                          bridge-local                                                                                                                                                                                             no       
 1 DL fe80::d/64                                            pppoe-out1                                                                                                                                                                                               no       
 2 DL fe80::d6ca:6dff:fea0:ff92/64                          ether1-gateway                                                                                                                                                                                           no       
 3  G 2001:4dd2:a7c8::1/64                        netdsl... bridge-local
It works again.
Workaround. Don't reboot router :lol: Or delete and re-add after each reboot.
╰_╯ Ciao Marco!
 
User avatar
ZeroByte
Forum Guru
Forum Guru
Posts: 4048
Joined: Wed May 11, 2011 6:08 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 01, 2017 11:47 pm

*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
So how do I use this feature?

Suppose my pool prefix is 2001:db8:abcd::/48 and I wish to assign subprefix 1234::1/64 from this pool onto interface ether1. How do I enter this?
Suppose further that I wish to define this in such a way that if the prefix changes in the future that I don't need to change anything in the router.
I.e. if tomorrow, my dhcpv6-client receives pool 2001:db8:4567::/48, then ether1 should change automatically:
from 2001:db8:abcd:1234::1/64
to 2001:db8:4567:1234::1/64

Or does this feature only apply to dhcpv6 PD server?
When given a spoon,
you should not cling to your fork.
The soup will get cold.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 02, 2017 2:32 pm

What's new in 6.41rc7 (2017-Aug-02 09:51):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) export - fixed export for different parameters where numerical range or constant string is expected;
*) ovpn-client - fixed incorrect netmask usage for pushed routes;
*) pppoe-client - fixed incorrectly formed PADT packet;
*) winbox - added "none-dynamic" and "none-static" options for "address-list-timeout" parameter under NAT, Mangle and RAW rules;
*) winbox - do not show duplicate filter parameters "Published" in ARP list;
*) winbox - show warnings under "/system routerboard settings" menu;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
boldsuck
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Sun Sep 01, 2013 1:07 am
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 02, 2017 8:42 pm

*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
So how do I use this feature?

Suppose my pool prefix is 2001:db8:abcd::/48 and I wish to assign subprefix 1234::1/64 from this pool onto interface ether1. How do I enter this?
Suppose further that I wish to define this in such a way that if the prefix changes in the future that I don't need to change anything in the router.
I get a new dynamic IPv6 prefix every time from my ISP after each reconnect or after 26 hours. (with IPv6-DHCP-Client)
Adding ::1/64 to this dynamic IPv6 prefix runs here over 4 years. A subprefix abcd::1/64, I have not yet tested. I will try the days. (If 'IPv6 address request from pool' is fixed in the rc version)

This works, the dynamic prefix is added automatically:
/ipv6 address> add address=::1/64 from-pool=ISP-pool-ipv6 interface=bridge-local advertise=yes

2001:db8:abcd::1/64
2001:db8:0123::1/64
2001:db8:4567::1/64
╰_╯ Ciao Marco!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 10:19 am

Everyone who is experiencing issues with DHCPv6 client - we will have a potential fix for this problem in next 6.41rc version. Please test it when it comes available and report to support@mikrotik.com with results. If fix will help, then we will also include in upcoming current versions.
 
th0massin0
Member Candidate
Member Candidate
Posts: 144
Joined: Sun May 11, 2014 4:16 am
Location: Poland

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 2:17 pm

*) lte - fixed LTE not passing any traffic while in running state;
Problem with reliability of SXT LTE still exists (now: PLMN search in progress) - ROS 6.41rc7.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 4:06 pm

What's new in 6.41rc9 (2017-Aug-03 12:02):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) certificate - fixed SCEP "get" request URL encoding;
*) dhcpv6-client - fixed IA evaluation order;
*) l2tp-server - fixed PPP services becoming unresponsive after changes on L2TP server with IPSec configuration;
*) lcd - fixed LCD blinking on RB2011 (introduced in 6.40);
*) lte - added initial passthrough support for wAP LTE;
*) pppoe-client - fixed wrong auto MRU detection over VLAN interfaces;
*) pppoe-server - fixed situation when PPPoE servers become invalid after reboot;
*) sfp - fixed invalid temperature readings when ambient temperature is below 0C;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
proximus
Member Candidate
Member Candidate
Posts: 107
Joined: Tue Oct 04, 2011 1:46 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 5:07 pm

LED's on RB2011 were working again on rc7. With rc9, there are on solid (with link), no activity blinking.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 10:30 pm

LEDs will be fixed again in the next rc release.
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 03, 2017 11:44 pm

Does the mikrotik development team have no change control? (Cvs)
Bugs always return.....
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 04, 2017 8:04 am

RB2011. pppoe-client from my provider was stop working after upgrade on rc9. Downgrade to stable release.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 12

Who is online

Users browsing this forum: No registered users and 3 guests