Community discussions

  • 1
  • 2
  • 3
  • 4
  • 5
  • 12
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 04, 2017 10:12 am

heaven - Please send supout file to support@mikrotik.com. Generate it while PPPoE client is not working. We have tested it locally and in general PPPoE client is working as suspected. There must be something very specific.
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 04, 2017 7:38 pm

heaven - Please send supout file to support@mikrotik.com. Generate it while PPPoE client is not working. We have tested it locally and in general PPPoE client is working as suspected. There must be something very specific.
I was already send it! Thank you for your job, guys! :-)
 
romihg
just joined
Posts: 22
Joined: Tue Jun 24, 2014 9:07 am
Location: SLOVENIA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 05, 2017 10:21 am

Reseting router with /system reset-configuration is the same as /system reset-configuration no-defaults option. So no defaults loaded on boot.

2011UiAS-2HnD with 6.41.9rc
 
manyyy
just joined
Posts: 2
Joined: Wed Nov 30, 2016 5:52 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 05, 2017 3:52 pm

I have an issue with 6.41.rc9 on RB751G-2HnD.

After upgrade from channel=current 6.40 there is no interface pppoe-client created.
Even if I add this manualy, it wont connect to the DSL BRAS.
Seems that something is wrong with Link Control Protocol.

Log debug below:
14:17:45 pppoe,ppp,debug netia: LCP lowerdown
14:17:45 pppoe,ppp,debug netia: LCP down event in initial state
14:17:45 pppoe,ppp,info netia: disconnected
14:17:55 pppoe,ppp,info netia: initializing...
14:17:55 pppoe,ppp,info netia: connecting...
14:18:05 pppoe,ppp,info netia: terminating... - disconnected
Downgrading to 6.40.1 everything goes back to operational.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 07, 2017 9:35 pm

Working on a new RB750Gr3 (hex). I installed 6.41rc9 and I'm unable to get an access port working for a VLAN on the new VLAN aware bridges. A similar configuration is working on a RB750Gr3 running 6,41rc6.
  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.41rc9 (c) 1999-2017       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level

[admin@rtr1] > export
# aug/07/2017 13:27:40 by RouterOS 6.41rc9
# software id = 247N-DPAI
#
# model = RouterBOARD 750G r3
# serial number = xxxxxxxxxxxx
/interface bridge
add admin-mac=6C:3B:6B:bb:xx:yy auto-mac=no fast-forward=no igmp-snooping=no name=br1 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=eth1
set [ find default-name=ether2 ] name=eth2
set [ find default-name=ether3 ] name=eth3
set [ find default-name=ether4 ] name=eth4
set [ find default-name=ether5 ] name=eth5
/ip neighbor discovery
set eth1 discover=no
/interface vlan
add interface=br1 name=br1-vlan11 vlan-id=11
add interface=br1 name=br1-vlan12 vlan-id=12
add interface=br1 name=br1-vlan999 vlan-id=999
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=vlan11 ranges=10.214.11.100-10.214.11.199
add name=vlan12 ranges=10.214.11.100-10.214.11.199
add name=vlan13 ranges=10.214.11.100-10.214.11.199
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=br1 name=defconf
add address-pool=vlan11 disabled=no interface=br1-vlan11 name=vlan11
add address-pool=vlan12 disabled=no interface=br1-vlan12 name=vlan12
/interface bridge port
add bridge=br1 hw=no interface=eth2 pvid=11
add bridge=br1 hw=no interface=eth3
add bridge=br1 hw=no interface=eth4
add bridge=br1 hw=no interface=eth5
/interface bridge vlan
add bridge=br1 untagged=eth2 vlan-ids=11
/ip address
add address=192.168.88.1/24 comment=defconf interface=br1 network=192.168.88.0
add address=10.214.11.254/24 interface=br1-vlan11 network=10.214.11.0
add address=10.214.12.254/24 interface=br1-vlan12 network=10.214.12.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=eth1
/ip dhcp-server network
add address=10.214.11.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.11.254
add address=10.214.12.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.12.254
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface=eth1
/system package update
set channel=release-candidate
#error exporting /system routerboard mode-button
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
A packet capture shows STP frames and discovery frames from the relevant VLAN interface, in this case br-vlan11, but does not seem to forward other traffic. I'm unable to mac-telnet into the router despite allowing it on the br1-vlan11 interface. I cannot ping the IP address assigned to br-vlan11 despite seeing it in the CDP message in WireShark (both interface and IP).
Last edited by idlemind on Thu Aug 17, 2017 3:38 am, edited 1 time in total.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 09, 2017 12:37 pm

What's new in 6.41rc11 (2017-Aug-08 09:32):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx (CLI only);
*) bridge - automatically turn off "fast-forward" feature if both bridge ports have "H" flag;
*) export - fixed interface list export;
*) ike1 - release mismatched PH2 peer IDs;
*) ike2 - check identities on "initial-contact";
*) ike2 - use peer configuration address when available on empty TSi;
*) interface - fixed corrupted "/interface list" configuration after upgrade;
*) ipsec - allow to specify remote peer address as DNS name (CLI only);
*) ipsec - renamed "firewall" argument to "notrack-chain" in peer configuration;
*) led - fixed "modem-signal" LEDs (introduced in 6.40);
*) modem - added initial support for Alcatel IK40 and Olicard 500;
*) rb2011 - fixed possible LCD blinking along with ethernet LED (introduced in 6.40);
*) rb750gr3 - show warning and do not allow to use "protected-bootloader" feature if "factory-firmware" older than 3.34.4 version;
*) ups - fixed duplicate "failed" UPS logs;
*) winbox - added certificate settings;
*) winbox - added support fro certificate CRL list;
*) winbox - do not show duplicate "Template" parameters for filter in IPSec policy list;
*) winbox - fixed bridge port sorting order by interface name;
*) winbox - hide "level" and "tunnel" parameters for IPSec policy templates;
*) winbox - hide FAN speed if it is 0RPM;
*) wireless - added "russia3" country settings;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
osc86
newbie
Posts: 46
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 09, 2017 1:47 pm

*) ipsec - allow to specify remote peer address as DNS name (CLI only);
does this mean ipsec tunnels can be established between 2 sites with dynamic ip addresses, so I can get rid of the additional L2TP Tunnel?
CCR1009-7G-1C-1S+ ROS6.45.2
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5910
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 09, 2017 2:01 pm

In road warrior setups, yes.
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 09, 2017 5:12 pm

PPPoE Client problem that I was wrote earlier is not solved in new RC. The Mikrotik support in mail was promised to me that it was been solved in future new rc((((
P.S. don' t use remote upgrade. pppoe client will not start automatically. After upgrade need to turnoff/turnon pppoe physical interface. Than pppoe client will work.
 
PeterFreeman
just joined
Posts: 11
Joined: Tue Aug 02, 2011 10:26 pm
Location: United Kingdom
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 09, 2017 9:32 pm

Hi all,

The LED issue on the SXT LTE is still not fixed in 6.41.rc11 but it is getting a little closer...
The LED's on the back of the SXT LTE now respond to signal strength but the scale is off. Without moving our bench SXT LTE device, it shows 3-4 LEDs of signal whilst running 6.39.2. Post upgrade to 6.41.rc11 the LEDs only show 2 bars and it does not fluctuate when the signal is either improved or degraded with any significance.
The webfig interface graphs are also still broken. The graph scale is between -40 and -120 dB but eh signal is being metered in 65xxx figures. Chupaka previously noted in the 6.40 release notes that this is probably due to using the wrong DWORD in the code?

Over to you MikroTik ;-)

Many thanks

Pete.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 10, 2017 1:46 am

New bridge with VLANs still appears broken on my test RB750Gr3 for anything later than 6.41rc6. I can't seem to get NetInstall to work on Windows 10 to try jumping backwards to 6.41rc6 to confirm 100% that is the case. I'm holding off upgrading a production RB750Gr3 past 6.41rc6 where a similar configuration is working without issue.

Packets are received on an interface at the Ethernet level and I can see the counters increment. I do not see it increase the counters on the VLAN interface though.
/interface bridge vlan add bridge=br1 untagged=eth2 vlan-ids=11
/interface vlan add add interface=br1 name=br1-vlan11 vlan-id=11
/interface bridge port add bridge=br1 hw=no interface=eth2 pvid=11
/ip address add interface=br-vlan11 address=10.214.11.254/24
 
snowflake
just joined
Posts: 8
Joined: Thu Oct 25, 2012 1:53 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 10:37 am

[quote="manyyy"]I have an issue with 6.41.rc9 on RB751G-2HnD.

I have similar problem with PPPoE on RB751G-2HnD with
6.41rc11. Even after reboot the PPPoE link does not activate.
I reconfigured it manually. Still did not work.

I tried unplugging and replugging the Ethernet cable
and the link sprang into life, so it's partially solved.
 
snowflake
just joined
Posts: 8
Joined: Thu Oct 25, 2012 1:53 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 10:38 am

[quote="manyyy"]I have an issue with 6.41.rc9 on RB751G-2HnD.

I have similar problem with PPPoE on RB751G-2HnD with
6.41rc11. Even after reboot the PPPoE link does not activate.
I reconfigured it manually. Still did not work.

I tried unplugging and replugging the Ethernet cable
and the link sprang into life, so it's partially solved.
 
User avatar
erreferre
just joined
Posts: 21
Joined: Mon Sep 08, 2014 2:29 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 10:45 am

*) sftp - added functionality which imports ".auto.rsc" file or reboots router on ".auto.npk" upload;
How can I test this new feature?
MTCNA, MTCWE, MTCTCE, MTCRE, MTCUME, MTCINE
www.aerowi.es
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 10:57 am

make a new plain text file with contents:
/system identity set name=ITWORKS
Save this file with name test.auto.rsc

Then upload it with SFTP. Check what your identity name is now.
No answer to your question? How to write posts
 
User avatar
erreferre
just joined
Posts: 21
Joined: Mon Sep 08, 2014 2:29 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 11:35 am

make a new plain text file with contents:
/system identity set name=ITWORKS
Save this file with name test.auto.rsc

Then upload it with SFTP. Check what your identity name is now.
Yes, with the SFTP client of my computer. But I thought it could be possible to transfer files between MikroTik routers with a native sftp client or with a new fetch mode=sftp.
Thanks,
MTCNA, MTCWE, MTCTCE, MTCRE, MTCUME, MTCINE
www.aerowi.es
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 7:10 pm

make a new plain text file with contents:
/system identity set name=ITWORKS
Save this file with name test.auto.rsc

Then upload it with SFTP. Check what your identity name is now.
So, if I rename the 6.41rc6 .npk file to 6.41rc6.auto.npk and upload it a RouterBoard it will reboot into 6.41rc6?
 
raffav
Member Candidate
Member Candidate
Posts: 278
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 11, 2017 11:00 pm

Hello

is there any problem on PPPOE-out?

after upgrade they desapear.
 
snowflake
just joined
Posts: 8
Joined: Thu Oct 25, 2012 1:53 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 12, 2017 2:55 pm

Hello

is there any problem on PPPOE-out?

after upgrade they desapear.
pppoe-client configs disappear after upgrade.
It also invalidates the firewall and NAT configs because the interface has disappeared.

I reinstall the pppoe-client config and try enabling pppoe-client.
I monitor the interface but nothing happens.
I unplug and re-insert the Ethernet lead and the pppoe-out1 interface springs into life.

All this is on RB751G-2HnD
 
raffav
Member Candidate
Member Candidate
Posts: 278
Joined: Wed Oct 24, 2012 4:40 am

Re: RE: Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 12, 2017 4:34 pm

Hello

is there any problem on PPPOE-out?

after upgrade they desapear.
pppoe-client configs disappear after upgrade.
It also invalidates the firewall and NAT configs because the interface has disappeared.

I reinstall the pppoe-client config and try enabling pppoe-client.
I monitor the interface but nothing happens.
I unplug and re-insert the Ethernet lead and the pppoe-out1 interface springs into life.

All this is on RB751G-2HnD
Even ir I recreate ir it don't work
The config is there but invisible lol,
If i go back to current release it show up again and working.

Enviado de meu XT1580 usando Tapatalk
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 12, 2017 6:58 pm

make a new plain text file with contents:
/system identity set name=ITWORKS
Save this file with name test.auto.rsc

Then upload it with SFTP. Check what your identity name is now.
So, if I rename the 6.41rc6 .npk file to 6.41rc6.auto.npk and upload it a RouterBoard it will reboot into 6.41rc6?
So, it works for newer versions but not older versions. MikroTik please make it so you can downgrade RouterOS through this mechanic. If necessary make it a boolean value in the /ip service sftp settings to toggle allow/disallow software downgrades.
 
User avatar
doneware
Trainer
Trainer
Posts: 481
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 15, 2017 5:50 pm

So, it works for newer versions but not older versions. MikroTik please make it so you can downgrade RouterOS through this mechanic. If necessary make it a boolean value in the /ip service sftp settings to toggle allow/disallow software downgrades.
on the older versions this works just with ftp.
but there's nothing a consecutive sftp and ssh cannot fix, right :-)

scp yourcommandfile.rsc admin@router:
ssh admin@router '/import file-name=yourcommandfile.rsc; /file remove [find where name="yourcommandfile.rsc"]'

the only thing you lose is the output log.
#TR0359
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 15, 2017 6:13 pm

To be clear I was talking only about uploading a .npk file to the device for the purpose of installing a different version of RouterOS.

It allows you to upgrade (newer code) but not downgrade (older code). As an example you can up to 6.41rc11 by uploading the code file. Once in that version you cannot upload 6.41rc7. You only get a syslog message saying it's an older version.

I'm looking for a way without netinstall to allow that action.
 
User avatar
doneware
Trainer
Trainer
Posts: 481
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 15, 2017 6:30 pm

I'm looking for a way without netinstall to allow that action.
sorry.
put your npk files on the /file section, then do a
[bat@hgw2] /ip firewall nat> /sys package downgrade
it will ask for confirmation on reload, and then install whatever version you have on the files, so yes it is the way you downgrade your OS.
i hope i got it right this time.
#TR0359
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 16, 2017 1:19 pm

What's new in 6.41rc13 (2017-Aug-15 13:09):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx (CLI only);
*) bridge - implemented software based "igmp-snooping" (CLI only);
*) bridge - removed "master-port" parameter (CLI only);
*) certificate - fixed import of certificates with empty SKID;
*) dhcp - require DHCP option name to be unique;
*) dhcpv6-client - ignore unknown IA;
*) hotspot - fixed missing "/ip hotspost server profile" if invalid "dns-name" was specified;
*) interface - added option to join and exclude "/interface list" from one and another;
*) lte - improved FastPath support for SXT LTE;
*) lte - added multi APN passthrough support for wAP LTE;
*) lte - do not show USB LTE modem under "/port" menu (introduced in 6.41rc);
*) lte - improved reliability of USB LTE modems;
*) lte - properly recognize USB devices under "/system resource usb" (introduced in 6.41rc12);
*) rb750gr3 - show warning and do not allow to use "protected-bootloader" feature if "factory-firmware" older than 3.34.4 version;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
eworm
Member
Member
Posts: 358
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 16, 2017 3:49 pm

I am having issues with CAPsMAN on 6.41rc13... Looks like cap interfaces with CAPsMAN forwarding do not pass any traffic.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
horza
just joined
Posts: 5
Joined: Sun Oct 19, 2014 3:30 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 16, 2017 5:42 pm

6.41rc11 -> 6.41rc13 broke my bridge on x86.
The bridge is still there, I can disable and enable it, but it registeres as "not ready" everywhere (firewall, ip...)
In an attempt to fix it, I've deleted the bridge and created a new one with default options and cleared bridge>settings, but the new bridge exhibits same behavior - "not ready" reported by ip, firewall, etc.
I've managed to nicely downgrade back to 6.41rc11 without any config changes, and it works just fine.

I've got a mipsbe test router that's configured almost identically, and that one upgraded nicely and no bridge problems (same bridge configuration as on x86 machine).
No need for help; just reporting an issue for your consideration ;-)
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 16, 2017 9:09 pm

I'm looking for a way without netinstall to allow that action.
sorry.
put your npk files on the /file section, then do a
[bat@hgw2] /ip firewall nat> /sys package downgrade
it will ask for confirmation on reload, and then install whatever version you have on the files, so yes it is the way you downgrade your OS.
i hope i got it right this time.
Thank you!!!! Nice and convenient way to downgrade. Exactly what I was after.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 17, 2017 3:40 am

EDIT: I'm able to replicate the problem the x86 (CHR in my case) problem as well. IP address goes invalid as soon as it's added to a VLAN interface. That said, it works fine on my RB750Gr3 now.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 17, 2017 2:50 pm

idlemind - Which type of interface is the master interface of VLAN?
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 17, 2017 4:37 pm

idlemind - Which type of interface is the master interface of VLAN?
A bridge. If br1 is the VLAN aware bridge the master interface of the VLAN is br1.
 
kobuki
Member Candidate
Member Candidate
Posts: 134
Joined: Sat Apr 02, 2011 5:59 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 17, 2017 10:46 pm

With the new bridge implementation using HW offload, will it be possible to use multiple bridges using the offload capability, effectively creating multiple "switch groups" that retain wire speed in the group? It's now possible to do something similar using VLANs where each VLAN has a CPU port besides the physical ports. Would the new bridge implementation automatically create VLANs to provide such a setup?
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 7:41 am

PPPoE failed problem was not solved in new RC. My question is - When?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 1:57 pm

What's new in 6.41rc15 (2017-Aug-18 07:33):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) capsman - added "vlan-mode=no-tag" option (CLI only);
*) capsman - return complete CA chain when issuing new certificate;
*) export - fixed "/system routerboard" export (introduced in 6.40.1);
*) ike1 - fixed initiator ID comparison to NAT-OA;
*) led - fixed "on" and "off" triggers when multiple LEDs are selected;
*) lte - added passthrough support (CLI only);
*) ospf - fixed OSPF v2 and v3 neighbor election;
*) rb1100ahx4 - fixed HW acceleration fragmented packet decryption when fragment is smaller than 64 bytes;
*) routerboard - added "mode-button" support for RB750Gr3 (CLI only);
*) sfp - fixed SFP interface power monitor when bad SFP DDMI information is received;
*) ssh - do not execute command if it starts with "-" symbol;
*) wireless - added New Zealand regulatory domain information for P2P links;
*) wireless - updated China and New Zealand regulatory domain information;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
th0massin0
Member Candidate
Member Candidate
Posts: 144
Joined: Sun May 11, 2014 4:16 am
Location: Poland

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 2:12 pm

What's new in 6.41rc15 (2017-Aug-18 07:33):
*) lte - added passthrough support (CLI only);
Is it available for SXT LTE?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 2:59 pm

Unfortunately, currently SXT LTE does not support passthrough mode.
 
irghost
Member Candidate
Member Candidate
Posts: 277
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 4:13 pm

*) lte - added passthrough support (CLI only);
where? i cant find it
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 4:29 pm

Please remember that this is rc version - new features appear, are tested, etc. Documentation, GUI support, etc. for new features might not appear right away. Also features are not fully tested yet.

LTE Passthrough is described here:
https://wiki.mikrotik.com/wiki/Manual:I ... assthrough

Soon supported LTE devices also will be listed here:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 5:07 pm

What's new in 6.41rc16 (2017-Aug-18 13:44):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) lcd - fixed unresponsive LCD (introduced in 6.41rc15);
*) lte - added passthrough support (CLI only);
*) traffic-flow - fixed reboots when IPv6 address has been set as target address without active IPv6 package;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
bommi
just joined
Posts: 24
Joined: Fri Jan 24, 2014 9:13 am
Location: Germany
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 5:44 pm

*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
Is there a chance to get support for brainpool ec curves like DH group 28, 29 and 30?
 
irghost
Member Candidate
Member Candidate
Posts: 277
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 18, 2017 5:57 pm

What's new in 6.41rc16 (2017-Aug-18 13:44):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) lcd - fixed unresponsive LCD (introduced in 6.41rc15);
*) lte - added passthrough support (CLI only);
*) traffic-flow - fixed reboots when IPv6 address has been set as target address without active IPv6 package;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
passthrough Works With E3372 Hilink Mode RB750Gr3
/interface lte set lte1 apn=apn1/vlan600
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Aug 19, 2017 11:01 am

In RC16 PPPoE failed too. Can Support ask me when it will be solved? I think im not alone who faced with this problm.
 
b3h3m07h
newbie
Posts: 30
Joined: Sat Dec 28, 2013 3:06 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Aug 20, 2017 8:01 am

still having issues with RB2011UAS-2HnD and optus (aus) Huawei E3372h-607 http://www.optus.com.au/shop/prepaid/mo ... /usb/e3372

under load, p2p , multiple users on netflix or youtube, router reboots.
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sun Aug 20, 2017 9:31 pm

Hallo!
After updating a RB922 with a Huawei ME909s-120 modem to 6.41RC16, the lte-interface doesn't switch in running mode. The status of the interface shows only one information: "Functionality == minimal", nothing else.
Is this a normal behavior in case of lte-passthrough or a bug?

regards
 
branto
just joined
Posts: 8
Joined: Mon Aug 21, 2017 2:03 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 2:17 am

Working on a new RB750Gr3 (hex). I installed 6.41rc9 and I'm unable to get an access port working for a VLAN on the new VLAN aware bridges. A similar configuration is working on a RB750Gr3 running 6,41rc6.
  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.41rc9 (c) 1999-2017       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level

[admin@rtr1] > export
# aug/07/2017 13:27:40 by RouterOS 6.41rc9
# software id = 247N-DPAI
#
# model = RouterBOARD 750G r3
# serial number = xxxxxxxxxxxx
/interface bridge
add admin-mac=6C:3B:6B:bb:xx:yy auto-mac=no fast-forward=no igmp-snooping=no name=br1 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=eth1
set [ find default-name=ether2 ] name=eth2
set [ find default-name=ether3 ] name=eth3
set [ find default-name=ether4 ] name=eth4
set [ find default-name=ether5 ] name=eth5
/ip neighbor discovery
set eth1 discover=no
/interface vlan
add interface=br1 name=br1-vlan11 vlan-id=11
add interface=br1 name=br1-vlan12 vlan-id=12
add interface=br1 name=br1-vlan999 vlan-id=999
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=vlan11 ranges=10.214.11.100-10.214.11.199
add name=vlan12 ranges=10.214.11.100-10.214.11.199
add name=vlan13 ranges=10.214.11.100-10.214.11.199
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=br1 name=defconf
add address-pool=vlan11 disabled=no interface=br1-vlan11 name=vlan11
add address-pool=vlan12 disabled=no interface=br1-vlan12 name=vlan12
/interface bridge port
add bridge=br1 hw=no interface=eth2 pvid=11
add bridge=br1 hw=no interface=eth3
add bridge=br1 hw=no interface=eth4
add bridge=br1 hw=no interface=eth5
/interface bridge vlan
add bridge=br1 untagged=eth2 vlan-ids=11
/ip address
add address=192.168.88.1/24 comment=defconf interface=br1 network=192.168.88.0
add address=10.214.11.254/24 interface=br1-vlan11 network=10.214.11.0
add address=10.214.12.254/24 interface=br1-vlan12 network=10.214.12.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=eth1
/ip dhcp-server network
add address=10.214.11.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.11.254
add address=10.214.12.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.12.254
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface=eth1
/system package update
set channel=release-candidate
#error exporting /system routerboard mode-button
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
A packet capture shows STP frames and discovery frames from the relevant VLAN interface, in this case br-vlan11, but does not seem to forward other traffic. I'm unable to mac-telnet into the router despite allowing it on the br1-vlan11 interface. I cannot ping the IP address assigned to br-vlan11 despite seeing it in the CDP message in WireShark (both interface and IP).

I am seeing something very similar on a CRS210-8G-2S+ switch... CDP/LLDP passes just fine... I even get ARP in the right VLAN(s), but no dice when sending from the neighboring device on the same VLAN.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 8:46 am

Hallo!
After updating a RB922 with a Huawei ME909s-120 modem to 6.41RC16, the lte-interface doesn't switch in running mode. The status of the interface shows only one information: "Functionality == minimal", nothing else.
Is this a normal behavior in case of lte-passthrough or a bug?

regards
What was the previos version where it worked? Enable the LTE logging topic and check the log file. What Firmware version you have fro the modem?
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 10:02 am

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 5:03 pm

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
 
kd6icz
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Wed Jun 15, 2016 11:29 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 8:27 pm

I'm happy to see support for Sierra AirPrime 7750. That's a pretty old card. The MC7455 is the current "all US carrier / all US band" card.

Any chance it would be to difficult to add whatever parameters are necessary to support the MC7455? It would be the end all be all card for two or three years.

Sent from my XT1650 using Tapatalk
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 21, 2017 9:03 pm

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
So, after a bit of testing the solution was, that I have to do a usb power reset over CLI. Over Winbox it doesn't work and after the next reboot I have to handle the same procedure. I think there is a problem with the USB-power-reset after reboot in 6.41RC16. After a downgrade to 6.40.1 everything works fine.
The passthrough itself was working as expectet, but I can't set it on a VLAN, only physical interfaces are supported. Would it be possible to support Vlan-interfaces too?
  • 1
  • 2
  • 3
  • 4
  • 5
  • 12

Who is online

Users browsing this forum: No registered users and 7 guests