Community discussions

  • 1
  • 2
  • 3
  • 4
  • 5
  • 12
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 9:45 am

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
So, after a bit of testing the solution was, that I have to do a usb power reset over CLI. Over Winbox it doesn't work and after the next reboot I have to handle the same procedure. I think there is a problem with the USB-power-reset after reboot in 6.41RC16. After a downgrade to 6.40.1 everything works fine.
The passthrough itself was working as expectet, but I can't set it on a VLAN, only physical interfaces are supported. Would it be possible to support Vlan-interfaces too?
Have you tried to specify that init-delay?
What does it show in the log when you enable the lte logging?
It should support the Vlan interface as well - what error message did it show?
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 11:09 am

With 9 seconds init-delay the lte modem doesn't start. When the moden isn't running, I get no errors in the log. Only after a manual usb power reset it start working and also I can see messages in the log.
If I try to set a Vlan, there is no error message. But after a export I see that nothing has changed and sfp1 is still set for passthrough.
Today I will try it on my second device too.
 
User avatar
eworm
Member
Member
Posts: 358
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 12:49 pm

I am having issues with CAPsMAN on 6.41rc13... Looks like cap interfaces with CAPsMAN forwarding do not pass any traffic.
The issue persists with 6.41rc16... Just downgraded to 6.41rc11 and wireless is up and running.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
dcolli
just joined
Posts: 5
Joined: Mon Mar 12, 2012 4:08 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 3:05 pm

Bug with pppoe + ipv6 + dhcp6server + static

When static addresses are created in /ipv6 dhcp-server binding (server = all) it is placed in the pool (/ipv6 pool used) after the user disconnects the pppoe it is removed from the / ipv6 pool used, and after reconnection does not return the Address for /ipv6 pool used.

commands:

/ipv6 pool used print
/ipv6 dhcp-server binding make-static numbers=0
ipv6 dhcp-server binding set 0 server=all
/ipv6 pool used print
/ppp active remove 0
/ipv6 pool used print
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 4:30 pm

Working on a new RB750Gr3 (hex). I installed 6.41rc9 and I'm unable to get an access port working for a VLAN on the new VLAN aware bridges. A similar configuration is working on a RB750Gr3 running 6,41rc6.
  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.41rc9 (c) 1999-2017       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level

[admin@rtr1] > export
# aug/07/2017 13:27:40 by RouterOS 6.41rc9
# software id = 247N-DPAI
#
# model = RouterBOARD 750G r3
# serial number = xxxxxxxxxxxx
/interface bridge
add admin-mac=6C:3B:6B:bb:xx:yy auto-mac=no fast-forward=no igmp-snooping=no name=br1 vlan-filtering=yes
/interface ethernet
set [ find default-name=ether1 ] name=eth1
set [ find default-name=ether2 ] name=eth2
set [ find default-name=ether3 ] name=eth3
set [ find default-name=ether4 ] name=eth4
set [ find default-name=ether5 ] name=eth5
/ip neighbor discovery
set eth1 discover=no
/interface vlan
add interface=br1 name=br1-vlan11 vlan-id=11
add interface=br1 name=br1-vlan12 vlan-id=12
add interface=br1 name=br1-vlan999 vlan-id=999
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip hotspot profile
set [ find default=yes ] html-directory=flash/hotspot
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=vlan11 ranges=10.214.11.100-10.214.11.199
add name=vlan12 ranges=10.214.11.100-10.214.11.199
add name=vlan13 ranges=10.214.11.100-10.214.11.199
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=br1 name=defconf
add address-pool=vlan11 disabled=no interface=br1-vlan11 name=vlan11
add address-pool=vlan12 disabled=no interface=br1-vlan12 name=vlan12
/interface bridge port
add bridge=br1 hw=no interface=eth2 pvid=11
add bridge=br1 hw=no interface=eth3
add bridge=br1 hw=no interface=eth4
add bridge=br1 hw=no interface=eth5
/interface bridge vlan
add bridge=br1 untagged=eth2 vlan-ids=11
/ip address
add address=192.168.88.1/24 comment=defconf interface=br1 network=192.168.88.0
add address=10.214.11.254/24 interface=br1-vlan11 network=10.214.11.0
add address=10.214.12.254/24 interface=br1-vlan12 network=10.214.12.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=eth1
/ip dhcp-server network
add address=10.214.11.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.11.254
add address=10.214.12.0/24 dns-server=10.214.0.1 domain=123.local gateway=10.214.12.254
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router.lan
/ip firewall nat
add action=masquerade chain=srcnat ipsec-policy=out,none out-interface=eth1
/system package update
set channel=release-candidate
#error exporting /system routerboard mode-button
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=br1
add interface=br1-vlan11
A packet capture shows STP frames and discovery frames from the relevant VLAN interface, in this case br-vlan11, but does not seem to forward other traffic. I'm unable to mac-telnet into the router despite allowing it on the br1-vlan11 interface. I cannot ping the IP address assigned to br-vlan11 despite seeing it in the CDP message in WireShark (both interface and IP).

I am seeing something very similar on a CRS210-8G-2S+ switch... CDP/LLDP passes just fine... I even get ARP in the right VLAN(s), but no dice when sending from the neighboring device on the same VLAN.
Turns out I missed adding the VLAN as tagged to my bridge in /interface bridge vlan

If you're already doing that check the docs. I remember a model or two of CRS was unsupported with the new bridges initially. I think they have it rectified now though
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 22, 2017 6:58 pm

What's new in 6.41rc3 (2017-Jul-26 09:32):
*) ippool6 - try to assign desired prefix for client if prefix is not being already used;
@MikroTik - @strods

Multiple people have asked in this thread without a reply about this feature line. Specifically your users are requesting the ability to "hint" what they want to be assigned for both the network and host portion of an address. This can be seen in practice in OpenWRT as class hints (source: https://wiki.openwrt.org/doc/uci/network6) for the network hinting portion.

I've also placed a support case for clarification. It is #2017082222001255.

Threads (will link as I dig them back out):

viewtopic.php?f=2&t=120254&p=591415&hil ... nt#p591415
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 11:44 am

What's new in 6.41rc17 (2017-Aug-22 11:58):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) bridge - fixed "R" state for bridge interfaces on x86 and CHR installations (introduced in v6.41rc12);
*) capsman - added "vlan-mode=no-tag" option;
*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) ipsec - allow to specify "remote-peer" address as DNS name;
*) lcd - fixed unresponsive LCD (introduced in v6.41rc15);
*) lte - added Passthrough support (CLI only);
*) pppoe - fixed invalid PPPoE server or client after reboot or "interface" edit (introduced in v6.41rc9);
*) snmp - fixed bridge host requests on devices with multiple bridge interfaces;
*) winbox - added possibility to define "comment" for "/routing bgp network" entries;
*) winbox - do not show LCD menu for devices which does not have it;
*) www - fixed unresponsive Web services (introduced in v6.40);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 12:52 pm

I am having issues with CAPsMAN on 6.41rc13... Looks like cap interfaces with CAPsMAN forwarding do not pass any traffic.
The issue persists with 6.41rc16... Just downgraded to 6.41rc11 and wireless is up and running.
Please provide us more info on your setup and how to reproduce the problem as we tested locally and the CAPsMAN forwarding is working.
 
irghost
Member Candidate
Member Candidate
Posts: 277
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 12:55 pm

What's new in 6.41rc17 (2017-Aug-22 11:58):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) bridge - fixed "R" state for bridge interfaces on x86 and CHR installations (introduced in v6.41rc12);
*) capsman - added "vlan-mode=no-tag" option;
*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) ipsec - allow to specify "remote-peer" address as DNS name;
*) lcd - fixed unresponsive LCD (introduced in v6.41rc15);
*) lte - added Passthrough support (CLI only);
*) pppoe - fixed invalid PPPoE server or client after reboot or "interface" edit (introduced in v6.41rc9);
*) snmp - fixed bridge host requests on devices with multiple bridge interfaces;
*) winbox - added possibility to define "comment" for "/routing bgp network" entries;
*) winbox - do not show LCD menu for devices which does not have it;
*) www - fixed unresponsive Web services (introduced in v6.40);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
SXT LTE?
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 1:00 pm

irghost - What is the question about SXT LTE? Are you referring to Passthrough support? if you do, then take a look at this list:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
 
Siona
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Thu Jan 29, 2015 11:56 am

Re: RE: Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 1:02 pm

irghost - What is the question about SXT LTE? Are you referring to Passthrough support? if you do, then take a look at this list:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
Is it possible to add this future in future release?
 
irghost
Member Candidate
Member Candidate
Posts: 277
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 1:11 pm

irghost - What is the question about SXT LTE? Are you referring to Passthrough support? if you do, then take a look at this list:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
in last 3 release
we have
*) lte - added Passthrough support (CLI only);
but why still no support For most important LTE device "SXT LTE"
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 1:45 pm

Currently SXT LTE does not support this functionality.

If you see the same changelog entry in multiple rc versions then it is a new feature which is being implemented and changelog entry is simply moved up on each rc when additional work on it has been done.
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 4:32 pm

@ Mikrotik Support
*) pppoe - fixed invalid PPPoE server or client after reboot or "interface" edit (introduced in v6.41rc9);
what this suppose to fix?
because even after this RC all my pppoe don't show up either
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 4:37 pm

raffav - What do you mean with "don`t show up either"? Be more specific. This fixed as written in changelog "invalid PPPoE server or client after reboot or "interface" edit". Did you upgrade device and you see invalid (red) PPPoE server or client interface?
 
raffav
Member Candidate
Member Candidate
Posts: 279
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 4:51 pm

raffav - What do you mean with "don`t show up either"? Be more specific. This fixed as written in changelog "invalid PPPoE server or client after reboot or "interface" edit". Did you upgrade device and you see invalid (red) PPPoE server or client interface?
i thought that fix applied to my case too ( pppoe interfaces disappears after reboot/upgrade)

but never mind, i just saw answer (Ticket#2017080722001328) on my mail.
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 23, 2017 11:19 pm

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
So, after a bit of testing the solution was, that I have to do a usb power reset over CLI. Over Winbox it doesn't work and after the next reboot I have to handle the same procedure. I think there is a problem with the USB-power-reset after reboot in 6.41RC16. After a downgrade to 6.40.1 everything works fine.
The passthrough itself was working as expectet, but I can't set it on a VLAN, only physical interfaces are supported. Would it be possible to support Vlan-interfaces too?
Have you tried to specify that init-delay?
What does it show in the log when you enable the lte logging?
It should support the Vlan interface as well - what error message did it show?

With RC17 I was able to set a Vlan for passthrough but the LTE-Modem doesn't start with 0,3,6 and 9 seconds init-delay. Also a total power-reset with a duration of more than 1 minute, didn't solve the problem. After a munual usb power-reset with a duration of 1 second, the LTE-interface starts. Tested with 2 RB922UAGS-5HPacT (current Firmware 3,41) with Huawei ME909s-120. With 3.40.1 or older I never had such problems (init-delay 1s)
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 24, 2017 8:23 am

PPPoE failed again in new RC(
 
dancsa
just joined
Posts: 6
Joined: Mon Jul 10, 2017 9:46 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 24, 2017 12:19 pm

We've bought several CRS326 for our network expansion plan, as we had no major issues with MT routers. As I see the future is the new offloaded bridge feature, so I tried the RC line as the 6.41 will be probably released before these switches become prod.

As for switching between ports, they work, this bridge configuration looks more comfortable than the old switch menu (which i unfamiliar).
But no mater how i tried I couldn't bring up packages to the "router", and couldn't find any pointers how should i do that. How can i create a vlan interface, for example management purpose.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 24, 2017 12:59 pm

What's new in 6.41rc18 (2017-Aug-24 07:52):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) bridge - changed "Host" and "MDB" table column order;
*) ipv6 - add dynamic "/ip dns" server address from RA when RA is permitted by configuration;
*) log - optimized "poe-out" logging topic logs;
*) lte - added Passthrough support (CLI only);
*) poe-out - fixed router reboot after "poe-out-status" changes;
*) userman - fixed "limitation" and "profile-limitation" update;
*) webfig - allow to open table entry even if table is not sorted by # (introduced in v6.40);
*) webfig - allow to unset "rate-limit" for DHCP leases;
*) winbox - added "notrack-chain" setting to IPSec peers;
*) winbox - do not show FAN related information under "/system health" menu for devices which does not have it;
*) winbox - fixed ARP table update after entry changes state to incomplete;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 24, 2017 5:30 pm

What's new in 6.41rc18 (2017-Aug-24 07:52):

*) ipv6 - add dynamic "/ip dns" server address from RA when RA is permitted by configuration;
Almost there, now allow us to control the DNS server distributed in RA to enable our IPv6 clients to use the local MikroTik resolver cache.

Add an option to /ipv6 nd to specify the DNS servers!
 
buzzdee
newbie
Posts: 35
Joined: Mon Apr 22, 2013 1:22 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Aug 25, 2017 6:49 pm

*) ipsec - allow to specify remote peer address as DNS name (CLI only);
does this mean ipsec tunnels can be established between 2 sites with dynamic ip addresses, so I can get rid of the additional L2TP Tunnel?
In road warrior setups, yes.
I tried that setup, mikrotik routers on both ends. Router 1 uses a dns-name as peer address, router 2 is set to 0.0.0.0/0. If I don't want to use any tunneling, I still have to specify the SA Dst. Address in router 1's policy-action. Are there plans to also make the use of dns-names possible in SA Address fields of policies?

Thanks,

BuzzDee

Edit: Seems, I'm not alone - see
viewtopic.php?f=2&t=124502&p=612878&hil ... ns#p612878
viewtopic.php?f=1&t=123534&p=610966&hil ... ns#p610966
Last edited by buzzdee on Mon Aug 28, 2017 4:34 pm, edited 1 time in total.
 
User avatar
eworm
Member
Member
Posts: 358
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 28, 2017 3:13 pm

I am having issues with CAPsMAN on 6.41rc13... Looks like cap interfaces with CAPsMAN forwarding do not pass any traffic.
The issue persists with 6.41rc16... Just downgraded to 6.41rc11 and wireless is up and running.
Please provide us more info on your setup and how to reproduce the problem as we tested locally and the CAPsMAN forwarding is working.
Opened Ticket#2017082822000816 with more details.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 28, 2017 3:22 pm

Hallo!
It is/was running perfect with 6.40.1 since it was released und before with 6.39.2. The Firmware of the modem is 11.617.06.00.00. To activate the logging is only with RC helpful, isn't it? I will try it once more in the evening.
We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
So, after a bit of testing the solution was, that I have to do a usb power reset over CLI. Over Winbox it doesn't work and after the next reboot I have to handle the same procedure. I think there is a problem with the USB-power-reset after reboot in 6.41RC16. After a downgrade to 6.40.1 everything works fine.
The passthrough itself was working as expectet, but I can't set it on a VLAN, only physical interfaces are supported. Would it be possible to support Vlan-interfaces too?
Have you tried to specify that init-delay?
What does it show in the log when you enable the lte logging?
It should support the Vlan interface as well - what error message did it show?

With RC17 I was able to set a Vlan for passthrough but the LTE-Modem doesn't start with 0,3,6 and 9 seconds init-delay. Also a total power-reset with a duration of more than 1 minute, didn't solve the problem. After a munual usb power-reset with a duration of 1 second, the LTE-interface starts. Tested with 2 RB922UAGS-5HPacT (current Firmware 3,41) with Huawei ME909s-120. With 3.40.1 or older I never had such problems (init-delay 1s)
Could you make a support output file after the reboot when the interface doesn't work and send that to support@mikrotik.com?
The problem also happens when you are not using the passthrough mode?
 
w0lt
Member
Member
Posts: 480
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 28, 2017 4:47 pm

I've been to testing IGMP-Snooping using ROS 6.41 rc18, and have found the multicast device (and group) I'm listening to seems to time out after about 5 minutes. I was working just fine up till then with a correct entry in the "Bridge MDB" section. Do you think that rc18 has a multicast time-out issue? Seems to work just fine other than that. :-)

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
klaus007
just joined
Posts: 16
Joined: Thu Aug 17, 2017 1:11 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Aug 28, 2017 6:20 pm

We tested and 909s-120 works with such firmware in RouterOS6.41rc16
Try to specify the init-delay in the System Routerboard settings to 9s and then reboot the board.
Also check if it works when you do a usb power reset option.
So, after a bit of testing the solution was, that I have to do a usb power reset over CLI. Over Winbox it doesn't work and after the next reboot I have to handle the same procedure. I think there is a problem with the USB-power-reset after reboot in 6.41RC16. After a downgrade to 6.40.1 everything works fine.
The passthrough itself was working as expectet, but I can't set it on a VLAN, only physical interfaces are supported. Would it be possible to support Vlan-interfaces too?
Have you tried to specify that init-delay?
What does it show in the log when you enable the lte logging?
It should support the Vlan interface as well - what error message did it show?

With RC17 I was able to set a Vlan for passthrough but the LTE-Modem doesn't start with 0,3,6 and 9 seconds init-delay. Also a total power-reset with a duration of more than 1 minute, didn't solve the problem. After a munual usb power-reset with a duration of 1 second, the LTE-interface starts. Tested with 2 RB922UAGS-5HPacT (current Firmware 3,41) with Huawei ME909s-120. With 3.40.1 or older I never had such problems (init-delay 1s)
Could you make a support output file after the reboot when the interface doesn't work and send that to support@mikrotik.com?
The problem also happens when you are not using the passthrough mode?

Hallo Uldis!

I have sent you the support.rif.
At the moment I have fixed it with a script after startup an a delay of 10s (It was disabled for the support-file).
Yes, the problem is still there without passthrough.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 11:16 am

What's new in 6.41rc20 (2017-Aug-29 06:41):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering
!) switch - "master-port" conversion into a bridge with hardware offload "hw" option;
https://wiki.mikrotik.com/wiki/Manual:S ... Offloading
!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx;
*) bridge - fixed "fast-forward" counters;
*) bridge - implemented software based "igmp-snooping";
*) bridge - implemented software based MSTP;
*) bridge - removed "master-port" parameter;
*) dhcpv6 client - added IAID check in reply;
*) dhcpv6-client - fixed IA check on solicit when "raoud-commit" is enabled;
*) dhcpv6-server - do not release address of static binding from pool after server removal;
*) export - fixed export for PoE-OUT related settings;
*) ipsec - kill PH1 on "mode-config" address failure;
*) led - fixed RB711UA ether1 LED (introduced in v6.38rc16);
*) lte - added Passthrough support (CLI only);
*) lte - integrated IP address acquisition without DHCP client for wAP LTE kit-US;
*) userman - fixed "limitation" and "profile-limitation" update;
*) userman - fixed CoA packet processing after changes in "/tool user-manager router" configuration;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 12:25 pm

What's the difference between /interface ethernet switch vlan/ports and the bridge VLAN implementation?
What is the correct way to create a switch with multiple VLANs (tagged and untagged) with a management IP on a vlan?
 
ivicask
Member Candidate
Member Candidate
Posts: 230
Joined: Tue Jul 07, 2015 2:40 pm
Location: Croatia, Zagreb

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 1:28 pm

So how is this new bridge HW offload supposed to work?I upgraded my WAP AC and than I printed my bridges after upgrade and they all say hw=no, tried creating new bridge, still says no.
Also I see there is new option Bridge Fast forward, what does it do?I tried ticking it again i see no differences anywhere regarding CPU load or anything else.
Last edited by ivicask on Tue Aug 29, 2017 1:36 pm, edited 1 time in total.
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 1:35 pm

How would one realize inter-vlan routing or generally vlan interfaces with the new bridge implementation?
Can't find anything on this except some emtpy placeholder topic in the Wiki.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 2:30 pm

How would one realize inter-vlan routing or generally vlan interfaces with the new bridge implementation?
Can't find anything on this except some emtpy placeholder topic in the Wiki.
Yes the wiki needs it documented formally! In the meantime:

Add your VLAN interfaces and set their interface as your bridge. Apply your IP and DHCP servers to the VLAN interfaces. Then go into /interface bridge vlan and add your VLANs and be sure to tag the bridge interface.

So it would look something like this if you were to make a brand new bridge, add VLANs 11 and 12 (10.99.11.0/24 and 10.99.12.0/24), create a VLAN 11 access port on ether2, create a VLAN 12 access port on ether3 and a trunk on ether4 with VLAN 1 as the native VLAN and allow VLANs 11 and 12 to be tagged.
/interface bridge add vlan-filtering=no name=br1

/interface vlan add interface=br1 vlan-id=11 name=br1-vlan11
/interface vlan add interface=br1 vlan-id=12 name=br1-vlan12

/ip address add interface=br-vlan11 address=10.99.11.254/24
/ip address add interface=br-vlan11 address=10.99.12.254/24

/interface bridge vlan add bridge=br1 vlan-ids=11 tagged=br1,ether4 untagged=ether2
/interface bridge vlan add bridge=br1 vlan-ids=12 tagged=br1,ether4 untagged=ether3

/interface bridge port add bridge=br1 interface=ether2 pvid=11 frame-types=admit-only-untagged-and-priority-tagged
/interface bridge port add bridge=br1 interface=ether3 pvid=12 frame-types=admit-only-untagged-and-priority-tagged
/interface bridge port add bridge=br1 interface=ether4 pvid=1 frame-types=admit-all

/interface bridge set [ find where name=br1 ] vlan-filtering=yes
Ker-blamo, you have a 2 VLAN network with an access port in each and a trunk port on ether4 to uplink to your network.
Last edited by idlemind on Tue Aug 29, 2017 4:08 pm, edited 2 times in total.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 3:30 pm

What's new in 6.41rc20 (2017-Aug-29 06:41):
uuuu, winbox support for new bridge implementation....
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 3:36 pm

What's new in 6.41rc20 (2017-Aug-29 06:41):
*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx;
Strods, is the CRS1xx/2xx now able to do the new bridge based VLANs without mucking around in the Ethernet switch menu? I know in the first releases it was indicated by MikroTik posts that this was required at the time. I don't own one of these types of devices so I can't test myself but I do see posts in other threads and would like to be able to help those users if possible and be as consistent as possible in my advice. I do love the new bridge implementation so far though. Good work.
 
andriys
Forum Guru
Forum Guru
Posts: 1116
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 3:42 pm

Also I see there is new option Bridge Fast forward, what does it do?
That is a special case of bridge FastPath that only works when you have exactly two interfaces in a bridge. My understanding is that this option has nothing to do with bridge HW offloading. And it's not that new, it first appeared in 6.39.
 
w0lt
Member
Member
Posts: 480
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 5:13 pm

v6.41rc20 has some really cool stuff. I'm still having a problem with IGMP-Snooping where it drops an ACTIVE multicast group (after about 4-5 Min.). I'm not sure why it is doing this and to remedy it, I have to deactivate IGMP-Snooping and redeploy PIM (v6.40.2). I can't seem to find the ability to list the "Master Port" under Interface/Ethernet anymore. This might have been on purpose, just asking. I believe you folks are coming along nicely on IGMP-Snooping though it needs some tweaks (time will tell, right?). Would the ability to "Query" for IGMP Groups help in my case? Just spit-balling there.. :-)

Thanks,

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
biatche
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Oct 13, 2015 6:50 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Aug 29, 2017 5:14 pm

@andirys and mikrotik
*) bridge - implemented software based MSTP;
thank you for making this happen
 
sindudas
newbie
Posts: 28
Joined: Thu Aug 16, 2012 2:59 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 1:10 pm

@andirys and mikrotik
*) bridge - implemented software based MSTP;
thank you for making this happen
+1 :-P
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 1:52 pm

...snip...
Ker-blamo, you have a 2 VLAN network with an access port in each and a trunk port on ether4 to uplink to your network.
Thanks, will give it a shot. :-)
 
User avatar
boldsuck
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Sun Sep 01, 2013 1:07 am
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 1:56 pm

- ipv6 - fixed IPv6 address request from pool (introduced in 6.41rc1);

RB2011UAS v6.41rc1 - rc20
IPv6 address assignment is broken :-( State is 'invalid'


Just for INFO:
MikroTik have managed to reproduce the problem. The error only occurs with me and a few others. MikroTik are working on it. But I fear this will remain an eternal bug.
:wink: I can live with the router not to reboot.

Since 6.41rc13 the DHCPv6 client has no more prefix. The IPv6 address could therefore not be assigned manually. Since 6.41rc20 gets the DHCPv6 client again a prefix which I then manually assigned.

I can not test the feature with the dynamic subprefix.
- Ippool6 - try to assign the requested prefix for client if prefix is not being already used;
╰_╯ Ciao Marco!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 2:10 pm

Seems that I managed to reproduce the problem with invalid IPv6 address on rc version. We will try to fix this as soon as possible.
 
becs
MikroTik Support
MikroTik Support
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 5:43 pm

How would one realize inter-vlan routing or generally vlan interfaces with the new bridge implementation?
Can't find anything on this except some emtpy placeholder topic in the Wiki.
The example "InterVLAN Routing by Bridge" has been updated:
https://wiki.mikrotik.com/wiki/Manual:I ... _Bridge.29
 
timberwolf
Member Candidate
Member Candidate
Posts: 274
Joined: Mon Apr 25, 2011 12:08 pm
Location: Germany

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 6:13 pm

The example "InterVLAN Routing by Bridge" has been updated:
https://wiki.mikrotik.com/wiki/Manual:I ... _Bridge.29
Thanks!
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Aug 30, 2017 9:41 pm

How about HW switching if STP and Layer3 Routing is needed? (bridge vlan disables HW)
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 31, 2017 7:17 pm

How about HW switching if STP and Layer3 Routing is needed? (bridge vlan disables HW)
Patrick, the new bridge automatically toggles HW support as you enable or disable features. This doesn't require you to manually switch between /interface Ethernet switch and /interface bridge when your feature need changes or you work on different models of hardware.

https://wiki.mikrotik.com/wiki/Manual:S ... Offloading

If you scroll down you'll see a table of each switches capabilities. Depending on which product you have you'll only get certain capabilities.

It's important to note that regardless of switch chip / hardware offloading, layer 3 interactions like inter-vlan routing have always been performed in CPU (per a MikroTik support case I opened).
 
jondavy
Member Candidate
Member Candidate
Posts: 124
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 31, 2017 8:30 pm

What's the difference between /interface ethernet switch vlan/ports and the bridge VLAN implementation?
What is the correct way to create a switch with multiple VLANs (tagged and untagged) with a management IP on a vlan?
I believe that the new implementation inside bridge of tag and tag was very simple to understand,
but for compatibility and understanding issues could be created dynamic interfaces VLAN and bridges for tagging or untagging vlans into interfaces menu
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 31, 2017 8:52 pm

I'm aware of that. VLAN aware bridges disables HW offload on small switches (RB750GL etc). I'd like to have routing (this will be in CPU) AND switching (in hardware) on the same device as it was possible before 6.41rc. STP is needed too. I don't see a way how to solve this.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Thu Aug 31, 2017 8:56 pm

I'm aware of that. VLAN aware bridges disables HW offload on small switches (RB750GL etc). I'd like to have routing (this will be in CPU) AND switching (in hardware) on the same device as it was possible before 6.41rc. STP is needed too. I don't see a way how to solve this.
If the underlying hardware supports it I imagine the new bridge implementation will catch up. Just watch the release notes for updates.
 
User avatar
NoXy
just joined
Posts: 15
Joined: Thu Sep 15, 2005 11:07 am
Location: Hungary

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 12:12 pm

InterVLAN routing with CRS326 (ROS 6.41rc20) works well.
I have a setup like this:
- ether1 (routed, DHCP client, Internet access)
- other ports in a bridge, separated to two different vlans (ID:2,3)
- each vlan has DHCP-Server, address etc.

I see poor bandwidth (max 25-40Mbps) between host connected to any inside vlan and Internet. Do you guys have same issue?
Ports are working in offload mode, hosts on same vlan can communicate wirespeed, with few precentage of CPU usage, which shows me that hw-offload is working well.

Is it a known problem?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 1:42 pm

Version 6.40.3 has been released:
viewtopic.php?f=21&t=125163
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 1:59 pm

What's new in 6.41rc21 (2017-Sep-01 08:56):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

!) bridge - implemented software based vlan-aware bridges;
https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering
!) switch - "master-port" conversion into a bridge with hardware offload "hw" option;
https://wiki.mikrotik.com/wiki/Manual:S ... Offloading
!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) arp - properly update dynamic ARP entries after interface related changes;
*) bridge - added initial support for hardware "igmp-snooping" on CRS1xx/2xx;
*) bridge - implemented software based "igmp-snooping";
*) bridge - implemented software based MSTP;
*) bridge - removed "master-port" parameter;
*) ike1 - remove PH1 and PH2 when "mode-config" exchange fails;
*) interface - added "/interface reset-counters" command (CLI only);
*) ipsec - added DH groups 19, 20 and 21 support for phase1 and phase2 (CLI only);
*) lcd - fixed "flip-screen=yes" state after reboot;
*) lte - added "/interface lte apn" menu (Passthrough requires reconfiguration) (CLI only);
*) lte - added Yota non-configurable modem support;
*) lte - fixed mode initialization after reboot;
*) sniffer - fixed VLAN tag reporting for TX packets (introduced 6.41rc14);
*) tile - improved reliability on MPLS package processing;
*) wireless - pass interface MAC address in Sniffer TZSP frames;
*) wireless - updated United Kingdom regulatory domain information;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
  • 1
  • 2
  • 3
  • 4
  • 5
  • 12

Who is online

Users browsing this forum: No registered users and 12 guests