Community discussions

 
gtj
Member Candidate
Member Candidate
Posts: 119
Joined: Thu Apr 30, 2015 2:52 am
Location: Colorado US

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 4:23 pm

I tried to upgrade a lab CRS-226-24P-2S+ from 6.40.1 to 6.41.rc18 and had major issues.

The switch is set up as a simple dumb switch, no vlans except the default and all ports switched. After the upgrade I had no IP connectivity to the switch and no connectivity through the switch. The switch was emitting LLDP since the upstream switch (also a CRS226 running 6.40.1) was showing it in the neighbors list but that's it. No mac-telnet either. Hooked up serial port and looked at the config. It "looked" correct (I have a supout which I'll send to support).

Now here's where the fun starts...
The switches are connected via SFP+ direct attach cables. After the upgrade, I lost connectivity to the UPSTREAM switch.
If I unplug the direct attach cable between the 2 switches, I get connectivity back to the upstream switch.
If I plug it back in again, I lose it. If I plug it in and change the bridge protocol on the upgraded switch to "none", I get connectivity back to the upstream switch but still no connectivity to the upgraded switch. After about an hour of playing with different settings, I decided to reset the config on the upgraded switch thinking that maybe the conversion process had an issue. No help.

Finally I did a reset with no default config and set the switch up manually by creating the bridge and adding the ports. YAY! It worked...
Except, I still have an SFP problem, but different. I no longer lose connectivity to the upstream switch but I still can't pass any traffic to the upgraded switch via that SFP port. With the 2 switches connected via ether1, no problem (I should have tried that earlier actually). Also, a Quanta 10G switch that's downstream from the upgraded switch is fine using the upgraded switch's SFP ports.

HMMM. As I'm typing this, I just heard the upgraded switch beep and sure enough, it's rebooting.

Anyway, I'm actually going to downgrade the switch back to 6.40.1 and retry the upgrade again to see if the connectivity issue was solely related to the SFP port or whether there was really a problem with the converted or default config.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 5:08 pm

Unfortunately, currently SXT LTE does not support passthrough mode.
irghost - What is the question about SXT LTE? Are you referring to Passthrough support? if you do, then take a look at this list:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
Is there a plan for this or even and ETA? SXT LTE is the ultimate platform to get this feature.
 
w0lt
Member
Member
Posts: 480
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 5:34 pm

v6.41rc20 has some really cool stuff. I'm still having a problem with IGMP-Snooping where it drops an ACTIVE multicast group (after about 4-5 Min.). I'm not sure why it is doing this and to remedy it, I have to deactivate IGMP-Snooping and redeploy PIM (v6.40.2). I can't seem to find the ability to list the "Master Port" under Interface/Ethernet anymore. This might have been on purpose, just asking. I believe you folks are coming along nicely on IGMP-Snooping though it needs some tweaks (time will tell, right?). Would the ability to "Query" for IGMP Groups help in my case? Just spit-balling there.. :-)

Thanks,

-tp
Still having the same problem with v6.41 rc21

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
irghost
Member Candidate
Member Candidate
Posts: 274
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 01, 2017 6:01 pm

Unfortunately, currently SXT LTE does not support passthrough mode.
irghost - What is the question about SXT LTE? Are you referring to Passthrough support? if you do, then take a look at this list:
https://wiki.mikrotik.com/wiki/Supporte ... and_modems
Is there a plan for this or even and ETA? SXT LTE is the ultimate platform to get this feature.
+1 For SXT LTE
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 04, 2017 2:45 pm

What's new in 6.41rc23 (2017-Sep-04 09:07):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) address - show warning on IPv6 address when acquire from pool has failed;
*) bridge - fixed connectivity issues when there are multiple VLAN interfaces on bridge;
*) bridge - show bridge interface local addresses in the host table;
*) crs317 - added initial support for HW offloaded MPLS forwarding;
*) dhcp - fixed DHCP services failing after reboot when DHCP option was used;
*) dhcpv4-client - allow to use DUID for client ID;
*) dhcpv6-client - require pool name to be unique;
*) routerboard - fixed "/system routerboard upgrade" for CRS212-8G-4S;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
TmH
just joined
Posts: 1
Joined: Mon Sep 04, 2017 9:19 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 04, 2017 9:26 pm

*) bridge - fixed connectivity issues when there are multiple VLAN interfaces on bridge;
.
I gave the new rc a go because of the multiple VLAN option, however after upgrading from the previous rc21 now the link is not stable anymore.
Every few minutes the link goes down and comes up again (from the mikrotik log).
Other than the new rc no changes were made to hardware [mikrotik hAP ac, RB962UiGS-5HacT2HnT] or settings. (same config etc)

Config used is blank, one bridge using all ports no vlans configured, dhcp-client on bridge interface, no firewall rules
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1807
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 3:53 pm

DANGER

If you are running CAPSMAN avoid 6.41rc23

6.41rc23 breaks CAP communication with CAPSMAN, at least when using a tunelled datapath. Downgrading to 6.41rc20 does not fix the problem :(

Mikrotik support are aware of this issue.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
anuser
Member
Member
Posts: 352
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 5:01 pm

DANGER

If you are running CAPSMAN avoid 6.41rc23

6.41rc23 breaks CAP communication with CAPSMAN, at least when using a tunelled datapath. Downgrading to 6.41rc20 does not fix the problem :(

Mikrotik support are aware of this issue.
Too late. My users complain that they are connected to the wifi, but there´s hardly any or only few traffic is getting through the connection.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 6:05 pm

You can download prior versions of the RC by manually adjusting the URL from the download page if you wanted to revert back to an RC that it still works at for you to retain the new bridge.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 6:07 pm

DANGER

If you are running CAPSMAN avoid 6.41rc23

6.41rc23 breaks CAP communication with CAPSMAN, at least when using a tunelled datapath. Downgrading to 6.41rc20 does not fix the problem :(

Mikrotik support are aware of this issue.
Too late. My users complain that they are connected to the wifi, but there´s hardly any or only few traffic is getting through the connection.
How are you connecting the CAP to the CAPsMAN? Are you using Local-forwarding or CAPsMAN forwarding? Are you using VLAN in our setup?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 6:09 pm

You can download prior versions of the RC by manually adjusting the URL from the download page if you wanted to revert back to an RC that it still works at for you to retain the new bridge.
There is bug that after the downgrade from the newest RC you need to do a soft reboot of the board as the dhcp-client doesn't start in the first boot. Powercycle will not help, you need to do a sift reboot.
 
stucki
just joined
Posts: 19
Joined: Sun Apr 16, 2017 3:57 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 7:44 pm

How many troubles will come with V8?
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1807
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 05, 2017 10:54 pm

How are you connecting the CAP to the CAPsMAN? Are you using Local-forwarding or CAPsMAN forwarding? Are you using VLAN in our setup?
Hi Uldis, it is Layer3 with CAPsMAN forwarding.

Even downgrading to the previously working 6.41rc20 through Package/Downgrade, the problem still remains :(
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
anuser
Member
Member
Posts: 352
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 06, 2017 7:57 am

There is bug that after the downgrade from the newest RC you need to do a soft reboot of the board as the dhcp-client doesn't start in the first boot. Powercycle will not help, you need to do a sift reboot.
Well, it doesn't matter what older version I used. I downgraded and then "telnet-mac" into the access point to add an dhcp-client interface which took ~ 30 seconds to be added. After a reboot the access points worked again (I went back to 6.40.3).
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 06, 2017 9:31 am

nz_monkey, are you using VLAN interfaces and Bridge interfaces as in v6.41RC versions there are lot of changes to the Bridge implementation that could cause some problem.
 
hzdrus
newbie
Posts: 36
Joined: Mon May 14, 2012 3:58 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 06, 2017 11:06 am

*) crs317 - added initial support for HW offloaded MPLS forwarding;
Can you elaborate on this feature? It applies solely when acting as a transit P router or when encapsulating/decapsulating l2circuit also?

P.S. Congrats on the work to implement multicast snooping. Looking forward to a stable release.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5893
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 06, 2017 2:53 pm

@hzdrus currently only as a P router.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 9:42 am

What's new in 6.41rc26 (2017-Sep-07 13:26):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) chr - added KVM memory balloon support;
*) chr - added suspend support;
*) crs1xx/2xx - fixed 1 Gbps forced mode for several SFP modules;
*) crs317 - added initial support for HW offloaded MPLS forwarding;
*) dhcp - fixed unresponsive DHCP service caused by inability to read not set RAW options;
*) e-mail - auto complete file name on "file" parameter (introduced in v6.40);
*) eoip - made L2MTU parameter read-only;
*) hotspot - fixed missing "/ip hotspot server profile" if invalid "dns-name" was specified;
*) lte - added Passthrough support (CLI only);
*) lte - added support for ZTE ME3630 E1C;
*) lte - fixed mode initialization after reboot;
*) ppp - fixed missing PPP client interface after reboot (introduced in v6.41rc);
*) rb931-2nd - fixed startup problems (requires additional reboot after upgrade);
*) userman - fixed unresponsive RADIUS server (introduced in v6.40.3);
*) webfig - improved reliability of login process;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
irghost
Member Candidate
Member Candidate
Posts: 274
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 11:39 am

What's new in 6.41rc26 (2017-Sep-07 13:26):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

!) bridge - general development of hw-offload bridge implementation (introduced in v6.40rc36);
*) chr - added KVM memory balloon support;
*) chr - added suspend support;
*) crs1xx/2xx - fixed 1 Gbps forced mode for several SFP modules;
*) crs317 - added initial support for HW offloaded MPLS forwarding;
*) dhcp - fixed unresponsive DHCP service caused by inability to read not set RAW options;
*) e-mail - auto complete file name on "file" parameter (introduced in v6.40);
*) eoip - made L2MTU parameter read-only;
*) hotspot - fixed missing "/ip hotspot server profile" if invalid "dns-name" was specified;
*) lte - added Passthrough support (CLI only);
*) lte - added support for ZTE ME3630 E1C;
*) lte - fixed mode initialization after reboot;
*) ppp - fixed missing PPP client interface after reboot (introduced in v6.41rc);
*) rb931-2nd - fixed startup problems (requires additional reboot after upgrade);
*) userman - fixed unresponsive RADIUS server (introduced in v6.40.3);
*) webfig - improved reliability of login process;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
is there any news about SXT LTE?
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
HasanAlawlaki
just joined
Posts: 3
Joined: Wed Sep 06, 2017 1:18 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 2:40 pm

In this vertion ..!

What about netcut and ip scanner for who using hotspot and not managed switch with ubnt AP's ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 2:56 pm

is there any news about SXT LTE?
Your question was already answered!
Unfortunately, currently SXT LTE does not support passthrough mode.
What about netcut and ip scanner for who using hotspot and not managed switch with ubnt AP's ?
Sorry, I don't understand, what are you talking about?
No answer to your question? How to write posts
 
HasanAlawlaki
just joined
Posts: 3
Joined: Wed Sep 06, 2017 1:18 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 4:05 pm

Sorry i mean


The netcut program and another ip scanner can we control and block them by this new bridge features ?
 
irghost
Member Candidate
Member Candidate
Posts: 274
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 08, 2017 4:29 pm

is there any news about SXT LTE?
Your question was already answered!
Unfortunately, currently SXT LTE does not support passthrough mode.
What about netcut and ip scanner for who using hotspot and not managed switch with ubnt AP's ?
Sorry, I don't understand, what are you talking about?
Does SXT LTE Support passthrough in this version?
the answer is "NO"
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1154
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Sep 09, 2017 7:05 pm

Could you please add Address List to the Queue module.
In firewall you can use Address List to make more flexible rules.
In Queue and Simple Queue you can only use IP or range of IP.
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
diasem
just joined
Posts: 5
Joined: Tue Dec 08, 2015 4:15 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Sat Sep 09, 2017 8:49 pm

Strods Please include dns resolution on interface torch.
 
cXXcoder
just joined
Posts: 1
Joined: Mon Sep 11, 2017 5:23 am

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 11, 2017 5:37 am

What's new in 6.41rc6 (2017-Aug-01 11:30):
[...]
*) ppp - added support for Sierra MC7750, Verizon USB730L;
[...]
For the Verizon USB730L / Novatel Global Mode USB730L, would it work if plugged into USB slot of the RB750UPr2? If not, which MikroTik routers compatible? And if yes, please point me to the relevant chapters/sections of documentation, or tutorials?

Please forgive my ignorance: I do software, not networks. :-(

Thank you!
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 11, 2017 4:15 pm

is there any news about SXT LTE?
Your question was already answered!
Unfortunately, currently SXT LTE does not support passthrough mode.
Normis could you Elaborate.
Your answer and Wiki is ambiguous:
Saying It's not supported and it can not be done due to hardware limitations.
OR
It is currently not supported, it can be done but we have not yet made a decision If or When?.

Yours J
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 11, 2017 4:18 pm

Passthrough is not currently supported on SXT LTE and we do not have plans to implement such functionality in near future.
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 11, 2017 4:46 pm

Passthrough is not currently supported on SXT LTE and we do not have plans to implement such functionality in near future.
strods, breaking hearts on a Monday. Love it.
 
Siona
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Thu Jan 29, 2015 11:56 am

Re: RE: Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 11, 2017 5:00 pm

Passthrough is not currently supported on SXT LTE and we do not have plans to implement such functionality in near future.
Why? It would be really nice to have this functionality...
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 12, 2017 2:24 pm

What's new in 6.41rc28 (2017-Sep-11 12:37):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) console - do not stop "/certificate sign" process if console times out in 1 minute;
*) crs317 - added L2MTU support;
*) crs3xx - added port ingress and egress rate limiting;
*) log - added "bridge" topic;
*) lte - added Passthrough support (CLI only);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 12, 2017 3:01 pm

Passthrough is not currently supported on SXT LTE and we do not have plans to implement such functionality in near future.
Thanks for the elaboration.

Looking at the SXT LTE device it is the perfect fit for this function. We will buy many more of these units when this is available.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 13, 2017 1:51 pm

Got my first Batch of CRS317-1G-16S+ 's unpacking the first and trying out this test version.

Connected Copper (1g) and startet winbox clearing conf. Looking around and tried to change l2mtu.

/interface ethernet set l2mtu=10000 numbers=1,2,3,4,5,6,7,8,9,10,11,12,13,14,15

Boom ether1 stoped working (interface nr 0) the switch rebooted and didn't let me in again over winbox.
serialport connect reset conf and back in buissnesss.

I did notice that ether1 is connected to the same switch chip (swtich1) and perhaps this is the wrong way to change mtu. But at the same if I want 10K frames on the sfpports and no switch connectivity to the ether1 how is this accomplished with the new implementation. is there a manual for this new implementation or some pointers to get our heads round to test it properly..
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Wed Sep 13, 2017 2:06 pm

JimmyNyholm - Did this happen when you used 6.41rc28?
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 15, 2017 11:24 am

JimmyNyholm - Did this happen when you used 6.41rc28?
Yes!

admin@MikroTik] > system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-arm 6.41rc28
1 system 6.41rc28
2 X ipv6 6.41rc28
3 X wireless 6.41rc28
4 X hotspot 6.41rc28
5 X dhcp 6.41rc28
6 mpls 6.41rc28
7 routing 6.41rc28
8 X ppp 6.41rc28
9 security 6.41rc28
10 advanced-tools 6.41rc28
[admin@MikroTik] >
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41rc [release candidate] is released! New bridge implementation!

Fri Sep 15, 2017 2:47 pm

What's new in 6.41rc26 (2017-Sep-07 13:26):
*) crs317 - added initial support for HW offloaded MPLS forwarding;
Is this gona be not bridged intefaces can hardware switch depending on label but ldp is running on ip so one would have to configure ip adresses and a routing protocol say ospf to get routes that would be hardware switched on labels without cpu. the cpu would only run routing protocol and ldp and the hardware chip would switch/route incoming mpls packes according to ldp. being a router no l2 domain but doing it true switching on ldp labels... Like the big guys....
Is this Initial something that works now in cli or is it the first door and something to be enabled later in the rc branch.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 12:02 pm

What's new in 6.41rc30 (2017-Sep-15 11:50):

Important note!!! Backup before upgrade!
RouterOS (v6.40rc36-rc40 and) v6.41rc1+ contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus for now.
Please, note that downgrading to previous RouterOS versions will not restore "master-port" configuration, so use backups to restore configuration on downgrade.


Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

Changes since previous 6.41rc release:

*) crs317 - added L2MTU support;
*) crs326 - fixed packet processing speed on switch chip if individual port link speed differs;
*) crs3xx - added port ingress and egress rate limiting;
*) export - fixed wireless "ssid" and "supplicant-identity" compact export;
*) ppp - fixed situation when part of PPP configuration was reset to default values after reboot;
*) wireless - added "allow-signal-out-of-range" option for Access List entries (CLI only);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 12:12 pm

added "allow-signal-out-off-range" option
should be 'out of range' or 'off-range', but not both, I think :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 12:39 pm

Chupaka - Thanks! Fixed the typo in changelog.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 1:01 pm

Any use cases for this option?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 4:12 pm

Just tested CRS326-24G-2S+ on 6.41rc30
- started from clean config (reset w/o default)
- simple config: all port in a bridge, RSTP active
- ip dhcp client on bridge interface
- set identity and users

Reboot >> device dead

Via console I see the device is booting correctly >> startup services >> login (and after 1 sec) >> System rebooting (but the board stuck there w/o rebooting).
Note: the ether1 was the only cable plugged in and the led was off.

I was not able to create a supout (too fast in locking down); netinstall to 6.40.3 and we are in business again
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 4:37 pm

bajodel - Can you please send to support@mikrotik,.com precise commands which you execute to reproduce this problem? We added all ports into bridge, added DHCP client on bridge, rebooted device and it is working just fine.
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 5:27 pm

Sure, as soon as possible I'll try to redo the same setup.
Now I remember that I also changed default MACs on etherXX interfaces and set admin-MAC on bridge one.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 5:44 pm

Any use cases for this option?
Here is the discussion about that option:
viewtopic.php?f=7&t=124884
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 6:12 pm

Any use cases for this option?
Here is the discussion about that option:
viewtopic.php?f=7&t=124884
Interesting how fast some options appear compared to others, cough useful IPv6 changes.

Yes, I'm heckling you because well it's apparently needed.

Side-note: It seems the pace is slowing on this RC. I imagine this means we'll be seeing 6.41rc moving to GA and 6.42 started? Will we see a general theme targeted in this next cycle like we say with the new bridge implementation?
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 6:36 pm

Interesting how fast some options appear compared to others, cough useful IPv6 changes.

Yes, I'm heckling you because well it's apparently needed.

Side-note: It seems the pace is slowing on this RC. I imagine this means we'll be seeing 6.41rc moving to GA and 6.42 started? Will we see a general theme targeted in this next cycle like we say with the new bridge implementation?
Good observation!
I am waiting until today for a simple reset counter:

viewtopic.php?f=1&t=108552&p=614961&hil ... er#p614961
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: v6.41rc [release candidate] is released! New bridge implementation!

Mon Sep 18, 2017 7:11 pm

bajodel - Can you please send to support@mikrotik,.com precise commands which you execute to reproduce this problem? We added all ports into bridge, added DHCP client on bridge, rebooted device and it is working just fine.
Board: CRS326-24G-2S+

1) netinstalled 6.40.3
2) upgraded to 6.41rc30
3) reset w/o default
4) create bridge and put all port into it
5) change all Ethernet MACs (sample below)
/interface ethernet
set [ find default-name=ether1 ] mac-address=CC:4E:24:00:EE:01
set [ find default-name=ether2 ] mac-address=CC:4E:24:00:EE:02
set [ find default-name=ether3 ] mac-address=CC:4E:24:00:EE:03
set [ find default-name=ether4 ] mac-address=CC:4E:24:00:EE:04
set [ find default-name=ether5 ] mac-address=CC:4E:24:00:EE:05
set [ find default-name=ether6 ] mac-address=CC:4E:24:00:EE:06
set [ find default-name=ether7 ] mac-address=CC:4E:24:00:EE:07
set [ find default-name=ether8 ] mac-address=CC:4E:24:00:EE:08
set [ find default-name=ether9 ] mac-address=CC:4E:24:00:EE:09
set [ find default-name=ether10 ] mac-address=CC:4E:24:00:EE:10
set [ find default-name=ether11 ] mac-address=CC:4E:24:00:EE:11
set [ find default-name=ether12 ] mac-address=CC:4E:24:00:EE:12
set [ find default-name=ether13 ] mac-address=CC:4E:24:00:EE:13
set [ find default-name=ether14 ] mac-address=CC:4E:24:00:EE:14
set [ find default-name=ether15 ] mac-address=CC:4E:24:00:EE:15
set [ find default-name=ether16 ] mac-address=CC:4E:24:00:EE:16
set [ find default-name=ether17 ] mac-address=CC:4E:24:00:EE:17
set [ find default-name=ether18 ] mac-address=CC:4E:24:00:EE:18
set [ find default-name=ether19 ] mac-address=CC:4E:24:00:EE:19
set [ find default-name=ether20 ] mac-address=CC:4E:24:00:EE:20
set [ find default-name=ether21 ] mac-address=CC:4E:24:00:EE:21
set [ find default-name=ether22 ] mac-address=CC:4E:24:00:EE:22
set [ find default-name=ether23 ] mac-address=CC:4E:24:00:EE:23
set [ find default-name=ether24 ] mac-address=CC:4E:24:00:EE:24
set [ find default-name=sfp-sfpplus1 ] mac-address=CC:4E:24:00:EE:25
set [ find default-name=sfp-sfpplus2 ] mac-address=CC:4E:24:00:EE:26
>> Reboot

On console you'll see..
BootROM 1.41
Booting from SPI flash
BootROM: Image checksum verification PASSED


RouterBOOT booter 3.41

CRS326-24G-2S+

CPU frequency: 800 MHz
  Memory size: 512 MiB
 Storage size:  16 MiB

Press <delete> key within 4 seconds to enter setup....

loading kernel... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...

Rebooting...
Stopping services...
The board is stuck (not really rebooting); unplugging power cable you start again as above.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 19, 2017 10:17 am

I am waiting until today for a simple reset counter:

viewtopic.php?f=1&t=108552&p=614961&hil ... er#p614961
so, now it's available in 6.41rc? :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 19, 2017 10:39 am

Chupaka, juliokato - Yes, it is:
*) interface - added "/interface reset-counters" command (CLI only);
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.41rc [release candidate] is released! New bridge implementation!

Tue Sep 19, 2017 4:01 pm

OK thanks, I'll test if it works I do not need to wait for V.7 .....

I'll just wait for the stable version.
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)

Who is online

Users browsing this forum: No registered users and 6 guests