Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.40.1 [current]

Fri Aug 04, 2017 1:02 pm

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.

What's new in 6.40.1 (2017-Aug-03 12:37):

*) bonding - improved reliability on bonding interface removal;
*) chr - fixed false warnings on upgrade reboots;
*) dhcpv6-client - do not run DHCPv6 client when IPv6 package is disabled;
*) export - fixed export for different parameters where numerical range or constant string is expected;
*) firewall - properly remove "address-list" entry after timeout ends;
*) interface - improved interface state change handling when multiple interfaces are affected at the same time;
*) lte - fixed LTE not passing any traffic while in running state;
*) ovpn-client - fixed incorrect netmask usage for pushed routes (introduced in 6.40);
*) pppoe-client - fixed incorrectly formed PADT packet;
*) rb2011 - fixed possible LCD blinking along with ethernet LED (introduced in 6.40);
*) rb922 - restored missing wireless interface on some boards;
*) torch - fixed Torch on PPP tunnels (introduced in 6.40);
*) trafficgen - fixed "lost-ratio" showing incorrect statistics after multiple sequences;
*) winbox - added "none-dynamic" and "none-static" options for "address-list-timeout" parameter under NAT, Mangle and RAW rules;
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 2:00 pm

*) rb2011 - fixed possible LCD blinking along with ethernet LED (introduced in 6.40);
NOP
LCD still blinking after Upgrade
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Fri Aug 04, 2017 2:34 pm

irghost - Are you talking about blinking LCD during Netinstall process? This fix solved problem when LCD was blinking while device is booted on RouterOS. Next rc release will fix also blinking LCD during Netinstall process (latest Netinstall will be required).
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 2:48 pm

irghost - Are you talking about blinking LCD during Netinstall process? This fix solved problem when LCD was blinking while device is booted on RouterOS. Next rc release will fix also blinking LCD during Netinstall process (latest Netinstall will be required).
same as before
LCD blinking with ethernet LED after the RB2011 booted
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
linux25
just joined
Posts: 5
Joined: Sat Apr 29, 2017 4:09 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 4:04 pm

Anyone have problem with ethernet link down and up? i see that after i upgrade 6.40 from 6.39.
 
timonlio
just joined
Posts: 6
Joined: Thu Mar 09, 2017 2:35 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 4:11 pm

Upgrade from v6.40 to v6.40.1

After reboot, new system forgot my PPPoE account and password setting.
Re-fill in QuickSet not working at all
Check /interfaces/pppoe-out1 manually, need specified the "interfaces" to ether1-gateway, and need set "add default route" manually to make it works again.
 
ksteink
newbie
Posts: 38
Joined: Thu Mar 31, 2016 6:54 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 5:14 pm

Same issue on the RB2011 with the led. I have to manually shut it off with set led command.
 
dgcapel
just joined
Posts: 8
Joined: Tue Jan 26, 2016 6:03 pm
Location: Spain
Contact:

Re: v6.40.1 [current]

Fri Aug 04, 2017 5:45 pm

Somebody have problem with Google Email with Google Suite Sync over 6.39.2 / 6.40 / 6.40.1??

C:\Users\dgcapel\AppData\Local\Google\Google Apps Sync\Tracing\OUTLOOK
2017-08-04T15:52:43.042+02:00 38d0 W:Network gsync32!LogPotentialProxyNetworkFailure   [Reason: Warning:Potential proxy failure] @ 306 (**email_address**)> WinHttpGetProxyForUrl auto-detect failed with 0x80072f94  [color=#FF0000][Reason: Warning:Network timeouts][/color] . 0/(null). IsNetworkActive is 1, flags 1, IsNetworkActive GetLastError 0x80004005
2017-08-04T15:52:43.497+02:00 38d0 W:Sync gsync32!GLookSyncHelper::GetSyncPermit @ 513 (**email_address**)> SyncEngine '4'; SyncPermit is SYNC_PERMIT_UNKNOWN (0)
2017-08-04T15:52:43.499+02:00 38d0 W:Sync gsync32!GLookSyncHelper::GetSyncPermit @ 513 (**email_address**)> SyncEngine '4'; SyncPermit is SYNC_PERMIT_UNKNOWN (0)
2017-08-04T15:52:43.499+02:00 38d0 A:Sync gsync32!GLookSyncHelper::SetSyncPermit @ 537 (**email_address**)> SyncEngine '4'; SyncPermit is now: SYNC_PERMIT_GRANTED (2).
2017-08-04T15:52:43.499+02:00 38d0 A:Sync gsync32!GLookSyncer::GoOnline @ 1315 (**email_address**)> Going Online.
2017-08-04T15:52:43.500+02:00 38d0 A:Sync gsync32!GLookSyncer::ScheduleAllSyncTasks @ 1549 (**email_address**)> Scheduling calendar sync task: init delay 5 sec, interval 600 sec
2017-08-04T15:52:43.500+02:00 38d0 A:Sync gsync32!GLookSyncer::ScheduleAllSyncTasks @ 1566 (**email_address**)> Scheduling contacts sync task: init delay 5 sec, interval 1200 sec
2017-08-04T15:52:43.500+02:00 38d0 A:Sync gsync32!GLookSyncer::ScheduleAllSyncTasks @ 1583 (**email_address**)> Scheduling email  sync task: init delay 5 sec, interval 60 sec
2017-08-04T15:52:43.500+02:00 38d0 A:Sync gsync32!GLookSyncer::ScheduleAllSyncTasks @ 1604 (**email_address**)> Scheduling AB sync task: init delay 30 sec, interval 21600 sec
2017-08-04T15:52:43.500+02:00 38d0 A:Sync gsync32!GLookSyncer::ScheduleAllSyncTasks @ 1621 (**email_address**)> Scheduling notes sync task: init delay 5 sec, interval 3600 sec
2017-08-04T15:52:43.500+02:00 3618 W:Network gsync32!LogPotentialProxyNetworkFailure   [Reason: Warning:Potential proxy failure] @ 306 (**email_address**)> WinHttpGetProxyForUrl auto-detect failed with 0x80072f94 [Reason: Warning:Network timeouts]. 0/(null). IsNetworkActive is 1, flags 1, IsNetworkActive GetLastError 0x80004005
[Reason: Warning:Network timeouts]
 
User avatar
eworm
Member
Member
Posts: 402
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.40.1 [current]

Fri Aug 04, 2017 6:02 pm

I have several devices that report error on export:
#error exporting /system routerboard mode-button
Tested on 750GL and mAP 2nD.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.40.1 [current]

Fri Aug 04, 2017 8:22 pm

Fasttrack does not work in 6.40.1
SXT LTE
Image
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
karnauskas
just joined
Posts: 1
Joined: Sat Aug 05, 2017 12:47 am

Re: v6.40.1 [current]

Sat Aug 05, 2017 12:50 am

Bug in Web UI:
IP > IPsec > Policies:
- No action if clicked on existing record. AFAIK I was able to edit them in past.
 
libyatik
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Wed Jun 28, 2017 4:31 am

Re: v6.40.1 [current]

Sat Aug 05, 2017 1:51 am

Anyone have problem with ethernet link down and up? i see that after i upgrade 6.40 from 6.39.
i noticed the same thing
 
Kindis
Member Candidate
Member Candidate
Posts: 251
Joined: Tue Nov 01, 2011 6:54 pm

Re: v6.40.1 [current]

Sat Aug 05, 2017 10:17 am

Fasttrack does not work in 6.40.1
SXT LTE
Can you see if the connections are marked as fasttrack?
 
User avatar
maznu
Member Candidate
Member Candidate
Posts: 197
Joined: Tue May 05, 2015 11:12 am
Location: Manchester, UK
Contact:

Re: v6.40.1 [current]

Sat Aug 05, 2017 2:01 pm

Having some OVPN problems having done an upgrade on clients from 6.38.5 to 6.40.1. Server is 6.37.5 still.

No VPN session stays up more than a minute:

11:53:40 ovpn,info,account XXXX logged in, A.B.C.D
11:53:40 ovpn,info <ovpn-XXXX>: connected
11:54:20 ovpn,info <ovpn-XXXX>: terminating... - nothing received for a while
11:54:21 ovpn,info,account XXXX logged out, 41 140 480 1 8
11:54:21 ovpn,info <ovpn-XXXX>: disconnected

The profile is set to be quite long - 28 days for the session timeout, 1 hour idle timeout.
Marek
 
User avatar
Ocean
just joined
Posts: 4
Joined: Mon Sep 03, 2012 11:10 am
Location: Russia/Moscow
Contact:

Re: v6.40.1 [current]

Sat Aug 05, 2017 7:06 pm

After the upgrade to version 6.40.1 from 6.39.2, problems with PoE ports:

00:10:11 poe-out,warning ether4 detected poe-out status: short_circuit
00:10:13 poe-out,info ether4 detected poe-out status: wait_for_load
00:10:14 poe-out,warning ether4 detected poe-out status: short_circuit
00:10:14 poe-out,info ether4 detected poe-out status: wait_for_load

RouterBoard 960PGS.

After returning to 6.39.2, the problem disappeared.
Andrey
 
lotnybartek
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Wed Apr 16, 2014 3:22 pm

Re: v6.40.1 [current]

Sun Aug 06, 2017 6:14 pm

*) rb2011 - fixed possible LCD blinking along with ethernet LED (introduced in 6.40);

Not true. All my 4x RB2011 LCD's are blinking constantly AFTER boot. I need to manually turn them off using WinBox - for example.
 
jondavy
Member Candidate
Member Candidate
Posts: 127
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: v6.40.1 [current]

Mon Aug 07, 2017 12:45 am

spectral-history not work
tested in SXT Lite5
 
damiantrx
just joined
Posts: 1
Joined: Mon Aug 07, 2017 2:41 am

Re: v6.40.1 [current]

Mon Aug 07, 2017 2:52 am

Hello,
Update from 6.39.2...aaand problem with dhcp:

Mikrotik(ap bridge,dhcp server)<----wireless--->ap_client[F8:D1:11:52:xx:xx](bridged wlan & eth, no other services)<----wired--->PC[B8:27:EB:8C:xx:xx]

aug/07 01:37:07 dhcp,warning dhcp1 offering lease 10.10.20.20 for B8:27:EB:8C:xx:xx to F8:D1:11:52:xx:xx without success

Reverted back to 6.39.2, problem disappears.
 
antonsb
MikroTik Support
MikroTik Support
Posts: 197
Joined: Sun Jul 24, 2016 3:12 pm
Location: Riga, Latvia

Re: v6.40.1 [current]

Mon Aug 07, 2017 11:34 am

Fasttrack does not work in 6.40.1
SXT LTE
Can you see if the connections are marked as fasttrack?
There is no fasttrack support for SXT LTE units yet!
What's new in v6.40 (2017-Jul-21 08:45):

!) lte - added initial fastpath support (except SXT LTE and Sierra modems);
!) lte - added initial support for passthrough mode for lte modems that supports fastpath;
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Mon Aug 07, 2017 11:55 am

irghost, ksteink, lotnybartek - LCD and LED issue will be fully fixed in 6.41rc release
linux25, libyatik - Please after link down/up generate supout file on your router and send it to support@mikrotik.com
timonlio, dgcapel, maznu, jondavy, damiantrx - Please generate supout file on your router and send it to support@mikrotik.com
eworm - This problem will be fixed in upcoming 6.41rc releases
irghost - SXT LTE does not support FastPath/FastTrack yet
karnauskas - This problem will be fixed in upcoming 6.41rc releases. Sort table after "#" column and then you will be able to open this entry
Ocean - Please write to support. You do not see such errors in older versions because only in 6.40 PoE logging topic was added
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.40.1 [current]

Mon Aug 07, 2017 1:14 pm

Fasttrack does not work in 6.40.1
SXT LTE
Can you see if the connections are marked as fasttrack?
There is no fasttrack support for SXT LTE units yet!
What's new in v6.40 (2017-Jul-21 08:45):

!) lte - added initial fastpath support (except SXT LTE and Sierra modems);
!) lte - added initial support for passthrough mode for lte modems that supports fastpath;
now what?
Image
on SXT LTE
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Mon Aug 07, 2017 2:28 pm

Currently FastTrack shows as active on SXT LTE by mistake. It does not work properly at the moment. We will try to fix it in upcoming RouterOS version. Meanwhile we suggest to disable FastTrack on SXT LTE devices.
 
mysz0n
Member Candidate
Member Candidate
Posts: 125
Joined: Tue Mar 03, 2009 2:14 am

Re: v6.40.1 [current]

Mon Aug 07, 2017 2:47 pm

Update from 6.38.5
When i send sms from 951Ui i recive empty sms with no timestamp or message from the number i just sent an sms.

I'm glad that special characters dont crush sms mesage anymore, the special characters are replaced by "?" which is great.
But in the current form, sms tools are useless due to the problem described above. Has anyone tested it?
 
berghofer
just joined
Posts: 2
Joined: Mon Aug 07, 2017 11:26 pm

Re: v6.40.1 [current]

Mon Aug 07, 2017 11:31 pm

After upgrade from 6.38.7 mipsbe to current release my repeater isn't working. Don't get IP-address.

After downgrade to 6.38.7 everythig is working fine again.
 
berghofer
just joined
Posts: 2
Joined: Mon Aug 07, 2017 11:26 pm

Re: v6.40.1 [current]

Mon Aug 07, 2017 11:32 pm

Hello,
Update from 6.39.2...aaand problem with dhcp:

Mikrotik(ap bridge,dhcp server)<----wireless--->ap_client[F8:D1:11:52:xx:xx](bridged wlan & eth, no other services)<----wired--->PC[B8:27:EB:8C:xx:xx]

aug/07 01:37:07 dhcp,warning dhcp1 offering lease 10.10.20.20 for B8:27:EB:8C:xx:xx to F8:D1:11:52:xx:xx without success

Reverted back to 6.39.2, problem disappears.

This was my problem. Same log-entry appears. After downgrade the problen disappears.
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: v6.40.1 [current]

Tue Aug 08, 2017 12:51 am

After the upgrade to version 6.40.1 from 6.39.2, problems with PoE ports:

00:10:11 poe-out,warning ether4 detected poe-out status: short_circuit
00:10:13 poe-out,info ether4 detected poe-out status: wait_for_load
00:10:14 poe-out,warning ether4 detected poe-out status: short_circuit
00:10:14 poe-out,info ether4 detected poe-out status: wait_for_load

RouterBoard 960PGS.

After returning to 6.39.2, the problem disappeared.
I am seeing the same thing, scenario is: a rb POE Hex Lite, that is powering another POE Hex Lite (that is about 140ft away, with good cat6 cable), on the far end POE hex Lite, i had to set eth1-poe-in (settings = long-cable = yes a while back, and have never had issues). after upgrade from 6.37.1 to 6.40.1 today, the 1st Hex LIte is showing Short-circut on the eth2 powering the far end hex Lite.

(switching to Forced-ON does restore power to the far end hex-lite)

much more concerning: after the same SW upgrade, the poe hex-lite was showing short-circuit on the eth going to my Cable Modem (a netgear CM-600) i had never seen this before, but after 6.40.1 i quickly switched that port to poe=OFF (from poe=auto-on) , on 6.37.1 it was def. not trying nor showing short-circuit on the eth5 to cable modem port

I will email mt support, as a rep instructed user "Ocean" above to do.

thanks
:beep :beep :beep
 
lotnybartek
Frequent Visitor
Frequent Visitor
Posts: 95
Joined: Wed Apr 16, 2014 3:22 pm

Re: v6.40.1 [current]

Tue Aug 08, 2017 9:56 am

IPSec site to site is extremely slow on 6.40.1. Reverted back to 3.39.2 - now is "as usual" - good.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Tue Aug 08, 2017 11:13 am

Everyone who sees log messages about PoE but did not see them in previous versions - There was no PoE-OUT logging topic in past RouterOS versions. It was just now introduced in 6.40 version.
 
msatter
Forum Guru
Forum Guru
Posts: 1285
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.40.1 [current]

Tue Aug 08, 2017 3:44 pm

*) winbox - added "none-dynamic" and "none-static" options for "address-list-timeout" parameter under NAT, Mangle and RAW rules;

Till now when you put an duration into the field you had an dynamic address that would disappear when the time is over. No duration entered the address only disappears when it is manually removed.

Now we have beside duration/no duration also none-dynamic and none-static....but what is the function of those last two?

Look at the manual but that was updated three years ago so info about that to be found there.
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta59 / Winbox 3.20 / MikroTik APP 1.3.7
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Tue Aug 08, 2017 3:50 pm

In the past if you had rule which adds IP address to address list, then you could either specify timeout or do not specify anything which is equal to none-dynamic behavior. None-static is introduced for those users who create blacklists for, for example, attackers and want to save them into address list still also after reboot.
 
msatter
Forum Guru
Forum Guru
Posts: 1285
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.40.1 [current]

Tue Aug 08, 2017 4:02 pm

In the past if you had rule which adds IP address to address list, then you could either specify timeout or do not specify anything which is equal to none-dynamic behavior. None-static is introduced for those users who create blacklists for, for example, attackers and want to save them into address list still also after reboot.
So I have a HEX and about 45.000 blacklisted addresses and if I make the none-static they will be be still there after a reboot? They have to be saved somewhere during the reboot and the Flash is to small for that if I am correct.
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta59 / Winbox 3.20 / MikroTik APP 1.3.7
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.40.1 [current]

Tue Aug 08, 2017 4:30 pm

65k address list entries takes ~1.9MB of disk space, so there should be enough space.
 
jo2jo
Forum Veteran
Forum Veteran
Posts: 958
Joined: Fri May 26, 2006 1:25 am

Re: v6.40.1 [current]

Wed Aug 09, 2017 7:43 pm

Everyone who sees log messages about PoE but did not see them in previous versions - There was no PoE-OUT logging topic in past RouterOS versions. It was just now introduced in 6.40 version.
in my post (in regards to passive POE issues introduced only in 6.40.1) , im not referring to log messages, these are poe SHORT errors/messages, which appear in the interface list, and thus cut POE to the affected port/device. (while on AUTO, which worked if i downgrade to any pre 6.40.1).

(also auto now attempting to provide power (and showing SHORT, so stopping passive poe) to a non POE cable modem is a entirely new thing.

(btw, i have sent supout and all info to support@mt a few days ago)

tks
:beep :beep :beep
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: v6.40.1 [current]

Thu Aug 10, 2017 12:48 am

I'm to lazy to read all the posts, but seen one with the same issue I have in 6.40.1

LCD screen flashes after a power cycle, if I make a change to anything like, " read only mode on or off, the screen stops flashing. It will flash on and off after a power up if read only was left check or unchecked. don't believe that the read only mode check box has anything to do with this, it just when Anything is changed about the screen settings it stops, until the power cycle.

The settings I have for the screen are off, disable - I see no reason to have this screen :-)

on RB 2011UiAS-2Hnd
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Thu Aug 10, 2017 11:18 am

The export mode button has no error, it has a comment symbol in front (#) so this is cosmetic only.
Mode button will be implemented in future hardware, so currently this menu has no function. The export line is also only informative, not an error.
No answer to your question? How to write posts
 
oruam
just joined
Posts: 1
Joined: Mon Oct 05, 2015 3:15 pm

Re: v6.40.1 [current]

Thu Aug 10, 2017 5:11 pm

Good morning, we found a problem with the version of Router OS 6.40.1, using PPPoE and PPtP, when climbing the default route in the establishment of the tunnel, it points the default route to the IP itself, manually routing the problem Does not occur, I believe it is a bug.
 
User avatar
Zeeester
just joined
Posts: 14
Joined: Mon Apr 24, 2006 8:28 am
Location: Osijek, Croatia

Re: v6.40.1 [current]

Thu Aug 10, 2017 6:13 pm

Since version 6.40 on x86 machine memory slowly increasing.

Image
 
dasvos
newbie
Posts: 29
Joined: Sat Mar 14, 2015 7:10 pm

Re: RE: Re: v6.40.1 [current]

Thu Aug 10, 2017 7:42 pm

I'm to lazy to read all the posts, but seen one with the same issue I have in 6.40.1

LCD screen flashes after a power cycle, if I make a change to anything like, " read only mode on or off, the screen stops flashing. It will flash on and off after a power up if read only was left check or unchecked. don't believe that the read only mode check box has anything to do with this, it just when Anything is changed about the screen settings it stops, until the power cycle.

The settings I have for the screen are off, disable - I see no reason to have this screen :-)

on RB 2011UiAS-2Hnd
Latest RC (6.41) fixes the issue.

Sent from my HUAWEI VNS-L31 using Tapatalk
 
User avatar
travisms
newbie
Posts: 28
Joined: Mon Jul 13, 2015 8:47 pm
Location: Strand, South Africa

Re: v6.40.1 [current]

Fri Aug 11, 2017 2:52 pm

The modem-signal LED display has broken from 6.39.2 > 6.40(.1) with the RB912 (BaseBox 5) + Sierra Wireless MC8705. Once downgraded back to 6.39.2 the LEDs light up again where as on 6.40 and 6.40.1 they do not light up.
 
Bitto
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Wed May 02, 2012 10:15 am

Re: v6.40.1 [current]

Fri Aug 11, 2017 6:40 pm

Web interface crashes on some CCR1036's i had to revert back 6.38.7 bugfix.
Also OSPF-MPLS crashes on first LER CCR1036 log shows Subnet mismatch between ospf routers while there aren't any.
if i revert back only first LER(label edge router) to 6.39.2 our backbone works without any problems.
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Sat Aug 12, 2017 2:00 pm

Seeing quite a strange behaviour here:

Updated from 6.39.2 to 6.40.1 on a hEX (RouterBOOT 3.35 before and after)
Cable modem only seen as 100 Mbps link now. It's being negotiated as 1 Gbps, stays up for a second, and after some tries falls back to 100 Mbps.
Old RouterOS logs confirm that previously it was 1 Gbps (I'm on a 200 Mbps line, so 100 Mbps isn't enough).
Setting fixed to 1 Gbps establishes link for a second, then goes down again. Playing with various autosensing settings didn't help either.

Cable modem brand is a Hitron CVE 3060 from German Vodafone Kabel Deutschland.
Connected via Cat7 cable, tried switching to a Cat6 from different vendor to no avail.
Tried different modem port to no avail.
I can confirm that modem shows port as 1 Gbps in its interface.

Modem reboot didn't help, neither did hEX reboot.
Also downgrade didn't help, neither a binary restore from an older backup.

In between, the hEX became unresponsive and I netinstalled, as even configuration reset didn't help.
With a blank configuration, the same behaviour. Switching to another ether port doesn't help either.
All other connections look fine, e.g. to my CRS switches, all shown as 1 Gbps.

I can confirm that using a regular notebook, the cable modem DOES provide 1 Gbps connectivity.
I can also confirm it's not just a display issue, as speedtests show via heX I'm on 100 Mbit/s, while directly via notebook I get 200 MBit/s.
Was there any NIC firmware update incorporated in 6.40.1 that broke things possibly?
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.40.1 [current]

Sat Aug 12, 2017 3:31 pm

Are you sure about RouterBOOT version? There is no such version at:
https://wiki.mikrotik.com/wiki/RouterBOOT_changelog
Also it seems to me that you have to update RouterBOOT separately by issuing
system routerboard upgrade 
and then reboot ...
Updated from 6.39.2 to 6.40.1 on a hEX (RouterBOOT 3.35 before and after)
...
Was there any NIC firmware update incorporated in 6.40.1 that broke things possibly?
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Sat Aug 12, 2017 3:34 pm

Yep, it's correct. ;)
> /system routerboard print
       routerboard: yes
             model: RouterBOARD 750G r3
     serial-number: ###
     firmware-type: mt7621L
  factory-firmware: 3.34
  current-firmware: 3.35
  upgrade-firmware: 3.35
 
 
zippel
newbie
Posts: 36
Joined: Sun Apr 23, 2017 1:55 pm

Re: v6.40.1 [current]

Sat Aug 12, 2017 3:34 pm

 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Sat Aug 12, 2017 7:00 pm

Updated from 6.39.2 to 6.40.1 on a hEX (RouterBOOT 3.35 before and after)
Cable modem only seen as 100 Mbps link now. It's being negotiated as 1 Gbps, stays up for a second, and after some tries falls back to 100 Mbps.
Old RouterOS logs confirm that previously it was 1 Gbps (I'm on a 200 Mbps line, so 100 Mbps isn't enough).
Setting fixed to 1 Gbps establishes link for a second, then goes down again. Playing with various autosensing settings didn't help either.
I now tried four other Cat6 cables of various length, to no avail.
Once (!) it connected with Gbps and it worked. Upon removing the cable and reattaching was back at 100 Mbps.
It somehows smells as if some timer/sync is severly broken...
Assuming it stays with Gbps after connected, not sure if not something else got broken HW-wise (and the upgrade is not to blame) and just didn't come to life yet, as I had no reconnect for some weeks...
 
nbctcp
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Tue Sep 16, 2014 7:32 pm

Re: v6.40.1 [current]

Sat Aug 12, 2017 10:22 pm

Hi,
I upgrading my RB1100X2AH to ROS 6.40.1, then I notice this error
#error exporting /system routerboard mode-button

Beside that, using console from Serial port didn't prompt Login, for example
admin
Password: password
You see that, there is no Login: prompt
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.40.1 [current]

Sun Aug 13, 2017 6:34 am

Another issue (CCR1009):
After the update from 6.39.2, one of my PPTP server binding entries lost the user name set for it.
Correction by hand solved it. All other similar entries where fine.
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
zippel
newbie
Posts: 36
Joined: Sun Apr 23, 2017 1:55 pm

Re: v6.40.1 [current]

Sun Aug 13, 2017 8:14 am

hAP mini, PPPoE<->NAT speed loss, max 60mbps in and 8mbps out
6.38 to 6.40
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Sun Aug 13, 2017 9:38 pm

Cable modem only seen as 100 Mbps link now. It's being negotiated as 1 Gbps, stays up for a second, and after some tries falls back to 100 Mbps.
Maybe false alert, seems to be NOT related to 6.40.1.
I had a chance to test with a friend's hEX. Worked reliably with 6.40, likewise with 6.40.1, both RouterBOOT 3.35.
Same cable, same port on my device - only 100 Mbps.

I assume something is broken hardware-wise on my box, and that this would have come to life also in case of just a regular reboot.
I switched power adaptors already, no dice.

I'll open a support ticket, smells like a RMA to me.
 
dadoremix
Member Candidate
Member Candidate
Posts: 118
Joined: Sat May 14, 2011 11:31 am

Re: v6.40.1 [current]

Sun Aug 13, 2017 11:09 pm

after upgrade i see some Strange behavior
i have hex r3
i use graphing for interfaces

after upgrade to 6.40.1 when you go to graphing via http, hex r3 stop responding, you musto go from interface to interface.. 5-6 and then block
winbox is working, but for 3-4 hours he block and only power off help
 
donline
just joined
Posts: 2
Joined: Mon Aug 14, 2017 10:31 am

Re: v6.40.1 [current]

Mon Aug 14, 2017 10:39 am

I also have the DHCP issue on wifi bridge clients where there the dhcprequest does not work after dhcpoffer is sent, hAP AC and hAP lite.
 
Bitto
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Wed May 02, 2012 10:15 am

Re: v6.40.1 [current]

Mon Aug 14, 2017 5:40 pm

after upgrade i see some Strange behavior
i have hex r3
i use graphing for interfaces

after upgrade to 6.40.1 when you go to graphing via http, hex r3 stop responding, you musto go from interface to interface.. 5-6 and then block
winbox is working, but for 3-4 hours he block and only power off help
Pretty much same behavior on our CCR-1036 routers.
Web interfaces freezup after you access graph page until reboot.
 
LTEuser
just joined
Posts: 1
Joined: Mon Aug 14, 2017 4:56 pm

Re: v6.40.1 [current]

Mon Aug 14, 2017 6:00 pm

The modem-signal LED display has broken from 6.39.2 > 6.40(.1) with the RB912 (BaseBox 5) + Sierra Wireless MC8705. Once downgraded back to 6.39.2 the LEDs light up again where as on 6.40 and 6.40.1 they do not light up.
I have the same problem with the SXT LTE. Moreover also the RSRQ and RSSI graphs on the "Quick Set" page show wrong values, something around 65000.
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.40.1 [current]

Mon Aug 14, 2017 7:10 pm

Maybe false alert, seems to be NOT related to 6.40.1.
I had a chance to test with a friend's hEX. Worked reliably with 6.40, likewise with 6.40.1, both RouterBOOT 3.35.
Thanks for the update ... I was too reluctant to go for 6.40.1 after your post ... now I may reconsider :)
Anyways seems to me that Mikrotik should document changes to RouterBOOT firmware ...
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Mon Aug 14, 2017 9:12 pm

Maybe false alert, seems to be NOT related to 6.40.1.
I had a chance to test with a friend's hEX. Worked reliably with 6.40, likewise with 6.40.1, both RouterBOOT 3.35.
Thanks for the update ... I was too reluctant to go for 6.40.1 after your post ... now I may reconsider :)
Anyways seems to me that Mikrotik should document changes to RouterBOOT firmware ...
I more and more think it's hardware-related.
I just put a switch in between the heX and the cable modem, and voilà, full sync with 1 Gbps
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Tue Aug 15, 2017 12:39 am

I more and more think it's hardware-related.
I just put a switch in between the heX and the cable modem, and voilà, full sync with 1 Gbps
Putting off power from the device for an hour seems to have helped, having a sync with 1 Gbps again now.
Probably some short circuit/power leakage/creepage.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Tue Aug 15, 2017 9:04 am

If you experience ethernet interface link speed issues with this RouterOS version, then please reboot router, reproduce the problem and generate supout file. Send this file to support@mikrotik.com and also give description of the problem - involved devices, cable description and what do you do in order to reproduce the same problem.
 
User avatar
floeff
newbie
Posts: 41
Joined: Sat Jan 28, 2017 6:39 pm
Location: Germany
Contact:

Re: v6.40.1 [current]

Tue Aug 15, 2017 12:27 pm

If you experience ethernet interface link speed issues with this RouterOS version, then please reboot router, reproduce the problem and generate supout file. Send this file to support@mikrotik.com and also give description of the problem - involved devices, cable description and what do you do in order to reproduce the same problem.
Support ticket has been created, just attached a supout file as well.
Sorry for hijacking this thread btw, it very much looked like an issue with 6.40.1 in first place.
 
Olshevsky
just joined
Posts: 2
Joined: Sun Aug 21, 2011 11:58 pm
Location: Israel

Re: v6.40.1 [current]

Tue Aug 15, 2017 6:55 pm

It seams that Scripting is broken,
I have script that send me configuration backup, it is working on many models in 6.39.2
in 40.1 it writs:
system,e-mail,error Error sending e-mail <JRouter-11 aug/15/2017 13:54:54 Configuration BACKUP File>: error
handling file
Moshe Olshevsky
OSTS
+372-572-30-300
moshe@tech-srv.com
 
lono
just joined
Posts: 6
Joined: Wed Apr 01, 2015 9:27 am

Re: v6.40.1 [current]

Wed Aug 16, 2017 8:46 am

Dear Mikrotik team

in my network 9 mikrotik are running ....... today i tried to update v6.40.1 ..........then Mikrotik are not open ... its auto rebooted

please give me any solution for this
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Wed Aug 16, 2017 9:35 am

lono - Always in such case send supout file from your router to support@mikrotik.com. We are the only ones who can try to see what went wrong with your router. It is not possible to simply guess cause of the reboot in forum. Make sure that file is generated after router has rebooted with latest current version. It would be great if in such case you could also test next version (6.41rc in this case) rc version.
 
xavierbt
newbie
Posts: 40
Joined: Thu Jan 22, 2015 11:55 am

Re: v6.40.1 [current]

Thu Aug 17, 2017 2:17 pm

On 31th july I asked:

Since update to version 6.40 backup scripts are failing with this message


Error sending e-mail <ROUTER1 - jul/31/2017 Mikrotik Config Backup>: error handling file

Any clue why this was working and after update begins to fail ?

thanks


and strods said:

xavierbt - Fixed in 6.41rc already:
viewtopic.php?f=21&t=123936

But 6.40.1 is failing to run my backup scripts with same error, too.
Only corrected in 6.41rc but not in current release 6.40.1 ?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24268
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Thu Aug 17, 2017 2:21 pm

Yes, 6.41 is not the same as 6.40.1
No answer to your question? How to write posts
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Thu Aug 17, 2017 2:42 pm

xavierbt - If problem persist on 6.41rc, then this must be another problem. Then send supout file to support@mikrotik.com and we will investigate what is the issue. Most likely script syntax should be updated to due:
*) email - added support for multiple attachments;
 
User avatar
aacable
Member
Member
Posts: 423
Joined: Wed Sep 17, 2008 11:58 am
Location: ISLAMIC Republic of PAKISTAN
Contact:

Re: v6.40.1 [current]

Fri Aug 18, 2017 6:50 am

6.40.1: error handling file while sending mikrotik backup file via GMAIL smtp.
Fixed it by
:local backupfile "$sub1 mt_config_backup.backup"
_____________
Regard's

Syed Jahanzaib
Web: http://aacable.wordpress.com
Email: aacable [at] hotmail.com
 
bminish
just joined
Posts: 8
Joined: Wed Mar 09, 2011 5:47 am

Re: v6.40.1 [current]

Fri Aug 18, 2017 6:04 pm

I think I have found a bug in 6.40.1

This relates to OSPF over PPPoE session
OSPF comes up on the dynamic PPPoE interface, forms adjacency and learns routes from the PPPoE server (currently on 6.38.7 ) however the ospf routes on the client side are not distributed back to the OSPF instance on the PPPoE server side
Expected behavior would be for OSPF to distribute locally known, valid ospf routes

The issue appears to be caused by the PPPoE-Client which will if both ends of the PPPoE session are encompassed by valid OSPF network statements add a dynamic interface to /routing ospf interface
for the PPPoE-client interface of type broadcast
On the server side this is set up (correctly) as a dynamic interface of type Point to Point
On the client side the workaround is to add a manual interface to /routing ospf interface for the PPPoE interface of type point to point

Expected behavior would be for the dynamically added ospf interface for a pppoe client session to be of type point to point as is the current behavior on the PPPoE server side
 
rymdbullen
just joined
Posts: 2
Joined: Sat Aug 19, 2017 9:51 pm

Re: v6.40.1 [current]

Sat Aug 19, 2017 9:54 pm

Anyone have problem with ethernet link down and up? i see that after i upgrade 6.40 from 6.39.
Yes, I have exactly the same issue. What can I provide to help this issue to be resolved?

//Jan
 
whitbread
Member Candidate
Member Candidate
Posts: 108
Joined: Fri Nov 08, 2013 9:55 pm

Re: v6.40.1 [current]

Sun Aug 20, 2017 11:18 am

One of my RB2011UiAS-RM's runs into kernel failure every couple of hours - back to 6.39.2 - no more reboot's occured.
 
n21roadie
Forum Guru
Forum Guru
Posts: 1889
Joined: Fri Aug 07, 2009 10:36 pm
Location: Limerick,Ireland

Re: v6.40.1 [current]

Sun Aug 20, 2017 4:14 pm

6.40.1: error handling file while sending mikrotik backup file via GMAIL smtp.
Fixed it by
:local backupfile "$sub1 mt_config_backup.backup"
I tried adding :local mikrotikexport "$sub1 mt_export_backup" but handling error still occurs!
 
mysz0n
Member Candidate
Member Candidate
Posts: 125
Joined: Tue Mar 03, 2009 2:14 am

Re: v6.40.1 [current]

Tue Aug 22, 2017 11:37 am

in 6.40.1 i'm using these bridge filters:
/interface bridge filter
add chain=input mac-protocol=pppoe-discovery
add chain=forward mac-protocol=pppoe-discovery
add chain=forward mac-protocol=pppoe
add chain=input mac-protocol=pppoe
add action=drop chain=forward in-interface=wlan1
add action=drop chain=forward out-interface=wlan1
add action=drop chain=input in-interface=wlan1
add action=drop chain=output out-interface=wlan1
When these filters are enabled, all pppoe sessions are droped.
So far I've discovered the problem on
SXT 5nD r2
SXT G-5HPnD r2
But tonight my co-worker put new soft on more than 120 APs
Downgrading to 6.38.7 does not help,
Went back to 6.36.4 and filters work properly.
 
tannexdadole
just joined
Posts: 4
Joined: Tue Aug 22, 2017 4:14 pm

Re: v6.40.1 [current]

Tue Aug 22, 2017 4:23 pm

Good day guys...

Has anyone tried running DHCP server on wlan1 interface? mine goes red after running dhcp server
wlan1 interface is on ap bridge and has an ip of 192.168.3.1
I used the wizard to run DHCP server on the wlan1 interface

haplite and an RB951G-2hnd same problem...

thanks in advance...
---------------------------------------
NVM

sorted it out, it goes red when no client is on lease.. , :) I'm just not used to this..
 
brwainer
newbie
Posts: 47
Joined: Tue Feb 02, 2016 2:55 am

Re: v6.40.1 [current]

Tue Aug 22, 2017 5:06 pm

Has anyone tried running DHCP server on wlan1 interface? mine goes red after running dhcp server
wlan1 interface is on ap bridge and has an ip of 192.168.3.1
I used the wizard to run DHCP server on the wlan1 interface
If an interface is part of a bridge, then the IP address and the DHCP server need to be on the bridge itself, not on any of the interfaces that are a member of that bridge.
 
rzirzi
Member
Member
Posts: 378
Joined: Mon Oct 09, 2006 2:33 pm

Re: v6.40.1 [current]

Wed Aug 23, 2017 8:35 am

There is problem with PPPoE server under ROS 6.40.1. After few hours it's not working properly. PPPoE client's are "connected" (created PPPoE interfaces), but there is no traffic at that client's, I can't ping them. Even disabling WLAN interface with PPPoE server - the PPPoE client's are still "connected"! Could You confirm that bug?
 
Miracle
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 11, 2015 9:04 am

Re: v6.40.1 [current]

Wed Aug 23, 2017 7:29 pm

Please fix www unresponse in 6.40.2, I don't want upgrade to 6.41
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.40.1 [current]

Thu Aug 24, 2017 11:16 am

Version 6.40.2 has been released:
viewtopic.php?f=21&t=124903

Who is online

Users browsing this forum: No registered users and 20 guests