Community discussions

 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

SwOS version 2.5 released!

Fri Sep 15, 2017 4:07 pm

SwOS version 2.5 released
http://www.mikrotik.com/download
What's new in v2.5:

*) SFP & SFP Status tabs are combined into one;
*) Global RSTP settings are moved unto RSTP tab;
*) Static Hosts & Hosts tabs are combined into one;
*) CSS106, CRS326, CRS317: added support for IGMP snooping;
*) CRS326 & CRS317: fixed occasional lockup on SFP module insertion;
*) CSS106: added global independent VLAN lookup option for all VLANs;
*) CSS106: do not enable IVL on reboot if it's disabled;
*) implemented DHCP client;
*) CRS326 & CRS317: added support for DHCP & PPPoE snooping and
injecting option 82 (Intermediate Agent info);
*) CRS317: support fans;

CAVEAT: switch address acquisition mode by default is DHCP with fallback to static address;
 
psannz
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: SwOS version 2.5 released!

Fri Sep 15, 2017 4:32 pm

Is IGMP Snooping supported on the CSS326, too?
 
w0lt
Member
Member
Posts: 484
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: SwOS version 2.5 released!

Fri Sep 15, 2017 6:23 pm

I would think you could enable IGMP-Snooping on an individual port but it looks like you need to be on a VLAN, is this a mistake?
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: SwOS version 2.5 released!

Fri Sep 15, 2017 7:05 pm

when will DHCP option 82 be implemented for ROS?
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: SwOS version 2.5 released!

Fri Sep 15, 2017 7:54 pm

*) CRS326 & CRS317: added support for DHCP & PPPoE snooping and injecting option 82 (Intermediate Agent info)
TLDR; break this single line down into what changed for DHCP and what changed for PPPoE specifically.

Intermediate Agent Info is specific to PPPoE. Please elaborate on the DHCP portions of the comment. Does this adjust the existing behavior of option 82 in DHCP that reported only the entire bridge to the actual port now? Is this a subscriber id option implementation in DHCP?
 
warheat1990
just joined
Posts: 6
Joined: Mon Sep 04, 2017 6:20 pm

Re: SwOS version 2.5 released!

Sat Sep 16, 2017 9:05 am

Can someone give me an instruction how to downgrade firmware version for SwOS? Is it just the same as upgrade (download the file and use it in the web GUI)?

So today I update my Mikrotik switch from v2.4 to v2.5 and notice that my PS4 no longer has internet connection (it works just fine before this update). My network diagram is something like this:

pfSense -> Mikrotik Switch (CSS326-24G-2S+) -> patch panel -> keystone jack -> TP-Link unmanaged switch (SG108)

There are PC, Raspberry Pi, laptop, and PS4 connected via ethernet cable under this TP-Link unmanaged switch. And every device seems to work just fine except PS4. So I begin to troubleshoot.

1. Use different cable -> not working
2. Use other port -> not working
3. Use static IP under PS4 setting (but still connected to unmanaged switch) -> works
4. Connect the PS4 directly to Mikrotik switch (bypassing the unmanaged switch) -> works

At this point, I'm confused if the problem is my Mikrotik switch or the unmanaged switch, in my test result, it seems like the problem is the unmanaged switch but I don't have this issue before I update my Mikrotik switch and other device (except PS4) seems to be working just fine under this unmanaged switch. How do I troubleshoot to make sure which one is the issue? I already tried to restart everything (pfSense, Mikrotik switch, unmanaged switch) and still not working. For now, I use static IP address for PS4.

Note: I don't use VLAN or any of these fancy settings.
 
sdot
just joined
Posts: 2
Joined: Sat Sep 16, 2017 3:21 pm

Re: SwOS version 2.5 released!

Sat Sep 16, 2017 3:22 pm

2.5 breaks LAG
All ports in separate LAG groups become the same Trunk - 1 after upgrade to 2.5 causing massive packet loss/drop
2.4 works fine
 
bds1904
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Tue Sep 10, 2013 2:52 am

Re: SwOS version 2.5 released!

Sun Sep 17, 2017 2:35 am

Upgrade 3x CRS326's with no issues.

2.5 working with 803.2ad LAG in passive mode, connected device is a NAS

2.5 Fixed the following issues for me:
  • Issue where switch sometimes wouldn't list hosts
    Now properly reports the FS.com DAC, before a temp and power level would be reported, the DAC does not have this capability
 
sdot
just joined
Posts: 2
Joined: Sat Sep 16, 2017 3:21 pm

Re: SwOS version 2.5 released!

Sun Sep 17, 2017 6:35 am

Upgrade 3x CRS326's with no issues.

2.5 working with 803.2ad LAG in passive mode, connected device is a NAS

2.5 Fixed the following issues for me:
  • Issue where switch sometimes wouldn't list hosts
    Now properly reports the FS.com DAC, before a temp and power level would be reported, the DAC does not have this capability
To clarify LAG is working fine in passive mode , but not in static
 
j8k2u
just joined
Posts: 1
Joined: Mon Sep 18, 2017 7:10 pm

Re: SwOS version 2.5 released!

Mon Sep 18, 2017 7:36 pm

Thanks for the continued work on SWOS!

I did notice a weird issue after upgrading to 2.5 on 2x CSS326-24G-2S+RM units connected together over SFP+ with a pfSense router using IPv6 and IPv4, for some reason I was only getting IPv6 addresses on on both units, however all IPv4 static assignments and existing leases continued to operate. Assuming this has something to do with the new DHCP Snooping feature as all functionality worked after swapping in a non-smart switch for troubleshooting purposes.

Under the DHCP and PPPoE settings, I tried disabling option 82 and ensuring all ports were selected as trusted, this did not resolve the issues so I tried resetting the units back to default then re-configuring them with no improvement (I don't have a lot of custom settings, no VLANs, etc...). Whats odd and makes me think its a DHCP snooping issue, is that when only one unit is plugged in DHCP seems to work again and everything starts getting both IPv4 and IPv6 assignments. None of these issues existed on the the 2.4 firmware version, please let me know if anyone has any ideas because at this point I can't think of anything else to try.

Thanks!
 
Siemir
just joined
Posts: 1
Joined: Tue Sep 19, 2017 10:03 am

Re: SwOS version 2.5 released!

Tue Sep 19, 2017 10:32 am

Don't know if it's right place to say it, but the 2.5 SwOS has critical bug regarding DHCP/PPPoE Snooping on CSS326 and because of it it is not possible to disable this feature. In my case it breaks DHCP/PPPoE completely, because CSS is sending back duplicated requests on uplink. So if anyone is using DHCP/PPPoE in his network, I strongly advice against upgrading to 2.5, also if you do upgrade downgrade to 2.4 works flawlessly.
 
rockzo
just joined
Posts: 1
Joined: Sun Sep 24, 2017 3:29 pm

Re: SwOS version 2.5 released!

Sun Sep 24, 2017 3:41 pm

I have a CRS317-1G-16S+
Default firmware 2.3p, i upgrade to 2.5
After upgrading i can't change password.
I use for "old password' a lot variations (empty field, admin, etc).
Accordingly, I can only log in as admin and with empty password.
Help
 
ruffy91
just joined
Posts: 2
Joined: Sun Sep 24, 2017 8:53 pm

Re: SwOS version 2.5 released!

Sun Sep 24, 2017 8:57 pm

Don't know if it's right place to say it, but the 2.5 SwOS has critical bug regarding DHCP/PPPoE Snooping on CSS326 and because of it it is not possible to disable this feature. In my case it breaks DHCP/PPPoE completely, because CSS is sending back duplicated requests on uplink. So if anyone is using DHCP/PPPoE in his network, I strongly advice against upgrading to 2.5, also if you do upgrade downgrade to 2.4 works flawlessly.
You can configure it undewr System -> DHCP & PPPoE Snooping
Uncheck "Add Information option" and it does seem to work again.
Can anyone explain what this does?
 
administracyjny
just joined
Posts: 5
Joined: Fri Sep 15, 2017 12:42 pm

Re: SwOS version 2.5 released!

Mon Sep 25, 2017 10:42 am

I have the same problem but with "CSS106-5G-1S" It's new switch, no changed default password, I only update to 2.5.
Image
 
SPAWNGLEE
just joined
Posts: 1
Joined: Tue Sep 26, 2017 10:00 am

Re: SwOS version 2.5 released!

Tue Sep 26, 2017 10:05 am

Yesterday I noticed that there was an upgrade available for my two CSS326 switches. As 2.4 (my first experience with Mikrotik software) has been super reliable for me, I upgraded without a second thought. Unfortunately, almost immediately, DHCP stopped working. Despite just having upgraded the switches, I did not realize they might be the source. I rebooted my vSphere server, pfSense, turned DHCPd on and off, restarted DNS, rebooted my WAN devices, reseated the lan cables in my wireless equipment and then gave up. I woke up this morning to find that still nothing received DHCP only then did I think to read this thread. After downgrading to 2.4, which luckily still had sitting in my downloads folder, everything is well again.

TL;DR
Upgraded to 2.5. DCHP stopped working.
Downgraded to 2.4. Everything started working again.
 
storp
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Nov 24, 2015 2:53 pm

Re: SwOS version 2.5 released!

Tue Sep 26, 2017 12:14 pm

I have the same problem but with "CSS106-5G-1S" It's new switch, no changed default password, I only update to 2.5.
Image
I have this exact same problem with a brand new CSS326-24G-2S+. I can't change the default empty password.
 
Wolfilux
just joined
Posts: 3
Joined: Thu Sep 28, 2017 4:10 pm

Re: SwOS version 2.5 released!

Thu Sep 28, 2017 4:18 pm

Hi,

I'm also experiencing problems with DHCP since upgrading to SWOS 2.5.

I want to try an downgrade to 2.4 but I can't find the file for download. Can anybody help me with that?

Thanks in advance!
 
Wolfilux
just joined
Posts: 3
Joined: Thu Sep 28, 2017 4:10 pm

Re: SwOS version 2.5 released!

Fri Sep 29, 2017 3:56 pm

Alright. Found the firmware file online and downgraded the switch to 2.4. Now DHCP works again!
 
warheat1990
just joined
Posts: 6
Joined: Mon Sep 04, 2017 6:20 pm

Re: SwOS version 2.5 released!

Fri Sep 29, 2017 5:39 pm

Hi,

I'm also experiencing problems with DHCP since upgrading to SWOS 2.5.

I want to try an downgrade to 2.4 but I can't find the file for download. Can anybody help me with that?

Thanks in advance!
I have SwOS v2.4 for CSS326, you can download it here. https://ufile.io/dxjfa

It's my first MikroTik device and I upgrade to v2.5 without thinking much and I'd have to say it's going to be the first and the last time I will ever buy from MikroTik, I think they make good product and their price is very competitive but the firmware (I don't mind outdated UI) is a joke, how is it even possible a critical bug like broken DHCP can be missed? Not to mention other bug like changing password. Okay sure it happens sometimes but it's been 2 weeks and still no word from MikroTik about this issue.

I posted the broken DHCP issue 2 weeks ago and it never receive any response

viewtopic.php?f=17&t=125692

at the time I'm still not 100% sure if the issue is the MikroTik switch, TP-Link switch, or my Unifi AP. I contacted Ubiquiti live chat and they help me track down the issue and it turned out the culprit is my CSS326, I checked the download page to download the previous version because I want to downgrade but to my surprise I can't find it, luckily I have backup. I posted another thread the day after to warn people not to upgrade to v2.5

viewtopic.php?f=17&t=125714

no response so far (surprise!), I also saw someone asking about where they can get SwOS archive a week ago, also no response

viewtopic.php?f=17&t=125896

I sent an email to MikroTik yesterday, let's see if I'd get a response, finger crossed since the support instruction page is filled with "read the doc, read the FAQ, read the forum, support only for paying customers, you should have basic networking knowledge, contact your reseller first", and that to me sounds like they don't want you.

I think I had better support from TP-Link.
 
Wolfilux
just joined
Posts: 3
Joined: Thu Sep 28, 2017 4:10 pm

Re: SwOS version 2.5 released!

Fri Sep 29, 2017 6:58 pm

Thank you very much for the download link.

I can fully understand you dissatisfaction with Mikrotik. I'm thinking the same way. DHCP is essential!
 
hubber
just joined
Posts: 4
Joined: Wed Nov 11, 2015 12:26 am

Re: SwOS version 2.5 released!

Fri Sep 29, 2017 7:50 pm

At once and the question, and the answer.
There are 3 switches
CSS326-24G-2S +
Between them the optics on s + 85
dhcp server - 3011

After updating 3011 to bugfix 6.38.7 and switches to swos 2.5, the whole network turned into a pumpkin.
On dhcp everything was in error. dhcp offering lease without success, probably loop
Typically, these errors are treated by installing the poppy on the bridge or disabling rstp, but in this case nothing helped.
Especially badly felt grandstream phones with mac 00: 0B: 82:
Spent two days on diagnostics, wireshark, searching for errors on ports, loops and so on.
Decision
Rollback of all 3 switches on swos 2.0 thanks to people for the link https://download2.mikrotik.com/swos/2.0 ... 26-2.0.bin
Rollback of the dhcp router to 6.37.5

That's all I wanted to say!
 
andriys
Forum Guru
Forum Guru
Posts: 1179
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: SwOS version 2.5 released!

Sat Sep 30, 2017 4:19 pm

but it's been 2 weeks and still no word from MikroTik about this issue
Here's a rhetorical question, but still... Have you written to support@ yet?

For your information, this is a user forum (i.e. a place where users share their experience and help each other). This is NOT a support platform. Mikrotik staff may (and sometimes do) answer the questions here, but do not expect them to answer all the questions here. If you need an official reaction to your problem- always write to support@.
 
blingblouw
Member Candidate
Member Candidate
Posts: 271
Joined: Wed Aug 25, 2010 9:43 am

Re: SwOS version 2.5 released!

Sat Sep 30, 2017 6:22 pm

but it's been 2 weeks and still no word from MikroTik about this issue
Here's a rhetorical question, but still... Have written to support@ yet?

For your information, this is a user forum (i.e. a place where users share their experience and help each other). This is NOT a support platform. Mikrotik staff may (and sometimes do) answer the questions here, but do not expect them to answer all the questions here. If you need an official reaction to your problem- always write to support@.

While that is the "official" stance, I would be very surprised to learn that Mikrotik don't know about this. This is an "official" thread started by them literally regarding the firmware update. Take a look at the main RouterOS RC thread, they are involved, yet there is literally zero comment from them regarding SOWS
 
warheat1990
just joined
Posts: 6
Joined: Mon Sep 04, 2017 6:20 pm

Re: SwOS version 2.5 released!

Sun Oct 01, 2017 8:24 am

but it's been 2 weeks and still no word from MikroTik about this issue
Here's a rhetorical question, but still... Have you written to support@ yet?

For your information, this is a user forum (i.e. a place where users share their experience and help each other). This is NOT a support platform. Mikrotik staff may (and sometimes do) answer the questions here, but do not expect them to answer all the questions here. If you need an official reaction to your problem- always write to support@.
Of course I already did, nothing so far.
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: SwOS version 2.5 released!

Mon Oct 02, 2017 3:13 pm

Hello, we are working on DHCP issues in SwOS v2.5, the new version with fixes is planned soon.
 
plankanater
Member Candidate
Member Candidate
Posts: 166
Joined: Wed Mar 14, 2012 3:56 am

Re: SwOS version 2.5 released!

Mon Oct 02, 2017 5:03 pm

Can we get a fix for the password issue or can you post 2.4 back online. It has made it so I can not roll out any new switches.
 
administracyjny
just joined
Posts: 5
Joined: Fri Sep 15, 2017 12:42 pm

Re: SwOS version 2.5 released!

Fri Oct 06, 2017 1:39 pm

I found way. You need to downgrade to 2.4, set the password and update again to 2.5. It works for me.
 
plankanater
Member Candidate
Member Candidate
Posts: 166
Joined: Wed Mar 14, 2012 3:56 am

Re: SwOS version 2.5 released!

Fri Oct 06, 2017 4:40 pm

Yeah, I know that works but I am not sure why they would leave a firmware posted with such a major bug that they are aware of. At least without posting the 2.4 firmware online with instructions to upgrade to that first.
 
coroslav
just joined
Posts: 17
Joined: Sat Oct 04, 2014 11:44 am

Re: SwOS version 2.5 released!

Sat Oct 07, 2017 4:05 pm

This update v2.5 swOS, broken my TV connection, something is blocking channel selection/changes/opening, probably some manycast/multicast stream.
I know only the fact that TV do show EPG program guide, but no video nor audio.
If I connect it using another switch (rb951g) and start watching a channel X, then remove rb951g and plug CSS106-5G-1S instead,
the TV keeps playing that single channel X. Tuning up or down result in black screen (but correct EPG guide), but retutned to channel X it play as before.
Of course after TV restart nothing works.
DOWNGRADED to v2.3 swOS and the TV plays everything well again..

viewtopic.php?f=17&t=123192#p622140
 
mducharme
Trainer
Trainer
Posts: 797
Joined: Tue Jul 19, 2016 6:45 pm

Re: SwOS version 2.5 released!

Sun Oct 08, 2017 1:19 am

I am still on 2.4 and given experiences above don't want to risk upgrading to 2.5. I did notice an issue not mentioned, even though 64-bit SNMP counters seem to be accessible, I am seeing rollover on the 64-bit counter OID consistent with a 32-bit counter. Has this been resolved? Our SNMP graphing is wacky without 64-bit counters.
 
junnuvi
just joined
Posts: 1
Joined: Tue Oct 10, 2017 9:17 am

Re: SwOS version 2.5 released!

Tue Oct 10, 2017 9:21 am

This update v2.5 swOS, broken my TV connection, something is blocking channel selection/changes/opening, probably some manycast/multicast stream.
I know only the fact that TV do show EPG program guide, but no video nor audio.
If I connect it using another switch (rb951g) and start watching a channel X, then remove rb951g and plug CSS106-5G-1S instead,
the TV keeps playing that single channel X. Tuning up or down result in black screen (but correct EPG guide), but retutned to channel X it play as before.
Of course after TV restart nothing works.
DOWNGRADED to v2.3 swOS and the TV plays everything well again..

viewtopic.php?f=17&t=123192#p622140
I have same problem with 2.5. With version 2.4 everything work fine but right after upgrading to 2.5 IPTV not working anymore. EPG and menu works fine (=unicast traffic) but picture and sound is missing (sound/picture=multicast).
 
storp
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Nov 24, 2015 2:53 pm

Re: SwOS version 2.5 released!

Tue Oct 10, 2017 9:45 am

I use 2.5 on two switches and have the "not able to change password bug" and also discovered that DHCP doesn't work, the DHCP server recieves the request and offers a lease but the client doesn't recieve that. So my question is since I've given up on 2.5, should I downgrade to 2.4 or 2.3? Any other bugs I might encounter by doing that?
 
kr0y
just joined
Posts: 3
Joined: Mon Oct 16, 2017 10:09 pm

Re: SwOS version 2.5 released!

Mon Oct 16, 2017 10:12 pm

Any way to get version 2.4 for CRS317? I just got this switch and am stuck in a bit of a hole.

2.3p (the recovery version), bootloops with more than a few SFP+ modules plugged in. 2.5 has the DHCP bug, and unfortunately disabling the option doesn't seem to do anything.

I can't seem to track down a copy of the 2.4 firmware so I can use this switch until the next version comes out.
 
storp
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Tue Nov 24, 2015 2:53 pm

Re: SwOS version 2.5 released!

Tue Oct 17, 2017 9:56 am

Reverting to 2.4 on my two CSS326 has fixed my issues (DHCP and not being able to change password).
 
becs
MikroTik Support
MikroTik Support
Topic Author
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: SwOS version 2.5 released!

Tue Oct 17, 2017 2:50 pm

Version 2.6 of SwOS has been released:
viewtopic.php?f=21&t=126752

Who is online

Users browsing this forum: No registered users and 8 guests