Page 1 of 1

v6.40.5 [current]

Posted: Tue Nov 07, 2017 2:28 pm
by strods
To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.

What's new in 6.40.5 (2017-Oct-31 13:05):

*) certificate - fixed import of certificates with empty SKID;
*) crs3xx - fixed 100% CPU usage after interface related changes;
*) firewall - do not NAT address to 0.0.0.0 after reboot if to-address is used but not specified;
*) ike1 - fixed crash after downgrade if DH groups 19,20,21 were used for phase1;
*) ike1 - fixed RSA authentication for Windows clients behind NAT;
*) ipsec - fixed lost value for "remote-certificate" parameter after disable/enable;
*) ipv6 - fixed IPv6 addresses constructed from prefix and static address entry;
*) log - properly recognize MikroTik specific RADIUS attributes;
*) lte - do not reset modem when it is not possible to access SMS storage;
*) lte - fixed modem initialization after reboot;
*) lte - fixed PIN option after setting up the band;
*) sms - include time stamps in SMS delivery reports;
*) sms - properly initialize SMS storage;
*) snmp - fixed "/system license" parameters for CHR;
*) winbox - allow shorten bytes to k,M,G in Hotspot user limits;
*) wireless - fixed rate selection process when "rate-set=configured" and NV2 protocol is used;

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 9:18 pm
by wencs
tool sms inbox message error
all message recib error
CCR1009-8G-1S-1S+
May/11/2001 07:15:07 GMT +11 a ekKECAdKGSESIC$o @@@@@@
SL@@@@@@d$@@@@@@@Xe@@@@@@@@*CUw@@@@@Ru=o$@@@@oae@@@@@@L;D@@@@@@0:haA
@@@@(@@@@@@

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 11:11 pm
by ErfanDL
The rb2011uias2hnd can not boot after upgrade from 6.40.4 to 6.40.5 !!!

Sent from my C6833 using Tapatalk

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 11:21 pm
by c400
just updated from 6.40.4 to 6.40.5 and i hear a loop reboot with a periodic beep sound!
HELP! What should i do to recover my router?!

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 11:30 pm
by strods
Please connect serial cable to your router, open serial console and power on the router. Send whole serial output to support@mikrotik.com. Most likely problem is not related to specific RouterOS version and is caused by some kind of issue during upgrade process.

Also you can try to power off router, press and hold reset button. power router on and release the button. If router now boots up, then run command "/system routerboard upgrade" and then router should boot up normally after upcoming reboots.

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 11:49 pm
by c400
"Also you can try to power off router, press and hold reset button. power router on and release the button."
tried, no luck

I do not have any serial cable. What should i do? (hAP AC was bought a week ago)
Tried patch cord + netinstall... The device reboots and invisible in Netinstall app

Re: v6.40.5 [current]

Posted: Tue Nov 07, 2017 11:53 pm
by WirelessRudy
*) wireless - fixed rate selection process when "rate-set=configured" and NV2 protocol is used;

When (version) did this go wrong and what was exactly the issue?

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:25 am
by sizeofbool
Whoa! I think I will pass on upgrading to this version...
I haven't experienced firmware\BIOS update failure in ages. How this version passed QA tests? :(

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:27 am
by strods
Installed RouterOS version does not in any way affect Netinstall process. Ether boot happens before you have reached RouterOS. If you can not Netinstall device then problem is either with Netinstall (recommended to test with another router), RouterBOOT or hardware.

Wireless fix is made for configurations where nv2 and configured rates are used. If you experienced system lock-up or reboots, then this fix will most likely will solve the problem.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:31 am
by c400
it happened right after upgrade to 6.40.5
no other changes were done. What could have happened?!

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:32 am
by irghost
cAP Lite died after upgrade
I have Tried Netinstall but router does not shown in List also I have pushed reset-button for more than 300sec
CAP-LED and WLAN-LED are just Blinking

There is no problem with Netinstall (tested)

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:59 am
by Cha0s
Upgraded various Routerboards (RB433AH, SEXTANT-G, cAP-Lite, mAP-Lite, hAP-Lite, SXT, Groove, RB3011, RB2011, RB1200, RB850Gx2, x86).

No problems so far :)

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 1:00 am
by c400
Updated through Winbox, pressed "Download and install". Previous version was 6.40.4. Connection was over cable. Maybe it depends on this?

What was already done:
1) Tried reset to default config - NO RESULT
2) Tried NetInstall 6.40.5/6.40.4/6.38 - NO RESULT (device is not visible)
3) Tried changing from 100Mbps to 1Gbps speed (thought it may be the reason. Based on RouterBOOT changelog: https://wiki.mikrotik.com/wiki/RouterBOOT_changelog) - NO RESULT (device is not visible)
4) Tried holding reset for more then 300 sec (based on this manual: https://wiki.mikrotik.com/wiki/Manual:R ... bootloader) - NO RESULT. Router reboots even before 300 sec are passed.

Just found those devices in my collection. Would it be enough to get any useful information about the reasons of such disaster? I am interested to solve this problem as fast as i can (if i can :)). - NO RESULT (device is not visible)
Image

Is there anybody who will guide me through the process?

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 9:37 am
by floeff
No problems on 3x cap 2n, 2x 951g-2hnd, 1x map lite and 1x ccr 1009. All from 6.40.4 to 6.40.5, with 3.41 RouterBOOT.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 9:43 am
by eriitguy
Hello, c400!
Is there anybody who will guide me through the process?
May you try to follow steps from this video https://www.youtube.com/watch?v=GIijZ6_i55g in order to Netinstall your device?


Thank you!

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 9:54 am
by c400
Done Netinstall based on your video manual. No luck. Device is not shown in the app.
Brand new hAP AC (Bought 28.10.17) became a brick. I am sure it is something with firmware ore bad circumstances

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:24 am
by strods
If you are not able to Netinstall the device, then maybe you have protected bootloader enabled?
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:25 am
by mszru
Hi,

I've upgraded RouterOS successfully on hAP lite, hEX and hAP ac from 6.40.4 to 6.40.5.
All devices had RouterBOARD firmware 3.41 before the upgrade.

So far so good...

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:37 am
by irghost
Updated through Winbox, pressed "Download and install". Previous version was 6.40.4. Connection was over cable. Maybe it depends on this?

What was already done:
1) Tried reset to default config - NO RESULT
2) Tried NetInstall 6.40.5/6.40.4/6.38 - NO RESULT (device is not visible)
3) Tried changing from 100Mbps to 1Gbps speed (thought it may be the reason. Based on RouterBOOT changelog: https://wiki.mikrotik.com/wiki/RouterBOOT_changelog) - NO RESULT (device is not visible)
4) Tried holding reset for more then 300 sec (based on this manual: https://wiki.mikrotik.com/wiki/Manual:R ... bootloader) - NO RESULT. Router reboots even before 300 sec are passed.

Just found those devices in my collection. Would it be enough to get any useful information about the reasons of such disaster? I am interested to solve this problem as fast as i can (if i can :)). - NO RESULT (device is not visible)
Image

Is there anybody who will guide me through the process?
Me too
same problem in cAP lite

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:46 am
by c400
If you are not able to Netinstall the device, then maybe you have protected bootloader enabled?
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader
If it is disabled by default, then i have not enabled it.
Any other suggestions? I do need help!

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:54 am
by lopar
L2TP/Ipsec died after ugrading from 6.40.4
Now I have a bunch of "possible wrong password" errors.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 11:03 am
by c400
WOW!!! i managed to see my device in NetInstall, but installing the package seems to be impossible due to looping restarts

UPD: Victory!

Here is the way i managed to get into Netinstall mode!!! It is not in the manual!

Tested on hAP AC

First way (do not remeber wich of them did really worked for me) But simply press and wait DID NOT WORKED in any combinations
1) Plug out power
2) Press RESET and hold, then plug in POWER
3) Continue holding
4) Watch SFP led blinking
5) Release RESET immediately
6) immediately start pressing RESET button fast and often

Second way:
1) Plug out power
2) Press RESET and hold, then plug in POWER
3) Continue holding
4) Watch SFP led blinking
5) Watch SFP led to start shine/not blinking
6) Release RESET immediately
7) immediately start pressing RESET button fast and often

Only after that i was able to write firmware. (Used NetInstall 6.40.5 and firmware 6.40.5)

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:21 pm
by lopar
Found possible problem point. I have two almost similar ipsec peers:
 8   R address=::/0 passive=yes auth-method=pre-shared-key secret="AAAAAAAA" generate-policy=port-strict 
       policy-template-group=l2tp exchange-mode=main-l2tp send-initial-contact=yes nat-traversal=yes proposal-check=obey 
       hash-algorithm=sha1 enc-algorithm=aes-256,aes-192,aes-128,3des dh-group=modp2048,modp1024 lifetime=1d dpd-interval=2m 
       dpd-maximum-failures=5 

 9  DR address=::/0 passive=yes auth-method=pre-shared-key secret="BBBBBBBB" generate-policy=port-strict 
       policy-template-group=default exchange-mode=main-l2tp send-initial-contact=yes nat-traversal=yes proposal-check=obey 
       hash-algorithm=sha1 enc-algorithm=aes-256,aes-192,aes-128,3des dh-group=modp2048,modp1024 lifetime=1d dpd-interval=2m 
       dpd-maximum-failures=5
One was created by hand while configuring L2TP (8), another is dynamic one, created by configuring site to site vpn tunnel (9). It seems, that now L2TP tunnels (8) are using secret from site to site (9) to connect.

Is there any way to fix the problem, because 6.40.4→6.40.5 upgrade caused the problem, but downgrading back didn't solve it at all.

found: typo in ipsec secret. but it's kinda strange, because everything worked with this typo for about more than a year, and crashed just after this update.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 12:22 pm
by WirelessRudy
Wireless fix is made for configurations where nv2 and configured rates are used. If you experienced system lock-up or reboots, then this fix will most likely will solve the problem.
Well, 80% of my network runs 6.40.4 and 95% of that has fixed configured rates across a whole range of different devices but so far never got the attention to strange system lock-up or reboots..
I am referring some 800 devices here....

So I don't know...

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 1:26 pm
by BartoszP
Upgraded couple of RB951G + 2 x RB1100AHx4 Dude .... seem to be working since night.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 1:49 pm
by mrz
Found possible problem point. I have two almost similar ipsec peers:
It is not a valid configuration. You cannot predict which peer will be used. Probably in older version static peer was added later so it was not used. After reboot/upgrade static peer became more preferred.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 1:55 pm
by irghost

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 2:20 pm
by c400
try my way of getting Netinstall work.

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 10:56 pm
by davidreaton
3 times in the past 18 months I've bricked one of my hAP AC units during the upgrade process. Now, it's happened with the 6.40.3 to 6.40.5 uograde.

Downloaded latest stable config. Copied .NPK file to the 'file' area using Winbox. Rebooted the unit, and it started in looping reboots. Invisible in WinBox. Each time I was unable to recover using NetInstall. Invisible in NetInstall. This has NEVER happened when I upgraded the single band 952 units. Each time I was able to RMA the hAP AC for a new one. Since this happened only with the hAP AC units, I wonder if something is up with this hardware? Any suggestions?

I see lots of forum posts about bricked routers amd looping restarts after upgrading to stable firmware.

Some help from Mikrotik would be welcome.

Regards,
Dave

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 11:00 pm
by mbt
[@kavir@Access-CoreRouter-KavirNet] > dude
[@kavir@Access-CoreRouter-KavirNet] /dude> pri
enabled: yes
data-directory: dude
status: db failure: constraint failed: stopped
[@kavir@Access-CoreRouter-KavirNet] /dude>

hi
our core router ccr1009 has stop working and after i split power cable its come back but the dude has stop working and in new terminal i have this error
what should i do ?

Re: v6.40.5 [current]

Posted: Wed Nov 08, 2017 11:10 pm
by jarda
Don't you use internal flash as dude storage, do you?

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 4:54 am
by normanz
I am having the exact same problem - upgraded a client's hAP ac from 6.40.4 to 6.40.5 and it gets stuck in a boot loop.

I am unable to recover it using any of the techniques listed in this thread - I cannot get it into Netinstall mode (I have successfully done this several times before with other Mikrotik hardware) no matter what I do. I also tried the 300-second reset button hold technique - it has no effect and the hAP ac continues to boot loop as if I hadn't pressed the button.

I realize I should have checked to see if anyone was having difficulties with v6.40.5 before I started the package upgrade process, but I've never had this problem with any Mikrotik gear before.

Any ideas? I consider myself a fairly savvy user and support a number of offices with Mikrotik gear.

thanks!

Norm

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 12:24 pm
by c400
I am having the exact same problem - upgraded a client's hAP ac from 6.40.4 to 6.40.5 and it gets stuck in a boot loop.

I am unable to recover it using any of the techniques listed in this thread - I cannot get it into Netinstall mode (I have successfully done this several times before with other Mikrotik hardware) no matter what I do. I also tried the 300-second reset button hold technique - it has no effect and the hAP ac continues to boot loop as if I hadn't pressed the button.

I realize I should have checked to see if anyone was having difficulties with v6.40.5 before I started the package upgrade process, but I've never had this problem with any Mikrotik gear before.

Any ideas? I consider myself a fairly savvy user and support a number of offices with Mikrotik gear.

thanks!

Norm
do not capitulate! :)
i was trying for 2 hours to see my hap AC in Netinstall tool. And suddenly succeeded!

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 12:53 pm
by upower3
Just out of curios: as i tried to upgrade MT under 6.39.1 with "/system package update install" it upgraded to 6.40.4. After the upgrade and reboot I issued the same command and it offered me 6.40.5.

So the whole way was: 6.39.1 -> 6.40.4, and the 6.40.4 -> 6.40.5. Why it won't tried to do the whole process in one step, like 6.39.1 -> 6.40.5?

Strange for me!

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 1:09 pm
by msatter
Maybe wise to put an hold or warning for updating the Hap AC to 6.40.5 because of problems written about earlier.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 1:11 pm
by msatter
Just out of curios: as i tried to upgrade MT under 6.39.1 with "/system package update install" it upgraded to 6.40.4. After the upgrade and reboot I issued the same command and it offered me 6.40.5.

So the whole way was: 6.39.1 -> 6.40.4, and the 6.40.4 -> 6.40.5. Why it won't tried to do the whole process in one step, like 6.39.1 -> 6.40.5?

Strange for me!
Maybe the new naming for the firmware blocks, a direct update to the last stable.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 1:15 pm
by upower3
Maybe the new naming for the firmware blocks, a direct update to the last stable.
Noop, the f/w still named as 3.41, not this weird new way ) And this was current branch all the way as I applied the updates.

This was my handy "play with" router, no problem, but should it be remote one this can be a problem as each extra reboot is an extra risk.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 1:17 pm
by Siona
I've just upgraded 433gl, 850, hap ac, 1009 everything is fine. Process went smoothly.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 1:28 pm
by facubertran
Hi. I have several CHR and in some I was able to update without problems, but in others I downloaded the package, it restarted but when starting again it continues with version 6.40.4. Try downloading the package from the CHR and downloading it from the page and copying it to the CHR. Same mistake.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 2:31 pm
by Chupaka
but in others I downloaded the package, it restarted but when starting again it continues with version 6.40.4. Try downloading the package from the CHR and downloading it from the page and copying it to the CHR. Same mistake.
Check the Log. Seems like you have expired license.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 7:46 pm
by Darryl
After testing with RB750 and RB3011, the upgrades are ok, but going from 6.39 to 6.40.5 reveals a problem on MLPPP. I'm using 2 DSL modems. If one of the modems loses its physical layer, such as loss of power or loss of ADSL sync, the MLPPPoE bundle gets confused and does not bring the link down to 1 line. If the second link is restored the bundle still stays degraded and doesn't seem to recognize that the second link is back. Its just packet loss. Resetting both links at the same time seems to be ok as MLPPPoE will properly recover.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 8:06 pm
by nightcom
Generally I got 4 units: RB3011, RB2011, RB750Gr3 and CRS326 only RB3011 and CRS326 upgraded with no problem. RB2011 in loop (I already did Netinstall and unit works fine (downgraded to 6.38.7 just looking for stable version and on forum I found out that people recommend that version), RB3011 was upgraded with no problem but still somehow it was unstable so downgraded to 6.38.7. CRS326 running with no problem till now but not much happening there, its working as switch with no features. RB750Gr3 is down, well it boot to OS but not showing any OS version so tomorrow I will try first copy file with lower version and if this will not help Netinstall also....so to much trust on MikroTik from my side, next time I will wait at least week to see if anyone will have issues during upgrade.

Re: v6.40.5 [current]

Posted: Thu Nov 09, 2017 10:05 pm
by indjov
Some of you can confirm that in NetWatch Interval time does not work properly.
I`m using NetWatch to alarm me when of my server down and i`m using this code.
:local result [/ping 200.200.200.201 count=15]
:global status
:if ($result = 15 && $status != true) do={
  tool sms send usb2 phone-number=8888888 message="SERVER UP"
:log info "UP SMS"
  :set status true
} else={
  :if ($result = 0 && $status != false) do={
    tool sms send usb2 phone-number=8888888 message="SERVER DOWN"
:log info "DOWN SMS"
    :set status false
  }
}
21:58:23 system,info netwatch host modified by admin 
21:58:41 script,info UP SMS 
21:59:49 system,info netwatch host modified by admin 
22:00:08 script,info DOWN SMS 
admin@Fa1c0n] /tool netwatch> print 
Flags: X - disabled 
 #   HOST                 TIMEOUT              INTERVAL             STATUS  SINCE               
 0   200.200.200.200       1s                   1m                   up      nov/07/2017 20:45:00
 1   200.200.200.201       1s                   1m30s                up      nov/09/2017 21:59:49
 2   200.200.200.202       1s                   3m                   up      nov/07/2017 20:51:20
You can see into the log that intervel time did`t match from the time where i set in NetWatch
Any idea why that happend

Re: v6.40.5 [current]

Posted: Fri Nov 10, 2017 9:35 am
by LetMeRepair
tool sms inbox message error
all message recib error
CCR1009-8G-1S-1S+
May/11/2001 07:15:07 GMT +11 a ekKECAdKGSESIC$o @@@@@@
SL@@@@@@d$@@@@@@@Xe@@@@@@@@*CUw@@@@@Ru=o$@@@@oae@@@@@@L;D@@@@@@0:haA
@@@@(@@@@@@
Same here, SMS text garbled on RB411UAHR (factory reset done after upgrade 6.40.5), and also on router upgraded from 6.40.4 to 6.40.5 , Sierra Wireless MC8792V

"Fixed in next version"? Or should i upload supout?


UPDATE: never mind, works again in latest RC

Re: v6.40.5 [current]

Posted: Fri Nov 10, 2017 1:43 pm
by mlenhart
Hello, just FYI, I have upgraded all of my RBs successfully on 1st try

List of RBs:
- RB433AH - previous version was 6.39.1 with factory default firmware
- RB951G-2HnD - previous version was 6.40.4 with 3.41 firmware
- RB2011UiAS-2HnD - previous version was 6.40.4 with 3.41 firmware

Re: v6.40.5 [current]

Posted: Fri Nov 10, 2017 9:06 pm
by docmarius
Also my report:
CCR1009-1C-7G-1S-1S+ including Dude on SD, 922UAGS-5HPacD (NetMetal5) + R11e-5Hnd, LHG5, 960PGS (hEX POE), OmniTIK UPA-5HnD, 921GS-5HPacD r2 (mANTBox), 951G-2HnD, 450G, 750GL and 911G-5HPnD (QRT5)
all upgraded from 6.40.4 without incidents.

Re: v6.40.5 [current]

Posted: Sat Nov 11, 2017 1:12 am
by nightcom
Today I uploaded on all my units via ftp or Winbox and all of them upgraded and working with no problems :) anyway I love those units that there are no problems with recovering them
Units that I upgraded you can find in my sign

Re: v6.40.5 [current]

Posted: Sun Nov 12, 2017 12:00 pm
by cflee
Can I report regression present now, but also traced back to earlier version?

Problem:
When using wireless interface in mode=station-pseudobridge-clone, bridged to ether1, infinite loop of "lost connection, found address to clone" is observed since v6.37 to v6.40.5. Naturally, the single device connected to ether1 does not have network connectivity, regardless of whether it tries to obtain address via DHCP, nor is it pingable with a static IP.

Before v6.37, pseudobridge-clone mode works as expected using exactly the same config.

Unfortunately, I cannot use station-wds or station-bridge mode as the other end is not a Mikrotik device, so I need pseudobridge-clone to work.

Hardware tested with:
hAP lite

Versions tested:
6.40.5 (current) - broken
6.40.4 (current) - broken
6.39.3 (bugfix) -broken
6.38.5 (current) - broken
6.37.3 (current) - broken
6.37.0 (current) - broken
6.36.4 (bugfix) - working
6.36.3 (current) - working
6.33.5 (current) - working

I have supout.rif file for 6.36.4, 6.37 and 6.40.5 if support would like to inspect them.

The device is fully Netinstall for each version, using this configure file:

Code: Select all

# jan/02/1970 00:35:16 by RouterOS 6.33.5
/interface bridge
add name=bridge1
/interface wireless security-profiles
add authentication-types=wpa2-psk eap-methods="" management-protection=allowed \
mode=dynamic-keys name=LLP supplicant-identity=""
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n disabled=no frequency=auto \
mode=station-pseudobridge-clone security-profile=LLP ssid=LLP \
wireless-protocol=802.11 wps-mode=disabled
/interface bridge port
add bridge=bridge1 interface=wlan1
add bridge=bridge1 interface=ether1
/ip cloud
set update-time=no
/ip service
set telnet disabled=yes
set ftp disabled=yes
set api disabled=yes
set api-ssl disabled=yes
Only wpa2-pre-shared-key for security-profiles is removed.

Re: v6.40.5 [current]

Posted: Sun Nov 12, 2017 2:34 pm
by biatche
deleted

Re: v6.40.5 [current]

Posted: Sun Nov 12, 2017 8:16 pm
by docmarius
deleted.

Re: v6.40.5 [current]

Posted: Sun Nov 12, 2017 8:18 pm
by ringlet
I have problem with two rb750GL both of them after upgrade to 6.40.5 are working fine for some time and then just freeze. I see them from other MT in the same bridge but cant log in , then go reboot and work fine for another 12 to 24 hours. Routerboard bios flashed to 3.41 , now I added WD to nearest device but i think that there is something wrong in this situation. Before there was no problem with any of them. Any ideas?

config is really simple one of them is just bridge other one has bridge and 3 vlan's thats all.

Re: v6.40.5 [current]

Posted: Tue Nov 14, 2017 8:43 pm
by Olojto
Hello,
I have hAP ac router, after update from 6.38.x to 6.40.5 the signal of 5GHz not stable, I can connect only with 2GHz channel. When I can see the 5GHz signal it no possible connect to Wi-Fi. I didnt do any changes in setups after update, update was automaticaly from "Quick Set" page.
May be I have to check some setups to restore functionality?

Re: v6.40.5 [current]

Posted: Wed Nov 15, 2017 6:24 pm
by pturkey
I have upgraded to 6.40.5 on (2) DynaDisk 5 and RB2011 also upgraded the firmware. After the upgrade all the RB's where cutting out. Using btest to any upgraded unit shows good speed, then no speed for several seconds intermittently. After downgrading all the speed test was constantly good. It looks like the firmware upgrade was the issue.

Re: v6.40.5 [current]

Posted: Thu Nov 16, 2017 4:09 am
by Azma
Hi,
I just upgrade my client router hap-lite2 and suddenly the connection lost. oh my god, their office is around 58.4KM away.
i wasn't give up, tried to mac telnet and it do the trick, i was able to connect to the terminal.

then i could reach the terminal, ports was running (flag R), but the ip was not working. after some check, port name and physical port wasn't match with the previous condition. why this could be happened?
upgraded from 6.29 to 6.40.5

Re: v6.40.5 [current]

Posted: Thu Nov 16, 2017 7:38 am
by jarda
My similar experience many years ago teached me not to rename the ports. I use comments to mark the ports by their meaning instead and keep the original port names.

Re: v6.40.5 [current]

Posted: Thu Nov 16, 2017 8:35 am
by Azma
My similar experience many years ago teached me not to rename the ports. I use comments to mark the ports by their meaning instead and keep the original port names.
Hi jarda,
Yes, agree. the interface name was remains default. ether1, ether2, ether3, ether4 and only commented on ether2 and ether4.

Re: v6.40.5 [current]

Posted: Fri Nov 17, 2017 7:16 pm
by msatter
need abit of CRS326 help.
...
Could you please use the proper forum sections and not pollute a firmware announcement topic?
Ahhhh the first victim of the new firmware version notation keeping in touch with the RouterOS version notation. ;-)

Re: v6.40.5 [current]

Posted: Mon Nov 20, 2017 12:21 am
by chechito
"Also you can try to power off router, press and hold reset button. power router on and release the button."
tried, no luck

I do not have any serial cable. What should i do? (hAP AC was bought a week ago)
Tried patch cord + netinstall... The device reboots and invisible in Netinstall app

try putting a switch between your laptop nic and the mikrotik device, sometimes netinstall does not work directly to the nic, happened to me last week

connect the RouterBOARD device to power with the RESET button pushed, until you see the device in the Netinstall program interface. Then release the RESET button (around 15 seconds since power on).

Re: v6.40.5 [current]

Posted: Mon Nov 20, 2017 9:13 pm
by soundman73
Updated rb952ui-5ac2nd and https on wifi connection stopped working, even winbox is kicked-out after 2 seconds. But only on wifi (using capsman).
When connected by ether ports, it works just fine, both https and winbox, from wan side is everything accesible also.

Re: v6.40.5 [current]

Posted: Tue Nov 21, 2017 12:42 am
by facubertran
Hello, I have the typical set of rules of drop ssh stages that is shown in the Mikrotik wiki, but I notice that in this version 6.40.5 does not detect when the connection is new, therefore it does not work. I had to make the new connection markup from the "mangle" table because in filter I stop working. Is it just my problem? Is it some new feature that I do not know?

Thank you.

Re: v6.40.5 [current]

Posted: Tue Nov 21, 2017 10:04 am
by upower3
Looks like there is no life in MT kingdom after 6.40.5 and 6.41rc52 - see no changes on download page for days. Hope to see another 6.40.x current before we see "6.41-Revolution-is-here" release!

Re: v6.40.5 [current]

Posted: Wed Nov 22, 2017 4:25 am
by Andrew08
increase in cpu usage to 16% from 1% on RB3011UiAS

Re: v6.40.5 [current]

Posted: Wed Nov 22, 2017 9:59 am
by Cha0s
increase in cpu usage to 16% from 1% on RB3011UiAS
I've also noticed a slight cpu (not as much as yours) increase on CCR1036 after upgrading to 6.40.5 from 6.38.x.

Re: v6.40.5 [current]

Posted: Thu Nov 30, 2017 4:46 pm
by JimmyNyholm
CRS317-1G-16S+ switch menu shows no ports is this normal?

Re: v6.40.5 [current]

Posted: Fri Dec 01, 2017 7:16 pm
by TomosRider
6.35.4-------->6.40.5 with ease.

Re: v6.40.5 [current]

Posted: Sat Dec 02, 2017 4:27 pm
by mhoswa
Hi all

I have the exact same problem after upgrading my RB951G-HnD to 6.40.5. It beeps every 6 seconds. It doesn't get picked up in Netinstall. Also, Windows cannot keep a LAN connection to the RB, it keeps on Identifying and then cable unplugged (loop). This occurs on all ports. Is there any solution to get my RB working again. I have done a reset as well with no success.

Any advise will be appreciated.

Regards
Marnus

Re: v6.40.5 [current]

Posted: Sun Dec 03, 2017 5:51 pm
by highlander
On RB433AH updated from old 6.39.2. It works good but something may be wrong with DHCP6Client.
6.39.2 got address and prefix from my ISP in few seconds.
6.40.5 got nothing and searching forever.
I downgrade to 6.39.3 and problem still the same.
So finaly downgrade back to 6.39.2 and it works fine.

So IPV6 implementation of my ISP may be buggy. Or something wrong with new 6.39.3 to 6.40.5 release.
Can i solve this when i reset RB to default and setup it again from backup ?

Re: v6.40.5 [current]

Posted: Sun Dec 03, 2017 9:41 pm
by highlander
So I upgrade it to 6.40.5 and reset it to default. Then I setup it from backup and it works fine. So best way is BACKUP -> UPGRADE -> RESET TO DEFAULT -> SETUP IT FROM BACKUP.

Re: v6.40.5 [current]

Posted: Mon Dec 04, 2017 12:16 pm
by anuser
I had problems with several Samsung Galaxy S7 Edge devices running Android 7.0 with wAP AC and central CAPSMAN controller running 6.40.5. The smartphones connected, but they had no internet. I updated the wAP AC from 6.40.5 to 6.41rc56. The CAPSMAN controller is still runing at 6.40.5
Now the smartphones can connect and have internet access. So whatever change the latest RC received it would be great if that one could be integrated into the next 6.40.x release.

Re: v6.40.5 [current]

Posted: Mon Dec 04, 2017 2:25 pm
by ibm
Last current has a problem about MTU.
Since I run MPLS I had a problem with a client that has VPLS flapping, after a lot of time throubleshooting I run a ping with don't fragment bit and packet size 1526 and despite the MTU and L2MTU of interfaces were 1600 and MPLS MTU 1530 it fragmented, so I raised to 1700 the L2MTU and it worked. Before the update I haven't had this problem on any network with same configuration.

Re: v6.40.5 [current]

Posted: Mon Dec 04, 2017 2:36 pm
by aditrodostress
after upgraded to 6.40.5 make increase cpu activity sometime always hit 100% usage
rb750r2
rb750gr2
rb450g
rb850gx2

edit: replace rb750r2 & rb750gr2 to rb750gr3, rb450g to rb850gx2, rb850gx2 to ccr1009-7g with same config currently look fine
i think the old hardware doesnt powerfull enough passing high bandwidth

Re: v6.40.5 [current]

Posted: Mon Dec 04, 2017 2:43 pm
by Kraken2k
Updated 2011UiAS-2HnD from 6.40.4 (firmware 3.41) to 6.40.5 - so far no problems.

Re: v6.40.5 [current]

Posted: Wed Dec 06, 2017 9:48 am
by davey
Upgraded my CHR(Dude Server) to 6.40.5 and now the Dude server lost all SVG icons for devices, the background grid map doesn't show and adding it back I get stuck in 'loading' but the images don't show.

Device discovery completes but the topology does not resolve. 1 hour later, still stuck at 'finishing 100% Complete'.

Re: v6.40.5 [current]

Posted: Thu Dec 07, 2017 10:24 pm
by bbs2web
PPP profile 'on-down' commands are run when connection attempts unsuccessful.

We run a simple script to clear connection tracking entries, so that NAT updates correctly when outbound connectivity for VoIP changes. Primary connection is PPPoE and failover is LTE.

Problem is that PPPoE client, when connection attempt times out, always runs 'on-down' commands, instead of only running them if the state changes.

The script:
/sys script
add name=clear_voip_conntrack owner=admin policy=read,write source="/ip firewall connection remove [find dst-address ~ \":4569\"];\r \n/ip firewall connection remove [find dst-address ~ \":5060\"];\r \n"
PPP profile:
/ppp profile
add change-tcp-mss=yes name=voip-reset-conntrack on-down="/sys script run clear_voip_conntrack" on-up="/sys script run clear_voip_conntrack"
/interface pppoe-client
add interface=ether1 keepalive-timeout=60 name=ADSL password=***** profile=voip-reset-conntrack user=user@realm
'/sys script print brief' will show run count incrementing when connect attempt to establish but times out...

Re: v6.40.5 [current]

Posted: Sat Dec 09, 2017 10:58 am
by KBV
------------------
[admin@MikroTik] > /certificate crl print detail
Flags: E - expired, D - dynamic
0 D cert=cert_export_KBV-CHR-CA.crt_0 url="http://192.168.80.251/crl/4.crl" num=0 revoked=0
signature="********"
next-update=dec/09/2018 08:05:30 last-update=dec/09/2017 08:50:44
------------------
Will this happen next year?

version: 6.40.5
architecture-name: x86_64
board-name: CHR

Re: v6.40.5 [current]

Posted: Sat Dec 09, 2017 12:26 pm
by kalai
sir, i have problem with user id and password , the login page showing me radius server is not repond

Re: v6.40.5 [current]

Posted: Sat Dec 09, 2017 12:49 pm
by kalai
sir, i hae not understand your what is the solution against the complaint login page showing Radius server is not responding against with user manager user id and password which showing already on the screen shot of the login page.

Re: v6.40.5 [current]

Posted: Tue Dec 12, 2017 3:42 am
by kometchtech
Dear Mikrotik Team

A DoS vulnerability has been released to RouterOS 6.40.5.

https://cve.mitre.org/cgi-bin/cvename.c ... 2017-17538
https://www.exploit-db.com/exploits/43317/

What kind of schedule is correspondence such as update?

Best regards.

Re: v6.40.5 [current]

Posted: Tue Dec 12, 2017 10:41 am
by normis
Dear Mikrotik Team

A DoS vulnerability has been released to RouterOS 6.40.5.

https://cve.mitre.org/cgi-bin/cvename.c ... 2017-17538
https://www.exploit-db.com/exploits/43317/

What kind of schedule is correspondence such as update?

Best regards.
That is not a vulnerability. Somebody made a ping script that floods the device, and result is that CPU usage rises.
Any task will affect CPU usage. This is normal.
The submitter is some person looking for internet fame.
We will see who we need to contact to de-list fake CVE submissions.

Re: v6.40.5 [current]

Posted: Tue Dec 12, 2017 2:19 pm
by kometchtech
Thanks normis.

Was there any such circumstance in this information ...

For the time being, I will try to keep this situation still.

Best regards.

Re: v6.40.5 [current]

Posted: Tue Dec 12, 2017 2:45 pm
by MiGel0
Hi.

I have a a few MK RB1100 on producction running the hotspot service and after update from 6.36 to 6.40.5 experience issues.

After x time 10/20/30 min, i suppose it depends on the amount of traffic, the portal starts to fail, could be:
Portal doesn´t appear or Login button does nothing, but firewall hotspot rules continues matching packets.
If i change any configuration on the hotspot server , everything start to work fine. Like if the service restarts resolve the issue.
My implementation use external radius server.
The ammount of simultaneous users is between 140 and 800

I have to say model CCR1016-12G woks fine with the same release.

Thanks

Re: v6.40.5 [current]

Posted: Thu Dec 21, 2017 12:48 am
by bajodel
Little "/export" issue:
in "ip dhcp-server" section, any setting to "bootp-support" (e.g. set bootp-support=none lan_dhcp) will not be exported

Re: v6.40.5 [current]

Posted: Fri Dec 22, 2017 2:59 pm
by strods
Version 6.41 has been released:
viewtopic.php?f=21&t=128915