Community discussions

 
temposuender
just joined
Posts: 1
Joined: Sun Mar 04, 2018 10:05 pm

Re: v6.42rc [release candidate] is released!

Sun Mar 04, 2018 10:26 pm

Upgrade fails on CHR:
/system package update install 
          channel: release-candidate
  current-version: 6.42rc30
   latest-version: 6.42rc35
           status: ERROR: not enough disk space, 19.4MiB is required and only 18.1MiB is free
/system resource print                                          
                   uptime: 2m44s
                  version: 6.42rc30 (testing)
               build-time: Feb/20/2018 10:44:28
              free-memory: 203.1MiB
             total-memory: 221.7MiB
                      cpu: Intel(R)
                cpu-count: 2
            cpu-frequency: 2594MHz
                 cpu-load: 0%
           free-hdd-space: 18.2MiB
          total-hdd-space: 63.5MiB
  write-sect-since-reboot: 416
         write-sect-total: 417
        architecture-name: x86_64
               board-name: CHR
                 platform: MikroTik
Upgrade path was 6.41.2 -> 6.42rc30 -> 6.42rc35. The system does not list any files except directories "skins" and "pub".
I suppose, you might have shrinked the disk, as normally (AFAIK) 128MB is the starting disk size of CHR in every type.
Or you started using CHR from the beginning, then 64MB was the starting size of the disk (as far as I can remember).
I can see 95+MiB total-hdd-space in every CHR I use, and 60+MiB free-hdd-space, so upgrade is always successful for me.

Probably, you should try resizing the disk of the CHR, then it might use the extra space, but probably, only the installation phase can resize the inner filesystem of CHR.

You should start from scratch, as stated in the System Requirements wiki, there 128MB of RAM and 128MB of disk space is required to operate/install CHR. You only need to copy out the current configuration, probably nothing more is needed.
Got a similar issue but I have a 128MB partition
[admin@MikroTik] /log> /system package update install
          channel: release-candidate
  current-version: 6.42rc28
   latest-version: 6.42rc37
           status: ERROR: not enough disk space, 10.0MiB is required and only 3.7MiB is free
[admin@MikroTik] /log> /system resource print
                   uptime: 41m13s
                  version: 6.42rc28 (testing)
               build-time: Feb/16/2018 07:02:32
              free-memory: 90.7MiB
             total-memory: 128.0MiB
                      cpu: MIPS 74Kc V4.12
                cpu-count: 1
            cpu-frequency: 600MHz
                 cpu-load: 11%
           free-hdd-space: 3872.0KiB
          total-hdd-space: 128.0MiB
  write-sect-since-reboot: 5375
         write-sect-total: 31175782
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: RB951Ui-2HnD
                 platform: MikroTik
 
I cant find anything that I can cleanup.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5559
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Mon Mar 05, 2018 10:01 am

You should make a backup, download that, then netinstall the device with "keep configuration" option, and when it
does not resolve the situation use "default configuration" and restore your backup.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 12:53 pm

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) bridge - added per-port forwarding options for broadcasts, unknown-multicasts and unknown-unicasts;
*) bridge - added per-port learning options;
*) bridge - added support for static hosts;
*) bridge - fixed reliability on software bridges when used on devices without switch chip;
*) capsman - added "allow-signal-out-of-range" option for Access List entries;
*) capsman - added support for "interface-list" in Access List and Datapath entries;
*) console - fixed "idpr-cmtp" protocol by changing its value from 39 to 38;
*) crs3xx - added initial "hw-offload" support for 802.3ad and "balance-xor" bonding;
*) crs3xx - added switch port "storm-rate" limiting options;
*) dhcp - improved DHCP service reliability when it is configured on bridge interface;
*) email - set maximum number of sessions to 100;
*) fetch - increased maximum number of sessions to 100;
*) ike1 - fixed wildcard policy lookup on responder;
*) quickset - fixed NAT if PPPoE client is used for Internet access;
*) winbox - made UDP local and remote TX size parameter optional in Bandwidth Test tool;
*) winbox - moved "ageing-time" setting from STP to General tab;
*) winbox - added "antenna" setting under GPS settings for MIPS platform devices;
*) winbox - added 160 MHz "channel-width" to wireless settings;
*) winbox - added broadcast and flood settings to bridge ports;
*) winbox - added missing protocol numbers to IPv4 and IPv6 firewall;
*) winbox - removed "VLAN" section from "Switch" menu for CRS3xx devices;
*) winbox - fixed maximal ID for Traffic Generator stream;
*) winbox - fixed name for "out-bridge-list" parameter under bridge firewall rules;
*) winbox - removed Enable and Disable buttons from IPsec "mode-config" list;
*) winbox - show "D" flag under "/ip dhcp-client" menu;
*) winbox - show CQI in LTE info;
*) winbox - show only master CAP interfaces under CAPsMAN wireless scan tool;
*) wireless - added support for "band=5ghz-n/ac";
*) wireless - added support for "interface-list" for Access List entries;
*) wireless - added support for legacy AR9485 chipset;
*) wireless - improved wireless scan functionality;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
dksoft
newbie
Posts: 47
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 2:36 pm

There now is support for "band=5ghz-n/ac" in the GUI but none in the capsman GUI.
Setup: Dt. Telekom FTTH, CHR on Promox, ZyXEL GS1900-48HP, WAP AC. MCTNA
 
biatche
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Oct 13, 2015 6:50 am

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 3:18 pm

There now is support for "band=5ghz-n/ac" in the GUI but none in the capsman GUI.
My exact thoughts. Why?
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 5:09 pm

I It is incredible that we have no improvement for IPv6.
Please please please do some work on IPv6!
E.g. following priorities from this posting: viewtopic.php?f=2&t=123302

Things I really need, the sooner the better:
- route marking and multi route tables using marks as in IPv4
(via ipv6 firewall mangle and/or ipv6 route rule)
- configurable IPv6 nameservers in DHCPv6 and RA, or at least the option to publish the router's own
address as nameserver instead of the configured external DNS servers
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2279
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 6:45 pm


*) winbox - added 160 MHz "channel-width" to wireless settings
Which products support 160Mhz? Thanks
LAN, FTTx, Wireless. ISP operator
 
User avatar
mozerd
Member Candidate
Member Candidate
Posts: 250
Joined: Thu Oct 05, 2017 3:39 pm
Location: Canada
Contact:

Re: v6.42rc [release candidate] is released!

Wed Mar 07, 2018 11:14 pm

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) winbox - show "D" flag under "/ip dhcp-client" menu;
Is this supposed to show under Terminal or via Winbox DHCP-Client Window row dispaly ? If its under window mine does not show the "D: flag as described for the release. If its under Terminal it does show up as in the Flags: row
My question:: when should the "D" flag appear under DHCP-Client? before the ip address has been assignend or after the ip addrsss has been assigned by the server?
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 12:25 am

I It is incredible that we have no improvement for IPv6.
Please please please do some work on IPv6!
E.g. following priorities from this posting: viewtopic.php?f=2&t=123302

Things I really need, the sooner the better:
- route marking and multi route tables using marks as in IPv4
(via ipv6 firewall mangle and/or ipv6 route rule)
- configurable IPv6 nameservers in DHCPv6 and RA, or at least the option to publish the router's own
address as nameserver instead of the configured external DNS servers
Yes can't agree more. Have got 6to4 backup as well as other tunnels but no can't route it properly, or heaven's forbid the ability to route specific ipv6 traffic over better suited tunnels :-(
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1702
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 1:45 am

What's new in 6.42rc39 (2018-Mar-07 07:01):
.....
*) wireless - added support for "interface-list" for Access List entries;
.....
Could we expect MAC-addresses list implemented?
Real admins use real keyboards.
 
kunago
just joined
Posts: 18
Joined: Sun Mar 09, 2014 1:58 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 3:25 pm

Is CAPsMAN's VLAN implementation going to be fixed to work with the new bridge implementation? Now PVID seems to be used over VLAN and therefore makes CAPsMAN a little unusable.
 
sindy
Forum Guru
Forum Guru
Posts: 3767
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 4:00 pm

Is CAPsMAN's VLAN implementation going to be fixed to work with the new bridge implementation? Now PVID seems to be used over VLAN and therefore makes CAPsMAN a little unusable.
To me CAPsMAN along with VLANs works in 6.41+, so can you open a separate topic for that and describe what you want to achieve? Maybe a workaround can be found.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 4:20 pm

*) bridge - added per-port forwarding options for broadcasts, unknown-multicasts and unknown-unicasts;
*) bridge - added per-port learning options;
*) bridge - added support for static hosts;
Thanks. This will make it possible to configure stuff that I was waiting for.
Is there any plans for more learning modes. now there are Auto, On, Off.
[admin@MikroTik] > interface bridge port set learn=
auto  no  yes


No I do understand do not learn, static only check...
Yes I do understand learn end of discussion check...
But Auto? No but Yes? For Auto to make sence it would be accompanied with max-learn-hosts=[nr] being integer number from 1 to n and the option on-max-replace-mode=[none, fifo, lifo] and on-max-replace-timeout=[nr] sec.
With the learn being Auto and:
No timeout set honor only on-max-replace-mode
timeout set honor on-max-replace-mode and check that the timeout is reached before.


Am I right to be waiting for this aswell?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Thu Mar 08, 2018 4:46 pm

dksoft, biatche - This is still an rc version. The first step is to add such mode in regular wireless settings;
mozerd - As changelog entry states "winbox - show "D" flag..." it is a Winbox fix. Applies to, for example, DHCP client created by "detect-internet" feature;
kunago - Have you contacted support regarding this matter? If not, then write to support, explain the issue that you have and if it an actual software issue, then we will try to resolve it;
 
mducharme
Trainer
Trainer
Posts: 788
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 2:42 am

Getting very poor performance with FastTrack, hap ac, 150Mbps download speed slows down to 15Mbps. Fasttrack disabled and I can get full speed. This only started recently, so I imagine it is from one of the RC's.
 
alexjhart
Member Candidate
Member Candidate
Posts: 191
Joined: Thu Jan 20, 2011 8:03 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 2:44 am



*) crs3xx - added initial hw-offload support for 802.3ad and balance-xor bonding
What does "initial" mean here?
Strods?
For those still wondering, I found this https://wiki.mikrotik.com/wiki/Manual:C ... es#Bonding
-----
Alex Hart

The Brothers WISP
 
pe1chl
Forum Guru
Forum Guru
Posts: 5559
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 10:31 am

Getting very poor performance with FastTrack, hap ac, 150Mbps download speed slows down to 15Mbps. Fasttrack disabled and I can get full speed. This only started recently, so I imagine it is from one of the RC's.
Such reports are probably meaningless without included export of your configuration, at least the firewall, queueing and routing part.
Maybe you should mail a supout.rif to support.
 
csi
newbie
Posts: 31
Joined: Wed Mar 02, 2016 10:05 am

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 12:25 pm

*) crs3xx - added initial "hw-offload" support for 802.3ad and "balance-xor" bonding;
Well done!
I can confirm it's working on a CRS326 now. Still open is the issue to change MTU size.
[admin@MikroTik] /interface bonding> set bond2 mtu=8148
failure: could not set mtu
[admin@MikroTik] /interface bonding>
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 12:58 pm

*) crs3xx - added initial "hw-offload" support for 802.3ad and "balance-xor" bonding;
Well done!
I can confirm it's working on a CRS326 now. Still open is the issue to change MTU size.
[admin@MikroTik] /interface bonding> set bond2 mtu=8148
failure: could not set mtu
[admin@MikroTik] /interface bonding>
Can allso Confirm that my LACP probelm still exists: accessing the ip owned by bridge over hw offloaded tag'ed only vlan lacp is not possible. Arp on upstream client gets mac for bridge/ip but no luck pinging or connecting.
 
User avatar
artz
MikroTik Support
MikroTik Support
Posts: 88
Joined: Tue Oct 17, 2017 5:51 pm
Location: Riga
Contact:

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 4:54 pm

Well done!
I can confirm it's working on a CRS326 now. Still open is the issue to change MTU size.
[admin@MikroTik] /interface bonding> set bond2 mtu=8148
failure: could not set mtu
[admin@MikroTik] /interface bonding>
You must set L2MTU on slave interfaces first.
 
NetflashTechnical
just joined
Posts: 15
Joined: Fri May 10, 2013 3:43 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 5:27 pm

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) bridge - added per-port forwarding options for broadcasts, unknown-multicasts and unknown-unicasts;
*) bridge - added per-port learning options;
*) bridge - added support for static hosts;
*) bridge - fixed reliability on software bridges when used on devices without switch chip;
Q: How do you set the "default" option for "Unknown Unicast Flood", "Unknown Multicast Flood" and "Broadcast Flood" overall for an interface. It seems like dynamic interfaces (say an l2tp interface on the bridge) default to all flooding ON can you can't modify the options. I wonder if you can add a "Default Unknown Unicast Flood", "Default Unknown Multicast Flood", and "Default Broadcast Flood" option to the bridge, OR allow the ppp profile to set the bridge options similar to how you can set horizon.
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 8:28 pm

Please would MikroTik consider allowing us to set granular pps (packets per second) filtering on ports, instead of percentage. 1% of 10 Gbps is still 100 Mbps, this would rapidly exhaust MAC address tables and take the network offline.

D-Link DGS and Netgear M4300 switches support setting most ports to selectively drop excess or shutdown port when exceeding eg 500 pps for customer facing ports, whilst having different values on internal ports.

Are there plans to provide dot1q-tunnel equivalent features and switch port rules to manipulate two VLAN tags? (eg pop outer and inner tags and replace them with others)
 
csi
newbie
Posts: 31
Joined: Wed Mar 02, 2016 10:05 am

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 8:38 pm

Well done!
I can confirm it's working on a CRS326 now. Still open is the issue to change MTU size.
[admin@MikroTik] /interface bonding> set bond2 mtu=8148
failure: could not set mtu
[admin@MikroTik] /interface bonding>
You must set L2MTU on slave interfaces first.
Many thanks for the hint. It's working now.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1810
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.42rc [release candidate] is released!

Fri Mar 09, 2018 11:48 pm

Please would MikroTik consider allowing us to set granular pps (packets per second) filtering on ports, instead of percentage. 1% of 10 Gbps is still 100 Mbps, this would rapidly exhaust MAC address tables and take the network offline.
+1

Please do this!! On our Extreme and Juniper switches we set PPS differently depending on the role of the port, e.g. ENNI's get very low limits, Trunks get very high limits, Servers get high limits, Edge devices get very low limits.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
idlemind
Forum Guru
Forum Guru
Posts: 1101
Joined: Fri Mar 24, 2017 11:15 pm
Location: USA

Re: v6.42rc [release candidate] is released!

Sat Mar 10, 2018 1:41 am

Are there plans to provide dot1q-tunnel equivalent features and switch port rules to manipulate two VLAN tags? (eg pop outer and inner tags and replace them with others)
I've been using QinQ trunking in software bridges on a hex for sometime now. Nothing really special to report about it. I imagine it's software switched but for me that's not a problem.
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Sat Mar 10, 2018 7:31 pm

# jan/13/1970 03:06:17 by RouterOS 6.42rc39
# software id = JLRA-QA36
#
# model = CRS326-24G-2S+
# serial number = 763C06E78477
/interface ethernet
set [ find default-name=sfp-sfpplus2 ] mac-address=6C:3B:6B:ED:F9:E6
/interface bridge
add admin-mac=6C:3B:6B:ED:F9:E6 auto-mac=no fast-forward=no name=bridge1 protocol-mode=none pvid=64 vlan-filtering=yes
/interface bonding
add lacp-rate=1sec min-links=1 mode=802.3ad name=Core slaves=sfp-sfpplus1,sfp-sfpplus2 transmit-hash-policy=layer-3-and-4
/interface bridge port
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=Core pvid=64
add bridge=bridge1 frame-types=admit-only-untagged-and-priority-tagged interface=ether1 pvid=64 unknown-multicast-flood=no unknown-unicast-flood=no
/interface bridge vlan
add bridge=bridge1 tagged=Core untagged=bridge1,ether1 vlan-ids=64
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/system identity
set name=dc-jkb-dsa-4
/system package update
set channel=release-candidate
/system routerboard settings
set boot-os=router-os silent-boot=no
You have model and version i initial comment rows my LACP problem connect only Core interface (LACP sfpsfpplus1,sfpsfplus2) to upstream network nothing else. Now the switch on vlan64 will get ip and can access everything it should. But nothing from the upstream device can access the bride not by mac nor IP.
If i then check the connection by connecting a laptop to ether1 this laptop gets ip from upstream dhcp and all works AND the bridge itself is accessable from upstream on other device(winbox l2 or l3).

The minute I disconnect the laptop (ether1) so that the only active port in bridge is Core (lacp hw bond/trunk) then the same upstream system can't access the bride no more through any l2 or l3 means in winbox. It is seen still but can't login.

Please try to replicate and Confirm that you are aware of this an working on fixing it.

[Ticket#2018031222001218] RE: LACP HW problem reac [...]
Last edited by JimmyNyholm on Mon Mar 12, 2018 10:07 am, edited 1 time in total.
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Sun Mar 11, 2018 12:15 am

Exactly... The CPUs in CRS class devices are weak, extremely weak. I assisted someone recently that couldn't do 10Mbps routing on a CRS125, as this was software based.

I would like to see more high end merchant silicon implementations. Broadcom Dune, for example, was released in 2015 and provides 800 Gbps forwarding capacity per device, VXLAN, NVGRE, Geneve, MPLS, VPLS, hierarchical traffic manager with support for thousands of flows and external DDR4 or GDDR5 packet buffering support.

People are excited about CRS326 when a 4 year old D-Link DGS (8x1Gbps UTP, 24x1Gbps SFP, 2x10Gbps, dual power) switch does everything wirespeed and supports (R|M)STP, QinQ, dot1q-tunnel?

Mikrotik should work on their RouterOS 7 unicorn, these functions are missing and sorely needed:
- IPv6 blackholing
- Per interface rp-filter settings (no reverse path filtering in IPv6 at all currently)
- MPLS for static or BGP routes
- BGP multi-protocol support (IPv4 BGP sessions that exchange IPv6 routes and then switch traffic using MPLS labels)
- IPv6 MPLS
- VirtIO NIC multi-queue support
- Integrate the high-availability work that community members have done. Most people would probably purchase pairs of CCR devices if they could simply connect a heartbeat cable and enable a feature.
- Proper VRF isolation and working trace routes
- IPv4 and IPv6 feature parity (NAT (even just 6to6 or prefix translation), connection tracking, etc)

I've been using QinQ trunking in software bridges on a hex for sometime now. Nothing really special to report about it. I imagine it's software switched but for me that's not a problem.
Are there plans to provide dot1q-tunnel equivalent features and switch port rules to manipulate two VLAN tags? (eg pop outer and inner tags and replace them with others)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5559
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Sun Mar 11, 2018 10:00 am

Exactly... The CPUs in CRS class devices are weak, extremely weak. I assisted someone recently that couldn't do 10Mbps routing on a CRS125, as this was software based.
Well the CPU is weak, but not THAT weak. To have that problem you would have to do IPsec or extremely lot of (and badly ordered) filters.

However, a CRS is NOT a replacement for an L3-routing switch as available from A-brand manufacturers (HP Procurve / Aruba Networks, Cisco etc).
Those switches do wirespeed routing just like they do wirespeed switching, and a CRS simply cannot do that.

My position remains, when you require a professional switch with wirespeed L3 routing and other facilities available in that range (DHCP and ARP snooping/filtering etc)
then do not buy from MikroTik. MicroTik has some nice low-end switches that can do some routing but it is only intended for management and/or some special use
case, not to route the main traffic of the switch. And it does not offer many of the facilities available on those professional switches.

Maybe it will change in the future, but hey, maybe in the future we'll also get RouterOS v7. However, that does not seem to be the near future.
So for now, buy CRS only when you need mainly plain switching and no advanced features.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Mon Mar 12, 2018 10:46 am

Version 6.41.3 has been released with fixes from 6.42rc backported to 6.41.x release tree:
viewtopic.php?f=21&t=131810
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Mon Mar 12, 2018 10:47 am

What's new in 6.42rc41 (2018-Mar-09 08:01):

*) ipsec - improved single tunnel hardware acceleration performance on MMIPS platform devices;
*) snmp - provide "board-name" information;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
biatche
Member Candidate
Member Candidate
Posts: 128
Joined: Tue Oct 13, 2015 6:50 am

Re: v6.42rc [release candidate] is released!

Mon Mar 12, 2018 1:40 pm

small changelog, final version soon? :)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5559
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Mon Mar 12, 2018 1:46 pm

small changelog, final version soon? :)
No, everyone is now working on the big IPv6 update!
(I am dreaming...)
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.42rc [release candidate] is released!

Mon Mar 12, 2018 2:33 pm

Me too.....
:lol:
No, everyone is now working on the big IPv6 update!
(I am dreaming...)
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
benbennett
just joined
Posts: 4
Joined: Thu May 05, 2016 6:53 am

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 9:52 am

Went from 6.42rc24 to 6.42rc41 and it broke my dual WAN configuration, its similar to this configuration except I am just using 2 WANS with a 3:1 ratio, ie one WAN gets more traffic. https://aacable.wordpress.com/tag/mikro ... wan-links/


Cannot roll back either or force a downgrade for some reason.

Would resetting the configuration and downgrading work? I don't know why the downgrade just fails. It just reboots and I am stuck on 6.42rc41

( I have the script that saves backup every reboot, so I was just going to reset, downgrade,upgrade ,restore)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 10:00 am

It just reboots and I am stuck on 6.42rc41
And nothing in Log?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
doneware
Trainer
Trainer
Posts: 483
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 1:20 pm

*) capsman - improved CAPsMAN responsiveness on systems with large amount of CAP interfaces;
can anyone please describe in numeric format, what "large amount" means?
#TR0359
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 2:19 pm

Hundreds
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
benbennett
just joined
Posts: 4
Joined: Thu May 05, 2016 6:53 am

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 10:02 pm

Here is the log where it started going wrong
omitting package system-6.41.3: older package is already provided
can not install ppp-6.41.3: system-6.41.3 is not installed, but is required
 
benbennett
just joined
Posts: 4
Joined: Thu May 05, 2016 6:53 am

Re: v6.42rc [release candidate] is released!

Tue Mar 13, 2018 10:14 pm

Got it to downgrade. There were packages in the root directory on the router that I was using to sync files to a dude server. That was causing a conflict.

Sorry my problem.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Thu Mar 15, 2018 3:33 pm

What's new in 6.42rc43 (2018-Mar-14 10:45):

!) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
*) crs326 - fixed known multicast flooding to the CPU;
*) dhcp - improved DHCP service reliability when it is configured on bridge interface;
*) ssh - generate SSH keys only on the first connect attempt instead of the first boot;
*) ups - improved disconnect message handling between RouterOS and UPS;
*) wireless - enable all chains by default on devices without external antennas after configuration reset;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.42rc [release candidate] is released!

Thu Mar 15, 2018 8:20 pm

*) ssh - generate SSH keys only on the first connect attempt instead of the first boot;
Could you please comment on why this change was made?

Is it not better to generate these at startup than to make an user wait the first time he connects?
Specifically on older boards (with single-core 400MHz CPUs), this generation can take a long time.

Lets say I power-on a new router , or a router that has been reset to empty config.
It's way more comfortable for me for that router to generate its SSH keys while I might be clicking doing other things, rather than make me wait when I want to connect.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
pe1chl
Forum Guru
Forum Guru
Posts: 5559
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 15, 2018 8:39 pm

Specifically on older boards (with single-core 400MHz CPUs), this generation can take a long time.

Lets say I power-on a new router , or a router that has been reset to empty config.
It's way more comfortable for me for that router to generate its SSH keys while I might be clicking doing other things, rather than make me wait when I want to connect.
My guess would be that routers are powered off-on during initialization when it takes so long, and configuration gets inconsistent resulting in complaints or returns.
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 12:01 am

Tried 6.42rc43 and found nice visual bug:

Image

Under System -> Routerboard I can see factory ROS version, while under System -> Resources it is blank field.

Any SIM slot control button still there even that RB951G-2HnD have no such slot. Funny to see this suddenly appeared "feature".
 
User avatar
eworm
Member
Member
Posts: 358
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 12:09 am

Under System -> Routerboard I can see factory ROS version, while under System -> Resources it is blank field.
One is RouterOS version, the other is boot firmware version.
Looks like older devices do not have a record about factory RouterOS version.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 1:00 am

*) ssh - generate SSH keys only on the first connect attempt instead of the first boot;
Could you please comment on why this change was made?

Is it not better to generate these at startup than to make an user wait the first time he connects?
Specifically on older boards (with single-core 400MHz CPUs), this generation can take a long time.

Lets say I power-on a new router , or a router that has been reset to empty config.
It's way more comfortable for me for that router to generate its SSH keys while I might be clicking doing other things, rather than make me wait when I want to connect.
+1
 
Keyko
just joined
Posts: 19
Joined: Sat Dec 23, 2017 6:27 pm

6.42rc43 +hAP AC^2 = boot loop

Fri Mar 16, 2018 1:07 am

Good afternoon.

Such a problem - 6.42rc43 +hAP AC^2 = boot loop. If you roll 6.42rc43 and do not update the firmware, everything seems to be fine, but it's worth updating the firmware and the router stupidly goes to the boot loops. At the same time, I tried to download a stable version via nethinstall, but there is still a loop.

If the router reboots from the button (pull out the button, hold down the button, insert the PS and wait for 20 seconds, the router allows you to go through the winbox, but if you just reboot or turn it off / on, it's a loop again.

I was able to roll back to stable firmware in this way - installed 6.41.3, then rebooted from the button to the factory, connected to winbox and rolled firmware by pressing "update firmware" several times and then rebooted the device.


So it goes.


Sincerely.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 7:14 am

tomaskir, pe1chl, 105547111 - Waiting time is not too long. This kind of implementation will satisfy the biggest part of the users so we decided to re-make this generate process.
upower3, eworm - This is not a bug. If router was installed in factory before we introduced this feature "show min RouterOS version", then this value is not specified. These are two different variables - RouterBOOT and RouterOS minimal supported versions.
Keyko - We will look into this problem and fix it as soon as possible if we managed to reproduce it. I recommend that you still contact support@mikrotik.com regarding this problem so you can get more feedback from our side and reach solution much faster.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 11:46 am

Waiting time is not too long. This kind of implementation will satisfy the biggest part of the users so we decided to re-make this generate process.
But what is the benefit - what was the original need to change this?

Because from what I can see, this has only disadvantages.
Making users wait when they want to connect is NOT a good UX.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
morf
Member Candidate
Member Candidate
Posts: 157
Joined: Tue Jun 21, 2011 5:31 pm
Location: Saint-Petersburg

Re: v6.42rc [release candidate] is released!

Fri Mar 16, 2018 12:07 pm

The big problem on CCR1072 with 6.42rc43 (Release candidate)
After the upgrade, all 10g interfaces were lost! Only 1 gb copper is still visible. Reset did not help.
I had to roll back to a stable 6.41.3
 
atlanticd
newbie
Posts: 29
Joined: Thu Jun 11, 2015 6:42 pm

Re: 6.42rc43 +hAP AC^2 = boot loop

Sat Mar 17, 2018 3:14 pm

Hi strods, Keyko,

I experienced the same on my hAP ac^2. I upgraded from factory 6.40.5 to 6.42rc43 using netinstall (netinstall version was also 6.42rc43). After successful update, I triggered firmware upgrade in Winbox by clicking on Upgrade button on System/Routerboard menu. After upgrading the firmware to 6.42rc43, the boot loop started. I tried to install with netinstall and RouterBOOT "15 seconds" method 6.41.3, again 6.42rc43, and lastly 6.40.6, and although install was always successful, the boot loop still remained. In the end I recognized that even without pressing reset button while plugging in the power, it always went to RouterBOOT (I saw it in netinstall Ready state always). Finally, I reverted by RouterBOOT "5 seconds" factory reset method to boot, that booted properly RouterOS 6.40.6 (the last I tried with netinstall), and I saw that current firmware was 6.42rc43, and Upgrade firmware was 3.43. Here is a screenshot:
Image

Once I clicked on Upgrade, and after reboot, I could properly boot again. And upgrade again to 6.42rc43 (and of course this time I skipped firmware upgrade, so it is running now with ROS=6.42rc43 and RouterBOOT 3.43)

So steps to reproduce:
1. Upgrade from factory firmware to 6.42rc43
2. Upgrade firmware to 6.42rc43
3. Bootloop start to happen

Revert:
1. Boot the device with "5 seconds method" : Hold this button during boot time until LED light starts flashing, release the button to reset RouterOS configuration (total 5 seconds)
2. Trigger Upgrade (which is actually Downgrade) of RouterBoot firmware


Kindly ask you to investigate this issue. Thank you.

Good afternoon.

Such a problem - 6.42rc43 +hAP AC^2 = boot loop. If you roll 6.42rc43 and do not update the firmware, everything seems to be fine, but it's worth updating the firmware and the router stupidly goes to the boot loops. At the same time, I tried to download a stable version via nethinstall, but there is still a loop.

If the router reboots from the button (pull out the button, hold down the button, insert the PS and wait for 20 seconds, the router allows you to go through the winbox, but if you just reboot or turn it off / on, it's a loop again.

I was able to roll back to stable firmware in this way - installed 6.41.3, then rebooted from the button to the factory, connected to winbox and rolled firmware by pressing "update firmware" several times and then rebooted the device.


So it goes.


Sincerely.

Who is online

Users browsing this forum: No registered users and 9 guests