Community discussions

 
psannz
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: 6.42rc43 +hAP AC^2 = boot loop

Sat Mar 17, 2018 4:21 pm

Good afternoon.

Such a problem - 6.42rc43 +hAP AC^2 = boot loop. If you roll 6.42rc43 and do not update the firmware, everything seems to be fine, but it's worth updating the firmware and the router stupidly goes to the boot loops. At the same time, I tried to download a stable version via nethinstall, but there is still a loop.
Can confirm the issue, 6.42rc43 RouterBoot and hAP AC^2 don't mix well.
 
User avatar
soonwai
Member Candidate
Member Candidate
Posts: 163
Joined: Mon Feb 06, 2012 10:50 pm
Location: Kuala Lumpur

Re: v6.42rc [release candidate] is released!

Sun Mar 18, 2018 8:59 pm

I'm getting this error "no such item (4)" when enabling or disabling the pppoe client interface. Router is RB750Gr3 6.42RC43.
Note that this problem is not unique to 6.42RC43. I've encountered it before. It's just that I've only started looking into it now.

Image

If I do a "/interface disable pppoe-out1 " then wait more than approximately 16 secs, and do a "/interface enable pppoe-out1 ", I will receive the error "no such item (4)".
Less than approx 16 secs, no error.

If I try the above with an ethernet port, no error.

Same thing happens on an RB2011UAS-2HnD running 6.42rc41.

Not a big problem, more of an annoyance, during normal use but wreaks havoc with scripts that takes longer than 16 secs between disabling and enabling the pppoe-out1 interface.
Last edited by soonwai on Sun Mar 18, 2018 9:17 pm, edited 1 time in total.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Sun Mar 18, 2018 9:16 pm

I'm getting this error "no such item (4)" when enabling or disabling the pppoe client interface. Router is RB750Gr3 6.42RC43.
Note that this problem is not unique to 6.42RC43. I've encountered it before. It's just that I've only started looking into it now.
I faced this kind of problem in WinBox a few times (enabling ipip and eoip interfaces, AFAIR) on ~v6.40-41
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 10:53 am

What's new in 6.42rc46 (2018-Mar-20 05:53):

*) dhcp - improved DHCP service reliability when it is configured on bridge interface;
*) dhcp - reduced resource usage of DHCP services;
*) netinstall - sign Netinstall executable with an Extended Validation Code Signing Certificate;
*) quickset - by default use "/24" subnet for local network;
*) quickset - properly detect IP address when one of the bridge modes is used;
*) routerboot - fixed RouterBOOT upgrade process (introduced in v6.42rc);
*) winbox - added "use-dn" setting in OSPF instance General menu;
*) winbox - moved OSPF instance "routing-table" setting in OSPF instance General menu;
*) winbox - use proper graph name for HDD graphs;
*) wireless - improved Nv2 PtMP performance;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
atlanticd
newbie
Posts: 29
Joined: Thu Jun 11, 2015 6:42 pm

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 10:57 am

*) routerboot - fixed RouterBOOT upgrade process (introduced in v6.42rc);
Hi strods,

can you please confirm that above line means the fix for the problem of boot loop on hAP ac^2 reported by Keyko, and confirmed by me and psannz in this forum topic? If yes, I will try to upgrade RouterBOOT in the evening on my hAP ac^2. Thank you!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 11:16 am

Update regarding 6.42rc latest release:

We have made a potentially significant improvement for wireless Nv2 PtMP configurations in the latest 6.42rc version release.

Those of you who are willing to test rc versions on your test network, please upgrade to the latest version, test the performance and report to support@mikrotik.com with the results. Your effort and feedback will be highly appreciated.

Please note that rc versions are released strictly for testing purposes and should not be used on crucial network devices.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 11:17 am

atlanticd - Yes, that is the fix for the problem. Please test it and report back to us with the results.
 
blingblouw
Member Candidate
Member Candidate
Posts: 271
Joined: Wed Aug 25, 2010 9:43 am

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 11:47 am

Regarding nv2.

Do we update clients and ap or just ap?
 
pe1chl
Forum Guru
Forum Guru
Posts: 5810
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 12:08 pm

We have made a potentially significant improvement for wireless Nv2 PtMP configurations in the latest 6.42rc version release.
Before such protocols are of any use to us, we need you to implement airMAX, the other guys to implement NV2, or you both agree
on a standard that both can implement. We invariably have a mix of different manufacturers of user equipment and now can
only use bare 802.11 or it will not be compatible :-( :-(
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 12:48 pm

Regarding nv2.

Do we update clients and ap or just ap?
All the changes are on the AP side so you need to upgrade the AP. Client version can stay the same.
 
atlanticd
newbie
Posts: 29
Joined: Thu Jun 11, 2015 6:42 pm

Re: v6.42rc [release candidate] is released!

Tue Mar 20, 2018 8:29 pm

atlanticd - Yes, that is the fix for the problem. Please test it and report back to us with the results.
Hi strods,

I can confirm that the RouterBOOT firmware upgrade to 6.42rc46 works, and it is not causing boot loop anymore. However I noticed that after firmware upgrade (and only after Firmware upgrade, not ROS upgrade), the total memory and free memory shows much less than before. Instead of ~256 MB now it is ~128 MB.
              
              free-memory: 79.1MiB
             total-memory: 106.3MiB
I reported earlier in another topic that interestingly my hAP ac^2 unit came with 256 MB unexpectedly, and a colleague from MikroTik support stated it that some unit came with more memory. Can you confirm that MikroTik now limit by intention the available memory in this new firmware just to meet the specs, even though the unit has more memory physically, or was it a software bug?
Thank you.
 
huntah
Member Candidate
Member Candidate
Posts: 267
Joined: Tue Sep 09, 2008 3:24 pm

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 12:56 am

Seems like my hap ac2 has 233 MB RAM . at least on ROS 6.40.5
Using it as Cap for testing. So did not jump tu 6.42rc yet..
uptime: 1d7h32m31s
                  version: 6.40.5 (stable)
               build-time: Oct/31/2017 13:05:15
         factory-software: 6.40.5
              free-memory: 208.7MiB
             total-memory: 233.4MiB
                      cpu: ARMv7
                cpu-count: 4
            cpu-frequency: 716MHz
                 cpu-load: 0%
           free-hdd-space: 4216.0KiB
          total-hdd-space: 15.3MiB
  write-sect-since-reboot: 136
         write-sect-total: 136
               bad-blocks: 0%
        architecture-name: arm
               board-name: hAP ac^2
                 platform: MikroTik
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 3:11 pm

What's new in 6.42rc48 (2018-Mar-21 11:13):

*) health - fixed empty measurements on CRS328-24P-4S+RM;
*) led - removed unused "link-act-led" trigger for devices which does not use it;
*) ups - improved communication between router and UPS;
*) wireless - improved Nv2 PtMP performance;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
User avatar
eworm
Member
Member
Posts: 391
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 3:38 pm

What's new in 6.42rc48 (2018-Mar-21 11:13):
Is the version a typo? My systems find 6.42rc49.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 177
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 3:41 pm

Is the version a typo? My systems find 6.42rc49.
Isn't a typo, were launched two versions today.

https://mikrotik.com/download/changelog ... lease-tree
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 3:45 pm

What's new in 6.42rc49 (2018-Mar-21 12:34):

*) w60g/Wireless-Wire - increased supported distance for wAP 60G to 200+ meters;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 3:46 pm

Update regarding 6.42rc latest release:

We have made a significant improvement for 60 GHz wireless (Wireless Wire and wAP 60G) configurations in the latest 6.42rc version release.

Those of you who are willing to test rc versions on your test network, please upgrade to the latest version, test the performance and report to support@mikrotik.com with the results. Your effort and feedback will be highly appreciated.

Please note that rc versions are released strictly for testing purposes and should not be used on crucial network devices.
 
psannz
Frequent Visitor
Frequent Visitor
Posts: 57
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 5:06 pm

*) routerboot - fixed RouterBOOT upgrade process (introduced in v6.42rc);
confirmed, RouterBOOT upgrade installed ok on hAP ac². Upgraded from ROS 6.41.3 to 6.42rc49, then from RouterBOOT 6.41.3 to 6.42rc49 without any problems.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42rc [release candidate] is released!

Wed Mar 21, 2018 6:08 pm

When you close your entire router they can use their 3G/4G connection.
That is what I see too, so then you have lost the battle :)
Better to give good education.
Exactly!
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
PaulsMT
MikroTik Support
MikroTik Support
Posts: 283
Joined: Tue Feb 10, 2015 3:21 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 22, 2018 1:10 pm

atlanticd - Yes, that is the fix for the problem. Please test it and report back to us with the results.
Hi strods,

I can confirm that the RouterBOOT firmware upgrade to 6.42rc46 works, and it is not causing boot loop anymore. However I noticed that after firmware upgrade (and only after Firmware upgrade, not ROS upgrade), the total memory and free memory shows much less than before. Instead of ~256 MB now it is ~128 MB.
              
              free-memory: 79.1MiB
             total-memory: 106.3MiB
I reported earlier in another topic that interestingly my hAP ac^2 unit came with 256 MB unexpectedly, and a colleague from MikroTik support stated it that some unit came with more memory. Can you confirm that MikroTik now limit by intention the available memory in this new firmware just to meet the specs, even though the unit has more memory physically, or was it a software bug?
Thank you.
Thank you for your report, the total-memory value will be reported correctly starting from the firmware version 6.42rc50
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Fri Mar 23, 2018 9:48 am

[admin@sw-under] > interface bonding print
Flags: X - disabled, R - running 
 0    name="CoreUplink" mtu=1500 mac-address=64:D1:54:EA:BC:83 arp=enabled arp-timeout=auto slaves=sfp-sfpplus1,sfp-sfpplus2 mode=802.3ad primary=none link-monitoring=mii arp-interval=100ms arp-ip-targets="" mii-interval=100ms down-delay=0ms up-delay=0ms lacp-rate=1sec 
      transmit-hash-policy=layer-3-and-4 min-links=0 
[admin@sw-under] > export 
# jan/09/1970 16:55:12 by RouterOS 6.42rc43
# software id = E34N-V9KR
#
# model = CRS317-1G-16S+
# serial number = 7A1407CB40B1
/interface ethernet
set [ find default-name=sfp-sfpplus2 ] mac-address=64:D1:54:EA:BC:83
/interface bridge
add fast-forward=no igmp-snooping=yes name=bridge1 protocol-mode=none pvid=64 vlan-filtering=yes
/interface bonding
add lacp-rate=1sec mode=802.3ad name=CoreUplink slaves=sfp-sfpplus1,sfp-sfpplus2 transmit-hash-policy=layer-3-and-4
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 frame-types=admit-only-vlan-tagged interface=CoreUplink pvid=4094 unknown-multicast-flood=no unknown-unicast-flood=no
/interface bridge vlan
add bridge=bridge1 tagged=CoreUplink untagged=bridge1,ether1 vlan-ids=64
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system identity
set name=sw-under
/system package update
set channel=release-candidate
/system routerboard settings
set boot-os=router-os silent-boot=no
[admin@sw-under] > 
As soon as a Bond is Created the Mac Fideling starts as in:
/interface ethernet
set [ find default-name=sfp-sfpplus2 ] mac-address=64:D1:54:EA:BC:83
Is this Correct... All Interfaces participating should be indiduall in their LACP BDPU collection,hasing,distribution offcource all sending the same system-id mac is this a mixup somewhere?

Will supply more in my Ticket but I think this show that there is something fishy here.
Last edited by JimmyNyholm on Fri Mar 23, 2018 11:01 am, edited 1 time in total.
 
Sheriff1972
just joined
Posts: 20
Joined: Fri Feb 16, 2018 7:48 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 23, 2018 10:04 am

I am having trouble with setting up a CAP AC using the 'quick setup'. Everything was fine until I rolled the last couple of RC updates. I am trying to set up as 'Home AP dual', and configure as before. However it refuses to get an IP address and then I cant access the device thought winbox as it refuses the connection. This then requires a manual reset if the device, but nothing seems to work when setting up with the 'Home AP Dual' quick settings. I have internet back now by using the 'WISP' quick setting and configuring that....

I am a no expert, but it's strange I had no problems from a few RC versions ago.
 
prague
just joined
Posts: 22
Joined: Tue Sep 25, 2012 10:37 am

Re: v6.42rc [release candidate] is released!

Fri Mar 23, 2018 11:45 am

20/40mhz-XX for 160MHz ?
 
tigro11
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Tue Feb 20, 2018 12:31 am

Re: v6.42rc [release candidate] is released!

Fri Mar 23, 2018 10:09 pm

hello guys, in the last rc49 release, I wanted to write my hotspot logs on micro sd, only that he can not write on disk1, he always writes on flash
RG 750g3
on the log action type menu, the sd name does not appear
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1302
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v6.42rc [release candidate] is released!

Sat Mar 24, 2018 12:17 pm

hello guys, in the last rc49 release, I wanted to write my hotspot logs on micro sd, only that he can not write on disk1, he always writes on flash
RG 750g3
on the log action type menu, the sd name does not appear
Not what you ask for, but you can send you log to syslog.
Install Splunk and you get an amazing log tool for your Mikrotik.
See my post here:
viewtopic.php?t=117509
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
tigro11
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Tue Feb 20, 2018 12:31 am

Re: v6.42rc [release candidate] is released!

Sat Mar 24, 2018 7:35 pm

I saw the Splunk installation, but I tried not to commit a machine to mount the Splunk server. On PFsense I use NTOPNG, unfortunate that on mikrotik you can not install as memory could be used or USB sticks or better still the Micro SD. I need it because I have to keep track of the surfing of my hotspot. If you have a solution to track without engaging a computer as a log server it would be a great thing
now i use this solution.
https://www.wirelessguru.it/mikrotik/mi ... poe-server
 
pe1chl
Forum Guru
Forum Guru
Posts: 5810
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Sat Mar 24, 2018 9:57 pm

When you have special requirements that require a special program which isn't available on MikroTik, and you
do not want to spend a lot of money on a dedicated computer, consider using a Raspberry Pi or similar SBC.
 
tigro11
Frequent Visitor
Frequent Visitor
Posts: 68
Joined: Tue Feb 20, 2018 12:31 am

Re: v6.42rc [release candidate] is released!

Sun Mar 25, 2018 7:41 pm

nice of the info, could I use the nas synology or qnap to save or view the logs?
 
staslabs
newbie
Posts: 38
Joined: Mon Feb 27, 2006 9:38 pm
Contact:

Re: v6.42rc [release candidate] is released!

Mon Mar 26, 2018 2:53 pm

6.42rc49 - DISK Lite AC (arm)

NTP client not work
 
mt99
newbie
Posts: 25
Joined: Wed Jan 03, 2018 6:07 pm

Re: v6.42rc [release candidate] is released!

Mon Mar 26, 2018 5:28 pm

nice of the info, could I use the nas synology or qnap to save or view the logs?
Synology NAS can do it if you install the Log Center package and configure it as the syslog destination for your Mikrotik. QNAP probably does something similar.
 
User avatar
eworm
Member
Member
Posts: 391
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 11:52 am

Updated a 750GL to 6.42rc52, when creating a backup I get:
backup,critical mikrotik: error creating backup file: could not read all configuration files
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 12:35 pm

What's new in 6.42rc52 (2018-Mar-26 12:41):

*) bridge - fixed "master-port" configuration conversion from pre-v6.41 RouterOS versions (introduced in 6.42rc);
*) certificate - fixed incorrect SCEP URL after an upgrade;
*) chr - added support for "multi-queue" feature for "virtio-net" driver;
*) chr - added support for Amazon Elastic Network Adapter (ENA) driver;
*) chr - added support for booting from NVMe disks;
*) chr - fixed interface matching by name on VMware installations;
*) chr - run startup scripts also on the first boot on AWS and Google Cloud installations;
*) crs3xx - added initial “hw-offload†support for 802.3ad and “balance-xor†bonding;
*) led - fixed unused "link-act-led" LED trigger on RBLHG 2nD, RBLHG 2nD-XL and RBSXTsq 2nD;
*) lte - added initial support for Quectel LTE EP06-E;
*) lte - fixed LTE band setting for SXT LTE;
*) routerboard - properly detect hAP ac^2 RAM size;
*) ssh - fixed SSH service becoming unavailable;
*) traffic-flow - fixed IPv6 destination address value when IPFIX protocol is used;
*) watchdog - retry to send "autosupout.rif" file to an e-mail if initial delivery failed up to 3 times within 20 second interval;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
dksoft
newbie
Posts: 47
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 1:07 pm

*) chr - added support for booting from NVMe disks;
Does this mean, that RouterOS can now be installed on UEFI devices?
Setup: Dt. Telekom FTTH, CHR on Promox, ZyXEL GS1900-48HP, WAP AC. MCTNA
 
hapi
Member Candidate
Member Candidate
Posts: 223
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 1:30 pm

Neighbors search sometimes seen, sometimes not in winbox (3.12). (CRS326)
Last edited by hapi on Tue Mar 27, 2018 1:43 pm, edited 1 time in total.
 
User avatar
kometchtech
Member Candidate
Member Candidate
Posts: 194
Joined: Sat Jun 15, 2013 4:25 am
Location: Japan
Contact:

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 1:37 pm

Neighbors search sometimes seen, sometimes not in winbox. (CRS326)
I am also experiencing this phenomenon.
It seems that it takes a tremendous amount of time to search RB from Winbox (3.12). After about 10 minutes, I saw some things.

- CCR1009-8G1S-S+
- RB850Gx2
- RB2011UAS

The following RBs were not searched.
- RB3011UiAS
- RB962UiGS-5HacT2HnT
--
Routerboard Users Group JP
http://www.rb-ug.jp/
CCR1009-8G-1S-1S+, RB750Gr3, CRS226-24G-2S+, RB850Gx2, RB960PGS, CRS317-1G-16S+,
RB2011UAS, CRS125-24G-1S, RB962UiGS-5HacT2HnT, CRS212-1G-10S-1S+, RB3011UiAS
 
hapi
Member Candidate
Member Candidate
Posts: 223
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 1:58 pm

Neighbors search sometimes seen, sometimes not in winbox. (CRS326)
I am also experiencing this phenomenon.
It seems that it takes a tremendous amount of time to search RB from Winbox (3.12). After about 10 minutes, I saw some things.

- CCR1009-8G1S-S+
- RB850Gx2
- RB2011UAS

The following RBs were not searched.
- RB3011UiAS
- RB962UiGS-5HacT2HnT

And also CRS112-8P, CRS112-8G, CRS317...
 
kez
newbie
Posts: 39
Joined: Tue Jul 05, 2005 4:13 am

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 3:36 pm

*) chr - added support for "multi-queue" feature for "virtio-net" driver;
I've been waiting for this! Thanks!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 4:37 pm

We will resolve Winbox ND issue as soon as possible.
 
dksoft
newbie
Posts: 47
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 6:06 pm

*) chr - added support for "multi-queue" feature for "virtio-net" driver;
I've been waiting for this! Thanks!
Me too.
How do I tell RouterOS how many queues I have allocated on the hypervisor or does RouterOS set them equal to the number of CPU cores?
Setup: Dt. Telekom FTTH, CHR on Promox, ZyXEL GS1900-48HP, WAP AC. MCTNA
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 7:06 pm

Per CPU, I think. Check with
/system resource irq print where users~"virtio"
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
dksoft
newbie
Posts: 47
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v6.42rc [release candidate] is released!

Tue Mar 27, 2018 11:25 pm

Per CPU, I think. Check with
/system resource irq print where users~"virtio"
Good tip, thanks.
It does automatically detect how many queues are configured. No need to change anything in RouterOS.
Setup: Dt. Telekom FTTH, CHR on Promox, ZyXEL GS1900-48HP, WAP AC. MCTNA
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Wed Mar 28, 2018 3:11 pm

My LACP problem is still Present in this RC ([Ticket#2018031222001218] LACP HW problem reaching bridge)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Wed Mar 28, 2018 4:06 pm

My LACP problem is still Present in this RC ([Ticket#2018031222001218] LACP HW problem reaching bridge)
We cannot see this ticket's contents.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 29, 2018 12:37 pm

I know that there are some problems in the WiFi section of hAP ac^2. There are significantly improvement with V6.42rc52, however, this is not enough. Please take at take at the following figures:

iperf3 server installed on a QNAP NAS
iperf3 client installed on MacBook Pro
5G With WiFi Password, Firmware 6.42RC52

Connecting to host 192.168.55.203, port 5201
[  4] local 192.168.88.253 port 50625 connected to 192.168.55.203 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-1.00   sec  46.2 MBytes   388 Mbits/sec                  
[  4]   1.00-2.00   sec  21.2 MBytes   178 Mbits/sec                  
[  4]   2.00-3.00   sec  28.4 MBytes   238 Mbits/sec                  
[  4]   3.00-4.00   sec  49.1 MBytes   414 Mbits/sec                  
[  4]   4.00-5.00   sec  48.9 MBytes   410 Mbits/sec                  
[  4]   5.00-6.00   sec  49.3 MBytes   414 Mbits/sec                  
[  4]   6.00-7.00   sec  48.6 MBytes   408 Mbits/sec                  
[  4]   7.00-8.00   sec  33.8 MBytes   283 Mbits/sec                  
[  4]   8.00-9.00   sec  34.8 MBytes   292 Mbits/sec                  
[  4]   9.00-10.00  sec  50.0 MBytes   419 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-10.00  sec   410 MBytes   344 Mbits/sec                  sender
[  4]   0.00-10.00  sec   410 MBytes   344 Mbits/sec                  receiver

iperf Done.
The figure shows very good. However, when we attempted to carry the actual file download tests, it turns out very dissatisfactory.

hAP ac² file transfer test
310.66MB file

V6.40.5 310MB (92s)27Mbps
V6.40.6(bug fixed) 310MB (82s) 30Mbps
V6.41.3 (stable) 310MB (124s) 20Mbps
V6.42.RC52 310MB (3s) 826Mbps
V6.42.RC52 310MB (30s) 83Mbps
V6.42.RC52 1.64GB file (147s) 89Mbps

hAP ac lite 5G WiFi file transfer test
V6.40.6 310MB (28s) 89Mbps.

Also I carried out the Mikrotik bandwidth test on both hAP ac^2 and hAP ac lite.


hAP ac^2 5G WiFi
Image

hAp ac lite
Image


Can anyone tell how comes the differences of them are so big?
Last edited by yhfung on Thu Mar 29, 2018 2:40 pm, edited 1 time in total.
 
mkx
Forum Guru
Forum Guru
Posts: 2929
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 29, 2018 2:22 pm

When you compare tests made with different tools (e.g. iperf VS. CIFS) you have to be aware of behaviour of test "tools". Tests done using iperf are not affected by latency much (apart from usual TCP slow-start) while some more "chatty" protocol (such as CIFS file transfer) can be affected by larger latency quite much.

In your particular case one needs to know what was latency during CIFS test (and latency with idle connection) and it might become quite obvious why CIFS shows so much worse results than iperf. Or it might not.

I work for mobile network operator and when we are measuring pure radio performance, we allways use iperf (and UDP). If such "raw" test shows good performance, then the rest is lost elsewhere, either other parts of network or is artefact of application. One example of application affecting tests was when using Ookla Speedtest on Android: we were consistently getting much worse results when running Speedtest directly on smart phone than when running Speedtest on laptop with USB tethering between the very same smart phone and laptop. We attributed the difference to the fact that phone's CPU was unable to process all data in due time. We also observed negative impact of app when testing latency. Speedtest, run on laptop, was giving us say 30ms RTT but we were able to show that reply from server arrived into the laptop after say 22ms ... but app took another few ms to process data. We couldn't say when additional delay occurred (at TX or at RX or both), but that's about how correct tests can be.
BR,
Metod
 
NetflashTechnical
just joined
Posts: 15
Joined: Fri May 10, 2013 3:43 pm

Re: v6.42rc [release candidate] is released!

Thu Mar 29, 2018 6:14 pm

With the Unknown Unicast/Multicast Flood disable button being added in to the bridgeports, is there a way we can get that added to PPP profiles similar to bridge/bridge priority/cost/horizon? OR have a bridge-wide default option for it to be either on or off? I'd rather it DIDN'T default to "on"

Image

Thanks
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: v6.42rc [release candidate] is released!

Fri Mar 30, 2018 7:08 am

When you compare tests made with different tools (e.g. iperf VS. CIFS) you have to be aware of behaviour of test "tools". Tests done using iperf are not affected by latency much (apart from usual TCP slow-start) while some more "chatty" protocol (such as CIFS file transfer) can be affected by larger latency quite much.

.......
Thank you very much for responding my post. Based on your information, I have already learned more about network bandwidth, throughput, and latency.

Based on the results of MikroTik Bandwidth test on hAP ac^2 5G ac and hAP ac lite 5G ac, they show that the firmware V6.42RC52 on hAP ac^2 has to be finely tuned to achieve a stable and nearly flat performance otherwise the sales order for this product will drop tremendously due to poor and unstable performance.

In summary,

1. Bandwidth - can be determined by iperf3, MikroTik bandwidth test

2. Throughput - can be determined by actual file transfer or the equivalent area in MikroTik bandwidth Test

3. Latency - can be determined by ping command.
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.42rc [release candidate] is released!

Sat Mar 31, 2018 2:57 pm

/system package> print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-arm 6.42rc52
1 system 6.42rc52
2 X ipv6 6.42rc52
3 wireless 6.42rc52
4 hotspot 6.42rc52
5 dhcp 6.42rc52
6 mpls 6.42rc52
7 routing 6.42rc52
8 ppp 6.42rc52
9 security 6.42rc52
10 advanced-tools 6.42rc52
...
/system routerboard> print
routerboard: yes
board-name: cAP ac
model: RouterBOARD cAP Gi-5acD2nD
serial-number: **************
firmware-type: ipq4000L
factory-firmware: 3.43
current-firmware: 6.42rc52
upgrade-firmware: 6.42rc52
...
14:18:26 system,info device changed by admin
14:18:35 wireless,debug wlan2: must select channel
14:18:35 wireless,debug wlan2: selected channel 5260000
14:18:35 wireless,debug wlan2: search for radars on 5260000
14:19:35 wireless,debug wlan2: no radar detetected, start network
14:19:42 system,info device changed by admin
14:19:51 wireless,debug wlan2: must select channel
14:19:51 wireless,debug wlan2: selected channel 5500000
14:19:51 wireless,debug wlan2: search for radars on 5500000
14:20:51 wireless,debug wlan2: no radar detetected, start network
14:20:53 system,info device changed by admin
14:21:02 wireless,debug wlan2: must select channel
14:21:02 wireless,debug wlan2: selected channel 5520000
14:21:02 wireless,debug wlan2: search for radars on 5520000
14:22:02 wireless,debug wlan2: no radar detetected, start network
14:22:03 system,info device changed by admin
14:22:12 wireless,debug wlan2: must select channel
14:22:12 wireless,debug wlan2: selected channel 5540000
14:22:12 wireless,debug wlan2: search for radars on 5540000
14:32:12 wireless,debug wlan2: no radar detetected, start network
14:32:14 system,info device changed by admin
14:32:22 wireless,debug wlan2: must select channel
14:32:22 wireless,debug wlan2: selected channel 5560000
14:32:22 wireless,debug wlan2: search for radars on 5560000
14:42:22 wireless,debug wlan2: no radar detetected, start network
14:42:26 system,info device changed by admin
14:42:35 wireless,debug wlan2: must select channel
14:42:35 wireless,debug wlan2: selected channel 5580000
14:42:35 wireless,debug wlan2: search for radars on 5580000
14:52:22 wireless,debug wlan2: no radar detetected, start network



Is there any bug? DFS searching time is 10minutes ??

p.s.: found answer... : IEEE 802.18-08/0016r0
Radar Detect and DFS on MikroTik
https://www.youtube.com/watch?v=ZbrbRUAfpac

Is it possible to display the time in the status window?
--
poi
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42rc [release candidate] is released!

Sun Apr 01, 2018 2:30 pm

...
Is there any bug? DFS searching time is 10minutes ??

p.s.: found answer... : IEEE 802.18-08/0016r0
Radar Detect and DFS on MikroTik
https://www.youtube.com/watch?v=ZbrbRUAfpac

Is it possible to display the time in the status window?
I also have Mimosa and there the DFS even takes the network down longer. Up to some 15-20 minutes. Partially also because when the AP if 'free'd' from the DFS it takes a long time before clients are associated back and in full running mode again. Actually, if your Mimosa P2MP network is hammered by DFS you might as well not use is it at all....... completely unusable. You have to find a band/channel that has no radar or no DFS restrictions. Only then it works. (there is no way of avoiding DFS in Mimosa product line, as we can with MT. ;-) )
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.42rc [release candidate] is released!

Sun Apr 01, 2018 5:16 pm

...
Is there any bug? DFS searching time is 10minutes ??

p.s.: found answer... : IEEE 802.18-08/0016r0
Radar Detect and DFS on MikroTik
https://www.youtube.com/watch?v=ZbrbRUAfpac

Is it possible to display the time in the status window?
I also have Mimosa and there the DFS even takes the network down longer. Up to some 15-20 minutes. Partially also because when the AP if 'free'd' from the DFS it takes a long time before clients are associated back and in full running mode again. Actually, if your Mimosa P2MP network is hammered by DFS you might as well not use is it at all....... completely unusable. You have to find a band/channel that has no radar or no DFS restrictions. Only then it works. (there is no way of avoiding DFS in Mimosa product line, as we can with MT. ;-) )
I understood it.
I'm playing with capsman ant 5 access points, At first time I did not understand why there is no wireless connection... :)

But I think it will be better if in satus window will show not only detecting radar but countdown timer, so you will known exactly when detecting will end.
--
poi
 
deanMKD1
Member
Member
Posts: 345
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: v6.42rc [release candidate] is released!

Mon Apr 02, 2018 5:17 pm

After flashing latest 6.42RC52 Winbox not auto detect my hAP AC2.
 
th0massin0
Member Candidate
Member Candidate
Posts: 144
Joined: Sun May 11, 2014 4:16 am
Location: Poland

Re: v6.42rc [release candidate] is released!

Mon Apr 02, 2018 11:56 pm

*) lte - fixed LTE band setting for SXT LTE;
What does it fix excatly? Does it improve connection stability?
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: v6.42rc [release candidate] is released!

Tue Apr 03, 2018 2:41 pm

I have already created another thread concentrating on the status of the WiFi problems found in hAP ac^2 in the following thread.

viewtopic.php?f=7&t=132648&p=651986#p651751

Even applied the most recent RC (V6.42RC52), although the speed for 5G WiFi has already been increased from 20Mbps to 90Mbps, which is much below our expectations. We want the device to be capable to download file at a steady and stable rate of 500Mbps over at least an hour and not just few mini-seconds..
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 12:27 am

*) lte - fixed LTE band setting for SXT LTE;
What does it fix excatly? Does it improve connection stability?
no
we couldn't change LTE band from 3 to 7
in older versions
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
schadom
Member Candidate
Member Candidate
Posts: 139
Joined: Sun Jun 25, 2017 2:47 am
Location: Austria

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 2:24 am

*) snmp - added w60g support;
BGP4 MIB (RFC 4273) next please :-)
 
jondavy
Member Candidate
Member Candidate
Posts: 126
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 2:31 am

PPPoE Server not work into VLAN Interfaces
reverting back to 6.39.1 that works perfectly
tested with RB3011 and CCR1009

I use a vlan to deliver to each neighborhood or sector,
/interface bridge add name=LAN
/interface bridge port add bridge=LAN interface=ether5
/interface bridge port add bridge=LAN interface=ether6
/interface bridge port add bridge=LAN interface=ether7
/interface bridge port add bridge=LAN interface=ether8

/interface vlan add name=POP-CENTRO-SECTOR-LESTE interface=LAN use-service-tag=yes vlan-id=100

/ip pool add name=PPPoE-RES-1M ranges=172.16.11.1-172.16.11.126

/ppp profile add dns-server=172.31.255.2,1.1.1.2 local-address=1.1.1.2 name="1 MEGA" rate-limit="1M/1M" remote-address=PPPoE-RES-1M
/interface pppoe-server server add disabled=no interface=POP-CENTRO-SECTOR-LESTE default-profile="1 MEGA" service-name=BRAS1


Arriving in the neighborhood, i untag the vlan in the sectorial wlan like this (into my sectors SXT SA5).
/interface bridge add name=bridge1
/interface bridge port add bridge=bridge1 interface=wlan1
/interface bridge port add bridge=bridge1 interface=ether1
/interface wireless set [ find default-name=wlan1 ] vlan-id=100 vlan-mode=use-service-tag

the PPPoE server shows this looping log:
jan/01 21:04:16 pppoe,info PPPoE connection established from D4:6E:0E:BC:E2:FB
jan/01 21:04:16 pppoe,info PPPoE connection from D4:6E:0E:BC:E2:FB was already active - closing previous one

it is not a problem of the sector nor the wireless configuration this also happens by cable or fiber, untagging and dialing with any other brand that is not RouterOS not only works RouterOS dial PPPoE, can test, it is not a configuration problem, because everything worked perfectly in earlier versions,

I apologize for the long thread in the forum, but I've been posting a lot of time on the forums on Release Candidate until now, never solved.
reverting back to 6.39.1 that works perfectly
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 6:07 am

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) ike1 - fixed wildcard policy lookup on responder;
What kind of cases does it address?
 
jarda
Forum Guru
Forum Guru
Posts: 7602
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 8:20 am

The rbd52g hap ac2 wifi performance is really painful.

Mikrotik, please provide a statement to this.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 10:30 am

After flashing latest 6.42RC52 Winbox not auto detect my hAP AC2.
In version 6.42rc52 on Hаp Ас^2 there are problems with Interface/interface list. Tools that use interface list do not work. Such as the MAC winbox server or parameter In. Interface list in firewall rules.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 11:52 am

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) ike1 - fixed wildcard policy lookup on responder;
What kind of cases does it address?
L2TP/IPSec wasn't working for me in earlier RCs :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 4:30 pm

What's new in 6.42rc39 (2018-Mar-07 07:01):

*) ike1 - fixed wildcard policy lookup on responder;
What kind of cases does it address?
L2TP/IPSec wasn't working for me in earlier RCs :)
I should have been more specific. Does it affect 6.41.3, or was introduced on this RC? Is it a problem with the wildcard no matching at all? Or matching too much? Or just matching incorrectly?

TIA
 
pe1chl
Forum Guru
Forum Guru
Posts: 5810
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42rc [release candidate] is released!

Thu Apr 05, 2018 5:11 pm

L2TP/IPsec works OK on 6.41.3 so it must have been introduced in the RC (or it is a problem I don't notice...)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42rc [release candidate] is released!

Fri Apr 06, 2018 12:07 pm

Yep, it was introduced in RC, just a few versions earlier. I noticed it on default configuration.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.42rc [release candidate] is released!

Fri Apr 06, 2018 5:01 pm

Yep, it was introduced in RC, just a few versions earlier. I noticed it on default configuration.
Ah, thanks. Good to know. :D
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42rc [release candidate] is released!

Fri Apr 06, 2018 6:13 pm

Confirmation from MT in Mail RC55 will have fix for my LACP Bonding problem. Have a Nice week end and I hope for the soon Release of RC55. One wonder what more magical fixes will be included.
;-)
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3082
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42rc [release candidate] is released!

Fri Apr 06, 2018 7:37 pm

Confirmation from MT in Mail RC55 will have fix for my LACP Bonding problem. Have a Nice week end and I hope for the soon Release of RC55. One wonder what more magical fixes will be included.
;-)
Let's hope is doesn't introduce new bugs after all that German beer..... :lol: :lol: :lol:
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Mon Apr 09, 2018 12:52 pm

What's new in 6.42rc56 (2018-Apr-09 08:18):

*) crs3xx - added initial "hw-offload" support for 802.3ad and "balance-xor" bonding;
*) dhcpv4-server - added "dns-none" option to "/ip dhcp-server network dns";
*) dns - do not generate "Undo" messages on changes to dynamic servers;
*) ike2 - fixed framed IP address received from RADIUS server;
*) ippool6 - added pool name to "no more addresses left" error message;
*) ipv6 - fixed IPv6 behavior when slave leaves bridge;
*) ipv6 - update IPv6 DNS from RA only when it is changed;
*) led - added "Dark Mode" support for wAP 60G;
*) led - added w60g alignment trigger;
*) rb1100ahx4 - improved reliability on hardware encryption;
*) w60g - added "tx-power" setting (CLI only);
*) w60g - added RSSI information (CLI only);
*) w60g - added TX sector alignment information (CLI only);
*) winbox - fixed Neighbor Discovery and MAC Winbox (introduced in v6.42rc);
*) wireless - fixed RB911-5HnD low transmit power issue;
*) wireless - fixed wsAP wrong 5 GHz interface MAC address;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.

Note that release candidate versions are published strictly for testing purposes and should not be used on production routers.
 
yhfung
Member Candidate
Member Candidate
Posts: 142
Joined: Tue Nov 20, 2012 6:58 pm

Re: v6.42rc [release candidate] is released!

Mon Apr 09, 2018 2:57 pm

This testing release (v6.42rc56) cannot resolve the poor WiFi performance issue in hAP ac^2. For details, please refer to the following link:

viewtopic.php?f=7&t=132648&p=653102#p653102

YH
 
soooc
newbie
Posts: 25
Joined: Thu Mar 10, 2011 1:51 pm

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 12:12 am

In rc56 w60g multipoint is not working and there is no opportunity to generate support.rif. Its looks lock, reboot takes about 2 minutes to start.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 8:30 am

hAP ac^2. When upgrading from rc52 to rc56, i get a bootloop again. Restored by netinstall.
 
pepek
just joined
Posts: 23
Joined: Tue Apr 10, 2018 12:14 am
Location: CZ

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 9:11 am

hAP ac^2 upgraded correctly from rc52 to rc56 but wifi performance is still very poor - the same problem yhfung is talking about.
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 106
Joined: Wed Feb 10, 2016 3:55 pm

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 9:20 am

hAP ac^2. When upgrading from rc52 to rc56, i get a bootloop again. Restored by netinstall.
Everything works for me without issues. Can you repeat this reboot loop after Netinstall with RouterOS and RouterBOOT
.rc56
versions?
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 9:30 am

Can you repeat this reboot loop after Netinstall with RouterOS and RouterBOOT
.rc56
versions?
No. Now, with rc56, router reboot correctly.
 
miencek
just joined
Posts: 5
Joined: Tue Apr 10, 2018 8:51 am

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 2:58 pm

Hello. I'm trying to use the new function of the fetch tool but unfortunately I can not send the content to a variable. Has anyone already used the USER mode?
:global zmienna [/tool fetch mode=tftp address=192.168.88.1 src-path=test.txt output=user]
 
dksoft
newbie
Posts: 47
Joined: Thu Dec 06, 2012 8:56 am
Location: Germany

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 4:33 pm

DELETED
Setup: Dt. Telekom FTTH, CHR on Promox, ZyXEL GS1900-48HP, WAP AC. MCTNA
 
bbs2web
Member Candidate
Member Candidate
Posts: 198
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Tue Apr 10, 2018 9:46 pm

Hi strods,

We run Proxmox (Debian 9 with KVM) and upgraded a CHR to 6.42rc 56 to test multi-queue VirtIO network support.

We set queues equal to the assigned CPU cores and upgraded the router. After booting RouterOS there are no entries in '/int ethernet'...
Last edited by bbs2web on Thu Apr 12, 2018 12:29 am, edited 1 time in total.
 
jfmt
just joined
Posts: 1
Joined: Wed Apr 11, 2018 6:00 pm

Re: v6.42rc [release candidate] is released!

Wed Apr 11, 2018 7:04 pm

Hello.

Maybe this bug or feature.

I use 6.42rc56 CRS317-1G-16S+ for build bonding (LAG+LACP+HW Offload) with HP G8 server with Ubuntu 16.04.3 LTS

I use Mikrotik as DHCP Server, Linux work as client. DHCP, ICMP work good. But from Linux over bonding interface in schem one i can't connect to Mikrotik SSH. Firewall empty. I use Mikrotik as DNS server, but from Linux name not resolve. In tcpdumps all look good, but not work.

Network card type same at all servers.

09:00.0 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (be3) (rev 01)
09:00.1 Ethernet controller: Emulex Corporation OneConnect 10Gb NIC (be3) (rev 01)

Image

Linux servers bonding configurations.

# Bond

auto ens2f0
allow-hotplug ens2f0
iface ens2f0 inet manual
bond-master bond0

auto ens2f1
allow-hotplug ens2f1
iface ens2f1 inet manual
pre-up sleep 5
bond-master bond0

auto bond0
iface bond0 inet dhcp
bond-mode 802.3ad
bond-miimon 100
bond-lacp-rate 1
bond-slaves ens2f0 ens2f1
bond_xmit_hash_policy layer2+3

Mikrotik configuration.

/interface bridge
add fast-forward=no name=bridge_servers priority=0x1000

/interface bonding
add lacp-rate=1sec min-links=1 mode=802.3ad name=bond_S1 slaves=sfp-sfpplus1,sfp-sfpplus2
add lacp-rate=1sec min-links=1 mode=802.3ad name=bond_H1 slaves=sfp-sfpplus3,sfp-sfpplus4
add lacp-rate=1sec min-links=1 mode=802.3ad name=bond_H2 slaves=sfp-sfpplus5,sfp-sfpplus6

/interface bridge port
add bridge=bridge_servers interface=bond_S1
add bridge=bridge_servers interface=bond_H1
add bridge=bridge_servers interface=bond_H2

Image

When i change configuration to active-backup mode at one server. I can ssh/resolve to Mikrotik from any servers.

# Bond

auto ens2f0
allow-hotplug ens2f0
iface ens2f0 inet manual
bond-master bond0

auto ens2f1
allow-hotplug ens2f1
iface ens2f1 inet manual
pre-up sleep 5
bond-master bond0

auto bond0
iface bond0 inet dhcp
bond-mode active-backup
bond-arp-interval 100
bond-arp-ip-target 192.168.112.1
bond-primary ens2f0

/interface bridge port
add bridge=bridge_servers interface=bond_H1
add bridge=bridge_servers interface=bond_H2
add bridge=bridge_servers interface=sfp-sfpplus1
add bridge=bridge_servers interface=sfp-sfpplus2

All other configuration at Mikrotik same. I attache support.rif in Ticket#2018041122005401

Can you help resolve this problem?

12.04.2018

When i disable hw-offload on 802.3ad bond interface all start work. When hw-offload enabled i can't connect to servers from Mikrotik.
I found workaround. Add empty EoIP interface to servers bridge and now all look working. Later i understand that this not solve problem.

14.04.2018

After some tests i found that communication randomly stop from H1 to S1, for example after one hour more or less. Up/Down bridge interface fix problem but only for some time. I check fault tolerance by logicaly shut one interface of bond, all traffic go one interface. After unshut interface traffic no comeback. This results not for production use. I move to active-backup with ARP monitoring. This without load balance but work. I not try downgrade software. If somebody have information about problem like this write it here.

19.04.2018

Mikrotik confirm this problem in ticket #018041122005401. I change schem and add VLAN because need seporate INET from MGMT. Still want use hw-offload for VLAN. But now i have another problem. I can't ping CSS326-24G-2S+ from CRS317-1G-16S+. If i disable hw-offload on port SFP16 all start work. If i shut/unshut bridge all start work.

Image

Maybe this other problem.

Sorry English no my native language.

Thank you.
Last edited by jfmt on Thu Apr 19, 2018 4:07 pm, edited 4 times in total.
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.42rc [release candidate] is released!

Thu Apr 12, 2018 12:56 am

hAP ac^2 upgraded correctly from rc52 to rc56 but wifi performance is still very poor - the same problem yhfung is talking about.
so there is two tests, one test and after few seconds - second test.

no changes, no move just chrome open new tab and repteat test
DL 2.75Mbps / UL 102.40Mbps
vs
DL 321Mps / UL 416.29Mbps
vs
and third test : DL 370.81Mbps / UL 463.15Mbps
fourth test with distance about half meter : DL 343.02Mbps / UL 517.73Mbps

so wehere is comment from MT ? :D

viewtopic.php?f=2&t=132576&p=653717#p653717
--
poi
 
bbs2web
Member Candidate
Member Candidate
Posts: 198
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Thu Apr 12, 2018 2:32 pm

Upgrading RouterOS x86 to 6.42rc56 on a reset configuration results in multi-queue VirtIO appearing to initialise.

Some questions:
  • I assume we should disable RPS?
  • Shouldn't the IRQ counters be incrementing on other queues? Perhaps someone running multi-queue vmxnet3 could compare?

Herewith a screenshot of multi-queue VirtIO. IRQ appear to exclusively increment on the first queue:
Image

Herewith our settings:
/queue type
add kind=mq-pfifo mq-pfifo-limit=10000 name=mq-pfifo-10k
/queue interface
set ether1 queue=mq-pfifo-10k
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=ether1
/system package update
set channel=release-candidate
/system resource irq rps
set ether1 disabled=yes
 
bbs2web
Member Candidate
Member Candidate
Posts: 198
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Thu Apr 12, 2018 3:00 pm

Perhaps multi-queue hasn't been enabled by the guest?

Documentation (http://www.linux-kvm.org/page/Multiqueue) details guests having to run:
ethtool -L eth0 combined $queue_num
 
conecting
newbie
Posts: 26
Joined: Sat Jul 12, 2014 11:38 pm

Re: v6.42rc [release candidate] is released!

Thu Apr 12, 2018 3:34 pm

Can anybody give me some advice how to get RSSI values from cli of WAP 60G ?
 
npero
Member
Member
Posts: 316
Joined: Tue Mar 01, 2005 1:59 pm
Location: Serbia

Re: v6.42rc [release candidate] is released!

Thu Apr 12, 2018 5:22 pm

interface w60g monitor wlan60-1 
Just replace wlan60-1 with your interface name they will give it something like this
connected: yes
       frequency: 58320
  remote-address: 04:xxxxxx
             mcs: 4
          signal: 40
            rssi: -68
       tx-sector: 28
  tx-sector-info: left 3.8 degrees, down 3.8 degrees
       rx-sector: 96

 
emptyfield
just joined
Posts: 7
Joined: Fri Mar 11, 2016 12:39 pm

Re: v6.42rc [release candidate] is released!

Fri Apr 13, 2018 12:16 pm

After upgrading to 6.42RC56 from 6.40 (to test NV2 improvements) wds interfaces in winbox randomly appearing/disappearing in period about 1 second, but in registration table looks like there is no disconnects and disappeared interfaces still working.. RB433AH with one R52Hn card, nv2, 20/40Ce, 5GHz band.
 
User avatar
indnti
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu Nov 09, 2006 11:53 am

Re: v6.42rc [release candidate] is released!

Sat Apr 14, 2018 4:00 am

Whats going on with 6.42 ? Problems over problems. Bricked hardware, update problems without ends. Maybe you begin from scratch :-(
 
eddieb
Member Candidate
Member Candidate
Posts: 137
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.42rc [release candidate] is released!

Sat Apr 14, 2018 10:24 am

There is NO 6.42
Only 6.42rc [release candidate]
RC are BETA versions that can be used to TEST certain new (or fixed) features.
BETA software should not be run on critical devices, just on test networks.
Running 6.45.6 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
oh3mbc
just joined
Posts: 4
Joined: Sun Apr 03, 2016 11:31 am

Re: v6.42rc [release candidate] is released!

Sat Apr 14, 2018 8:47 pm

In rc56 w60g multipoint is not working
I confirm this. Went back to 6.41.4 and PtMP is working again.
 
Kerbia
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Wed Nov 16, 2016 3:03 pm

Re: v6.42rc [release candidate] is released!

Sat Apr 14, 2018 11:13 pm

Please MikroTik give us more information about the weak performance of hap ac² and cap ac.

What further things can we do to support you fixing the issue?
How have you been able to get the figures published on the product's page?
What's the ETA to fix this huge problem?


Please follow these threads:
viewtopic.php?f=2&t=132576&p=653717#p653717
viewtopic.php?f=3&p=654207#p654207
 
bbs2web
Member Candidate
Member Candidate
Posts: 198
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.42rc [release candidate] is released!

Mon Apr 16, 2018 3:26 am

We repeated the exercise again and had success upgrading to 6.42rc56, only the first queue receives IRQ events though. Probably not calling:
ethtool -L ether1 combined 8
Hi strods,

We run Proxmox (Debian 9 with KVM) and upgraded a CHR to 6.42rc 56 to test multi-queue VirtIO network support.

We set queues equal to the assigned CPU cores and upgraded the router. After booting RouterOS there are no entries in '/int ethernet'...
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42rc [release candidate] is released!

Fri Apr 20, 2018 2:18 pm

Version 6.43rc has been released:
viewtopic.php?f=21&t=133420

Who is online

Users browsing this forum: No registered users and 7 guests