Page 1 of 1

v6.41.2 [current]

Posted: Fri Feb 09, 2018 3:29 pm
by strods
RouterOS version 6.41.2 has been released in public "current" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.41.2 (2018-Feb-06 12:29):

*) bridge - fixed ARP settings on bridge interfaces (introduced v6.41);
*) discovery - fixed discovery interface list change;
*) disk - fixed disk related processes becoming unresponsive after unplugging used disk;
*) filesystem - fixed situations when "/flash" directory lost files after upgrade;
*) ppp - do not lose "/ppp profile" script configuration after other profile parameters are edited;
*) routerboard - properly report warnings under "/system routerboard" menu;
*) snmp - added w60g support;
*) w60g - fixed "/interface w60g reset-configuration";
*) webfig - fixed backup loading from Webfig on RouterBOARD running default configuration;
*) winbox - changed default bridge port PVID value to 1;
*) wireless - fixed wireless protocol mode restrictions if lockpack is installed and has limits for it;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after crash.

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 4:52 pm
by pe1chl
Does it fix all the reported new 6.41.1 (vs 6.41) issues reported in the 6.41.1 topic?
It does not look like that in the changelog...

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 6:37 pm
by w0lt
Upgraded several 6.4.1 versions, no problems yet. 8)

-tp

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 6:53 pm
by ErfanDL
After upgrade to 6.41.2 bridge mac address changed :|

Sent from my C6833 using Tapatalk



Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 7:09 pm
by lisek
Thank goodness WEBFIG dude works on the server in the web interface, and there is access to information. Difficult but it is.

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 7:19 pm
by drees
I noticed that starting with v6.41.1 (and v6.41.2) that the routerboard-firmware versioning has changed to match the RouterOS version.

This is fine, but with these last two versions, there were firmware updates for my 951G-2HnD and 941-2nD.

Problem is that there's no real indication that a firmware update is available when updating RouterOS, so a firmware update is easy to miss - it's also impossible to tell what changes are in the firmware and how important it might be to apply those firmware updates.

On a similar note, after pressing the Upgrade button on the Routerboard firmware upgrade page, some sort of simple message saying that you should reboot when the firmware is updated should be presented. Right now I usually go to the Log file to verify that the firmware updated before rebooting.

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 9:14 pm
by jackx
After upgrade to 6.41.2 bridge mac address changed :|
I suspect the changes in the bridge settings and behavior caused my hAP lite bridges to become unresponsive. I'd like to upgrade for the hardware offloading features but I'm afraid my devices will lock up again.

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 9:31 pm
by LucZWFM
After upgrading my only just 3 months old 2011iL-RM got stuck in a bootloop and
I am not able to recover it, what ever I try..

:(

Re: v6.41.2 [current]

Posted: Fri Feb 09, 2018 11:02 pm
by PashaT
interface,warning ether3: bridge port received packet with own address as source address (#MAC), probably loop

hap-ac-lite(port3) connected to the hap-lite(port1).
hap-lite configured as bridge.

Reproduced with 6.41, 6.41.1, 6.41.2.

[Ticket#2018020922005437]

What's new in 6.41.1 (2018-Jan-30 10:26):
*) bridge - fixed situation when packet could be sent with local MAC as dst-mac;

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 12:38 am
by strods
pe1chl - Which specific fix are you looking for;
drees - Thank you for suggestion. Yes, at the moment you can see warning on CLI and System/RouterBOARD/Settings menu but do not see any warning pop-up;
jackx - Please do not assume that if someone did upgrade model X device to specific version and it did not boot up that there is some version related problem with particular model device. It is possible, but usually it is false alarm. In most cases, when router becomes unavailable after upgrade, problem is caused due to configuration changes (affected by upgrade - admin did not see changes in changelog) or there was a problem during upgrade (upgrade happens on old version, not the one which you install);
LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;
PashaT - This has nothing to do with the fix which you referenced. Are you sure that there is no actual loop in your network? Are you sure that there is no other device in network with same MAC address as this routers ether3 interface;

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 5:42 am
by i4ko
None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 5:58 am
by 105547111
The special dummy rule in filters, mangle and raw to show fasttrack is 0, but my own fasttrack rules are working and counting packets.

Actually they are counting but I see only 11 packets after 2 hours. My own fasttrack on fwd that is more restrictive shows 4 million and increasing.

Checked connections using fasttrack yes and no and indeed 2/3 of the traffic is fasttrack

Another new bug?

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 7:22 am
by CZFan
None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

/system package print

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 10:47 am
by LucZWFM
Still stuck in bootloop... no matter what I try...

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 10:48 am
by LucZWFM
LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;

The board refuses to appear in netinstall, tried on 3 computers now...
This make me unable to try anything...

I upgraded from 6.41.1.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 11:40 am
by strods
i4ko - Which RouterOS packages you have installed on your device;
105547111 - Most likely there are processes running on your router which stop FastTrack:
https://wiki.mikrotik.com/wiki/Manual:IP/Fasttrack
LucZWFM - Have you tried to Netinstall any other RouterBOARD to be sure that Netinstall is properly running?

Note: Netinstall is a tool which detects router running in Ether boot mode. Ether boot mode is started from firmware. RouterOS upgrade does not affect firmware. This clearly states that you simply can not upgrade RouterOS and suddenly Netinstall possibility would be broken. In 95% of cases there is a problem with Netinstall + computer + network configuration.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 12:48 pm
by Lakis
*) crs317 - improved transmit performance between 10G and 1G ports;
yes its fixed

but on 960PGS transmit performance between 1G and 100mbit not fixed (when hw offload enable)

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 5:30 pm
by zervan
Somebody using CRS112-8G-4S? I have 2 SFP modules on it. It is rebooting me each 2 minutes when I turn on IGMP Snooping. The same problem was with v6.41. Can't make supout, because not enough time to next reboot. Automatic Supout in Watchdog is not working (don't know why). No problem with CRS109-8G-1S-2HnD (and no SFP module).

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 5:44 pm
by PashaT
1. [Ticket#2018021022001447]
Detect Internet not working on two different providers.

2. [Ticket#2018020922005437]
PashaT - This has nothing to do with the fix which you referenced. Are you sure that there is no actual loop in your network? Are you sure that there is no other device in network with same MAC address as this routers ether3 interface;
No other devices with same mac, only one PC connected.

Additional info:
hap-lite configured as bridge, DHCP client on the bridge.
I see two DHCP leases on the root router, one with bridge port MAC, second with ether1 port MAC address.

EDITED:
When Detect Internet is activated on the interface without the address - invisible DHCP client running on that interface. Ether1 was added to detect interface list.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 6:19 pm
by GreySer
After upgrading my only just 3 months old 2011iL-RM got stuck in a bootloop and
I am not able to recover it, what ever I try..

:(
At RB3011 bootloop too.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 6:28 pm
by AntonReviakin
On Virtual of WLAN can't receive IP. Log: XX:XX:XX:XX:XX:XX@WLAN_VIRTUAL: disconnected, received deauth: sending station leaving (3)

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 7:08 pm
by jackx
jackx - Please do not assume that if someone did upgrade model X device to specific version and it did not boot up that there is some version related problem with particular model device. It is possible, but usually it is false alarm. In most cases, when router becomes unavailable after upgrade, problem is caused due to configuration changes (affected by upgrade - admin did not see changes in changelog) or there was a problem during upgrade (upgrade happens on old version, not the one which you install);
Let me be clear: before the upgrade, each bridge had its own MAC address. After the upgrade, there were MAC address conflicts because some of the bridges had the same MAC address. This should never happen. This was on FACTORY DEFAULT firmware and settings.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 9:29 pm
by mstead
The ping tool is broken and has been for many versions - I only noticed this tonight. The "timeout" option doesn't change the ping timeout but rather the interval between pings. So this is either a bug or a badly labelled "ping interval" option. However timeout is a crucial parameter for any ping tool.

Re: v6.41.2 [current]

Posted: Sat Feb 10, 2018 10:06 pm
by i4ko
None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

Code: Select all

[mkadm@MikroTik] > /file print
# NAME TYPE SIZE CREATION-TIME
0 flash directory feb/09/2018 20:46:43
1 flash/pub directory feb/09/2018 20:46:43
2 flash/skins directory feb/09/2018 20:46:43
[mkadm@MikroTik] >
/system package print

Code: Select all

[mkadm@MikroTik] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.41.1
1 system 6.41.1
2 X ipv6 6.41.1
3 wireless 6.41.1
4 X hotspot 6.41.1
5 dhcp 6.41.1
6 X mpls 6.41.1
7 routing 6.41.1
8 X ppp 6.41.1
9 security 6.41.1
10 advanced-tools 6.41.1
[mkadm@MikroTik] >
[/quote]
And the relevant portion from /system resource print

Code: Select all

uptime: 16h14m40s
version: 6.41.1 (stable)
build-time: Jan/30/2018 10:26:14
free-memory: 6.0MiB
total-memory: 32.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 9%
free-hdd-space: 7.0MiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 36352
write-sect-total: 39081061
bad-blocks: 0%
architecture-name: smips
board-name: hAP lite
platform: MikroTik

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 12:14 pm
by strods
Lakis, zervan, AntonReviakin - Please contact support@mikrotik.com regarding this issue. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem.
GreySer - What do you see on serial console? Did you try to Netinstall device?
jackx - If you did not have admin-mac configured, then bridge uses MAC address of first interface recognized by RouterOS. MAC can change between reboots, etc. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem?
mstead - This topic is created to find problems which were not in RouterOS in 6.41.1 and are in 6.41.2. Have you contacted support regarding this problem? We are not aware about such problem. Write to support@mikrotik.com regarding this problem.
i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 12:39 pm
by AntonReviakin
Lakis, zervan, AntonReviakin - Please contact support@mikrotik.com regarding this issue. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem.
GreySer - What do you see on serial console? Did you try to Netinstall device?
jackx - If you did not have admin-mac configured, then bridge uses MAC address of first interface recognized by RouterOS. MAC can change between reboots, etc. I assume that downgrade to 6.41.1 fix the problem and after upgrade to 6.41.2 again shows the same problem?
mstead - This topic is created to find problems which were not in RouterOS in 6.41.1 and are in 6.41.2. Have you contacted support regarding this problem? We are not aware about such problem. Write to support@mikrotik.com regarding this problem.
i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?
Thanks, it's works. In virtual WLAN dropdown "VLAN Mode" select "no tag" and reconnecting to both interfaces :-)

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 12:41 pm
by Mikhail73
Just now upgraded my wAP AC from 6.41 to 6.41.2. With my MacBook Air '15 RX/TX was 585/526, became nearly 270/270.
P.S. On 6.42 results are much worse.

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 2:42 pm
by CZFan
None of my 941-2nDs are able to upgrade. I have no files in files menu in winbox besides the regular ones. Yet the available space is only 6.9mb. The winbox will not start downloading the update, nor it is possible to upload a complete update file manually. I've tried recreating the flash folder and the flash/pub and flash/skins sub folders - no go. Please advise.
Provide results for:

/file print

Code: Select all

[mkadm@MikroTik] > /file print
# NAME TYPE SIZE CREATION-TIME
0 flash directory feb/09/2018 20:46:43
1 flash/pub directory feb/09/2018 20:46:43
2 flash/skins directory feb/09/2018 20:46:43
[mkadm@MikroTik] >
/system package print

Code: Select all

[mkadm@MikroTik] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.41.1
1 system 6.41.1
2 X ipv6 6.41.1
3 wireless 6.41.1
4 X hotspot 6.41.1
5 dhcp 6.41.1
6 X mpls 6.41.1
7 routing 6.41.1
8 X ppp 6.41.1
9 security 6.41.1
10 advanced-tools 6.41.1
[mkadm@MikroTik] >
And the relevant portion from /system resource print

Code: Select all

uptime: 16h14m40s
version: 6.41.1 (stable)
build-time: Jan/30/2018 10:26:14
free-memory: 6.0MiB
total-memory: 32.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 650MHz
cpu-load: 9%
free-hdd-space: 7.0MiB
total-hdd-space: 16.0MiB
write-sect-since-reboot: 36352
write-sect-total: 39081061
bad-blocks: 0%
architecture-name: smips
board-name: hAP lite
platform: MikroTik
[/quote]

Think only solution will be to export config, save this off the router, then use netinstall with 6.41.2 and import config again

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 6:26 pm
by eifLZ9D8zSwW
Hi,
RB750Gr3 went to bootloap :-(
I upgraded from 6.41.1, routerboard 6.41.1. I did it via System -> packages -> check for updates.

I managed to fix it with, however I am not sure what was the solution-trigger:
1) poweroff
2) press reset button, power on
3) keep the reset button pressed for 300 seconds (I found this somewhere on this forum)
4) poweroff
5) do the Netinstall procedure. I used Netinstall v6.38.5. (for some reason 6.41.1 didnt work)
6) I loaded 6.38.5 Main package,
7) it looked like it didnt work but after some time mikrotik beeped and started working.
8) upgrade from 6.38.5 to 6.41.1

It has been working for 2 days without problem.
Cheers, good luck

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 6:33 pm
by Mikhail73
I did an upgrad of RB750Gr3 from 6.41 to 6.41.2 - no problems.

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 7:05 pm
by strods
Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
CZFan - Does reboot free up some space on your router?
eifLZ9D8zSwW - You did - launch backup booter and reset router and bootloader configuration and then Netinstalled router. You could just skip the first part. However, if you had protected bootloader enabled (disabled reset button), then yes - you could not Netinstall router in any other way:
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader

We do recommend to use protected bootloader only if you really need it and are aware how to recover device in case something goes wrong. If you simply decide to enable this feature without actually knowing what it does, most likely you will not be able to recover unit when something goes wrong and in the end will want to return device for warranty repair. However, there is no actual problem with the router.

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 7:30 pm
by i4ko
i4ko - Have you had other RouterOS packages installed on the device in the past? If you reboot router is space freed up?
No and No
What I noticed is that config backup usually used to take shy of 500kb. After the 6.41.1 upgrade, the config backup right now takes shy of 700kb, and there isn't that much config on them either - address lists with about 940 IPs total (some of it is dynamic entries), 630 static dns entries, and 1 script that has 30 lines.
Some of the device had issues updating to 6.41.1 in the first place as well - they did not update via winbox, but I was able to upload the file and reboot them and they took it (which was unusual - normally it worked the other way around). It seems my last option is netupdate but these are all at remote sites, so not easy to schedule and do and I would like to avoid it. Would downgrade to 6.39.3 and upgrade to 6.41.2 directly if it wasn't for bridge config changes.

Re: v6.41.2 [current]

Posted: Sun Feb 11, 2018 7:35 pm
by strods
i4ko - Most likely you will need to re-install devices by using Netinstall. However, I recommend that you send supout file from one of your routers to support. We might see in supout file what is filling up the space.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 12:33 am
by wmiguel
Hi.
I just upgrade my RB750Gr3 to version 6.41.2, and The Dude 6.41.2 server (on RB750Gr3) and the surprise when I try to connect to this system with The Dude client (other times the application itself upgrades downloading directly from MikroTik) is that NOT WORKS. More accurately, the client cannot connect the server because The client 6.41.2 WAS NOT RELEASED YET, and the applicaion complete DOES NOT WORK.

I also try to downgrade to 6.41.1, but the router does not accept it.

Why MikrotiK release only partiallly his software, making impossible the management? I don't understand nothing.

I hope that Mikrotik releases quickly the new client. At a moment, more than 250 devices of my network cannot be managed. It is a very strange thing.
Best regards.

Miguel
P.D. NOTE: I just made the downgrade from 6.41.2 to 6.41.1. This was an mistake from my part. Sorry. I will expect MikroTik releases all needed sofware before trying to upgrade.
Regards. M.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 12:58 am
by rmonteiraum
After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 3:48 am
by skuykend
Upgraded all devices from 6.41.1 to 6.41.2.

Went well, but then after some time my CRS317 lost management DHCP client lease from my CCR1009 (log message via serial on 317 indicates lost lease). Using trunked VLANS.

Haven't noticed any other devices losing connectivity yet.

edit: Other traffic was still being switched normally. Noticed I was still on 6.41.1 routerboard firmware on the 317. Updated the firmware via serial console (couldn't connect via MAC either) and rebooted. Connectivity restored via IP and MAC winbox. Will reply again if connectivity lost.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 6:52 am
by strods
rmonteiraum - Please send supout file from your device to support@mikrotik.com. Send two supout files - one from old version where everything is working properly and one from latest version where it is not. Generate file after you have experienced disconnects;

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 8:28 am
by seventh
Can't connect to Dude server after upgrade.
Dude client update stopped with error "bad http response from cloud".
Dude server is on router os 6.41.2.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 9:25 am
by seventh
Hi this ver not work in Windows system. Do not download from mikrotik.com. Info from Dude client:

bad http response from cloud
Hi, could you solve the problem?
There's no way to workaround the bug. We need a new RouterOS release or the dude client 6.41.2 which is not available now. I suspect it's not available because they know it's bugged and so last resource is to wait for next RouterOS release. Hope soon.


Hm. I just change version number in standart download link https://download2.mikrotik.com/routeros ... 6.41.2.exe and download dude-client. Looks like it work.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 9:28 am
by uldis
After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
Please write more detailed what kind of wireless connectivity problems you see.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 9:29 am
by Clauu
Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 10:17 am
by normis
Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.
Where did you get that link? Download page shows correct and working link:
https://download2.mikrotik.com/routeros ... 6.41.2.ova

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 10:25 am
by Note
Ill post it here and i hope all u mikrotik engineers will take a look at that comment. We need u to introduce codel algorithm, it is the best working feature this time we speak in routers.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 10:48 am
by LucZWFM
LucZWFM - Have you tried to Netinstall device? From which version did you upgrade your router? Can you install same version, same configuration and try to upgrade once more and reproduce the same problem;

The board refuses to appear in netinstall, tried on 3 computers now...
This make me unable to try anything...

I upgraded from 6.41.1.

Connecting the board via a switch did it...
Windows didn't bring up the NIC when there is no link...

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 10:55 am
by Clauu
Ova for chr - 404 not found..
https://www.mikrotik.com/chr-6.41.2.ova
Isn't anyone from the team checking this basics stuff? We always have to report such trivial issues.
Where did you get that link? Download page shows correct and working link:
https://download2.mikrotik.com/routeros ... 6.41.2.ova
Hi normis, from here - https://mikrotik.com/download
Now as i can see links were updated because it points correctly so yes, after my report now it;s fine.
P.S i'm not using any caching proxy etc

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 11:06 am
by normis
The link might be wrong when release is not yet completed, just reload the page if some link doesn't work.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 11:38 am
by eifLZ9D8zSwW
Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
CZFan - Does reboot free up some space on your router?
eifLZ9D8zSwW - You did - launch backup booter and reset router and bootloader configuration and then Netinstalled router. You could just skip the first part. However, if you had protected bootloader enabled (disabled reset button), then yes - you could not Netinstall router in any other way:
https://wiki.mikrotik.com/wiki/Manual:R ... bootloader

We do recommend to use protected bootloader only if you really need it and are aware how to recover device in case something goes wrong. If you simply decide to enable this feature without actually knowing what it does, most likely you will not be able to recover unit when something goes wrong and in the end will want to return device for warranty repair. However, there is no actual problem with the router.

Hi,
I forgot to mention that I didn't use protected-bootloader. But if I had used, the 300s reset would have erased mikoritk even with protected-bootloader?
thx

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 11:52 am
by strods
eifLZ9D8zSwW - Are you sure that you did not enable feature by accident? Or simply enabled it without knowing what it does? Wiki page will explain how it works. Your solution would work only if these 500 seconds are between min/max timeout values. Wiki page should explain how long you have to hold that button pressed if feature is enabled.

Again - we strongly recommend to NOT use this feature if you are not aware about how it works. If you will not know min/max settings, then you will not be able to recover device in any way.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 12:14 pm
by Airell
bridge - fixed ARP settings on bridge interfaces (introduced v6.41);
Would this actually fix the issue I had in the start post of this topic?
It sounds it could: viewtopic.php?f=2&t=130581

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 3:25 pm
by mszru
I found a couple of strange entries in the routing table after the upgrade on my hAP ac. The upgrade path was the following: 6.40.5 > 6.41 > 6.41.1 > 6.41.2. Not sure when it happened exactly.

Image

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 3:31 pm
by Mikhail73
Mikhail73 - Please send supout file from your router to support@mikrotik.com. In best case scenario provide two files - one from 6.41.2 and one from 6.41.1 where everything works just fine. This version does not have any wireless fixes;
Done. Upgrade was from 6.41, not 6.41.1.
Do i need to downgrade also routerboard firmware from 6.41.2 to 6.41 now?

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 4:08 pm
by mrz
I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 4:41 pm
by mszru
I found a couple of strange entries in the routing table after the upgrade on my hAP ac.
What exactly is considered strange there?
The new routes to 0.0.0.0/32 in the list which were not there before.
According to the RFC 3330 it is kind of special address, and I cannot understand if it was added on purpose or by mistake during the upgrade.

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 5:02 pm
by mrz
Can you generate supout file from 6.41.2 downgrade and generate another file from older version and send both files to support?

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 5:10 pm
by fabifri
Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!

Re: v6.41.2 [current]

Posted: Mon Feb 12, 2018 10:24 pm
by Rule47
I've got trouble connecting older devices such as Android 4.0, iPhone 4 or Blackberry probably since Rel. 6.41 to access points using CAPsMAN. I downgraded to Rel. 6.35.4, which works well with these devices. Newer devices work (tested: iPhone 6, iPhone 8).

Currently installed on all devices: Rel. 6.41.2. The error I get is: "received deauth: class 3 frame received (7)".

Does someone have a clue, what to do. Users are complaining heavily.

Jo

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 1:11 am
by Jotne
Boot loop on RB750Gr3 too. :-(
Datacenter offline. Night shift incomming. Thanks!
RB750Gr3 is a low cost product ment for home and small offices.
Running a whole datasenter behind it seems for me some strange.

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 6:18 am
by i4ko
After upgrading from version 6.39.3 [BugFix] to 6.41.1 and then to 6.41.2, my device [RB751U-2HnD] presented wireless connectivity problems.

I also upgraded the firmware, leaving it equivalent to the ROS.

The causes of the problem could not be identified in the logs.

Even after resetting and redoing all the settings one by one, it was not possible to keep the wireless connection stable.
Please write more detailed what kind of wireless connectivity problems you see.
I have seen a wireless issue on two of the RB941-2nD I have. I don't know if it is the same or not.
Initially it started with wireless devices intermittently dropping. Later on it progressed to more severe intermittent connectivity - about 50 percent of the time there will be no devices connected. Logs would show key exchange timeout and drop the wireless devices about every 30 minutes, then it changed to about every 2 minutes. It progressed further onto the wireless devices not being able to hold stable connection for more than 2-3 seconds, it would not matter if the frequency was set to auto or set frequency. Initially devices tried to connect frequently, then connection attempt became more rare, until almost no connection attempts would be made. Every time the router kicked out the device for unicast key exchange timeout. But it became even worse - the devices were not trying to connect because they could not see the SSID. Those two devices now (no longer at customer) do not advertise SSID no matter what, I can't see it even with kismet. It seems like the radio RF portion just gradually and eventually died after the 6.41.1 upgrade. Multiple resets, and power off/power on did not make any difference.
Needless to say I had to replace these two. Initially they did not have the 6.41.1 firmware installed when they started being weird. When I got the issues, I installed the 6.41.1 firmware which made things worse and ultimately the WIFI portion just does not seem to work at all. The whole degradation from a fully stable working router to fully non-discoverable wifi (even on scans) started about a month after the 6.41.0 upgrade, and tool like 3-4 days with a 6.41.1 upgrade in the middle.
Regular AP bridge, no CAPsMAN, 2GHz-N-only band, 20Mhz channel, 802.11 protocol, WPS disabled, Hide SSID not set. Frequency - regulatory domain, Country - United States, Data rates - Default, Distance - indoors, Preamble - long/both

Hmm, tried setting the country to something else - Latvia - it would make the SSID temporarily discoverable (for about 5-10 seconds) and then it will die again. At the same time the status will claim it is running, at -112dBm noise floor and 2427/20/gn(20dBm) channel (sometimes 2422).
Nothing informative in the logs, even if wireless is on debug

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 8:18 am
by Clauu
About firewall new feature 'tls-host' i cannot make use of it no matter what sites i try, i'm i missing something or this feature is broken?
/ip firewall filter add chain=forward dst-port=443 protocol=tcp tls-host=*google.com action=drop

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 8:35 am
by strods
Clauu - Such rule should be working. Most likely some other firewall rule matches such traffic before this one. Are you using FastTrack?

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 8:53 am
by Clauu
Hi strods, i'm not using fastrack and tls rule was in top of all other forward chain rules.
Hm as i can see there is a fix for this feature in latest rc
What's new in 6.42rc24 (2018-Feb-08 09:42):
*) firewall - fixed "tls-host" firewall feature (introduced v6.41);
Is this related to my issue?
L.E: tested again and now it's working.. odd.

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 4:43 pm
by tangram
Hi,

I don't know if it's a winbox or routeros bug, but it's easy to reproduce. Connected with winbox, if you have a script open for editing and you delete that script from script list the session is dropped.
Oh and it generates autosupout :)

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 4:46 pm
by mrz
Do you use latest winbox version?

Re: v6.41.2 [current]

Posted: Tue Feb 13, 2018 9:42 pm
by ksteink
I upgraded my RB2011UiAS-2HnD-IN with no major issues. All my basic connection features worked fine (OVPN, IPv6 and VLANs). I did noticed that after the upgrade the LED on the router was constantly ON even in my setting I have it by default on OFF. I did turned ON and OFF again and it finally turn it off.

I have been working all day with it and no issues. I still want to revisit the configuration changes on the HW off-loading but from the end user experience no services have been impacted.

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 2:47 am
by aaronw
Never mind. I switched to a different laptop and disabled the firewall and I was able to recover the system. I still do not know why the initial update failed. Using netinstall I was able to boot the new system and install it.

This update appears to have broken an RB850GX2 router. After the update the router never recovered and failed to boot. I have since tried to get it to boot using netinstall and that fails.

Here is the output when booting from NAND:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... OK
setting up elf image... OK
jumping to kernel code
Starting...
Starting services...
connect failed (errno=2)
died with signal 6 on Thu Jan 1 00:00:12 1970

Aborted
connect failed (errno=2)
Aborted

Here is the output when I attempt to use netinstall and boot over Ethernet:
RouterBOOT booter 3.24

RouterBoard 850Gx2

CPU frequency: 533 MHz
Memory size: 512 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol.... OK
Got IP address: 192.168.0.100
resolved mac address 3C:97:0E:24:41:BC
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************falling back to small packet size
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
**************************************************************************************************************
********************kernel loading failed
Basically it bricked the Routerboard. I have also cleared the configuration from the bootloader and that did not help. It seems to pass the memory test.

Everything was working fine until the update. The update process completed then the box showing the progress just hung (obviously because it could not reboot).

Any suggestions?

-Aaron

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 6:35 am
by strods
Seems that either there is some issue with link between computer and router or there is another device in the path (switch, for example) causing this problem. Router starts to communicate with Netinstall, however, they both are not being able to make stable connection in order to start Netinstall process.

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 6:46 am
by i4ko
i4ko - Most likely you will need to re-install devices by using Netinstall. However, I recommend that you send supout file from one of your routers to support. We might see in supout file what is filling up the space.
Finally manged to update remotely. While on 6.41.1 disabled all packages except for system, dhcp and wireless, and uploaded the same from the 6.41.2 all packages file to the router (those were all i had room for), then rebooted, all in one go. Now I no longer have any packages besides these (routeros-smips is also gone) but everything is working fine. This also dropped 1.5mb in disk usage, I'll add some of the other packages where I need them.

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 9:35 am
by osmoticzest
Spotted the following on Superuser today, and it accurately describes what I’m seeing on the last couple of releases (potentially since 6.41.0) – the WiFi interface will just ‘stop’ at random, nothing in registration table, 0/0 tx/rx. Restarting the interface or doing something like using the ‘Scanner’ will bring things back to life. Same behaviour on both APs here.

https://superuser.com/questions/1293579 ... -is-restar

951G-2HnD + RB941-2nD
frequency-mode=regulatory-domain country=united kingdom

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 9:37 am
by Nuubo
Unfortunately my fears were true: bridging is still working bad because ARP is not fixed.
I am wondering why did Mikrotik eliminate master/slave options using switching?, since I am using Mikrotik I just use bridges to link wifi / ethernet interfaces but when the other day I upgraded to 6.41.2 it was impossible to keep the network running, the old master/slave interfaces of same switch were wrong, the old master interface loosing packets continuosly and the slave interface just not populate MAC addreses connected.

Please, consider my option: back to the old status, master slave is a much better option using switiching, if someone wants bridging, use bridging, but I think it is much worse.

Thanks.

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 10:20 am
by tangram
Do you use latest winbox version?
Thank you, I was using 3.11. In 3.12 problem is fixed.

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 10:23 am
by R1st0
I have problem with neighbor discovery on CRS106. My intention is to allow neighbor discovery only on uplink port (sfp5).
When using configuration:
/interface list
add name=clients
/interface list member
add interface=sfp1 list=clients
add interface=sfp2 list=clients
add interface=sfp3 list=clients
add interface=sfp4 list=clients
/ip neighbor discovery-settings
set discover-interface-list=!clients
It works, but when exporting the config "!" mark disappears: /ip neighbor discovery-settings set discover-interface-list=clients. When I use "/ip neighbor discovery-settings pr" the "!" is there.
To reduce lines I tried similar configuration, but this one doesn´t work (no discovery on sfp5):
/interface list
add name=uplink
/interface list member
add interface=sfp5 list=uplink
/ip neighbor discovery-settings
set discover-interface-list=uplink

Re: v6.41.2 [current]

Posted: Wed Feb 14, 2018 2:05 pm
by eddieb
updated my RB2011UAS from 6.40.5 to 6.41.2 ...
everything went smooth.
2 IPSEC site-to-site tunnels
DHCP and DNS server
PPPOE on wan

look fine here

Re: v6.41.2 [current]

Posted: Thu Feb 15, 2018 2:29 am
by LIV2
After upgrading my mAP2n to 6.41.2 I've found that doing /system reset-configuration no-defaults=no results in an empty configuration, and I can only connect to the router via mac-telnet
Same result when using the reset button to do a config reset, even on 6.42rc24 it also doesn't work

Re: v6.41.2 [current]

Posted: Thu Feb 15, 2018 6:52 am
by strods
osmoticzest - Provide supout file from your router to support@mikrotik.com
Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;
R1st0 - We will resolve this export command problem in upcoming RouterOS releases;
LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.

Re: v6.41.2 [current]

Posted: Thu Feb 15, 2018 9:56 am
by LIV2
LIV2 - Have you tried to Netinstall your device and reset it only after that? Seems that default configuration has been changed to something else by using configuration script on Netinstall.
I've tried Netinstall ensuring "Apply Default Config" is ticked with various versions with the following results
6.42rc20 - No default config
6.41.1 - No default config
6.41 - No default config
6.40.5 - Default config works
6.39.3 - Default config works

Re: v6.41.2 [current]

Posted: Fri Feb 16, 2018 10:50 am
by Nuubo
Nuubo - Please provide precise problem description and supout files to support@mikrotik.com. From which version with what exact configuration did you upgrade this device and did you upgrade directly to 6.41.2 release;

I am sorry but I did the change to my configuration with a new subnet just for one computer. I thought it was some upgrade problem (I did it from 6.41 directly) I deleted the bridge and I recreated it with same results, there was no MAC address in ARP table and continuous interruptions of network traffic. I just want ask you in future releases the recover of master/slave option, I can not understand why did you eliminate the use of switching, it is much better since it is flexible and instant.

Re: v6.41.2 [current] - scripting and terminal "no such item"

Posted: Fri Feb 16, 2018 7:24 pm
by buzzdee
Hi,

seems the issue described here

viewtopic.php?f=21&t=128915&p=637801&hi ... em#p637801

still persists. When enabling/disabling ppp-devices from terminal or script, I get "no such item (4)" the first time I run the command, but it works when I run it again. Have a couple of 411U's and 912's with 3G modems, would be nice if I could use my scripts to reset those modems would work again.

Re: v6.41.2 [current]

Posted: Fri Feb 16, 2018 10:57 pm
by macsrwe
Again - we strongly recommend to NOT use this feature if you are not aware about how it works. If you will not know min/max settings, then you will not be able to recover device in any way.
I suspect there are many routers out there where this value is set to arbitrary garbage due to recent (still current?) bug in Winbox where calling up /system routerboard settings always populates this value as 00:00:00 -- in red since zero is an invalid value -- and then demands the user set it to something nonzero before they can make the unrelated change they originally wished to make.

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 10:58 am
by strods
buzzdee - First of all, please do not post version u relafed issues within new release topic. Your problem has nothing to do with release and even ia not a bug. Do not use ID in scripts or run print first.

For example:
1) will not work
/interface ethernet set 1 name=test
2) will work
/interface ethernet set ether2 name=test
3) will work
/interface ethernet print
/interface ethernet set 1 name

On #1 script does not know which interface is 1 and that is why you see such error.

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 11:48 am
by buzzdee
Hi strods, thanks for the quick reply.
First of all, please do not post version u relafed issues within new release topic
Sorry, I should have been more precise - what I experienced was on 6.41.2.

Heres is a snippet from the script. I'm not using ID's but the interfaces name:
# Set UMTS Interface name
:global WanName "ppp-out1"
# get its ID number #
:local WanID [/interface ppp-client find name=$WanName];
# Change the data channel setting
/interface ppp-client set data-channel="3" $WanID
If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 12:26 pm
by sindy
If I get you right, interface should come before set-command in the last line:
/interface ppp-client $WanID set data-channel="3"
Does this also apply when using interface names instead of ID's?

Thanks, BuzzDee.
No, the order is less obvious, 1. set 2. in which item 3. which attribute:
/interface ppp-client set $WanID data-channel="3"
You can abbreviate your example into
/interface ppp-client set [find name=$WanName] data-channel="3"
And yes, you can replace the number(s) in the set, remove, unset etc. by "find" referring to any attribute.

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 1:38 pm
by Institor
Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 5:37 pm
by GARCIADOEGOGERMAN
Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....
In my RB750GR3 the same thing happens ... looking for more info I found this that seems to be the reason why what happens is what happens.

Release 6.41.1 2018-02-02
What's new in 6.41.1 (2018-Jan-30 10:26):

*) bridge - fixed hw-offload disabling for Mediatek and Realtek switches when STP / RSTP configured;
*) bridge - fixed hw-offload disabling when adding a port with "horizon" set;

This will have to do with what you mention ???

Regards!!!

Re: v6.41.2 [current]

Posted: Sat Feb 17, 2018 10:32 pm
by mpadmin
Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none

Re: v6.41.2 [current]

Posted: Sun Feb 18, 2018 2:53 am
by GARCIADOEGOGERMAN
Bridge on RB750Gr3 (6.41.2) seems to be broken.
1) No HW offload on ethernet interfaces after upgrade from 6.41.1:
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 #     INTERFACE                      BRIDGE                      HW  PVID PRIORITY  PATH-COST INTERNAL-PATH-COST    HORIZON
 0     eth2                           bridge_local                yes    1     0x80         10                 10       none
 1     eth3                           bridge_local                yes    1     0x80         10                 10       none
 2 I   eth4                           bridge_local                yes    1     0x80         10                 10       none
 3 I   eth5                           bridge_local                yes    1     0x80         10                 10       none
 
interface bridge port print detail
Flags: X - disabled, I - inactive, D - dynamic, H - hw-offload
 0     interface=eth2 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 1     interface=eth3 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 2 I   interface=eth4 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no

 3 I   interface=eth5 bridge=bridge_local priority=0x80 path-cost=10 internal-path-cost=10 edge=auto point-to-point=auto
       external-fdb=auto horizon=none hw=yes auto-isolate=no restricted-role=no restricted-tcn=no pvid=1
       frame-types=admit-all ingress-filtering=no
2) Bridge settings freezes constantly (for example, after trying to check/uncheck "igmp snooping", bridge completely shuts down and remain disabled for approx. 1 minute).

It's slightly annoying....


I have 750Gr3 and HW offload works, but you need to set Protocol Mode to "none".
/interface bridge
add name=bridge-internal protocol-mode=none
Then because the script of the default configuration of the RB750GR3 has set "protocol-mode = rstp" ??? It would be a problem to solve by Mikrotik support, since being in RSTP mode will never use HW OFF ...

Re: v6.41.2 [current]

Posted: Sun Feb 18, 2018 5:31 am
by Institor
Yes, rstp was enabled on bridge...
However, disabling rstp took about 3-4 minutes, i think that's a little too slow... Changing other settings (like "fast forward") also freezes the bridge for several minutes.

Re: v6.41.2 [current]

Posted: Sun Feb 18, 2018 8:57 pm
by kuzma2000
Hi!
I successfully updated through Dude all my rb941 (2 pieces) ccr1009 (2 pieces) and RB WAP G-5hact2hnd from 6.41.1 to 6.41.2.
But I couldn't update any rb962.
Also, I tried to update rb962 via Winbox.
The reason is: there is not enough space.
rb962 have only 16 MB, of which only 20-30% is available.
Last time I altering them through NetInstall/
What to do now?

Re: v6.41.2 [current]

Posted: Mon Feb 19, 2018 11:01 am
by ATROX
ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

Image
Image

Image
Real IPQ4019 ???
In specification - IPQ4018.
Image

Re: v6.41.2 [current]

Posted: Tue Feb 20, 2018 12:40 am
by tigro11
hi guys, on my rb750Gr3 with firmware 6.42rc28 I wanted to mount a hotspot for a job. I can not install the user-manager package.
Are there any solutions?
thank you all

Valerio

Re: v6.41.2 [current]

Posted: Tue Feb 20, 2018 7:28 am
by ATROX
ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
OS - 6.41.2

Some clients are disconnected from the point here with such an error:
disconnected, extensive data loss
and
disconnected, received disassoc: sending station leaving (8)
I settings many MicroTick AP.
The settings are the same everywhere, it's on this, new such problems.

Image

For example, this client is sitting on the spot, does not run around the office.

Well, here's a look at what the rest are doing ...
Image

Re: v6.41.2 [current]

Posted: Tue Feb 20, 2018 8:50 am
by docmarius
...
Current Tx Power 2GHz - empty
...
FYI: 0 dBm does not mean "empty"/zero power. It is a valid value and means 1 mW. Still odd though, if it changed by itself.

Re: v6.41.2 [current]

Posted: Tue Feb 20, 2018 6:06 pm
by buzzdee
@sindy

Thanks for pointing out which order to use in scripting. I must have been lucky that my scripts worked in earlier versions without paying that much attention to the order.

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 10:50 am
by ATROX
ap - cAP ac (RouterBOARD cAP Gi-5acD2nD)
ARP table - empty
Current Tx Power 2GHz - empty

OS - 6.41.2

The new chips have a new method of obtaining power data. not yet supported Route OS.
MikroTik support answered

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 6:55 pm
by HiroZA
My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 8:12 pm
by sindy
My current router was ISP supplied and has all the default config on it. If i download this update and install it, will this setup be overwritten? Will i have issues due to PPPoE settings being factory reset ?
Even if you upgrade between stable versions, you should always backup the configuration and download the backup file from the router. Exporting it in the text form into another file (using "/export file=backup_version_today") is also a good practice because the "binary" backups from older versions are not always readable by newer versions. And noting down any credentials (in your case, especially those related to the PPPoE account) is also a good idea.

I assume that your ISP doesn't mind you to do the upgrade as they've given you administrator rights to the router.

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 9:03 pm
by coliflower
I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 9:18 pm
by sindy
I am sorry but I am still confused with the new bridge implementation :-(

I updaten one of my wAP-ac to 6.41.2 and created a bridge - this bridge has an IP 10.0.100.4/24 and PVID1 because the AP itself is a part of the administrative-VLAN1-un-tagged (Internet-Cable-Modem to Firewall to Switch to wAP-ac via TRUNKs).

Connected to the bridge via PORT is the only one available ether1 - this port has a PVID1 as well because if I understood the brief explanation of MikroTik, it is need for the un-tagged ingress (from ether-cable to port-ether1 / port-ether1 to the bridge) traffic ... On this PORT there is a cable with Trunk (vlan1-un-tagged, vlan10-tagged, vlan20-tagged, etc.).
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

The next PORT to the bridge is the physical WLAN-chip (not vAP) - this port also has PVID1 because the SSID of the WLAN-chip is the administrative-VLAN1-un-tagged.
Frame-Types = admit all ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Now the vAP's ... e.g. vAP10, vAP20, vAP30, etc.
For example: vAP10 has PVID10
Frame-Types = admit only VLAN tagged ... correct / why ?
Ingress-Filtering = unchecked ... correct / why ?

Next is interface / bridge / VLAN:

I created VLAN ID = 1
Tagged = empty ... correct / why ?
Untagged = bridge, vlan1, wAP-2GHz, wAP5GHz ... correct / why ?

I created VLAN ID = 10
Tagged = bridge, vlan10 ... correct / why ?
Untagged = vAP10 ... correct / why ?

At the end I activated VLAN-Filtering under /interface bridge

One additional question ... is it needed to create the VLANs under /interface VLAN, too ?

As you see there are some puzzle-brickets I know but I am not able to make a picture of them :-(

Any help is highly appreciated - especially with explanation :-)
I'd suggest you to either join this topic or create a new one.

Re: v6.41.2 [current]

Posted: Wed Feb 21, 2018 9:49 pm
by coliflower
I did, but I am still confused :( Maybe because of the WLAN-aspect ?
And I opened one here - but I found other issues in between ... viewtopic.php?f=7&t=130734

Re: v6.41.2 [current]

Posted: Thu Feb 22, 2018 12:01 am
by davidv
LHG´s AC 6.41.2
After the restarts it shows:
memory; system, error, critical; kernel failure in previous boot.
in the shutdown of the system only reboots

any solution?
Thank
.......................................................................................................
reset when you change the configuration and the connection wlan falls
problem coment: viewtopic.php?f=7&t=128916

Re: v6.41.2 [current]

Posted: Thu Feb 22, 2018 3:42 am
by aforster
Folks,

I tried twice to move from 6.40.3 to other streams, but a few weeks after the upgrade, the router started going slow, and after a reboot, the same problem happened, exactly the same the two times: it lost part of the new bridge configurations. Even with reboots or reloading the configs, it would not fix it.. very, very strange.

It was a real pain to download the old 6.40.3 code using my cell phone as internet access to upload it to the router and restore old config.

Anyone had the same problem?

Now, Im back to 6.40.x.. just moved to 6.40.6 to see how that one is.. otherwise, will downgrade to 6.40.3 again.

Re: v6.41.2 [current]

Posted: Thu Feb 22, 2018 8:28 am
by jaytcsd
My hAPlite locked up after upgrading from 6.3 something using quickset to download and install.

I upgraded winbox through the tool option first, it crashed.
It worked when I restarted it and I got into the router to run quickset.
It rebooted OK, I got in and was looking at the log when it died.
I've done 3 power cycles and it still won't respond to pings.

Will netinstall preserve any supout data? I think that is my only recourse to help troubleshoot what happened.
My 10+ year old RB532 is working fine, otherwise this would be a letter.

Re: v6.41.2 [current]

Posted: Sat Feb 24, 2018 6:16 am
by minhcoi
I was upgrade my 951ui-2hnd from 6.40 to 6.41 and then i deleted all files in router... Now my 951ui become continually reset... I tried Netinstall but it cant see my router...
How can i fix this?

Re: v6.41.2 [current]

Posted: Sun Feb 25, 2018 1:44 pm
by xtcinmymind
Hello

great job with the latest firmware work so fast and more reliable .I just wonder to know about bonding .
before i used to uncheck master port on ether1 or 2 to be able to create bonding .
Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2

thnx

Re: v6.41.2 [current]

Posted: Sun Feb 25, 2018 2:42 pm
by sindy
Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2
Go to Bridge -> Ports, remove ether1 and ether2 from the list, go to Interfaces -> Add new -> Bonding, set ether1 and ether2 as slaves, then maybe make the new bonding interface a member of that bridge from which you've removed ether1 and ether2. Done.

Re: v6.41.2 [current]

Posted: Sun Feb 25, 2018 3:43 pm
by xtcinmymind
Now i cant do that cos it say ether1 or 2 already on brigde1 .
Can someone tell me how to create bonding easy way on the firmware 6.41.2
Go to Bridge -> Ports, remove ether1 and ether2 from the list, go to Interfaces -> Add new -> Bonding, set ether1 and ether2 as slaves, then maybe make the new bonding interface a member of that bridge from which you've removed ether1 and ether2. Done.
Yes thnx was easy way .also in the end have to add ports with the bond created and brigde ..thnxxx again

Re: v6.41.2 [current]

Posted: Tue Feb 27, 2018 12:46 pm
by weldox
I have my 7 milkrotik devices all stick to 6.38.5 and I am really scared in try to upgrade. I see a lot of problems in this thread....
Is it really so dangerous?

Re: v6.41.2 [current]

Posted: Tue Feb 27, 2018 2:57 pm
by jarda
Don't update anything if it scares you. Read the release notes that describe version differences. If you think there is a change you would like to have, make your own tests with backup devices before you decide to roll out the new version to your production ones.

Re: v6.41.2 [current]

Posted: Tue Feb 27, 2018 5:36 pm
by pe1chl
Also, when you want to be conservative set the update channel to "bugfix only" and you can update to 6.40.6 which does not
have this new style bridge instead of the existing bridge master-port setup. That should avoid a lot of problems when you
have a complicated configuration with VLAN and switching.

Re: v6.41.2 [current]

Posted: Tue Feb 27, 2018 5:39 pm
by weldox
Thank You very much!

Re: v6.41.2 [current]

Posted: Wed Feb 28, 2018 12:25 am
by bbs2web
We've had several instances of CCR routers losing bridge ports after upgrading from 6.41 to 6.41.2.

We run rancid as a configuration revision management system and reviewed logs after scheduling upgrades at 3am, ports simply missing.

Example:
/interface bridge port
add bridge=bridge-hosting interface=xxx-vlan12
missing after upgrade:

add bridge=bridge-nat interface=sfp11
add bridge=bridge-nat interface=xxx-vlan13
add bridge=bridge-management interface=xxx-vlan11
add bridge=bridge-management interface=sfp10
add bridge=bridge-hosting interface=sfp7

Re: v6.41.2 [current]

Posted: Wed Feb 28, 2018 11:29 am
by mrz
Did you have any of bridge ports disabled?

Re: v6.41.2 [current]

Posted: Thu Mar 01, 2018 12:16 am
by lukas2511
I upgraded a RouterBoard hEX from 6.41 to 6.41.2 and had bridge ports disappearing too.

ether1 and ether2 were no longer part of any bridges (which was kinda unfortunate as those were my uplink and local-network ports)

Re: v6.41.2 [current]

Posted: Thu Mar 01, 2018 12:26 am
by bbs2web
No, they were active and working perfectly. This occurred on another CCR where I subsequently connected via mac telnet and simply dumped all bridge ports back again, any that already existed we skipped.

I'll book a maintenance window for next weekend (10th March) and take a supout before and after upgrading.

I initially thought that it may relate to large number of bridge ports but the example above occurred on a router with 3 bridges, each with pairs...
Did you have any of bridge ports disabled?

Re: v6.41.2 [current]

Posted: Thu Mar 01, 2018 9:00 am
by docmarius
On my CCR1009 this version is unstable.
After an unpredictable time, the DHCP server stops responding, and routing seems to go amok (routes are there, but it is like connection tracking is not working). A reboot restores functionality for a time (from minutes up to a day).
Downgrading to 6.40.6 "cures" this behavior. I do not remember seeing this on 6.41.1. This could be the beginning of a beautiful friendship with 6.40.6 :lol:

Re: v6.41.2 [current]

Posted: Sun Mar 04, 2018 6:21 am
by b2fshen
Hi!
I am having trouble sending AT commands to LTE interface. After entering of ANY AT command like "interface lte at-chat lte1 input="ATI"" I receive: "action timed out - try again, if error continues contact MikroTik support and send a supout file (13)" reply.
My board is hAP (RB951ui-2nD) running 6.41.2. I tried it with USB modems ZTE MF730M and Huawei e3372 with the same result.
From Windows PC I can
Does anybody had same issues?

Re: v6.41.2 [current]

Posted: Sun Mar 04, 2018 7:41 pm
by kasana825
Hello,
I have routerboard and I configure 1 as WAN and 2,3 Bridge with WAN and I have set bandwidth limit on ethernet port 3, see attached file please

but today I bought rb1100ahx4
there is no option to set bandwidth limit on interface
but there is no option to set bandwidth limit

Re: v6.41.2 [current]

Posted: Mon Mar 05, 2018 2:33 pm
by nimbo78
FR:
plz add ICCID to lte info. needed to identify what SIM is now installed into the LTE kit. physically difficult to take out SIM from LTE kit and insert it back to the routerboard every time when we need to see ICCID.

Re: v6.41.2 [current]

Posted: Mon Mar 05, 2018 7:52 pm
by scrarfussi
i upgraded my rb750gr2 to 6.41.2 and i lost internet access
i can ping on the router
but devices connected to it have no internet access

Re: v6.41.2 [current]

Posted: Tue Mar 06, 2018 6:01 pm
by bbs2web
I've sent supout files for a CHR instance before and after upgrading (6.41 to 6.41.2) where bridge ports disappear after upgrading. This problem has occurred on CCR, CHS and 750Gr3 routers, one of which only had 3 bridges with 6 bridge ports...
I'll book a maintenance window for next weekend (10th March) and take a supout before and after upgrading.

I initially thought that it may relate to large number of bridge ports but the example above occurred on a router with 3 bridges, each with pairs...

Re: v6.41.2 [current]

Posted: Wed Mar 07, 2018 12:06 am
by ok1mgj
Hi all.

i`v upgraded 2 routerboards and on both of them i get into troubles with wireless.
RB751U-2HnD and RB751G-2HnD - both of them were on some 6.3x.x versions.

after upgrade to 6.41.2 (and corresponding firmware version) was RB unstable, after reboot and when wireless was enabled routerboard goes into booting loop.
configuration reset is unusable, because in default config is wifi enabled => booting loop.
next step was netinstall - yes, it helped. but after enabling wifi it was in booting loop again
i`v used netinstall again, did some tests and things were fine until i`v enabled wifi. Welcome to booting loop.
on 751U i`v tried 6.42rc37 - and after enabling wifi -> whooo, booting loop.
OK, something went wrong.
netinstall with older version (some 6.39.x) - and after enabling wifi..... voila, booting loop.

I have these RBs on very simple configuration - only one bridge across all ports including wifi - RBs acts only as AP for home usage.
So, now these routerboards is in stable config, but with disabled wireless.

Any idea how to solve this issue?

Re: v6.41.2 [current]

Posted: Wed Mar 07, 2018 11:28 am
by pe1chl
Save your configuration and do a completely new netinstall.
In the past there have been changes to the wireless and at that time it already was tricky to update past that release,
it would not surprise me when it again causes problems when you still had the wireless package from before that change.

Re: v6.41.2 [current]

Posted: Wed Mar 07, 2018 1:18 pm
by ok1mgj
Hi,
after netinstall is configuration clear, so it is not about configuration.

edit: on RB951G-2HnD is all OK and working properly.

Re: v6.41.2 [current]

Posted: Wed Mar 07, 2018 9:22 pm
by ok1mgj
guys, please, don`t panic (..and thanks for all the fish)

after a few hours of tests with other pices of routerboards (i have many RBs of many types) i have found, where trouble is located.

and this was: power adapter.

so, i`m very sorry to all the people.

Re: v6.41.2 [current]

Posted: Thu Mar 08, 2018 1:28 pm
by JanezFord
We've had several instances of CCR routers losing bridge ports after upgrading from 6.41 to 6.41.2.
I can also confirm that. CCR lost about half of bridge ports for no apparent reason after upgrading from 6.41 to 6.41.2. I also had to netinstall one hAP-AC with very simple config (simple CAP with all ports bridget + dhcp on bridge) which went into reboot loop after upgrade.

JF.

Re: v6.41.2 [current]

Posted: Thu Mar 08, 2018 2:07 pm
by pe1chl
A not so widely know feature of the "older" routers (this was lost in the recent low-end models that have only 16MB of flash) is the
possibility to divide the flash in two partitions that can be copied over and one can be activated. On a CCR you can copy the existing
firmware+config to the inactive partition, upgrade, reboot and when is not troublefree you can activate the second partition and reboot again to
fall back to the previous situation (without the issue that an upgrade could have modified the configuration).
You probably already know this but I bet not every admin does.

Re: v6.41.2 [current]

Posted: Mon Mar 12, 2018 10:01 am
by strods
Version 6.41.3 has been released in current channel:
viewtopic.php?f=21&t=131810