Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.41.3 [current]

Mon Mar 12, 2018 10:00 am

RouterOS version 6.41.3 has been released in public "current" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.41.3 (2018-Mar-08 11:55):

!) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
*) chr - automatically generate new system ID on first startup;
*) console - do not allow variables that start with digit to be referenced without "$" sign;
*) defconf - fixed DISC Lite5 LED default configuration;
*) export - fixed "/system routerboard mode-button" compact export;
*) filesystem - improved error correction process on RB1100AHx4 storage;
*) firewall - fixed "tls-host" firewall feature (introduced in v6.41);
*) gps - added GPS port support for Quectel EC25-E modem when used in LTE mode;
*) lte - fixed r11-LTE-US interface initialization process after reboot;
*) romon - make "secret" field sensitive in console;
*) smb - improved NetBIOS name handling and stability;
*) snmp - fixed w60g SSID value;
*) tile - fixed bogus voltage readings;
*) tr069-client - fixed TR069 service becoming unavailable when related service package is not available;
*) usb - improved packet processing over USB modems;
*) winbox - fixed "/tool e-mail send" attachment behavior;
*) winbox - fixed maximal ID for Traffic Generator stream;
*) winbox - removed "Enable" and "Disable" buttons from IPsec "mode-config" list;
*) winbox - show "D" flag under "/ip dhcp-client" menu;
*) wireless - removed unused "/interface wireless registration-table monitor" command;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
 
User avatar
eworm
Member
Member
Posts: 402
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:28 am

Looks like the ipsec fix did not make it into the release. *sigh* Do I have to wait for version 6.42?
Thanks anyway!
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8317
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:32 am

What fix? Please don't hope that everybody knows
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
okazdal
Trainer
Trainer
Posts: 21
Joined: Fri Aug 07, 2015 4:44 pm

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:38 am

Hello,
!) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
Any details about tile improvement?

Regards,
 
User avatar
eworm
Member
Member
Posts: 402
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:45 am

Looks like the ipsec fix did not make it into the release. *sigh* Do I have to wait for version 6.42?
Thanks anyway!
What fix? Please don't hope that everybody knows
This one:
*) ipsec - properly detect interface for "mode-config" client IP address assignment;
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
telcouk
just joined
Posts: 17
Joined: Mon Jan 08, 2018 3:50 pm

Re: v6.41.3 [current]

Mon Mar 12, 2018 11:25 am

Hello,
!) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
Any details about tile improvement?

Regards,
I've asked this before on the RC forum, however I've had no response.
I did e-mail support, they didn't understand the question, fingers crossed you get a better response!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Mon Mar 12, 2018 12:32 pm

We have improved handling of operations on TILE based devices (CCRs). This fix will not affect anyone negatively, but might help in rare cases with different random problems. For example, there were users who used CCR1072 and CPU core was stuck on 100% usage due to IPsec HW encryption. This fix resolves it. Basically, CPU is now better handling assigned processes. There is no need to upgrade, if you do not have any problems with your device.
 
telcouk
just joined
Posts: 17
Joined: Mon Jan 08, 2018 3:50 pm

Re: v6.41.3 [current]

Mon Mar 12, 2018 1:24 pm

We have improved handling of operations on TILE based devices (CCRs). This fix will not affect anyone negatively, but might help in rare cases with different random problems. For example, there were users who used CCR1072 and CPU core was stuck on 100% usage due to IPsec HW encryption. This fix resolves it. Basically, CPU is now better handling assigned processes. There is no need to upgrade, if you do not have any problems with your device.
Bit of a long shot, however will this improve things for BGP?
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.41.3 [current]

Mon Mar 12, 2018 7:19 pm

bumpt - rb2011 - bricked :D
--
poi
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.41.3 [current]

Mon Mar 12, 2018 8:35 pm

Any fix for the DHCP server stopping on bridge after some time?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
zoombie
just joined
Posts: 5
Joined: Mon Mar 12, 2018 9:04 pm

Re: v6.41.3 [current]

Mon Mar 12, 2018 9:10 pm

can't upgrade from 6.40.3 to 6.41.3 or new rc on arm processor. Very low quality on bandwidth test, no good :(
 
eddieb
Member Candidate
Member Candidate
Posts: 141
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.41.3 [current]

Mon Mar 12, 2018 9:12 pm

upgraded from 6.41.2 -> 6.41.3 without any issues on RB962 / RB1100 / RB2011 / CRS125

tnx
Running 6.45.7 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:42 pm

Out of sudden I found nice dialog with drop-down box named "SIM", under System -> Routerboard -> SIM:

Image

Something that I neved expected from my old (but good) CRS125-24G-1S (https://mikrotik.com/product/CRS125-24G-1S-IN, which is essentially a 24-ports switch with decent router (like 951's) built-in, and it doesn't feature any SIM slot for what I know. Or there is a hidden one? :)

On my image you can see ROS and f/w versions (6.41.3), device model and button I talk about.

What's that? Hidden feature or another bug-not-a-feature thing?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Mon Mar 12, 2018 10:42 pm

poizzon - If you have a RB2011 model which has serial console port, then please provide serial output so we can see why router can not boot any more;
docmarius - Are you referring to one of the fixes in 6.42rc version or some other problem which you have resolved/reported to support?
zoombie - Please provide more information. Do you have any problems with real life traffic not with the BTest? Can you downgrade to 6.41.2, make sure that problem is gone, upgrade back to 6.41.3 and see that problem appears once more?
 
105547111
Member Candidate
Member Candidate
Posts: 132
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 12:40 am

Out of sudden I found nice dialog with drop-down box named "SIM", under System -> Routerboard -> SIM:

Image

Something that I neved expected from my old (but good) CRS125-24G-1S (https://mikrotik.com/product/CRS125-24G-1S-IN, which is essentially a 24-ports switch with decent router (like 951's) built-in, and it doesn't feature any SIM slot for what I know. Or there is a hidden one? :)

On my image you can see ROS and f/w versions (6.41.3), device model and button I talk about.

What's that? Hidden feature or another bug-not-a-feature thing?
Yes! I have 3 CRS125's one's a desktop version other two are rack mount and I see this also...
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.41.3 [current]

Tue Mar 13, 2018 12:48 am

docmarius - Are you referring to one of the fixes in 6.42rc version or some other problem which you have resolved/reported to support?
I had issues with the DHCP server not handing out addresses after some time of proper functioning in 6.41.2 if the interface is a bridge. This was reported by some users, and seemed it was addressed in the RC, so I assumed a ticket would not be necessary anymore (In my case I reverted my main router to 6.40.6 which solved the issue, so no emergency on this side).
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
zoombie
just joined
Posts: 5
Joined: Mon Mar 12, 2018 9:04 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 1:00 am

zoombie - Please provide more information. Do you have any problems with real life traffic not with the BTest? Can you downgrade to 6.41.2, make sure that problem is gone, upgrade back to 6.41.3 and see that problem appears once more?

Real traffic and Btest shows the same result, poor :( I can't upgrade to 6.41.3 and also to 6.41.2 from 6.40.3
 
zoombie
just joined
Posts: 5
Joined: Mon Mar 12, 2018 9:04 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 1:09 am

zoombie - Please provide more information. Do you have any problems with real life traffic not with the BTest? Can you downgrade to 6.41.2, make sure that problem is gone, upgrade back to 6.41.3 and see that problem appears once more?

Real traffic and Btest shows the same result, poor :( I can't upgrade to 6.41.3 and also to 6.41.2 from 6.40.3
And I checked upgrade from 6.41.2 to 6.41.3 on arm routerboard, not working :(
 
guipoletto
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Mon Sep 19, 2011 5:31 am

Re: v6.41.3 [current]

Tue Mar 13, 2018 4:57 am

We have improved handling of operations on TILE based devices (CCRs). This fix will not affect anyone negatively, but might help in rare cases with different random problems. For example, there were users who used CCR1072 and CPU core was stuck on 100% usage due to IPsec HW encryption. This fix resolves it. Basically, CPU is now better handling assigned processes. There is no need to upgrade, if you do not have any problems with your device.
Will this help with SNMP being limited to a single core? (clipping that core to 100% if you're pooling too many parameters)?
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Tue Mar 13, 2018 7:02 am

105547111 - You see this option on your device by mistake. Of course, since you do not have a SIM slot, you should not see SIM related options on CRS125 device;
docmarius - This problem required re-work of DHCP service functionality on bridge interface. Since it was more like a re-written functionality not a fix, we decided to leave this for 6.42 release and not include in 6.41.x for safety reasons;
zoombie - Why can not you upgrade? Upgrade functionality is not working or simply you did decide to stick with 6.40.3 version? I recommend that you contact support@mikrotik.com. Sounds like conversion from old bridge implementation to new one might have affected you, but we can not comment on this further without debugging your specific case through support;
guipoletto - This feature does not make single core processes multi-core, this does not make CPU more powerful. This new fix can help you in cases if device works abnormally and, for example, gets stuck on single core 100% usage which could lead up to Watchdog reboots.
 
tonymobile
newbie
Posts: 37
Joined: Mon Jul 07, 2008 2:10 am

Re: v6.41.3 [current]

Tue Mar 13, 2018 8:07 am

And where are these features in 6.41.3?

I do not understand.

*) wireless - added "realm-raw" setting for "/interface wireless interworking-profiles" (CLI only);
*) wireless - added initial support for "nstreme-plus";
*) wireless - added support for "band=5ghz-n/ac";
*) wireless - added support for "interface-list" for Access List entries;
*) wireless - added support for legacy AR9485 chipset;
*) wireless - fixed "wds-slave" channel selection when single frequency is specified;
*) wireless - fixed incompatibility with macOS clients;
*) wireless - fixed long "scan-list" entries not working for ARM based wireless interfaces;
*) wireless - fixed nv2 protocol on ARM platform SXTsq devices;
*) wireless - fixed RTS/CTS option for the ARM based wireless devices;
*) wireless - improved compatibility with specific wireless AC standard clients;
*) wireless - improved packet processing on ARM platform devices;
*) wireless - improved wireless scan functionality;
*) wireless - improved wireless stability on hAP ac2 devices while USB is being used;
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Tue Mar 13, 2018 8:15 am

105547111 - You see this option on your device by mistake. Of course, since you do not have a SIM slot, you should not see SIM related options on CRS125 device;
I ask since it was my picture and question initially. What will happen if I set this setting to different value ;) and, more seriously, since sim slot is not built in, does it mean firmware reports it is there by mistake and so f/w may be considered buggy?
 
eddieb
Member Candidate
Member Candidate
Posts: 141
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.41.3 [current]

Tue Mar 13, 2018 8:42 am

strods - I see this SIM option on my RB2011 and CRS125. On the RB1100 it is not visible.
Running 6.45.7 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 9:22 am

poizzon - If you have a RB2011 model which has serial console port, then please provide serial output so we can see why router can not boot any more;
Image

Which pinout?
--
poi
 
poizzon
Member Candidate
Member Candidate
Posts: 113
Joined: Fri Jun 21, 2013 12:53 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 9:33 am

Image

does it really have console port ?
U903 are empty

RB2011iLS-IN - so does not have serial console port.
Last edited by poizzon on Tue Mar 13, 2018 11:18 am, edited 2 times in total.
--
poi
 
atlanticd
newbie
Posts: 29
Joined: Thu Jun 11, 2015 6:42 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 10:45 am

105547111 - You see this option on your device by mistake. Of course, since you do not have a SIM slot, you should not see SIM related options on CRS125 device;
strods - I also see SIM option on RB433AH and on hAP ac lite. Winbox 3.12
 
dadaniel
Member Candidate
Member Candidate
Posts: 158
Joined: Fri May 14, 2010 11:51 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 2:52 pm

Is it now really necessary to update routerboard firmware everytime we update ROS since the version numbering now follows ROS version number? I cannot believe there are changes everytime and it is quite annoying to have to reboot twice.
I also have the SIM menu on RB951G-2HnD now.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24258
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Tue Mar 13, 2018 2:58 pm

Is it now really necessary to update routerboard firmware everytime we update ROS since the version numbering now follows ROS version number? I cannot believe there are changes everytime and it is quite annoying to have to reboot twice.
I also have the SIM menu on RB951G-2HnD now.
We will eventually improve it, so that you only need one reboot. For now, you are free to ignore the upgrade and reboot when you need to.
You can also turn off the auto-upgrade in the routerboot menu.
No answer to your question? How to write posts
 
User avatar
zilf
just joined
Posts: 7
Joined: Fri Jul 22, 2016 4:06 pm
Location: Ukraine

Re: v6.41.3 [current]

Tue Mar 13, 2018 3:14 pm

Upgraded from 6.41.2 to 6.41.3 without any issues on SXT Lite2 / RB850Gx2 / hAP Lite / hAP ac lite tower.
Thanks.
 
msatter
Forum Guru
Forum Guru
Posts: 1278
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.41.3 [current]

Tue Mar 13, 2018 3:43 pm

This was posted in the 6.41.2 thread to which I can't post any more because it is closed.
update: I noticed running with the bridge the dail-on-demand pppoe was never going to sleep and I had to force an time-out to have change state to "waiting for pakets". Back on 6.40.5 it sleeps again till needed. The pppoe connection was no part of the bridge.
I had to re-enter one of my L2pt/IPSEC connections and noticed again that it went not going to sleep despite I was on 6.40.6. So I looked in the export file on my name for that connection and saw the Neighbour Discover was enabled for that connection. This discovery gave regular a kick to the L2pt/IPSEC connection so it could not catch sleep and stayed awake all the time.

I told of the bully, Neighbour Dicovery to not do that any more in the /ip neighbour discovery
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta59 / Winbox 3.20 / MikroTik APP 1.3.7
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
meshnet
Frequent Visitor
Frequent Visitor
Posts: 55
Joined: Tue Jun 01, 2004 6:57 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 3:48 pm

No X86 packages yet?
The requested URL /routeros/6.41.3/routeros-x86-6.41.3.npk was not found on this server.
 
User avatar
linkwave
Trainer
Trainer
Posts: 53
Joined: Fri May 25, 2007 9:13 pm
Location: Grosseto, Italy
Contact:

Re: v6.41.3 [current]

Tue Mar 13, 2018 3:55 pm

All the downloads for the 6.41.3 are not available :shock:
No X86 packages yet?
The requested URL /routeros/6.41.3/routeros-x86-6.41.3.npk was not found on this server.
MTCNEL
 
User avatar
GaToMaLaCo
just joined
Posts: 8
Joined: Fri Jan 10, 2014 2:13 am

Re: v6.41.3 [current]

Tue Mar 13, 2018 4:03 pm

@meshnet @linkwave

You have to edit the download link adding a 2. For example "download2"
https://download.mikrotik.com/routeros/6.41.3/routeros-mipsbe-6.41.3.npk
...
https://download2.mikrotik.com/routeros/6.41.3/routeros-mipsbe-6.41.3.npk

Seems all downloads are moving to a secondary server at the moment.
 
Aufan388
newbie
Posts: 35
Joined: Mon Nov 09, 2015 9:20 am
Location: Poznan, Poland

Re: v6.41.3 [current]

Tue Mar 13, 2018 4:31 pm

I haven't seen any information here on forum but hopefully this version patches the malware attack "Slingshot". It was only announced 2 days ago, but possibly it was known already to Mikrotik and fixed, as mentioned at the end of the article in the link below.

https://www.engadget.com/2018/03/11/sop ... h-routers/
 
ronets
just joined
Posts: 1
Joined: Tue Mar 13, 2018 6:00 pm

Re: v6.41.3 [current]

Tue Mar 13, 2018 6:03 pm

thanks
 
msatter
Forum Guru
Forum Guru
Posts: 1278
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.41.3 [current]

Tue Mar 13, 2018 6:08 pm

I haven't seen any information here on forum but hopefully this version patches the malware attack "Slingshot". It was only announced 2 days ago, but possibly it was known already to Mikrotik and fixed, as mentioned at the end of the article in the link below.

https://www.engadget.com/2018/03/11/sop ... h-routers/

You missed the thread about that: viewtopic.php?f=2&t=131748
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta59 / Winbox 3.20 / MikroTik APP 1.3.7
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
duncanunderwood
just joined
Posts: 2
Joined: Fri Mar 02, 2018 1:01 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 12:49 am

Hi..installed update v6.41.3 on to my RB2011UiAS-RM and now its caught in a booting loop. any ideas? :(

-- ISSUE RESOLVED! Thanks
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Wed Mar 14, 2018 6:55 am

tonymobile - Such features will never be added into 6.41.x version. v6.41, v6.42, v6.43, etc. will have new features. v.6.41.x, v.6.42.x, v.6.43.x, etc. will include only fixes. That is the whole point of bug fixes only versions.
upower3, eddieb, atlanticd - At the moment you will see this option on all MIPSBE and MMIPS devices. There is no need to worry about this setting since it is simply showed there by mistake. In future we will try to remove it from devices which does not need such setting.
poizzon - You can not make serial console work if you do not have serial port already built-in. Do you have RB2011 device which has RJ45 serial port? If not, then you can not user serial console. RB2011iLS-IN does not have such port.
dadaniel - 6.42 introduces auto upgrade feature which after RouterOS upgrade also upgrades firmware. Yes, extra reboot is required, however, feature is still a work in progress;
Aufan388 - Visit this post - viewtopic.php?f=2&t=131748. This "vulnerability" was possible only if you sued old RouterOS/Winbox versions and also had an open access to your device;
msatter - Thank you for this report. Please also send in supout files to support@mikrotik.com and explain the problem that you have.
meshnet, linkwave - Are you using the correct URL "https://download.mikrotik.com/routeros/ ... 6.41.3.npk" or "https://download2.mikrotik.com/routeros ... 6.41.3.npk"?
duncanunderwood - How did you resolve the problem and what was it?
 
User avatar
jpaine619
just joined
Posts: 7
Joined: Tue Mar 13, 2012 6:37 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 7:28 am

bumpt - rb2011 - bricked :D
941-2nD bricked as well.....

Router appears to just endlessly reboot itself. All the lights go out.. they come back on... a few seconds and they all go out again.
This was a fairly new device. No more than 2 months old... Not sure how much uptime. It's my personal one so I didn't pay much attention.
 
User avatar
jpaine619
just joined
Posts: 7
Joined: Tue Mar 13, 2012 6:37 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 7:36 am

Hi..installed update v6.41.3 on to my RB2011UiAS-RM and now its caught in a booting loop. any ideas? :(

-- ISSUE RESOLVED! Thanks
How did you resolve? I'm dealing with a router doing that right now..
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Wed Mar 14, 2018 8:25 am

Please note that upgrade process happens on the old version - not the one which you install on your router. For example, upgrade from 6.38.7 to 6.41.3 is handled by 6.38.7. So if indeed problem is caused by the upgrade, then you must look for the fault in the old version not in this 6.41.3 release.

If that is correct, then I recommend that you:
1) Write to support@mikrotik.com explaining the problem that you have;
2) Point out precisely version which you had on the router before an upgrade;
3) Send supout file from the old version (so we can see configuration and installed packages);
4) If possible, then provide contents of files section so we can see how much of the free space was left on the device before an upgrade;
5) Describe how did you upgrade device - uploaded packages and rebooted device (which ones?), used check-for-updates feature or used auto upgrade server.
 
User avatar
jpaine619
just joined
Posts: 7
Joined: Tue Mar 13, 2012 6:37 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 8:32 am

3) Send supout file from the old version (so we can see configuration and installed packages);
That's going to be difficult if the router bricks (like mine just did).. I don't keep supout files laying around, I'd have to generate a new one every time I did any modification to my settings for it to be relevant anyhow.
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 8:37 am

Please note that upgrade process happens on the old version - not the one which you install on your router.
It should be done by the firmware, isn't it?

Like it is the only part that's intact during the upgrade process. I got used to the idea that upgrade is handled by some extra software part that is unchanged and can handle boot up in a case something is wrong.
 
Aufan388
newbie
Posts: 35
Joined: Mon Nov 09, 2015 9:20 am
Location: Poznan, Poland

Re: v6.41.3 [current]

Wed Mar 14, 2018 10:26 am

msatter and Strods - Thanks for the info, I did miss that post :/
 
irghost
Member Candidate
Member Candidate
Posts: 281
Joined: Sun Feb 21, 2016 1:49 pm

Re: v6.41.3 [current]

Wed Mar 14, 2018 12:42 pm

sxt lte does not switch to band 7
Image
Image
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
User avatar
ScottReed
Member Candidate
Member Candidate
Posts: 111
Joined: Thu Sep 24, 2009 9:47 pm
Location: Montana / Western Massachusetts

Re: v6.41.3 [current]

Wed Mar 14, 2018 3:58 pm

We have improved handling of operations on TILE based devices (CCRs). This fix will not affect anyone negatively, but might help in rare cases with different random problems. For example, there were users who used CCR1072 and CPU core was stuck on 100% usage due to IPsec HW encryption. This fix resolves it. Basically, CPU is now better handling assigned processes. There is no need to upgrade, if you do not have any problems with your device.
Bit of a long shot, however will this improve things for BGP?
I would like to know the same thing.
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.41.3 [current]

Wed Mar 14, 2018 7:20 pm

:lol:
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
tonymobile
newbie
Posts: 37
Joined: Mon Jul 07, 2008 2:10 am

Re: v6.41.3 [current]

Wed Mar 14, 2018 9:51 pm

tonymobile - Such features will never be added into 6.41.x version. v6.41, v6.42, v6.43, etc. will have new features. v.6.41.x, v.6.42.x, v.6.43.x, etc. will include only fixes. That is the whole point of bug fixes only versions.
Thanks
 
mpadmin
just joined
Posts: 18
Joined: Sun May 22, 2016 3:48 pm

Re: v6.41.3 [current]

Wed Mar 14, 2018 10:38 pm

Any workaround for the "DHCP on bridge" bug?
 
pawelkopec88
just joined
Posts: 9
Joined: Wed Mar 14, 2018 11:06 pm

Re: v6.41.3 [current]

Wed Mar 14, 2018 11:11 pm

Hi,

A have a new one HAP AC^2. (D52G-5HacD2HnD-TC)

The 2.4GHz network have better bandwith then 5.0GHz. Does anyone have the same? ?

Best Redgards,
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Thu Mar 15, 2018 6:55 am

ScottReed - This feature does not make single core processes multi-core, this does not make CPU more powerful. This new fix can help you in cases if device works abnormally and, for example, gets stuck on single core 100% usage which could lead up to Watchdog reboots.
jpaine619 - Please use Netinstall in order to resolve this problem. Without additional information we can not say for sure what happened, however, my guess would be that you ran out of free space during upgrade process and that caused this problem. Upgrade is re-worked in 6.42 version so you should not experience such problems when you will start an upgrade from (not to) 6.42 and other future RouterOS versions.
irghost - Please contact support regarding this problem. Send in supout files so we can help you as soon as possible.
mpadmin - About what kind of "bug" are you talking about? Have you contacted with support and figured out that there is an actual software issue with DHCP on your network?
pawelkopec88 - After an upgrade to this version 5 GHz wireless started to work slower than in 6.41.2?
kalsze, grusu, varcus, TmH, lewekleonek - Sorry about that. We will resolve this problem as soon as possible. However, only changelogs are affected - version files are right there for an upgrade.
 
pawelkopec88
just joined
Posts: 9
Joined: Wed Mar 14, 2018 11:06 pm

Re: v6.41.3 [current]

Thu Mar 15, 2018 7:11 am

Hi Strods,

This situation is on 6.41.2 and 6.41.3. On latest version RC perfomance growing up. But my HAP aftred update routerboard is going to only boot to NetInstall. Reflashing OS hasn't help me :)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Thu Mar 15, 2018 7:36 am

pawelkopec88 - If you had already this problem in 6.41.2, then please in the future at least mention this in forum or contact support team first. This is not a version related problem and such posts might discourage others from upgrade since others might assume that this version in some way makes wireless work worse than before. Please contact support@mikrotik.com and try to debug your wireless issue through an e-mail.

Others - Changelogs on our server are fixed now.
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Thu Mar 15, 2018 7:42 am

This is not a version related problem and such posts might discourage others from upgrade since others might assume that this version in some way makes wireless work worse than before.
So to say, the only safe option is to stay with bugfix branch and read forum even for its bugs and features. Current is too risky.
It would be only good to have public bugtracker anyway.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Thu Mar 15, 2018 8:52 am

Upgrade tests are made for each RouterOS release and version is released when upgrade works perfectly on all the lab units. Upgrades usually fail for end users due to:
1) Power issues;
2) Damaged storage;
3) Full storage;
4) Wrong package installations usually caused by installed rc version in the past.

For example, upgrade with bundle package should never fail.

We have re-worked upgrade in 6.42 version in order to avoid #3 and #4 caused problems as much as possible.
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Thu Mar 15, 2018 9:40 am

Upgrade tests are made for each RouterOS release and version is released when upgrade works perfectly on all the lab units. Upgrades usually fail for end users due to:
1) Power issues;
2) Damaged storage;
3) Full storage;
4) Wrong package installations usually caused by installed rc version in the past.

For example, upgrade with bundle package should never fail.

We have re-worked upgrade in 6.42 version in order to avoid #3 and #4 caused problems as much as possible.
By the way, may I ask for an advice: what if a person installed full set of ROS packages (for reason unknown) - the ones the listed as "Extra packages", is there a way to have router be back on standart set of packages (named "Main package") beside deleting it one by one? Once I tried to mark as deleted all packages and upload Main package to flash and reboot and recieved bricked device and some hours of netinstall.

Thank you for an advice!
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Thu Mar 15, 2018 10:22 am

Please keep topic related to release. That is the reason why we create such topic.

However, answer is simple - you can downgrade or upgrade device away from the version which you use by simply dropping bundle package into files section and either upgrading or downgrading the device.
 
upower3
Member
Member
Posts: 384
Joined: Thu May 07, 2015 11:46 am

Re: v6.41.3 [current]

Thu Mar 15, 2018 10:35 am

However, answer is simple - you can downgrade or upgrade device away from the version which you use by simply dropping bundle package into files section and either upgrading or downgrading the device.
What I see on this topic the process of ROS update/downgrade should be described in details?
 
zoombie
just joined
Posts: 5
Joined: Mon Mar 12, 2018 9:04 pm

Re: v6.41.3 [current]

Thu Mar 15, 2018 11:24 am

Still problems with downgrade/upgrade from 6.40.3 on ARM Routerboard, I've got answer from U, Hello,

"Please use the Netinstall utility to reinstall the device to the latest 6.42rc41 RouterOS release candidate version there have been multiple changes to improve the new AC chipset performance :
https://wiki.mikrotik.com/wiki/Manual:Netinstall" But please, this router boards are already installed to customer :/
 
Mriha2015
just joined
Posts: 1
Joined: Thu Dec 03, 2015 12:18 pm

Re: v6.41.3 [current]

Thu Mar 15, 2018 3:40 pm

Hello,

i have one critical problem. I am upgrading RB750 ver. 6.34.2 do 6.41.3 and now is DHCP client on port1 stopped+unknown port :(.
There is a big problem for remote upgrades :(.
....My estimated problem is this: Current FW3.33 up to FW 6.41.3....

Image

https://ibb.co/j9SGKc

THX for answer.
 
fredcom
just joined
Posts: 9
Joined: Thu Jan 18, 2018 7:55 pm

Re: v6.41.3 [current]

Thu Mar 15, 2018 11:22 pm

Hi,

I have a peculiar problem with 6.41.3 and an LTE modem. The board is RBM11G, the modem is Huawei ME909s-120.
The problem is that when I'm downloading something and the download speed goes up to a certain level, starting at, say, 40 Mbps, the internet connection just drops. There is no info in log, and the RSSI and RSRP meters are showing the same signal level (although there is a drop one notch when the connection disappears).
I've rolled back to 6.41.2 and this does not happen.
I've checked the voltage with the meter, and it does not sag, I've used two power adapters: 12 and 24v, but it does not change a thing.

Thanks
 
mpadmin
just joined
Posts: 18
Joined: Sun May 22, 2016 3:48 pm

Re: v6.41.3 [current]

Thu Mar 15, 2018 11:39 pm

...
mpadmin - About what kind of "bug" are you talking about? Have you contacted with support and figured out that there is an actual software issue with DHCP on your network?
...
Hi strods,
I also had issues with the DHCP server not handing out addresses after some time if the interface is a bridge. As docmarius wrote:
I had issues with the DHCP server not handing out addresses after some time of proper functioning in 6.41.2 if the interface is a bridge. This was reported by some users, and seemed it was addressed in the RC, so I assumed a ticket would not be necessary anymore (In my case I reverted my main router to 6.40.6 which solved the issue, so no emergency on this side).
And your answer was:
...
docmarius - This problem required re-work of DHCP service functionality on bridge interface. Since it was more like a re-written functionality not a fix, we decided to leave this for 6.42 release and not include in 6.41.x for safety reasons;
...
So I plan to downgrade all my routers, because bridge and dhcp server on it is a must (small routers with WiFi). Is there any workaround for the dhcp server hang on bridge before the 6.42 release?
 
asik
just joined
Posts: 20
Joined: Tue Sep 20, 2016 3:12 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 12:30 am

from a few months this set is available only from the command line:

/interface wireless set wlan1 security-profile=profile1

for following hardware:

SXT5AC
groove A-52Hpn
711GA-5HnD
711UA-5HnD
RB921GS-5HPacD r2

please fix this settings for winbox.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Fri Mar 16, 2018 7:09 am

upower3 - Sorry, but I did not understand your message. Upgrade has always worked like this - RouterOS checks all packages before an upgrade and tells if upgrade is possible, if it is, then packages are simply applied during reboot on RouterBOOT. So RouterOS old version (one before an upgrade) decides, for example, if there will be enough space for all the packages.
zoombie - What kind of problems? Connect serial console to this device, upgrade only when serial console is opened and provide serial console output to us. We will resolve your upgrade issue as soon as possible.
Mriha2015 - Please send supout file from your router to support. From which RouterOS version did you upgrade your device? If interface is a slave (for example, bridge port), then DHCP will not work on it. It must be configured on the bridge itself. Seems that in the past you had a version which by mistake allowed this wrong configuration and this is the result. Already for a while it is not possible to configure device like this.
fredcom - Please send supout file from your router to support@mikrotik.com. Generate file after modem has re-connected due to high traffic.
mpadmin - Without additional information we can not through forum detect what kind of problem do you have. I recommend that you contact support@mikrotik.com. It might be configuration issue, it might be an issue which is already resolved, it might be an issue which still needs to be resolved.
asik - Are you talking about Nv2 wireless interfaces "https://wiki.mikrotik.com/wiki/Manual:N ... v2_network"?
 
djmanas
just joined
Posts: 5
Joined: Tue Nov 07, 2017 9:28 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 10:35 am

Hi,

A have a new one HAP AC^2. (D52G-5HacD2HnD-TC)

The 2.4GHz network have better bandwith then 5.0GHz. Does anyone have the same? ?

Best Redgards,
Thanks for pointing out. I was not using large data transfers, so I would find out in a month or so, but as I see it, standard TX Rate was showing between 100-300 Mbit on my network interface, now I see only 40Mbit...

Also my quick test copy from notebook to network drive (notebook -> AC Wifi -> Router -> cable -> Disk) which was from 7 MByte to its best around 15 MByte is now 2.5 MByte.
 
djmanas
just joined
Posts: 5
Joined: Tue Nov 07, 2017 9:28 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 10:44 am

pawelkopec88 - If you had already this problem in 6.41.2, then please in the future at least mention this in forum or contact support team first. This is not a version related problem and such posts might discourage others from upgrade since others might assume that this version in some way makes wireless work worse than before. Please contact support@mikrotik.com and try to debug your wireless issue through an e-mail.
I didn’t have this problem in 6.41.2, last time I checked, before upgrade it was still on the speeds I have mentioned in previous post. I will contact the support also.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.41.3 [current]

Fri Mar 16, 2018 11:53 am

Hello Folks!

Upgrade successful on rb411, rb333, sxt, sextant, qrt5, rb711, crs.

Sadly I lost all remote Dynadish devices, after upgrading they never got contact with the wireless base stations again.
I have no ability to visit customers at this time, so I can not tell if there is any ethernet connection to it or what happened.
Dynadish was okey before upgrade, and had 6.37.5 before upgrade.

I asked them to power off and on the Dynadishes when they come home after work, lets see if that works or I have to travel some 300Km to fix it, annoying.
 
zoombie
just joined
Posts: 5
Joined: Mon Mar 12, 2018 9:04 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 11:59 am

I don't have sure that u know what You doing mikrotik team ;) but I still can't now upgrade from 6.41.3 to new RC. Did U test before release ?
Last edited by zoombie on Fri Mar 16, 2018 2:54 pm, edited 2 times in total.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: v6.41.3 [current]

Fri Mar 16, 2018 12:22 pm

Hello Folks!

Upgrade successful on rb411, rb333, sxt, sextant, qrt5, rb711, crs.

Sadly I lost all remote Dynadish devices, after upgrading they never got contact with the wireless base stations again.
I have no ability to visit customers at this time, so I can not tell if there is any ethernet connection to it or what happened.
Dynadish was okey before upgrade, and had 6.37.5 before upgrade.

I asked them to power off and on the Dynadishes when they come home after work, lets see if that works or I have to travel some 300Km to fix it, annoying.
All affected customers reached, unplugging power waiting 10 seconds and then plugging power back again made them connect to basestations again.
But we have stopped the rollout till further, we need to have personal available locally before continuing.

A sad story this with DHCP, hope our DHCP servers do not stop working till next ros release comes out with a fix..
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Fri Mar 16, 2018 5:20 pm

zoombie - To which IP address does your router resolve upgrade.mikrotik.com?
 
User avatar
WirtelPL
newbie
Posts: 34
Joined: Sat Nov 11, 2017 11:22 am
Location: Poland

Re: v6.41.3 [current]

Fri Mar 16, 2018 6:54 pm

RB951G-2HnD for home production
RBmAP2nD | RB952Ui-5ac2nD-TC for home lab
 
asik
just joined
Posts: 20
Joined: Tue Sep 20, 2016 3:12 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 7:05 pm

asik - Are you talking about Nv2 wireless interfaces "https://wiki.mikrotik.com/wiki/Manual:N ... v2_network"?
[/quote]
No.
Let me explain.

1. i set nv2 on my wireless interface
2. i don't use "Security_in_Nv2_network" (UNCHECKED Security)
3. I use security-profile only for RADIUS autentication with MODE=none for authentication (No security)

i have to do following from console

/interface wireless set wlan1 security-profile=profile1

for RADIUS mac address authentication for wireless interface with nv2 and no security used for this interface.

I understood that nv2 ignores security profile and use Nv2-security, but i use only RADIUS from menu in security-profile for authentication mac addresses and i think RADIUS menu should be independent when i choose nv2, nstreme or 802.11
 
Sob
Forum Guru
Forum Guru
Posts: 4780
Joined: Mon Apr 20, 2009 9:11 pm

Re: v6.41.3 [current]

Fri Mar 16, 2018 7:25 pm

Another bug fixed in this version: https://www.coresecurity.com/advisories ... r-overflow
I think this is what those people, who sometimes accuse MikroTik of not being transparent enough, are talking about. Sure, "smb - improved NetBIOS name handling and stability" is technically correct, fixing buffer overflow does improve stability. But exploitable buffer overflow sounds like quite important detail that should be mentioned somewhere on MikroTik's site.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: v6.41.3 [current]

Sat Mar 17, 2018 4:59 pm

Another bug fixed in this version: https://www.coresecurity.com/advisories ... r-overflow
I think this is what those people, who sometimes accuse MikroTik of not being transparent enough, are talking about. Sure, "smb - improved NetBIOS name handling and stability" is technically correct, fixing buffer overflow does improve stability. But exploitable buffer overflow sounds like quite important detail that should be mentioned somewhere on MikroTik's site.
...and should be incorporated into the bugfix branch, for those of us who want to patch the vulnerability, without also having to rework our complex bridge/VLAN/DHCP configurations to work with the new implementation in 6.41.
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
josthonsousa
just joined
Posts: 7
Joined: Thu Mar 15, 2018 8:56 pm
Location: colinas - maranhao brazil
Contact:

Re: v6.41.3 [current]

Sun Mar 18, 2018 8:19 pm

como reinstalar o routerOS nessa Cloud Core Router 1016-12S-1S+ sendo que a mesma so tem porta sfp , qual a porta que pode ser usada para transferir o arquivo ?
 
josthonsousa
just joined
Posts: 7
Joined: Thu Mar 15, 2018 8:56 pm
Location: colinas - maranhao brazil
Contact:

Re: v6.41.3 [current]

Sun Mar 18, 2018 8:22 pm

how to reinstall the routerOS in this Cloud Core Router 1016-12S-1S + that you can use to transfer the file?
Has anyone done this?
I am with two here giving only a beep and do not initialize more at all, someone can help me thank you!
 
josthonsousa
just joined
Posts: 7
Joined: Thu Mar 15, 2018 8:56 pm
Location: colinas - maranhao brazil
Contact:

Re: v6.41.3 [current]

Sun Mar 18, 2018 8:28 pm

zoombie - To which IP address does your router resolve upgrade.mikrotik.com?

how to reinstall the routerOS in this Cloud Core Router 1016-12S-1S + that you can use to transfer the file?
Has anyone done this?
I am with two here giving only a beep and do not initialize more at all, someone can help me thank you!
 
xrobau
just joined
Posts: 5
Joined: Wed Jan 03, 2018 4:18 am

Re: v6.41.3 [current]

Mon Mar 19, 2018 12:32 am

'Cable Test' is still broken. Tried it on a hAP ac and CCR1016-12G-4S and CCR1009-7G-1C-1S+
 
User avatar
soonwai
Member Candidate
Member Candidate
Posts: 163
Joined: Mon Feb 06, 2012 10:50 pm
Location: Kuala Lumpur

Re: v6.41.3 [current]

Mon Mar 19, 2018 7:27 am

RB2011UAS-2HnD ROS v6.41.3

Enabling pppoe client interface, waiting for a number of seconds (>14 secs), then disabling it results in "no such item (4)" error.
Occurs in Winbox and Terminal.
Also happens in 6.42rc43

Image

Image
 
Andrej16
just joined
Posts: 4
Joined: Mon Apr 03, 2017 10:02 am

Re: v6.41.3 [current]

Thu Mar 22, 2018 8:55 am

Problem with DHCP Server in this (6.41.3) release!
I periodically see series warning messages from some clients in Log. Mesages have the form:
dhcp_server offering lease 192.168.88.X for XX:XX:XX:XX:XX:XX without success
.
At start:
Image
At finish:
Image
About 50 warning messages.
It seems that everything works, but these messages should not be. Previously, they were not.
 
Nitin
just joined
Posts: 7
Joined: Sat Sep 24, 2011 8:16 pm

Re: v6.41.3 [current]

Thu Mar 22, 2018 4:53 pm

Why is it so difficult for Mikrotik to write proper DHCP server?

I have been using Mikrotiks since 2010s, and this has been a consistent pain in the wrong place.
If you google, most of the senior forum members will deny this problem existence and will blame faulty hardware and or cables. But seriously? In 7 years, multiple iterations of hardware, countless patch cables, countless clients - and this keeps getting in every few of their releases.

Suggestion (and ONLY possible alternative) - Start rolling back versions. You will find that one of the earlier version will work (and negating ALL those forum writes who claim this happens due to faulty wiring).

And dont get me started on "etherx received a packets with its own address as source". Answer to this - again - roll back to version which works.
 
rajo
newbie
Posts: 36
Joined: Tue Aug 16, 2011 11:12 pm

Re: v6.41.3 [current]

Thu Mar 22, 2018 6:31 pm

tls-host does not work with "mark-routing" mangle rules.

We have two Internet connections and I want all YouTube traffic using the slower of the two Internet connections. Unfortunately, YouTube breaks, if I do this, because the tls-host feature is not working properly in this case.

Here are the relevant rules:
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=to_GW2 passthrough=no protocol=tcp routing-mark=to_GW2 tls-host=*.youtube.com
add action=mark-routing chain=prerouting new-routing-mark=to_GW2 passthrough=no protocol=tcp routing-mark=to_GW2 tls-host=*.googlevideo.com

/ip route
add comment="ISP2 route" distance=1 gateway=192.168.0.1 routing-mark=to_GW2
 
Sob
Forum Guru
Forum Guru
Posts: 4780
Joined: Mon Apr 20, 2009 9:11 pm

Re: v6.41.3 [current]

Thu Mar 22, 2018 6:37 pm

tls-host does not work with "mark-routing" mangle rules.
It can't, because when you want to route connection to another WAN, you need to start with very first SYN packet. But the info needed by tls-host only comes later, and then it's too late to route connection elsewhere.
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
rajo
newbie
Posts: 36
Joined: Tue Aug 16, 2011 11:12 pm

Re: v6.41.3 [current]

Thu Mar 22, 2018 6:44 pm

Oh OK. Thanks, Sob. So much for that.
 
User avatar
eworm
Member
Member
Posts: 402
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41.3 [current]

Thu Mar 22, 2018 6:53 pm

tls-host does not work with "mark-routing" mangle rules.
It can't, because when you want to route connection to another WAN, you need to start with very first SYN packet. But the info needed by tls-host only comes later, and then it's too late to route connection elsewhere.
You could match tls-host and create a dynamic address-list entry for the address. Then match new connections for these addresses for routing-mark. You miss the first connection, but it is worth a try.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
rajo
newbie
Posts: 36
Joined: Tue Aug 16, 2011 11:12 pm

Re: v6.41.3 [current]

Thu Mar 22, 2018 8:08 pm

Not feeling that adventurous. Too bad Google uses the same IP blocks for everything; otherwise, I could have simply created a list for YouTube and used that.
 
User avatar
eworm
Member
Member
Posts: 402
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.41.3 [current]

Thu Mar 22, 2018 9:21 pm

Not feeling that adventurous. Too bad Google uses the same IP blocks for everything; otherwise, I could have simply created a list for YouTube and used that.
Adventurous? Should be pretty straight forward. Something like this should work:
/ip firewall filter
add action=add-dst-to-address-list chain=forward address-list=youtube protocol=tcp tls-host=*.youtube.com
/ip firewall mangle
add action=mark-routing chain=prerouting  connection-state=new  dst-address-list=youtube new-routing-mark=youtube
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
hairfarmer
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Thu Jan 31, 2008 1:11 am

Re: v6.41.3 [current]

Thu Mar 22, 2018 10:37 pm

Upgrade failed?

After upgrading RB1100AHx4 (arm) Dude Edition - Hotspot would not create simple queues for all users and speed drastically slowed down.

So some users had queues (about 17) but there were 40 people logged. Less than half had a queue dynamically created. I could not find any association with a user profile etc, it just seemed random.

Anyone else see an issue like this?
 
telcouk
just joined
Posts: 17
Joined: Mon Jan 08, 2018 3:50 pm

Re: v6.41.3 [current]

Fri Mar 23, 2018 3:30 pm

Word of !WARNING for anyone who has the CCR1072-1G-8S+.

We have two of these units, since the upgrade both have used consistently 10 more watts of power!
This has also increased the temperature of the device and fan speed, that can't be a good thing can it?

We've contacted Mikrotik and this is their response:
***
Power consumption is caused by this improvement:
*) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
This fix will make your CCR work more stable.
***
Just be aware if you're in a data centre environment with limited power.

We have also upgraded our two CCR1036-8G-2S+ which only saw a slight increase in power usage after the upgrade.
 
User avatar
zap71
Frequent Visitor
Frequent Visitor
Posts: 83
Joined: Fri Sep 27, 2013 11:10 am
Location: Berlin, Germany
Contact:

Re: v6.41.3 [current]

Sat Mar 24, 2018 9:09 am

Hi,
just bricked two of my three RB962UiGS-5HacT2HnT by upgrading from 6.41.2 to 6.41.3.

I did the following steps - as I did with the last update:
1. uploaded routeros-mipsbe-6.41.3.npk
2. reboot
3. uploaded active modules
- advanced-tools-6.41.3-mipsbe.npk
- dhcp-6.41.3-mipsbe.npk
- ipv6-6.41.3-mipsbe.npk
- multicast-6.41.3-mipsbe.npk
- ntp-6.41.3-mipsbe.npk
- routing-6.41.3-mipsbe.npk
- security-6.41.3-mipsbe.npk
- system-6.41.3-mipsbe.npk
- user-manager-6.41.3-mipsbe.npk
- wireless-6.41.3-mipsbe.npk
4. /system routeros upgrade
5. reboot

and now the system is in an endless reboot loop where it beeps alternating at a loud beep and less loud afterwards.

Whats wrong and how could I get them back to life?

Zap.
 
User avatar
grusu
Member Candidate
Member Candidate
Posts: 100
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: v6.41.3 [current]

Sat Mar 24, 2018 9:18 am

Hi,
just bricked two of my three RB962UiGS-5HacT2HnT by upgrading from 6.41.2 to 6.41.3.

I did the following steps - as I did with the last update:
1. uploaded routeros-mipsbe-6.41.3.npk
2. reboot
3. uploaded active modules
- advanced-tools-6.41.3-mipsbe.npk
- dhcp-6.41.3-mipsbe.npk
- ipv6-6.41.3-mipsbe.npk
- multicast-6.41.3-mipsbe.npk
- ntp-6.41.3-mipsbe.npk
- routing-6.41.3-mipsbe.npk
- security-6.41.3-mipsbe.npk
- system-6.41.3-mipsbe.npk
- user-manager-6.41.3-mipsbe.npk
- wireless-6.41.3-mipsbe.npk
4. /system routeros upgrade
5. reboot

and now the system is in an endless reboot loop where it beeps alternating at a loud beep and less loud afterwards.

Whats wrong and how could I get them back to life?

Zap.
routeros-mipsbe-6.41.3.npk contains almost all the packages you have installed separately:

routeros-mipsbe (mipsbe) combined package for mipsbe (includes system, hotspot, wireless, ppp, security, mpls, advanced-tools, dhcp, routerboard, ipv6, routing)

You should only install ntp separately...
The device has only 16MB flash.
 
KBoris
just joined
Posts: 20
Joined: Sun Sep 30, 2012 10:06 pm

Re: v6.41.3 [current]

Sat Mar 24, 2018 1:23 pm

Hi

I receive 50pcs of new hAP lite with installed firmware version 6.40.4. I have exported configuration config.rsc file made in one of the previous firmware version (Ithink 6.3X.X) and was succesfuly uploaded on aprox. 400 routers. Everything works fine till last firmware versions. I also try to upgrade router to v6.41.3 but when I upload my config and run command ....

[admin@MikroTik] > system reset-configuration no-defaults=yes run-after-reset=config.rsc

...my configuration become defective. There is no LAN configuration, DHCP, bridges are also not ok, settings for Inteenet is not as expected...
I also try to upgrade working router to latest version and export config, but I get same situation.

Can somebody help me with some advice. What was changed in this routers or there are some changes in syntax ????

Boris
 
rac
just joined
Posts: 8
Joined: Fri Oct 15, 2010 4:47 pm

Re: v6.41.3 [current]

Sat Mar 24, 2018 6:10 pm

Hi Boris,

I have this kind of problem most times, especially when transfering a configuration to another kind of device. Try this:
  • Have a test router in your local network - upgrade it.
  • Reset configuration without using a configuration script (system reset-configuration no-defaults=yes)
  • Open your script file in editor
  • Connect to the test router with winbox e.g. via mac address and open "new terminal"
  • Mark some lines from script file and use copy paste to terminal in winbox (winbox paste in right mouse menu)
  • If you get an error look at the line and try to correct it
If you have now idea how to correct, login to a working system on target version (e.g. install "old" version with your config and do normal upgrade with in system/packages menu) and use the export subcommand (e.g. problem in bridge config -> /interface bridge export). You also can do the defective config over the menus and show the result with the export subcommand.

Holger
 
Diesal
just joined
Posts: 2
Joined: Sat Mar 24, 2018 12:47 am
Location: Cape Town, South Africa
Contact:

Re: v6.41.3 [current]

Sun Mar 25, 2018 1:08 am

Hey MikroTik Team,

I'm getting a strange issue, upon re-enabling my PPPoE-client, Winbox spits out the following error:
Couldn't change Interface <TelkomInternet> - object doesn't exist (4)
Enabling the interface again after dismissing the warning, enables the interface, however this does create an issue for me as I use the scheduler to switch pppoe accounts, the above error causes the account not to activate at the correct time.

This particular issue started after the 6.41 update.

What I've done thus far:
[*]Removing PPPoE client and re-adding it
[*]Full reset of the RB

I am running on a HAP Lite (RouterBOARD 941-2nD) and connecting to my ISP via ADSL.
Let me know if you guys need anymore info.
 
sindy
Forum Guru
Forum Guru
Posts: 3886
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.3 [current]

Sun Mar 25, 2018 9:51 am

Enabling the interface again after dismissing the warning, enables the interface, however this does create an issue for me as I use the scheduler to switch pppoe accounts, the above error causes the account not to activate at the correct time.
To keep rolling until the actual issue gets fixed, check whether use of a standalone
:do {...}
possibly followed by
on-error {...}
as described here doesn't help. Something like
{
  :local attempts 3
  :while ([/interface pppoe-client print count-only where disabled=no && name=pppoe-out1]=0 and $attempts>0)  do={
    :do={/interface pppoe-client enable [find name=pppoe-out1]};
    :set attempts ($attempts-1)
  }
}
Alternatively, you may use
execute script=" ... "
instead of the inner
do={ ... }
.
Last edited by sindy on Sun Mar 25, 2018 10:38 am, edited 1 time in total.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
User avatar
soonwai
Member Candidate
Member Candidate
Posts: 163
Joined: Mon Feb 06, 2012 10:50 pm
Location: Kuala Lumpur

Re: v6.41.3 [current]

Sun Mar 25, 2018 10:34 am

Hey MikroTik Team,

I'm getting a strange issue, upon re-enabling my PPPoE-client, Winbox spits out the following error:
Couldn't change Interface <TelkomInternet> - object doesn't exist (4)
...
I've encountered the same problem. Details in post #80 above.
viewtopic.php?p=650142&sid=12116311e944 ... 85#p648907
 
netflow
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Sat Oct 01, 2016 3:53 pm

Re: v6.41.3 [current]

Sun Mar 25, 2018 2:20 pm

With 6.41.3, LTE interface on USB is not longer passing any packets after running for example a speed test. Have to power reset the USB to get it back to life.
As I cannot work like this, I downgraded to 6.41.2 which is behaving properly.
 
netflow
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Sat Oct 01, 2016 3:53 pm

Re: v6.41.3 [current]

Sun Mar 25, 2018 2:30 pm

Problem with DHCP Server in this (6.41.3) release!
I periodically see series warning messages from some clients in Log. Mesages have the form:
dhcp_server offering lease 192.168.88.X for XX:XX:XX:XX:XX:XX without success
.
I have the same with an HP Printer connected over wifi through a non MT device. This has been so with every MT firmware. I believe the device requesting the IP is to blame.
 
Diesal
just joined
Posts: 2
Joined: Sat Mar 24, 2018 12:47 am
Location: Cape Town, South Africa
Contact:

Re: v6.41.3 [current]

Sun Mar 25, 2018 3:13 pm

I've encountered the same problem. Details in post #80 above.
viewtopic.php?p=650142&sid=12116311e944 ... 85#p648907
Thanks for the heads up, thought I was the only one after not finding anything, hence I had to register just to report this :lol:
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.41.3 [current]

Sun Mar 25, 2018 10:39 pm

Word of !WARNING for anyone who has the CCR1072-1G-8S+.

We have two of these units, since the upgrade both have used consistently 10 more watts of power!
This has also increased the temperature of the device and fan speed, that can't be a good thing can it?

We've contacted Mikrotik and this is their response:
***
Power consumption is caused by this improvement:
*) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
This fix will make your CCR work more stable.
***
Just be aware if you're in a data centre environment with limited power.

We have also upgraded our two CCR1036-8G-2S+ which only saw a slight increase in power usage after the upgrade.
Duly noted. BUT is it just an increase and nothing to bother with or is it out of MT SPEC for MAXWattage witch is what you should calculate in your DC or TelCo Rack not to hit stuff down the road.

Direct Question then is it out of the SPEC or not?
 
telcouk
just joined
Posts: 17
Joined: Mon Jan 08, 2018 3:50 pm

Re: v6.41.3 [current]

Sun Mar 25, 2018 11:09 pm

Word of !WARNING for anyone who has the CCR1072-1G-8S+.

We have two of these units, since the upgrade both have used consistently 10 more watts of power!
This has also increased the temperature of the device and fan speed, that can't be a good thing can it?

We've contacted Mikrotik and this is their response:
***
Power consumption is caused by this improvement:
*) tile - improved overall system performance and stability ("/system routerboard upgrade" required);
This fix will make your CCR work more stable.
***
Just be aware if you're in a data centre environment with limited power.

We have also upgraded our two CCR1036-8G-2S+ which only saw a slight increase in power usage after the upgrade.
Duly noted. BUT is it just an increase and nothing to bother with or is it out of MT SPEC for MAXWattage witch is what you should calculate in your DC or TelCo Rack not to hit stuff down the road.

Direct Question then is it out of the SPEC or not?
Before the update they were both consuming around 45W each, now they are consuming around 55W each.
That's around a 22% increase in power consumption, just by applying this update...

It's still well within the 125W specification, which is why we've kept the update in place.
 
GamacchioAssiderato
just joined
Posts: 3
Joined: Fri Dec 29, 2017 2:38 pm

Re: v6.41.3 [current]

Mon Mar 26, 2018 8:48 pm

*) smb - improved NetBIOS name handling and stability; = fixed vulnerability
https://github.com/BigNerd95/Chimay-Blue
 
escandor
just joined
Posts: 9
Joined: Mon Mar 26, 2018 9:54 pm

Re: v6.41.3 [current]

Mon Mar 26, 2018 10:06 pm

Hi,

does anybody experiencing problems with wifi on 2011UAS-2HnD
with latest version 6.41.3 wifi disappear over the time (devices can not connect to wifi, in webfig, wireless interface has status 'not running').
After interface restart (via modification of settings or reboot) wifi appears again(devices can connect and use internet). But within one day wifi disappear again.
During this problem Ethernet ports continue working without problems.

Also in log appears following log records "@wifi: disconnected, extensive data loss" before problem

With version 6.41.1 wifi was disappearing after one week, with version 6.41.3 this happens in one day.

Thanks in advance for any help
 
Simono
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Tue Mar 20, 2018 9:41 am

Re: v6.41.3 [current]

Tue Mar 27, 2018 8:16 am

@up I have some problems with RB2011UiAS-2HnD. On my network I have two Caps and WiFi on router connected to Capsman on RB2011UiAS-2HnD.
I also sometimes observe that wifi disappear with place that signal i strong, also tranfer over WiFi on leateest stable version is slow (2-3MB/s) on 2.4 GHz band, I have also one device on my network with so slow transfer over WiFi with the user turns off and stop it using. On previous version before 6.41 al was ok. I'm waiting for next version.
 
megalogplus
just joined
Posts: 4
Joined: Wed Mar 29, 2017 1:34 pm

Re: v6.41.3 [current]

Wed Mar 28, 2018 11:32 am

Hello.
I have a problem with RBLHGG-5acD. I upgrade the software and firmware up to 6.41.3.
When I change some settings in "wireless" like "scan list" or "wireless protocol", the device reboots.
After this settings are not changed and I see in log "router was rebooted without shutdown" "Kernel failure in previous boot"
This is the first time I've come across this.
Help me please.
 
japres
just joined
Posts: 6
Joined: Tue Jan 16, 2018 5:14 pm

Re: v6.41.3 [current]

Wed Mar 28, 2018 1:12 pm

Hello,

Anybody experiencing the extremely frustrating bug whereby you go to add an interface to a bridge and it just disconnects you from Winbox??

It's infuriating...

Seems fine in the terminal if anybody else is running into the problem.
 
Anatoly
just joined
Posts: 7
Joined: Tue Feb 17, 2015 12:51 pm

Re: v6.41.3 [current]

Thu Mar 29, 2018 12:11 am

Please return ISPEC Priority! Without this option, I will have to rewrite about 1000 rules or refuse further updates. Madness of some kind ...
 
Skippi
just joined
Posts: 3
Joined: Tue Apr 26, 2016 2:04 pm

Re: v6.41.3 [current]

Thu Mar 29, 2018 10:02 am

Hello.
I have a problem with RBLHGG-5acD. I upgrade the software and firmware up to 6.41.3.
When I change some settings in "wireless" like "scan list" or "wireless protocol", the device reboots.
After this settings are not changed and I see in log "router was rebooted without shutdown" "Kernel failure in previous boot"
This is the first time I've come across this.
Help me please.
Faced this with RBLHGG-5acD, fixed 6.42rc52.
Also this board does not work at 40 MHz.
 
AlexT
just joined
Posts: 22
Joined: Thu Mar 29, 2018 9:51 am

Re: v6.41.3 [current]

Thu Mar 29, 2018 10:20 am

Hi!
hAP ac², 6.41.3.

Where is the switch menu in winbox/web-iface?
Where can I see "Overall stats", "Rx Stats" and "Tx Stats" for wired interfaces?

P. S. Compared with my first mikrotik device (hAP lite classic (RB941-2nD)), the wireless 2.4 GHz in hAP ac² sucks
 
jarda
Forum Guru
Forum Guru
Posts: 7603
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.41.3 [current]

Thu Mar 29, 2018 3:04 pm

Switch menu was removed recently because the hw accelerated bridges are the way mikrotik goes these days.
 
Kraken2k
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Wed Oct 01, 2014 1:50 pm
Location: Prague

Re: v6.41.3 [current]

Thu Mar 29, 2018 3:19 pm

Updated my RB1100AHx4 a week ago - so far no problem, but today morning rebooted unexpectedly with "router rebooted because some critical program crashed" error.

Report sent, Ticket#2018032922004596
 
sindy
Forum Guru
Forum Guru
Posts: 3886
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.3 [current]

Thu Mar 29, 2018 4:10 pm

Switch menu was removed recently because the hw accelerated bridges are the way mikrotik goes these days.
hAP ac lite does show the switch menu in WebFig, hAP ac² doesn't, while both of them run the same version (6.42rc49 at the moment of checking this). I cannot believe Mikrotik would remove the switch menu before having the complete functionality available via bridge configuration, so does this really mean that for ar8327, VLAN filtering configuration of bridge already completely manages the VLAN filtering in the switch chip?

The fact that the whole
/interface ethernet switch
tree is still there in the CLI cools my optimism down a bit, though.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
mikeeg02
just joined
Posts: 10
Joined: Fri Mar 30, 2018 2:28 am

Re: v6.41.3 [current]

Fri Mar 30, 2018 2:52 am

I'm not sure where to put this question so here goes.

I've built a vpls network using mikrotik equipment (3011s and CCRs) that goes across the state using PTP microwave links,(26 sites/routers all together) using single 172.16.0.0/29 subnets per interface link. Everything was completely stable on 6.38.5 for months. Dude monitoring service was also happy. Upgraded to 6.41.3 after seeing mikrotik being attacked, figuring all would be well after testing with a few routers at my bench, all seemed good. After deployment, my vpls tunnels all establish and everything mpls related works, I can reach everything if I use the router (running the dude) as my gateway, but the dude (whether an external dude server as it originally was or when I recently swapped out one for a rb1100 dude edition) it reports a few devices down.

Even though the vpls tunnels has been established to the remote device, the router the dude is running on cannot ping/telnet/whatever you want to the device, and the dude ping service reports it down. Though using the same router as my gateway, I can access the same device that router cannot access. What am I missing here? Ive been struggling with it for a couple days now.
 
AlexT
just joined
Posts: 22
Joined: Thu Mar 29, 2018 9:51 am

Re: v6.41.3 [current]

Fri Mar 30, 2018 11:42 am

Switch menu was removed recently because the hw accelerated bridges are the way mikrotik goes these days.
It's clear, but it's bad.

And what about this (hAP ac²)?
Where can I see "Overall stats", "Rx Stats" and "Tx Stats" for wired interfaces?
Last edited by AlexT on Fri Mar 30, 2018 10:31 pm, edited 1 time in total.
 
netflow
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Sat Oct 01, 2016 3:53 pm

Re: v6.41.3 [current]

Fri Mar 30, 2018 5:53 pm

Anybody experiencing the extremely frustrating bug whereby you go to add an interface to a bridge and it just disconnects you from Winbox??
What makes you think it is a bug ? If you play with the interface you are connected with, you can expect that behavior.
Be sure of what you do, do not activate safe mode, then hold your breath for 2 sec and reconnect.
 
sindy
Forum Guru
Forum Guru
Posts: 3886
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.41.3 [current]

Sat Mar 31, 2018 2:17 pm

Switch menu was removed recently because the hw accelerated bridges are the way mikrotik goes these days.
hAP ac lite does show the switch menu in WebFig, hAP ac² doesn't, while both of them run the same version (6.42rc49 at the moment of checking this). I cannot believe Mikrotik would remove the switch menu before having the complete functionality available via bridge configuration, so does this really mean that for ar8327, VLAN filtering configuration of bridge already completely manages the VLAN filtering in the switch chip?

The fact that the whole
/interface ethernet switch
tree is still there in the CLI cools my optimism down a bit, though.
I went a bit deeper into it and setting VLAN filtering at bridge level just disables hardware acceleration (without MSTP so that's not the reason) but has no visible effect in
/interface ethernet switch port
and
/interface ethernet switch vlan
settings, while if I do some settings using these configuration branches, they do affect the switch behaviour. So I assume it is a bug of WebFig/Winbox, not an intention.
And what about this (hAP ac²)?
Where can I see "Overall stats", "Rx Stats" and "Tx Stats" for wired interfaces?
Is
/interface ethernet print stats
and
/interface ethernet switch print stats
not what you want?
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
AlexT
just joined
Posts: 22
Joined: Thu Mar 29, 2018 9:51 am

Re: v6.41.3 [current]

Sat Mar 31, 2018 8:43 pm

And what about this (hAP ac²)?
Where can I see "Overall stats", "Rx Stats" and "Tx Stats" for wired interfaces?
Is
/interface ethernet print stats
and
/interface ethernet switch print stats
not what you want?
From console is ok, but what about show this in winbox & web-iface?
 
KBoris
just joined
Posts: 20
Joined: Sun Sep 30, 2012 10:06 pm

Re: v6.41.3 [current]

Sat Mar 31, 2018 9:33 pm

Hi Boris,

I have this kind of problem most times, especially when transfering a configuration to another kind of device. Try this:
  • Have a test router in your local network - upgrade it.
  • Reset configuration without using a configuration script (system reset-configuration no-defaults=yes)
  • Open your script file in editor
  • Connect to the test router with winbox e.g. via mac address and open "new terminal"
  • Mark some lines from script file and use copy paste to terminal in winbox (winbox paste in right mouse menu)
  • If you get an error look at the line and try to correct it
If you have now idea how to correct, login to a working system on target version (e.g. install "old" version with your config and do normal upgrade with in system/packages menu) and use the export subcommand (e.g. problem in bridge config -> /interface bridge export). You also can do the defective config over the menus and show the result with the export subcommand.

Holger
Hello Holger
Thank you for your advice, but.....
I did like you sugested and find a lot of changes in syntax. I don't understand why but this is Mikrotik developer decision. I made changes in my .rsc file and still doesn't work so I start to configure from scratch (on latest firmware version).
I finish with configuration and Now I expect that export and than import should work. I export file , download this file, I take another router, upload file and run command in terminal:
[admin@MikroTik] > system reset-configuration no-defaults=yes run-after-reset=config.rsc

Some parts of the configuration are OK, other are not. I also try through Winbox with Reset configuration , x- No default Configuration and than I select from dropdown menu config.rsc file.
After configuratin was reset I see that IP address on LAN in 0.0.0.0/0 ......

Now I realy need some help, because I would not like to configre 50pcs (now and more in the future) manualy :-(
 
User avatar
43north
Member Candidate
Member Candidate
Posts: 197
Joined: Fri Nov 14, 2014 7:06 am

Re: v6.41.3 [current]

Sun Apr 01, 2018 3:32 am

Can someone confirm for me specifically with the DHCP issue on a bridge only occurs if you have the DHCP server on an individual physical interface that is part of a bridge? I have my DHCP assigned directly to the bridge itself, will I have issues with it setup this way or is that the way it is working properly?
 
AlexT
just joined
Posts: 22
Joined: Thu Mar 29, 2018 9:51 am

Re: v6.41.3 [current]

Sun Apr 01, 2018 10:48 am

hAP ac², 6.41.3:

[xxx@router] > /interface wireless spectral-scan wlan1
failure: this device can not do spectral scan
[xxx@router] > /interface wireless spectral-scan wlan2
failure: this device can not do spectral scan


and one more thing

2.4 GHz
Image
5.2 GHz
Image

Will this be fixed in future updates?
 
Jeanluck
Member Candidate
Member Candidate
Posts: 272
Joined: Tue Apr 19, 2011 7:07 pm

Re: v6.41.3 [current]

Sun Apr 01, 2018 1:43 pm

105547111 - You see this option on your device by mistake. Of course, since you do not have a SIM slot, you should not see SIM related options on CRS125 device;
docmarius - This problem required re-work of DHCP service functionality on bridge interface. Since it was more like a re-written functionality not a fix, we decided to leave this for 6.42 release and not include in 6.41.x for safety reasons;
zoombie - Why can not you upgrade? Upgrade functionality is not working or simply you did decide to stick with 6.40.3 version? I recommend that you contact support@mikrotik.com. Sounds like conversion from old bridge implementation to new one might have affected you, but we can not comment on this further without debugging your specific case through support;
guipoletto - This feature does not make single core processes multi-core, this does not make CPU more powerful. This new fix can help you in cases if device works abnormally and, for example, gets stuck on single core 100% usage which could lead up to Watchdog reboots.
I have 6.38.3 version, and I want to upgrade, but I want to avoid DHCP Server fail on bridge. What version is afected? Can I upgrade to 6.40.6 without risk of this bug?
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: v6.41.3 [current]

Tue Apr 03, 2018 1:51 am

I have 6.38.3 version, and I want to upgrade, but I want to avoid DHCP Server fail on bridge. What version is afected? Can I upgrade to 6.40.6 without risk of this bug?
IMHO yes, but better to ask here >> viewtopic.php?f=21&t=131129&start=50
 
rac
just joined
Posts: 8
Joined: Fri Oct 15, 2010 4:47 pm

Re: v6.41.3 [current]

Tue Apr 03, 2018 3:42 pm

Hello Holger
Thank you for your advice, but.....
I did like you sugested and find a lot of changes in syntax. I don't understand why but this is Mikrotik developer decision. I made changes in my .rsc file and still doesn't work so I start to configure from scratch (on latest firmware version).
I finish with configuration and Now I expect that export and than import should work. I export file , download this file, I take another router, upload file and run command in terminal:
[admin@MikroTik] > system reset-configuration no-defaults=yes run-after-reset=config.rsc

Some parts of the configuration are OK, other are not. I also try through Winbox with Reset configuration , x- No default Configuration and than I select from dropdown menu config.rsc file.
After configuratin was reset I see that IP address on LAN in 0.0.0.0/0 ......

Now I realy need some help, because I would not like to configre 50pcs (now and more in the future) manualy :-(
Hello Boris,

try my suggested cut&paste procedure now on this configuration. With new/changed features there are sometimes bugs in the export. The default export tries to minimize the commands, skipping parameters with default value. But by mistake sometimes a mandatory paremeter is skipped and this line fail on import. With cut&paste to a terminal in Winbox you will find the error.
Not a nice way, but this helped me many times.
You can also try the "verbose" option on export to get complete commands including default/not set options.

If you find an export bug, please report it to support to get it fixed for next upgrade.

Holger
 
A9691
just joined
Posts: 13
Joined: Sat May 14, 2016 10:58 am

Re: v6.41.3 [current]

Wed Apr 04, 2018 3:25 pm

RB2011UAS-2HnD ROS v6.41.3

Enabling pppoe client interface, waiting for a number of seconds (>14 secs), then disabling it results in "no such item (4)" error.
Occurs in Winbox and Terminal.
Also happens in 6.42rc43

I have the same problem with a PPP Client interface:
[admin@teszt] /interface> set ppp disabled=yes;          
no such item (4)
[admin@teszt] /interface> set ppp disabled=yes;
[admin@teszt] /interface>  /delay 20; set ppp disabled=no
no such item (4)
[admin@teszt] /interface> set ppp disabled=no            
[admin@teszt] /interface> 
The first statement gives error, but when repeated without delay executes correctly.
After 20 seconds the same error first, but executed correctly when repeated.
The same happens using the GUI in Winbox.

(RB951G-2HnD - Router OS 6.41.3 (stable) )
 
trace310
just joined
Posts: 15
Joined: Sun Jan 26, 2014 5:16 pm

Re: v6.41.3 [current]

Wed Apr 04, 2018 5:35 pm

Hello,

I have over 5,000 Mikrotik deployed. I have them on 6.32.2 ( which I know is old, but it was stable never had an issue and always worked fine.

I upgraded to firmware 6.38.7 > I started to have major issues with connectivity issues. I use a hotspot for my Mikrotiks. < I downgraded to 6.35.2 works like a charm, no issues.

Now since all the stuff that's going on I have upgraded few sites that I know that are working great, i upgraded them to 6.41.3 > I started to notice speed issues, performance issues.

I still have not gotten complaints from it but based on the tests I am doing there is something wrong here.

I use hotspots for a lot of my Mikrotiks, and I Notice a lot of the firmware don't work to well with hotspots.

So it's just very hard to upgrade..
 
trace310
just joined
Posts: 15
Joined: Sun Jan 26, 2014 5:16 pm

Re: v6.41.3 [current]

Wed Apr 04, 2018 5:56 pm

SO update...

I upgraded one of the properties that I had on 6.35.2 to > 6.41.3

No internet access for my LAN customers. Throughout the site. They can connect but they were not hitting my splash page, even when the hotspot turned off no internet access. I turned it back on and manually whitelisted them so they won't have to see my splash page and same thing. They get a valid IP address of my DHCP but no Internet axx at all.

This is a major issue especially for people who use hotspot and especially for me that i have over 5000 Mikrotik deployed.

This is 400 room hotel. No one was seeing my terms, either on an iPhone, tablet, laptop, desktop,iPad.

So yes. We need a fix for this.

NEED HELP! ASAP!!!!!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8317
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41.3 [current]

Wed Apr 04, 2018 6:53 pm

So yes. We need a fix for this.

NEED HELP! ASAP!!!!!
Looks like you need some network engineer for basic troubleshooting of the problem you have after update. Like ping, traceroute...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
trace310
just joined
Posts: 15
Joined: Sun Jan 26, 2014 5:16 pm

Re: v6.41.3 [current]

Wed Apr 04, 2018 7:05 pm

Nope.. I can ping out to google dns, yahoo without issues. I can traceroute without issues. I have access to all my equipment behind my Mikrotik without issues.

So it's a firmware issue that needs to get fixed ASAP. Shit isn't rocking science kid.

Obviously, if it works fine on all firmware below 6.38.7 then it's something with that firmware not my configs or my networks

So yes. We need a fix for this.

NEED HELP! ASAP!!!!!
Looks like you need some network engineer for basic troubleshooting of the problem you have after update. Like ping, traceroute...
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: v6.41.3 [current]

Wed Apr 04, 2018 7:33 pm

Nope.. I can ping out to google dns, yahoo without issues. I can traceroute without issues. I have access to all my equipment behind my Mikrotik without issues.
So it's a firmware issue that needs to get fixed ASAP. Shit isn't rocking science kid.
Obviously, if it works fine on all firmware below 6.38.7 then it's something with that firmware not my configs or my networks
We ran into a similar problem when upgrading from 6.40.6 to 6.41.3. It may be due to the re-implementation of bridges in 6.41, which seems to result in some combinations of features working differently (i.e., not as intended) under the new version. In our case, I think the change in behavior pertains to our use of VLANs. (As soon as I get the time to build a testbed, and figure out what we need to change in our standard configuration to make it work the same in 6.41.x, I'll post the findings.)

In any case, I'd try upgrading this one location to 6.40.6. If that works, then you may be running into the same problem that we are.
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8317
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41.3 [current]

Wed Apr 04, 2018 7:37 pm

Nope.. I can ping out to google dns, yahoo without issues. I can traceroute without issues. I have access to all my equipment behind my Mikrotik without issues.

So it's a firmware issue that needs to get fixed ASAP. Shit isn't rocking science kid.
Yeah, but we still don't know anything about the issue except that "Internet is not working". For example, what error does your browser show when you're trying to open some page? Did you use Torch/Firewall rules/Packet sniffer to see where exactly packets are lost?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
trace310
just joined
Posts: 15
Joined: Sun Jan 26, 2014 5:16 pm

Re: v6.41.3 [current]

Wed Apr 04, 2018 7:49 pm

No websites will load. They can ping my LAN default gateway which is 192.168.10.1 . Even after whitelisting the device, bypassing my TERMS OF SERIVCE page, could not ping out to google dns or anything. No pages will load, youtube,facebook,msn.

The Mikrotik itself, I can ping out, traceroute, access equipment behind my equipment.

The user had an IP of 192.168.10.23 - I had her disconnect and reconnect. I was running a ping on her device notice it replied back for two seconds when she connected back to my wifi network and then timed out.

I downgraded back to 6.35.2 I had her diconnect/reconnect she immediately started to respond back to pings. I got over 300 hits on my wallgarden, and users were authenticating right away without issues. She was pinging 1ms , this is via the Mikrotik. She got online immediately, can pull emails, surf the web.



Nope.. I can ping out to google dns, yahoo without issues. I can traceroute without issues. I have access to all my equipment behind my Mikrotik without issues.

So it's a firmware issue that needs to get fixed ASAP. Shit isn't rocking science kid.
Yeah, but we still don't know anything about the issue except that "Internet is not working". For example, what error does your browser show when you're trying to open some page? Did you use Torch/Firewall rules/Packet sniffer to see where exactly packets are lost?
 
trace310
just joined
Posts: 15
Joined: Sun Jan 26, 2014 5:16 pm

Re: v6.41.3 [current]

Wed Apr 04, 2018 7:59 pm

I'm going to try this, and see if ti works. I'll let you know shortly.

Nope.. I can ping out to google dns, yahoo without issues. I can traceroute without issues. I have access to all my equipment behind my Mikrotik without issues.
So it's a firmware issue that needs to get fixed ASAP. Shit isn't rocking science kid.
Obviously, if it works fine on all firmware below 6.38.7 then it's something with that firmware not my configs or my networks
We ran into a similar problem when upgrading from 6.40.6 to 6.41.3. It may be due to the re-implementation of bridges in 6.41, which seems to result in some combinations of features working differently (i.e., not as intended) under the new version. In our case, I think the change in behavior pertains to our use of VLANs. (As soon as I get the time to build a testbed, and figure out what we need to change in our standard configuration to make it work the same in 6.41.x, I'll post the findings.)

In any case, I'd try upgrading this one location to 6.40.6. If that works, then you may be running into the same problem that we are.
 
mikeeg02
just joined
Posts: 10
Joined: Fri Mar 30, 2018 2:28 am

Re: v6.41.3 [current]

Wed Apr 04, 2018 8:53 pm

While different. This sounds similar to what I'm experiencing. Router A cannot ping router F, but I can ping router F using router A as a gateway. Router A can establish a vpls tunnel to router F. There are some oddities that didn't present themself in 6.38.5 for me. I changed some path costs and made things stable, but if anything in the network changes it can resort to previous issues.

Yours appears to be in reverse where you're endpoints can't use them as a gateway.

I can make it do what you're doing, where I can't use it as a gateway but router A can ping F. But using A as my gateway I cannot ping F.
 
User avatar
Hotz1
Member
Member
Posts: 391
Joined: Tue Oct 09, 2007 6:55 am

Re: v6.41.3 [current]

Wed Apr 04, 2018 10:42 pm

While different. This sounds similar to what I'm experiencing. Router A cannot ping router F, but I can ping router F using router A as a gateway. Router A can establish a vpls tunnel to router F. There are some oddities that didn't present themself in 6.38.5 for me. I changed some path costs and made things stable, but if anything in the network changes it can resort to previous issues.

Yours appears to be in reverse where you're endpoints can't use them as a gateway.

I can make it do what you're doing, where I can't use it as a gateway but router A can ping F. But using A as my gateway I cannot ping F.
FWIW, our standard configuration in a Multi-Unit Dwelling (MUD) works something like this:

A location has a main router. That router has one bridge named LocalPorts, as well as a bridge for administration and for each subscriber:
/interface bridge add name=LocalPorts
/interface bridge add name=AdminBridge
/interface bridge add name=Sub1Bridge
/interface bridge add name=Sub2Bridge
etc.


A number of Ethernet ports on the router are assigned to the LocalPorts bridge:
/interface bridge port add bridge=LocalPorts interface=ether3
/interface bridge port add bridge=LocalPorts interface=ether4
etc.


An administrative VLAN, and one for each subscriber, is defined on the LocalPorts bridge
/interface vlan add name=AdminV100 vlan-id=100 interface=LocalPorts
/interface vlan add name=Sub1V201 vlan-id=201 interface=LocalPorts
/interface vlan add name=Sub2V202 vlan-id=202 interface=LocalPorts
etc.


Admin and subscriber VLANs are added to their respective bridges, along with any other interfaces that may be reserved for that purpose/subscriber:
/interface bridge port add bridge=AdminBridge interface=AdminV100
/interface bridge port add bridge=AdminBridge interface=ether1
/interface bridge port add bridge=Sub1Bridge interface=Sub1V201
/interface bridge port add bridge=Sub2Bridge interface=SubV202
/interface bridge port add bridge=Sub2Bridge interface=ether8
etc.


On the router, IP addresses are assigned to the admin and subscriber bridges:
/ip address add interface=AdminBridge address=10.10.1.1/24
/ip address add interface=Sub1Bridge address=192.168.1.1/28
/ ip address add interface=Sub2Bridge address=192.168.1.17/28
etc.


Now administration and each subscriber have their own subnets that are accessible on multiple Ethernet ports (e.g., multiple access points) via VLAN, along with zero or more dedicated local interfaces. Add DHCP servers etc. as needed.

So you can see why any significant change to how bridges and VLANs work is bound to affect us. And why whatever changed between 6.40.x and 6.41 may not be trivial to fix.

Specifically, when we upgrade, if we have a Dell 5324 switch connected to one of the LocalPorts, the switch stops responding on the Admin VLAN, and subscriber VLANs through the switch also stop working. If it's a Ubiquiti EdgeSwitch, it continues to work fine. I think it's odd that the same MT configuration that works with both switches under 6.40.x, works with one switch but not the other switch under 6.41.x. Eventually, unless I can figure out a workaround, we're going to have to replace all our Dell switches--and we're not very happy about that.
Principal, Engineering
Cape Ann Communications, Inc.
Gloucester, MA, USA
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.41.3 [current]

Thu Apr 05, 2018 11:43 am

I might sound like a big noob here now, but:

I just upgraded my DUDE server/Router from 6.35.4 to 6.41.3 and all of a sudden my WINBOX TOOL has disappeard from the right click tool menu???

Is this a bug just in my installation, or is it some reason for this?

A DUDE without WINBOX tool is kinda useless! :D
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8317
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.41.3 [current]

Thu Apr 05, 2018 11:48 am

Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.41.3 [current]

Thu Apr 05, 2018 2:36 pm

 
Filip92
just joined
Posts: 5
Joined: Fri Dec 30, 2016 6:28 pm

Re: v6.41.3 [current]

Thu Apr 05, 2018 6:59 pm

I am already tired of these problems with the routeros system. I have about 1000 clients with RB711 / SXT / DISC5 as CPE. After upgrading to version 6.41.3 there were problems with DHCP, with the "enable pppoe interface" function ...
Who will give my time and nerves? Who will calm up upset customers?
[admin@SXT_ROUTER_xxx] > interface pppoe-client set disabled=no 0
no such item (4)
[admin@SXT_ROUTER_xxx] > interface pppoe-client set disabled=no 0
[admin@SXT_ROUTER_xxx] > 
Now i must downgrade version from 6.41.3 to 6.40.7 (bugfix).....
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.41.3 [current]

Mon Apr 09, 2018 1:03 pm

Version 6.41.4 has been released in current channel:
viewtopic.php?f=21&t=132934

Who is online

Users browsing this forum: No registered users and 6 guests