Page 1 of 1

v6.40.7 [bugfix] is released!

Posted: Wed Apr 04, 2018 4:53 pm
by sergejs
To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device.


What's new in 6.40.7 (2018-Mar-29 13:29):

!) smb - fixed buffer overflow vulnerability, everyone using this feature is urged to upgrade;
*) console - do not allow variables that start with digit to be referenced without "$" sign;
*) led - fixed unused "link-act-led" LED trigger on RBLHG 2nD, RBLHG 2nD-XL and RBSXTsq 2nD;
*) netinstall - sign Netinstall executable with an Extended Validation Code Signing Certificate;
*) romon - make "secret" field sensitive in console;
*) tr069-client - fixed TR069 service becoming unavailable when related service package is not installed;
*) winbox - fixed "/tool e-mail send" attachment behavior;
*) winbox - fixed maximal ID for Traffic Generator stream;
*) winbox - made UDP local and remote TX size parameter optional in Bandwidth Test tool;
*) winbox - removed "Enable" and "Disable" buttons from IPsec "mode-config" list;
*) winbox - show "D" flag under "/ip dhcp-client" menu;
*) winbox - use proper graph name for HDD graphs;
*) wireless - enable all chains by default on devices without external antennas after configuration reset;

Please keep this forum topic strictly related to this concrete RouterOS release.

Re: v6.40.7 [bugfix] is released!

Posted: Wed Apr 04, 2018 7:45 pm
by jarda
all packages zip files are not available for download on the download page...

Re: v6.40.7 [bugfix] is released!

Posted: Wed Apr 04, 2018 8:18 pm
by GaToMaLaCo
all packages zip files are not available for download on the download page...
This one works:
https://download.mikrotik.com/routeros/6.40.7/routeros-mipsbe-6.40.7.npk

Re: v6.40.7 [bugfix] is released!

Posted: Wed Apr 04, 2018 10:39 pm
by jarda
It is not good idea to install combined package when you can individually select the packages you really need.

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 12:11 am
by GaToMaLaCo
It is not good idea to install combined package when you can individually select the packages you really need.
Indeed, this link still works:
https://download.mikrotik.com/routeros/6.40.7/all_packages-mipsbe-6.40.7.zip

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 12:33 am
by Spirch
the netinstall link on the download page doesnt work

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 9:24 am
by zBear
the netinstall link on the download page doesnt work

try changing https://www.mikrotik.com/routeros/6.40.7/... link to https://download.mikrotik.com/routeros/6.40.7/...

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 10:05 am
by djdrastic
Gonna test this in the lab , but big up to including that SMB fix in the bugfix releases.
Might be worth sending another mailing list email regarding this being put into bugfix.

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 12:38 pm
by upower3
!) smb - fixed buffer overflow vulnerability, everyone using this feature is urged to upgrade;
*) console - do not allow variables that start with digit to be referenced without "$" sign;
*) led - fixed unused "link-act-led" LED trigger on RBLHG 2nD, RBLHG 2nD-XL and RBSXTsq 2nD;
*) netinstall - sign Netinstall executable with an Extended Validation Code Signing Certificate;
*) romon - make "secret" field sensitive in console;
*) tr069-client - fixed TR069 service becoming unavailable when related service package is not installed;
*) winbox - fixed "/tool e-mail send" attachment behavior;
*) winbox - fixed maximal ID for Traffic Generator stream;
*) winbox - made UDP local and remote TX size parameter optional in Bandwidth Test tool;
*) winbox - removed "Enable" and "Disable" buttons from IPsec "mode-config" list;
*) winbox - show "D" flag under "/ip dhcp-client" menu;
*) winbox - use proper graph name for HDD graphs;
*) wireless - enable all chains by default on devices without external antennas after configuration reset;
Rare case when update isn't needed for most of users ) beside SMB, if any.

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 6:52 pm
by petterg
Seems like all 6.40.7 download links are dead on https://mikrotik.com/download

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 6:56 pm
by upower3
Seems like all 6.40.7 download links are dead on https://mikrotik.com/download
So to say, 6.40.7 download link is like: https://mikrotik.com/routeros/6.40.7/routeros-mipsbe-6.40.7.npk.
while 6.41.3 is https://download.mikrotik.com/routeros/6.41.3/routeros-mipsbe-6.41.3.npk.

See the difference? There is mikrotik.com vs download.mikrotik.com. Just add "download" in domain part!

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 8:46 pm
by jarda
This is just to say to mikrotik that their links on the download page do not work. Nothing else.

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 8:54 pm
by macsrwe
*) netinstall - sign Netinstall executable with an Extended Validation Code Signing Certificate;
Finally! Now the Dude, please!

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 8:59 pm
by msatter
If you add the sub-domain "download" in front of mikrotik.com it will download. For the ones that don't want to wait.

The bug-fix needs a link-fix. ;-)

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 05, 2018 9:05 pm
by upower3
If you add the sub-domain "download" in front of mikrotik.com it will download.
Nice addition, exactly the idea that was mentioned two answer up in this very thread :) Have you read the topic at all?
Looks like MT still update the page manually, isn't it?

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 06, 2018 1:33 pm
by normis
Looks like MT still update the page manually, isn't it?
no, but the download server was recently migrated to new location, so our upgrade scripts broke, sorry about that. We are fixing them

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 06, 2018 2:21 pm
by upower3
Looks like MT still update the page manually, isn't it?
no, but the download server was recently migrated to new location, so our upgrade scripts broke, sorry about that. We are fixing them
Links were ok today morning, and update from device itself worked fine even yesterday.

By the way, are there any stats on currect active ROS usage can be seen? Out of curriosity.

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 06, 2018 8:13 pm
by msatter
If you add the sub-domain "download" in front of mikrotik.com it will download.
Nice addition, exactly the idea that was mentioned two answer up in this very thread :) Have you read the topic at all?
The same to you. Did you read the posting, four postings above yours?

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 06, 2018 8:14 pm
by upower3
The same to you. Did you read the posting, four postings above yours?
So why did you repeated it twice? :)

Re: v6.40.7 [bugfix] is released!

Posted: Sat Apr 07, 2018 12:28 am
by Jotne
And no need need for quoting the post above, only if you pic some of it. It just clogs the forum..

Re: v6.40.7 [bugfix] is released!

Posted: Sat Apr 07, 2018 9:54 am
by venthyl
6.36.4 cpu snmp ok-> 6.40.6 no cpu snmp-> 6.40.7 no cpu snmp
x86
stil no cpu graphs catched by snmp librenms

Regards

Re: v6.40.7 [bugfix] is released!

Posted: Sat Apr 07, 2018 12:34 pm
by easyspot
Since long time ago i always use reset config n autorun file.rsc configurations. Its always working normally until 6.37.5. I skip 6.38.x. I got the problem in 6.39.3 n 6.40.6. Havent test 6.40.7 yet.
The problem is: only few first lines applied. The rest lines below skipped. This problem very annoying, make me must travel for 5 hours to remote location for reprogram mikrotik router. The file.rsc working normally when copy paste to winbox terminal. No error at all. Tested reset n autorun file.rsc with 6.37.5 n its working! No error! So i dont think the problem came from my file.rsc, but the new ros. Please fix it. Thanks.

Re: v6.40.7 [bugfix] is released!

Posted: Sat Apr 07, 2018 12:46 pm
by strods
venthyl - Which OID do you use for CPU load monitoring?
easyspot - Most likely the cause of your issue is described here - https://wiki.mikrotik.com/wiki/Manual:C ... rtup_delay

Re: v6.40.7 [bugfix] is released!

Posted: Sun Apr 08, 2018 4:28 am
by yhfung
The bug fixed version of v6.40.7 does not solve the poor performance of WiFi in hAP ac^2 router. The average speed of 5G ac WiFi is only 25Mbps.

viewtopic.php?f=7&t=132648&p=652859#p652859

Re: v6.40.7 [bugfix] is released!

Posted: Sun Apr 08, 2018 10:45 am
by venthyl
venthyl - Which OID do you use for CPU load monitoring?
easyspot - Most likely the cause of your issue is described here - https://wiki.mikrotik.com/wiki/Manual:C ... rtup_delay
system resource cpu print oid
all the same oid on 6.36.4, 6.40.x and 6.41.x

Libre nms has auto discovery ,
in libre log was info that cpu snmp was removed , i't looks like mikrotik no send cpu info in 6.40.x and 6.41.x


( added 6.36.4) 2018-03-12 12:20:02 System Processor added: type hr index 1 descr Processor

(updated 6.40.x and 6.41.x ) 2018-04-04 06:33:42 System Processor removed: type hr index 1 descr Processor

Regards

Re: v6.40.7 [bugfix] is released!

Posted: Mon Apr 09, 2018 6:59 am
by Spirch
i'm not knowledgeable enough but two weird thing happen to me

i have a hAP ac2 and cAP ac connected by lan, the hAP is the dhcp server

1. somehow creating a bridge on the cAP took over all the interface of the hAP, i lost internet and when connecting to the hAP ip address, i was in fact going to the cAP, removing the bridge on the cAP fixed it

2. doing a reboot on the cAP also rebooted the hAP (i wasnt expecting that)

Re: v6.40.7 [bugfix] is released!

Posted: Mon Apr 09, 2018 10:29 am
by mistry7
The bug fixed version of v6.40.7 does not solve the poor performance of WiFi in hAP ac^2 router. The average speed of 5G ac WiFi is only 25Mbps.

viewtopic.php?f=7&t=132648&p=652859#p652859
Take a look at the changelog, the fixes for ARM platform are only in 6.42 RC Versions

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 12, 2018 3:38 am
by Spirch
im not going to play with rc version or stable version but the h/cAP ac have a wireless issue for sure, i prefer to stick with bugfix for now so im not going to install the other one

i got a NAS connected to my hAP ac2 by LAN
my computer connected to the hAP ac2 by LAN
the cAP ac connected to the hAP ac2 by LAN
my phone (honor 8) connected to my cAP ac by WLAN 5g and/or 2.4g
my phone (honor 8) connected to my hAP ac2 by WLAN 5g and/or 2.4g

transferring a file to my computer from my nas reach the full 1gig (switch mode)
transferring a file to my phone with cAP ac 5g, about 0.5-3mbytes/sec
transferring a file to my phone with cAP ac 2.4g, about 1.5-4mbytes/sec
transferring a file to my phone with hAP ac2 5g, about 0.5-5mbytes/sec
transferring a file to my phone with hAP ac2 2.4g, about 0.25-3.5mbytes/sec

in all scenario, CPU on both device stick around 0-3%

the h/cAP ac is maybe 2.5 meters away (7-8 foot)

Re: v6.40.7 [bugfix] is released!

Posted: Thu Apr 12, 2018 9:59 pm
by pepek
Spirch: this is known problem, you can get much better results with current beta (6.42rc56), but still slow according to speeds you should get on 802.11ac
Much more info for example here: viewtopic.php?f=7&t=132648
Mikrotik is aware of this issue and is should be working on it

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 13, 2018 7:09 am
by strods
Everyone - We are working on improvements for ARM devices wireless performance within 6.42rc version. Such fixes/improvements can not be backported to older versions and will be included in RouterOS current versions only starting from 6.42 release.
venthyl - I just tested the same and it worked. Ran print OID command, took random OID from multicore system and this snmpget command worked just fine for me = "snmpget -v2c -c public 192.168.88.2 .1.3.6.1.2.1.25.3.3.1.2.32".
Spirch - Most likely you have, for example, DHCP servers on both devices which messes up addressing or something like that. I recommend that you send supout files to support@mikrotik.com. As for reboot - do you power hAP from cAP ac PoE out interface?

Re: v6.40.7 [bugfix] is released!

Posted: Fri Apr 13, 2018 8:45 am
by jarda
Good to read that. Thank you strods.

Re: v6.40.7 [bugfix] is released!

Posted: Sat Apr 14, 2018 4:55 am
by Spirch
Everyone - We are working on improvements for ARM devices wireless performance within 6.42rc version. Such fixes/improvements can not be backported to older versions and will be included in RouterOS current versions only starting from 6.42 release.
Spirch - Most likely you have, for example, DHCP servers on both devices which messes up addressing or something like that. I recommend that you send supout files to support@mikrotik.com. As for reboot - do you power hAP from cAP ac PoE out interface?
I will wait until 6.42 is under stable release to get it but i hope the bugfix release with the fix wont be too far away

for my first issue, i did a reset configuration with an empty configuration and i bridged all interface and created a proper dhcp-relay to the hAP and everything work fine now.


for the second one, the hAP is the main router and i used the poe injector to go from hAP -> cAP


thanks

Re: v6.40.7 [bugfix] is released!

Posted: Sun Apr 15, 2018 3:09 pm
by djdrastic
50+ Mikrotik Devices updated yesterday at one site and no issues (RB2011,SXT AC,951,WAP).
Only thing we saw in the logs , was some of techs configured DHCP Servers/Clients on incorrect interfaces on the bridges and the Mtk devices would tell you in clear English how to fix/address the issue.

Re: v6.40.7 [bugfix] is released!

Posted: Tue Apr 24, 2018 12:31 pm
by strods
Version 6.40.8 has been released in bugfix channel:
viewtopic.php?f=21&t=133585