Community discussions

 
lomayani
just joined
Posts: 18
Joined: Sat Jun 17, 2017 7:21 am

Re: v6.42.1 [current]

Thu May 10, 2018 7:46 pm

I have upgraded my core routers CCR1036-12G-4S. Am running mpls,ospf and bgp within these routers. One ccr keeps rebooting after like 15-20 minutes.
the rest are ok. the router which keep rebooting is acting head of mpls traffic engineering tunnel and is pushing traffic via this tunnel. On tail side am not pushing traffic via the tunnel. Upload from client is following the normal path chosen by ospf. these routers are not rebooting
I remember we used to have similar problem in this router before mikrotik fixed mpls relating issue last year
Other routers are working fine. Downgraded this router to 41.4 and it is stable now
I confirm this issue is fixed in 6.43rc11. I tested for couple of hours and am not seeing crashes
 
JimmyNyholm
Member Candidate
Member Candidate
Posts: 249
Joined: Mon Apr 25, 2016 2:16 am
Location: Sweden

Re: v6.42.1 [current]

Fri May 11, 2018 9:13 am

still waiting for the bugfix only update

This vulnerability isn't much of a problem. The problem is administrators leaving their firewall services (API, Winbox, SSH, etc.) exposed to untrusted networks. It's better to apply firewall filters to the input chain that will protect against this and other future attacks.
On a pure Router it is better to not enable the Firewall AT ALL and have Fastpath enabled still. IPRestrict IPSERVICES in their setting (Disable services that you will not use) and IPRESTRICT USERS login from in their setting. We don't need any firewall for that basic security.
 
User avatar
WirtelPL
newbie
Posts: 34
Joined: Sat Nov 11, 2017 11:22 am
Location: Poland

Re: v6.42.1 [current]

Fri May 11, 2018 12:07 pm

Returning to the increase of the parameter "Sector write since reboot" on 6.42.1, i have about 3k writes instead of about 700-800 on 6.43.rc3 after 12 hours uptime. Is it a bug or a feature?
RB951G-2HnD
I reported the problem to Mikrotik ([Ticket#2018042722002867]). In response I got:
"...Sector write value which shows NAND lifetime, but more precisely you can read in these articles: https://wiki.mikrotik.com/wiki/Manual:R ... bad_blocks, https://wiki.mikrotik.com/wiki/Manual:S ... Properties ..."

My actually values are:
You do not have the required permissions to view the files attached to this post.
RB951G-2HnD for home production
RBmAP2nD | RB952Ui-5ac2nD-TC for home lab
 
leon84
Member Candidate
Member Candidate
Posts: 172
Joined: Wed Dec 02, 2009 12:15 pm

Re: v6.42.1 [current]

Fri May 11, 2018 12:45 pm

Hi to all,
I updated RouterBoard 450 from 5.26 to 6.42.1 and now the routerboard doesn't boot. It reboot continously !
Can you help me?
Thanks
 
maxfava
Member Candidate
Member Candidate
Posts: 219
Joined: Mon Oct 17, 2005 12:30 am

Re: v6.42.1 [current]

Fri May 11, 2018 1:23 pm

With 6.42.1 we noted the following issues:
a) Marking assured and related packet as fast track, after a while some SIP client is not able to receive the calls even if seems registered. The connection tracking table has the entry of the UDP packet, and it receive from the server SIP the call but seems that router NAT does not forward to internal host. I have removed the fast track rule (action fast track for packets that are assured and related in filter rule) and it solves the issue.
b) But after the fast track firewall rule disabled the UDP connections with dst-port 5060 are not marked as sip connection-type but as general UDP stream, applying on connection tracking table 3 minutes timeout instead of 60 minutes. I have not rebooted yet, since is a production router, I have planned reboot this night, hope can solve.
 
TestCRS
just joined
Posts: 13
Joined: Mon Jan 22, 2018 4:49 pm

Re: v6.42.1 [current]

Fri May 11, 2018 4:47 pm

Please answer: switch crs317 dont forwards the qinq packets at wire-speed, why ?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8310
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.1 [current]

Fri May 11, 2018 4:59 pm

Please answer: switch crs317 dont forwards the qinq packets at wire-speed, why ?
How do you check it? Was it working at wire-speed in previous versions?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
rzirzi
Member
Member
Posts: 378
Joined: Mon Oct 09, 2006 2:33 pm

Re: v6.42.1 [current]

Fri May 11, 2018 7:52 pm

I think ROS 6.42.1 i VERY buggy version :( Many,many things not working or working randomly. For instance - next NOT working: Intel i350 miniPCIe cards at x86, working "randomly" Queues. Today I have had NOT working Simple Queues at one x86 machine. I was looking for a problem long time, and..... after disable and enable all Queues - they starded working again. VERY, very strange problems...with ROS 6.42.1
 
TestCRS
just joined
Posts: 13
Joined: Mon Jan 22, 2018 4:49 pm

Re: v6.42.1 [current]

Fri May 11, 2018 8:06 pm

Please answer: switch crs317 dont forwards the qinq packets at wire-speed, why ?
How do you check it? Was it working at wire-speed in previous versions?
You ask because you have such switch and everything works ? our switch crs317 never worked with qinq.
I will be glad to hear a confirmation that someone have working qinq on switch crs317.
But I think it is not.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5834
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.1 [current]

Fri May 11, 2018 8:50 pm

our switch crs317 never worked with qinq.
Then please don't discuss it in this topic!!! This topic is only for issues specific for 6.42.1
Open a new topic in another section and fully explain you problem and configuration.
 
TestCRS
just joined
Posts: 13
Joined: Mon Jan 22, 2018 4:49 pm

Re: v6.42.1 [current]

Sat May 12, 2018 6:42 pm

our switch crs317 never worked with qinq.
Then please don't discuss it in this topic!!! This topic is only for issues specific for 6.42.1
Open a new topic in another section and fully explain you problem and configuration.
viewtopic.php?f=1&t=134316#p661270
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.42.1 [current]

Sun May 13, 2018 3:06 pm

Just updated my RB2011UiAS-RM to 6.42.1
After updating and rebooting I go back and check for updates, it shows 6.42 instead of 6.42.1, this does not happen on any of my other routers.


Capture.PNG
I have same problem on a RB2011UAS-2HnD!
Whatever kind of upgrade of ROS if Current 6.42.1 or RC version, the RB just seems to ignore that there is an update package downloaded in files and reboots to 6.42.

Has any1 else had this problem, and/or solved this?

Its kinda frustrating not getting it updated now since there actually is a voulnarability!
 
maxfava
Member Candidate
Member Candidate
Posts: 219
Joined: Mon Oct 17, 2005 12:30 am

Re: v6.42.1 [current]

Sun May 13, 2018 3:43 pm

add more info
after playing with fast track and non fast track i confine i’m seeing the issue of packet marked sip and non sip wrongly.
After a reboot all work fine.

the issue we are seeing is the vpls interface associated to pppoe server are not listed. but i noted is going to be fixed since rc showing fixed dynamic interfaces
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 647
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.1 [current]

Mon May 14, 2018 12:11 am

13:31:55 system,info router rebooted
13:31:56 system,error,critical router rebooted because some critical program crashed
----------------------------------------------------------------------------------------------------------------------
3 causes after upgrade to 6.42.1 ( CCR1036-8G-2S+ with 60-70 OVPN tunnels)
26-th of April, 4-th of May, 10-th of May
I am also experiencing a flood of supouts from previously content CPEs (SXT, 911) since installing 6.42.1 on April 24. Two examples:
Screen Shot 2018-05-13 at 2.06.06 PM.jpg
Screen Shot 2018-05-13 at 2.06.43 PM.jpg
You do not have the required permissions to view the files attached to this post.
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 647
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.1 [current]

Mon May 14, 2018 12:19 am

I think ROS 6.42.1 i VERY buggy version :( Many,many things not working or working randomly. For instance - next NOT working: Intel i350 miniPCIe cards at x86, working "randomly" Queues. Today I have had NOT working Simple Queues at one x86 machine. I was looking for a problem long time, and..... after disable and enable all Queues - they starded working again. VERY, very strange problems...with ROS 6.42.1
Your report is believable, but the issue is not new to 6.42.1. For ten years I have been "solving" inexplicable queueing problems by exporting queues (both simple and tree), wiping out all queues, then reimporting. Someday I'm sure they will find this problem.
 
RN3QTB
newbie
Posts: 30
Joined: Mon Oct 03, 2016 9:43 am
Location: Russia

Re: v6.42.1 [current]

Mon May 14, 2018 11:41 am

Hello!
Help me please! After updating SXT 5nDr2 from version 6.40.8 to version 6.42.1, the router dies! I have to restore the firmware via netinstall! After restoring the firmware to the initial version 5.26, the update on the Internet is up to 6.40.8, the router reboots and offers to update to 6.42.1 current if you click "update" the router downloads the update, reboots and does not turn on again! Tried it 2 times. What to do?
 
MartijnVdS
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Wed Aug 13, 2014 9:36 am

Re: v6.42.1 [current]

Mon May 14, 2018 1:23 pm

Hello!
Help me please! After updating SXT 5nDr2 from version 6.40.8 to version 6.42.1, the router dies! I have to restore the firmware via netinstall! After restoring the firmware to the initial version 5.26, the update on the Internet is up to 6.40.8, the router reboots and offers to update to 6.42.1 current if you click "update" the router downloads the update, reboots and does not turn on again! Tried it 2 times. What to do?
Have you tried netinstalling 6.42.1?
 
akavousa
just joined
Posts: 2
Joined: Mon May 14, 2018 5:01 pm

Re: v6.42.1 [current]

Mon May 14, 2018 5:14 pm

All good after upgrade on RB435G.
Keep checking for hickups.
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Mon May 14, 2018 9:12 pm

Ive been testing 43RC11.. It addressed a huge number of issues posted in this thread. Good job Mikrotik.

It does not address the short sighted feature neutering of Netwatch tho. I still cannot send a alert or change a LED state based on a ping of a target. Because I use Netwatch for many things, I still cant use firmware past 41.5 because of this.

While im really impressed all the other bugs introduced in 42 have been so quickly addressed, I am upset Netwatch has not been addressed.
 
marcin21
Member Candidate
Member Candidate
Posts: 188
Joined: Tue May 04, 2010 4:50 pm

Re: v6.42.1 [current]

Mon May 14, 2018 11:16 pm

Image

wireleswire link ~150m, after upgrade rate/signal loss.
are there any options I should tweak after upg ?
You do not have the required permissions to view the files attached to this post.
 
mt99
newbie
Posts: 25
Joined: Wed Jan 03, 2018 6:07 pm

Re: v6.42.1 [current]

Tue May 15, 2018 2:07 am

Ive been testing 43RC11.. It addressed a huge number of issues posted in this thread. Good job Mikrotik.

It does not address the short sighted feature neutering of Netwatch tho. I still cannot send a alert or change a LED state based on a ping of a target. Because I use Netwatch for many things, I still cant use firmware past 41.5 because of this.

While im really impressed all the other bugs introduced in 42 have been so quickly addressed, I am upset Netwatch has not been addressed.
Mikrotik at the very least needs to explain what is and what isn't supported after 6.42 in their Netwatch documentation. It's not that much to ask. I got the sense that calling a script which requires certain permissions doesn't work anymore. But if you put the entire script in the Netwatch code block instead of simply calling the script, does that work? I haven't upgraded from 6.41.4 so haven't tested this. Apologies if you've already given this a try.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.1 [current]

Thu May 17, 2018 3:35 pm

Version 6.42.2 has been released in current channel:

viewtopic.php?f=21&t=134522
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.1 [current]

Thu May 31, 2018 9:49 am

Everyone who complained about the Netwatch issue - Please see this topic viewtopic.php?f=2&t=134538

Who is online

Users browsing this forum: No registered users and 12 guests