Community discussions

 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1154
Joined: Sat Dec 24, 2016 11:17 am
Location: Magrathean

Re: v6.42.1 [current]

Tue Apr 24, 2018 8:07 pm

My PC Bios is not 10 as in Windows 10
Our Cisco 3650 switches at work is on Hw version 3.56 and IOS-XE is on 16.3.5b
I can make a long list where hw is not in sync with os.
But the list for where it is in sync will be short.

As of know, it's confusing and extra reboot for nothing?
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
Pea
Member Candidate
Member Candidate
Posts: 190
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: v6.42.1 [current]

Tue Apr 24, 2018 8:13 pm

pe1chl: yes, this is clear.
The report about problem in this version is due to missing feedback in log after pressing the Upgrade button.
This "Firmware upgraded successfully, please reboot for changes to take effect!" did not appear in log. And this is unusual.
This information line was always there after pressing the button but this time was missing. That is all.
 
User avatar
doneware
Trainer
Trainer
Posts: 477
Joined: Mon Oct 08, 2012 8:39 pm
Location: Hungary

Re: v6.42.1 [current]

Tue Apr 24, 2018 10:26 pm

stumbled upon a strange stuff after upgrade.
[me@hgw2] > /log print follow-only 
21:20:46 ssh,error Corrupt host's key, regenerating it! Reboot required!
it happens when i'm trying to access the router from my freebsd box
debug1: Local version string SSH-2.0-OpenSSH_7.2 FreeBSD-20160310
debug1: Remote protocol version 2.0, remote software version ROSSSH
debug1: no match: ROSSSH
debug1: Authenticating to 192.168.1.1:222 as 'me'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: diffie-hellman-group-exchange-sha256
debug1: kex: host key algorithm: ssh-dss
debug1: kex: server->client cipher: aes192-ctr MAC: hmac-sha2-256 compression: none
debug1: kex: client->server cipher: aes192-ctr MAC: hmac-sha2-256 compression: none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(2048<8192<8192) sent
debug1: got SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
Received disconnect from 192.168.1.1 port 222:3: 
Disconnected from 192.168.1.1 port 222
whereas if i use my mac with a more recent SSH version, it just works. lucky me, otherwise i would be locked out.
debug1: Local version string SSH-2.0-OpenSSH_7.6
debug1: Remote protocol version 2.0, remote software version ROSSSH
debug1: no match: ROSSSH
debug1: Authenticating to 192.168.1.1:222 as 'me'
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: algorithm: diffie-hellman-group-exchange-sha256
debug1: kex: host key algorithm: ssh-rsa
debug1: kex: server->client cipher: aes192-ctr MAC: hmac-sha2-256 compression: none
debug1: kex: client->server cipher: aes192-ctr MAC: hmac-sha2-256 compression: none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(2048<8192<8192) sent
debug1: got SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: got SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: ssh-rsa SHA256:N3zKod3ejAr1GLrtPPxf0ySdhQpwSVh3qo1tIdf88zU
debug1: Host '[192.168.1.1]:222' is known and matches the RSA host key.
the routerOS ssh config is as follows:
[me@hgw2] > /ip ssh print 
           forwarding-enabled: no
  always-allow-password-login: yes
                strong-crypto: yes
                host-key-size: 2048
and no, reboot doesn't fixes the stuff, opposed to what the log message states.
#TR0359
 
Beone
Member Candidate
Member Candidate
Posts: 243
Joined: Fri Feb 11, 2011 1:11 pm

Re: v6.42.1 [current]

Tue Apr 24, 2018 11:57 pm

ARM upgrade from 6.42 to 6.42.1 will fail if another architecture package is also found on the flash... sometimes required to upgrade caps...

in the past it would upgrade correctly and just ignored the extra architecture packages. Is this a bug or just intentional now?

/system routerboard> /log print
22:41:35 system,info installed routeros-arm-6.42.1

/system resource print
uptime: 3m28s
version: 6.42 (stable)
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 646
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 12:27 am

ARM upgrade from 6.42 to 6.42.1 will fail if another architecture package is also found on the flash... sometimes required to upgrade caps...

in the past it would upgrade correctly and just ignored the extra architecture packages. Is this a bug or just intentional now?
I haven't worked with caps, but working with /system upgrade I learned that if you put npks in a subfolder, they will show up as "available" for other MikroTiks to fetch to upgrade themselves, but will not appear as available to upgrade the host MikroTIk on reboot, nor be consumed in doing so. Perhaps if you put your caps npks in a subfolder, this would solve your issue.
 
raymondr15
Member Candidate
Member Candidate
Posts: 118
Joined: Fri Sep 05, 2014 1:11 am
Location: East London, South Africa
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 2:01 am

Just updated my RB2011UiAS-RM to 6.42.1
After updating and rebooting I go back and check for updates, it shows 6.42 instead of 6.42.1, this does not happen on any of my other routers.

Capture.PNG
You do not have the required permissions to view the files attached to this post.
 
mt99
just joined
Posts: 24
Joined: Wed Jan 03, 2018 6:07 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:24 am

Just updated one of our Metal G-52SHPacn to new v6.42.1 RouterOS.

tools/netwatch does not work anymore. When the tested server is "up", we run [:global srvstat "up"] to set the variable srvstat. Did work with 6.41.2
Looks like up event is not working.
Version 6.42 has this changelog entry:
*) netwatch - limit to read, write, test and reboot policies for Netwatch script execution;
I guess that breaks your use case.
Yes, netwatch is no longer usable to start scripts. Even to write to global variables fails. Only write to .txt files works. On up event, I need to write the server status up to a variable or file and start a script.

Still did not find a solution for that use. A high interval schedule is no option.
I haven't installed 6.42.x yet but I use Netwatch to run scripts on all my devices. I use local variables in these scripts, will they no longer work after this update?
 
User avatar
hknet
Frequent Visitor
Frequent Visitor
Posts: 87
Joined: Sun Jul 17, 2016 6:05 pm
Location: Vienna, Austria
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:50 am

EoIP Ethernet Frame issue is still there (introduced in 6.42 breaking fragmenting big frames somehow broken) verified on RB2011 and sent supout to MT-support.
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 4:59 am

I wanted to follow up... Yes my Netwatch is not working.. This is really annoying as its sets up my DDNS. we need a 42.2 that fixes this..

Im not sure what happened last night, but, somehow none of my scripts would run from scheduler. I could run them manually. Its like scheduler somehow was not running, or did not have permissions to run scripts.. I always use 2 partitions and flipped back to 41.3 and all was well. Netwatch also worked of course.

I copied over 41.3, overwriting the 42.1.. Then switched to that.. All was well.. Then upgraded 41.3 to 42.1.. I lost Netwatch but gained back scheduler.

Ive gained a even weirder issue... I cant get around this...

/system leds> add leds=user-led type=on
input does not match any value of type

I can do off,,, but not on.. It seems to have lost on...
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 5:30 am

I can get on from Winbox,,, just not from command line or scripting..
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 646
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 7:46 am

Im not sure what happened last night, but, somehow none of my scripts would run from scheduler. I could run them manually. Its like scheduler somehow was not running, or did not have permissions to run scripts.. I always use 2 partitions and flipped back to 41.3 and all was well.
You know, I’ve been working with Support on an issue exactly like this. I have discovered that scheduler will often not start a script anymore if you just use the name of the script in the action, but if you say /system script run scriptname, it runs fine. Try that.
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 7:49 am

This change to Netwatch MUST BE REVERSED... Im REAALY UNHAPPY... I use this for a great many things. This change in what it can run seems, well, STUPID and POORLY THOUGHT OUT.. Mikrotik can't just take away features like that.

I cant even imagine a reason to do that.

Put this back ASAP or im gonna be REALLY VOCAL about this.

If your going to take away this big a feature that has been present in RouterOS for so many years at least provide a rationale for implimenting such a devastating reduction in functionality.
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 7:50 am

Im not sure what happened last night, but, somehow none of my scripts would run from scheduler. I could run them manually. Its like scheduler somehow was not running, or did not have permissions to run scripts.. I always use 2 partitions and flipped back to 41.3 and all was well.
You know, I’ve been working with Support on an issue exactly like this. I have discovered that scheduler will often not start a script anymore if you just use the name of the script in the action, but if you say /system script run scriptname, it runs fine. Try that.
I will... Thank you :)
 
bennyh
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Fri Mar 03, 2017 12:37 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 8:52 am

We have two 912UAG-5HPnD in bridged configuration. All of them was upgraded yesterday from 41.4. Until the upgrade, i could switch between nv2 and Nstreme protocol without problems (the Nstreme is faster but high packet losses, I always try after upgrades with Nstreme if there is any changes with packet losses, and then I switch back to NV2).
After upgrade, when I tried to switch to Nstreme on local AP, the webfig connection lost (local side, with UTP cable between AP and local router), and I could not ping from the router the local AP's IP address (the Layer2 connection seemed to be OK, there was Ethernet link, connected with 1GBps). After a power cycle and 5-10 minutes the network came back and the AP was reachable. I tried to switch back to NV2, but the AP connection was lost again, and I had to make a new power cycle, but the AP stayed at Nstreme. I had to revert to the backup config, and after reboot the AP switched back to NV2. It seem there is some problem with the bridge, the radio and the ethernet port is in same bridge. The IP address is connecting to unknown interface and i cannott change it to the bridge, the interface switchbox is empty at the address config page.

PS: After I loaded back the config backup again, now the adress is belong to the right bridge. Strange, maybe unsuccessful restore at first time or the Webfig is sick.
 
User avatar
astraliens
just joined
Posts: 11
Joined: Fri May 08, 2015 10:39 pm
Location: Deep Space
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 9:17 am

After upgrade to 6.42 (and the same after 6.42.1) found a problem with high sector writes values. More than 4000 writes for less than 24 hours.
Is it normal or not.
mikrotik_sector_writes.jpg
You do not have the required permissions to view the files attached to this post.
Somewhere but Nowhere
WebDev
 
Genkun
newbie
Posts: 33
Joined: Mon Jul 27, 2015 11:32 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 10:40 am

Got 2 separate issues. One is verified and can be duplicated. Other is still being investigated:

When there is a AP Bridge / Station(Station Bridge) with a RB433 on either the AP or Station in 802.11 the station will not connect Rx rates whatsoever.
This is true regardless of password, connect list or access list settings. This is also true for bridged or non-bridged setups.
Will supply supout when available for the above.

Second issue is a PowerBox with a CPE connected to it. Lose all connection to the CPE. Still investigating the cause as we need to get on site to see what is causing this issue. Also don't see anything in particular in forums for RB750 issue. Could be unrelated.
 
icsterm
just joined
Posts: 23
Joined: Sun Mar 11, 2018 11:11 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 11:45 am

RouterOS version 6.42.1 has been released in public "current" channel!

*) led - added "dark-mode" functionality for hAP ac and hAP ac^2 devices;

Still can't turn off the port led indicators in the hap ac2, winbox returns error that the board doesn't have this functionality.
 
User avatar
WirtelPL
newbie
Posts: 34
Joined: Sat Nov 11, 2017 11:22 am
Location: Poland

Re: v6.42.1 [current]

Wed Apr 25, 2018 11:51 am

Still can't turn off the port led indicators in the hap ac2, winbox returns error that the board doesn't have this functionality.

In mAP is the same. Is it possible to add such functionality also for this model?
RB951G-2HnD for home production
RBmAP2nD | RB952Ui-5ac2nD-TC for home lab
 
lomayani
just joined
Posts: 18
Joined: Sat Jun 17, 2017 7:21 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 12:31 pm

I have upgraded my core routers CCR1036-12G-4S. Am running mpls,ospf and bgp within these routers. One ccr keeps rebooting after like 15-20 minutes.
the rest are ok. the router which keep rebooting is acting head of mpls traffic engineering tunnel and is pushing traffic via this tunnel. On tail side am not pushing traffic via the tunnel. Upload from client is following the normal path chosen by ospf. these routers are not rebooting
I remember we used to have similar problem in this router before mikrotik fixed mpls relating issue last year
Other routers are working fine. Downgraded this router to 41.4 and it is stable now
 
vytuz
newbie
Posts: 26
Joined: Mon Jul 31, 2017 3:12 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 12:49 pm

improved compatibility with BCM chipset devices
Looks huge improvement for mobile devices. 2.4G speed increased from ~10-20Mbit to 2-3x more. We use as endpoint devices for consumers. 2.4G had poor perfomance if several devices use traffic, much more better now so far.
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 1:27 pm

Ive verified on 3 different models, with 6.42.1 I cannot turn on a LED from command line or script. I can turn it off however. I use the LED control to drive a relay to control power to another device. So this functionality is important to me. Its more then just a LED to me. Completely repeatable on any model of router I have tried.

add led=sfp-led type=on
input does not match any value of type
 
Kraken2k
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Oct 01, 2014 1:50 pm
Location: Prague

Re: v6.42.1 [current]

Wed Apr 25, 2018 2:43 pm

Just a small thing: when you change Comment of an item, it is really necessary to "disable and enable" ("device changed" message is logged) the commented item? For example when I change comment to IPsec policy or wireless interface, it gets restarted which is annoying, because clients will disconnect. For other settings I can understand it, but comment should not affect any item settings, right?
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 640
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 2:59 pm

After upgrade to 6.42 (and the same after 6.42.1) found a problem with high sector writes values. More than 4000 writes for less than 24 hours.
Is it normal or not.
mikrotik_sector_writes.jpg
I have same issue on RB951Ui-2HnD (with ROS 6.42.1 upgraded just today). I can imagine there are writes if you are using it a lot (you have over 2M writes total so obviously writes are happening a lot). However, my total is 30k for whole lifetime and I own this device over 5 years. Something definitely must be wrong:
2018-04-25_2138.png
I noticed there are random writes each 1-2 minutes. after enabling debug log, some of these writes corresponds with "skip Router Advertisement sending on XXXX: no prefixes to send" (where XXXX is bridge / eth). Some writes appear without any log entry - cant figure out...

my whole "/export" config is following:
# apr/25/2018 21:22:42 by RouterOS 6.42.1
# software id = 0HA0-YFNN
#
# model = 951Ui-2HnD
# serial number = 4AC7024C3DBE
/interface bridge
add fast-forward=no name=bridge1
/interface wireless
set [ find default-name=wlan1 ] ssid=MikroTik
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=ether2
add bridge=bridge1 interface=ether3
add bridge=bridge1 interface=ether4
add bridge=bridge1 interface=ether5
/ip dhcp-client
add dhcp-options=hostname,clientid disabled=no interface=bridge1
/system clock
set time-zone-name=Australia/Hobart
/system logging
add topics=debug
/system routerboard settings
set silent-boot=no
/tool romon
set enabled=yes

edit: In addition I noticed missing "switch" menu in winbox connected to hAP ac^2 (last update added this menu to cAP, not quite sure why not hAP ac^2)

edit2: Just checked one another RB951 and noticed it has same issue with older ROS:
2018-04-25_2211.png
This one was AP in busy restaurant for over 2 years. Then about 5 month ago upgraded and deployed elsewhere ... Since deployment the ROS is same, so if last 18 days caused 70k writes, then it means those 660k writes would happen during approximately 5.6 month ... what a coincidence :( This makes me believe that increased writes are happening since earlier ROS.

edit3: I believe I found culprit! default setting now enables "cloud - update time". so in default setting, mikrotik is sending request to cloud.mikrotik.com (seems unsuccessfully) and that is causing useless memory writes! (actually i noticed that those queries often fail so it is better to enable SNTP client)
edit4: nope. requests to cloud are just part of those writes. writing rate decreased significantly but it is still happening (around 3k within last 9 hours)
You do not have the required permissions to view the files attached to this post.
Last edited by vecernik87 on Thu Apr 26, 2018 12:41 am, edited 4 times in total.
 
User avatar
nichky
Long time Member
Long time Member
Posts: 506
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:20 pm

How can i check which interface support fast-path on 6.42.

Like on previous versions, i was getting that kind info from

interface pr detail fast-path=yes/no ................. "What about on 6.42? how can i check?
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
vytuz
newbie
Posts: 26
Joined: Mon Jul 31, 2017 3:12 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:21 pm

add led=sfp-led type=on
input does not match any value of type
Confirm, that type=on is not recognisable( 4 changed via winbox to type - on):
/system leds> print
Flags: X - disabled, * - default
# TYPE INTERFACE
0 * interface-activity ether1
1 * interface-activity ether2
2 * interface-activity ether3
3 * interface-activity ether4
4 * (unknown)

Second question: we use custom startup script(easy modified), earlier QuickSet showed Dual Home AP mode, now it detects WISP AP mode and only one 5G wifi in QuickSet. I understand QuickSet is used rarely, but sometimes it is useful. Just question, how QuickSet identifies work mode? Totaly same exported scripts when QuickSet selected Home AP Dual and WISP AP.
It could be usefull option to disable QuickSet somewere at all. Just add option QuickSet=1 or 0. User can control by script if there are several bridges or specific firewall, QuickSet could be disabled.
 
rkadmins
just joined
Posts: 1
Joined: Wed Apr 25, 2018 3:35 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:42 pm

in the winbox, BRIDGE section is showing NOTHING in PORTS section.

If you select Detail Mode - ports are showing.

Winbox - last verstion, RouterOS 6.42.1 .
On the 6.42 version everything was ok.

Any ideas???
 
deadmaus911
just joined
Posts: 1
Joined: Wed Apr 25, 2018 3:47 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:52 pm

When I just open and immediately close without saving the quick settings, the configuration on the device changes. hap ac^2
 
pe1chl
Forum Guru
Forum Guru
Posts: 5369
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 3:58 pm

in the winbox, BRIDGE section is showing NOTHING in PORTS section.
I reported that before and the report was acknowledged and they are investigating.
 
atlanticd
newbie
Posts: 29
Joined: Thu Jun 11, 2015 6:42 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 4:06 pm

I'm not sure if this issue happened after upgrading to v6.42.1, but on my hAP ac^2 the write-sect-since-reboot and the write-sect-total is missing in Winbox v3.13 / System Resources screen. /system resource print shows the values. Routerboard firmware is v6.42.1
 
cmwv6
just joined
Posts: 2
Joined: Wed Apr 25, 2018 4:14 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 4:21 pm

Hello,

I upgrade to v 6.42.1 SXT 5 ac, but not work > BRIDGE > Filter, until v6.41.3 is working well .
/interface bridge filter

Please FIX this bug.

Thank so much
 
User avatar
Xymox
Member
Member
Posts: 387
Joined: Thu Jan 21, 2010 5:04 pm
Location: Phoenix, Arizona US
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 5:23 pm

I assume someone is keeping track of this epic list of serious faults with a production "stable" release ?

Does Mikrotik have any bug tracker web URL ?

I have a suggestion, apply the security patch to 6.41.3 and lets roll back to 6.41 and skip 6.42.. There are really serious issues covered and confined in this thread, its time to take a serious stand and get things fixed.

Ive been doing Mikrotik a LONG time and ive never seen a mess like this. Normally even the Release Candidates are way more stable then this.

Im also really unhappy they took away the ability to use netwatch to monitor things and send a email alert.. This loss of functionality is honestly unfathomable. I want a official response here on the forum please.
 
User avatar
GaToMaLaCo
just joined
Posts: 8
Joined: Fri Jan 10, 2014 2:13 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:05 pm


edit3: I believe I found culprit! default setting now enables "cloud - update time". so in default setting, mikrotik is sending request to cloud.mikrotik.com (seems unsuccessfully) and that is causing useless memory writes! (actually i noticed that those queries often fail so it is better to enable SNTP client)

You mean if you set the SNTP client to a NTP server then "Cloud update-time" must be set to "YES" ?
 
mkx
Forum Guru
Forum Guru
Posts: 2482
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:11 pm

@bennyh: I assume that you have RB's IP address set on bridge. Do you have admin-mac statically set and auto-mac=no?
If not, bridge will assume mac address from one of member interfaces and if that member interface (momentarily) drops from bridge (I can imagine that happening when you change properties of wifi device), anything can happen.
BR,
Metod
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:14 pm

Do not update the time from cloud. Use reliable time server instead.
 
xbipin
just joined
Posts: 6
Joined: Mon Aug 07, 2017 5:22 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:22 pm

tried it on metal 52ac international and wireless became almost useless on 24ghz and clients dropping every few mins, reverted to 6.41.4

not to mention still waiting for the day when ill be able to see current tx power table as well be able to set tx power mode to card rates or manual
Last edited by xbipin on Wed Apr 25, 2018 6:22 pm, edited 1 time in total.
 
User avatar
GaToMaLaCo
just joined
Posts: 8
Joined: Fri Jan 10, 2014 2:13 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:22 pm

Do not update the time from cloud. Use reliable time server instead.
So "Cloud update-time" must be set to "No" right?
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 6:43 pm

I checked this on all our routers upgraded to 6.42 or 6.41 ...
And In ROS 6.41 and 6.42 Mikrotik Neighbor Discovery protocol outgoing traffic is actually allowed to bypass firewall altogether and cannot be caught in any chain, not something that any process should be IMHO ...
And for me this is actually pretty serious issue because I used firewall (as I should with any outgoing traffic) to control this on all of our routers ...
Not related to Winbox security issue, but seems like a bug ...
On 6.41.x and 6.42.x MNDP trafic is not visible anymore in firewall output chain ...
For example I am using this rules
/ip firewall raw> print 
Flags: X - disabled, I - invalid, D - dynamic
 0    chain=output action=passthrough log=yes log-prefix="" protocol=udp
 1    ;;; MT discovery
      chain=prerouting action=notrack dst-port=5678 log=no log-prefix="" protocol=udp dst-address=255.255.255.255 
 2    ;;; MT discovery
      chain=output action=notrack dst-port=5678 log=no log-prefix="" protocol=udp dst-address=255.255.255.255 
And on 6.40.x it works as expected
print stats
Flags: X - disabled, I - invalid, D - dynamic 
 #    CHAIN                                                                                                                                                                                         ACTION                            BYTES         PACKETS
 0  D ;;; special dummy rule to show fasttrack counters
      prerouting                                                                                                                                                                                    passthrough                  55 903 342         279 167
 1    prerouting                                                                                                                                                                                    notrack                         295 008           2 176
 2    output                                                                                                                                                                                        notrack                          25 870             195
 
But on 6.41.x and 6.42.x no packet is ever detected in output chain
 print stats
Flags: X - disabled, I - invalid, D - dynamic 
 #    CHAIN                                                                                                                                                                                         ACTION                            BYTES         PACKETS
 0    output                                                                                                                                                                                        passthrough                     226 965           1 663
 1    ;;; MT discovery
      prerouting                                                                                                                                                                                    notrack                          99 706             724
 2    ;;; MT discovery
      output                                                                                                                                                                                        notrack                               0               0
So is this some undocumented new feature and if so what is the benefit, or is it just a bug?

Regards
 
User avatar
WirtelPL
newbie
Posts: 34
Joined: Sat Nov 11, 2017 11:22 am
Location: Poland

Re: v6.42.1 [current]

Wed Apr 25, 2018 7:48 pm

After upgrade to 6.42 (and the same after 6.42.1) found a problem with high sector writes values. More than 4000 writes for less than 24 hours.
Is it normal or not.
I have too high write value. What is this and how to diagnose it ?
You do not have the required permissions to view the files attached to this post.
RB951G-2HnD for home production
RBmAP2nD | RB952Ui-5ac2nD-TC for home lab
 
msatter
Forum Guru
Forum Guru
Posts: 1120
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.42.1 [current]

Wed Apr 25, 2018 8:18 pm

I checked this on all our routers upgraded to 6.42 or 6.41 ...
And In ROS 6.41 and 6.42 Mikrotik Neighbor Discovery protocol outgoing traffic is actually allowed to bypass firewall altogether and cannot be caught in any chain, not something that any process should be IMHO ...
And for me this is actually pretty serious issue because I used firewall (as I should with any outgoing traffic) to control this on all of our routers ...
Not related to Winbox security issue, but seems like a bug ...
On 6.41.x and 6.42.x MNDP trafic is not visible anymore in firewall output chain ...
For example I am using this rules
/ip firewall raw> print 
Flags: X - disabled, I - invalid, D - dynamic
 0    chain=output action=passthrough log=yes log-prefix="" protocol=udp
 1    ;;; MT discovery
      chain=prerouting action=notrack dst-port=5678 log=no log-prefix="" protocol=udp dst-address=255.255.255.255 
 2    ;;; MT discovery
      chain=output action=notrack dst-port=5678 log=no log-prefix="" protocol=udp dst-address=255.255.255.255 
And on 6.40.x it works as expected
print stats
Flags: X - disabled, I - invalid, D - dynamic 
 #    CHAIN                                                                                                                                                                                         ACTION                            BYTES         PACKETS
 0  D ;;; special dummy rule to show fasttrack counters
      prerouting                                                                                                                                                                                    passthrough                  55 903 342         279 167
 1    prerouting                                                                                                                                                                                    notrack                         295 008           2 176
 2    output                                                                                                                                                                                        notrack                          25 870             195
 
But on 6.41.x and 6.42.x no packet is ever detected in output chain
 print stats
Flags: X - disabled, I - invalid, D - dynamic 
 #    CHAIN                                                                                                                                                                                         ACTION                            BYTES         PACKETS
 0    output                                                                                                                                                                                        passthrough                     226 965           1 663
 1    ;;; MT discovery
      prerouting                                                                                                                                                                                    notrack                          99 706             724
 2    ;;; MT discovery
      output                                                                                                                                                                                        notrack                               0               0
So is this some undocumented new feature and if so what is the benefit, or is it just a bug?

Regards
It was discussed in a closed thread:

viewtopic.php?f=21&t=133533&start=150#p656843

It seem to be feature.
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.8
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
User avatar
Fangcz
just joined
Posts: 2
Joined: Sun Jan 07, 2018 11:28 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 8:19 pm

Having same issue with alot sector writes but here is catch - I've tried solution mentioned by vecernik87 but simply IP > Cloud setting is not there on x86 or am I missing something here?
x86_sector_writes.PNG
You do not have the required permissions to view the files attached to this post.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 735
Joined: Mon May 14, 2012 9:30 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 8:25 pm

Updated a CRS125 to 6.42.1.

Broke a few things.
Bridge changed.
Arp disabled
DHCP server moved to wrong interface.
etc
etc

Took a bit... but got it back on line.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
pe1chl
Forum Guru
Forum Guru
Posts: 5369
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 8:32 pm

I know that updating from 6.40 or below to 6.41 automatically reconfigures the ethernet master-port config to a bridge with ports and hw accel on.
Could it be that this upgrading support has been dropped from 6.42? When I upgraded a router from an older release (I think 6.39.2) immediately to 6.42.1 the master port config was deleted but it wasn't converted to a bridge, I had to do that manually.
 
coylh
Member Candidate
Member Candidate
Posts: 160
Joined: Tue Jul 12, 2011 12:11 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 10:01 pm

I'm seeing two things:

1. ssh keys are being regenerated as part of the upgrade.
2. Looks like netwatch is gone. Was this planned, or part of vulnerability mitigation?
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 646
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.1 [current]

Wed Apr 25, 2018 10:20 pm

Im not sure what happened last night, but, somehow none of my scripts would run from scheduler. I could run them manually. Its like scheduler somehow was not running, or did not have permissions to run scripts.. I always use 2 partitions and flipped back to 41.3 and all was well.
You know, I’ve been working with Support on an issue exactly like this. I have discovered that scheduler will often not start a script anymore if you just use the name of the script in the action, but if you say /system script run scriptname, it runs fine. Try that.
I will... Thank you :)
Let us know if this works for you. Support is still nonplussed, and it never hurts to make them aware that multiple people are seeing the same problem.
 
ac6529
just joined
Posts: 4
Joined: Sun Apr 30, 2017 9:22 am

Re: v6.42.1 [current]

Wed Apr 25, 2018 10:36 pm

6.42.1 has caused a noticeable bump in disk usage on CCR1009-7G-1C.
Is that normal (expected?)
ros_s.png
You do not have the required permissions to view the files attached to this post.
 
rzz
just joined
Posts: 1
Joined: Wed Apr 25, 2018 11:11 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 11:17 pm

Upgraded to 6.42.1 and for some reason almost all switch ports were removed from bridges (luckily admin. bridge remained w. 1 port attached so I regained access to the router).
Device is RB2011iL-IN.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5369
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.1 [current]

Wed Apr 25, 2018 11:41 pm

Upgraded to 6.42.1 and for some reason almost all switch ports were removed from bridges (luckily admin. bridge remained w. 1 port attached so I regained access to the router).
Device is RB2011iL-IN.
Did you upgrade from a pre-6.40 version? The you may be seeing the same thing as I mentioned in message #93 above. Like you, I was lucky I could recover the router.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 640
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.42.1 [current]

Thu Apr 26, 2018 1:02 am

Having same issue with alot sector writes but here is catch - I've tried solution mentioned by vecernik87 but simply IP > Cloud setting is not there on x86 or am I missing something here?
x86_sector_writes.PNG
Hi,
Not quite sure why you dont see it. I believe it should be accessible through console as well:
# to see what is currently set
/ip cloud print  
# to disable update time from mikrotik cloud
/ip cloud set update-time=no
today morning i checked my both RB951. On both, write-rate decreased a bit (but still many times higher than pre-update)
Before i disabled update-time, first router was showing around 1000 writes per hour and second was showing 161 writes per hour.
Currently, one shows about 300 writes per hour and second shows 50 writes per hour.

I am well aware that according to viewtopic.php?t=128904#p634198 , this write rate is not going to cause any issues, however, I have to wonder why there is such increase after update. Both those RB were in use for several years without any significant writes while using some older ROS. After I took care of both and upgraded them, suddenly, they need to write so much...

Do not update the time from cloud. Use reliable time server instead.
Sure thing :) trick is, that not everyone knows about this feature and it is by default enabled (even after reset config with no-defaults). Everyone has to manually disable this.

I'm not sure if this issue happened after upgrading to v6.42.1, but on my hAP ac^2 the write-sect-since-reboot and the write-sect-total is missing in Winbox v3.13 / System Resources screen. /system resource print shows the values. Routerboard firmware is v6.42.1
I can confirm that it is not visible on 6.42 as well. Unfortunately I don't have any of my devices on older ROS so I can't check right now if it was missing earlier.
Also, the switch menu is not visible for hAP ac^2


I can see plenty of "bugreports" in this topic. Is there some summary or are we expected to report each of them to support@mikrotik ? Obviously, same bug will get reported many times by multiple people.
 
r00t
Member Candidate
Member Candidate
Posts: 140
Joined: Tue Nov 28, 2017 2:14 am

Re: v6.42.1 [current]

Thu Apr 26, 2018 1:43 am

6.42.1 has caused a noticeable bump in disk usage on CCR1009-7G-1C.
Is that normal (expected?)
Can see the same on RB600, big jump in disk usage:
weekly.gif
Used automatic download from packages in Winbox to update it.
You do not have the required permissions to view the files attached to this post.
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.42.1 [current]

Thu Apr 26, 2018 4:05 am


edit3: I believe I found culprit! default setting now enables "cloud - update time". so in default setting, mikrotik is sending request to cloud.mikrotik.com (seems unsuccessfully) and that is causing useless memory writes! (actually i noticed that those queries often fail so it is better to enable SNTP client)

You mean if you set the SNTP client to a NTP server then "Cloud update-time" must be set to "YES" ?
Nice one that is the source of rewrites! Thank you

Who is online

Users browsing this forum: No registered users and 1 guest