Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.42.3 [current]

Fri May 25, 2018 10:24 am

RouterOS version 6.42.3 has been released in public "current" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.42.3 (2018-May-24 09:20):

*) lte - fixed automatic LTE band selection for R11e-LTE;
*) wireless - improved client "channel-width" detection;
*) wireless - improved Nv2 PtMP performance;
*) wireless - increased stability on hAP ac^2 and cAP ac with legacy data rates;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
 
lomayani
just joined
Posts: 18
Joined: Sat Jun 17, 2017 7:21 am

Re: v6.42.3 [current]

Fri May 25, 2018 12:29 pm

I have started testing this version. So far the issue of one client having high download causing slowness to other clients has been resolved. Mikrotik great and good work on this. We are going somewhere now

One question is dynamic downlink ratio behaviour changed? In 6.42.2 with ratio of 60% ap can shoot to 90-100mbps download speed to a client but now in 6.42.3 I can only shoot to around 60-70mbps. I changed the ratio to 70% in 6.42.3, I can see the same results as 6.42.2(with 60% ratio) but with better sharing between clients than previous versions
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: v6.42.3 [current]

Fri May 25, 2018 1:19 pm

No issues on my network 15 devices. Thanks for the update!
 
joserudi
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Thu Nov 22, 2007 10:16 pm

Re: v6.42.3 [current]

Fri May 25, 2018 1:38 pm

Good morning, I wanted to know if there are improvements regarding version 6.42 where the same was announced or there are improvements in this regard:

Release 6.42

*) wireless - improved Nv2 PtMP performance;
 
joserudi
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Thu Nov 22, 2007 10:16 pm

Re: v6.42.3 [current]

Fri May 25, 2018 1:41 pm

I have started testing this version. So far the issue of one client having high download causing slowness to other clients has been resolved. Mikrotik great and good work on this. We are going somewhere now

One question is dynamic downlink ratio behaviour changed? In 6.42.2 with ratio of 60% ap can shoot to 90-100mbps download speed to a client but now in 6.42.3 I can only shoot to around 60-70mbps. I changed the ratio to 70% in 6.42.3, I can see the same results as 6.42.2(with 60% ratio) but with better sharing between clients than previous versions

Dear friend, I have been testing with dynamic downlink ratio and I have not noticed any difference in altering this value. Do you really notice difference in leaving it at 50%? Thank you
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.3 [current]

Fri May 25, 2018 2:32 pm

I'll repeat my question here:

I have a ccr1009 with flash partitioned into 2 partitions. So each of that flash parts are of 32 Mb, which was ok for me so far.

After recent upgrade to 6.42.1 I found all of my flash almost taken by unknown (invisible) files or data. Right now I have only 10 Mb of flash and the upgrade to 6.42.2 needs ~15Mb. I asked this in different topic and got viewtopic.php?f=2&t=134713&p=663589#p663890 this answer saying I'm not along with the problem, so looks like 6.42.1 upgrade script won't do its job well, or something. Not sure is this can be more widespread or not, and surely don't know if this can happen to any new version.

What should I do? The device is on remote location so it's not an option to netinstall it. So far I can not upgrade to any new version.

How can I clean up these extra files/data? If I format the flash then the device won't boot afterwards, isn't it?
 
MartijnVdS
Frequent Visitor
Frequent Visitor
Posts: 93
Joined: Wed Aug 13, 2014 9:36 am

Re: v6.42.3 [current]

Fri May 25, 2018 3:36 pm

What should I do? The device is on remote location so it's not an option to netinstall it. So far I can not upgrade to any new version.

How can I clean up these extra files/data? If I format the flash then the device won't boot afterwards, isn't it?
I can't guarantee that this'll work for you, but it worked for me (try at your own risk, and try on some local devices first):
  • Download the "all packages" zip for your device's architecture from the Mikrotik website
  • Extract the .npk files you need (at least "system", and additionally wireless, mpls, etc.). You only the ones that are currently enabled on the device and/or that you are using features from (for instance, you don't need to get the "dhcp" one if you don't have a DHCP server or client on the device).
  • Upload those NPK files to the router
  • Reboot
On my devices, this replaced the big "bundle" system package (which contains ppp, dhcp, mpls, routing, etc.) with the smaller "unbundled" one (which only contains "system", the other packages are separated out), and it also upgraded the other packages and their configuration.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8290
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.3 [current]

Fri May 25, 2018 3:43 pm

I would try to repartition it to 1 partition, upgrade and repartition back to 2 partitions. But:
1. Don't forget about backup.
2. Make sure that new version does not leak free space :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Kindis
Member Candidate
Member Candidate
Posts: 244
Joined: Tue Nov 01, 2011 6:54 pm

Re: v6.42.3 [current]

Fri May 25, 2018 3:44 pm

Upgrades two CHR (running on Hyper-V), two 3011, one 493G and 2 wAP AC without any issues.
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.3 [current]

Fri May 25, 2018 3:48 pm

I can't guarantee that this'll work for you, but it worked for me (try at your own risk, and try on some local devices first):
Frankly this was my plan, too, but once I did that and out of sudden cleared the device config (don't know the reason why) so it was a bit... bad idea.

And also will this clear up invisible files? Looks like no, it'll just fit the new ROS into tiny 10 Mb space I still have.

Will format flash erases the boot OS files, it ROS loads not from accessible (and formatable) flash?

P.S. Is the upgrade code messes up and won't remove the temp files afterward?
 
timoid
newbie
Posts: 36
Joined: Tue Jan 01, 2008 8:20 am

Re: v6.42.3 [current]

Fri May 25, 2018 4:43 pm

Anyone know more about this:
*) tile - fixed Ethernet interfaces becoming unresponsive;
 
MEV
just joined
Posts: 2
Joined: Thu May 24, 2018 10:39 pm

Re: v6.42.3 [current]

Fri May 25, 2018 6:03 pm

I have 2 locations. Location A and location B.

From A to B working EoIP tunnel.

In tunnel going multicast traffic in direction from A to B.

On side "B" I do EoIP tunnel disable, it show like not active.
Multicast flow stop on side "B", but income traffic on my WAN port
on side "B" is still going.

Why so, if EoIP tunnel not active and no connection through EoIP?

Traffic on side "B" on WAN port stop going only if I disable EoIP tunnel on
source side "A".
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5909
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.42.3 [current]

Fri May 25, 2018 6:07 pm

Is EoIP active on router A (meaning that you have disabled keepalive) ?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8290
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.3 [current]

Fri May 25, 2018 6:08 pm

I have 2 locations. Location A and location B.

From A to B working EoIP tunnel.

In tunnel going multicast traffic in direction from A to B.

On side "B" I do EoIP tunnel disable, it show like not active.
Multicast flow stop on side "B", but income traffic on my WAN port
on side "B" is still going.

Why so, if EoIP tunnel not active and no connection through EoIP?

Traffic on side "B" on WAN port stop going only if I disable EoIP tunnel on
source side "A".
If you don't have 'Keepalive' enabled, side A doesn't know that the tunnel is disabled on side B, so it keeps sending packets.

TL;DR: Enable Keepalive on EoIP tunnel

P.S. And create separate topic for your question if it's not specific to RouterOS 6.42.3
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.3 [current]

Fri May 25, 2018 6:11 pm

I would try to repartition it to 1 partition, upgrade and repartition back to 2 partitions. But:
1. Don't forget about backup.
2. Make sure that new version does not leak free space :)
The only thing I need is some confirmation from someone wise that repartition won't crear up whole disk so ROS won't be able to load.
I will do the backup but it is useless as device is on remote place. And the leakage is something that should be commented by Mikrotik engineers I think :)
Last edited by upower3 on Fri May 25, 2018 8:33 pm, edited 1 time in total.
 
User avatar
TomjNorthIdaho
Forum Veteran
Forum Veteran
Posts: 979
Joined: Mon Oct 04, 2010 11:25 pm
Location: North Idaho
Contact:

Re: v6.42.3 [current]

Fri May 25, 2018 6:55 pm

I have started testing this version. So far the issue of one client having high download causing slowness to other clients has been resolved. Mikrotik great and good work on this. We are going somewhere now

One question is dynamic downlink ratio behaviour changed? In 6.42.2 with ratio of 60% ap can shoot to 90-100mbps download speed to a client but now in 6.42.3 I can only shoot to around 60-70mbps. I changed the ratio to 70% in 6.42.3, I can see the same results as 6.42.2(with 60% ratio) but with better sharing between clients than previous versions

Dear friend, I have been testing with dynamic downlink ratio and I have not noticed any difference in altering this value. Do you really notice difference in leaving it at 50%? Thank you
You most notice the dynamic downlink radio settings is really doing something when your APs are getting close to client throughput saturation (such as peak hours when everybody is doing something). Under light throughput loads (non-peak usage periods), you should not normally see much of a difference.

I normally use a setting of 75 or 80 percent on all of my APs. This mostly helps when everybody is doing something where you want near 80 percent of traffic to be from Internet to clients. A setting of 20 percent kills client download speeds during peak usage but boosts the 1 percent of clients who are uploading.
 
User avatar
payday
Member Candidate
Member Candidate
Posts: 233
Joined: Thu Aug 16, 2012 11:05 pm

Re: v6.42.3 [current]

Fri May 25, 2018 11:32 pm

My terminal doesn't work in Webfig. It shows just an empty space.
Can you please check if it is me only or you also have that problem?
 
Mackiavelly
just joined
Posts: 12
Joined: Wed Aug 31, 2016 12:59 am

Re: v6.42.3 [current]

Fri May 25, 2018 11:46 pm

if
/interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes
then have promlems:
1. dont work simple queues (upload)
2. and then other mikrotik connect to this mikrotik by pppoe then have 0.1 mbit/s download speed, and unlocked speed upload (promlem 1)

if
/interface bridge settings set use-ip-firewall=no
all ok
 
SnakeSK
just joined
Posts: 16
Joined: Fri Mar 09, 2018 1:30 am

Re: v6.42.3 [current]

Fri May 25, 2018 11:48 pm

Still no fix for chr hyperv?
 
joserudi
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Thu Nov 22, 2007 10:16 pm

Re: v6.42.3 [current]

Fri May 25, 2018 11:53 pm

With nv2 and the new update we get 96 mbps per sector with 15 users and good signal. Great news

Now we need to improve in nv2 ptp since we can not get past those 100 mbps in ptp mode as well.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.42.3 [current]

Sat May 26, 2018 12:31 am

My terminal doesn't work in Webfig. It shows just an empty space.
Can you please check if it is me only or you also have that problem?
I guess just you: https://www.screencast.com/t/V6dfdHvv
I tested this on two hAP ac^2 where one is 6.42.1 and second 6.42.3 ... Both working well

If you open dev panel, can you see some errors in console or failed requests ?


Still no fix for chr hyperv?
Can you describe is wrong with CHR on Hyper-V?
I have one CHR on Hyper-V and I did not notice some issue. User Kindis is also reporting he upgraded his CHR on Hyper-V and had no issues
 
eddieb
Member Candidate
Member Candidate
Posts: 128
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.42.3 [current]

Sat May 26, 2018 8:06 am

RB2011 / RB1100 / RB951 / RB962 (9pc) / CRS125 / CHR / CHR-Dude all updated to 6.42.3.
no problems
Running 6.45.2 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
netflow
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Oct 01, 2016 3:53 pm

Re: v6.42.3 [current]

Sat May 26, 2018 9:56 am

How can I clean up these extra files/data? If I format the flash then the device won't boot afterwards, isn't it?
A simple reboot usually removes those invisible left overs.

If still not enough, a trick I use on an overloaded 941-2nD. Push manually first only some core packages (system and as much as needed for accessing the device after reboot). Then after reboot push the rest of the packages needed for full operation. Hope it helps and MT team will eventually improve in this area as well.
 
anuser
Member
Member
Posts: 368
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.42.3 [current]

Sat May 26, 2018 11:08 am

Version 6.43rc17 has been released.
*) wireless - fixed wireless interface lockup after period of inactivity;
It would be great if we get this fix into the next current release, aswell.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: v6.42.3 [current]

Sat May 26, 2018 11:38 am

Confirm further aggregate throughput increase on AP. Almost there Mikrotik soon be overtaking the the competition in performance as well as price. Well done dev team excellent work, go have yourselves a well deserved beer :-)
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.3 [current]

Sat May 26, 2018 11:42 am

Confirm further aggregate throughput increase on AP. Almost there Mikrotik soon be overtaking the the competition in performance as well as price. Well done dev team excellent work, go have yourselves a well deserved beer :-)
Not that many competitors are there so far. AP mabe but not routers. VyOS on Ubiquity routers maybe?
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.3 [current]

Sat May 26, 2018 11:44 am

How can I clean up these extra files/data? If I format the flash then the device won't boot afterwards, isn't it?
A simple reboot usually removes those invisible left overs.

If still not enough, a trick I use on an overloaded 941-2nD. Push manually first only some core packages (system and as much as needed for accessing the device after reboot). Then after reboot push the rest of the packages needed for full operation. Hope it helps and MT team will eventually improve in this area as well.
Reboot won't helped at all, I tried that first. Will try mess with individual packages, but that looks risky.
 
User avatar
amt
Long time Member
Long time Member
Posts: 525
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.42.3 [current]

Sat May 26, 2018 2:33 pm

Now we need to improve in nv2 ptp since we can not get past those 100 mbps in ptp mode as well.
Definitely I agree with you..
 
tmcnulty1982
just joined
Posts: 10
Joined: Sat Feb 13, 2016 11:29 pm

Re: v6.42.3 [current]

Sun May 27, 2018 2:08 am

My wAP ac will not run this firmware.

I was running 6.40.8 previously. After installing 6.42.3 the wireless AP lights do not come on.

I have tried resetting the configuration (holding down reset for 5 seconds after start up). Still no wifi and ethernet port is not getting IP address.

I have tried enabling capsman (reset button for 10 seconds). Still no wifi and ethernet port is not getting IP address.

Tried installing 6.42.8 via netinstall and repeating the above. Still nothing.

The only way to get the router to start again is to install 6.40.8 via netinstall, and reset the configuration.

Please advise.
 
ofer
newbie
Posts: 48
Joined: Wed May 23, 2018 11:45 am

Re: v6.42.3 [current]

Sun May 27, 2018 11:35 am

Upgraded my 3 HAP AC units from without issues

Thanks!
 
MEV
just joined
Posts: 2
Joined: Thu May 24, 2018 10:39 pm

Re: v6.42.3 [current]

Sun May 27, 2018 10:34 pm

Is EoIP active on router A (meaning that you have disabled keepalive) ?

EoIP was created with standard settings, in standard no keepalive set on both side.
 
S4bulba
just joined
Posts: 10
Joined: Mon May 07, 2018 12:18 am

Re: v6.42.3 [current]

Mon May 28, 2018 1:26 am

There is some issue with firewall rules or maybe they work differently now.I think it started with 42.2 version.
My ICMP rules made on input and/or forward chains are ignored.
They were working just fine in 42.1.
I usually drop ICMP Type 8 Echo Request when i am not playing online games from WAN (BF4 for example requires it otherwise you get kicked).
When this rule was enforced no ping could be seen in BF4 players list , now the ping shows up with the exact same rules :).So what s the problem ?
Why is ICMP going thru even when no rule is allowing it ? :)
Has something changed in relation to firewall rules since 42.2 ?
Over & Out !
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.3 [current]

Mon May 28, 2018 7:22 am

joserudi - Also this release includes improvements regarding Nv2 performance when multiple clients are connected to the same AP;
upower3, Mackiavelly - Please contact support@mikrotik.com and send supout file from your router to us;
timoid - Please try to keep this forum topic strictly related to v6.42.3 release;
payday - I assume that problem did not appear in this release. Please try to keep this topic related to problems introduced in v6.42.3. Contact support regarding the Webfig terminal issue. Meanwhile, test if problem persist when using different WEB browsers;
SnakeSK - Could you be more specific? Your post does not indicate what kind of issue do you have and which fix you were expecting within this version. Have you reported your problem to support@mikrotik.com?
anuser - If this fix will be well tested and will introduce only improvements, then it will be included in next release;
tmcnulty1982 - Please send supout file from v6.40.8 to support@mikrotik.com. We will try to reproduce your problem in our lab;
S4bulba - There are no firewall changes in this release so the problem must be related to configuration problems. Please send supout file to support@mikrotik.com and we will try to trace cause of it.
 
Beone
Member Candidate
Member Candidate
Posts: 243
Joined: Fri Feb 11, 2011 1:11 pm

Re: v6.42.3 [current]

Mon May 28, 2018 1:14 pm

I'll repeat my question here:

I have a ccr1009 with flash partitioned into 2 partitions. So each of that flash parts are of 32 Mb, which was ok for me so far.

After recent upgrade to 6.42.1 I found all of my flash almost taken by unknown (invisible) files or data. Right now I have only 10 Mb of flash and the upgrade to 6.42.2 needs ~15Mb. I asked this in different topic and got viewtopic.php?f=2&t=134713&p=663589#p663890 this answer saying I'm not along with the problem, so looks like 6.42.1 upgrade script won't do its job well, or something. Not sure is this can be more widespread or not, and surely don't know if this can happen to any new version.

What should I do? The device is on remote location so it's not an option to netinstall it. So far I can not upgrade to any new version.

How can I clean up these extra files/data? If I format the flash then the device won't boot afterwards, isn't it?
We have exactly the same issue, we reported it to Mikrotik with Ticket#2018051822005031, there beautiful answer was to remove the partitioning (which i've done) but just resulted in 1 bigger partition with still invisible files using up all the diskspace.

When reporting this, the answer of support was to just fully netinstall the device which i've reported not to be a working production solution. We cannot just go everywhere reinstalling all the devices just because of this issue.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.3 [current]

Mon May 28, 2018 2:18 pm

We have provided an answer to you within e-mail conversation between you and support team.

Please note that provided steps in this case (and usually also within other support tickets) are first provided in order to debug the problem and when we can find a cause of it, we can work on a permanent solution.
 
heavyd
Frequent Visitor
Frequent Visitor
Posts: 85
Joined: Wed Aug 08, 2007 12:32 pm

Re: v6.42.3 [current]

Mon May 28, 2018 8:26 pm

I got increased performance but broke the clients VoIP. Downgraded back to 6.41.3 and all is good again
 
pe1chl
Forum Guru
Forum Guru
Posts: 5529
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.3 [current]

Mon May 28, 2018 9:39 pm

I updated a CCR1009 which was running 6.42.1 with the combined package plus ntp. hotspot, mpls and wireless are disabled.
As I wanted to take the opportunity to migrate to individual packages and add multicast, I uploaded the individual packages for 6.42.3 and rebooted.
advanced-tools-6.42.3-tile.npk
dhcp-6.42.3-tile.npk
ipv6-6.42.3-tile.npk
multicast-6.42.3-tile.npk
ntp-6.42.3-tile.npk
ppp-6.42.3-tile.npk
routing-6.42.3-tile.npk
security-6.42.3-tile.npk
system-6.42.3-tile.npk

The upgrade went fine, however before this update there was 24.5 MB free of the 64MB partition (2 partitions), and after the update only 11.5 MB free
so no further updating will be possible. Apparently the same issue as some others had.
What is the solution? Netinstall is not an option, but I can switch to the second partition which holds a copy of the 6.42.1 and latest config.
 
Mackiavelly
just joined
Posts: 12
Joined: Wed Aug 31, 2016 12:59 am

Re: v6.42.3 [current]

Tue May 29, 2018 12:53 pm

if
/interface bridge settings set use-ip-firewall=yes use-ip-firewall-for-pppoe=yes
then have promlems:
1. dont work simple queues (upload)
2. and then other mikrotik connect to this mikrotik by pppoe then have 0.1 mbit/s download speed, and unlocked speed upload (promlem 1)

if
/interface bridge settings set use-ip-firewall=no
all ok
some one have this problems?
 
pe1chl
Forum Guru
Forum Guru
Posts: 5529
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.3 [current]

Tue May 29, 2018 12:53 pm

MikroTik:
Will there be any public followup on the topic of lost diskspace? where is the problem and how can it be solved or circumvented other than by netinstall?
Is it a problem in 6.42.1 that is going to occur not matter what you upgrade it to? Or is the right thing to do to go back to 6.42.1 (switch to other partition) and
then wait for 6.42.4 which will then not have this behaviour? Or will there be a 6.42.4 that can be installed by first going back to single partition, then install
it and to back to two partitions? Or will there be a small fixup package for 6.42.3 that can be installed to fix it and re-enable update with 2 partitions again?

Please give some details within a couple of days, so it is still an option to go back to 6.42.1 if required (without losing changes made in the meantime).
We all understand there sometimes can be mistakes, but we cannot understand the lack of information there sometimes seems to be.
 
S4bulba
just joined
Posts: 10
Joined: Mon May 07, 2018 12:18 am

Re: v6.42.3 [current]

Tue May 29, 2018 6:52 pm

There is some issue with firewall rules or maybe they work differently now.I think it started with 42.2 version.
My ICMP rules made on input and/or forward chains are ignored.
They were working just fine in 42.1.
I usually drop ICMP Type 8 Echo Request when i am not playing online games from WAN (BF4 for example requires it otherwise you get kicked).
When this rule was enforced no ping could be seen in BF4 players list , now the ping shows up with the exact same rules :).So what s the problem ?
Why is ICMP going thru even when no rule is allowing it ? :)
Has something changed in relation to firewall rules since 42.2 ?
I have downgraded to 6.42.1 and the ICMP rules on the input chain are picking up traffic again and loging it.So in the 42.3 a simple rule that logs ICMP would not do anything while a ICMP rule on the forward chain would not pick up all ICMP traffic.On 6.42.1 the things seem to be working properly ,same firewall ruleset made from within the winbox interface keep in mind.
It s like ICMP would go around the firewall in 42.3 ,on it s own:)
Over & Out !
 
0ldman
Forum Guru
Forum Guru
Posts: 1445
Joined: Thu Jul 27, 2006 5:01 am

Re: v6.42.3 [current]

Wed May 30, 2018 3:26 am

The Dude 6.42.3 client link, "file not found".
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 736
Joined: Mon May 14, 2012 9:30 pm

Re: v6.42.3 [current]

Wed May 30, 2018 6:36 am

RB2011 Upgraded to 6.42.3
In the Bridge... selecting any port causes Winbox to close.

Disable the bridge... it reenabled itself and turned on hardware off loading on some ports. Still can't access
/interface bridge ports

Reboot router.
Now you can select ports.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
middelink
just joined
Posts: 1
Joined: Wed May 30, 2018 9:56 am
Location: Switzerland

Re: v6.42.3 [current]

Wed May 30, 2018 10:01 am

After upgrading to 6.42.3 I had lots of trouble with the Wifi on my CRS125-24G-1S-2HnD, clients kept being deauthed which I believe is more a side effect of the SSID not getting broadcasted :(
Downgraded to 6.42.2 and immediately it started broadcasting the SSID and my clients (17) popped back in and have been since.

Smell like a bug :(
Thanks,
Pauline
 
anuser
Member
Member
Posts: 368
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.42.3 [current]

Wed May 30, 2018 1:14 pm

wAP AC: With 6.43rc12 a user was able to connect with its Huawei smartphone. Now with 6.42.3 he is unable to connect at all, neither with WPA2/EAP nor with open/unprotected SSID. There´s no entry within the log when he tries to connect. After upgrading to 6.43rc12 he can happily connect again.
 
timoid
newbie
Posts: 36
Joined: Tue Jan 01, 2008 8:20 am

Re: v6.42.3 [current]

Wed May 30, 2018 1:52 pm

timoid - Please try to keep this forum topic strictly related to v6.42.3 release;
I would have if it wasn't locked.... *facepalm*

So please answer my question.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.42.3 [current]

Wed May 30, 2018 3:09 pm

After upgrading to 6.42.3 I had lots of trouble with the Wifi on my CRS125-24G-1S-2HnD, clients kept being deauthed which I believe is more a side effect of the SSID not getting broadcasted :(
Downgraded to 6.42.2 and immediately it started broadcasting the SSID and my clients (17) popped back in and have been since.

Smell like a bug :(
Please be more specific on this problem - what is your configuration on the AP, can you provide us support output file to support@mikrotik.com?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3424
Joined: Mon May 31, 2004 2:55 pm

Re: v6.42.3 [current]

Wed May 30, 2018 3:10 pm

wAP AC: With 6.43rc12 a user was able to connect with its Huawei smartphone. Now with 6.42.3 he is unable to connect at all, neither with WPA2/EAP nor with open/unprotected SSID. There´s no entry within the log when he tries to connect. After upgrading to 6.43rc12 he can happily connect again.
Is it happening on both 2.4ghz and 5ghz? Please provide support output file when this happens and send to support@mikrotik.com
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3074
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42.3 [current]

Wed May 30, 2018 3:13 pm

RouterOS version 6.42.3 has been released in public "current" channel!

*) wireless - improved client "channel-width" detection;
Can we have an explanation on this one. How is it improved? What did not happen before? If client is set at 20Mhz where AP is at 40Mhz or higher client simply can't communicate on anything wider then 20Mhz isn't it? So what is improved now?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3074
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42.3 [current]

Wed May 30, 2018 3:17 pm

RouterOS version 6.42.3 has been released in public "current" channel!
*) wireless - improved Nv2 PtMP performance;
Does this improvement need an upgrade of AP only or all CPE's need to have the upgrade? Or if not, what minimal version do CPE's need to have to work with this improvement?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
xrayd
newbie
Posts: 37
Joined: Thu Feb 27, 2014 7:28 pm

Re: v6.42.3 [current]

Thu May 31, 2018 1:37 am

...+1

Who is online

Users browsing this forum: No registered users and 10 guests