Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

v6.42.4 [current]

Tue Jun 19, 2018 11:26 am

RouterOS version 6.42.4 has been released in public "current" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.42.4 (2018-Jun-15 14:14):

*) bridge - allow to make changes for bridge port when it is interface list;
*) bridge - fixed FastPath for bridge master interfaces (introduced in v6.42);
*) certificate - fixed "add-scep" template existence check when signing certificate;
*) chr - fixed adding MSTI entries;
*) chr - fixed boot on hosts older than Windows Server 2012 when running CHR on Hyper-V;
*) chr - fixed various network hang scenarios when running CHR on Hyper-V;
*) console - fixed script permissions if script is executed by other RouterOS service;
*) dhcpv4-server - fixed DHCP server that was stuck on invalid state;
*) health - changed "PSU-Voltage" to "PSU-State" for CRS328-4C-20S-4S+;
*) health - fixed incorrect PSU index for CRS328-4C-20S-4S+;
*) ipsec - improved reliability on IPsec hardware encryption for RB1100Dx4;
*) kidcontrol - fixed dynamically created firewall rules order;
*) led - added "dark-mode" functionality for hEX S and SXTsq 5 ac devices;
*) led - fixed CCR1016-12S-1S+ LED behaviour after Netinstall (introduced in v6.41rc58);
*) led - use routers uptime as a starting point when turning off LEDs if option was not enabled on boot;
*) ppp - fixed "hunged up" grammar to "hung up" within PPP log messages;
*) quickset - added missing wireless "channel-width" settings;
*) quickset - added support for "5ghz-a/n" band when CPE mode is used;
*) snmp - added remote CAP count OID for CAPsMAN;
*) snmp - fixed readings for CAPsMAN slave interfaces;
*) supout - added "partitions" section to supout file;
*) usb - properly detect USB 3.0 flash on RBM33G when jumper is removed;
*) userman - improved unique username generation process when adding batch of users;
*) w60g - improved RAM memoy allocation processes;
*) winbox - added missing "dscp" and "clamp-tcp-mss" settings to IPv6 tunnels;
*) winbox - allow to specify full URL in SCEP certificate signing process;
*) winbox - by default specify keepalive timeout value for tunnel type interfaces;
*) winbox - show "scep-url" for certificates;
*) winbox - show "System/Health" only on boards that have health monitoring;
*) winbox - show firmware upgrade message at the bottom of "System/RouterBOARD" menu;
*) wireless - enable all chains by default on devices without external antennas after configuration reset;
*) wireless - improved Nv2 reliability on ARM devices;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
 
Donkeyrollerz
just joined
Posts: 5
Joined: Thu Feb 15, 2018 1:18 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 11:37 am

Hey there, many thanks for the latest release though it looks like I am getting a 404 not found for ARM (rb3011) through your download page. I might just be a very keen bean!
 
pe1chl
Forum Guru
Forum Guru
Posts: 5523
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 11:55 am

Does it fix the "lost space after upgrade" issue on CCR?
(when upgrading 6.42.1 to 6.42.3 on a CCR split into two 64MB partitions a lot of diskspace remains in-use after the upgrade and not enough space is left for another upgrade)
 
bennyh
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Fri Mar 03, 2017 12:37 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 11:56 am

Hey there, many thanks for the latest release though it looks like I am getting a 404 not found for ARM (rb3011) through your download page. I might just be a very keen bean!
You can download it from the archive:
https://mikrotik.com/download/archive
(slide down to the current releases)
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.4 [current]

Tue Jun 19, 2018 12:27 pm

Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
 
Donkeyrollerz
just joined
Posts: 5
Joined: Thu Feb 15, 2018 1:18 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 12:53 pm

Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
Thanks for that, successfully downloaded now!
 
User avatar
nichky
Long time Member
Long time Member
Posts: 516
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:09 pm

do i need to upgrade the firmware every time when new version comes out?
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2278
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:38 pm

do i need to upgrade the firmware every time when new version comes out?
Yes, it is impossible to live without it :-)
LAN, FTTx, Wireless. ISP operator
 
msatter
Forum Guru
Forum Guru
Posts: 1158
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:51 pm

The firmware has gotten in sync with RouterOS versions....even if nothing has changed in the firmware.

I hope one time it will be separated again and as extra information a second version number stating minimal RouterOS version.
Two RB760iGS (hEX S) in series. One does PPPoE/IKEv2 and the other does the rest of the tasks.
Running:
RouterOS 6.46Beta / Winbox 3.19 / MikroTik APP 1.2.10
Having an Android device, use https://github.com/M66B/NetGuard/releases no root required
 
joserudi
Frequent Visitor
Frequent Visitor
Posts: 66
Joined: Thu Nov 22, 2007 10:16 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:54 pm

*) wireless - improved Nv2 reliability on ARM devices;

I'm sorry to indicate that the nv2 protocol on arm devices continues to fail. It is unstable and has packet loss. Nstreme is still the best option
 
User avatar
nichky
Long time Member
Long time Member
Posts: 516
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:55 pm

The firmware has gotten in sync with RouterOS versions....even if nothing has changed in the firmware.

I hope one time it will be separated again and as extra information a second version number stating minimal RouterOS version.

brow..you doing upgrade on your firmware or NO after new version cum up. My question i more than simple.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
pe1chl
Forum Guru
Forum Guru
Posts: 5523
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 1:56 pm

Donkeyrollerz - You tried to download version while it was still being released.
pe1chl - Version fixes all the problems mentioned in changelog. There are no hidden fixes.
So how is the indicated problem going to be fixed?
Users who have installed 6.42.1-6.42.3 on CCR are effectively at a dead end.
Having to use netinstall on all those "bricked" routers is simply not acceptable!
Either a fix package or an included fix in a later release is required.
As it is now, I can no longer upgrade my two CCR that are on 6.42.1 because that disables future upgrades on them.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3074
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42.4 [current]

Tue Jun 19, 2018 5:21 pm

The firmware has gotten in sync with RouterOS versions....even if nothing has changed in the firmware.

I hope one time it will be separated again and as extra information a second version number stating minimal RouterOS version.
Can anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?
Now each and every unit has to be rebooted twice. which is a pain if you have to do big amounts....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3074
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42.4 [current]

Tue Jun 19, 2018 5:25 pm

*) wireless - improved Nv2 reliability on ARM devices;

I'm sorry to indicate that the nv2 protocol on arm devices continues to fail. It is unstable and has packet loss. Nstreme is still the best option
OH! So I'll sit and wait again.... Getting a bit frustrated over arm devices and NV2.....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
icsterm
newbie
Posts: 26
Joined: Sun Mar 11, 2018 11:11 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 5:58 pm

Can anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?
Now each and every unit has to be rebooted twice. which is a pain if you have to do big amounts....
here you go
:log info "Checking firmware...";
/system routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
     :log info "Updating firmware";
     upgrade;
     #  Automatic restart
     :delay 2s
     /system reboot
     } else={
     :log info "No update."
     }
create this script then make a schedule on startup for it.
 
User avatar
eworm
Member
Member
Posts: 354
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.4 [current]

Tue Jun 19, 2018 6:05 pm

Can anybody make me a solution / script so after the ROS upgrade the unit either in the same reboot, or thereafter reboots again to update the fw version?
Now each and every unit has to be rebooted twice. which is a pain if you have to do big amounts....
here you go
:log info "Checking firmware...";
/system routerboard
:if ([get current-firmware] != [get upgrade-firmware]) do={
     :log info "Updating firmware";
     upgrade;
     #  Automatic restart
     :delay 2s
     /system reboot
     } else={
     :log info "No update."
     }
create this script then make a schedule on startup for it.
Don't do that! It can result in a boot loop!
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
icsterm
newbie
Posts: 26
Joined: Sun Mar 11, 2018 11:11 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 6:14 pm

It's tested & working just fine on 2 ROS devices I own.
It's not my script but I find it usefull.

The only bootloop possible is one caused by the new bootloader not being properly written. Which didn't happen to me on 30-40 RC updates.

If bootloop happens, just netinstall the router again and make sure to have backups available. I backup my router configs daily using another script that sends the backup config files over email.

Bad day = netinstall + restore backup.

It's probably less than 1% chance to get a bootloop, though.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3074
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.42.4 [current]

Tue Jun 19, 2018 6:23 pm

Don't do that! It can result in a boot loop!
Well, I am not of yesterday. I have to try it first. I made some scripts myself in the past but just as script that I'd copy and paste in a terminal window when we upgrade units.
But sometimes on the new cpu's the scripts are processed so fast some setting that in a 'step by step' try out work fine in a 'one script' just don't perform. Then I tried to build in more delay times and we tried this, then that. And next time there is a new ROS the bloody script language is changed again and nothing works anymore.... (I usually use ROS upgrades to keep record which units have had other configuration changes as well. After 12 years of working with MT we still learn new things each time which makes us to change the general OS setting of all the CPE's..

So yeah, I am going to try something like this on a unit on my desk first... then another unit, and another, before in the field....

I just don't understand why both the OS and the fw can't be upgraded in one go....
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 876
Joined: Sun Oct 01, 2006 11:44 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 7:13 pm

I'm also not a fan of the labeling of firmware by RouterOS version. Previously, after updating RouterOS, I could easily see if firmware was outdated and choose to do a 2nd reboot. Now it always appears outdated, even if there were no changes between versions.
 
icsterm
newbie
Posts: 26
Joined: Sun Mar 11, 2018 11:11 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 8:52 pm

Just script it just be the new Mikrotik slogan :)
 
pe1chl
Forum Guru
Forum Guru
Posts: 5523
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.4 [current]

Tue Jun 19, 2018 8:57 pm

I have suggested improvement in other topics but it appears they are not interested.
It is probably best to just set System->Routerboard->settings "auto upgrade" to enabled and then just ignore anything about firmware version.
Usually the changes (if any) are not important and they will become active at your next reboot anyway.
 
User avatar
macsrwe
Long time Member
Long time Member
Posts: 646
Joined: Mon Apr 02, 2007 5:43 am
Location: Arizona, USA
Contact:

Re: v6.42.4 [current]

Wed Jun 20, 2018 1:42 am

The only bootloop possible is one caused by the new bootloader not being properly written. Which didn't happen to me on 30-40 RC updates.
MikroTik put out a release about six months ago where the "new available firmware" field always showed up as blank. Boot loop.

I use a more cautious approach in which the "reboot" line is replaced with a line that enables a scheduler entry timed to go off in the wee hours. That line kicks off a script that disables the scheduler entry, then reboots. That way, if there is a boot loop, at least it's a day long.
 
mt99
just joined
Posts: 24
Joined: Wed Jan 03, 2018 6:07 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 2:17 am

I upgraded an RB750GL, a 3011, a CRS226, and a RB951G-2HnD from 6.41.4 to 6.42.4 with no issues.

However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
 
elpamyelhsa
just joined
Posts: 5
Joined: Sat Apr 12, 2014 6:43 am

Re: v6.42.4 [current]

Wed Jun 20, 2018 4:59 am

For the last few versions I've been having IPSec issues, Looks like a missing default group that is causing it

Notice no * flag exist on the default group
[admin@PRIMARY-ROUTER] /ip ipsec policy group> print
Flags: * - default 
 #   NAME                                                                                                         
 0   group2                                                                                                       
 1   group1                                                                                                       
 2   default
 
This causes problems with L2TP generating a dynamic Peer that gets a "Policy Template Group: Unknown" that gives a "failed to pre-process ph2 packet"
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.4 [current]

Wed Jun 20, 2018 6:55 am

joserudi, WirelessRudy - These fixes has nothing to do with Nv2 performance. In some cases ARM routers were rebooting themselves while runnning Nv2 links. Now we have introduced fixes that help in such cases.
pe1chl - Unfortunately I can not give you any ETA for any of fixes in RouterOS. When it will be fixed in rc versions, then fix will be backported to current/bugfix versions if possible.
WirelessRudy - You can not do that within the same reboot.
icsterm - Auto upgrade feature under RouterBOARD settings does the same thing automatically.
mt99 - Please send supout file from your router to support@mikrotik.com. This release does not have any DNS related fixes so it must be something else.
elpamyelhsa - We will look into this.

Everyone - As asked many times before in other topics too, please keep MikroTik announcement topics strictly related to their topic. If you have questions about, for example, RouterBOOT upgrade then either create a new discussion or contact support@mikrotik.com. We are making these topics in order to inform other users about version status and find out about new issues introduced in this release ourselves. Unrelated posts does not help to do that.
 
makstex
newbie
Posts: 46
Joined: Fri Mar 27, 2009 6:31 am

Re: v6.42.4 [current]

Wed Jun 20, 2018 8:09 am

Model RB1000
After update to 6.42.4 and firmware update that he worked for about 8 hours and DNS stopped responding. Switching the "Allow remote request" checkbox did not help. DNS chopped off completely. The restart has helped, but I still do not know how much it will work.
 
notToNew
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Feb 19, 2016 3:15 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 9:22 am

However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?

Same problem with CCR. I stay with 6.40.8 until i find a solution. Please report if you find any....
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
Wlad24rus
just joined
Posts: 1
Joined: Wed Jun 20, 2018 10:09 am

Re: v6.42.4 [current]

Wed Jun 20, 2018 10:19 am

How I do resolve problem with no free disc space to upgrade firmware?
I have HAP Lite with old FW, when I try to upload new pkg, - see error, "You have only 6.4mB of free space", Write error..
and new FW pkg is 7+ mBytes.. What i can delete for upgrade fitmware?

Total is 16 mbytes.. AutoUpgrade still not working - due this reason..
 
User avatar
Lifz
newbie
Posts: 35
Joined: Tue Feb 26, 2013 1:05 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 10:32 am

How I do resolve problem with no free disc space to upgrade firmware?
I have HAP Lite with old FW, when I try to upload new pkg, - see error, "You have only 6.4mB of free space", Write error..
and new FW pkg is 7+ mBytes.. What i can delete for upgrade fitmware?

Total is 16 mbytes.. AutoUpgrade still not working - due this reason..
You can try Netinstall. But first, run /export and save your config.
 
Note
newbie
Posts: 49
Joined: Fri Jun 03, 2016 12:39 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 11:24 am

rb952ui-5ac2nD hap lite
You do not have the required permissions to view the files attached to this post.
 
ptm
just joined
Posts: 1
Joined: Wed Jun 20, 2018 11:30 am

Re: v6.42.4 [current]

Wed Jun 20, 2018 11:48 am

I upgraded an RB750GL, a 3011, a CRS226, and a RB951G-2HnD from 6.41.4 to 6.42.4 with no issues.

However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
I have the same issue with CCR1036 and RB1100AHx2, it started after upgrading to 6.42.1 and I've checked with 6.42.2 and 6.42.3. The issue persists with some routers, I've upgraded 20, had problems with 6 of them and 2 of this 6 didn't work after downgrade them to a previous version.
 
User avatar
eworm
Member
Member
Posts: 354
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.4 [current]

Wed Jun 20, 2018 1:10 pm

icsterm - Auto upgrade feature under RouterBOARD settings does the same thing automatically.
But it does not reboot to take the changes into account. After upgrade you see a comment in export:
[admin@mikrotik] > /system routerboard print 
                ;;; Firmware upgraded successfully, please reboot for changes to take effect!
       routerboard: yes
       ...
But this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
:if ([/system routerboard get pending-upgrade ] = true) do={ /system reboot }
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
notToNew
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Feb 19, 2016 3:15 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 1:40 pm

But this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
Scripts can read the log! See https://wiki.mikrotik.com/wiki/Manual:S ... _log_entry
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
User avatar
eworm
Member
Member
Posts: 354
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.4 [current]

Wed Jun 20, 2018 1:54 pm

But this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
Scripts can read the log! See https://wiki.mikrotik.com/wiki/Manual:S ... _log_entry
Yes...
:if ([ :len [ /log find where topics=system,info,critical and message="Firmware upgraded successfully, please reboot for changes to take effect!" ] ] > 0) do={ /system reboot }
But it's pretty dumb to read the full log for something a boolean property can provide.
Additionally it is prone to errors. If I have a system which produces a lot of logs and my script is scheduled to run not too frequent this will fail. With persistent log memory this can produce boot loop.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
pe1chl
Forum Guru
Forum Guru
Posts: 5523
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 2:07 pm

But this is not available to scripts, no? Perhaps you should add a read-only property "pending-upgrade". A scheduled script could look like this:
:if ([/system routerboard get pending-upgrade ] = true) do={ /system reboot }
As I wrote before, the router should do this automatically just after the automatic upgrade, before it brings up all the interfaces.
That would cause less disturbances and would be quicker.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 880
Joined: Tue Oct 11, 2005 4:53 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 2:10 pm

rb952ui-5ac2nD hap lite
That refers to the remote side ROS version.
 
User avatar
krafg
Member Candidate
Member Candidate
Posts: 239
Joined: Sun Jun 28, 2015 7:36 pm

Re: v6.42.4 [current]

Wed Jun 20, 2018 4:25 pm

After upgrade, still have problems with DHCP.

Regards.
You do not have the required permissions to view the files attached to this post.
Image
 
ofer
newbie
Posts: 48
Joined: Wed May 23, 2018 11:45 am

Re: v6.42.4 [current]

Wed Jun 20, 2018 5:00 pm

updated 3xHAP AC units everything went as planned and without issues
bridges HW offloading activated everything seems to be in order

Thanks!
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8290
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.4 [current]

Wed Jun 20, 2018 11:19 pm

After upgrade, still have problems with DHCP.

Regards.
What problems? I can't click your WinBox to see actual settings for some reason.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
krafg
Member Candidate
Member Candidate
Posts: 239
Joined: Sun Jun 28, 2015 7:36 pm

Re: v6.42.4 [current]

Thu Jun 21, 2018 2:05 am

After upgrade, still have problems with DHCP.

Regards.
What problems? I can't click your WinBox to see actual settings for some reason.

Randomly all computers sometimes can't get IP from DHCP server.

Regards.
Image
 
DummyPLUG
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Wed Jan 03, 2018 10:17 am

Re: v6.42.4 [current]

Thu Jun 21, 2018 3:18 am

CCR1009, confirm DNS server stop working after about a few hours after update to 6.42.4
 
mt99
just joined
Posts: 24
Joined: Wed Jan 03, 2018 6:07 pm

Re: v6.42.4 [current]

Thu Jun 21, 2018 7:14 am

I upgraded an RB750GL, a 3011, a CRS226, and a RB951G-2HnD from 6.41.4 to 6.42.4 with no issues.

However, after the upgrade I noticed that the two routers with DNS servers (one for internal, one for my guest network) were no longer resolving. This wasn't an issue before the upgrade. I did see them receiving UDP 53 packets. After checking IP > DNS to see if anything had obviously changed and toggling "allow remote requests" on and off with no help, I activated a backup partition with 6.41.4 on both devices and rebooted. DNS is working again. Has anyone else seen this problem?
Opened Ticket#2018062122002481 with supouts as requested, please take a look Strods.
 
TmouR
just joined
Posts: 3
Joined: Wed Aug 15, 2012 2:46 pm

Re: v6.42.4 [current]

Thu Jun 21, 2018 6:41 pm

I also confirm that DNS stops after a few hours on some CCR1009's
Last edited by TmouR on Fri Jun 22, 2018 9:07 am, edited 1 time in total.
 
w0lt
Member
Member
Posts: 480
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.42.4 [current]

Thu Jun 21, 2018 7:50 pm

I also confirm that DNS stops after a few hours on some CCR1009's

Sent from my ONEPLUS A5010 using Tapatalk
I had this happen on a RB800, drove me crazy till I downgraded to 6.41 then upgraded by loading files directly instead of auto-upgrade. Seems to work now.
I'm crossing my fingers, eh? :?
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "
 
twingman
just joined
Posts: 6
Joined: Mon Oct 07, 2013 11:10 am
Location: Žilina, Slovakia
Contact:

Re: v6.42.4 [current]

Thu Jun 21, 2018 9:24 pm

I also confirm that DNS stops after a few hours on some CCR1009's

Sent from my ONEPLUS A5010 using Tapatalk

Same issue - dns stops working after some time (random) in my two 1009 ccrs.

I have not enough space issue, too. With 2 partitions. Will be some non-netinstall solution available?
2x CCR1009-7G-1C-1S+
1x CRS328-24P-4S+
many (cca 200) RB951`s, some 2011, 4011, wAPs, ...
 
upower3
Member
Member
Posts: 377
Joined: Thu May 07, 2015 11:46 am

Re: v6.42.4 [current]

Fri Jun 22, 2018 11:17 am

After I got my CCR1009 upgraded to 6.42.4 (both ROS and f/w) remote API login become invalid. My scripts can not log in at all, and on device I can see "login failure for user <my-user> from <my-ip>" messages in log.

I have a dedicated user to allow API requests on my device, it is of group named "api" I created to narrow its rights. This worked for years, until last night I had the upgrade installed.

Over the years before, the api group has only the following rights enabled: api, read, write. As I did my tests afterwards, I found I need to add extra right winbox to allow old scripts to connect.

I use "RouterOS PHP API class v1.6" php library from http://wiki.mikrotik.com/wiki/API_PHP_class so I think this should be fixed to have old scripts still work.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5523
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.4 [current]

Fri Jun 22, 2018 11:58 am

I have seen that error report in the 6.43rc topic as well. It looks like some erroneous fix was backported into the current version.
It is a bit unfortunate that MikroTik does not track the release annoucement topics closely and instead relies on everything being reported to their mail address...
(maybe this particular issue wasn't reported there)
 
Pudel
just joined
Posts: 1
Joined: Mon Jun 11, 2018 9:21 pm

Re: v6.42.4 [current]

Fri Jun 22, 2018 3:10 pm

Amazing update. I can't login to RB951. Wrong password/login from Winbox and Webfig
Dear Mikrotik, I suggest to hire really good programmers.

EDIT:

SSH works. Very funny

Edit2:
Downgraded from ssh. It's very funny because after downgrade password back to changed a few days ago...
In Polish "hokus pokus, czary mary"
Last edited by Pudel on Fri Jun 22, 2018 3:29 pm, edited 2 times in total.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5909
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.42.4 [current]

Fri Jun 22, 2018 3:14 pm

upower3, pe1chl - API problem will be fixed in next version.
 
rfabriciop
just joined
Posts: 1
Joined: Tue Jun 19, 2018 7:08 pm

Re: v6.42.4 [current]

Fri Jun 22, 2018 6:57 pm

buenas tardes este firmware lo instale en 3 equipos rb750gl pero los mismos dejaron de funcionar, se reinicia constantemnete y los leds encienden y apagan a cada momento no los puedo recuperar ni con netinstall, tienen alguna solucion para este problema me quedaron 3 equipos como pisapapeles.

Who is online

Users browsing this forum: No registered users and 11 guests