Community discussions

 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:13 pm

Hi,

What is the idea of that I can't use IKE2 with "pre shared key xauth" ?
When I try to set it up I get the message in attached picture.
Pre-shared key with XAuth was never really supported in IKEv2. Also IKEv2 rfc does not acknowledge XAuth as an authentication method.
 
User avatar
blue
Member Candidate
Member Candidate
Posts: 243
Joined: Sun Dec 12, 2004 1:48 pm
Location: Serbia

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:24 pm

Many, many, many thanx for speedtest. Finally test uses all cores of the routerboard...
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8140
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:41 pm

Finally test uses all cores of the routerboard...
Have you checked BTest?

MT Staff: why create speed-test? You already have BTest - develop it! :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
g22113
just joined
Posts: 6
Joined: Sat Aug 19, 2017 3:21 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:45 pm

What's new in 6.44beta39 (2018-Nov-27 12:14):
!) ipsec - added new "identity" menu with common peer distinguishers;
This new menu keeps complaining about my IKEv2-PSK configuration. After upgrade, I have 5 entries autogenerated in "/ip ipsec identity", but all of them (except one) show an error:

initiator peer can have only one identity

I don't know why that restriction was added -- it is completely valid in IKEv2 to use same IDi but a different PSK for each different remote peer (and I've been doing so for quite a while).

Also, the corresponding "/ip ipsec peer" entries also show This entry is unreachable... but oddly, they're connected and established despite that.
 
flyfinlander
just joined
Posts: 3
Joined: Tue Nov 27, 2018 4:47 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:53 pm

Hi,

What is the idea of that I can't use IKE2 with "pre shared key xauth" ?
When I try to set it up I get the message in attached picture.
Pre-shared key with XAuth was never really supported in IKEv2. Also IKEv2 rfc does not acknowledge XAuth as an authentication method.
Very strange... Below are logs before and after on remote device(77.70.x.x with ROS 6.43).
Before - device (46.23.x.x with ROS 6.44beta28)
After - device (46.23.x.x with ROS 6.44beta39)
You do not have the required permissions to view the files attached to this post.
 
flyfinlander
just joined
Posts: 3
Joined: Tue Nov 27, 2018 4:47 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 5:55 pm

Hi,

What is the idea of that I can't use IKE2 with "pre shared key xauth" ?
When I try to set it up I get the message in attached picture.
Pre-shared key with XAuth was never really supported in IKEv2. Also IKEv2 rfc does not acknowledge XAuth as an authentication method.
Very strange... Below are logs before and after on remote device(77.70.x.x with ROS 6.43).
Before - device (46.23.x.x with ROS 6.44beta28)
After - device (46.23.x.x with ROS 6.44beta39)


P.S. First log (before) is generated due wrong Xauth user name
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 6:00 pm

g22113, that is not a limitation, simply the warning messages are misleading. The limitation should be - one identity per one initiator peer. We will resolve the issue in the next beta.

The same goes for "this peer is unreachable" warnings - they are not working as expected. Also resolved in the next beta.

Another known issue - identity generated by L2TP server does not have generate-policy set to port-strict, meaning phase 2 will fail.

flyfinlander, if XAuth was configured with IKEv2 exchange-mode in older versions, asymmetric authentication was actually used. It worked between two RouterOS devices and most likely nowhere else without some weird configuration. We have plans to implement asymmetric authentication in the future and not mix it with XAuth which has nothing to do with it.
 
g22113
just joined
Posts: 6
Joined: Sat Aug 19, 2017 3:21 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 6:19 pm

g22113, that is not a limitation, simply the warning messages are misleading. The limitation should be - one identity per one initiator peer. We will resolve the issue in the next beta.

The same goes for "this peer is unreachable" warnings - they are not working as expected. Also resolved in the next beta.
Thanks very much for the response.
 
dakotabcn
just joined
Posts: 17
Joined: Thu Apr 21, 2016 11:16 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 6:35 pm

L2TP/IPSEC no work, the message are "failed to pre-process ph2 packet"
config
# nov/27/2018 17:36:36 by RouterOS 6.44beta39
#
# model = 951G-2HnD
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha256,sha1 enc-algorithms=aes-256-cbc,aes-192-cbc,aes-128-cbc,3des
/interface l2tp-server server
set allow-fast-path=yes authentication=mschap2 default-profile=default enabled=yes ipsec-secret=********** use-ipsec=yes

config by default, i have deleted all old config ipsec an created by default
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8140
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 6:55 pm

Isn't the answer two posts above?..
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
dakotabcn
just joined
Posts: 17
Joined: Thu Apr 21, 2016 11:16 pm

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 7:07 pm

Isn't the answer two posts above?..
i use this config in 6.4.34 in all clients, in the new beta no work the peer, the port-override and main-l2tp no work
if upgrade to next version all vpn l2tp/ipsec with this config will they stop working?

/interface l2tp-server server
set authentication=mschap2 enabled=yes
/ppp profile
add change-tcp-mss=yes dns-server=8.8.4.4,8.8.8.8 name="VPN IPSEC" only-one=\
yes use-upnp=yes
/ip firewall filter
add action=accept chain=input comment="ipsec-ike-natt - VPN ROAMING - IPSEC" \
dst-port=4500 in-interface=ether1 protocol=udp
add action=accept chain=input comment="ipsec-ike-natt - VPN ROAMING" \
dst-port=500 in-interface=ether1 protocol=udp
add action=accept chain=input comment="ipsec-ike-natt - VPN ROAMING" \
dst-port=1701 in-interface=ether1 protocol=udp
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override passive=yes secret=SECRETL2TPPASSWORD
 
User avatar
blue
Member Candidate
Member Candidate
Posts: 243
Joined: Sun Dec 12, 2004 1:48 pm
Location: Serbia

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 7:08 pm

Finally test uses all cores of the routerboard...
Have you checked BTest?

MT Staff: why create speed-test? You already have BTest - develop it! :)
I gave up on btest long time ago, and iperf is not always possible :(
 
msatter
Forum Veteran
Forum Veteran
Posts: 960
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 8:54 pm

Isn't the answer two posts above?..
i use this config in 6.4.34 in all clients, in the new beta no work the peer, the port-override and main-l2tp no work
if upgrade to next version all vpn l2tp/ipsec with this config will they stop working?
.
.
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override passive=yes secret=SECRETL2TPPASSWORD
What if you try:
add exchange-mode=main generate-policy=port-override passive=yes secret=SECRETL2TPPASSWORD
RB760iGS (hEX S) with the SFP being cooled.
Running:
RouterOS 6.44Beta40 / Winbox 3.18 / MikroTik APP 1.0.13
Cooling a SFP module: viewtopic.php?f=3&t=132258&p=671105#p671105
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 9:10 pm

L2TP/IPSEC no work, the message are "failed to pre-process ph2 packet"
config
# nov/27/2018 17:36:36 by RouterOS 6.44beta39
#
# model = 951G-2HnD
/ip ipsec proposal
set [ find default=yes ] auth-algorithms=sha256,sha1 enc-algorithms=aes-256-cbc,aes-192-cbc,aes-128-cbc,3des
/interface l2tp-server server
set allow-fast-path=yes authentication=mschap2 default-profile=default enabled=yes ipsec-secret=********** use-ipsec=yes

config by default, i have deleted all old config ipsec an created by default
As stated above, we are aware of the issue and will be fixed in the next beta versions.
i use this config in 6.4.34 in all clients, in the new beta no work the peer, the port-override and main-l2tp no work
if upgrade to next version all vpn l2tp/ipsec with this config will they stop working?

/interface l2tp-server server
set authentication=mschap2 enabled=yes
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override passive=yes secret=SECRETL2TPPASSWORD
The configuration will automatically convert to the new format on upgrade. If you wish to configure the same configuration on new versions, you have to change the IPsec peer configuration to something like this:
/ip ipsec peer
add exchange-mode=main passive=yes name=l2tpserver
/ip ipsec identity
add generate-policy=port-override auth-method=pre-shared-key secret=SECRETL2TPPASSWORD peer=l2tpserver
 
rememberme
just joined
Posts: 18
Joined: Fri Nov 13, 2015 10:13 pm
Location: Chicago, USA

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 9:47 pm

After upgrade:

RouterBOOT booter 3.41

CCR1036-8G-2S+

CPU frequency: 1200 MHz
Memory size: 4096 MiB
NAND size: 1024 MiB

Press any key within 2 seconds to enter setup..

loading kernel... OK
setting up elf image... OK
jumping to kernel code
ERROR: no system package found!
Kernel panic - not syncing: Attempted to kill init!

Starting stack dump of tid 1, pid 1 (init) on cpu 4 at cycle 36191216532
frame 0: 0xfffffff70051f768 dump_stack+0x0/0x20 (sp 0xfffffe407fdbfc08)
frame 1: 0xfffffff700518700 panic+0x168/0x398 (sp 0xfffffe407fdbfc08)
frame 2: 0xfffffff700053a78 do_exit+0x1c8/0xd48 (sp 0xfffffe407fdbfcb0)
frame 3: 0xfffffff700054740 do_group_exit+0xf0/0x1e8 (sp 0xfffffe407fdbfd78)
frame 4: 0xfffffff700054858 __wake_up_parent+0x0/0x18 (sp 0xfffffe407fdbfdb0)
frame 5: 0xfffffff7005204d8 handle_syscall+0x210/0x2d0 (sp 0xfffffe407fdbfdc0)
<syscall while in user mode>
frame 6: 0x8e2f0 0x8e2f0 (sp 0x7f8bf990)
Stack dump complete
Rebooting in 1 seconds..Resetting chip and restarting.
 
rememberme
just joined
Posts: 18
Joined: Fri Nov 13, 2015 10:13 pm
Location: Chicago, USA

Re: v6.44beta [testing] is released!

Tue Nov 27, 2018 11:00 pm

Netinstall fixed the router. Same package files.
 
strods
MikroTik Support
MikroTik Support
Posts: 1365
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 4:32 am

Netinstall fixed the router. Same package files.
Unfurtunately this serial console output is the result of the problem. Not the output from the moment when packages were lost.

Upgrade happens on old version (one from which you upgrade router). Which version was installed on your router before an upgrade? Based on old firmware I assume that it was not one of the latest ones.
 
antonsb
MikroTik Support
MikroTik Support
Posts: 164
Joined: Sun Jul 24, 2016 3:12 pm
Location: Riga, Latvia

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 7:31 am

Finally test uses all cores of the routerboard...
Have you checked BTest?

MT Staff: why create speed-test? You already have BTest - develop it! :)
I gave up on btest long time ago, and iperf is not always possible :(
Please read carefully through change log:
*) btest - added multithreading support for both UDP and TCP tests;
 
dakotabcn
just joined
Posts: 17
Joined: Thu Apr 21, 2016 11:16 pm

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 10:07 am

As stated above, we are aware of the issue and will be fixed in the next beta versions.
i use this config in 6.4.34 in all clients, in the new beta no work the peer, the port-override and main-l2tp no work
if upgrade to next version all vpn l2tp/ipsec with this config will they stop working?

/interface l2tp-server server
set authentication=mschap2 enabled=yes
/ip ipsec peer
add exchange-mode=main-l2tp generate-policy=port-override passive=yes secret=SECRETL2TPPASSWORD
The configuration will automatically convert to the new format on upgrade. If you wish to configure the same configuration on new versions, you have to change the IPsec peer configuration to something like this:
/ip ipsec peer
add exchange-mode=main passive=yes name=l2tpserver
/ip ipsec identity
add generate-policy=port-override auth-method=pre-shared-key secret=SECRETL2TPPASSWORD peer=l2tpserver

PERFECT, this code works
I made the following test, 2 users with windows 10, a team with the 1803 and another with the 1809, two VPN L2TP, the two connected perfectly, I perform a continuous ping to the VPN GW, in the first responds for about 15 seconds and in the second one, it is suddenly inverted, the one that was working the ping stops responding and the other one starts, the two active VPNs but they alternate
This is already an advance, before when the second VPN connection L2TP was disconnected the first, now it maintains it but the two at the same time do not work
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 120
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 10:54 am

Please read carefully through change log:
*) btest - added multithreading support for both UDP and TCP tests;
Great job. Now a single Btest can saturate a w60 link :)
 
nkourtzis
Member Candidate
Member Candidate
Posts: 195
Joined: Tue Dec 11, 2012 12:56 am
Location: Greece

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 12:36 pm

Dear Mikrotik engineers,

Thank you for the relentless development of new and improved features.

Would you consider fixing this issue: viewtopic.php?f=2&t=119267
Imagine relying on l2tp for a backup (failover) connection, only to realise that it is not working when you need it. Well, it just happened to me. :-)

Regards
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 3:32 pm

Version 6.44beta40 has been released.

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.44beta40 (2018-Nov-28 12:46):

Important note!!! Backup before upgrade!
Due to major IPsec configuration changes in RouterOS v6.44beta39+ (see changelog below), it is advised to make a backup before upgrading. Regular downgrade will still be possible as long as no changes in IPsec peer menu are done.

MAJOR CHANGES IN v6.44:
----------------------
!) cloud - added command "/system backup cloud" for backup storing on cloud (CLI only);
!) radius - initial implementation of RadSec (Radius communication over TLS);
!) upgrade - release channels renamed - "bugfix" to "long-term", "current" to "stable" and "release candidate" to "testing";
!) upgrade - "testing" release channel now can contain "beta" together with "release-candidate" versions;
!) speedtest - added "/tool speed-test" for ping latency, jitter, loss and TCP and UDP download, upload speed measurements (CLI only);
----------------------

Changes in this release:

!) ipsec - added new "identity" menu with common peer distinguishers;
!) ipsec - removed "main-l2tp" exchange-mode, it is the same as "main" exchange-mode;
!) ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;
*) capsman - fixed "group-key-update" parameter not using correct units;
*) certificate - fixed certificate signing by SCEP client if multiple CA certificates are provided;
*) crs317 - fixed TX not working on sfp-sfpplus9 interface (introduced in v6.40beta12);
*) dhcpv6-client - use default route distance also for unreachable route added by DHCPv6 client;
*) discovery - fixed malformed neighbor information for routers that has incomplete IPv6 configuration;
*) discovery - fixed neighbor discovery for PPP interfaces;
*) ipsec - fixed active connection killing when changing peer configuration;
*) ipsec - made peers autosort themselves based on reachability status;
*) ipsec - moved "profile" menu outside "peer" menu (CLI only);

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.
 
Stril
Member Candidate
Member Candidate
Posts: 100
Joined: Fri Nov 12, 2010 7:18 pm

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 6:42 pm


*) winbox - show "W60G" wireless tab on wAP 60G AP;
Hi!

That problem still exists with 6.44beta40
w60g monitoring is still only valid on CLI. GUI shows empty values.
 
strods
MikroTik Support
MikroTik Support
Posts: 1365
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44beta [testing] is released!

Wed Nov 28, 2018 10:42 pm

Stril - Is "W60G" tab missing for your wAP device on Winbox interface under Wireless menu? That is the problem which was fixed. If tab is still missing or you have another problem which has not been addressed in this release, then please send message to support@mikrotik.com and include supout file in attachment.
 
anuser
Member Candidate
Member Candidate
Posts: 277
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.44beta [testing] is released!

Thu Nov 29, 2018 10:12 pm

Version 6.44beta40 has been released.
*) capsman - fixed "group-key-update" parameter not using correct units;
Can you please give some more information about this one?
 
msatter
Forum Veteran
Forum Veteran
Posts: 960
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.44beta [testing] is released!

Thu Nov 29, 2018 11:35 pm

With the last two betas if have Winbox glitching and crashing. I re-downloaded Winbox but it still sometimes does not the windows and while typing all the windows disappear. Only a restart helps and then I have still sometimes manually reload the layout.

I find this strange because Winbox always worked great for me while others had problems with it.

I forgot to mention that I can't drag-and-drop anymore between file in Winbox and folders outside Winbox and vice versa. Really strange. I am using Win10 x64.
RB760iGS (hEX S) with the SFP being cooled.
Running:
RouterOS 6.44Beta40 / Winbox 3.18 / MikroTik APP 1.0.13
Cooling a SFP module: viewtopic.php?f=3&t=132258&p=671105#p671105
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 278
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44beta [testing] is released!

Fri Nov 30, 2018 9:35 am

anuser the parameter was not set properly and a different interval was used in the background.

msatter if there is an autosupout.rif file generated on the router after such crashes, it is worth to send it to us.
 
msatter
Forum Veteran
Forum Veteran
Posts: 960
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.44beta [testing] is released!

Fri Nov 30, 2018 11:59 am

Thanks Emils and this morning I tried drag and drop from the Files window in Winbox and it worked again. :D

I hope that it was a temporary problem and downloading/install and clearing the Winbox cache did not work.

One thing that is interesting now it working again I could not connect to the router by means of the MAC address despite it is shown in Neighbors of the connect screen. During the glitches and crashes I could again use the MAC to connect, today all is back to normal not glitches till now and connect through the MAC address.

If it returns I don't thing that the router will notice it except that the Winbox connection is gone.

So all is good now.
RB760iGS (hEX S) with the SFP being cooled.
Running:
RouterOS 6.44Beta40 / Winbox 3.18 / MikroTik APP 1.0.13
Cooling a SFP module: viewtopic.php?f=3&t=132258&p=671105#p671105
 
Extrems
just joined
Posts: 1
Joined: Tue Sep 11, 2018 8:09 pm
Location: Quebec, Canada
Contact:

Re: v6.44beta [testing] is released!

Fri Nov 30, 2018 5:13 pm

DHCP Snooping is causing reboots (no kernel panic) on CRS326-24G-2S+ since v6.44beta39.
 
User avatar
amt
Member
Member
Posts: 461
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.44beta [testing] is released!

Fri Nov 30, 2018 10:28 pm

Average Joe will not know how to use iperf. I think target audience for this feature is defferent from iperf users :)
But it is fun anyway:
[admin@1072_bonding_test_1] > /tool speed-test 192.168.1.2 test-duration=60
                  ;;; results can be limited by cpu, note that traffic generation/termination performance might not be 
                      representative of forwarding performance
              status: done
      time-remaining: 0s
    ping-min-avg-max: 111us / 123us / 2.14ms
  jitter-min-avg-max: 0s / 10us / 2.01ms
                loss: 0% (0/1200)
        tcp-download: 11.6Gbps local-cpu-load:83%
          tcp-upload: 12.1Gbps local-cpu-load:89% remote-cpu-load:84%
        udp-download: 24.3Gbps local-cpu-load:5% remote-cpu-load:79%
          udp-upload: 23.1Gbps local-cpu-load:87% remote-cpu-load:20%
Why there are no tcp-download "remote-cpu-load"?
tested beta version on CCR1072 ?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8140
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 1:21 am

Why not? It's 1072 for tests, anyway :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
amt
Member
Member
Posts: 461
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 9:04 am

if it is worked without problem, I will install too :)
 
Lakis
Long time Member
Long time Member
Posts: 698
Joined: Wed Sep 23, 2009 7:52 pm

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 11:20 am

Dude multithreading support when?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8140
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 11:24 am

if it is worked without problem, I will install too :)
Only on test CCR, which you can Netinetall any time!
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
amt
Member
Member
Posts: 461
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 12:56 pm

if it is worked without problem, I will install too :)
Only on test CCR, which you can Netinetall any time!
exatly, both 1072 are at very critic area, so I will wait :)
 
User avatar
amt
Member
Member
Posts: 461
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 1:01 pm

Dude multithreading support when?
and bgp multithreading support when?
 
msatter
Forum Veteran
Forum Veteran
Posts: 960
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 1:14 pm

...and bgp multithreading support when?
First the hell has to freeze over. ;-)

viewtopic.php?f=1&t=141920#p699481
RB760iGS (hEX S) with the SFP being cooled.
Running:
RouterOS 6.44Beta40 / Winbox 3.18 / MikroTik APP 1.0.13
Cooling a SFP module: viewtopic.php?f=3&t=132258&p=671105#p671105
 
raffav
Member Candidate
Member Candidate
Posts: 249
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.44beta [testing] is released!

Sat Dec 01, 2018 2:25 pm

...and bgp multithreading support when?
First the hell has to freeze over. ;-)

viewtopic.php?f=1&t=141920#p699481
I have the feeling that maybe this will be last beta if not the last is going to a close ending..
Maybe we have some v7 beta to play with on this Christmas ImageImage

Sent from my XT1580 using Tapatalk

 
server8
Member
Member
Posts: 311
Joined: Fri Apr 22, 2011 1:27 pm

Re: v6.44beta [testing] is released!

Sun Dec 02, 2018 9:03 pm

I am too old I don't believe in Santa Claus :-)
Maybe we have some v7 beta to play with on this Christmas ImageImage
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8140
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44beta [testing] is released!

Sun Dec 02, 2018 9:55 pm

Me too. I bet Europe MUM :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1794
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.44beta [testing] is released!

Mon Dec 03, 2018 4:14 am

Me too. I bet Europe MUM :)
I gave up betting on RouterOS v7 release dates many years ago after incurring significant losses :D

I do still hope it will be released at next years European MUM !
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1688
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.44beta [testing] is released!

Mon Dec 03, 2018 12:15 pm

tested beta version on CCR1072 ?
All deployments that are scheduled for deployment are stress-tested here on the table, it just happens to be bonding setup with pair of CCR1072, at that particular moment.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
osc86
just joined
Posts: 14
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.44beta [testing] is released!

Tue Dec 04, 2018 10:40 pm

I still see SAs are not removed when they expire. Why isn't it possible to remove single SAs?
 
heaven
just joined
Posts: 13
Joined: Mon Aug 15, 2016 12:14 pm

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 6:23 am

You could check the ARP table of the client to see if it has any strange entries (other IP addresses than the router, with the router's MAC address).
If so you need to debug the client.
I would not know a legitimate reason why proxy-arp would work and normal arp would not, when the client is correctly configured.
(correct subnet on the LAN interface and a default route via the router's IP address)
The same situation. In DHCP Server/Lease many ip addresses with router MAC address and other.
 
nkourtzis
Member Candidate
Member Candidate
Posts: 195
Joined: Tue Dec 11, 2012 12:56 am
Location: Greece

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 11:28 am

and bgp multithreading support when?

Normis has already answered this one: not in the foreseeable future. It appears that BGP is very hard to make multithreaded, due to transaction integrity issues. No vendor has done it, as far as I know. But he has also promised that v7 will bring significant improvements in BGP performance, even though it will still be single-threaded.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5696
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 4:49 pm

will still be single-threaded
kind of but not exactly
 
ivn
just joined
Posts: 6
Joined: Sun Mar 11, 2018 3:37 pm

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 7:25 pm

Hi! Can you please tell us when approximately will 6.44 be released? Several weeks or a mounth or maybe more?
Just waiting for "*) ike2 - added option to specify certificate chain;" sooo much :) Do not want to use beta in production.
Thanks!
 
raffav
Member Candidate
Member Candidate
Posts: 249
Joined: Wed Oct 24, 2012 4:40 am

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 7:49 pm

will still be single-threaded
kind of but not exactly
Enigmatic affirmation
:mrgreen:
 
Paternot
Member
Member
Posts: 444
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.44beta [testing] is released!

Wed Dec 05, 2018 9:44 pm

will still be single-threaded
kind of but not exactly
Enigmatic affirmation
:mrgreen:
Normis beeing Normis. :lol: :lol:

If I remember correctly, the BGP process will be broken in multiple threads. The system route update itself will be single threaded - but we will have multiple threads doing another tasks. Won't be perfect - but will be far better than what we have today.
 
strods
MikroTik Support
MikroTik Support
Posts: 1365
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44beta [testing] is released!

Thu Dec 06, 2018 11:26 pm

msatter - Usually there is no such thing as temporary "crash". If problem was related to network situation (just, for example, fully saturated link) or not enough resources (for example, full RAM), then it would be understandable. But if there is an actual service crashing, then this problem should not just disappear.
Extrems - Please provide supout file to support@mikrotik.com.
amt - Test is running just fine on any system that is powered by RouterOS.
Lakis, amt - Not in v6.44 :)
osc86 - Can you please provide supout file to support@mikrotik.com? We will look into this problem since this is not a common problem and SAs are usually removed.
heaven - Do you mean that there are leases that has DHCP servers MAC address? Can you provide an example?
ivn - At the moment this is a question that we can not answer. We will release this (and any other stable/long-term version) when there will be no critical, known crashes and new features will be finalized. Starting from v6.44 beta and rc versions can be released in testing channel so you will see rc when we will be finalizing things.

Who is online

Users browsing this forum: DenisPDA, mducharme and 3 guests