Community discussions

 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 471
Joined: Thu Dec 11, 2014 8:53 am

v6.42.9 [long-term] is released!

Mon Oct 01, 2018 10:39 am

RouterOS version 6.42.9 has been released in public "long-term" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.42.9 (2018-Sep-27 05:19):

Important note!!! Backup before upgrade!
RouterOS v6.41 and above contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus.
Please, note that downgrading below RouterOS v6.41 will not restore "master-port" configuration, so use backups to restore configuration on downgrade.

*) bridge - ignore tagged BPDUs when bridge VLAN filtering is used;
*) bridge - improved packet handling when hardware offloading is being disabled;
*) crs317 - fixed packet forwarding on bonded interfaces without hardware offloading;
*) crs326/crs328 - fixed packet forwarding when port changes states with IGMP Snooping enabled;
*) defconf - properly clear global variables when generating default configuration after RouterOS upgrade;
*) dns - fixed DNS cache service becoming unresponsive when active Hotspot server is present on the router (introduced in 6.42);
*) filesystem - fixed NAND memory going into read-only mode (requires "factory-firmware" >= 3.41.1 and "current-firmware" >= 6.43);
*) health - added missing parameters from export;
*) health - fixed voltage measurements for RB493G devices;
*) hotspot - properly update dynamic "walled-garden" entries when changing "dst-host";
*) ike2 - fixed rare authentication and encryption key mismatches after rekey with PFS enabled;
*) ike2 - improved subsequent phase 2 initialization when no child exist;
*) ipsec - improved invalid policy handling when a valid policy is uninstalled;
*) ipsec - improved stability when using IPsec with disabled route cache;
*) led - added "dark-mode" functionality for wsAP ac lite, RB951Ui-2nD, hAP, hAP ac lite and LtAP mini devices;
*) lte - fixed LTE interface not working properly after reboot on RBSXTLTE3-7;
*) lte - fixed LTE registration in 2G/3G mode;
*) netwatch - limit to read, write, test and reboot policies for Netwatch script execution;
*) ospf - improved link-local LSA flooding;
*) ospf - improved stability when originating LSAs with OSPFv3;
*) routerboard - fixed memory tester reporting false errors on IPQ4018 devices ("/system routerboard upgrade" required);
*) routerboard - show "boot-os" option only on devices that have such feature;
*) routerboot - fixed RouterOS booting on devices with particular NAND memory;
*) sniffer - made "connection", "host", "packet" and "protocol" sections read-only;
*) supout - added "files" section to supout file;
*) upgrade - fixed RouterOS upgrade process from RouterOS v5 on PowerPC;
*) upnp - improved UPnP service stability when handling HTTP requests;
*) userman - fixed "shared-secret" parameter requiring "sensitive" policy;
*) w60g - added "frequency-list" setting;
*) w60g - fixed interface LED status update on connection;
*) w60g - fixed random disconnects;
*) w60g - general stability and performance improvements;
*) webfig - fixed time interval settings not applied properly under "IP/Kid Control/Kids" menu;
*) webfig - fixed www service becoming unresponsive;
*) winbox - show "System/RouterBOARD/Mode Button" on devices that has such feature;
*) wireless - accept only valid path for sniffer output file parameter;
*) wireless - fixed "/interface wireless sniffer packet print follow" output;

What's new in 6.42.8 (2018-Sep-21 13:30):

(factory only release)

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
 
User avatar
Murmaider
Member Candidate
Member Candidate
Posts: 121
Joined: Fri Oct 30, 2015 10:10 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 10:54 am

Does this upgrade include the fix for the CCR-1072's that keep crashing when trying to run them at 1200Mhz ? (viewtopic.php?f=3&t=122525)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 11:14 am

Does this upgrade include the fix for the CCR-1072's that keep crashing when trying to run them at 1200Mhz ? (viewtopic.php?f=3&t=122525)
Did support@ tell you it should be fixed in this version? I can't see any signs of this in the topic. Also, this topic is for problems introduced in this version, not for some old problems — they should have separate topics.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 12:06 pm

This is a bad move! Now users of 6.40.x versions cannot install updates anymore.
We need full support of hw-accelerated VLAN switching in the new bridge at some locations before versions >6.40 can be used.
 
djdrastic
Member
Member
Posts: 305
Joined: Wed Aug 01, 2012 2:14 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 12:24 pm

Will monitor this thread . I understand the reasoning for the new bridge implemenation but I find some of the things still a bit alien to be honest and there still seems to be cases where there isn't 1:1 feature parity over the old way of doing things.

Have a boatload of 2011's that act as shaping L2 bridges that I will have to swing over and config scripts that need to be rewritten.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 12:42 pm

What is unknown string string "bugfix"? :) Where string "long term"?
1.png
You do not have the required permissions to view the files attached to this post.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 1:55 pm

After downgrading from 6.43.2 to 6.42.9 mikrotik ddns don't work. On router DDNS service ip address is valid. But any device don't connect to router because ip address is old. Note from mikrotik Wiki:
"Note: Since RouterOS v6.43 your device will use cloud2.mikrotik.com to communicate with the MikroTik's Cloud server. Older versions will use cloud.mikrotik.com to communicate with the MikroTik's Cloud server. "
If cloud2.mikrotik.com remember old ip address, how disable my old ip from cloud2.mikrotik.com and enable my new ip from cloud.mikrotik.com?
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 471
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 2:19 pm

You have to disable DDNS service on v6.43 before downgrading for it to work on older versions.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 2:25 pm

You have to disable DDNS service on v6.43 before downgrading for it to work on older versions.
Thank you :) But i don`t disable ddns service. I must upgrading to 6.43.2, disabling ddns and downgrading to 6.42.9 again? Or is there an easier way?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 2:50 pm

Yes, that is correct. If you jump between versions older than 6.43 and 6.43 or newer, then you must disable IP/Cloud DDNS feature first and re-enable it back after upgrade/downgrade.

!) cloud - reworked "/ip cloud ddns-enabled" implementation (suggested to disable service and re-enable after installation process);
 
User avatar
artz
MikroTik Support
MikroTik Support
Posts: 88
Joined: Tue Oct 17, 2017 5:51 pm
Location: Riga
Contact:

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 2:55 pm

This is a bad move! Now users of 6.40.x versions cannot install updates anymore.
We need full support of hw-accelerated VLAN switching in the new bridge at some locations before versions >6.40 can be used.
All VLAN related features are available in newer versions. they have been available since 6.41

An exception is with CRS3xx series switches, they did not certain switching features in 6.40.x yet so they were only added in 6.42 and 6.43

No features were removed, only one feature was renamed and that is the "master-port" that had various limitations, now it is replaced with a simple bridge configuration. Nothing else is changed regarding to VLAN configuration. You simply have to replace every configuration line that involves the master-port with a bridge, or better - let RouterOS convert your configuration when upgrading, it will automatically replace the master-port with a bridge. All VLAN switching configuration for non-CRS3xx is still under /interface ethernet switch. You should check this guide:
https://wiki.mikrotik.com/wiki/Manual:B ... _switching
Here you can see that VLANs (for non-CRS3xx) are still configured under /interface ethernet switch menu, master-port is replaced with a bridge, that is it.

In addition with 6.41 you now have the ability to filter VLANs on devices that do not support VLAN switching or do not have a built-in switch chip in a way that does not violates IEEE 802.1W and will be compatible with other switches in your network.

Will monitor this thread . I understand the reasoning for the new bridge implemenation but I find some of the things still a bit alien to be honest and there still seems to be cases where there isn't 1:1 feature parity over the old way of doing things.

Have a boatload of 2011's that act as shaping L2 bridges that I will have to swing over and config scripts that need to be rewritten.
Can you please share more details which configuration you are not able to use since 6.41?
 
tdw
Member Candidate
Member Candidate
Posts: 178
Joined: Sat May 05, 2018 11:55 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 3:09 pm

The warning about master-port configurations being updated to the new bridge configuration should really be repeated in the release notes now this version has changed track from current/stable to bugfix/long-term - people who have been using the bugfix branch may be unaware of the change introduced back in 6.41
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 471
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 3:43 pm

Thanks, we have added the bridge migration warning back for this release.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 4:14 pm

This is a bad move! Now users of 6.40.x versions cannot install updates anymore.
We need full support of hw-accelerated VLAN switching in the new bridge at some locations before versions >6.40 can be used.
All VLAN related features are available in newer versions. they have been available since 6.41

An exception is with CRS3xx series switches, they did not certain switching features in 6.40.x yet so they were only added in 6.42 and 6.43

No features were removed, only one feature was renamed and that is the "master-port" that had various limitations, now it is replaced with a simple bridge configuration. Nothing else is changed regarding to VLAN configuration. You simply have to replace every configuration line that involves the master-port with a bridge, or better - let RouterOS convert your configuration when upgrading, it will automatically replace the master-port with a bridge. All VLAN switching configuration for non-CRS3xx is still under /interface ethernet switch. You should check this guide:
https://wiki.mikrotik.com/wiki/Manual:B ... _switching
Here you can see that VLANs (for non-CRS3xx) are still configured under /interface ethernet switch menu, master-port is replaced with a bridge, that is it.
But when an existing configuration with master-port with VLAN subinterfaces on the master-port is converted to a single bridge with VLAN subinterfaces on the bridge and VLAN filtering, the result is that it is no longer hw-accelerated.
(on routers like RB2011 and RB750)
Is that ever going to be fixed? Or do you recommend keeping the switch configuration and not use the bridge VLAN filtering?
 
mkx
Forum Guru
Forum Guru
Posts: 2778
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 4:30 pm

But when an existing configuration with master-port with VLAN subinterfaces on the master-port is converted to a single bridge with VLAN subinterfaces on the bridge and VLAN filtering, the result is that it is no longer hw-accelerated.
This is simply not true, at least not on RB951G. In old config, you had VLAN filtering configured explicitly in /interface ethernet switch, then a master port and vlan interfaces on that master port. Change from 6.40 to 6.42 converts master port to bridge, all the rest (VLAN filtering on switch chip and vlan interfaces now hanging off the bridge) remain the same. Switching is still done in hardware as it used to be. If something was not possible due to switch chip limitations, it still isn't possible ... not in the old manner nor HW-offloaded in the new manner.

With ROS > 6.40 it is possible to use "new" bridge vlan-filtering, but it is not mandatory to do it.
New way lacks HW offload support for non-trivial tasks, but it allows things to be done which were not possible previously on some devices due to lack of support in hardware.
BR,
Metod
 
dvm
just joined
Posts: 12
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 4:47 pm

No features were removed, only one feature was renamed and that is the "master-port" that had various limitations, now it is replaced with a simple bridge configuration. Nothing else is changed regarding to VLAN configuration.
So if there are no any master-ports in my 6.40.9 setup, then upgrade to 6.42.9 should not cause any problems?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 4:51 pm

So if there are no any master-ports in my 6.40.9 setup, then upgrade to 6.42.9 should not cause any problems?
Generally, it should not cause problems at all :)
This is simply not true, at least not on RB951G. In old config, you had VLAN filtering configured explicitly in /interface ethernet switch, then a master port and vlan interfaces on that master port. Change from 6.40 to 6.42 converts master port to bridge, all the rest (VLAN filtering on switch chip and vlan interfaces now hanging off the bridge) remain the same. Switching is still done in hardware as it used to be. If something was not possible due to switch chip limitations, it still isn't possible ... not in the old manner nor HW-offloaded in the new manner.

With ROS > 6.40 it is possible to use "new" bridge vlan-filtering, but it is not mandatory to do it.
New way lacks HW offload support for non-trivial tasks, but it allows things to be done which were not possible previously on some devices due to lack of support in hardware.
Well, when you switch on VLAN FIltering, Hw. Offload switches off. So, you say it's just cosmetic error, and everything is still hardware-accelerated?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 4:57 pm

With ROS > 6.40 it is possible to use "new" bridge vlan-filtering, but it is not mandatory to do it.
New way lacks HW offload support for non-trivial tasks, but it allows things to be done which were not possible previously on some devices due to lack of support in hardware.
I converted an RB2011 router which had VLAN switching to a bridge according to https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering and it lost the hw-accel while many other routers which had switching but no VLAN had hw-accel after that.
So apparently the bridge only can do hw-accel without VLAN, which is weird because the hardware clearly can do it (this was only on ports 1-5 on that RB2011).
 
mkx
Forum Guru
Forum Guru
Posts: 2778
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 5:07 pm

@Chupaka and @pe1chl: the way 6.40 config is converted, there's no sign of bridge vlan-filtering. Bridge acts as a dummy (VLAN unaware) switch. VLAN filtering is done by switch chip in hardware.
Its only after you start configuring VLANs on bridge (transforming it to VLAN-aware switch) when yiu loose HW offloading.
BR,
Metod
 
storp
newbie
Posts: 48
Joined: Tue Nov 24, 2015 2:53 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 7:57 pm

Replaced running v6.43.2 on RB1100Hx2, hAP and a few wAP AC and cAP without any major problems. Had some issues with detect-internet enabled interface and dhcp-client. I removed the interface from the interface list and recreated the dhcp client and got it working.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 01, 2018 11:27 pm

I tried using bridge on my 2011 before and it was too slow.

Does this mean I can no longer update my router?
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 12:47 am

I tried using bridge on my 2011 before and it was too slow.

Does this mean I can no longer update my router?
It shouldn't be slower than before as long as hardware-offload is working. If hardware offload works, performance should be the same as 6.40.x.

If you find there is a big performance drop, and hardware offload is working for the ports, open up a support ticket so that they can fix it.
 
User avatar
chechito
Forum Guru
Forum Guru
Posts: 1681
Joined: Sun Aug 24, 2014 3:14 am
Location: Bogota Colombia
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:29 am

With ROS > 6.40 it is possible to use "new" bridge vlan-filtering, but it is not mandatory to do it.
New way lacks HW offload support for non-trivial tasks, but it allows things to be done which were not possible previously on some devices due to lack of support in hardware.
I converted an RB2011 router which had VLAN switching to a bridge according to https://wiki.mikrotik.com/wiki/Manual:I ... _Filtering and it lost the hw-accel while many other routers which had switching but no VLAN had hw-accel after that.
So apparently the bridge only can do hw-accel without VLAN, which is weird because the hardware clearly can do it (this was only on ports 1-5 on that RB2011).
at this moment yes you need to run bridge without vlans to maintain hw accel in this devices

keep your old vlan configuration on the switch menu, and you are done

will be nice if mikrotik makes this vlan on bridge work with hw accel on atheros mediatek and realtek 5 port switches integrated on routerboards
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:40 am

Yes, there are some major misunderstandings regarding VLANs with hardware offload in 6.41+. The bottom line is that if you pretend that the new bridge VLAN options do not exist and do not use them, and you set up VLANs the old way using the switch (which still works), you should continue to have hardware offload work for VLANs with the same performance as 6.40.x and earlier.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:43 am

The upgrade does not work.

All the firewall configuration is deleted and I lose connectivity.

I have to set a fixed IP configuration on the computer to be able to use Winbox.

Good thing I have partitions. I rolled back (bugfix).

Also, this update does not appear on the bugfix channel. I had to upload the package.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:46 am

The upgrade does not work.

Also, this update does not appear on the bugfix channel. I had to upload the package.
That's strange, it appears on the bugfix channel for me in "check for updates" on the device.

And it certainly should not delete the firewall config, you should open a support ticket. That sounds like a major issue potentially.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:50 am

Maybe the firewall config is not deleted, just Winbox not showing it, as sometimes everything appears empty.

Winbox also disconnects frequently. I cannot even upload.

I always use Webfig, but I cannot connect even with the fixed IP.

I was on firmware 3.33 (2011).

I upgraded the firmware now.
Last edited by vortex on Tue Oct 02, 2018 2:56 am, edited 1 time in total.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:55 am

Maybe the firewall config is not deleted, just Winbox not showing it, as sometimes everything appears empty.

Winbox also disconnects frequently. I cannot even upload.

I always use Webfig, but I cannot connect even with the fixed IP.
Are you using MAC winbox to connect currently, and it is something showing things empty? MAC winbox requires that your admin device supports an L2MTU the same as MikroTik (mikrotik default is 1598 on most devices), if your system only supports a 1518 L2MTU or something smaller like that, or you are connected through an MTU limited switch, then larger frames passed by MAC winbox will be dropped and then you get empty windows and disconnects.

Did you already have a bridge on your device prior to the upgrade? I believe the default for 6.40.x and previous for the RB2011 was to have a bridge named "bridge" with ports ether2-master and ether6-master, is that what you had configured on the device prior to upgrade?
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 2:59 am

I have 1500 as MTU.

I added that I was in 3.33 firmware.

I have deactivated bridges.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:01 am

I have 1500 as MTU.
Are you sure? The default MTU (i.e. layer 3 MTU is 1500) but the default Layer 2 MTU is 1598 (unless you have changed the layer 2 MTU from the default), since MAC winbox is layer 2 it will send the larger 1598 frames and those may get dropped on their way to the Winbox client on your computer. Layer 3 MTU (just called "MTU") and Layer 2 MTU are two different settings.

Also if you had bridges that were connected to the master ports but were disabled, it's possible that the conversion routine failed in this case. Either way I'm sure MikroTik would like to fix this, so best to open a support ticket.
Last edited by mducharme on Tue Oct 02, 2018 3:07 am, edited 2 times in total.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:04 am

I changed the L2 MTU to 1500. I think because of the Airport Extreme.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:11 am

I changed the L2 MTU to 1500. I think because of the Airport Extreme.
Can you clarify what you meant by deactivated bridges - did you have a bridge created but it was disabled? Maybe this is why the conversion failed, if it wasn't expecting this.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:15 am

I set the L2 MTU to default. I think it fixed Winbox because I could upload.

I meant I created bridges which I deactivated. I deleted them and will try to upgrade again.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:39 am

The L2 MTU did not fix Winbox. I had used IP to upload. There are no switches.

I deleted all the Bridge config, and no bridge was added. The Firewall config still shows empty. And no connectivity.

I rolled back again.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:43 am

The L2 MTU did not fix Winbox. I had used IP to upload. There are no switches.

I deleted all the Bridge config, and no bridge was added. The Firewall config still shows empty. And no connectivity.

I rolled back again.
Send MikroTik a supout from your device, I'm sure they will want to fix the auto convert because it will help prevent other customers from having issues.
 
OldSwitchConfigLiker
just joined
Posts: 12
Joined: Tue Aug 29, 2017 5:34 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 4:38 am

Well it's at least clear what MT is meaning with 'long-term' now... Really not so long-term apparently.

Binning 6.40.xxx is a big mistake, since it is simply not in the interest of the business customers of MT, only in the interest of the enthusiasts.
It has been discussed at length here before 'why', and I'm not going to repeat it here.
But the master-ports change is too big of a change to just sweep it under the rug just like that. And provisions for it's successor are just not all in place yet.

For the readers that didn't read the previous posts: YES you can do all with a bridge, and YES I know how. But that is beside the point.
Point is that the old function is binned too soon for industrial/production environments. And auto-convert, even when it works, is just not enough in those cases. In these environments the upgrade requires extensive investments in testing, documentation, re-certification....
In general, what those environments needs is just a bugfix/security-patching branch, that is really "long term" (at least a few years).

I had (a little) good hope MT had finally gone in the right direction, but this release basically killed that dream.
With this move MT made it clear that, despite also producing devices for the industry, it will follow the path of ONLY making a RoS that is state of the art with latest features, bells and whistles. Which is of course superb from an engineers point of view. But totally unsuited from business-customers standpoint.

If you want to continue to use a perfectly fine-working config with master-ports, you will loose security from now on. (after only 10 months of "bugfix/longterm"...).
Only other option is that you follow the MT path and get the new version force-fed into your company, and invest again a lot of time and money in a setup that might just reach the same level, but possibly also might not. And in another 10 months again, and ....so on. Only to keep your RoS safe.
Very disappointing !!
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 5:34 am

Point is that the old function is binned too soon for industrial/production environments. And auto-convert, even when it works, is just not enough in those cases. In these environments the upgrade requires extensive investments in testing, documentation, re-certification....
In general, what those environments needs is just a bugfix/security-patching branch, that is really "long term" (at least a few years).
I would contact them via email directly about this, in the forum it might escape notice.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 11:11 am

Well it's at least clear what MT is meaning with 'long-term' now... Really not so long-term apparently.
Well, technically speaking, it's still "bugfix", not "long-term" - it will become long-term after v6.44 :) So 6.42 can be the first "real" long-term. Or not be :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:32 pm

Well, technically speaking, it's still "bugfix", not "long-term"
It is not true :)
1.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
eworm
Member
Member
Posts: 376
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:44 pm

Well, technically speaking, it's still "bugfix", not "long-term"
It is not true :)
Try this:
[admin@MikroTik] > :put ("Version " . [ / system package update get latest-version ] . " is channel " . [ / system package update get channel ] . "!");
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:49 pm

Try this:
Yes. But this topic is named long-term too. Confusion from mikrotik :)
 
User avatar
eworm
Member
Member
Posts: 376
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 3:51 pm

Try this:
Yes. But this topic is named long-term too. Confusion from mikrotik :)
That's true. But I think RouterOS itself will do the change with version 6.44. Any official statement on this?
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
dvm
just joined
Posts: 12
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 4:39 pm

Try this:
Yes. But this topic is named long-term too. Confusion from mikrotik :)
Console:
longterm.JPG
You do not have the required permissions to view the files attached to this post.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 5:55 pm

I managed to upgrade by removing the master ports and doing the bridge configuration myself.

But now routing is too slow.

I have one bridge on the gigabit chip and 2 bridges on the fast chip.

I will check at another time, as it shows only about 10% slower.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:12 pm

I have one bridge on the gigabit chip and 2 bridges on the fast chip.
If you have two bridges on one chip it will only be able to hardware accelerate one of those two bridges (this was also the case before, where you could only have one master port per switch chip).
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:17 pm

I thought that was the case, but the stuff on switch2 does not have to be fast.

I found a speedtest server where I hit my contracted bandwidth.

How do you check if hardware acceleration is enabled?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:22 pm

If you have two bridges on one chip it will only be able to hardware accelerate one of those two bridges (this was also the case before, where you could only have one master port per switch chip).
Wrong, both switch chips are have hardware acceleration for traffic that happens within them, if you need traffic between switch chips then it goes through processor.

You need to make sure that hw=yes enabled on all your bridge ports and you will see "H" flag in front of them
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:26 pm

Wrong
What? You are saying on a 2011 with 6.40.x you could have 4 master ports? Two master ports per switch chip? I have never seen this work with a MikroTik SOHO device, they normally only support one master port per switch chip (so 2 master ports on the 2011). And I could similarly have four bridges on a 2011 with 6.41+ and have HW accel on all four bridges simultaneously? I doubt this to be the case, but I don't have a 2011 at home to test on.

Please note that I clearly wrote "two bridges on one switch chip" and not "two bridges on the device", and by that I meant if you have three bridges on the device all three will not be hw accelerated, only two of them could be at most. But you say this is wrong?
Last edited by mducharme on Tue Oct 02, 2018 6:38 pm, edited 2 times in total.
 
Traveller
just joined
Posts: 24
Joined: Thu Apr 05, 2018 10:12 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:28 pm

Console:
Wow. Mikrotik programmers use telnet and do not use winbox :)
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1721
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:40 pm


What? You are saying on a 2011 with 6.40.x you could have 4 master ports? Two master ports per switch chip? I have never seen this work with a MikroTik SOHO device, they normally only support one master port per switch chip (so 2 master ports on the 2011). And I could similarly have four bridges on a 2011 with 6.41+ and have HW accel on all four bridges simultaneously? I doubt this to be the case, but I don't have a 2011 at home to test on.

Please note that I clearly wrote "two bridges on one switch chip" and not "two bridges on the device", and by that I meant if you have three bridges on the device all three will not be hw accelerated, only two of them would be. But you say this is wrong?
Reading is underrated, as statement to have 2x bridges on the same switch chip on RB2011 seemed too unrealistic, my brain didn't registered that, why the hell would you need setups like this, if you can have it all in one hw bridge/switch and configure port isolation?
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:44 pm

Reading is underrated, as statement to have 2x bridges on the same switch chip on RB2011 seemed too unrealistic, my brain didn't registered that, why the hell would you need setups like this, if you can have it all in one hw bridge/switch and configure port isolation?
I do not know why @vortex has this set up, but that is what he has -- three bridges in total on the device, one bridge on one switch chip and two bridges on the other.
 
SnakeSK
just joined
Posts: 16
Joined: Fri Mar 09, 2018 1:30 am

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:47 pm

Does this upgrade include the fix for the CCR-1072's that keep crashing when trying to run them at 1200Mhz ? (viewtopic.php?f=3&t=122525)
Did support@ tell you it should be fixed in this version? I can't see any signs of this in the topic. Also, this topic is for problems introduced in this version, not for some old problems — they should have separate topics.
if something is considered bugfix, it should be stable on all devices. He made a valid point, so please don´t be butthurt by his question. It definetely should´ve been patched in this release, as its a long term release.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 6:58 pm

if something is considered bugfix, it should be stable on all devices. He made a valid point, so please don´t be butthurt by his question. It definetely should´ve been patched in this release, as its a long term release.
The first message of the topic:
Please keep this forum topic strictly related to this concrete RouterOS release.
Also, in the topic mentioned, people can't answer simple questions, so I prefer they speak about nothing in that topic rather than flooding here.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 02, 2018 7:43 pm

I figured out how to enable hardware acceleration, but I have to check at another time.
 
mblfone
just joined
Posts: 14
Joined: Sun Feb 02, 2014 2:22 am

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 4:34 am

Hello,

I am still confused about the layer 2 routing issue with this upgrade. I have a CCR1016-12G with which we use layer 2 routing. No switch button shows within Winbox. This router is also not listed in the Manual:Switch Chip Features article in the wiki. Although I can go to "/interface ethernet switch port" in the terminal, I don't believe setting changes will occur as I don't believe this router has a switch chip. I am assuming that upgrading should still go nicely?

Presently we add a VLAN interface with the VLAN ID to a bonded LACP interface which connects physically to our switch. IP address subnets are then added to the VLAN interfaces. No bridges are used at all in our present configuration.

I have a backup router and will probably try that first before committing fully to the 6.42.9 long term version.

Any thoughts or comments are appreciated!

Thanks.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 5:51 am

@mblfone: You should create separate topic about your routing/switching as it is unrelated to this RouterOS release.
Anyway shortly said - CCR1016-12G is router, not switch. It does not have switch chip so you cant see "switch" button and it can't be listed among other switches on "switch chip features" page. You can manage Layer 2 features via Bridge menu.
Due to that Bridge/switch changes will have no effect on your CCR.
Last edited by vecernik87 on Thu Oct 04, 2018 6:19 am, edited 1 time in total.
 
aidan
newbie
Posts: 28
Joined: Thu Jun 25, 2015 12:48 am

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 5:56 am

Hello,

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?

Thank you.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 5:59 am

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?
I noticed this as well, threw me off at first, not that I use the default config. But I imagine this will effect others.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 9:06 am

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?
What type of router is that? The above has always been the default on the more enterprise-oriented CCR routers, the detailed config that you describe was always only on the smaller home-oriented routers.
 
feris
just joined
Posts: 11
Joined: Tue May 16, 2017 3:58 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 12:11 pm

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?
What type of router is that? The above has always been the default on the more enterprise-oriented CCR routers, the detailed config that you describe was always only on the smaller home-oriented routers.
Just tested on RB750Gr3, 6.42.9 default configuration script just sets IP on ether1. Version 6.42.7 have full default configuration, fw, dhcp, bridge etc.
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 98
Joined: Thu Jun 21, 2018 9:29 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 12:46 pm

How is it possible that I'm still able to login with my password after downgrading from 6.43.2 to 6.42.9?
I thought 6.43 changed the authentication API in order to be able to save passwords as hashes and not as plaintext. However, the fact that I'm still able to login after downgrade to 6.42 clearly indicates that the plaintext password file was not replaced/deleted and could still be extracted by future "read all files" security holes leading to the same exposure of passwords as just witnessed.
 
andriys
Forum Guru
Forum Guru
Posts: 1130
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 1:00 pm

... that the plaintext password file was not replaced/deleted ...

Sure it was not. Do you read the release notes?
What's new in 6.43 (2018-Sep-06 12:44):
...
*) user - all passwords are now hashed and encrypted, plaintext passwords are kept for downgrade (will be removed in later upgrades);
 
whatever
Frequent Visitor
Frequent Visitor
Posts: 98
Joined: Thu Jun 21, 2018 9:29 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 2:13 pm

Must have missed that, thank you for pointing it out.
 
Nivalis
just joined
Posts: 3
Joined: Thu Oct 04, 2018 3:30 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 4:20 pm

Hello, I have some RB 750UP routers and i try to update packages from 6.40.9 to 6.42.9. This update work fine. After i try to update firmware from 3.41 to 6.42.9 and my router won't work. Eth1 led is very fast blinking. And don't work all interfaces (i don't get wan ip-address from my dhcp-server and all lan users - don't get lan addresses). If I reset my router I can login to router through mac-address with help winbox neighbors and I saw what ip address mikrotik is 0.0.0.0/0 and no start dhcp-server. I try to netinstall 6.42.9 - its work. Then i try to update to 6.43.2 packages - work fine, but firmware broke my router too and very fast blinking eth1 port again.
 
mpadmin
just joined
Posts: 18
Joined: Sun May 22, 2016 3:48 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 7:41 pm

I like this long-term version and it works fine for me. I have a small problem with my auto-update script, that updates all my devices (only to bugfix channel). Until now it works just fine with RouterOS and Routerboard firmware updates, but now this code asks for [y/n]...
/system routerboard
   :if ( [get current-firmware] != [get upgrade-firmware]) do={ 
      ## New version of firmware available, let's upgrade
      :delay 15s;
      upgrade
}
Any chance to upgrade firmware from script without this question?
 
User avatar
eworm
Member
Member
Posts: 376
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 7:49 pm

I like this long-term version and it works fine for me. I have a small problem with my auto-update script, that updates all my devices (only to bugfix channel). Until now it works just fine with RouterOS and Routerboard firmware updates, but now this code asks for [y/n]...
/system routerboard
   :if ( [get current-firmware] != [get upgrade-firmware]) do={ 
      ## New version of firmware available, let's upgrade
      :delay 15s;
      upgrade
}
Any chance to upgrade firmware from script without this question?
This should work when running from scheduler. If you want to reboot from terminal without confirmation replace "upgrade" with:
/execute "/system reboot";
Edit: Of course this should read:
/execute "/system routerboard upgrade";
Last edited by eworm on Thu Oct 04, 2018 8:48 pm, edited 1 time in total.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
mpadmin
just joined
Posts: 18
Joined: Sun May 22, 2016 3:48 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 04, 2018 8:30 pm

I like this long-term version and it works fine for me. I have a small problem with my auto-update script, that updates all my devices (only to bugfix channel). Until now it works just fine with RouterOS and Routerboard firmware updates, but now this code asks for [y/n]...
/system routerboard
   :if ( [get current-firmware] != [get upgrade-firmware]) do={ 
      ## New version of firmware available, let's upgrade
      :delay 15s;
      upgrade
}
Any chance to upgrade firmware from script without this question?
This should work when running from scheduler. If you want to reboot from terminal without confirmation replace "upgrade" with:
/execute "/system reboot";
Thank you eworm! My mistake - it works fine from scheduler. It doesn't work only with /system script run ...
 
MonkeyDan
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Fri Dec 29, 2017 8:41 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 05, 2018 1:54 am

For Wireless Wires, v6.42.9 is a vast improvement over v6.42.5 through v6.42.7 and v6.43.x which seems to exhibit the same problems of repeated disconnections.
Good work, Mikrotik!
 
bennyh
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Fri Mar 03, 2017 12:37 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 05, 2018 9:06 am

For Wireless Wires, v6.42.9 is a vast improvement over v6.42.5 through v6.42.7 and v6.43.x which seems to exhibit the same problems of repeated disconnections.
Good work, Mikrotik!
Older MIPSBE models are stable too in 802.11 mode with 6.42.9, I swiched back from buggy laggy NV2, and less ping loss, low latency for a long range (11km) PtP connection.
Nstreme was the best when we started to use the long range PtP, and 802.11 was unstable. After years and updates Nstreme became unstable (after channel changes too), I had to switch to NV2 what was stable but slow, but after upgrading 6.42.9, I tried 802.11 and after 3 days it seems stable and faster then nv2.
 
sophitus
just joined
Posts: 11
Joined: Sun Jul 23, 2017 10:04 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 05, 2018 10:13 am

I got mem leak reboot again on 6.42.9. 6.42.7 was fine. Also see "ipsec phase1 negotiation failed due to time up" multiple times right before reboot with "out of memory condition". Anybody else having this issue on hap ac?
 
dvm
just joined
Posts: 12
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.42.9 [long-term] is released!

Sat Oct 06, 2018 4:21 pm

Just tested on RB750Gr3, 6.42.9 default configuration script just sets IP on ether1. Version 6.42.7 have full default configuration, fw, dhcp, bridge etc.
I can confirm this on RB951Ui-2HnD, hAP ac^2.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Sat Oct 06, 2018 5:49 pm

No features were removed, only one feature was renamed and that is the "master-port" that had various limitations, now it is replaced with a simple bridge configuration. Nothing else is changed regarding to VLAN configuration. You simply have to replace every configuration line that involves the master-port with a bridge, or better - let RouterOS convert your configuration when upgrading, it will automatically replace the master-port with a bridge.
I decided to try it on one router which had 5 ports with a single master-port on the first switch of an RB2011 running 6.40.9.
There were several VLAN interfaces all bound to ether2 which was the master port, and a switch chip config with 8 VLANs some tagged and some untagged on the ports.
No bridge at all on this router, the ports on the second switch are used as independent (link) ports.

I upgraded to 6.42.7 but it did nothing to auto-convert (except removing the master-port setting).
So I tried again (copied old version from 2nd partition) with 6.41.4 but same thing.

Fortunately I could still access it via a link, so I manually created a bridge and made the ports on switch1 member of it, and manually moved all VLANs from ether2 to bridge to get things running again. Then I upgraded to 6.42.9.
It did not become a disaster because the router is in a closed network with many links and no NAT and default-deny incoming on the links.

What is the reason there was no auto conversion? What are the conditions for this auto conversion to happen?
 
mkx
Forum Guru
Forum Guru
Posts: 2778
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42.9 [long-term] is released!

Sat Oct 06, 2018 5:58 pm

My guess, based on my reputably bad memory, is as follows: by default there used to be single bridge present even with ROS 6.40 and earlier, if nothing else it would bridge the master port and wireless interface. Or, in case of 2011, it would bridge both master ports. So I guess upgrade procedure actually expects to find that bridge and only adds slave ports to the same bridge. In your case, that bridge was not there and coversion automagic did not create one.

I may well be wrong on the above.
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Sat Oct 06, 2018 7:53 pm

It is true that there is a bridge by default but in the past I have converted RB750 and RB750G routers which by default have no bridge, and it created the bridge.
But those did not have VLANs on the switch, only the default LAN with a couple of ports and a master-port where the IP address is configured.
I expected that the RB2011 would be handled the same. But maybe it is like you said and it only works for routers that are running almost default configuration.
I was lucky that I was not configuring it from the LAN side or I would be locked out. I think I have seen other postings from people that were locked out due to upgrade.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Sat Oct 06, 2018 9:36 pm

But maybe it is like you said and it only works for routers that are running almost default configuration.
I somewhat doubt that this is what MikroTik intended. I would send them your previous config so they can try to figure out why their conversion routine failed with your setup. Maybe they can improve the auto conversion process.
 
recepkarapinar
just joined
Posts: 5
Joined: Sun Feb 18, 2018 8:09 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 10, 2018 8:58 pm

hiya friend i had 1036 on my office on client i had lite5 i did update both 6,42.9 long term. when i update lite i cant make btest to lite5 . before it was 6.40.4 stable. anyone has idea why i cant do btest
 
kadhim09
newbie
Posts: 38
Joined: Sat Oct 29, 2016 10:11 am
Location: iraq/samawa

Re: v6.42.9 [long-term] is released!

Thu Oct 11, 2018 7:11 pm

RouterOS version 6.42.9 has been released in public "long-term" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.42.9 (2018-Sep-27 05:19):

Important note!!! Backup before upgrade!
RouterOS v6.41 and above contains new bridge implementation that supports hardware offloading (hw-offload).
This update will convert all interface "master-port" configuration into new bridge configuration, and eliminate "master-port" option as such.
Bridge will handle all Layer2 forwarding and the use of switch-chip (hw-offload) will be automatically turned on based on appropriate conditions.
The rest of RouterOS Switch specific configuration remains untouched in usual menus.
Please, note that downgrading below RouterOS v6.41 will not restore "master-port" configuration, so use backups to restore configuration on downgrade.

*) bridge - ignore tagged BPDUs when bridge VLAN filtering is used;
*) bridge - improved packet handling when hardware offloading is being disabled;
*) crs317 - fixed packet forwarding on bonded interfaces without hardware offloading;
*) crs326/crs328 - fixed packet forwarding when port changes states with IGMP Snooping enabled;
*) defconf - properly clear global variables when generating default configuration after RouterOS upgrade;
*) dns - fixed DNS cache service becoming unresponsive when active Hotspot server is present on the router (introduced in 6.42);
*) filesystem - fixed NAND memory going into read-only mode (requires "factory-firmware" >= 3.41.1 and "current-firmware" >= 6.43);
*) health - added missing parameters from export;
*) health - fixed voltage measurements for RB493G devices;
*) hotspot - properly update dynamic "walled-garden" entries when changing "dst-host";
*) ike2 - fixed rare authentication and encryption key mismatches after rekey with PFS enabled;
*) ike2 - improved subsequent phase 2 initialization when no child exist;
*) ipsec - improved invalid policy handling when a valid policy is uninstalled;
*) ipsec - improved stability when using IPsec with disabled route cache;
*) led - added "dark-mode" functionality for wsAP ac lite, RB951Ui-2nD, hAP, hAP ac lite and LtAP mini devices;
*) lte - fixed LTE interface not working properly after reboot on RBSXTLTE3-7;
*) lte - fixed LTE registration in 2G/3G mode;
*) ospf - improved link-local LSA flooding;
*) ospf - improved stability when originating LSAs with OSPFv3;
*) routerboard - fixed memory tester reporting false errors on IPQ4018 devices ("/system routerboard upgrade" required);
*) routerboard - show "boot-os" option only on devices that have such feature;
*) routerboot - fixed RouterOS booting on devices with particular NAND memory;
*) sniffer - made "connection", "host", "packet" and "protocol" sections read-only;
*) supout - added "files" section to supout file;
*) upgrade - fixed RouterOS upgrade process from RouterOS v5 on PowerPC;
*) upnp - improved UPnP service stability when handling HTTP requests;
*) userman - fixed "shared-secret" parameter requiring "sensitive" policy;
*) w60g - added "frequency-list" setting;
*) w60g - fixed interface LED status update on connection;
*) w60g - fixed random disconnects;
*) w60g - general stability and performance improvements;
*) webfig - fixed time interval settings not applied properly under "IP/Kid Control/Kids" menu;
*) webfig - fixed www service becoming unresponsive;
*) winbox - show "System/RouterBOARD/Mode Button" on devices that has such feature;
*) wireless - accept only valid path for sniffer output file parameter;
*) wireless - fixed "/interface wireless sniffer packet print follow" output;

What's new in 6.42.8 (2018-Sep-21 13:30):

(factory only release)

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
the bad block disappear from the resourse in system tap
 
nescafe2002
Long time Member
Long time Member
Posts: 617
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.42.9 [long-term] is released!

Thu Oct 11, 2018 9:34 pm

the bad block disappear from the resourse in system tap

Wow, do you really have to quote the full change log to mention this?

Either report your findings to support as stated, or add some details to let us check it out (e.g. what RB model).
 
bhickey
just joined
Posts: 18
Joined: Fri Feb 17, 2006 3:21 am

Re: v6.42.9 [long-term] is released!

Sat Oct 13, 2018 10:49 am

Upgrading from 6.40.8 to 6.42.9 on a hEX :

1. Master-slave configs disappeared and there was no new bridge created in their place. This brought down all devices on a switch connected to one of the slave ports and required an onsite visit to investigate. Config details before upgrade were :

/interface ethernet
set [ find default-name=ether4 ] master-port=ether5-LAN name=\
ether4-slave-local

2. I manually created the bridge with ether4 & ether5 ports and I now get log messages "... bridge port received packet with own address as source address ... probably loop"

3. IP/Cloud stopped working. After disabling and re-enabling, it eventually started working again
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: v6.42.9 [long-term] is released!

Sat Oct 13, 2018 8:00 pm

Upgrading from 6.40.8 to 6.42.9 on a hEX

I've upgraded mine 'Tiks, but I eventually did a reset, just to be safe.
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Jul 08, 2010 10:18 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 16, 2018 5:53 pm

Hello,

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?

Thank you.
I can confirm this on a 951G, a 450G, and an old 751U.
 
spsurajit
just joined
Posts: 1
Joined: Tue Oct 16, 2018 9:51 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 16, 2018 10:07 pm

mickrotik rb750r2 hex lite Router User Manager availability?

Setting up User Manager, but logging hotspot RADIUS server is not responding message
Solve This Problem
 
skullzaflare
just joined
Posts: 20
Joined: Tue Apr 12, 2016 12:01 am

Re: v6.42.9 [long-term] is released!

Thu Oct 18, 2018 6:12 pm

Has anyone run into an issue with ports randomly leaving the bridge to go "unknown" interface?
We upgraded 1100 customer after a small test batch, all almost 2 weeks ago. We are having random customers call and finding the wlan or another port leaving the bridge, and usually when it does it also kills dhcp that was on the bridge. SOMETIMES internal address also goes "unknown"

Yes the firmwares are also upgraded with software (2 weeks ago now)
This week alone we have had 73 people call in with this issue

No we were not using master-port
Routers in complaint have been all 951 or 952. I think we had one 941. No RBD52's since they are on 6.43.2 (wont go lower.)
We have not flashed any tower sites or customer RB2011's yet
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Jul 08, 2010 10:18 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 18, 2018 6:52 pm

I had a similar issue with a RB751U. Ether1 suddenly became a member of the bridge. This was not a result of the upgrade process as I configured it from scratch on 6.42.9. There were other random changes as well.
Has anyone run into an issue with ports randomly leaving the bridge to go "unknown" interface?
We upgraded 1100 customer after a small test batch, all almost 2 weeks ago. We are having random customers call and finding the wlan or another port leaving the bridge, and usually when it does it also kills dhcp that was on the bridge. SOMETIMES internal address also goes "unknown"

Yes the firmwares are also upgraded with software (2 weeks ago now)
This week alone we have had 73 people call in with this issue

No we were not using master-port
Routers in complaint have been all 951 or 952. I think we had one 941. No RBD52's since they are on 6.43.2 (wont go lower.)
We have not flashed any tower sites or customer RB2011's yet
 
jukka
just joined
Posts: 1
Joined: Sun Oct 21, 2018 2:46 am

Re: v6.42.9 [long-term] is released!

Sun Oct 21, 2018 3:10 am

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?
What type of router is that? The above has always been the default on the more enterprise-oriented CCR routers, the detailed config that you describe was always only on the smaller home-oriented routers.
I noticed the same behaviour on a hAP AC (RouterBOARD 962UiGS-5HacT2HnT).

The old factory default configuration was quite useful since it required at most a few adjustments to create a working WiFi AP / router for the typical home scenario. The new factory default configuration on the other hand requires quite some manual work until you reach the same functionality...
 
amorsen
newbie
Posts: 31
Joined: Wed Jun 13, 2007 2:17 pm

Re: v6.42.9 [long-term] is released!

Mon Oct 22, 2018 6:09 pm

So, the old master-port code is gone. Now we are stuck with bridge interfaces being always up, whether there are any ports up in the switch. I have posted repeatedly why this is unacceptable.

Please bring back security fixes for the 6.40.x releases.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Mon Oct 22, 2018 10:26 pm

I have posted repeatedly why this is unacceptable.
To be honest, never saw such posts. Any links?

Anyway, have you reported to support@mikrotik.com?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1813
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 4:58 am

Any chance of 6.42.10 with the IP Traffic Flow NAT fixes ?
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
andriys
Forum Guru
Forum Guru
Posts: 1130
Joined: Thu Nov 24, 2011 1:59 pm
Location: Kharkiv, Ukraine

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 10:31 am

Any chance of 6.42.10 with the IP Traffic Flow NAT fixes ?
Can you provide more details (or a link) of what's broken, please?
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 642
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 12:31 pm

Any chance of 6.42.10 with the IP Traffic Flow NAT fixes ?
Can you provide more details (or a link) of what's broken, please?
I am not him but this is pretty clear:
6.43.4 Stable - https://mikrotik.com/download/changelog ... 33626d2540
*) traffic-flow - fixed post NAT port reporting;
 
ivanfm
newbie
Posts: 46
Joined: Sun May 20, 2012 5:07 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 1:49 pm

I have posted repeatedly why this is unacceptable.
To be honest, never saw such posts. Any links?

Anyway, have you reported to support@mikrotik.com?
I have found a single post about this : viewtopic.php?f=21&t=123936&p=626322#p626322

It's a valid use case. But I agree with you, this should be directed to support@mikrotik.com
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1813
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 2:10 pm

Any chance of 6.42.10 with the IP Traffic Flow NAT fixes ?
Can you provide more details (or a link) of what's broken, please?
I am not him but this is pretty clear:
6.43.4 Stable - https://mikrotik.com/download/changelog ... 33626d2540
*) traffic-flow - fixed post NAT port reporting;
Bingo.

The problem is resolved in 6.44rc and 6.43.4 but we have a rule of only running LTS/Bugfix in production.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
avn
just joined
Posts: 10
Joined: Tue Apr 04, 2017 6:34 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 9:06 pm

I've found a different factory reset behavior after upgrading to v6.42.9. In v6.40.9 the interfaces, DHCP server, and firewall policies were included by default. Now in v6.42.9, only a static IP address of 192.168.88.1 is configured on Interface 1, without a DHCP server, or firewall policies (which leaves the router insecure and vulnerable to hacking when connected to the internet). Why was this changed?
What type of router is that? The above has always been the default on the more enterprise-oriented CCR routers, the detailed config that you describe was always only on the smaller home-oriented routers.
All types of routers now behave like this. Hex/hex lite, hap/hap lite, rb7xx, rb9xx, rb2011... You can check yourself (/system default-configuration print).
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Jul 08, 2010 10:18 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 10:52 pm


[/quote]
All types of routers now behave like this. Hex/hex lite, hap/hap lite, rb7xx, rb9xx, rb2011... You can check yourself (/system default-configuration print).[/quote]


But the question is, was this a deliberate change by Mikrotik or a bug? Unless I've missed it we've yet to hear any kind of an official reply to this.
 
Swordforthelord
Frequent Visitor
Frequent Visitor
Posts: 56
Joined: Thu Jul 08, 2010 10:18 pm

Re: v6.42.9 [long-term] is released!

Tue Oct 23, 2018 10:58 pm

I really can't see the new default configuration as anything other than a bug, at least not in the smaller routers. It's been MT's policy for years now to make them end user friendly and no default firewall/bridge/NAT setup is the very opposite of that. I even tried using quick set and that still produces the new limited default config.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 471
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.42.9 [long-term] is released!

Wed Oct 24, 2018 12:31 pm

Unfortunately, it looks like default configuration is not properly generated on 6.42.8 and 6.42.9 versions. A workaround is to upgrade your router to the latest stable or testing builds and reset configuration then. We will definitely resolve the issue in the next long-term version. Sorry for any inconvenience.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 12:02 am

I have found a single post about this : viewtopic.php?f=21&t=123936&p=626322#p626322

It's a valid use case. But I agree with you, this should be directed to support@mikrotik.com
Well, for me it's not very valid. If you're using bridging, why do you add addresses to the ports, not on the bridge? If you need routing — don't use bridging/switching. If you bridge — why do you need different IP addresses on different ports? :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 11:17 am

I have found a single post about this : viewtopic.php?f=21&t=123936&p=626322#p626322

It's a valid use case. But I agree with you, this should be directed to support@mikrotik.com
Well, for me it's not very valid. If you're using bridging, why do you add addresses to the ports, not on the bridge? If you need routing — don't use bridging/switching. If you bridge — why do you need different IP addresses on different ports? :)
It is not at all related to that! The point is, in the old version you could put an IP address (subnet) on a master port with some slave ports (a switch), and when you route the subnet e.g. using BGP with synchronize=yes the route would only be advertised when something is plugged into one of the ports of the switch. When all devices are unplugged or powered down, the master port would go down and BGP would no longer advertise the subnet. You could then advertise it somewhere else (where the same config is present).

However, with the new approach where you use a bridge with those ports (and hw=yes), put the address on the bridge, i.e. the "new config" for a "switch", it no longer works like this. The bridge is "up" even when none of the ports in the bridge is up, and BGP always advertises the subnet even when synchronize=yes.
That is a change in functionality, and although most people will not bother, he is apparently affected by it.

The new config can only do the above when only a single port is used, so the IP address can be directly configured on the port, and the ports still can be up or down.
But that means you can no longer offer the multiple ports (with switch) feature to the customer and use this failover/move scenario.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 11:53 am

Good point, we definitely need some option to stop bridge if all bridge ports are down (or to run it only if there are active ports). Someone just needs to contact support@mikrotik.com with that request :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5919
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 12:02 pm

Bridge always worked that way and if suddenly bridge with inactive (no ports) will not have running flag, it will break all configurations with loopbacks and other configurations where bridge is used as dummy interface.
 
User avatar
xvo
Member
Member
Posts: 341
Joined: Sat Mar 03, 2018 1:12 am
Location: Moscow, Russia

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 12:33 pm

Bridge always worked that way and if suddenly bridge with inactive (no ports) will not have running flag, it will break all configurations with loopbacks and other configurations where bridge is used as dummy interface.
Well, there can be an option to choose the desired behaviour: to leave a running flag no matter what, or to monitor the state of slave interfaces.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 12:46 pm

Bridge always worked that way and if suddenly bridge with inactive (no ports) will not have running flag, it will break all configurations with loopbacks and other configurations where bridge is used as dummy interface.
Exactly, that's why I called that an option. Not default one :)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
juliokato
Member Candidate
Member Candidate
Posts: 229
Joined: Mon Oct 26, 2015 4:27 pm
Location: Brazil

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 3:32 pm

Unfortunately, it looks like default configuration is not properly generated on 6.42.8 and 6.42.9 versions. A workaround is to upgrade your router to the latest stable or testing builds and reset configuration then. We will definitely resolve the issue in the next long-term version. Sorry for any inconvenience.
amazing how launch long-term version and you guys introduce a failure of these.
I apologize my grammatical errors, my english not so good, I am not a native speaker.
Wiki is maintained in English. I use Google translator. 8)
 
vortex
Forum Veteran
Forum Veteran
Posts: 713
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.42.9 [long-term] is released!

Thu Oct 25, 2018 3:40 pm

I put one bridge on the whole chip, created 2 VLANs with the same subnet, but DHCP does not work for one of them (DHCP server on the bridge).
 
vodokotlic
just joined
Posts: 13
Joined: Thu Mar 29, 2018 11:13 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 26, 2018 2:32 pm

This is my first version running a new bridge, don't know if it's a known bug.
RB951G-2HnD running as just a Switch/AP (all ethernet+wlan ports under one switch/bridge, no vlans, no nat).
If I change the mac address of an ethernet port while it's a member of a switch/bridge, most of the OS will hang. Switch will continue to pass traffic (on other ports) and the system clock runs but pretty much everything else is frozen.
Device does not respond to /system reboot or reboot via winbox and needs to be power cycled to restore full function. (Crappy situation if the device is on a remote location)
 
mkx
Forum Guru
Forum Guru
Posts: 2778
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 26, 2018 2:40 pm

Does it happen when you change MAC address of just any member port or does it happen only when you change MAC address of a port which previously had same MAC address as bridge?
BR,
Metod
 
nescafe2002
Long time Member
Long time Member
Posts: 617
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.42.9 [long-term] is released!

Fri Oct 26, 2018 2:45 pm

I have reported this issue earlier and it has been fixed in 6.44beta14.

Sadly it has not been merged to stable yet.

Edit: This issue => referring to device lockup when changing MAC address.
Last edited by nescafe2002 on Fri Oct 26, 2018 5:05 pm, edited 1 time in total.
 
ivanfm
newbie
Posts: 46
Joined: Sun May 20, 2012 5:07 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 26, 2018 3:12 pm

Bridge always worked that way and if suddenly bridge with inactive (no ports) will not have running flag, it will break all configurations with loopbacks and other configurations where bridge is used as dummy interface.

In the migration from master to bridge you have break an always working configuration that really makes sense.
Create an option the the bridge with default to keep running anyway, and selection to stop running if no attached port is running.
 
vodokotlic
just joined
Posts: 13
Joined: Thu Mar 29, 2018 11:13 pm

Re: v6.42.9 [long-term] is released!

Fri Oct 26, 2018 4:38 pm

Quote original post:
This is my first version running a new bridge, don't know if it's a known bug.
RB951G-2HnD running as just a Switch/AP (all ethernet+wlan ports under one switch/bridge, no vlans, no nat).
If I change the mac address of an ethernet port while it's a member of a switch/bridge, most of the OS will hang. Switch will continue to pass traffic (on other ports) and the system clock runs but pretty much everything else is frozen.
Device does not respond to /system reboot or reboot via winbox and needs to be power cycled to restore full function. (Crappy situation if the device is on a remote location)
Quote mkx:
Does it happen when you change MAC address of just any member port or does it happen only when you change MAC address of a port which previously had same MAC address as bridge?
Just a member port, not previous master. It does that even when the port is not running (cable not connected). It has to be removed from the bridge, MAC address changed and then added back to the bridge. Fix could be as simple as preventing the change if port is bridge member. Just return an error and not hang the OS.

Quote nescafe2002:
I have reported this issue earlier and it has been fixed in 6.44beta14.

Sadly it has not been merged to stable yet.
Assuming you're replying to my post; Good to know, it'll trickle down eventually.
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.42.9 [long-term] is released!

Mon Oct 29, 2018 11:15 am

This is my first version running a new bridge, don't know if it's a known bug.
RB951G-2HnD running as just a Switch/AP (all ethernet+wlan ports under one switch/bridge, no vlans, no nat).
If I change the mac address of an ethernet port while it's a member of a switch/bridge, most of the OS will hang. Switch will continue to pass traffic (on other ports) and the system clock runs but pretty much everything else is frozen.
Device does not respond to /system reboot or reboot via winbox and needs to be power cycled to restore full function. (Crappy situation if the device is on a remote location)
After changing the MAC have you tried flushing arp table on your computer? After all you are vodokotlic :D ...
 
AllisonF
just joined
Posts: 6
Joined: Wed Oct 31, 2018 7:29 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 31, 2018 7:37 pm

Hello everyone,

So I work for an ISP and have been using 42.9 (long term) as the standard for my current Router OS version in deployment and it works great for the RB2011's, the Cloud Core units, the hAP AC's and the hAP AC^2's, however I have discovered in which if you upgrade a hAP AC^2 to Router OS 42.9, the unit will be bricked if you perform a hard reset while on that version. I have replicated this on 5 different units in total. You are able to still use Netinstall to restore this unit to its former glory, but this is problematic for times in which a field hard reset is necessary during unit deployment. I suspect this is actually related to the ARM version of Router OS 42.9 and thus would impact other units running on it, but the only unit we deploy here that uses an ARM processor is the AC^2, so I'm unable to test other units that share this version. Is there anything that can be done about this?

Thank you so much!

Update:
It's not related to the ARM release, as hard resetting a hAP AC1 on 42.9 has the same result. Will post back again after testing with an RB2011.

Update 2:
Hard reset of configuration with an RB2011 on 42.9 does indeed brick that device as well, so this seems to be across the board.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 31, 2018 8:44 pm

What is your definition of "bricked"? No longer boots, you can no longer access it, or what?
There have been reports that this version does not install the familiar default config with DHCP server, NAT, firewall etc, but it merely puts address 192.168.88.1/24 on one of the ports as already was the standard on "business" routers like the CCR.
Did you try connecting from a system with address 192.168.88.10/24 or similar? Did you try connecting to the MAC address? (with winbox)
 
AllisonF
just joined
Posts: 6
Joined: Wed Oct 31, 2018 7:29 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 31, 2018 8:56 pm

What is your definition of "bricked"? No longer boots, you can no longer access it, or what?
There have been reports that this version does not install the familiar default config with DHCP server, NAT, firewall etc, but it merely puts address 192.168.88.1/24 on one of the ports as already was the standard on "business" routers like the CCR.
Did you try connecting from a system with address 192.168.88.10/24 or similar? Did you try connecting to the MAC address? (with winbox)
By "bricked", I mean that I can no longer get the router to hand out an IP to anything resulting in loss of access, though admittedly I don't recall which LAN ports I used. Does this behavior you mention assign 192.168.88.1/24 to a single port or to the bridge?

I tried pulling an IP via DHCP first and could not, then I set my NIC to a static address of 192.168.88.5 and still could not pull the address from the router on any of the tested devices.

Most of my Mikrotik units don't have console ports, so I haven't tried that yet (though I could on an RB2011 if necessary). As to Winbox, I have never used the application, but I can give this a test as well.


Update:
I consoled into a "bricked" RB2011 from this process. Turns out, the device doesn't apply the usual default config if you do this other than the following:

[admin@MikroTik] > /exp
# jan/02/1970 00:02:56 by RouterOS 6.42.9
# software id = 25GR-X6TN
#
# model = 2011UiAS
# serial number = XXXXXXXXXXXX
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip address
add address=192.168.88.1/24 comment="default configuration" interface=ether1 \
network=192.168.88.0
/system routerboard settings
set silent-boot=no


Which is why I have no access. So it doesn't brick the device per se, it just doesn't apply any default router configuration like other versions do, and since it applied the IP pool to Eth 1, which is normally expected as the WAN port, I couldn't get an IP on anything, as I was plugged into the typical LAN ports.
 
AllisonF
just joined
Posts: 6
Joined: Wed Oct 31, 2018 7:29 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 31, 2018 9:50 pm

Unfortunately, it looks like default configuration is not properly generated on 6.42.8 and 6.42.9 versions. A workaround is to upgrade your router to the latest stable or testing builds and reset configuration then. We will definitely resolve the issue in the next long-term version. Sorry for any inconvenience.
This was definitely my issue all along. Thanks for the assistance!
 
pe1chl
Forum Guru
Forum Guru
Posts: 5694
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.42.9 [long-term] is released!

Wed Oct 31, 2018 10:27 pm

Yes, that is the problem I described, only 192.168.88.1 on a single port and no DHCP etc. I did not know which port it would use on RB2011 but apparently ether1 like on CCR which is indeed unfortunate as your PC normally would not be connected to that.
Well, good that you found out. On the 2011UiAS you have you could have used the LCD to find what was happening.
 
amorsen
newbie
Posts: 31
Joined: Wed Jun 13, 2007 2:17 pm

Re: v6.42.9 [long-term] is released!

Fri Nov 02, 2018 1:43 pm

Good point, we definitely need some option to stop bridge if all bridge ports are down (or to run it only if there are active ports). Someone just needs to contact support@mikrotik.com with that request :)
I contacted support multiple times. They refused to accept that it is an issue. Oh well, Juniper likes the extra business.
 
User avatar
eworm
Member
Member
Posts: 376
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.42.9 [long-term] is released!

Fri Nov 02, 2018 2:56 pm

Good point, we definitely need some option to stop bridge if all bridge ports are down (or to run it only if there are active ports). Someone just needs to contact support@mikrotik.com with that request :)
I contacted support multiple times. They refused to accept that it is an issue. Oh well, Juniper likes the extra business.
How about using a script with a scheduler?
:foreach bridge in=[ / interface bridge find ] do={
  :local brname [ / interface bridge get $bridge name ];
  :local inactive true;
  :foreach port in=[ / interface bridge port find where bridge=$brname ] do={
    :if ([ /interface bridge port get $port inactive ] != true) do={
      :set inactive false;
    }
  }
  :if ($inactive = true) do={
    / ip address disable [ find where !dynamic interface=$brname ];
  } else={
    / ip address enable [ find where !dynamic interface=$brname ];
  }
}
Run that every minute and you are done.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8305
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.42.9 [long-term] is released!

Fri Nov 02, 2018 3:36 pm

I would even simplify it a bit :)
:foreach bridge in=[ /interface bridge find ] do={
  :local brname [ /interface bridge get $bridge name ];
  :if ([/interface bridge port print count-only where bridge=$brname and inactive=no] = 0) do={
    / ip address disable [ find where !dynamic interface=$brname ];
  } else={
    / ip address enable [ find where !dynamic interface=$brname ];
  }
}
Or, if you need only 1 bridge, even shorter:
/ip address set [ find dynamic=no interface=bridge-local ] \
   disabled=([/interface bridge port print count-only where bridge=bridge-local and inactive=no] = 0)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
mducharme
Trainer
Trainer
Posts: 795
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.42.9 [long-term] is released!

Mon Nov 12, 2018 7:19 pm

Any change of an updated long-term version soon that fixes the bridge VLAN filtering memory leak bug?
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 471
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.42.9 [long-term] is released!

Tue Nov 20, 2018 8:19 am

New version 6.42.10 has been released in long-term RouterOS channel:

viewtopic.php?f=21&t=141792

Who is online

Users browsing this forum: No registered users and 7 guests