Community discussions

 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 453
Joined: Thu Dec 11, 2014 8:53 am

v6.43.8 [stable] is released!

Fri Dec 21, 2018 10:54 am

RouterOS version 6.43.8 has been released in public "stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.43.8 (2018-Dec-21 07:10):

MAJOR CHANGES IN v6.43.8:
----------------------
!) telnet - do not allow to set "tracefile" parameter;
----------------------

Changes in this release:

*) bridge - fixed IPv6 link-local address generation when auto-mac=yes;
*) capsman - fixed "group-key-update" parameter not using correct units;
*) crs3xx - improved data transmission between 10G and 1G ports;
*) console - properly remove system note after configuration reset;
*) dhcpv4-server - fixed dynamic lease reuse after expiration;
*) dhcpv6-server - properly handle DHCP requests that include prefix hint;
*) ethernet - fixed VLAN1 forwarding on RB1100AHx4 and RB4011 devices;
*) gps - added "coordinate-format" parameter;
*) led - fixed default LED configuration for RBMetalG-52SHPacn;
*) led - fixed PWR-LINE AP ethernet led polarity ("/system routerboard upgrade" required);
*) lte - disallow setting LTE interface as passthrough target;
*) lte - fixed DHCP IP acquire (introduced in v6.43.7);
*) lte - fixed passthrough functionality when interface is removed;
*) lte - increased reported "rsrq" precision;
*) lte - reset USB when non-default slot is used;
*) package - use bundled package by default if standalone packages are installed as well;
*) resource - fixed "total-memory" reporting on ARM devices;
*) snmp - added "tx-ccq" ("mtxrWlStatTxCCQ") and "rx-ccq" ("mtxrWlStatRxCCQ") values;
*) switch - fixed MAC learning when disabling interfaces on devices with Atheros8327 and QCA8337 switch chips;
*) system - fixed situation when all configuration was not properly loaded on bootup;
*) timezone - fixed "Europe/Dublin" time zone;
*) upgrade - automatically uninstall standalone package if already installed in bundle;
*) webfig - do not show bogus VHT field in wireless interface advanced mode;
*) winbox - added "allow-roaming" parameter in "Interface/LTE" menu;
*) winbox - allow to change VHT rates when 5ghz-n/ac band is used;
*) winbox - renamed "Radius" to "RADIUS";
*) winbox - show "Switch" menu on RB4011iGS+5HacQ2HnD and RB4011iGS+;
*) wireless - added new "installation" parameter to specify router's location;
*) wireless - improved stability for 802.11ac;
*) wireless - improvements in wireless frequency selection;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this concrete RouterOS release.
 
sindudas
newbie
Posts: 28
Joined: Thu Aug 16, 2012 2:59 pm

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 11:25 am

On a wAP R LTE reports:

/interface lte info number=0
rsrp: -100dBm
rsrq: -15dB
sinr: -2dB
cqi: 4

But on Winbox:
RSRQ: -1.5 dB

Before update from 6.43.7 => 6.37.8 shows:
RSRQ: -15dB

What value is correct? As in changelog tells that:
*) lte - increased reported "rsrq" precision;
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 266
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 1:56 pm

) wireless - added new "installation" parameter to specify router's location;
Where is this option?

Sent from my C6833 using Tapatalk

 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5893
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 2:12 pm

In wireless interface settings obviously.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2274
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 3:07 pm

Any info about DFS?
LAN, FTTx, Wireless. ISP operator
 
kez
newbie
Posts: 39
Joined: Tue Jul 05, 2005 4:13 am

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 3:45 pm

hello support!
Could you give us more information about this changelog entry?

*) wireless - improved stability for 802.11ac;

What have been changed? Any improvement in NV2?

Thanks!
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 3:54 pm

) wireless - added new "installation" parameter to specify router's location;
Where is this option?

Sent from my C6833 using Tapatalk
Screenshot 2018-12-21 at 14.09.39.png
You do not have the required permissions to view the files attached to this post.
No answer to your question? How to write posts
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 266
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 4:39 pm

) wireless - added new "installation" parameter to specify router's location;
Where is this option?

Sent from my C6833 using Tapatalk
Screenshot 2018-12-21 at 14.09.39.png
Thanks. Does it affects wifi power when selecting indoor or outdoor?


Sent from my C6833 using Tapatalk

 
User avatar
awacenter
Member Candidate
Member Candidate
Posts: 198
Joined: Thu Dec 09, 2004 12:58 pm
Location: Castellón
Contact:

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 4:51 pm

I have just update a RB951Ui from 6.42.1 to last ros version 6.43.8 and there is a little bug
because the log function dissapear.

I execute / log print and nothing appears.
ImageImage
 
hapi
Member Candidate
Member Candidate
Posts: 222
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 5:02 pm

OSPF randomly passes only part of the records to the routing table. It stops having fun.
 
mikelaurense
just joined
Posts: 5
Joined: Mon Dec 03, 2018 9:14 am

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 9:40 pm

hello support!
Could you give us more information about this changelog entry?

*) wireless - improved stability for 802.11ac;

What have been changed? Any improvement in NV2?

Thanks!
Would like to know as well. My RB4011 keeps disabling 5ghz WiFi after a few days (see graph). Only a reboot can bring the WiFi up again. Wondering if this has been fixed
You do not have the required permissions to view the files attached to this post.
 
Redmor
Member Candidate
Member Candidate
Posts: 248
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 9:47 pm

Thank you very much for this present!
Now if I have a country set I can only use regulatory domain and default scanlist, a real pain in the a*s.
That should be in changelog!
ImageImage
 
eddieb
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.43.8 [stable] is released!

Fri Dec 21, 2018 11:18 pm

Updated from 6.43.7 to 6.43.8 without any problems.
Wifi works as expected, no problems
Running 6.45.1 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
User avatar
peterh
just joined
Posts: 19
Joined: Tue Dec 11, 2018 7:39 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 12:01 am

Working fine on mAP and RB2011.
 
sff
just joined
Posts: 13
Joined: Fri Aug 13, 2010 5:15 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 12:04 am

The reported fix to performance between 1Gb and 10Gb ports on CRS3xx series devices in 6.43.8 does not fix the issue. I've upgraded three CRS326 devices so far today, one from 6.43.4 and two from 6.43.7, and there has been no improvement. We ran extensive tests, all of which proved that while there was a "slight" increase in performance, as soon as you start to approach 100Mb of steady traffic going from (not to) a 1Gb port to a 10Gb uplink the 326 starts to fail to pass packets and performance drops significantly below 100Mb.

We've actually had to drop to 1Gb SFPs for the fiber uplinks to get ANY kind of performance above 20-30Mb/sec. As a 1Gb switch, it works great. 10Gb uplink? Back to the drawing board folks...I have 8 CRS317s (three groups of rings) and a core/edge of multiple CCR1072s/1036s that is waiting for a fix to be able to deploy.

No issue on 317s -- never had any. But the DOZENS of 326s that we have are pretty much boat anchors since the change to the way bridges are configured. The 226s we've been retiring may need to go back in service. They work -- if configured the "traditional" way instead of the new method of setting up VLANS.

Love Mikrotiks. Have hundreds of them. Don't love this bug.
 
hapi
Member Candidate
Member Candidate
Posts: 222
Joined: Fri Mar 11, 2011 11:21 am
Location: Czech Republic

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 12:48 am

You write that 8 CRS317 are waiting for repair and then they do not have the problem. I do not understand.

  I also have CRS317 and CRS328, and sometimes I do not have management on both the two and the data impediment.

Next time I prefer to buy something from UBNT where there is no problem.
 
sff
just joined
Posts: 13
Joined: Fri Aug 13, 2010 5:15 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 1:13 am

No, they are waiting to be used. We deploying five new 10Gb backbones. Two of them are multiple switch RSTP rings between the three data centers, three are just ship to shore to handle backend storage for the server cluster and other high volume data such as cameras.

There are also two 1072s, two 1036s, four 1009s (w/10Gb port) waiting to cut over from the existing network.

Not that this is necessarily a "huge" network, but this is a summary of Mikrotiks deployed onsite right now. And yes, we still have several nearly ten year old RB1200s handling edge services for one of the external network connections.

Most maintenance/upgrades (as well as backups) have been automated using in-house developed databases, so other than devices that are offline at the moment, the ship looks like this:

+--------------------+----------+
| model | count(*) |
+--------------------+----------+
| | 1 |
| cAP | 23 |
| cAP ac | 1 |
| CCR1009-7G-1C-1S+ | 2 |
| CCR1009-8G-1S-1S+ | 4 |
| CCR1036-8G-2S+ | 2 |
| CCR1072-1G-8S+ | 2 |
| CRS106-1C-5S | 1 |
| CRS109-8G-1S-2HnD | 9 |
| CRS125-24G-1S-2HnD | 1 |
| CRS210-8G-2S+ | 3 |
| CRS212-1G-10S-1S+ | 6 |
| CRS226-24G-2S+ | 15 |
| CRS317-1G-16S+ | 10 |
| CRS326-24G-2S+ | 8 |
| CRS328-24P-4S+ | 4 |
| hAP ac | 12 |
| hAP ac lite | 3 |
| mAP | 1 |
| RB Groove A-52HPn | 1 |
| RB SXT 5HPnD | 2 |
| RB SXT G-2HnD | 3 |
| RB1200 | 3 |
| RB2011UAS | 2 |
| RB4011iGS+ | 2 |
| RB912UAG-5HPnD | 1 |
| RB951G-2HnD | 25 |
| SXT SA5 ac | 2 |
| unknown | 2 |
| wAP ac | 3 |
+--------------------+----------+
30 rows in set (0.00 sec)

MariaDB [mikrotik]>

+----------+----------+
| routeros | count(*) |
+----------+----------+
| | 1 |
| 6.38.3 | 1 |
| 6.40.2 | 7 |
| 6.40.5 | 14 |
| 6.42.6 | 1 |
| 6.42.7 | 3 |
| 6.43.4 | 113 |
| 6.43.7 | 4 |
| 6.43.8 | 8 |
| Unknown | 2 |
+----------+----------+
10 rows in set (0.00 sec)

Most of the network is on 6.43, but a lot of the crs226s have been kept back on 6.40 waiting for maintenance time to upgrade the "old style" configurations.

There are also a dozen or so HP and Netgear switches still to be decommissioned. The 1072s, 1036s and most of the 317s are in part of the network that we are upgrading from a single 10Gb ring to five distinct connections ship to shore. There are sometimes more than ten thousand active mac addresses visible during the day. The dynamic DHCP pool is multiple /16s.

This is an aircraft carrier. :)
 
anav
Forum Guru
Forum Guru
Posts: 2841
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 3:01 am

Has anyone at Mikrotik investigated this report??
viewtopic.php?f=2&t=143065
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
 
Redmor
Member Candidate
Member Candidate
Posts: 248
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 3:09 am

Has anyone at Mikrotik investigated this report??
viewtopic.php?f=2&t=143065
It isn't a report, is a decision.
You should use only regulatory domain in some countries, but when you face to low quality transmission and TDMA, and occupied frequencies, what else can you do?
ImageImage
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:00 am

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
amt
Long time Member
Long time Member
Posts: 524
Joined: Fri Jan 16, 2015 2:05 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:04 am

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
me too :)
 
mistry7
Forum Guru
Forum Guru
Posts: 1225
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:19 am

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
me too :)
distance is for ACK calculation and installation ist foot frequency selection.....
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:25 am

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
me too :)
distance is for ACK calculation and installation ist foot frequency selection.....

make sense ,but need more info
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
ognjen
newbie
Posts: 35
Joined: Wed Nov 15, 2017 10:31 am
Location: Serbia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:55 am

Hello,

I have a problem with wireless.
I getting internet from ISP Access Point [ROS: 6.27]. This link is 7 year old.
My station is RB433 and after upgrade from 6.43.7 to 6.43.8 link is drop down.
After troubleshooting i see diffence in Wireless tab.
On old conf, Frequency is 5920, Frequence Mode is superchannel, Conutry romania.
On new conf, Frequency is auto, Frequence Mode is regulary-domain, Conutry romania.
I cannot change back Frequency to 5920.
Can anyone help me? (I downgrade to 6.43.7 and push backup and this is work, but I won't use old ROS)

Before upgrade:
Image

After upgrade:
Image
Be careful with MikroTik Firewall because you can cut the line [yourself - MikroTik] :shock:
Image
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8280
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:11 am

On old conf, Frequency is 5920, Frequence Mode is superchannel, Conutry romania.
On new conf, Frequency is auto, Frequence Mode is regulary-domain, Conutry romania.
I cannot change back Frequency to 5920.
Just set Country to no_country_set and use superchannel
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
ognjen
newbie
Posts: 35
Joined: Wed Nov 15, 2017 10:31 am
Location: Serbia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:30 am

Just set Country to no_country_set and use superchannel
That is it! Ty :)
Be careful with MikroTik Firewall because you can cut the line [yourself - MikroTik] :shock:
Image
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2274
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:42 am

Thank you very much for this present!
Now if I have a country set I can only use regulatory domain and default scanlist, a real pain in the a*s.
That should be in changelog!
That is true
LAN, FTTx, Wireless. ISP operator
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 1:21 pm

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
Distance adjusts ack settings.
Installation decides which frequencies and powers you can use, based on regulations.
Just set Country to no_country_set and use superchannel
That is it! Ty :)
Careful, this can bring you trouble, depending on which country you are in.

As it was always possible, check specifics in menu "/interface wireless info county-info germany" or other country.
[normis@rb4011] > interface wireless info country-info germany
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)
          2417-2457/g-turbo(20dBm)
          5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
          5190-5310/a-turbo(20dBm)/dfs
          5180-5300/a-turbo(20dBm)/dfs
          5520-5680/a-turbo(27dBm)/dfs,passive
          5510-5670/a-turbo(27dBm)/dfs,passive
          902-927/b,g,g-turbo,gn20,gn40(30dBm)
          
No answer to your question? How to write posts
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 1:38 pm

sindudas - We are sorry for any inconvenience caused. We will fix this problem in upcoming RouterOS releases.
ErfanDL - You can change value by using "/interface wireless set <interface> installation=any/indoor/outdoor".
honzam - What kind of information about DFS are you looking for?
kez - Sometimes router that was using "ac" did tend to reboot due to a Watchdog timer. This problem is now resolved. This does not mean that all "Watchdog reboots" are fixed in RouterOS. Usually such reboot happens on overloaded router.
ErfanDL, nichky, amt, mistry7 - This setting (installation) makes your router to take into account parts from "/interface wireless info country-info <country>" that specify usage in indoors or outdoors.
awacenter - What do you see when you run "/system logging export" command?
hapi - Please send supout.rif file from your router to support@mikrotik.com. Name from which version you did upgrade your router.
mikelaurense - Does interface actually gets disabled? Or it becomes inacessible? If it disabled, then someone has done that manually. Please provide supout.rif file tp support@mikrotik.com. Make sure that file is generated while interface is "disabled".
Redmor - Yes, but that is the whole point of country settings. You can still change settings in order to do so. Country settings are made in order to comply to regulatory domain.
sff - Have you contacted support@mikrotik.com regarding this matter. We have fixed suh bug in RouterOS already, however, your problem might be little bit different.
hapi - Please provide supout file from your router that would be generated while router is inaccessible either over another interface or over serial console. We will see why you can not access router at some point. I do not see any reason why you should jump tp consclusions right away and announce this as a "bug".
anav - Yes - "viewtopic.php?f=2&t=143065#p704717"
ognjen - In Europe (country selected) you can not use any other settings besides regulatory domain.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 1:42 pm

I think that "normis" post was missing "indoor/outdoor" setting in country information simply because example country does not have such limits.

Here you can see info for Latvia:

/interface wireless info country-info latvia
ranges: 2402-2482/b,g,gn20,gn40(20dBm)
2417-2457/g-turbo(20dBm)
5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive,indoor
5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
5190-5310/a-turbo(20dBm)/dfs
5180-5300/a-turbo(20dBm)/dfs
5520-5680/a-turbo(27dBm)/dfs,passive
5510-5670/a-turbo(27dBm)/dfs,passive
902-927/b,g,g-turbo,gn20,gn40(30dBm)

These settings can be used only if any or indoor is selected on wireless interface. If you select outdoor, then you can not use this part. Same rules apply if info says "outdoor" - indoor configuration will not be able to use it:

"5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive,indoor"
 
Redmor
Member Candidate
Member Candidate
Posts: 248
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 2:35 pm

strods I'm not saying that this change is wrong, it should work like that, but:
1. Write it in changelog
2. If you have to update and set regulatory domain for countries, why removing superchannel with country set instead of unsetting country with superchannel set?
ImageImage
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 23998
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 4:50 pm

You are right that there could have been two ways to adjust the inaccurate setting for some users.
We chose to adjust towards compliance, not towards incompliance. If user has set a country, he possibly wanted to be compliant already.
No answer to your question? How to write posts
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 6:24 pm

All of my MIPS devices (5x hAP ac, 2x RB951) upgraded automatically last night by script.

My one ARM device (hAP ac2) did not upgrade, logging that there were no updates available.

I tried to update it this morning from /system packages, and it still reports no updates are available. It's still on 6.43.7.

Was the upgrade removed for ARM?

The file downloads successfully from the Mikrotik webpage.

Sent from my Pixel 3 using Tapatalk

 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 7:56 pm

yottabit - To which IP address does your router resolve upgrade.mikrotik.com (:put [:resolve upgrade.mikrotik.com])? Upgrade should work on this router without any problems. There might be some proxy server between your router and upgrade server causing this.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 8:03 pm

yottabit - To which IP address does your router resolve upgrade.mikrotik.com (:put [:resolve upgrade.mikrotik.com])? Upgrade should work on this router without any problems. There might be some proxy server between your router and upgrade server causing this.

[yottabit@rb1] > /ip dns print
                      servers: 8.8.8.8,8.8.4.4
              dynamic-servers: 
        allow-remote-requests: yes
          max-udp-packet-size: 4096
         query-server-timeout: 2s
          query-total-timeout: 10s
       max-concurrent-queries: 100
  max-concurrent-tcp-sessions: 20
                   cache-size: 2048KiB
                cache-max-ttl: 1w
                   cache-used: 205KiB
[yottabit@rb1] > :put [:resolve upgrade.mikrotik.com]
159.148.147.204
[yottabit@rb1] > /system package update check-for-updates 
            channel: stable
  installed-version: 6.43.7
             status: ERROR: connection timed out


Strange, right? It's also worth noting that all but 2 of the other routers I mentioned above are behind this router that won't upgrade, and are forced to use this router for DNS. There is no proxy.

Edit: switched to OpenDNS, and the resolve is the same, but still can't connect.

[yottabit@rb1] > /ip dns print 
                      servers: 208.67.222.123,208.67.220.123
              dynamic-servers: 
        allow-remote-requests: yes
          max-udp-packet-size: 4096
         query-server-timeout: 2s
          query-total-timeout: 10s
       max-concurrent-queries: 100
  max-concurrent-tcp-sessions: 20
                   cache-size: 2048KiB
                cache-max-ttl: 1w
                   cache-used: 139KiB
[yottabit@rb1] > /ip dns cache flush
[yottabit@rb1] > :put [:resolve upgrade.mikrotik.com]     
159.148.172.226
[yottabit@rb1] > :put [:resolve upgrade.mikrotik.com]
159.148.147.204
[yottabit@rb1] > /system package update check-for-updates 
            channel: stable
  installed-version: 6.43.7
             status: ERROR: connection timed out


Edit again, nevermind, figured it out. It was new firewall rule I had implemented a while back, since the last upgrade. I guess I need to add an "allow related, etc." rule above the tarpit rule:

 3    ;;; tarpit WAN
      chain=input action=tarpit protocol=tcp in-interface-list=WAN log=no log-prefix="tarpit"


Sorry for the false alarm. ;-)

This fixed it, for anyone playing along:

 3    ;;; Accept WAN established,related before tarpit
      chain=input action=accept connection-state=established,related in-interface-list=WAN log=no log-prefix="" 

 4    ;;; tarpit WAN
      chain=input action=tarpit protocol=tcp in-interface-list=WAN log=no log-prefix="tarpit"
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:29 pm

I think that "normis" post was missing "indoor/outdoor" setting in country information simply because example country does not have such limits.

Here you can see info for Latvia:

/interface wireless info country-info latvia
ranges: 2402-2482/b,g,gn20,gn40(20dBm)
2417-2457/g-turbo(20dBm)
5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive,indoor
5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
5190-5310/a-turbo(20dBm)/dfs
5180-5300/a-turbo(20dBm)/dfs
5520-5680/a-turbo(27dBm)/dfs,passive
5510-5670/a-turbo(27dBm)/dfs,passive
902-927/b,g,g-turbo,gn20,gn40(30dBm)

These settings can be used only if any or indoor is selected on wireless interface. If you select outdoor, then you can not use this part. Same rules apply if info says "outdoor" - indoor configuration will not be able to use it:

"5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive,indoor"

Can i ask you i have already updated to the later Router, why i couldn't get same result like you? Have a look:

Thanks
You do not have the required permissions to view the files attached to this post.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:36 pm

i'm wondering what's differences between new "installation" and distance?
actually what the new feature does?

Thanks
Distance adjusts ack settings.
Installation decides which frequencies and powers you can use, based on regulations.

So normis basically it means we always have to look what this command says:

/interface wireless info county-info xxx

And dependent of that we can use indoor or outdoor ( regulatory domain)

Thanks


Just set Country to no_country_set and use superchannel
That is it! Ty :)
Careful, this can bring you trouble, depending on which country you are in.

As it was always possible, check specifics in menu "/interface wireless info county-info germany" or other country.
[normis@rb4011] > interface wireless info country-info germany
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)
          2417-2457/g-turbo(20dBm)
          5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
          5190-5310/a-turbo(20dBm)/dfs
          5180-5300/a-turbo(20dBm)/dfs
          5520-5680/a-turbo(27dBm)/dfs,passive
          5510-5670/a-turbo(27dBm)/dfs,passive
          902-927/b,g,g-turbo,gn20,gn40(30dBm)
       
Last edited by nichky on Sat Dec 22, 2018 10:25 pm, edited 1 time in total.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:44 pm

Can you provide supout file to support@mikrotik.com? Honestly, I do not see how (if you did not play around with Photoshop :) ) you could get this information under country info.
Screenshot 2018-12-22 21.41.45.png
You do not have the required permissions to view the files attached to this post.
 
Redmor
Member Candidate
Member Candidate
Posts: 248
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:46 pm

You are right that there could have been two ways to adjust the inaccurate setting for some users.
We chose to adjust towards compliance, not towards incompliance. If user has set a country, he possibly wanted to be compliant already.
I don't think that a user using superchannel with a country set wants to be compliant and I think the second option (changing country on update) is the best option.
In the end, these are things that should be written in changelog, I think lots of users lost CPE connection for this update.
ImageImage
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 9:54 pm

Can you provide supout file to support@mikrotik.com? Honestly, I do not see how (if you did not play around with Photoshop :) ) you could get this information under country info.

Screenshot 2018-12-22 21.41.45.png
I dare not play with you. :)
you can see from other device
You do not have the required permissions to view the files attached to this post.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:29 pm

nichky - "/interface wireless export verbose" should tell us why your output differs from mine.
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 10:38 pm

nichky - "/interface wireless export verbose" should tell us why your output differs from mine.
However i send to you rif file. from your last command
You do not have the required permissions to view the files attached to this post.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
sutrus
just joined
Posts: 24
Joined: Fri Jun 30, 2017 11:27 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:22 pm

The same result - RB962, 2 x SXT HG5 ac
[admin@MikroTik962_Fug31] /interface wireless info> country-info "czech republic" 
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)
          2417-2457/g-turbo(20dBm)
          5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
          5190-5310/a-turbo(20dBm)/dfs
          5180-5300/a-turbo(20dBm)/dfs
          5520-5680/a-turbo(27dBm)/dfs,passive
          5510-5670/a-turbo(27dBm)/dfs,passive
          902-927/b,g,g-turbo,gn20,gn40(30dBm)

# dec/22/2018 22:08:30 by RouterOS 6.43.8
# software id = Y9WG-XJW8
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6F1206AB3E12
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk disable-pmkid=no eap-methods="" group-ciphers=aes-ccm \
    group-key-update=1h interim-update=0s management-protection=disabled management-protection-key="" mode=\
    dynamic-keys mschapv2-password="" mschapv2-username="" name=default radius-called-format=mac:ssid \
    radius-eap-accounting=no radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none \
    static-algo-2=none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" \
    static-sta-private-algo=none static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik \
    tls-certificate=none tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=\
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" group-ciphers=aes-ccm group-key-update=1h \
    interim-update=0s management-protection=disabled management-protection-key="" mode=dynamic-keys \
    mschapv2-password="" mschapv2-username="" name=WPA2 radius-called-format=mac:ssid radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled radius-mac-format=\
    XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=none \
    static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
    static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no ampdu-priorities=\
    0,1,2,3,4,5,6,7 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 area="" arp=enabled arp-timeout=auto band=\
    2ghz-g/n basic-rates-a/g=24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b="" bridge-mode=enabled channel-width=\
    20/40mhz-Ce compression=no country="czech republic" default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes disable-running-check=no disabled=no disconnect-timeout=3s \
    distance=indoors frame-lifetime=0 frequency=2412 frequency-mode=regulatory-domain frequency-offset=0 \
    guard-interval=any hide-ssid=no ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs\
    -0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,m\
    cs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" hw-fragmentation-threshold=disabled hw-protection-mode=cts-to-self \
    hw-protection-threshold=0 hw-retries=4 installation=indoor interworking-profile=disabled keepalive-frames=enabled \
    l2mtu=1600 mac-address=6C:3B:6B:42:3D:5A max-station-count=20 mode=ap-bridge mtu=1500 multicast-buffering=enabled \
    multicast-helper=full name=wlan1-2.4GHz noise-floor-threshold=default nv2-cell-radius=30 nv2-downlink-ratio=50 \
    nv2-mode=dynamic-downlink nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 \
    nv2-security=disabled nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=both radio-name=6C3B6B423D5A \
    rate-selection=advanced rate-set=default rx-chains=0,1,2 scan-list=default secondary-channel="" security-profile=\
    WPA2 ssid=sutrus_fug31 station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=enabled supported-rates-a/g=\
    24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b="" tdma-period-size=2 tx-chains=0,1,2 tx-power-mode=default \
    update-stats-interval=disabled vlan-id=1 vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
    set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no ampdu-priorities=\
    0,1,2,3,4,5,6,7 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 area="" arp=enabled arp-timeout=auto band=\
    5ghz-a/n/ac basic-rates-a/g=6Mbps bridge-mode=enabled channel-width=20/40/80mhz-Ceee compression=no country=\
    "czech republic" default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=\
    yes disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors frame-lifetime=0 frequency=5180 \
    frequency-mode=regulatory-domain frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,\
    mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" \
    hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 installation=\
    indoor interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 mac-address=6C:3B:6B:42:3D:59 \
    max-station-count=2007 mode=ap-bridge mtu=1500 multicast-buffering=enabled multicast-helper=full name=wlan2-5GHz \
    nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=dynamic-downlink nv2-preshared-key="" nv2-qos=default \
    nv2-queue-count=2 nv2-security=disabled nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=long \
    radio-name=6C3B6B423D59 rate-selection=advanced rate-set=default rx-chains=0,1,2 scan-list=default \
    secondary-channel="" security-profile=WPA2 ssid=sutrus_fug31_5G station-bridge-clone-mac=00:00:00:00:00:00 \
    station-roaming=enabled supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
    tdma-period-size=2 tx-chains=0,1,2 tx-power-mode=default update-stats-interval=disabled vht-basic-mcs=mcs0-7 \
    vht-supported-mcs=mcs0-9,mcs0-9,mcs0-9 vlan-id=1 vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
/interface wireless manual-tx-power-table
set wlan1-2.4GHz manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps\
    :17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,\
    HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
set wlan2-5GHz manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:1\
    7,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT\
    40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan1-2.4GHz disable-csma=no enable-nstreme=no enable-polling=no framer-limit=3200 framer-policy=none
set wlan2-5GHz disable-csma=no enable-nstreme=no enable-polling=no framer-limit=3200 framer-policy=none
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 \
    frame-size=300 frames-per-second=25 receive-all=no ssid-all=yes
/interface wireless cap
set bridge=bridgeLocal caps-man-addresses="" caps-man-certificate-common-names="" caps-man-names="" certificate=none \
    discovery-interfaces=bridgeLocal enabled=no interfaces=wlan1-2.4GHz,wlan2-5GHz lock-to-caps-man=no \
    static-virtual=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no \
    receive-errors=no streaming-enabled=no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:27 pm

The same result - RB962, 2 x SXT HG5 ac
[admin@MikroTik962_Fug31] /interface wireless info> country-info "czech republic" 
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)
          2417-2457/g-turbo(20dBm)
          5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
          5190-5310/a-turbo(20dBm)/dfs
          5180-5300/a-turbo(20dBm)/dfs
          5520-5680/a-turbo(27dBm)/dfs,passive
          5510-5670/a-turbo(27dBm)/dfs,passive
          902-927/b,g,g-turbo,gn20,gn40(30dBm)

# dec/22/2018 22:08:30 by RouterOS 6.43.8
# software id = Y9WG-XJW8
#
# model = RouterBOARD 962UiGS-5HacT2HnT
# serial number = 6F1206AB3E12
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk disable-pmkid=no eap-methods="" group-ciphers=aes-ccm \
    group-key-update=1h interim-update=0s management-protection=disabled management-protection-key="" mode=\
    dynamic-keys mschapv2-password="" mschapv2-username="" name=default radius-called-format=mac:ssid \
    radius-eap-accounting=no radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled \
    radius-mac-format=XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none \
    static-algo-2=none static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" \
    static-sta-private-algo=none static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik \
    tls-certificate=none tls-mode=no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=\
add authentication-types=wpa2-psk disable-pmkid=yes eap-methods="" group-ciphers=aes-ccm group-key-update=1h \
    interim-update=0s management-protection=disabled management-protection-key="" mode=dynamic-keys \
    mschapv2-password="" mschapv2-username="" name=WPA2 radius-called-format=mac:ssid radius-eap-accounting=no \
    radius-mac-accounting=no radius-mac-authentication=no radius-mac-caching=disabled radius-mac-format=\
    XX:XX:XX:XX:XX:XX radius-mac-mode=as-username static-algo-0=none static-algo-1=none static-algo-2=none \
    static-algo-3=none static-key-0="" static-key-1="" static-key-2="" static-key-3="" static-sta-private-algo=none \
    static-sta-private-key="" static-transmit-key=key-0 supplicant-identity=MikroTik tls-certificate=none tls-mode=\
    no-certificates unicast-ciphers=aes-ccm wpa-pre-shared-key="" wpa2-pre-shared-key=
/interface wireless
set [ find default-name=wlan1 ] adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no ampdu-priorities=\
    0,1,2,3,4,5,6,7 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 area="" arp=enabled arp-timeout=auto band=\
    2ghz-g/n basic-rates-a/g=24Mbps,36Mbps,48Mbps,54Mbps basic-rates-b="" bridge-mode=enabled channel-width=\
    20/40mhz-Ce compression=no country="czech republic" default-ap-tx-limit=0 default-authentication=yes \
    default-client-tx-limit=0 default-forwarding=yes disable-running-check=no disabled=no disconnect-timeout=3s \
    distance=indoors frame-lifetime=0 frequency=2412 frequency-mode=regulatory-domain frequency-offset=0 \
    guard-interval=any hide-ssid=no ht-basic-mcs=mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs\
    -0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,m\
    cs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" hw-fragmentation-threshold=disabled hw-protection-mode=cts-to-self \
    hw-protection-threshold=0 hw-retries=4 installation=indoor interworking-profile=disabled keepalive-frames=enabled \
    l2mtu=1600 mac-address=6C:3B:6B:42:3D:5A max-station-count=20 mode=ap-bridge mtu=1500 multicast-buffering=enabled \
    multicast-helper=full name=wlan1-2.4GHz noise-floor-threshold=default nv2-cell-radius=30 nv2-downlink-ratio=50 \
    nv2-mode=dynamic-downlink nv2-noise-floor-offset=default nv2-preshared-key="" nv2-qos=default nv2-queue-count=2 \
    nv2-security=disabled nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=both radio-name=6C3B6B423D5A \
    rate-selection=advanced rate-set=default rx-chains=0,1,2 scan-list=default secondary-channel="" security-profile=\
    WPA2 ssid=sutrus_fug31 station-bridge-clone-mac=00:00:00:00:00:00 station-roaming=enabled supported-rates-a/g=\
    24Mbps,36Mbps,48Mbps,54Mbps supported-rates-b="" tdma-period-size=2 tx-chains=0,1,2 tx-power-mode=default \
    update-stats-interval=disabled vlan-id=1 vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
    set [ find default-name=wlan2 ] adaptive-noise-immunity=ap-and-client-mode allow-sharedkey=no ampdu-priorities=\
    0,1,2,3,4,5,6,7 amsdu-limit=8192 amsdu-threshold=8192 antenna-gain=0 area="" arp=enabled arp-timeout=auto band=\
    5ghz-a/n/ac basic-rates-a/g=6Mbps bridge-mode=enabled channel-width=20/40/80mhz-Ceee compression=no country=\
    "czech republic" default-ap-tx-limit=0 default-authentication=yes default-client-tx-limit=0 default-forwarding=\
    yes disable-running-check=no disabled=no disconnect-timeout=3s distance=indoors frame-lifetime=0 frequency=5180 \
    frequency-mode=regulatory-domain frequency-offset=0 guard-interval=any hide-ssid=no ht-basic-mcs=\
    mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7 ht-supported-mcs="mcs-0,mcs-1,mcs-2,mcs-3,mcs-4,mcs-5,mcs-6,mcs-7,\
    mcs-8,mcs-9,mcs-10,mcs-11,mcs-12,mcs-13,mcs-14,mcs-15,mcs-16,mcs-17,mcs-18,mcs-19,mcs-20,mcs-21,mcs-22,mcs-23" \
    hw-fragmentation-threshold=disabled hw-protection-mode=none hw-protection-threshold=0 hw-retries=7 installation=\
    indoor interworking-profile=disabled keepalive-frames=enabled l2mtu=1600 mac-address=6C:3B:6B:42:3D:59 \
    max-station-count=2007 mode=ap-bridge mtu=1500 multicast-buffering=enabled multicast-helper=full name=wlan2-5GHz \
    nv2-cell-radius=30 nv2-downlink-ratio=50 nv2-mode=dynamic-downlink nv2-preshared-key="" nv2-qos=default \
    nv2-queue-count=2 nv2-security=disabled nv2-sync-secret="" on-fail-retry-time=100ms preamble-mode=long \
    radio-name=6C3B6B423D59 rate-selection=advanced rate-set=default rx-chains=0,1,2 scan-list=default \
    secondary-channel="" security-profile=WPA2 ssid=sutrus_fug31_5G station-bridge-clone-mac=00:00:00:00:00:00 \
    station-roaming=enabled supported-rates-a/g=6Mbps,9Mbps,12Mbps,18Mbps,24Mbps,36Mbps,48Mbps,54Mbps \
    tdma-period-size=2 tx-chains=0,1,2 tx-power-mode=default update-stats-interval=disabled vht-basic-mcs=mcs0-7 \
    vht-supported-mcs=mcs0-9,mcs0-9,mcs0-9 vlan-id=1 vlan-mode=no-tag wds-cost-range=50-150 wds-default-bridge=none \
    wds-default-cost=100 wds-ignore-ssid=no wds-mode=disabled wireless-protocol=802.11 wmm-support=enabled wps-mode=\
    disabled
/interface wireless manual-tx-power-table
set wlan1-2.4GHz manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps\
    :17,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,\
    HT40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
set wlan2-5GHz manual-tx-powers="1Mbps:17,2Mbps:17,5.5Mbps:17,11Mbps:17,6Mbps:17,9Mbps:17,12Mbps:17,18Mbps:17,24Mbps:1\
    7,36Mbps:17,48Mbps:17,54Mbps:17,HT20-0:17,HT20-1:17,HT20-2:17,HT20-3:17,HT20-4:17,HT20-5:17,HT20-6:17,HT20-7:17,HT\
    40-0:17,HT40-1:17,HT40-2:17,HT40-3:17,HT40-4:17,HT40-5:17,HT40-6:17,HT40-7:17"
/interface wireless nstreme
set wlan1-2.4GHz disable-csma=no enable-nstreme=no enable-polling=no framer-limit=3200 framer-policy=none
set wlan2-5GHz disable-csma=no enable-nstreme=no enable-polling=no framer-limit=3200 framer-policy=none
/interface wireless align
set active-mode=yes audio-max=-20 audio-min=-100 audio-monitor=00:00:00:00:00:00 filter-mac=00:00:00:00:00:00 \
    frame-size=300 frames-per-second=25 receive-all=no ssid-all=yes
/interface wireless cap
set bridge=bridgeLocal caps-man-addresses="" caps-man-certificate-common-names="" caps-man-names="" certificate=none \
    discovery-interfaces=bridgeLocal enabled=no interfaces=wlan1-2.4GHz,wlan2-5GHz lock-to-caps-man=no \
    static-virtual=no
/interface wireless sniffer
set channel-time=200ms file-limit=10 file-name="" memory-limit=10 multiple-channels=no only-headers=no \
    receive-errors=no streaming-enabled=no streaming-max-rate=0 streaming-server=0.0.0.0
/interface wireless snooper
set channel-time=200ms multiple-channels=yes receive-errors=no

change with country-info latvia and post the result
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
sff
just joined
Posts: 13
Joined: Fri Aug 13, 2010 5:15 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:28 pm

Nope. Haven't contacted support. I'm in the US on "eastern" time, so support lag time tends to be rather large. All parts in the connection are Mikrotik (no 3rd party SFPs involved), and the problem appears with a 10Gb link between the switches and goes away with 1Gb. Very clearly what they say they fixed but clearly didn't. It is absolutely the same issue. 1Gb port going through a 10Gb fiber uplink going to a 1Gb port at the other location.

Switches correctly configured, hardware offload setup correctly, all VLANS defined as recommended. Direct single mode fiber link between the switches (one on shore, the other on the Yorktown about 550m run down the pier and up to the data center under the flight deck). 10Gb SFPs can't handle even 100Mb of throughput. 1Gb SFPs deliver rated throughput perfectly.

I also ran a speed test here from my Mac through a [correctly configured] CRS109 uplinked to a CRS226 then 10Gb DAC to a CRS317, to a 10Gb port on a CCR1036 out another 10Gb port into another VLAN on the same 317, then into a server via 10Gb DAC to a local speedtest server. Return path. 1000Mb+ in both directions. That's an old 109, a 226, a 317 and a 1036. All Mikrotik gear until we hit the server. 1Gb and getting full 1Gb throughput with no dropped packets.

I just got a new CRS317 that arrived Friday that will be configured to match the CRS226 and I'll run the same test. But this is the Saturday before xmas and I'm busy keeping all the 3D printers going making tree ornaments (mostly star wars stormtrooper angels) so this is on the back burner until tomorrow.
 
sff
just joined
Posts: 13
Joined: Fri Aug 13, 2010 5:15 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:29 pm

Sorry...meant to say a new CRS326 that arrived yesterday. Long day. One of the printers has been fighting me and requiring quite a bit of attention.
 
sff
just joined
Posts: 13
Joined: Fri Aug 13, 2010 5:15 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:31 pm

And of course I have to wait until the printers are finished what they are running now, since the printer file storage is NFS and the path passes through the same 317/226 (but to a different 109).
 
sutrus
just joined
Posts: 24
Joined: Fri Jun 30, 2017 11:27 pm

Re: v6.43.8 [stable] is released!

Sat Dec 22, 2018 11:38 pm

change with country-info latvia and post the result
[admin@MikroTik962_Fug31] > /interface wireless info country-info latvia 
  ranges: 2402-2482/b,g,gn20,gn40(20dBm)
          2417-2457/g-turbo(20dBm)
          5170-5250/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(23dBm)/passive
          5250-5330/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(20dBm)/dfs,passive
          5490-5710/a,an20,an40,ac20,ac40,ac80,ac160,ac80+80(27dBm)/dfs,passive
          5190-5310/a-turbo(20dBm)/dfs
          5180-5300/a-turbo(20dBm)/dfs
          5520-5680/a-turbo(27dBm)/dfs,passive
          5510-5670/a-turbo(27dBm)/dfs,passive
          902-927/b,g,g-turbo,gn20,gn40(30dBm)
 
User avatar
DimaFIX
just joined
Posts: 7
Joined: Wed Apr 18, 2018 7:46 pm
Location: Ukraine

Re: v6.43.8 [stable] is released!

Sun Dec 23, 2018 12:32 am

Symbol: ` in WLAN SSID brake all wlan interfaces.
Or even not a symbol, but a virtual WLAN. When I create a virtual WLAN and reboot hap ac^2, I don't see all interfaces and export doesn't work in the console.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.43.8 [stable] is released!

Sun Dec 23, 2018 2:16 am

Symbol: ` in WLAN SSID brake all wlan interfaces.
Or even not a symbol, but a virtual WLAN. When I create a virtual WLAN and reboot hap ac^2, I don't see all interfaces and export doesn't work in the console.
Is this new? 802.11 spec specifies SSID can be up to 32 bytes. It does NOT require alpha-numeric, printable, etc. Therefore ` should be legal as well as NUL character, trailing space, etc.

This is fresh in my mind because just last week I helped a colleague troubleshoot a new device not connecting to his MikroTik Wi-Fi network. The problem was a trailing space in his SSID, so the fault of the new device.

Therefore using string operations, such as strcopy() is not the correct method. Either way, ` should be valid even in that function. MikroTik should ensure they're allowing any character, and figure out how to properly escape them in the CLI export, which by default would not allow non-printable exports/imports.

Cisco doesn't allow certain characters, or trailing space, but that's also against the spec.

Sent from my Pixel 3 using Tapatalk



Who is online

Users browsing this forum: No registered users and 2 guests