Community discussions

 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

v6.44rc [testing] is released!

Fri Feb 15, 2019 3:58 pm

Version 6.44rc1 has been released.

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.44rc1 (2019-Feb-15 07:12):

Important note!!! Backup before upgrade!
Due to major IPsec configuration changes in RouterOS v6.44beta39+ (see changelog below), it is advised to make a backup before upgrading. Regular downgrade will still be possible as long as no changes in IPsec peer menu are done.

MAJOR CHANGES IN v6.44:
----------------------
!) cloud - added command "/system backup cloud" for backup storing on cloud (CLI only);
!) ipsec - added new "identity" menu with common peer distinguishers;
!) ipsec - removed "main-l2tp" exchange-mode, it is the same as "main" exchange-mode;
!) ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;
!) radius - initial implementation of RadSec (Radius communication over TLS);
!) speedtest - added "/tool speed-test" for ping latency, jitter, loss and TCP and UDP download, upload speed measurements (CLI only);
!) telnet - do not allow to set "tracefile" parameter;
!) upgrade - release channels renamed - "bugfix" to "long-term", "current" to "stable" and "release candidate" to "testing";
!) upgrade - "testing" release channel now can contain "beta" together with "release-candidate" versions;
----------------------

Changes since last beta release:

!) ipsec - added new "identity" menu with common peer distinguishers;
!) radius - initial implementation of RadSec (Radius communication over TLS);
*) dhcpv4-server - use ARP for conflict detection;
*) discovery - use source MAC address from master interface for MNDP packets (introduced in v6.44beta50);
*) fetch - improved file downloading to slow memory;
*) hotspot - added per-user NAT rule generation based on "incoming-filter" and "outgoing-filter" parameters;
*) ike1 - fixed memory leak;
*) ipsec - allow to specify single address instead of IP pool under "mode-config";
*) kidcontrol - added "tur-fri", "tur-mon", "tur-sat", "tur-sun", "tur-thu", "tur-tue", "tur-wed" parameters;
*) lte - added initial support for Telit LN940;
*) lte - added option to lock the LTE operator;
*) smb - added commenting option for SMB users (CLI only);
*) supout - fixed Profile output on single core devices;
*) userman - added first and last name fields for signup form;
*) webfig - improved file handling;
*) winbox - improved file handling;
*) wireless - improved AR5212 response to incoming ACK frames;
*) wireless - improved system stability for all ARM devices with wireless;
*) wireless - improved system stability for all devices with 802.11ac wireless;

Full changelog is available here: https://mikrotik.com/download/changelog ... lease-tree
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 4:02 pm

We are getting close to v6.44 stable release. Please report any version related issues found to support@mikrotik.com
 
R1CH
Forum Veteran
Forum Veteran
Posts: 893
Joined: Sun Oct 01, 2006 11:44 pm

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 4:21 pm

Just to clarify,
*) wireless - improved system stability for all ARM devices with wireless;
*) wireless - improved system stability for all MIPSBE devices with 802.11ac wireless;
Does this improve wireless performance or only RouterOS software stability?

Also what devices are using AR5212? This is a chipset from 2003!
 
User avatar
kmansoft
Frequent Visitor
Frequent Visitor
Posts: 58
Joined: Tue Jan 22, 2019 5:00 pm

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 5:21 pm

Checking for updates in WebFig gives an error:
ERROR: file not found
Channel testing
Installed Version 6.44beta75
Latest Version 6.44rc1

What's new in 6.43.12 (2019-Feb-08 11:46):

*) winbox - improvements in connection handling to router with open winbox service;
Perhaps the changelog file for 6.44rc1 is missing on the server?

The changelog is now there but starts with:

What's new in 5.9 (2011-Nov-29 14:32):
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 5:52 pm

What is the default setting for nf_conntrack_loose? It should be 0 (disabled) for better scaling against TCP DoS attacks. Had it been 0 or 1 before being exposed? Or is it new to the MT kernel branch?

Sent from my Pixel 3 using Tapatalk

 
R1CH
Forum Veteran
Forum Veteran
Posts: 893
Joined: Sun Oct 01, 2006 11:44 pm

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 5:57 pm

That setting should have no effect on DoS resistance unless you aren't properly filtering your inbound traffic. It's set to 1 which is the default, for good reason, otherwise any time a router reboots every single active TCP connection would have to time out instead of continuing to work.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 6:08 pm

You make a good point about reboots creating zombie TCP connections on the nodes, but you are wrong about the DoS mitigation.

Setting nf_conntrack_tcp_loose to 0 (not the default) stops false SYN-ACK and ACK packets before they hit the “listen” state lock, thereby allowing conntrack to scale much higher (also requires a drop invalid state rule).

RedHat says it allows conntrack to scale 20x higher in DoS attacks of these types.

It has no effect on basic SYN flooding, though.

Anyway, good to know what the default is; and sure it's probably best left that way. But at least we now have another mitigation option in the case of scaling problems and DoS attacks.
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 275
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 6:13 pm

ha ha ha. mikrotik goes crazy :)) the 6.44rc1 released in 2011 as 5.9 :)
Capture.PNG
You do not have the required permissions to view the files attached to this post.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 893
Joined: Sun Oct 01, 2006 11:44 pm

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 6:16 pm

You make a good point about reboots creating zombie TCP connections on the nodes, but you are wrong about the DoS mitigation.

Setting nf_conntrack_tcp_loose to 0 (not the default) stops false SYN-ACK and ACK packets before they hit the “listen” state lock, thereby allowing conntrack to scale much higher (also requires a drop invalid state rule).

RedHat says it allows conntrack to scale 20x higher in DoS attacks of these types.

It has no effect on basic SYN flooding, though.

Anyway, good to know what the default is; and sure it's probably best left that way. But at least we now have another mitigation option in the case of scaling problems and DoS attacks.
While this is true for listening services, you should not have any of those exposed to the WAN side of your router, or you'll be a victim of the next Mikrotik vulnerability.
 
yottabit
Member Candidate
Member Candidate
Posts: 160
Joined: Thu Feb 21, 2013 5:56 am

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 6:26 pm

While this is true for listening services, you should not have any of those exposed to the WAN side of your router, or you'll be a victim of the next Mikrotik vulnerability.
Hey great point.

I do expose SSH with public-key-only authentication for remote management in case tunnels go down. So this setting can help with that exposed service. (I also have an auto-upgrade script that checks for updates to stable every night and upgrades. A little dangerous, yes. But a zero-day is worse.)
 
blihtar
just joined
Posts: 2
Joined: Mon Nov 14, 2016 4:12 pm

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 7:14 pm

Checking for updates in WebFig gives an error:
ERROR: file not found
Channel testing
Installed Version 6.44beta75
Latest Version 6.44rc1

What's new in 6.43.12 (2019-Feb-08 11:46):

*) winbox - improvements in connection handling to router with open winbox service;
Perhaps the changelog file for 6.44rc1 is missing on the server?

The changelog is now there but starts with:

What's new in 5.9 (2011-Nov-29 14:32):
same to me starts with 5.9 on CHR where i test it
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 7:22 pm

The correct changelog should be displayed now under check for updates.
 
dhoulbrooke
newbie
Posts: 48
Joined: Sun Apr 19, 2015 7:24 am
Location: Whakatane, New Zealand

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 8:07 pm

Hi!

!) ipsec - added new "identity" menu with common peer distinguishers;

Following my upgrade to 6.44rc1 my IPsec IKEv2 eap radius VPN no longer seems to be working:

ipsec,error identity not found for peer: FQDN: *username*

Using eap radius how should I match the remote id? I have tried auto, ignore, and setting the fqdn to the username as shown in the logs but none seem to match. Config following upgrade from 6.43:

/ip ipsec identity
add auth-method=eap-radius certificate=fullchain.pem_0,fullchain.pem_1 generate-policy=port-strict mode-config=rw-config my-id=fqdn:vpn.example.com peer="IKE2 RW" policy-template-group=rw-policy
 
User avatar
eworm
Member
Member
Posts: 391
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 10:41 pm

With this upgrade I lost the wireless package on wAP LTE, again. The files were downloaded via weak LTE connection.
Reported this before for the update to 6.44beta50: viewtopic.php?f=21&t=139057&start=250#p703960
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.44rc [testing] is released!

Fri Feb 15, 2019 10:44 pm

Reporting on forum again won't help much.

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.
 
User avatar
BG4DRL
just joined
Posts: 7
Joined: Sat Jan 26, 2019 4:00 pm

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 4:37 am

RB4011iGS+5HacQ2HnD-IN
and
wAP 60G AP x2 (Ap Bridge and Station Bridge)
upgraded to RC version

BandWidth test BOTH=756.1 Mbps/847.7 Mbps

recv=0 bps/1758.9 Mbps
send=1793.7 Mbps/0 bps
You do not have the required permissions to view the files attached to this post.
 
joegoldman
Member
Member
Posts: 492
Joined: Mon May 27, 2013 2:05 am

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 5:08 am

what does /tool speed-test test to? Do we host a server? Is it same as bandwidth-test and will TCP tests be CPU limited?
 
anuser
Member
Member
Posts: 397
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 12:37 pm

*) wireless - improved system stability for all ARM devices with wireless;
*) wireless - improved system stability for all MIPSBE devices with 802.11ac wireless;
I can't find the posting anymore, but (Normis?) mentioned that there will be a new wireless driver package, but he didn't mention the time, when this will be published. So does this release include mentioned new drivers?
 
heizer
just joined
Posts: 2
Joined: Mon Mar 20, 2017 3:46 pm

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 3:37 pm


MAJOR CHANGES IN v6.44:

!) speedtest - added "/tool speed-test" for ping latency, jitter, loss and TCP and UDP download, upload speed measurements (CLI only);
Hello there, for when will this new function be available? [i mean, out of beta]
I am really anxious to update the firmware of the routers once it comes out in stable [but preferably, in long-term]
Thanks in advance :D :)
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1302
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 4:38 pm

Simple answer.
When its ready.
 
How to use Splunk to monitor your MikroTik Router

MikroTik->Splunk
 
 
mistry7
Forum Guru
Forum Guru
Posts: 1314
Joined: Tue Oct 13, 2009 11:57 am
Location: Germany

Re: v6.44rc [testing] is released!

Sat Feb 16, 2019 9:29 pm

*) wireless - improved system stability for all ARM devices with wireless;
*) wireless - improved system stability for all MIPSBE devices with 802.11ac wireless;
I can't find the posting anymore, but (Normis?) mentioned that there will be a new wireless driver package, but he didn't mention the time, when this will be published. So does this release include mentioned new drivers?
No
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1219
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.44rc [testing] is released!

Sun Feb 17, 2019 2:37 am

Updated my RBM33G with a RB11E-LTE.
- Modem firmware update - OK
- New LTE additions like cell info - OK
Everything working as expected. :D
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
mducharme
Trainer
Trainer
Posts: 798
Joined: Tue Jul 19, 2016 6:45 pm

Re: v6.44rc [testing] is released!

Sun Feb 17, 2019 11:49 pm

I upgraded from 6.43.12 and had two IPsec peers with RSA key auth. After upgrading to 6.44rc1, only one of the two peers was added to the new ipsec identities tab. I had to recreate the other to bring it up again.
 
User avatar
vecernik87
Long time Member
Long time Member
Posts: 644
Joined: Fri Nov 10, 2017 8:19 am

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 12:14 am

@heizer
... when will this new function be available? [i mean, out of beta]...
its a bit OT, but since more people might be interested... It is not that significant improvement as it may seem. It works as an envelope command to usual ping and btest. These commands runs on background and speedtest just summarize the output. It does not do anything else, what these two commands wouldn't do on their own. Due to that, it can be run even with target devices which do not have support for the command. Only info, which I couldn't find anywhere else is the "jitter" value. Although it can be calculated from ping results, this tool makes it easier.
In the end, it is not some breakthrough, but I can't deny it is a nice simple tool for less experienced people.
 
nkourtzis
Member Candidate
Member Candidate
Posts: 204
Joined: Tue Dec 11, 2012 12:56 am
Location: Greece

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 10:27 am

@heizer
... when will this new function be available? [i mean, out of beta]...
its a bit OT, but since more people might be interested... It is not that significant improvement as it may seem. It works as an envelope command to usual ping and btest. These commands runs on background and speedtest just summarize the output. It does not do anything else, what these two commands wouldn't do on their own. Due to that, it can be run even with target devices which do not have support for the command. Only info, which I couldn't find anywhere else is the "jitter" value. Although it can be calculated from ping results, this tool makes it easier.
In the end, it is not some breakthrough, but I can't deny it is a nice simple tool for less experienced people.
It also displays the peak cpu load on both ends during the test, which is useful, and it also has a test timer, which is handy. And without being sure, I think it is multicore.
Passionate about networks
Enthusiastic about Mikrotik
MTCNA | MTCRE | MTCINE

No trees were killed to send this message,
but a large number of electrons were terribly inconvenienced.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 10:33 am

I upgraded from 6.43.12 and had two IPsec peers with RSA key auth. After upgrading to 6.44rc1, only one of the two peers was added to the new ipsec identities tab. I had to recreate the other to bring it up again.
Could you please send us the supout.rif file from the router?
 
NanaK
just joined
Posts: 4
Joined: Mon Feb 18, 2019 8:53 am

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 10:58 am

Hi there,

I see v6.44rc doesn't have the IPSec policy option to "tunnel" as compared to the previous versions eg. v6.43.2.

Why is this?
You do not have the required permissions to view the files attached to this post.
 
nescafe2002
Long time Member
Long time Member
Posts: 622
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 11:09 am

Screenshots 1 shows ipsec policy template, screenshot 2 shows ipsec policy (not a template).
 
DenisPDA
newbie
Posts: 30
Joined: Tue Sep 04, 2018 5:42 pm

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 11:12 am

Hi there,

I see v6.44rc doesn't have the IPSec policy option to "tunnel" as compared to the previous versions eg. v6.43.2.

Why is this?
ipsec_mt.JPG
You do not have the required permissions to view the files attached to this post.
 
NanaK
just joined
Posts: 4
Joined: Mon Feb 18, 2019 8:53 am

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 12:12 pm

Hi there,

I see v6.44rc doesn't have the IPSec policy option to "tunnel" as compared to the previous versions eg. v6.43.2.

Why is this?
ipsec_mt.JPG
Dennis, this is what I am still seeing
You do not have the required permissions to view the files attached to this post.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 12:39 pm

As nescafe2002 already explained, you have checked the "Template" checkbox under General tab which makes "Tunnel" checkbox not available.
 
alejosalmon
just joined
Posts: 23
Joined: Sun May 31, 2015 3:02 pm

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 2:00 pm

Hello anyone has noticed any improvement in wireless in arm devices? Please commet.
 
Malosa
just joined
Posts: 14
Joined: Thu Nov 15, 2012 4:32 pm

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 4:28 pm

SFP is still flapping (link ok - no link - link ok - no link - link ok...) on a RB4011iGS+.

The SFP is a Cisco module working at 1 Gbps.

I have no problem with the same SFP module on a RB3011UiAS.

The only way to make it stable is disconnecting and connecting the fiber manually. It lasts until the Mikrotik is rebooted, at that moment, it starts flapping again.
 
mfr476
Member Candidate
Member Candidate
Posts: 170
Joined: Thu Oct 11, 2018 4:51 pm

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 5:23 pm

Any improvement in wireless device. Dame problem with arm i don't why mikrotik don't solve this problem yet.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 6:07 pm

Any improvement in wireless device. Dame problem with arm i don't why mikrotik don't solve this problem yet.
Isn't that the answer: viewtopic.php?p=713311#p713311 ?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
mfr476
Member Candidate
Member Candidate
Posts: 170
Joined: Thu Oct 11, 2018 4:51 pm

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 6:27 pm

Is there an approximate date when the problem will be resolved?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1407
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44rc [testing] is released!

Mon Feb 18, 2019 9:21 pm

I might try to guess, but without more details we can not answer if, for example, "problem with ARM wireless" is resolved. If problem is related to this RouterOS release, then please post more details about it. If it is not related to release, then write e-mail to support@mikrotik.com. Unfortunately things are not so black and white. There might be a problem with configuration. software, hardware, limits of the chip, etc. It simply is not possible to answer anything about your problem as long as we are not aware about what exactly are you talking about.

Wireless related changes in this release should resolve little regression in wireless performance on ARM devices introduced in 6.44beta releases. Other fix is made in order to resolve problems that in most cases resulted in Watchdog reboot or 100% CPU usage on your router. However, these were rare cases and most of them were introduced in v6.43. Problem was possible also before, however, 6.43 made such problem to appear much more often.
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 131
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 10:20 am

I am trying several 1 Gbps SFP modules on a RB4011 and they seem to be working fine with the betas and rc.

Both Mikrotik (1000BASE-SX and 1000BASE-LX) and Solid Optics (again, single mode and multi mode).

They work with auto negotiation set to on and speed set to 1 Gbps.

Using the stable releases (6.43.12 included) I can't establish a link. With 6.44 betas and rc it works, it just needs to set the interface to 1 Gbps
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] speed=1Gbps
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 106
Joined: Wed Feb 10, 2016 3:55 pm

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 12:03 pm

Using the stable releases (6.43.12 included) I can't establish a link. With 6.44 betas and rc it works, it just needs to set the interface to 1 Gbps
These fixes will be included in upcoming v6.44.
 
Malosa
just joined
Posts: 14
Joined: Thu Nov 15, 2012 4:32 pm

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 12:26 pm

I am trying several 1 Gbps SFP modules on a RB4011 and they seem to be working fine with the betas and rc.

Both Mikrotik (1000BASE-SX and 1000BASE-LX) and Solid Optics (again, single mode and multi mode).

They work with auto negotiation set to on and speed set to 1 Gbps.

Using the stable releases (6.43.12 included) I can't establish a link. With 6.44 betas and rc it works, it just needs to set the interface to 1 Gbps
/interface ethernet
set [ find default-name=sfp-sfpplus1 ] speed=1Gbps

Okay, I didn't force to 1 Gbps. In my opinion, I think it should work with autonegotiation.

Perhaps in the 6.44 final, autonegotiation works.

I will test again in next rc, if not automatically, forcing the speed, like you said.

Thanks.
 
User avatar
eworm
Member
Member
Posts: 391
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 12:40 pm

Upgrading from stable to testing I have allow-none-crypto enabled:
/ip ssh set allow-none-crypto=yes strong-crypto=yes
I think this should default to disabled.

If you want to keep the former behavior please consider setting it to disabled if strong-crypto has been enabled before. I am certain someone setting strong-crypto to enabled does not want allow-none-crypto.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
szkalman
just joined
Posts: 6
Joined: Fri Aug 10, 2018 4:37 pm

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 12:54 pm

On ltap, the gps gives back wrong coordinates for me. After a downgrade to stable, i see the right coordinates.
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 131
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 1:29 pm

Using the stable releases (6.43.12 included) I can't establish a link. With 6.44 betas and rc it works, it just needs to set the interface to 1 Gbps
These fixes will be included in upcoming v6.44.
I imagined :)

So far I'm checking all the betas and rcs to make sure it still works.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24205
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 1:31 pm

On ltap, the gps gives back wrong coordinates for me. After a downgrade to stable, i see the right coordinates.
How do you know which one is right? Give an example please
No answer to your question? How to write posts
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 131
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 1:39 pm


Okay, I didn't force to 1 Gbps. In my opinion, I think it should work with autonegotiation.

Perhaps in the 6.44 final, autonegotiation works.

I will test again in next rc, if not automatically, forcing the speed, like you said.

Thanks.
I think negotiation is taking place. Otherwise the switch to which I am connecting probably wouldn't establish the link.

Making an educated guess, I think that by setting the speed parameter you are not forcing the interface, but changing the operating mode of the SFP/+ cage instead and telling autonegotiation not to advertise 10 Mbps, 100 Mbps nor 10 Gbps.

That said, it would make sense to do it automatically. They can identify the SFP module and it's obvious wether it's a SFP or SFP+ module.
 
User avatar
eworm
Member
Member
Posts: 391
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 2:10 pm

On ltap, the gps gives back wrong coordinates for me. After a downgrade to stable, i see the right coordinates.
How do you know which one is right? Give an example please
Probably he knows the coordinates the device is located. Something about wrong coordinates has been reported for 6.44beta75:
viewtopic.php?f=21&t=139057&start=350#p714713
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Tue Feb 19, 2019 3:54 pm

Upgrading from stable to testing I have allow-none-crypto enabled:
/ip ssh set allow-none-crypto=yes strong-crypto=yes
I think this should default to disabled.

If you want to keep the former behavior please consider setting it to disabled if strong-crypto has been enabled before. I am certain someone setting strong-crypto to enabled does not want allow-none-crypto.
This is cosmetic only. Even when both are set to yes, null crypto is not allowed. We will adjust the "allow-none-crypto" parameter to better represent its value in the stable release.
 
chubbs596
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Dec 06, 2013 6:07 pm

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 8:45 am

Hi Guys

I have ran into an issue with simple queues, seem rate-limiting is not working as expected, I have done testing on CCR1009-7G-1C-1S+ and hEX S (RB760iGS) with similar results

I don’t have access to the hEX S any more but now using the CCR1009-7G-1C-1S+, I have send a mail to support@mikrotik.com with supout.rif

uptime: 5h7m18s
version: 6.44rc1 (testing)
build-time: Feb/15/2019 07:12:10
factory-software: 6.38.5
free-memory: 1718.2MiB
total-memory: 1984.0MiB
cpu: tilegx
cpu-count: 9
cpu-frequency: 400MHz
cpu-load: 16%
free-hdd-space: 81.1MiB
total-hdd-space: 128.0MiB
architecture-name: tile
board-name: CCR1009-7G-1C-1S+
platform: MikroTik

Below is the configure queue at 150M/150M and if I run a speedtest on this I get below see screenshot

/queue simple
add max-limit=150M/150M name=INTERNET queue=default/default target=3_vl_data total-queue=default
add limit-at=2M/2M max-limit=150M/150M name=hi-prio packet-marks=ack,icmp,voice parent=INTERNET priority=1/1 queue=default/default target=3_vl_data total-priority=1 total-queue=default
add limit-at=20M/20M max-limit=150M/150M name=roku packet-marks=roku parent=INTERNET priority=3/3 queue=default/default target=3_vl_data total-priority=3 total-queue=default
add limit-at=15M/15M max-limit=150M/150M name=http packet-marks=HTTP parent=INTERNET priority=4/4 queue=default/default target=3_vl_data total-priority=4 total-queue=default
add limit-at=5M/5M max-limit=150M/150M name=guest packet-marks=guest parent=INTERNET priority=5/5 queue=default/default target=3_vl_data total-priority=5 total-queue=default
add limit-at=3M/3M max-limit=150M/150M name=data_unmarked packet-marks=no-mark parent=INTERNET priority=7/7 queue=default/default target=3_vl_data total-priority=6 total-queue=default
add bucket-size=0.03/0.03 disabled=yes max-limit=5M/5M name=Guest queue=default/default target=100_vl_guest

Speedtest result is 72Mbps down and 132Mbps up

With Queue disabled, and only limited from provider side to 150M/150M


144Mbps down and 145 Mbps up
 
szkalman
just joined
Posts: 6
Joined: Fri Aug 10, 2018 4:37 pm

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 1:41 pm

I'm next to the device and it shows that i'm ~100km far from the real place.

On ltap, the gps gives back wrong coordinates for me. After a downgrade to stable, i see the right coordinates.
How do you know which one is right? Give an example please
Probably he knows the coordinates the device is located. Something about wrong coordinates has been reported for 6.44beta75:
viewtopic.php?f=21&t=139057&start=350#p714713
Last edited by szkalman on Wed Feb 20, 2019 1:48 pm, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24205
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 1:48 pm

LtAP doesn't have a map inside, so the question again is - how are you checking this? Did you use the coordinates in google maps or somewhere else?
No answer to your question? How to write posts
 
szkalman
just joined
Posts: 6
Joined: Fri Aug 10, 2018 4:37 pm

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 1:50 pm

I check it with google maps.

I have a script in the ltap, that uploads the coordinates into an sql database. When i insert the last coordinates into the google maps, it show the wrong place.
With stable version it works well.
LtAP doesn't have a map inside, so the question again is - how are you checking this? Did you use the coordinates in google maps or somewhere else?
Last edited by szkalman on Wed Feb 20, 2019 1:57 pm, edited 1 time in total.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24205
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 1:55 pm

Email support@mikrotik.com with actual information from the router. There could be several causes - poor signal, incorrect use of google maps, etc .
No answer to your question? How to write posts
 
szkalman
just joined
Posts: 6
Joined: Fri Aug 10, 2018 4:37 pm

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 2:00 pm

It's not becouse of the poor signal, etc. With the stable version, it works normally.

Email support@mikrotik.com with actual information from the router. There could be several causes - poor signal, incorrect use of google maps, etc .
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24205
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 2:03 pm

If there is a bug, please send the information to support :D
No answer to your question? How to write posts
 
szkalman
just joined
Posts: 6
Joined: Fri Aug 10, 2018 4:37 pm

Re: v6.44rc [testing] is released!

Wed Feb 20, 2019 2:20 pm

Thanks, i will! :)
If there is a bug, please send the information to support :D
 
chubbs596
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Fri Dec 06, 2013 6:07 pm

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 1:05 am

Hi Guys

I have ran into an issue with simple queues, seem rate-limiting is not working as expected, I have done testing on CCR1009-7G-1C-1S+ and hEX S (RB760iGS) with similar results

I don’t have access to the hEX S any more but now using the CCR1009-7G-1C-1S+, I have send a mail to support@mikrotik.com with supout.rif

uptime: 5h7m18s
version: 6.44rc1 (testing)
build-time: Feb/15/2019 07:12:10
factory-software: 6.38.5
free-memory: 1718.2MiB
total-memory: 1984.0MiB
cpu: tilegx
cpu-count: 9
cpu-frequency: 400MHz
cpu-load: 16%
free-hdd-space: 81.1MiB
total-hdd-space: 128.0MiB
architecture-name: tile
board-name: CCR1009-7G-1C-1S+
platform: MikroTik

Below is the configure queue at 150M/150M and if I run a speedtest on this I get below see screenshot

/queue simple
add max-limit=150M/150M name=INTERNET queue=default/default target=3_vl_data total-queue=default
add limit-at=2M/2M max-limit=150M/150M name=hi-prio packet-marks=ack,icmp,voice parent=INTERNET priority=1/1 queue=default/default target=3_vl_data total-priority=1 total-queue=default
add limit-at=20M/20M max-limit=150M/150M name=roku packet-marks=roku parent=INTERNET priority=3/3 queue=default/default target=3_vl_data total-priority=3 total-queue=default
add limit-at=15M/15M max-limit=150M/150M name=http packet-marks=HTTP parent=INTERNET priority=4/4 queue=default/default target=3_vl_data total-priority=4 total-queue=default
add limit-at=5M/5M max-limit=150M/150M name=guest packet-marks=guest parent=INTERNET priority=5/5 queue=default/default target=3_vl_data total-priority=5 total-queue=default
add limit-at=3M/3M max-limit=150M/150M name=data_unmarked packet-marks=no-mark parent=INTERNET priority=7/7 queue=default/default target=3_vl_data total-priority=6 total-queue=default
add bucket-size=0.03/0.03 disabled=yes max-limit=5M/5M name=Guest queue=default/default target=100_vl_guest

Speedtest result is 72Mbps down and 132Mbps up

With Queue disabled, and only limited from provider side to 150M/150M


144Mbps down and 145 Mbps up
I have not received any feedback from support,

Anyone else seeing this issue?
 
msatter
Forum Guru
Forum Guru
Posts: 1229
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 1:25 am

It takes a bit longer and if you don't have any response from support during this monday then send a reminder.
Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta / Winbox 3.20 / MikroTik APP 1.3.4
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 1:43 pm

Version 6.44rc4 has been released.

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.44rc4 (2019-Feb-22 10:11):

Important note!!! Backup before upgrade!
Due to major IPsec configuration changes in RouterOS v6.44beta39+ (see changelog below), it is advised to make a backup before upgrading. Regular downgrade will still be possible as long as no changes in IPsec peer menu are done.

MAJOR CHANGES IN v6.44:
----------------------
!) cloud - added command "/system backup cloud" for backup storing on cloud (CLI only);
!) ipsec - added new "identity" menu with common peer distinguishers;
!) ipsec - removed "main-l2tp" exchange-mode, it is the same as "main" exchange-mode;
!) ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;
!) radius - initial implementation of RadSec (Radius communication over TLS);
!) speedtest - added "/tool speed-test" for ping latency, jitter, loss and TCP and UDP download, upload speed measurements (CLI only);
!) telnet - do not allow to set "tracefile" parameter;
!) upgrade - release channels renamed - "bugfix" to "long-term", "current" to "stable" and "release candidate" to "testing";
!) upgrade - "testing" release channel now can contain "beta" together with "release-candidate" versions;
----------------------

Changes in this release:

!) ipsec - added new "identity" menu with common peer distinguishers;
*) ike1 - do not allow using RSA-key and RSA-signature authentication methods simultaneously on single peer;
*) interface - added "pwr-line" interface support (more information will follow in next newsletter);
*) rb4011 - improved SFP+ interface linking to 1Gbps;
*) ssh - added "allow-none-crypto" parameter to disable "none" encryption usage (CLI only);
*) winbox - organized wireless parameters between simple and advanced modes;
*) wireless - improved NV2 performance for all ARM devices;

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as expected or after crash.
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 131
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 2:43 pm

*) rb4011 - improved SFP+ interface linking to 1Gbps;
This looks good :) Now there's no need to specify the speed, the interface works with the default configuration.
[admin@MikroTik] /interface ethernet> export 
# feb/22/2019 13:38:14 by RouterOS 6.44rc4
# software id = JND5-07E0
#
# model = RB4011iGS+
# serial number = 
[admin@MikroTik] /interface ethernet> monitor 10
                      name: sfp-sfpplus1
                    status: link-ok
          auto-negotiation: done
                      rate: 1Gbps
               full-duplex: yes
           tx-flow-control: no
           rx-flow-control: no
               advertising: 
  link-partner-advertising: 
        sfp-module-present: yes
               sfp-rx-loss: no
              sfp-tx-fault: no
                  sfp-type: SFP-or-SFP+
        sfp-connector-type: LC
       sfp-link-length-9um: 10000m
           sfp-vendor-name: SOLID-OPTICS
    sfp-vendor-part-number: EX-SFP-1GE-LX-SO
       sfp-vendor-revision: A
         sfp-vendor-serial: SOS131L.32123
    sfp-manufacturing-date: 19-01-08
            sfp-wavelength: 1310nm
           sfp-temperature: 42C
        sfp-supply-voltage: 3.256V
       sfp-tx-bias-current: 16mA
              sfp-tx-power: -5.744dBm
              sfp-rx-power: -6.459dBm
              

Before this update it was needed to manually set the speed in order to select the operating mode of the SFP cage. Now
it seems it will work out of the box.

So, are you doing automatically based on the information provided by the SFP/SFP+ EEPROM?

Now, some questions/suggestion:

Is autonegotiation taking place? In that case it would be great to see the "advertising" and "link partner adversising" filled out. I notice
that these fields are always empty on SFP interfaces?

Does this change the compatibility with passive DA cables? It's been reported on another thread that ONT/SFP modules (previously known
not to work and unsupported) now work.

Good job ;)
 
User avatar
skylark
MikroTik Support
MikroTik Support
Posts: 106
Joined: Wed Feb 10, 2016 3:55 pm

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 3:15 pm

Yes, with the latest release-candidate version they should work with auto-negotiation enabled. Also, S-RJ01 are supported now.

DAC is a bit different case, but we will look into it.
 
alejosalmon
just joined
Posts: 23
Joined: Sun May 31, 2015 3:02 pm

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 4:22 pm

Hello please comment your results about this:
*) wireless - improved NV2 performance for all ARM devices;
 
heizer
just joined
Posts: 2
Joined: Mon Mar 20, 2017 3:46 pm

Re: v6.44rc [testing] is released!

Fri Feb 22, 2019 6:33 pm

@heizer
... when will this new function be available? [i mean, out of beta]...
its a bit OT, but since more people might be interested... It is not that significant improvement as it may seem. It works as an envelope command to usual ping and btest. These commands runs on background and speedtest just summarize the output. It does not do anything else, what these two commands wouldn't do on their own. Due to that, it can be run even with target devices which do not have support for the command. Only info, which I couldn't find anywhere else is the "jitter" value. Although it can be calculated from ping results, this tool makes it easier.
In the end, it is not some breakthrough, but I can't deny it is a nice simple tool for less experienced people.
Hi there
Sure it is, and we have a CCR in our NOC with 6.44RC to do some tests and it works as expected [including test done with 'speed-test' tool]
i want to upgrade firmware on routers when this is ready, because we do two types of test:
One test to default gateway, to know how much maximum throughput we have in that link [wireless PTP link], and then how much troughput we have to our NOC.
And the default gateway test is something we can't do right now with 'speed-test' tool.
Also, i have a request
is there any possibility to specify in which direction the test can be done? and the time duration?
I mean: TCP upload and download only, with 'x' time duration, skipping the UDP test, ping packet size, amount of pings packets send.
I know some of these features is available now in btest tool, [and i know in recent versions of RC btest tool is now multicore] i want it in speed-test because of multicore reason and is more nicer to get a report of that for some ppl.
Thank you Mikrotik team, you are doing an excellent job!!
 
TheCondor
just joined
Posts: 12
Joined: Sun Jul 26, 2015 4:00 pm

Re: v6.44rc [testing] is released!

Sun Feb 24, 2019 2:45 pm

How IPsec modecfg matching works?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44rc [testing] is released!

Sun Feb 24, 2019 9:26 pm

Huh.. Funny thing, trying to upgrade 6.44 beta28 to rc4:
[admin@XXXXX-Main] > log print 
22:17:21 system,info installed routeros-mipsbe-6.44rc4 
22:17:21 system,info installed multicast-6.44rc4 
22:17:21 system,error not enough space for upgrade 
22:17:21 system,info router rebooted 
I thought if packages are downloaded, then space is enough %)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
Paternot
Long time Member
Long time Member
Posts: 607
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.44rc [testing] is released!

Mon Feb 25, 2019 2:15 am

Huh.. Funny thing, trying to upgrade 6.44 beta28 to rc4:
[admin@XXXXX-Main] > log print 
22:17:21 system,info installed routeros-mipsbe-6.44rc4 
22:17:21 system,info installed multicast-6.44rc4 
22:17:21 system,error not enough space for upgrade 
22:17:21 system,info router rebooted 
I thought if packages are downloaded, then space is enough %)
Packets are downloaded to ramdrive, aren't they?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8308
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44rc [testing] is released!

Mon Feb 25, 2019 8:27 am

They are, but it's the first time I face "out of space" during the installation, not during downloading :)
I was worrying because some packages have been installed already with new version, according to the log. But all versions stayed the same.
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
sid5632
Member
Member
Posts: 352
Joined: Fri Feb 17, 2017 6:05 pm

Re: v6.44rc [testing] is released!

Mon Feb 25, 2019 10:51 am

!) ipsec - added new "identity" menu with common peer distinguishers;
!) ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;
The Settings button, which used to be on the "Users" tab, has now been moved to the "Keys" tab.
This seems a very strange place to put it. Surely it should have been moved to the "Identities" tab, shouldn't it? This is a much more logical place for it.
Also, the dialog box still opens with a title saying "IPSec User Settings". This should be re-titled "IPSec Identity Settings".
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 494
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44rc [testing] is released!

Tue Feb 26, 2019 9:22 am

New version 6.44 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=145793

Who is online

Users browsing this forum: No registered users and 11 guests