Community discussions

 
radenli
just joined
Posts: 13
Joined: Tue Apr 04, 2017 10:45 am

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 8:24 pm

*) wireless - improved connection stability for new model Apple devices;
*) wireless - improved NV2 performance for all ARM devices;
*) wireless - improved system stability for all ARM devices with wireless;
*) wireless - improved system stability for all devices with 802.11ac wireless;
Just bought a Cap AC and these changes are really in time :D
 
schadom
Member Candidate
Member Candidate
Posts: 132
Joined: Sun Jun 25, 2017 2:47 am
Location: Austria

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 8:26 pm

Updated a CCR1009 and RB4011 without any issues. Great work MT!
Now please make us happy with some BGP improvements in 6.45 :-)
 
User avatar
Chaosphere64
newbie
Posts: 28
Joined: Wed Aug 10, 2016 10:19 pm

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 8:58 pm

Updated all MT devices to 6.44. Now in Winbox Neighbors view the devices are no longer represented by their Bridges Admin MAC Address but by the MAC Address of the respective ethernet interface. This is not what I wanted, so the question is: is it a bug? Can I get the "old" setting somehow?
 
Pea
Member Candidate
Member Candidate
Posts: 189
Joined: Fri Jul 17, 2015 11:07 pm
Location: Czech

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 10:18 pm

*) capsman - always accept connections from loopback address;

Hi, I tested but I still need input firewall rule to accept router IP to get working CAP on the same board as CAPsMAN:
/ip firewall filter
add action=accept chain=input protocol=udp dst-address="router IP" src-address="router IP"

/caps-man manager interface
set [ find default=yes ] forbid=yes
add disabled=no interface=bridge-local

/interface wireless cap
set discovery-interfaces=bridge-local interfaces=wlan1
Could you please share what should be the preferred config for CAP in CAPsMAN and update wiki?
https://wiki.mikrotik.com/wiki/Manual:S ... in_CAPsMAN
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 154
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 10:25 pm

Any news about "Delegated-IPv6-Prefix" attribute for PPPoE??? → viewtopic.php?t=89443
Half Live 3 come out faster?
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
tamagochi
just joined
Posts: 2
Joined: Tue Sep 18, 2018 4:38 pm

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 10:57 pm

Email test is done, but sending e-mail from /tools/logging sender e-mail address is empty.
Log showing:
21:16:03 e-mail,error Error sending e-mail <l2tp,ppp,info,account xxxxxxx logged out, 142 57839 5 : invalid TO address
------
Piece from e-mail server log:
Feb 26 21:16:03 mail-xxxx postfix/submission/smtpd[2193]: NOQUEUE: reject: RCPT from xxxxx.xxx[192.168.xx.x]: 554 5.7.1 <admin@xxxx.xx>: Recipient address rejected: Policy rejection due to null sender; from=<> to=<admin@xxxx.xx> proto=ESMTP helo=<[192.168.xx.x]>
-----.
Firmware is 6.44 on hardware CCR1009-7G-1C-1S+

Early fimware version 6.43.12 and not showing this problem.

Sincerelly: Tamagochi
 
madman22
just joined
Posts: 8
Joined: Fri Mar 23, 2018 4:28 pm

Re: v6.44 [stable] is released!

Tue Feb 26, 2019 11:15 pm

Can confirm the RB4011 SFP+ port is correctly working with a 3rd party 1G sfp. Thanks guys!
 
geiger
just joined
Posts: 1
Joined: Sat Jan 26, 2019 12:48 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 12:26 am

RB4011iGS+5HacQ2HnD 6.44
After install, L2TP/IPSEC tunnels stopped working, "no auth key". I gave them the secrets peer by peer. The tunnels went up. Just in case i made a reboot, and then again all connections were down. Then i realized that the full ipsec menu was EMPTY. Tried to make supout, it was stuck at 1%. Made a restore from backup, now everything seems to be ok. Strange as it is. :)
MTCNA, MTCRE, MTCTCE, MTCWE
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 2:51 am

Just i need info about this:

!) ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;

Basically from now we have to use identity tab. Because USER has been replaced with it. I got PC clients using this features

Does it will covered ?

/ip ipsec identity
add auth-method=pre-shared-key-xauth peer=peer1 secret="secret" xauth-login=user xauth-password=pass
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
Paternot
Long time Member
Long time Member
Posts: 573
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 4:00 am

Just upgraded to 6.44
/ip ipsec identity
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=alfandega1
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=alfandega2
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=paternot
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=valida
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=victor
All of them are related to a "peer9" group. It didn't exist - was created on the upgrade.

This is my peer tab:
/ip ipsec peer
add comment="Redescambo psk xauth" name=peer9 passive=yes profile=profile_1
Working ok after upgrade.
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 5:29 am

Just upgraded to 6.44
/ip ipsec identity
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=alfandega1
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=alfandega2
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=paternot
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=valida
add auth-method=pre-shared-key-xauth generate-policy=port-strict peer=peer9 policy-template-group=redescambo xauth-login=victor
All of them are related to a "peer9" group. It didn't exist - was created on the upgrade.


This is my peer tab:
/ip ipsec peer
add comment="Redescambo psk xauth" name=peer9 passive=yes profile=profile_1
that was my point User has been replaced with pre-shared-key-xauth user and password.

I want to be sure before implement on my clients

Working ok after upgrade.
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 7:40 am

Kampfwurst - What is the error that you get? Does your router have an access to cloud2.mikrotik.com? Test it from CLI (Winbox would use computers DNS in order to resolve this address);
Simono - Please provide an example rule that you use in access list and interface configuration within an e-mail to support@mikrotik.com;
Chupaka - We will update wiki page as soon as possible;
WirelessRudy - Do you have an access to this IP address? Please provide supout file from your router to support@mikrotik.com. Speed Test works just fine for me to/from all accessible IP addresses;
osc86, MDE, geiger - Please provide supout file from your router to support@mikrotik.com;
lenciso - Please provide more information about what kind of crash did you experience on your router;
isacalmeida - Please provide an example. This fix was made in order to fix an issue when, for example, you have PPPoE tunnel which creates default route and then have an L2TP tunnel over it. Then special route towards L2TP server must be created dynamically which uses PPPoE as a gateway, if L2TP adds its own default route. Otherwise L2TP server would be reachable over L2TP tunnel itself which is not correct;
Chaosphere64 - Are these devices discovered by MNDP? If yes, then please provide supout file from your router to support@mikrotik.com;
Pea - This change allows to specify interfaces under "/caps-man manager interface" menu and at the same time allows to use router itself as a CAP and CAPsMAN at the same time. Before you could not forbid all and allow traffic from router itself to CAPsMAN. It affects interface list not the firewall. Firewall accept rule still must be present;
saaremaa - What is the question here actually? Delegated-IPv6-Prefix is already working for DHCP service (RADIUS). Such parameter is not available yet for PPP service. If you make PPPoE server which then distributes addresses by using DHCP service, then this will not work since users are authenticated by using PPP service, not DHCP;
tamagochi - Do you mean that e-mail settings were corrupted? I do not see how this would be possible by this upgrade. If you downgrade router back, then setting re-appears? Please test if when you downgrade device, set TO parameter, upgrade back and the setting is gone again;
Nicky - If details about new IPsec implementation are not clear from the changelog, then please write to support@mikrotik.com. Provide your configuration and an example of configuration which can not seem to get working. We will help you as soon as possible;
 
kefealo
just joined
Posts: 3
Joined: Mon Jan 29, 2018 11:43 am
Location: Cegléd

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 8:23 am

Hello,


After the upgrade, the VPN client cannot connects. One of my colleague updated 5 routers. Please don't ask me why, but not working. Can I ask any expert where and what can I have to change to make it working again? :(

TIA
 
TimurA
Member Candidate
Member Candidate
Posts: 113
Joined: Sat Dec 15, 2018 6:13 am
Location: Tashkent
Contact:

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 8:27 am

There is a problem on RB4011 on wifi 5Ghz. CAPSMAN mode or not.

When a client transitions from RB4011 wifi 5ghz to another device, the physical interface 5ghz crash. Enable only reload.

While seen only with the iPhone XS, XS Max, new iPad Pro. This is a problem only on RB4011.

So it was up to 6.44. You have not fixed this problem. Sent you the supout.rif file to the support@mikrotik.com, Ticket#2019022722003126
Last edited by TimurA on Wed Feb 27, 2019 8:45 am, edited 1 time in total.
Image
 
User avatar
grusu
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 8:31 am

Hello,


After the upgrade, the VPN client cannot connects. One of my colleague updated 5 routers. Please don't ask me why, but not working. Can I ask any expert where and what can I have to change to make it working again? :(

TIA
Hi,

What VPN solution do you use? I guess you mean you can not connect to the VPN server on the Mikrotik router.
If you use IPSEC check change log:
*) ipsec - moved "profile" menu outside "peer" menu;
and
ipsec - removed "users" menu, XAuth user configuration is now handled by "identity" menu;

Best regards,
Geo
 
User avatar
saaremaa
Member Candidate
Member Candidate
Posts: 154
Joined: Tue Feb 02, 2010 7:48 pm
Location: Baltijos šalių miestas

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 8:51 am

strods, Your message → viewtopic.php?f=1&t=89443&start=100#p691742
In short, if under "/radius" menu you have selected service "DHCP", then "Delegated-IPv6-Prefix" is supported. If under "/radius" menu you have selected "PPP" service, then "Delegated-IPv6-Prefix" is not supported at the moment.
OK understood.
One step at the time - we added "Delegated-IPv6-Prefix" suport for DHCP in v6.43, we will see what we can do about PPP service in future RouterOS releases.
in v6.44 this does not work for me.
My users work with PPP(PPPoE ) and should receive a static prefix from Billing (tied to an account) via "Delegated-IPv6-Prefix" attribute. This is a requirement of government.
When authorization has occurred, a dynamic DHCPV6 server should be created for this PPPoE connection and distribute the associated (in billing) IPV6-Prefix to the subscriber.
CMDR Saaremaa (Gutamaya Sierra Alpha Alpha)
 
User avatar
ErfanDL
Member Candidate
Member Candidate
Posts: 266
Joined: Thu Sep 29, 2016 9:13 am
Location: IRAN
Contact:

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 9:18 am

*) hotspot - added "https-redirect" under server profiles;
I can't find this option under server profiles !
 
eddieb
Member Candidate
Member Candidate
Posts: 126
Joined: Thu Aug 28, 2014 10:53 am
Location: Netherlands

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 9:31 am

Updated all my devices from 6.43.12 to 6.44 thru dude, no problems

Eddie
Running 6.45.1 (stable) on :
CCR1009-8G-1S (2x ipsec/l2tp site-to-site, ipsec/l2tp roadwarrior, dhcpd, dns), CRS125-24G-1S, RB1100, RB962UiGS-5HacT2HnT (10pc), RB931-2nD, RB951, RB750GL ,RB2011UAS-RM, CHR running dude (CHR running in VirtualBox on OSX)
 
prorekhin
just joined
Posts: 1
Joined: Wed Feb 27, 2019 7:29 am

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 10:22 am

Hello all
After performed update 6.44 on 2011UiAS E-mail notification is working incorrectly (Log messages send to me by e-mail). As I have found out field "from" in e-mail message does not fill (It is empty). Moreover if you try to check e-mail it works rightly and field from fill corectly.
Could you help me to fix it, please? May be I don't know anything? Before update It was working rightly.
 
Note
newbie
Posts: 49
Joined: Fri Jun 03, 2016 12:39 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 10:36 am

Mikrotik....... ok and great job,

Now we need to get priorities first.

speed test is nice, i understand but is useless, some other things u implement also ok and we ty for that, but.........

We need SQM package with codel algorithm

If u undertsand what is this ( i know u understand ) u will include it i suppose sometime.

Regards.
 
User avatar
eworm
Member
Member
Posts: 339
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 10:47 am

Upgraded a RB851G (both RouterOS and RouterBOOT) from 6.42.12 today. I get errors every time I try to save a backup file (both local and cloud, same error).
[admin@xxxx] > /system backup save 
Saving system configuration
Configuration backup saved
08:54:42 echo: backup,critical error creating backup file: could not read all configuration files
Try to regenerate the ssh host keys:
/ ip ssh regenerate-host-key
Thank you @eworm! You nailed it! I was just reading this other thread where you had the same issue, but for a previous version.
As this pops up every now and then... Mikrotik should consider extending the error handling - in case of ssh host key file print something like: "could not read ssh host key file, try to regenerate: / ip ssh regenerate-host-key"
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
VincentL
just joined
Posts: 11
Joined: Fri Feb 03, 2017 3:27 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 11:11 am

Hello,

After upgrade from 6.43.8 to 6.44 all my comments were lost for /ip ipsec policies and peers. I manage more than 60 VPN to one of my Mikrotiks and Mikrotiks I installed to customer use sometimes 3 or more VPN
Can you imagine the amount of work needed to put it back in order if I update all my device? Luckily I tested on one before a massive upgrade.

Please keep comments, they are useful.

Vincent
 
User avatar
BartoszP
Forum Guru
Forum Guru
Posts: 1699
Joined: Mon Jun 16, 2014 1:13 pm
Location: Poland

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 12:44 pm

Strange ... IPSec works for me :-) after upgrade 6.43.12 -> 6.44

IPSeced IPIP and GRE tunnels work smooth after upgrade, self-reconnected without problems. Comments still in place.
Real admins use real keyboards.
 
Paternot
Long time Member
Long time Member
Posts: 573
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 12:59 pm


that was my point User has been replaced with pre-shared-key-xauth user and password.

I want to be sure before implement on my clients

Working ok after upgrade.
I was using pre-shared-key-xauth and password. Yes, the system created that "peer9" out of the blue - but it did it only to have something on the peers tab. It is just a placeholder.
 
DenisPDA
just joined
Posts: 21
Joined: Tue Sep 04, 2018 5:42 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:06 pm

ROS 6.44. When exporting
/ip neighbor discovery-settings
, inversion is not taken into account. Be careful!
ROS_6.44_neighbor.jpg
You do not have the required permissions to view the files attached to this post.
 
VincentL
just joined
Posts: 11
Joined: Fri Feb 03, 2017 3:27 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:13 pm

Strange ... IPSec works for me :-) after upgrade 6.43.12 -> 6.44

IPSeced IPIP and GRE tunnels work smooth after upgrade, self-reconnected without problems. Comments still in place.
Some of my device are in 6.43.12. I ll test.
Thank you for your reply.

Vincent
 
Kindis
Member Candidate
Member Candidate
Posts: 241
Joined: Tue Nov 01, 2011 6:54 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:19 pm

I have now updated two wAP AC, One 493G, Two CHR's, one 4011 and two 3011. One 3011 hold several GRE tunnels with IPSec and no issues after upgrade. Endpoints to where GRE tunnels are connecting are still on 6.43.12 so no issues between versions either.
Great job MT!
 
nescafe2002
Long time Member
Long time Member
Posts: 599
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:30 pm

ROS 6.44. When exporting
/ip neighbor discovery-settings
, inversion is not taken into account. Be careful!
ROS_6.44_neighbor.jpg

This is strictly spoken not a 6.44 issue, as the problem exists in 6.43 as well. You are welcome to report it, with supout.rif, to support.
 
deanMKD1
Member
Member
Posts: 345
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:38 pm

Upgraded my hAP AC2 from 6.43.4 without issues. Working fine ! Thanks MT
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 453
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 1:58 pm

Currently looks like missing IPsec configuration after an upgrade is caused by having a 6.44beta version installed at some point in the past. If the router is missing some IPsec related configuration after an upgrade, please generate a supout.rif file as soon as possible before doing any other changes and send it to us.

Paternot, everything looks good for you. Users menu was removed, each user is automatically converted to an identity and assigned to the peer.
 
xtrans
just joined
Posts: 6
Joined: Fri Feb 15, 2019 3:44 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 2:32 pm

https-redirect is not working
 
VincentL
just joined
Posts: 11
Joined: Fri Feb 03, 2017 3:27 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 2:51 pm

Currently looks like missing IPsec configuration after an upgrade is caused by having a 6.44beta version installed at some point in the past. If the router is missing some IPsec related configuration after an upgrade, please generate a supout.rif file as soon as possible before doing any other changes and send it to us.

Paternot, everything looks good for you. Users menu was removed, each user is automatically converted to an identity and assigned to the peer.
@Emils,

I alway use stable channel. So I m sure I never had beta somewhere on my devices.
I modify my configuration after finding missing configuration.
if that happen again, I ll send supout.rif file.

Kind regards,

Vincent
 
Paternot
Long time Member
Long time Member
Posts: 573
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 3:18 pm

Paternot, everything looks good for you. Users menu was removed, each user is automatically converted to an identity and assigned to the peer.
Yes, it all works great - excellent job! I was pointing out to nichky that the upgrade went smooth. :D
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3069
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 3:36 pm

WirelessRudy - Do you have an access to this IP address? Please provide supout file from your router to support@mikrotik.com. Speed Test works just fine for me to/from all accessible IP addresses;
Already know the answer. Both units need to be 6.44 to have all CLI bandwidth features working.
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
MetUys
just joined
Posts: 17
Joined: Mon Mar 17, 2014 1:19 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 5:12 pm

Noticed DHCP feature is enabled after upgrade to v6.44 (firmware also updated) on CCR1036-12G-4S,
If I attempt to disable DHCP again and reboot, it says "can not disable dhcp-6.44: security depends on it"

Sorry if this is not related to this version, upgraded from a slightly older version. Not the end of the world, just thought I would note it.
 
nescafe2002
Long time Member
Long time Member
Posts: 599
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 5:29 pm

The dhcp package is mandatory, as mentioned in change log, but you should be able to delete / disable any dhcp servers or clients.

What's new in 6.44 (2019-Feb-25 14:11):

Changes in this release:

*) upgrade - made security package depend on DHCP package
 
tamagochi
just joined
Posts: 2
Joined: Tue Sep 18, 2018 4:38 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 5:53 pm

tamagochi - Do you mean that e-mail settings were corrupted? I do not see how this would be possible by this upgrade. If you downgrade router back, then setting re-appears? Please test if when you downgrade device, set TO parameter, upgrade back and the setting is gone again;

No, e-mail settings are not corrupt, showing good, but sender address is null <>... Settings are not gone, i checked all parameters.
I try downgrade to 6.42.12 e-mail is perfekt when VPN user logged in. Set TO parameters also are good admin received email, but sender empty.
email_setting.PNG
log_to_email.PNG
You do not have the required permissions to view the files attached to this post.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1405
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 9:05 pm

kefealo - Without additional information we are blind. Please provide supout file to support@mikrotik.com from router which is not working properly but was working just fine before an upgrade;
saaremaa - Sorry about that. I mixed both services together. We do support Delegated-IPv6-Prefix for DHCP service but not for PPP yet. It is in our plans to add support for this in the future;
ErfanDL - Not yet added to GUI "/ip hotspot profile set https-redirect=";
VincentL - We are very sorry that you experienced such problem. We will look into this and try to reproduce this problem. If we manage to do so, then we will fix this problem in next release;
xtrans - What exactly is not working? Please provide more details (preferably to support@mikrotik.com);
tamagochi - Please send supout file and problem description to support@mikrotik.com. We will look into this. I can not seem to reproduce this problem and e-mail are being sent to me without any problems from my routers (log, simple e-mail send command, etc.).
 
User avatar
roulyz
just joined
Posts: 11
Joined: Sun Jul 17, 2016 1:00 am
Location: Ivory Coast
Contact:

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 10:52 pm

...
ErfanDL - Not yet added to GUI "/ip hotspot profile set https-redirect=";
...
Please can you explain this new feature and how is working.
Tks
 
swtth
just joined
Posts: 10
Joined: Tue Feb 02, 2016 10:50 pm

Re: v6.44 [stable] is released!

Wed Feb 27, 2019 11:16 pm

"I cannot upgrade my devices through DUDE which is running on a RB750GR3. I tried it with dude client 6.43.12 and 6.44. Dude says "needed packages are not available". I also tried several types mipsbe, arm, tile."


Solved, maybe broken packages.
 
i4ko
just joined
Posts: 14
Joined: Sat Sep 26, 2015 9:23 pm

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 12:30 am

major issues upgrading rb952Ui to 6.43.12 and 6.44
The upgrade to 6.43.12 from 6.43.7 went ok, but 6.43.12 caused the device to go into high cpu usage and eventually crash with autosup out being generated. The first 2 times this happened router got rebooted by customer in about 15-20 minutes. The third time I was present and connected to a ethernet port. Router had high cpu usage for about 3-4 minutes after which all routing and dhcp seemed to stop working. I rebooted after about 1-2 minutes and the router became paperweight - it would not boot. Had a bit of a hard time getting it to netinstall, but after 30+ minutes of retries it did. Since on 6.43.12 customer has complained that either laptops cannot connect or connect for 10 minutes and get kicked out. Log investigation showed computers were unable to get their DHCP lease renewed, (increasing to 24 hours kind of solved that), and the router frequently logging certain mac address disconnected, group key exchange timeout. Investigation indicated these are all windows devices.
6.43.12 also caused the router to rename a usb disk from disk2 to disk 3.
Upgrade to 6.44 from 6.43.12 went mostly ok, but the issues persisted - both the broken dhcp lease renew and the bund of wireless devices getting disconnected with a group key exchange timeout. I am able to reproduce with another 952 and a laptop in my lab. The group key exchange timeout happens approximately every 5 minutes.
 
oooscar
Frequent Visitor
Frequent Visitor
Posts: 80
Joined: Sun Jan 05, 2014 12:56 pm
Location: Spain
Contact:

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 12:36 am

...
ErfanDL - Not yet added to GUI "/ip hotspot profile set https-redirect=";
...
Please can you explain this new feature and how is working.
Tks
Yes please, an exaplanation ?

for both features:

*) hotspot - added "https-redirect" under server profiles;
*) hotspot - added per-user NAT rule generation based on "incoming-filter" and "outgoing-filter" parameters;

thanks,
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1209
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 1:36 am

*) discovery - detect proper slave interface on bounded interfaces;
If this means reporting the neighbor on each interface of the bond, then it works as expected.
It is just not correct, since the neighbor should appear only once because it is a single logical interface.
And some of them show the IP only on one of the instances.
Was this really necessary?
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
njoniec
just joined
Posts: 1
Joined: Thu Feb 28, 2019 5:46 am

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 5:59 am

I am also seeing the blank from header email issue after upgrading to 6.44 from 6.42.5.

The default from address (/tool email print) is set to what it should be for me but does not get passed along for my email log actions. If I send a test message and manually specify the from header, the mail is sent successfully.

I've enabled email,debug logging and can confirm that it shows "send MAIL FROM: <>" in the logs

Our Postfix mail relay shows "from=<>" as the header and receives a bounce from Gmail with the error: "Messages missing a valid address in From: 550 5.7.1 header, or having no From: header, are not accepted."

I've confirmed this is an issue with 6.44 on two different model routers that I've upgraded so far. Considering this breaks log email notifications, this is quite important for us.

Please let me know what else I can provide. Thanks!
 
wilsonlmh
newbie
Posts: 26
Joined: Fri Oct 10, 2014 9:44 pm

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 6:27 am

One of my hEX enabled auto-upgrade. It upgraded this morning(I’m in Macau) to 6.44. The new version messed the interface list result firewall filter went wrong. The situation is: I got 2 more interfaces in a interface list which wasn’t before update(and the list supposed to be blocked by firewall). It’s a big issue if an upgrade could be able to mess up config. Do you need an investigation?
 
User avatar
nichky
Long time Member
Long time Member
Posts: 505
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 7:51 am

tamagochi - Do you mean that e-mail settings were corrupted? I do not see how this would be possible by this upgrade. If you downgrade router back, then setting re-appears? Please test if when you downgrade device, set TO parameter, upgrade back and the setting is gone again;

No, e-mail settings are not corrupt, showing good, but sender address is null <>... Settings are not gone, i checked all parameters.
I try downgrade to 6.42.12 e-mail is perfekt when VPN user logged in. Set TO parameters also are good admin received email, but sender empty.

email_setting.PNG

log_to_email.PNG

did you send email so far?
Nikola Shuminoski
Network Engineer
E-Mail: nikola.suminoski@outlook.com
MikroTik Consultan
MTCRE l MTCWE

!) Safe Mode is your friend;
 
nuffrespect
newbie
Posts: 38
Joined: Wed Jun 14, 2017 5:21 pm

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 8:30 am

Hi,
Didn't understand this topic (how it works):
*) lte - added "firmware-upgrade" command for R11e-LTE international modems (CLI only);
Tried to update WAP-LTE with CLI - it shows that exist new firmware - enter "upgrade"
/ interface lte firmware-upgrade lte1
installed: MikroTik_CP_2.160.000_v008
latest: MikroTik_CP_2.160.000_v010

/ interface lte firmware-upgrade lte1 upgrade=yes
.... lost connection.... reboot.... same version on modem
 
notToNew
Member Candidate
Member Candidate
Posts: 146
Joined: Fri Feb 19, 2016 3:15 pm

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 9:04 am

/ interface lte firmware-upgrade lte1 upgrade=yes
.... lost connection.... reboot.... same version on modem
I have 2 carriers with 2 different SIMs. One works, one seems to block it!
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
User avatar
eworm
Member
Member
Posts: 339
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 9:32 am

Hi,
Didn't understand this topic (how it works):
*) lte - added "firmware-upgrade" command for R11e-LTE international modems (CLI only);
Tried to update WAP-LTE with CLI - it shows that exist new firmware - enter "upgrade"
/ interface lte firmware-upgrade lte1
installed: MikroTik_CP_2.160.000_v008
latest: MikroTik_CP_2.160.000_v010

/ interface lte firmware-upgrade lte1 upgrade=yes
.... lost connection.... reboot.... same version on modem
Did you login via LTE connection? Lost connection is expected then, probably failed upgrade is as well. I use this script for remote upgrade: unattended-lte-firmware-upgrade
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
bawolek
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Thu Mar 29, 2007 3:33 pm
Location: Poland/Wroclaw

Re: v6.44 [stable] is released!

Thu Feb 28, 2019 10:06 am

............ Since on 6.43.12 customer has complained that either laptops cannot connect or connect for 10 minutes and get kicked out. Log investigation showed computers were unable to get their DHCP lease renewed, (increasing to 24 hours kind of solved that), and the router frequently logging certain mac address disconnected, group key exchange timeout. Investigation indicated these are all windows devices.
6.43.12 also caused the router to rename a usb disk from disk2 to disk 3.
Upgrade to 6.44 from 6.43.12 went mostly ok, but the issues persisted - both the broken dhcp lease renew and the bund of wireless devices getting disconnected with a group key exchange timeout. I am able to reproduce with another 952 and a laptop in my lab. The group key exchange timeout happens approximately every 5 minutes.
we have the same problem in our company where we have a lot of HP notebooks with intel wifi cards. I don't have time to analyze this, so we go back to 6.42.12

Who is online

Users browsing this forum: No registered users and 7 guests