Community discussions

 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 2:38 am

MAC telnet broken in 6.44.1, appears to be when router has multiple interfaces.

Problem on all routers we've upgraded to 6.44.1 whilst 6.44 worked perfectly.

We'll need to lab this, to provide more granular detail...
 
LeftyTs
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu Nov 03, 2016 2:39 am
Location: Athens, Greece
Contact:

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 10:10 am

Updated all my devices from 6.44 to 6.44.1 thru dude, no problems
ipsec site-to-site run fine
l2tp-ipsec roadwarrior dailin works fine

Eddie
Can you show your config? I am unable to get windows clients for l2tp ipsec to work... it's lost somewhere in phase1 or 2
For me, windows l2tp ipsec client also stopped working, but I did not update my router (still on 6.44). I think it may be associated with installation of March windows 10 patches; the VPN worked before they installed last week.
Windows 7 with all updates works fine here with 6.44.1
 
bratislav
Frequent Visitor
Frequent Visitor
Posts: 50
Joined: Mon May 05, 2014 10:36 am

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 3:22 pm

Can't upgrade one of my hAP lite from 6.44 to 6.44.1 -- "not enough space for upgrade" :(

Files are empty, all modules are disabled (system is active only), 14.3MB free RAM.
But how much HDD space is free? That's what's used for upgrade in hAP Lite.

Also, disabling packages does not free up HDD space. Uninstall it instead of disabling.
Are you sure about that? As far as I know on routers like hAP lite RAM is used for storing upgrade files ...
As can be seen when we print resources with no update files
[admin@MikroTik] > file print                                          
 # NAME                                       TYPE                                            SIZE CREATION-TIME       
 0 flash                                      disk                                                 jan/01/1970 01:00:05
 1 flash/skins                                directory                                            jan/01/1970 01:00:01
 2 flash/pub                                  directory                                            jan/02/1970 01:33:40
 [admin@MikroTik] > system resource print 
                   uptime: 2d5h45m26s
                  version: 6.42.12 (long-term)
               build-time: Feb/12/2019 08:23:13
         factory-software: 6.29.1
              free-memory: 41.7MiB
             total-memory: 64.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 5%
           free-hdd-space: 4688.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 807
         write-sect-total: 95645
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: hAP ac lite
                 platform: MikroTik
[admin@MikroTik] > file print 
 # NAME                                       TYPE                                            SIZE CREATION-TIME       
 0 flash                                      disk                                                 jan/01/1970 01:00:05
 1 routeros-mipsbe-6.42.7.npk                 package                                      10.3MiB mar/19/2019 14:11:46
 2 flash/skins                                directory                                            jan/01/1970 01:00:01
 3 flash/pub                                  directory                                            jan/02/1970 01:33:40
[admin@MikroTik] > system resource print 
                   uptime: 2d5h42m47s
                  version: 6.42.12 (long-term)
               build-time: Feb/12/2019 08:23:13
         factory-software: 6.29.1
              free-memory: 31.4MiB
             total-memory: 64.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 8%
           free-hdd-space: 4688.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 807
         write-sect-total: 95645
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: hAP ac lite
                 platform: MikroTik

And after we upload upgrade files the only thing that changes is RAM usage, not to mention that there would be no room for 10.3MiB file on free-hdd-space: 4688.0KiB ...
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 8:52 pm

6.44.1 does not make it possible to stop MikroTik neighbour discovery announcements.

Winbox shows settings from 6.44 but advertisements are still broadcast and export config contradicts Winbox:
#> /ip neighbor discovery-settings set discover-interface-list=!external

#> /ip neighbor export
/ip neighbor discovery-settings set discover-interface-list=external

Export config does not retain negative expression...
 
mada3k
Frequent Visitor
Frequent Visitor
Posts: 77
Joined: Mon Jul 13, 2015 10:53 am
Location: Sweden

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 9:04 pm

MAC telnet broken in 6.44.1, appears to be when router has multiple interfaces.

Problem on all routers we've upgraded to 6.44.1 whilst 6.44 worked perfectly.

We'll need to lab this, to provide more granular detail...
Thats worrying, But I can't confirm this at home
[xxxxxxxx@rba] > /ip neighbor pr
 # INTERFACE ADDRESS                                                                             MAC-ADDRESS       IDENTITY   VERSION    BOARD                                           
 0 eth1      fe80::ce2d:e0ff:fe07:1f5e                                                           CC:2D:E0:07:1F:5E rbb       6.44.1 ... RB750Gr3                                        


[xxxxxxxx@rba] > /tool mac-telnet CC:2D:E0:07:1F:5E
Login: xxxxxxxx
Password: 
Trying CC:2D:E0:07:1F:5E...
Connected to CC:2D:E0:07:1F:5E








  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.44.1 (c) 1999-2019       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level
  
[xxxxxxxx@rbb] > 
Manages some CCR's, RB750Gr3, RB922 and wAP's
 
LeftyTs
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Thu Nov 03, 2016 2:39 am
Location: Athens, Greece
Contact:

Re: v6.44.1 [stable] is released!

Tue Mar 19, 2019 10:09 pm

MAC telnet broken in 6.44.1, appears to be when router has multiple interfaces.

Problem on all routers we've upgraded to 6.44.1 whilst 6.44 worked perfectly.

We'll need to lab this, to provide more granular detail...
Thats worrying, But I can't confirm this at home
[xxxxxxxx@rba] > /ip neighbor pr
 # INTERFACE ADDRESS                                                                             MAC-ADDRESS       IDENTITY   VERSION    BOARD                                           
 0 eth1      fe80::ce2d:e0ff:fe07:1f5e                                                           CC:2D:E0:07:1F:5E rbb       6.44.1 ... RB750Gr3                                        


[xxxxxxxx@rba] > /tool mac-telnet CC:2D:E0:07:1F:5E
Login: xxxxxxxx
Password: 
Trying CC:2D:E0:07:1F:5E...
Connected to CC:2D:E0:07:1F:5E








  MMM      MMM       KKK                          TTTTTTTTTTT      KKK
  MMMM    MMMM       KKK                          TTTTTTTTTTT      KKK
  MMM MMMM MMM  III  KKK  KKK  RRRRRR     OOOOOO      TTT     III  KKK  KKK
  MMM  MM  MMM  III  KKKKK     RRR  RRR  OOO  OOO     TTT     III  KKKKK
  MMM      MMM  III  KKK KKK   RRRRRR    OOO  OOO     TTT     III  KKK KKK
  MMM      MMM  III  KKK  KKK  RRR  RRR   OOOOOO      TTT     III  KKK  KKK

  MikroTik RouterOS 6.44.1 (c) 1999-2019       http://www.mikrotik.com/

[?]             Gives the list of available commands
command [?]     Gives help on the command and list of arguments

[Tab]           Completes the command/word. If the input is ambiguous,
                a second [Tab] gives possible options

/               Move up to base level
..              Move up one level
/command        Use command at the base level
  
[xxxxxxxx@rbb] > 
Works fine here also without issues in all routers and interfaces so far.
 
lucidnx
just joined
Posts: 11
Joined: Tue Jan 08, 2019 10:17 am

Re: v6.44.1 [stable] is released!

Wed Mar 20, 2019 1:01 am

Updated all my devices from 6.44 to 6.44.1 thru dude, no problems
ipsec site-to-site run fine
l2tp-ipsec roadwarrior dailin works fine

Eddie
Can you show your config? I am unable to get windows clients for l2tp ipsec to work... it's lost somewhere in phase1 or 2
For me, windows l2tp ipsec client also stopped working, but I did not update my router (still on 6.44). I think it may be associated with installation of March windows 10 patches; the VPN worked before they installed last week.
Windows 7 with all updates works fine here with 6.44.1

found it!
probably windows is not properly detecting nat, there is registry to force windows to assume both client and server is behind NAT..
reg add HKLM\SYSTEM\CurrentControlSet\Services\PolicyAgent /v AssumeUDPEncapsulationContextOnSendRule /t REG_DWORD /d 0x2 /f
0 - no nat
1 - server behind nat
2 - both
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8291
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.44.1 [stable] is released!

Wed Mar 20, 2019 10:37 am

Are you sure about that? As far as I know on routers like hAP lite RAM is used for storing upgrade files ...
As can be seen when we print resources with no update files
[admin@MikroTik] > file print                                          
 # NAME                                       TYPE                                            SIZE CREATION-TIME       
 0 flash                                      disk                                                 jan/01/1970 01:00:05
 1 flash/skins                                directory                                            jan/01/1970 01:00:01
 2 flash/pub                                  directory                                            jan/02/1970 01:33:40
 [admin@MikroTik] > system resource print 
                   uptime: 2d5h45m26s
                  version: 6.42.12 (long-term)
               build-time: Feb/12/2019 08:23:13
         factory-software: 6.29.1
              free-memory: 41.7MiB
             total-memory: 64.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 5%
           free-hdd-space: 4688.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 807
         write-sect-total: 95645
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: hAP ac lite
                 platform: MikroTik
[admin@MikroTik] > file print 
 # NAME                                       TYPE                                            SIZE CREATION-TIME       
 0 flash                                      disk                                                 jan/01/1970 01:00:05
 1 routeros-mipsbe-6.42.7.npk                 package                                      10.3MiB mar/19/2019 14:11:46
 2 flash/skins                                directory                                            jan/01/1970 01:00:01
 3 flash/pub                                  directory                                            jan/02/1970 01:33:40
[admin@MikroTik] > system resource print 
                   uptime: 2d5h42m47s
                  version: 6.42.12 (long-term)
               build-time: Feb/12/2019 08:23:13
         factory-software: 6.29.1
              free-memory: 31.4MiB
             total-memory: 64.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 8%
           free-hdd-space: 4688.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 807
         write-sect-total: 95645
               bad-blocks: 0%
        architecture-name: mipsbe
               board-name: hAP ac lite
                 platform: MikroTik

And after we upload upgrade files the only thing that changes is RAM usage, not to mention that there would be no room for 10.3MiB file on free-hdd-space: 4688.0KiB ...
Yep, but you have hAP AC Lite, not hAP Lite. In hAP Lite, there's no "flash" dir and only 32M RAM (6M free for me - definitely not enough to keep an upgrade files).
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5545
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.44.1 [stable] is released!

Wed Mar 20, 2019 11:05 am

probably windows is not properly detecting nat, there is registry to force windows to assume both client and server is behind NAT..
reg add HKLM\SYSTEM\CurrentControlSet\Services\PolicyAgent /v AssumeUDPEncapsulationContextOnSendRule /t REG_DWORD /d 0x2 /f
0 - no nat
1 - server behind nat
2 - both
It would be nice when RouterOS had some setting to force UDP encapsulation without NAT-detection too!
The "NAT traversal" checkmark in Profiles is only enabling the autodetection, there could be another setting in Peers that forces it.
(e.g. for networks that do not have NAT but are not transparent for ESP/AH only for TCP and UDP)
 
ssbaksa
newbie
Posts: 28
Joined: Tue Oct 20, 2015 10:38 am

Re: v6.44.1 [stable] is released!

Thu Mar 21, 2019 8:19 am

MAC telnet broken in 6.44.1, appears to be when router has multiple interfaces.

Problem on all routers we've upgraded to 6.44.1 whilst 6.44 worked perfectly.

We'll need to lab this, to provide more granular detail...

I didn't try MAC telnet but ... I have an old RB411 which I use for testing different setups. After upgrading it to 6.44.1 all worked fine. Then it was time to clear all configuration from it to build some test environment from scratch. After reboot - no MAC connectivity at all using Winbox. It wasn't shown in neighbors at all. Luckily I am old school guy and there is always an serial cable around. That worked and after adding IP to Ethernet port MAC connectivity was up again.

Very strange!
 
ISPIE001
just joined
Posts: 3
Joined: Thu Jan 18, 2018 12:00 pm

Re: v6.44.1 [stable] is released!

Thu Mar 21, 2019 11:10 am

There is a problem with 6.44 and 6.44.1 with Radius servers - on NAS routers after around 24hours, we get radius timeouts, where PPP users are unable to authenticate. The only solution is to reboot the router.
We have seen this problem on both 6.44 and 6.44.1 and have downgraded these routers to 6.43.13.
I do not know if this issue is present or not in the 6.43 releases, as everything we had upgraded had been in the 6.42 strain.

BUT if you have radius authentication for clients, do not upgrade to 6.44.x
 
User avatar
indnti
Frequent Visitor
Frequent Visitor
Posts: 64
Joined: Thu Nov 09, 2006 11:53 am

Re: v6.44.1 [stable] is released!

Fri Mar 22, 2019 1:27 am

Upgrade CCR1016-12G. We have massive packet loss on an IPSEC connection. The bigger the packet size, the more packets are lost. - up to 45%.
Downgrading to 6.44 solves the Problem !!!
 
pe1chl
Forum Guru
Forum Guru
Posts: 5545
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.44.1 [stable] is released!

Fri Mar 22, 2019 10:49 am

Downgrading to 6.44 solves the Problem !!!
Did you also try a reboot before downgrade?
 
bbs2web
Member Candidate
Member Candidate
Posts: 197
Joined: Sun Apr 22, 2012 6:25 pm
Location: Johannesburg, South Africa
Contact:

Re: v6.44.1 [stable] is released!

Sat Mar 23, 2019 12:38 am

This is definitely an issue with 6.44.1...
I unfortunately haven't had an opportunity to distil this yet but have a client's router on which this problem also occurs with a far simpler setup than our own.

Presume it's related to bond interfaces, when they interface via a switch...
MAC telnet broken in 6.44.1, appears to be when router has multiple interfaces.
 
User avatar
karo84
Member Candidate
Member Candidate
Posts: 194
Joined: Fri Aug 17, 2007 9:06 am

Re: v6.44.1 [stable] is released!

Mon Mar 25, 2019 12:21 am

Hello.
After updating to 6.44.1 everything was OK. But in some days certificates for ipsec had been expired and I had to add new certificates. So I can not connect to my router now. Getting "ipsec,error identity not found for peer:". Before this I was connecting from Iphone and from Windows 10.
I have tried all combinations in ipsec identifier menu. Nothing helped.
Is there any ideas? (/sys routerboard print
routerboard: yes
model: 2011UiAS-2HnD
serial-number: 569404965A09
firmware-type: ar9344
factory-firmware: 3.19
current-firmware: 6.44
upgrade-firmware: 6.44.1
)

Thanks
 
tesme33
newbie
Posts: 45
Joined: Mon May 26, 2014 10:25 pm

Re: v6.44.1 [stable] is released!

Mon Mar 25, 2019 8:06 am

Hi
just upgraded my CCR1009 and a hAP Lite. Up to now no problems.
OS and firmware upgraded.
But the config is quite simple.


Yours
 
User avatar
Anastasia
newbie
Posts: 32
Joined: Wed Oct 28, 2015 7:12 pm

Re: v6.44.1 [stable] is released!

Tue Mar 26, 2019 3:57 pm

Yep, but you have hAP AC Lite, not hAP Lite. In hAP Lite, there's no "flash" dir and only 32M RAM (6M free for me - definitely not enough to keep an upgrade files).
Нi!
You should try online upgrade (delete all what you can from Files + 15-16 MB should be in RAM) - and it should work.

1) System => Packages => Check For Updates
2) Download&Upgrade (+reboot)
3) System => Routerboard. Compare Current Firmware and Upgrade Firmware. Click Upgrade.
Here is article in russian https://asp24.ru/mikrotik/obnovlenie-ro ... -mikrotik/
 
igogo56136
just joined
Posts: 1
Joined: Fri Mar 29, 2019 3:52 pm

Re: v6.44.1 [stable] is released!

Fri Mar 29, 2019 4:12 pm

Hello. On the RB1100AHx2 Mikrotik Firmware 6.43, the QOS DSCP HTB was configured according to the instruction https://wiki.mikrotik.com/wiki/DSCP_based_QoS_with_HTB. Internet access was through PPPoE configured was on ether1. Everything worked. The provider has changed the settings and now the trunk-port comes to ether1 with VLAN 130 (Internet ivlan130) and VLAN 120 (L2 communication channel with another network). Updated to 6.44.1. I migrated the DSCP to the new interface ivlan130. I stopped showing traffic in Queues - Queue tree (Avg Rate 0, Bytes 0 and so on) Tell me if QoS is working or am I doing something wrong? sorry google translate =)
Image
Image
 
LeoCombes
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Mon May 28, 2007 3:56 pm

Re: v6.44.1 [stable] is released!

Fri Mar 29, 2019 8:47 pm

We try 6.44.1 in CCR1009 and 1100AHx2.
DHCP server fails giving IP to clients, apparently when relay is used.
DHCP leases list fill completelly, all with mac-address field '00: 00: 00: 00: 00: 00 ', and then complains with a message like' ip pool is empty '. All IPs in pool are assigned to mac-address '00: 00: 00: 00: 00: 00 'and any client receive no IP address.

The configuration is:
/ ip dhcp-server
add address-pool = "private IPs" bootp-lease-time = lease-time bootp-support = dynamic disabled = no interface = ether4 lease-time = 12h name = "customers" relay = 172.16.2.1

In both routers, back to the 6.42.10 fix the problem. No other intermediate versions are been tested.
 
gdelacruz
just joined
Posts: 8
Joined: Mon Oct 23, 2017 4:27 pm

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 7:21 am

unfortunately my MT is not upgrading to 6.44 from 6.43.12.

i am using the upgrade tool from winbox. downloading and reboot but it does not change at all...

pls. advise .. using RB952Ui-5ac2nD..

thanks
 
uldise
just joined
Posts: 7
Joined: Fri Jul 27, 2018 6:04 pm

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 8:28 am

unfortunately my MT is not upgrading to 6.44 from 6.43.12.

i am using the upgrade tool from winbox. downloading and reboot but it does not change at all...

pls. advise .. using RB952Ui-5ac2nD..

thanks
you just need to hit Downgrade button on System/packages
 
sponge
just joined
Posts: 1
Joined: Sat Mar 30, 2019 3:06 pm

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 3:14 pm

after upgrading 2 of my APs to v6.44.1 stable I am facing a problem with rx, bandwidth test shows very high tx and 0 rx, anyone facing the same issue ? any solutions ?
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1300
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 3:16 pm

unfortunately my MT is not upgrading to 6.44 from 6.43.12.

i am using the upgrade tool from winbox. downloading and reboot but it does not change at all...

pls. advise .. using RB952Ui-5ac2nD..

thanks
Having the same problem on 1 device, trying to upgrade from 6.43.8 to 6.44.1, it downloads it, reboots, and then still on 6.43.8
MTCNA, MTCTCE, MTCRE & MTCINE
 
mkx
Forum Guru
Forum Guru
Posts: 2583
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 3:46 pm

@CZFan, @gdelacruz: is there anything in the log about upgrading (or its failure)?
BR,
Metod
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1300
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.44.1 [stable] is released!

Sat Mar 30, 2019 11:59 pm

@CZFan, @gdelacruz: is there anything in the log about upgrading (or its failure)?

When I try to uninstall the packages that are disabled, I get error, cant uninstall bundled package

Have over 1000 of these devices deployed at 1 client only
Log info after trying to upgrade:
23:46:30 system,info installed routeros-smips-6.44.1 
23:46:30 system,info installed tr069-client-6.44.1 
23:46:30 system,error not enough space for upgrade 
23:46:31 system,info router rebooted 

/file pri:
 # NAME                                                TYPE                                                     SIZE CREATION-TIME       
 0 routeros-smips-6.44.1.npk                           package                                                7.3MiB mar/30/2019 23:46:25
 1 skins                                               directory                                                     jan/01/1970 02:00:01
 2 tr069-client-6.44.1-smips.npk                       package                                              108.1KiB mar/30/2019 23:46:25

/sys reso pri:
                   uptime: 6m28s
                  version: 6.43.8 (stable)
               build-time: Dec/21/2018 07:10:42
         factory-software: 6.38
              free-memory: 7.7MiB
             total-memory: 32.0MiB
                      cpu: MIPS 24Kc V7.4
                cpu-count: 1
            cpu-frequency: 650MHz
                 cpu-load: 1%
           free-hdd-space: 16.0KiB
          total-hdd-space: 16.0MiB
  write-sect-since-reboot: 608
         write-sect-total: 99506
               bad-blocks: 0%
        architecture-name: smips
               board-name: hAP lite
                 platform: MikroTik

Flags: X - disabled 
 #   NAME                                                            VERSION                                                            SCHEDULED              
 0   tr069-client                                                    6.43.8                                                                                    
 1   routeros-smips                                                  6.43.8                                                                                    
 2   system                                                          6.43.8                                                                                    
 3 X ipv6                                                            6.43.8                                                                                    
 4   wireless                                                        6.43.8                                                                                    
 5 X hotspot                                                         6.43.8                                                                                    
 6   dhcp                                                            6.43.8                                                                                    
 7 X mpls                                                            6.43.8                                                                                    
 8   routing                                                         6.43.8                                                                                    
 9 X ppp                                                             6.43.8                                                                                    
10   security                                                        6.43.8                                                                                    
11   advanced-tools                                                  6.43.8                                                                                    

MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
osc86
newbie
Posts: 46
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.44.1 [stable] is released!

Sun Mar 31, 2019 12:10 am

uninstall tr069 package, remove everything from /files, upgrade only routeros, after suiccessful upgrade install tr069 again
CCR1009-7G-1C-1S+ ROS6.45.2
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1300
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.44.1 [stable] is released!

Sun Mar 31, 2019 12:18 am

uninstall tr069 package, remove everything from /files, upgrade only routeros, after suiccessful upgrade install tr069 again

Yes, if it was a device at my home, no issues, but now I must go do that on over 1000 devices at client site?

WTF is it even necessary to do that, I am a patient person, been a MT "evangelist" in all I do, but MT is starting to embarrass me on every corner now and my patience is starting to wear thin now.

Plus, I read the other day that NAND pricing has dropped seriously last year or so, so why are we sitting with &^%%$& 16MB of NANDs, MT starting to limit us?????
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
osc86
newbie
Posts: 46
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.44.1 [stable] is released!

Sun Mar 31, 2019 12:37 am

so why are we sitting with &^%%$& 16MB of NANDs
I agree, this is ridiculous
CCR1009-7G-1C-1S+ ROS6.45.2
 
mkx
Forum Guru
Forum Guru
Posts: 2583
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.44.1 [stable] is released!

Sun Mar 31, 2019 10:36 am

It is possible to covert from "bundle" package to individual packages ... grab extra packages archive from download site, then extract only packages needed (at least system, probably security and dhcp ... security is needed for ssh access and dhcp is dependency for security), upload them to router and reboot the router. This way the disabled packages won't use up NAND space ...
BR,
Metod
 
pe1chl
Forum Guru
Forum Guru
Posts: 5545
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.44.1 [stable] is released!

Sun Mar 31, 2019 10:17 pm

"bundle" package should be phased out by MikroTik!
It did not have any advantages and it has disadvantages when having small flash space.
Just change the next update so that it will load individual packages (only those that are present) the next time.
And of course install those individual packages at installation.
I always convert to individual packages for the first update after buying, but it is extra work because you have to download
the .zip and extract only the needed packages, instead of simply clicking "download&upgrade" in the package menu.
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1300
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.44.1 [stable] is released!

Mon Apr 01, 2019 1:43 am

Thx @mkx, @pe1chl for the info.

Have over 1000 of these deployed in user homes (FTTx Deployment), so if things go wrong, not easy to get physical access to these plus user / client downtime.

There was a time when I still had hair, when all jumped ship from Novell (had a very soft spot for Novell) to MS. At the time, I decided to do both, but keep focusing on Novell, re-certifying in Novell, selling Novell, etc, just hope I am not making same mistake here...

I am just a bit annoyed at the moment and will get over it, info you provided is much appreciated, thx again, so you learn every day....
MTCNA, MTCTCE, MTCRE & MTCINE
 
pe1chl
Forum Guru
Forum Guru
Posts: 5545
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.44.1 [stable] is released!

Mon Apr 01, 2019 4:42 pm

Of course you should never upgrade all those 1000 in one pass of some magic script.
First try it on a couple of routers.
I never had issues moving from bundle package to separate packages during an upgrade!
Just login to the router, see in /system packages what packages are installed (and enabled), upload only
those packages (extracted from the all-packages zipfile for that architecture) of the wanted new version,
and do a reboot. After the reboot, login to the router and check that the new version packages have installed
without error (look at the top of the logs).
Now there should be more free space.

When you have 1000 of those deployed, I presume you have some test "sites" or local routers where you
can test such things before deploying everywhere. When you manage the routers yourself and know that
they are all the same, you can blindly upload the correct set of packages. When you have packages that
you are sure you are not using (like mpls, hotspot) you can disable them before doing the above and gain
even more space. This may also be true for packages like ppp and security but be careful, you may have
unexpected dependencies on those.
 
pe1chl
Forum Guru
Forum Guru
Posts: 5545
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.44.1 [stable] is released!

Mon Apr 01, 2019 10:57 pm

I'm not completely sure when this problem was introduced, but I find that the "distance" specification in the advanced settings for Wireless does not work correctly.
The distance given when dynamic mode is selected is higher than the actual distance (in my case for an 8.3 kilometer link it says 11 kilometer) and when a fixed value
is given that is "too low" (in this case when I specified 9km) the resulting TX CCQ is very low.
 
hhoeth
just joined
Posts: 9
Joined: Wed Oct 17, 2018 11:22 am

Re: v6.44.1 [stable] is released!

Tue Apr 02, 2019 11:47 am

I'm running ovpn-client on my MT devices and the openvpn server on a Debian box. After upgrading from 43.x to 44.1 I get lots of "IP packet with unknown IP version=0 seen" in my server logs. I've solved this by downgrading to 43.13 now, but I hope this gets fixed in stable.
 
mativcp
just joined
Posts: 1
Joined: Tue Apr 02, 2019 6:52 pm

Re: v6.44.1 [stable] is released! - URGENT

Tue Apr 02, 2019 11:00 pm

After upgrade to 6.44.1 (Stable) CCR1009-7G-1C-1S+ STOP WORKINKG

All routes got deleted and there is not posible way to add routes, manually or by ip addresses added
The only connection method was by mac
PPP conections wont dial
(ATTACHED IMAGES)

With other errors,....The only way to fix it was to back to 6.43.13 (long term)

I dont remember the firmware i was when y upgrade (By automatic update), but after downgrade to 6.43.13 to fix it, try to update by copying NPK to files, and reboot, and same result, router broken with no functions.

Downgrade again and now is workling on 6.43.13.

Is hardware related issue with the new firmware?.

Is this a general error?.


Could not make the support.rif...did mikrotik found/is able to reproduce this error or is smthg particular with our router?.

ill wait answer...Thanks in advance
You do not have the required permissions to view the files attached to this post.
 
User avatar
Deantwo
Member Candidate
Member Candidate
Posts: 289
Joined: Tue Sep 30, 2014 4:07 pm

Re: v6.44.1 [stable] is released! - URGENT

Wed Apr 03, 2019 10:34 am

@mativcp:
After upgrade to 6.44.1 (Stable) CCR1009-7G-1C-1S+ STOP WORKINKG
...
ill wait answer...Thanks in advance
As it says in the opening post, you need to make a supout while the issue is present and send it to MikroTik support along with your report.
RouterOS version 6.44.1 has been released in public "stable" channel!
...
If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device
I wish my FTP was FTL.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 460
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.44.1 [stable] is released!

Thu Apr 04, 2019 10:46 am

New version 6.44.2 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=147277

Who is online

Users browsing this forum: No registered users and 7 guests