Page 1 of 1

v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 2:29 pm
by emils
RouterOS version 6.45.5 has been released in public "stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.45.5 (2019-Aug-26 10:56):

Important note!!!
Due to removal of compatibility with old version passwords in this version, downgrading to any version prior to v6.43 (v6.42.12 and older) will clear all user passwords and allow password-less authentication. Please secure your router after downgrading.
Old API authentication method will also no longer work, see documentation for new login procedure:
https://wiki.mikrotik.com/wiki/Manual:API#Initial_login


Changes in this release:

*) crs328 - adjust fan speed based on SFP and CPU temperature;
*) dhcpv4-server - fixed "Acct-Output-Octets" reporting to RADIUS;
*) health - improved fan control on CRS3xx and CCR1016-12S-1S+r2;
*) ike2 - don't release policy on rekey when child not found;
*) ike2 - fixed ID validation with multiple SAN;
*) ike2 - fixed policy port selection for responder with natted initiator;
*) ike2 - fixed traffic selector address family selection when using IPv6;
*) ike2 - improved rekeying process with Windows initiators;
*) ike2 - properly start all initiators to the same remote address;
*) ipsec - allow inline "passphrase" parameter when importing keys;
*) ipsec - fixed "eap-radius" authentication method (introduced in v6.45);
*) ipsec - fixed minor spelling mistakes in logs;
*) lte - fixed cell information monitoring on R11e-LTE-US (introduced in v6.45.2);
*) lte - fixed LTE interface disappearing on RBSXTLTE3-7;
*) smb - improved stability on x86 and CHR (CVE-2019-16160);
*) snmp - fixed encrypted data sequence (introduced in v6.44.5);
*) ssh - fixed carriage return presence in subsequent sessions;
*) switch - fix port isolation for non-CRS series switch chips;
*) system - accept only valid string for "name" parameter in "disk" menu (CVE-2019-15055);
*) upnp - fixed XML parsing (FG-VD-19-110);
*) watchdog - renamed "no-ping-delay" parameter to "ping-start-after-boot";
*) winbox - added "auto-erase" parameter to "Tools/SMS" menu;
*) winbox - added "https-redirect" parameter to "IP/Hotspot/Profiles menu";
*) winbox - added "revision" parameter to "System/Routerboard" menu;
*) winbox - removed "max-sms" parameter from "Tools/SMS" menu;
*) wireless - fixed basic rate reporting in snooper;

What's new in 6.45.4 (2019-Aug-13 09:04):

(factory only release)

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this particular RouterOS release.

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 3:36 pm
by alibloke
*) crs328 - adjust fan speed based on SFP and CPU temperature;
After reboot my fan speed dropped slowly down to zero. Temperatures are climbing up from ~40 degrees previously (and ~2900rpm fan speed):
/system health> print 
         temperature: 49C
     cpu-temperature: 54C
   power-consumption: 41.7W
  board-temperature1: 36C
        psu1-voltage: 26.4V
        psu2-voltage: 52.6V
        psu1-current: 0.3A
        psu2-current: 0.6A
          fan1-speed: 0RPM
          fan2-speed: 0RPM
*EDIT

Things seems to have stabilised now:
/system health> print 
         temperature: 56C
     cpu-temperature: 58C
   power-consumption: 42.2W
  board-temperature1: 41C
        psu1-voltage: 26.4V
        psu2-voltage: 52.7V
        psu1-current: 0.3A
        psu2-current: 0.6A
          fan1-speed: 495RPM
          fan2-speed: 390RPM

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 5:21 pm
by Chupaka
Guys, when making a topic with new version released, please post a link in previous topic (that is been closed) so that people receive notifications...

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 5:37 pm
by HZsolt
Topic of previous (6.45.3) version: viewtopic.php?f=21&t=150767

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 7:32 pm
by ErfanDL
I have problem by 6.45.5 with wifi on RB951Ui. The clients connection is not stable and connection lost

Capture.jpg
Sent from my SM-A705FN using Tapatalk

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 9:25 pm
by Jotne
Topic of previous (6.45.3) version: viewtopic.php?f=21&t=150767
This does not help.
Someone needs to make a post in previous version with a link to this new version so that people who subscribe to previous version, see that a new version is released. Then its ok to close old release.

Re: v6.45.5 [stable] is released!

Posted: Wed Aug 28, 2019 9:33 pm
by elbob2002
*) crs328 - adjust fan speed based on SFP and CPU temperature;
*) health - improved fan control on CRS3xx and CCR1016-12S-1S+r2;

Yes indeed. I should have known better than to upgrade. Edit: This is a CRS328-24P-4S+
SW-TEMP.PNG

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 2:37 am
by k6ccc
I note that both alibloke and the chart that elbob2002 posted show the temperature stabilized at 58 degrees C. Makes me think that is what it is designed to do. I don't know what the specs for the CPU chips involved are, but as a comparison, the Raspberry Pi does not start throttling to control heat until it gets to 80 degrees C. Based solely on that comparison, 60 C is not bad...
Yea, we would all like to have our CPU chips cold to the touch, but that's not realistic.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 7:53 am
by Chupaka
Topic of previous (6.45.3) version: viewtopic.php?f=21&t=150767
This does not help.
Someone needs to make a post in previous version with a link to this new version so that people who subscribe to previous version, see that a new version is released. Then its ok to close old release.
Correct. Something like this: viewtopic.php?p=747274#p747274

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 9:53 am
by ofer
Upgraded HapACx3 6.45.3 => 6.45.5 no special issues, all is good.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 2:31 pm
by bda
Sorry, but are any news on bug with "GRE marking as invalid pakets" in this release?

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 2:42 pm
by JanezFord
Tried upgrading hAP from 6.45.1 to 6.45.5. Result: Not enough space for upgrade!

JF.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 2:59 pm
by notToNew
Sorry, but are any news on bug with "GRE marking as invalid pakets" in this release?
There is no bug. It just got fixes some Versions ago.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 3:03 pm
by sindy
There is no bug. It just got fixes some Versions ago.
"The accuracy of your information could be sucessfully questioned". You are right that the bug consisting in having the firewall too open for GRE was fixed, but bundled with this fix came another bug - the very first GRE packet of a new tunnel is improperly labelled with connection-state=invalid.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 3:20 pm
by nichky
*) winbox - added "revision" parameter to "System/Routerboard" menu;

what for?

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 3:51 pm
by Frostbyte
On the topic of CRS328:
Since there are always going to be conflicting opinions between people who require a quieter experience and don't mind it running hotter (but still within spec) than usual and people who don't mind the noise and prefer running them cooler.. Why not finally offer options to set things manually and everyone can be happy? (relevant thread)

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 3:54 pm
by ErfanDL
I have problem by 6.45.5 with wifi on RB951Ui. The clients connection is not stable and connection lost

Capture.jpg
Sent from my SM-A705FN using Tapatalk
؟؟؟؟؟؟؟؟؟؟؟؟؟

Sent from my SM-A705FN using Tapatalk


Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 4:04 pm
by Sunlight
Not fixed in this release: viewtopic.php?f=2&t=151456

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 4:10 pm
by LeftyTs
On the topic of CRS328:
Since there are always going to be conflicting opinions between people who require a quieter experience and don't mind it running hotter (but still within spec) than usual and people who don't mind the noise and prefer running them cooler.. Why not finally offer options to set things manually and everyone can be happy? (relevant thread)
+1000 in other fan controlable MT devices as well this would be a really nice feature to add

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 9:07 pm
by docmarius
The bug preventing multicast RIP announcements over IPIP tunnels in 6.45.3 is solved. Not in the changelog, but anyway, tnx...

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 9:19 pm
by Jotne
Tried upgrading hAP from 6.45.1 to 6.45.5. Result: Not enough space for upgrade!
On my hAP lite, I had to delete all backup files and other files from the flash folder to be able to upgrade. Så this may be your problem as well.

Re: v6.45.5 [stable] is released!

Posted: Thu Aug 29, 2019 9:50 pm
by danieltecnet
I would like to know what is going on with the CCR1036? because after a while after updates etc .. they lock from nothing even with cooling and low use of cpu the equipment simply crashes and if someone doubts put one like BPG / OSPF or PPPOE and will see who in about 30 days use it will crash out of nowhere. and we have several in the network about 4 months ago we did not have these problems and only happens with the 1036 2s + I'm already until I have to exchange the pppoes servers that eran mikrotik 1036 for cisco huawei and other things that do not crash without explanation and have scalability since mikrotik does nothing but a 1072

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 1:12 am
by bda
There is no bug. It just got fixes some Versions ago.
"The accuracy of your information could be sucessfully questioned". You are right that the bug consisting in having the firewall too open for GRE was fixed, but bundled with this fix came another bug - the very first GRE packet of a new tunnel is improperly labelled with connection-state=invalid.
Sure! This bug still present... Too bad...

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 2:46 pm
by Caci99
There is no bug. It just got fixes some Versions ago.
"The accuracy of your information could be sucessfully questioned". You are right that the bug consisting in having the firewall too open for GRE was fixed, but bundled with this fix came another bug - the very first GRE packet of a new tunnel is improperly labelled with connection-state=invalid.
Sure! This bug still present... Too bad...
It is not a bug. This has being long discussed in 6.45.1 release. The behavior of GRE now is related to CVE-2014-8160.
Read the 6.45.1 topic and you'll find solutions on how to get your GRE up and running. What Mikrotik can do though, is to automatically add filter rules in firewall once one sets up a gre tunnel, or any tunnel dependent on gre.

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 5:40 pm
by w0lt
What Mikrotik can do though, is to automatically add filter rules in firewall once one sets up a gre tunnel, or any tunnel dependent on gre.

Where is the procedure detailed on how firewall rules are automatically created?

-tp

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 8:28 pm
by Caci99

Where is the procedure detailed on how firewall rules are automatically created?

-tp
I didn't say it exists, I said they can implement it.

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 8:47 pm
by eddieb
updating to 6.45.5 went smooth ... from 6.45.3 to 6.45.5 with some help from the dude ;-)
No problems so far

Re: v6.45.5 [stable] is released!

Posted: Fri Aug 30, 2019 9:12 pm
by RavenWing71
Web-Proxy Access Redirect is still failing to redirect. Reverting to 6.44.5 corrects the problem. See Ticket#2019082422001346 for more details.

Re: v6.45.5 [stable] is released!

Posted: Sat Aug 31, 2019 1:37 am
by manojlovicl
I have two routers that are doing BGP (they are made redundant by using VRRP ...) Since update on 6.45.5 IPv6 static routes are simply ignored and after BGP becomes stable (after rebooting that was needed for update) I was forced to change gateway to some dummy IP on all static routes in my routing table to make it work again. So basically it seems like it does ignores static routes on boot. Disabling and re-enabling the static route does not help. As I said - I was forced to change gateways on both routes for those specific static routes to make them work again.

Luka

Re: v6.45.5 [stable] is released!

Posted: Sat Aug 31, 2019 5:35 pm
by meazz1
Upgraded my hex mmips from 64.45.3 to 6.45.5, no upgrade issue and everything seems good. My setup is just basic out of the box for my home use.

Re: v6.45.5 [stable] is released!

Posted: Sat Aug 31, 2019 8:12 pm
by CZFan
Upgraded Hap AC2 to 6.45.5 and getting ssh auth messages in log I did not get before
14:39:22 ssh,info auth timeout 
14:39:23 ssh,info auth timeout 
14:45:45 ssh,info auth timeout 
14:46:37 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:56:28 ssh,info auth timeout 
15:06:41 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:25:40 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:32:58 ssh,info auth timeout 
15:36:42 ssh,info auth timeout 
15:36:43 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:06:11 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:25:56 ssh,info auth timeout 
16:38:51 ssh,info auth timeout 
16:38:52 ssh,info auth timeout 
16:42:40 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
18:10:24 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:42:37 ssh,info auth timeout 
18:44:51 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 

Re: v6.45.5 [stable] is released!

Posted: Sat Aug 31, 2019 9:34 pm
by anav
Upgraded Hap AC2 to 6.45.5 and getting ssh auth messages in log I did not get before
14:39:22 ssh,info auth timeout 
14:39:23 ssh,info auth timeout 
14:45:45 ssh,info auth timeout 
14:46:37 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:56:28 ssh,info auth timeout 
15:06:41 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:25:40 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:32:58 ssh,info auth timeout 
15:36:42 ssh,info auth timeout 
15:36:43 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:06:11 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:25:56 ssh,info auth timeout 
16:38:51 ssh,info auth timeout 
16:38:52 ssh,info auth timeout 
16:42:40 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
18:10:24 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:42:37 ssh,info auth timeout 
18:44:51 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 

Do you mean, messages you should have been getting and now are getting.........good! or
extra invalid messages......... bad :-(

Re: v6.45.5 [stable] is released!

Posted: Sat Aug 31, 2019 10:27 pm
by CZFan
Upgraded Hap AC2 to 6.45.5 and getting ssh auth messages in log I did not get before
14:39:22 ssh,info auth timeout 
14:39:23 ssh,info auth timeout 
14:45:45 ssh,info auth timeout 
14:46:37 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:56:28 ssh,info auth timeout 
15:06:41 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:25:40 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:32:58 ssh,info auth timeout 
15:36:42 ssh,info auth timeout 
15:36:43 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:06:11 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:25:56 ssh,info auth timeout 
16:38:51 ssh,info auth timeout 
16:38:52 ssh,info auth timeout 
16:42:40 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
18:10:24 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:42:37 ssh,info auth timeout 
18:44:51 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
To add info to above, this device has been connected to internet for more than a year, first time these messages came up is after upgrade, hence I thought reporting it.
I am getting login failures also in logs, but surely the "bad guys" did not only discover my device now after a year and only trying to access it now?
Maybe RoS is only starting to report these properly now, dont know, maybe I got a "Known bad IP" from PPPoE when I restarted after upgrade, dont know...
Restarted PPPoE to get new IP, nothing so far, will monitor

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 8:25 am
by Jotne
But do you have SSH to your router wide open on public internet????

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 2:55 pm
by heyandyhey
Hi all, first post but long time forum lurker... I'm struggling to get this update on my RouterBOARD 941-2nD hAP lite
Current version 6.45.2 to 6.45.5

Error not enough disk space 7.3MiB required and only 7.3iMiB is free

I've cleared out all the files and rebooted

[admin@R1] > /file print
# NAME TYPE SIZE CREATION-TIME
[admin@R1] >

admin@R1] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.45.2
1 system 6.45.2
2 X ipv6 6.45.2
3 wireless 6.45.2
4 X hotspot 6.45.2
5 mpls 6.45.2
6 routing 6.45.2
7 ppp 6.45.2
8 dhcp 6.45.2
9 security 6.45.2
10 advanced-tools 6.45.2

Could anyone help? Ive not had a problem updating in the past using winbox

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 3:32 pm
by abbyrobinson
Upgraded from 6.44.3 on rb750gr3 without issue. Everything works great.

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 3:54 pm
by soohoe
Hi all, first post but long time forum lurker... I'm struggling to get this update on my RouterBOARD 941-2nD hAP lite
Current version 6.45.2 to 6.45.5

Error not enough disk space 7.3MiB required and only 7.3iMiB is free

I've cleared out all the files and rebooted

[admin@R1] > /file print
# NAME TYPE SIZE CREATION-TIME
[admin@R1] >

admin@R1] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.45.2
1 system 6.45.2
2 X ipv6 6.45.2
3 wireless 6.45.2
4 X hotspot 6.45.2
5 mpls 6.45.2
6 routing 6.45.2
7 ppp 6.45.2
8 dhcp 6.45.2
9 security 6.45.2
10 advanced-tools 6.45.2

Could anyone help? Ive not had a problem updating in the past using winbox

Maybe can give this a try: https://blog.pessoft.com/2019/03/02/mik ... sk-device/.
Same device with same error.

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 4:28 pm
by mkx
Hi all, first post but long time forum lurker... I'm struggling to get this update on my RouterBOARD 941-2nD hAP lite
Current version 6.45.2 to 6.45.5

Error not enough disk space 7.3MiB required and only 7.3iMiB is free

I've cleared out all the files and rebooted

[admin@R1] > /file print
# NAME TYPE SIZE CREATION-TIME
[admin@R1] >

admin@R1] > /system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-smips 6.45.2
1 system 6.45.2
2 X ipv6 6.45.2
3 wireless 6.45.2
4 X hotspot 6.45.2
5 mpls 6.45.2
6 routing 6.45.2
7 ppp 6.45.2
8 dhcp 6.45.2
9 security 6.45.2
10 advanced-tools 6.45.2

Could anyone help? Ive not had a problem updating in the past using winbox

Maybe can give this a try: https://blog.pessoft.com/2019/03/02/mik ... sk-device/.
Same device with same error.
Good article. Only ... SOHO users almost definitely don't need routing package, that one is needed for advanced routing protocols such as BGP or OSPF ... simple routing (with a few static routes with some default gateway) is performed by system.

Re: v6.45.5 [stable] is released!

Posted: Sun Sep 01, 2019 9:41 pm
by CZFan
Upgraded Hap AC2 to 6.45.5 and getting ssh auth messages in log I did not get before
14:39:22 ssh,info auth timeout 
14:39:23 ssh,info auth timeout 
14:45:45 ssh,info auth timeout 
14:46:37 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:53:13 ssh,info auth timeout 
14:56:28 ssh,info auth timeout 
15:06:41 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:19:12 ssh,info auth timeout 
15:25:40 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:29:21 ssh,info auth timeout 
15:32:58 ssh,info auth timeout 
15:36:42 ssh,info auth timeout 
15:36:43 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:48:42 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:55:21 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
15:58:41 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:02:24 ssh,info auth timeout 
16:06:11 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:10:05 ssh,info auth timeout 
16:25:56 ssh,info auth timeout 
16:38:51 ssh,info auth timeout 
16:38:52 ssh,info auth timeout 
16:42:40 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:04:57 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:14:34 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:27:29 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
17:30:41 ssh,info auth timeout 
18:10:24 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:20:01 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:36:07 ssh,info auth timeout 
18:42:37 ssh,info auth timeout 
18:44:51 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
18:49:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
19:05:08 ssh,info auth timeout 
To add info to above, this device has been connected to internet for more than a year, first time these messages came up is after upgrade, hence I thought reporting it.
I am getting login failures also in logs, but surely the "bad guys" did not only discover my device now after a year and only trying to access it now?
Maybe RoS is only starting to report these properly now, dont know, maybe I got a "Known bad IP" from PPPoE when I restarted after upgrade, dont know...
Restarted PPPoE to get new IP, nothing so far, will monitor

Further to above, the upgrade seems to have broken my firewall, all rules that had in-interface-list specified, changed to "unknown", and when you open the rule, it says in-interface-list=all
FWInterfaceList.JPG

Re: v6.45.5 [stable] is released!

Posted: Mon Sep 02, 2019 11:13 am
by Didzito
Hi, After upgrade to 6.45.5 my BGP connections start going to idle state and renews only after enable/disable or some time. They drops each 10mins - 2 hours.

Configuration ir ipsec/over gre and bgp.

I revert all routers to 6.45.3. all works. 6.45.4 didnt mentioned this problem too, but there was RADIUS issue.

Re: v6.45.5 [stable] is released!

Posted: Mon Sep 02, 2019 1:50 pm
by Kazek
I'm not sure if this problem was already mentioned at this forum but I had already few times a problem where after upgrading (ccr) to newest Os - bridges changed the mac address and they have exactly the same ones = conflict and the whole network goes bat crazy.
I know using Admin MAC would avoid this but there should be some kind of security against that by default.

Re: v6.45.5 [stable] is released!

Posted: Tue Sep 03, 2019 8:09 am
by Elans
On the topic of CRS328:
Since there are always going to be conflicting opinions between people who require a quieter experience and don't mind it running hotter (but still within spec) than usual and people who don't mind the noise and prefer running them cooler.. Why not finally offer options to set things manually and everyone can be happy? (relevant thread)
There is no particular reason to do so, since device must be cooled down when it becomes hot. There are various reasons why this feature has not been implemented yet, although, as I have said in the thread you have mentioned - we are planning to add some basic fan control, however, currently we are unable to tell You when such changes could be available.

Re: v6.45.5 [stable] is released!

Posted: Wed Sep 04, 2019 7:07 pm
by annc
"Tried upgrading hAP from 6.45.1 to 6.45.5. Result: Not enough space for upgrade!"

+1, never ending story.....

Re: v6.45.5 [stable] is released!

Posted: Thu Sep 05, 2019 12:10 am
by irobot
UPDATE:
tried the following way
https://blog.pessoft.com/2019/03/02/mik ... sk-device/

but it didn't work. Files have been uploaded using Files menu in the root folder. After restart nothing happened. Version remains the same.

UPDATE2 (Problem SOLVED):
dhcp package was missing.
router has 6.45.5


------------------------------
hello

can't update my hap lite from 6.45.3 to 6.45.5:

ERROR: not enough disk space, 7.3MiB is required and only 7.3MiB is free

I have no scripts or anything like this. Just stock firmware updated regularly.
How can I proceed with the upgrade?

Thank you!

Re: v6.45.5 [stable] is released!

Posted: Thu Sep 05, 2019 8:36 am
by Jotne
Not tested, but may work.

Downgrade to an older or upgrade to beta image that is a smaller image than you currently have installed, then upgrade to 6.45.5, or wait for 6.46 that looks to be smaller.

List of SMIPS version and the size of them.
Version   bytes
6.46.38b  7445921
6.45.5    7689899
6.45.4    7722659
6.45.3    7722646
6.45.2    7808734
6.45.1    7767691
6.45      7767663
6.44.5    7702189
6.43.16   7672934
6.42.12   7533422
Problem is that 6.45.x are the largest image for the SMIPS devices. When did upgrade to it, you did barely have space to do so. Then when you try to upgrade from one 6.45 to another 6.45, you have two larger image..

So by changing to an smaller image, you may be able to upgrade to a larger image later.

Doing so, my give you problem with your configuration, so have both a full backup and a readable backup file of you config.

Re: v6.45.5 [stable] is released!

Posted: Fri Sep 06, 2019 12:10 pm
by DenisPDA
viewtopic.php?f=19&t=151903
RouterOS v7 beta
http://mt.lv/v7
Only for hap ac2, wap ac

Re: v6.45.5 [stable] is released!

Posted: Fri Sep 06, 2019 3:38 pm
by Maxke
I used my SPF port as WAN but after the upgrade it doesn't work anymore.
If I use the default eht1 it works fine.
Even using the spf as brige for LAN doesn't work.
Anybody an idea ?

Thx

Re: v6.45.5 [stable] is released!

Posted: Sat Sep 07, 2019 9:59 pm
by Ataker
Hotspot does not redirect to login page in hap lite. Its working normally on release 6.44.5.

Re: v6.45.5 [stable] is released!

Posted: Mon Sep 09, 2019 7:28 pm
by Multik
Can't add script:

I have a script for upload resources to my web service. After insert text and click OK - Winbox is disconnect. And that same result when insert MD5 calculation script (find on somewhere in forum).

Its a simple script for fetch tool

Code: Select all

/system script run "MD5"
:global StrToMd5

:local secureKey "ddddd"
:local architectureName [/system resource get architecture-name]
:local boardName [/system resource get board-name]
:local version [/system resource get version]
:local badBlocks [/system resource get bad-blocks]
:local factorySoftware [/system resource get factory-software]
:local identity [/system identity get name]
:local model [/system routerboard get model]
:local serialNumber [/system routerboard get serial-number]
:local firmwareType [/system routerboard get firmware-type]
:local factoryFirmware [/system routerboard get factory-firmware]
:local currentFirmware [/system routerboard get current-firmware]
:local upgradeFirmware [/system routerboard get upgrade-firmware]

:local httpData ("architectureName=".$architectureName."&boardName=".$boardName."&version=".$version."&badBlocks=".$badBlocks."&identity=".$identity."&serialNumber=".$serialNumber."&model=".$model."&firmwareType=".$firmwareType."&factoryFirmware=".$factoryFirmware."&currentFirmware=".$currentFirmware."&upgradeFirmware=".$upgradeFirmware."&factorySoftware=".$factorySoftware)

:local hash [ :pick [ $StrToMd5 ($httpData."&hash=".$secureKey) ] 1 ]

/tool fetch url="https://mysite?hash=$hash" mode=https keep-result=no http-data=$httpData http-method=put

Re: v6.45.5 [stable] is released!

Posted: Tue Sep 10, 2019 5:02 am
by plankanater
Had to add an accept gre firewall rule at the very top to get tunnels to establish and use packets bigger then 1458.

Re: v6.45.5 [stable] is released!

Posted: Tue Sep 10, 2019 3:21 pm
by DanielT
YAY!! HTTPS redirect, YAY!!

Thanks Mikrotik... only 2 years late - but better late than never, right ;-)

Works a charm,

Thank you!

Re: v6.45.5 [stable] is released!

Posted: Tue Sep 10, 2019 5:10 pm
by XaTTa6bl4
Web-Proxy Access Redirect is still failing to redirect. Reverting to 6.44.5 corrects the problem. See Ticket#2019082422001346 for more details.
Hotspot does not redirect to login page in hap lite. Its working normally on release 6.44.5.

I think in your cases there is not enough memory for the cache:
6.45.1
*) proxy - increased minimal free RAM that can not be used for proxy services;
I've just found the same problem on my test hap lite. Setting, for example,
/ip proxy set max-cache-object-size=1KiB
- resolves issue

Re: v6.45.5 [stable] is released!

Posted: Tue Sep 10, 2019 5:29 pm
by spacemind
IP Cloud not working in 6.45.5 or 6.46beta38.

keeps updating and does not work.

[X] /ip cloud> print
ddns-enabled: yes
ddns-update-interval: none
update-time: yes
status: updating...

Re: v6.45.5 [stable] is released!

Posted: Wed Sep 11, 2019 8:57 am
by osc86
IP Cloud not working in 6.45.5 or 6.46beta38.

keeps updating and does not work.

[X] /ip cloud> print
ddns-enabled: yes
ddns-update-interval: none
update-time: yes
status: updating...
[CORE] > ip cloud pr
ddns-enabled: yes
ddns-update-interval: none
update-time: yes
public-address: X.X:X.X
public-address-ipv6: X:X:X:X:X:X:X:X
dns-name: xxxxxxxxx.sn.mynetname.net
status: updated
[CORE] > sys rou pr
routerboard: yes
model: CCR1009-7G-1C-1S+
serial-number: XXXXXXXXXX
firmware-type: tilegx
factory-firmware: 3.33
current-firmware: 6.45.5
upgrade-firmware: 6.45.5

working fine here, check dns and output filter rules

Re: v6.45.5 [stable] is released!

Posted: Wed Sep 11, 2019 1:28 pm
by emils
New version 6.45.6 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=152033