Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 671
Joined: Thu Dec 11, 2014 8:53 am

v6.46.3 [stable] is released!

Thu Feb 06, 2020 6:07 pm

RouterOS version 6.46.3 has been released in public "stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.46.3 (2020-Jan-28 10:46):

*) hotspot - fixed redirect to log in page (introduced in v6.45);
*) lora - added "ru-864-mid" channel plan;
*) lora - improved immediate packet delivery;
*) lte - added GPS port support for Quectel EP06 modem;
*) lte - added "psc" (Primary Scrambling Code) parameter for "cell-monitor" function on R11e-LTE6 and R11e-LTE;
*) lte - do not show invalid "phy-cellid" when it is not yet received on "R11e-LTE";
*) lte - do not show unrelated info parameters after network mode failover;
*) port - fixed multiple identical USB serial device detection (introduced in v6.46);
*) ppp - fixed connection establishment when receiving "0.0.0.0" DNS;
*) snmp - fixed "ifOperStatus" reporting for combo ports;
*) winbox - removed duplicate "counter", "chain", "size" and "payload" parameters under "LoRa/Traffic";

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this particular RouterOS release.
 
markmcn
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Wed Mar 03, 2010 2:15 am

Re: v6.46.3 [stable] is released!

Thu Feb 06, 2020 6:36 pm

Any chance we could get more details about
*) hotspot - fixed redirect to log in page (introduced in v6.45)
Just wondering what was the issue and what changed to fix it ?
 
User avatar
anav
Forum Guru
Forum Guru
Posts: 5766
Joined: Sun Feb 18, 2018 11:28 pm
Location: Nova Scotia, Canada
Contact:

Re: v6.46.3 [stable] is released!

Thu Feb 06, 2020 8:58 pm

@emils, If I am happy with 6.46.2 is there any need to change/update for a plain vanilla setup (ie there are no security fixes in this new version and thus not mandatory??)??
I'd rather manage rats than software. Follow my advice at your own risk! (Sob & mkx forced me to write that!)
MTUNA Certified, by the Ascerbic Llama!
 
mkx
Forum Guru
Forum Guru
Posts: 5067
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.46.3 [stable] is released!

Thu Feb 06, 2020 10:09 pm

@emils, If I am happy with 6.46.2 is there any need to change/update for a plain vanilla setup ...

MT wants you to believe that published change log is full story. Hence if change log doesn't mention any of your itches you're not obliged to upgrade your ROS devices.
BR,
Metod
 
Zacharias
Forum Guru
Forum Guru
Posts: 2309
Joined: Tue Dec 12, 2017 12:58 am
Location: Greece

Re: v6.46.3 [stable] is released!

Thu Feb 06, 2020 10:12 pm

Any chance we could get more details about
*) hotspot - fixed redirect to log in page (introduced in v6.45)
Just wondering what was the issue and what changed to fix it ?
There was an issue with the redirect to the hotspot page... i dont know more info...
 
markmcn
Frequent Visitor
Frequent Visitor
Posts: 88
Joined: Wed Mar 03, 2010 2:15 am

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 12:00 am

Any chance we could get more details about
*) hotspot - fixed redirect to log in page (introduced in v6.45)
Just wondering what was the issue and what changed to fix it ?
There was an issue with the redirect to the hotspot page... i dont know more info...
@Zacharias Thank you so so much for the really constructive input. But maybe some more details about what the actual issue was. Were all types of host impacted(Windows,Linux,Android,iOS) or only certain hosts or browsers maybe? I'm trying to understand if this is an issue which I may be seeing somewhere in a production environment and don't want to deploy and upgrade saying it will fix issue unless I have more details.
 
EgidijusL
just joined
Posts: 3
Joined: Fri Feb 07, 2020 1:25 am

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 1:27 am

hAP ac2, 256MB ram: With v6.46.* I get a random reboot.
 
td32
Member Candidate
Member Candidate
Posts: 104
Joined: Fri Nov 18, 2016 5:55 am

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 8:02 am

hAP ac2, 256MB ram: With v6.46.* I get a random reboot.
some suggest disabling the ntp package
viewtopic.php?f=21&t=156825&sid=81b15b9 ... 47#p773118
viewtopic.php?f=21&t=156825&sid=81b15b9 ... 47#p773712
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1444
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 8:41 am

markmcn, Zacharias - On devices with low resources (for example, SMIPS) it was possible that Hotspot login page does not appear properly
anav - As always, if you do not see changes in changelog that you require, then there is no need for an upgrade
EgidijusL, td32 - You will not ever be able to determine the cause of the reboot in the forum. If your router is rebooting by itself, then contact support@mikrotik.com right away and provide supout file. Forum posts regarding a crash due to NTP service is a random guess without any reason. Only MikroTik staff can determine precise cause of the problem and if it is caused by the software, then we want to fix this problem as soon as possible. If you even manage to workaround a problem based on other user experience, then the issue is still there and others suffer from it. All bug reports are very welcome
 
WeWiNet
Member
Member
Posts: 470
Joined: Thu Sep 27, 2018 4:11 pm

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 11:48 am

Audience 6.46.3 / Winbox V3.20:
- in Winbox content of schedules / scripts / netwatch is completely concatenated (no line breaks)
- when doing export in terminal, line breaks are there...
- In Webfig all is shown correctly as well with line breaks

bug or feature ?
WeWiNet

**
MTCNA
I like a new challenge, I migrate to ROS7... :? or maybe I am just crazy :lol: !!!
 
msatter
Forum Guru
Forum Guru
Posts: 1984
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 12:14 pm

Audience 6.46.3 / Winbox V3.20:
- in Winbox content of schedules / scripts / netwatch is completely concatenated (no line breaks)
- when doing export in terminal, line breaks are there...
- In Webfig all is shown correctly as well with line breaks

bug or feature ?
Was also a feature in previous versions.
One RB4011 (cooled) and a RB760iGS (hEX S) in series. The 4011 Does PPPoE/IKEv2.
The cooler: viewtopic.php?f=3&t=138613&start=300#p799879
Running:
RouterOS 6.48beta58 / Winbox 3.27 64bits / MikroTik APP 1.3.15
 
Florian
Frequent Visitor
Frequent Visitor
Posts: 90
Joined: Sun Mar 13, 2016 9:45 am
Location: France

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 1:46 pm

Does this include all the 6.47 test version fixes, since it's newer ?

Thx.
- Sorry for my english -
 
OndrejHolas
newbie
Posts: 26
Joined: Mon Jul 30, 2018 5:54 pm

Re: v6.46.3 [stable] is released!

Fri Feb 07, 2020 10:08 pm

During startup just after upgrade 6.46.2 -> 6.46.3, there are extra two lines in the log:

17:48:27 script,info Defconf(debug): isAp=0;isLte=0;model=cAPGi;numCombo=0;numGig=0;numSfp=0;numSfpPlus=0;other=;prefix=RouterBOARD;wireless= 5acD2nD
17:48:27 script,info Defconf(debug): w1=chains=0,1;frequencyMode=5;isAc=1;isAd=0;isN=0;w2=chains=0,1;frequencyMode=2;isAc=0;isAd=0;isN=1

Is it some new feature and we'll see this in log in future releases also or is it something forgotten from dev/test?

Observed on arm and mipsbe, haven't yet tried other archs. During subsequent reboots (without upgrade) these extra lines are not logged.

Ondrej
 
Matta
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Sat Sep 04, 2010 3:13 pm

Re: v6.46.3 [stable] is released!

Sat Feb 08, 2020 8:07 am

When trying to update my RB3011, I get "kernel failure in previous boot" in log, and it didn't update.
Same thing happened when going from 6.46.1 to 6.46.2. Eventually succeeded in update but it took some tries.
And this never happened before.
 
ksteink
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Thu Mar 31, 2016 6:54 pm

Re: v6.46.3 [stable] is released!

Tue Feb 11, 2020 6:08 pm

I did upgrade a bunch of devices without major issues: hAP AC2 (Qty 2), hEX S (Qty 4), CRS312 (Qty 1), RB2011 (Qty 1), CRS326 (Qty 1).

Related to the hAP AC2 I got a very weird issue. The 2 units that I manage both did the upgrade without any issues and reported no issues at all. One of them 2 days later reported zero Wi-Fi Clients. Checking Winbox I noticed on Wireless Association that clients were trying to connect associating at 1 Mbps and after few seconds gets disconnected. None of the Wi-Fi clients were able to get IP connectivity.

I did rollback that hAP AC2 to the version 6.46.2 and the problem persisted. I did check online on several founds related with this specific issue (only is that there are a lot of complains of poor performance on Wi-Fi on this unit.

I did try to put the long term version ( ver 6.45.8 ) and after I rebooted the router to downgrade it never came back.

Aside that I need to get onsite and check what's going on (if it's hang or simple is brick it) what else can I do to: (1) Avoid this problem in my other hAP AC2 if it shows up. and (2) What can I do to correct this problem after I manually recover my brick it hAP AC2 device?

Thanks!
 
anuser
Member
Member
Posts: 492
Joined: Sat Nov 29, 2014 7:27 pm

Re: v6.46.3 [stable] is released!

Tue Feb 11, 2020 10:21 pm

With my cAP ac (same chipset as hap ac2), I had to downgrad to 6.44.6 from 6.46.x in order to have normal wifi connections with my clients again.
 
Darkness89
just joined
Posts: 4
Joined: Mon Dec 30, 2019 2:32 pm

Re: v6.46.3 [stable] is released!

Wed Feb 12, 2020 3:50 pm

I have upgraded my RB951G-2HnD (mipsbe) from 6.46.2 to the lastest version 6.46.3 and it never come back.

I tried to restart it several times but it doesn't come back.

Checking the router, I saw that the LED on which I have the network cable plugged in did not blink, I proceeded to plug it in again and it started to flash again, but the router still does not work


Has something similar happened to anyone? Have you been able to fix it in any way?

I have enough configuration and I would not like to have to reset it.

Thanks.
 
shahani
just joined
Posts: 24
Joined: Wed Jan 02, 2019 11:29 pm

Re: v6.46.3 [stable] is released!

Fri Feb 14, 2020 3:02 am

Thank you for this Update
Hotspot Login page now opens on huawei P10 Android 8
CCR1036-12G-4S-149 | CRS328_24p_4s_rm | RB4011iGS+5HacQ2HnD-IN | RB2011UiAS-2HnD-IN | RB952Ui-5ac2nD
 
mryauch
just joined
Posts: 3
Joined: Sun Apr 30, 2017 9:41 pm

Re: v6.46.3 [stable] is released!

Fri Feb 14, 2020 6:47 pm

markmcn, Zacharias - On devices with low resources (for example, SMIPS) it was possible that Hotspot login page does not appear properly
Ruh roh that's not very reassuring. I was encountering this on my fleet of hundreds of CCR1036s. Wouldn't those be considered relatively high resource devices?
 
BeMax
just joined
Posts: 2
Joined: Thu Feb 13, 2020 10:30 am

Re: v6.46.3 [stable] is released!

Sat Feb 15, 2020 5:55 pm

Audience v6.46.3 [stable]
Auto-connecting to the second Audience does not work :(
You must manually link the two Audiences.

After installing v6. 45. 8 [long-term]
When the second audience is enabled, it automatically connects to the first one.
 
User avatar
chipby
just joined
Posts: 3
Joined: Tue Dec 10, 2019 3:15 pm

Re: v6.46.3 [stable] is released!

Wed Feb 19, 2020 7:59 am

I will try to repeat.
hAP AC2. Update - from 6.45.7 to 6.46 with WinBOX 6.20. Result - crash, device is not available from Winbox and reboot after about 1 min. Restored the device through netinstall to 6.45.7. The device is able to work. I tried to flash 6.46 through netinstall - crash, the analog result and ...
Exactly the same situation with Update - from 6.45.7 to 6.46.3. The only way to recover is netinstall.

Is it really just my problem?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8493
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: v6.46.3 [stable] is released!

Wed Feb 19, 2020 1:42 pm

Did you upgrade routerboard firmware (System -> Routerboard)?
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
OlofL
newbie
Posts: 47
Joined: Mon Oct 12, 2015 2:37 pm

Re: v6.46.3 [stable] is released!

Thu Feb 20, 2020 2:47 pm

I am seeing some issues with routes over a /29 gre interface.
This has been observed since I went to v6.46.

viewtopic.php?f=2&t=157756&p=775916#p775705

Bug?
 
Polina13
just joined
Posts: 1
Joined: Fri Feb 21, 2020 10:55 am

Re: v6.46.3 [stable] is released!

Fri Feb 21, 2020 11:02 am

what has changed after the update. In general, the router is good, but I see many have problems. in the end, how is he at work?
 
User avatar
Psiho
just joined
Posts: 10
Joined: Tue Apr 19, 2016 2:25 am
Location: SPB, Russia

Re: v6.46.3 [stable] is released!

Sat Feb 22, 2020 1:17 am

Mac server broken? hAP ac lite
 
saab
just joined
Posts: 1
Joined: Sat Feb 22, 2020 1:42 pm

Re: v6.46.3 [stable] is released!

Sat Feb 22, 2020 1:58 pm

Hello!
The Dude (4.0 beta 3, 6.46.2, 6.46.3) stopped connecting to CCR, CRS and RB1100 on versions 6.46.2, 6.46.3 and 6.45.8 long term. The logs do not write the correct username and password. It connects to other devices (RB750, SXT, QRT, DISC) on these firmware without problems.
mik1.png
mik2.png
You do not have the required permissions to view the files attached to this post.
 
User avatar
chipby
just joined
Posts: 3
Joined: Tue Dec 10, 2019 3:15 pm

Re: v6.46.3 [stable] is released!

Sun Feb 23, 2020 11:05 am

Did you upgrade routerboard firmware (System -> Routerboard)?
Yes, up to 6.45.8 - last work ver
All 6.46 - crash
 
User avatar
CZFan
Forum Guru
Forum Guru
Posts: 1892
Joined: Sun Oct 09, 2016 8:25 pm
Location: South Africa, Randburg
Contact:

Re: v6.46.3 [stable] is released!

Mon Feb 24, 2020 3:30 pm

just had a case on a Hap AC2 where the 2,4 GHz wlan1 stopped running, nothing in the log file.

Created supout file but when I restarted device to see if it solves the problem, the supout file created during the problem was deleted. (Supout file should be created in "/flash" if it exists by default)

None of the wifi devices could see the wifi, i.e. iPad tablets, Samsung phones and tablets

Disable / Enable wlan1 did not solve, restart did.

Will do supout file should it occur again
MTCNA, MTCTCE, MTCRE & MTCINE
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 671
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.46.3 [stable] is released!

Thu Feb 27, 2020 12:21 pm

New version 6.46.4 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=158100

Who is online

Users browsing this forum: Majestic-12 [Bot], shiyiqiang08 and 17 guests