Community discussions

MikroTik App
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 659
Joined: Thu Dec 11, 2014 8:53 am

v6.46.6 [stable] is released!

Tue Apr 28, 2020 3:03 pm

RouterOS version 6.46.6 has been released in public "stable" channel!

Before an upgrade:
1) Remember to make backup/export files before an upgrade and save them on another storage device;
2) Make sure the device will not lose power during upgrade process;
3) Device has enough free storage space for all RouterOS packages to be downloaded.

What's new in 6.46.6 (2020-Apr-27 10:32):

Important note!!!

- The Dude server must be updated to monitor v6.46.4+ and v6.47beta30+ RouterOS type devices.
- The Dude client must be manually upgraded after upgrading The Dude server.
- The Dude requires "winbox" policy instead of "dude" to monitor v6.46.4+ and v6.47beta30+ RouterOS type devices.

Changes in this release:

*) crs3xx - fixed switch rule "dst-port" parameter for IPv6 traffic on CRS305-1G-4S+, CRS326-24G-2S+, CRS328-24P-4S+, CRS328-4C-20S-4S+, netPower 15FR devices;
*) defconf - fixed default IP address assigning on non-paired 60 GHz devices;
*) lora - added "altitude", "latitude" and "longitude" to stat json if GPS is available;
*) lte - fixed "band" value setting when configuration is reset on R11e-4G;
*) snmp - fixed "ifSpeed" reporting for tunnel interfaces;
*) snmp - fixed multiple LTE interface OID reporting;
*) ssh - fixed SHA256 user authentication algorithm checking (introduced in v6.46.4);
*) winbox - fixed memory leak (introduced in v6.46.4);
*) winbox - increased limit of multi-entry fields to 100;
*) wireless - improved 5GHz interface stability on RB4011iGS+5HacQ2HnD and Audience;
*) wireless - improved system stability on hAP ac^2;
*) wireless - updated "south africa" regulatory domain information;

To upgrade, click "Check for updates" at /system package in your RouterOS configuration interface, or head to our download page: http://www.mikrotik.com/download

If you experience version related issues, then please send supout file from your router to support@mikrotik.com. File must be generated while router is not working as suspected or after some problem has appeared on device

Please keep this forum topic strictly related to this particular RouterOS release.
 
templeos
just joined
Posts: 7
Joined: Mon Aug 26, 2019 3:58 pm

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 3:42 pm

Any reasons why it says v6.46.6 (testing) instead of stable?
 
dvm
just joined
Posts: 22
Joined: Thu Feb 01, 2018 9:54 am

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 3:42 pm

"stable" channel
You do not have the required permissions to view the files attached to this post.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24745
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 4:00 pm

This is just text, you can ignore it. Small bug in the description field
No answer to your question? How to write posts
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 659
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 4:01 pm

Unfortunately we have left it as "testing" by mistake when building the version. It is just the name of the version - this is a stable build published in stable channel.
 
User avatar
CoUL
newbie
Posts: 39
Joined: Thu Feb 05, 2015 11:34 pm
Location: Ukraine

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 4:14 pm

Poor dude who just didn't break it ... With every update it's getting worse. :(
I want you to administer 100000 MikroTik to your dude using the built-in features. :shock:
hAP, LHG, mANTBox, mAP, NetBox, NetMetal, PowerBox, PWR-Line, QRT, RB9xx, SXTsq, cAP, hEX Lite, RB4xx, wAP, BaseBox, DynaDish, RB2011, SXT, Groove, hAP mini, hAP lite, CRS3xx, CCR, RB3011, CHR, X86
RouterOS 6.45.9 (Long-term) | WinBox 3.27 (64-bit)
 
Grant
just joined
Posts: 15
Joined: Sat Oct 26, 2013 10:55 am
Location: Ukraine, Dnipro

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 4:50 pm

Make a correct WOL or remove it. Without hosts list it is useless. Add bridge interface
 
templeos
just joined
Posts: 7
Joined: Mon Aug 26, 2019 3:58 pm

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 4:57 pm

Make a correct WOL or remove it. Without hosts list it is useless.
Not only that but you cannot select bridge from the list because it's not there. Terminal command works so that's what I am going to use until WoL gets improved in WinBox.
 
User avatar
nerxu
just joined
Posts: 6
Joined: Thu Jul 10, 2014 11:16 pm
Location: Ćurwa Mać :)

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 5:14 pm

Why you don't fix OSPF ? :?
 
llubik
newbie
Posts: 30
Joined: Mon Mar 04, 2019 7:33 pm

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 5:42 pm

which means specifically *) wireless - improved system stability on hAP ac ^ 2 ?
 
User avatar
eworm
Long time Member
Long time Member
Posts: 683
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 5:48 pm

Why you don't fix OSPF ? :?
Possibly because they could not reproduce. Did you open a support ticket?
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
bda
Member Candidate
Member Candidate
Posts: 184
Joined: Fri Sep 03, 2010 11:07 am
Location: Russia,Moscow

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 7:06 pm

Why you don't fix OSPF ? :?
Possibly because they could not reproduce. Did you open a support ticket?
We have this strange OSPF problems too. Especially on large routers with many EPL circuits, with many Ethernet links and many GRE-links.
This problem rise up at random, but I do not know how to reproduce it... It is appear after large scale carrier takes downtime and many links goes down\up at once. I think so, but I may be wrong...
Several members here note this problem from 6.44.6 till now...
God bless UNIX!
 
corp9592
just joined
Posts: 9
Joined: Sun May 05, 2019 10:14 pm

Re: v6.46.6 [stable] is released!

Tue Apr 28, 2020 7:37 pm

Hello,
Please could you elaborate on
*) wireless - improved system stability on hAP ac^2;
I just opened a ticket asking for tech support regarding wireless sudden re-associations of some of my devices, and I just saw this release. I am currently on long-term branch, but if you explain this wireless changes I may consider switching to stable. Working from home is a pain in the *** doing video calls and getting disconnected of the AP, even for juts 5 seconds.

Regards.
 
w0lt
Long time Member
Long time Member
Posts: 505
Joined: Wed Apr 02, 2008 2:12 pm
Location: Minnesota USA

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 1:09 am

Does L2TP_IPSec now work? :?
I had to downgrade from 6.47.rc60 to 6.44.6 in order to find a version that would behave normally.
Not sure if I had to go that far but did it by recommendation.
Guess I'm going to wait till someone else gives me an ok wave. 8)

-tp
MTCNA - 2011

" The Bitterness of Poor Quality Remains Long After the Sweetness of Low Price is Forgotten "

Image
 
easyspot
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Thu Jun 07, 2012 7:09 pm

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 2:33 am

Upgraded from 6.46.5 to 6.46.6 n so far I didnt see any better. Maybe need to wait for 6.46.7 for stability.
 
User avatar
Jotne
Forum Guru
Forum Guru
Posts: 1820
Joined: Sat Dec 24, 2016 11:17 am
Location: jo.overland at gmail.com

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 8:46 am

Upgraded from 6.46.5 to 6.46.6 n so far I didnt see any better. Maybe need to wait for 6.46.7 for stability.
Did it get worse than 6.46.5? Do you have problems with 6.46.5? All fixes are not for all, so it may be that there are changes that makes it better for others.
 
How to use Splunk to monitor your MikroTik Router(s)

MikroTik->Splunk
 
 
notToNew
Member Candidate
Member Candidate
Posts: 167
Joined: Fri Feb 19, 2016 3:15 pm

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 9:31 am

Upgraded a AC 2 to this Version, configured as CAP. Nothing else changed. Several Devices cannot see the WiFi ssid. Nö connection possible.
Just downgrading to LT Version helps.
--------------------------------------------------------------------------------------------
CCR1036-12G-4S, several 952Ui-5ac2nD, ...
 
easyspot
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Thu Jun 07, 2012 7:09 pm

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 9:48 am

Upgraded from 6.46.5 to 6.46.6 n so far I didnt see any better. Maybe need to wait for 6.46.7 for stability.
Did it get worse than 6.46.5? Do you have problems with 6.46.5? All fixes are not for all, so it may be that there are changes that makes it better for others.
Some of my routers are HAP AC2. Not getting worse but not any better.
I can tell if 6.43.16 still faster n more stable than 6.44.6 to 6.46.6.
Problem? Yes.
1. Sometimes wireless G cant connect, while wireless N can always connect n working just fine. Mode bgn. 6.43.16 dont have this issue.
2. Some installation at office building with alot of noise, 6.43.16 perform better for 2.4ghz.
3. PPTP from android phone, will go disconnect in few mins. With 6.43.16, the same phone can connected for hours without any problem.
Most installation still with 6.43.16 n will stay at 6.43.16 until MT can make another real stable version.
 
User avatar
CoUL
newbie
Posts: 39
Joined: Thu Feb 05, 2015 11:34 pm
Location: Ukraine

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 4:54 pm

Downgraded to 6.45.8 (longhterm). It's a pleasure to work with a dude after 2 months of hell with "super stable" versions of the dude 6.46.4 - 6.46.6. How did you manage to make him such a disabled person?
hAP, LHG, mANTBox, mAP, NetBox, NetMetal, PowerBox, PWR-Line, QRT, RB9xx, SXTsq, cAP, hEX Lite, RB4xx, wAP, BaseBox, DynaDish, RB2011, SXT, Groove, hAP mini, hAP lite, CRS3xx, CCR, RB3011, CHR, X86
RouterOS 6.45.9 (Long-term) | WinBox 3.27 (64-bit)
 
User avatar
Splash
Member Candidate
Member Candidate
Posts: 159
Joined: Fri Oct 16, 2015 10:09 am
Location: Johannesburg, South Africa

Re: v6.46.6 [stable] is released!

Wed Apr 29, 2020 8:19 pm

Interesting :) this stable version is marked as "testing"
            uptime: 1h33m5s
            version: 6.46.6 (testing)
         build-time: Apr/27/2020 10:32:16
...
I see it has been mentioned already :)
MTCNA, MTCRE, MTCINE, MTCTCE, MTCIPv6E, MTCUME, MTCSE
 
mmc
newbie
Posts: 31
Joined: Wed Dec 29, 2004 1:44 am

Re: v6.46.6 [stable] is released!

Thu Apr 30, 2020 3:59 pm

Why you don't fix OSPF ? :?
Possibly because they could not reproduce. Did you open a support ticket?
We have this strange OSPF problems too. Especially on large routers with many EPL circuits, with many Ethernet links and many GRE-links.
This problem rise up at random, but I do not know how to reproduce it... It is appear after large scale carrier takes downtime and many links goes down\up at once. I think so, but I may be wrong...
Several members here note this problem from 6.44.6 till now...
we are using ospf, and mt ospf was always a little bit 'sensitive', special when u have a lot of interface changes because you have 'dynamic' interfaces inside the ospf - than it just stops working sometimes.

currently i'm chasing an ospf bug, where just the presence of an ospf-out filter breaks ecmp / cost calculation, but i don't know if this happened already in previous versions..

you mentioned that 'your problems' started with 6.44.6 - you mean the 'long term build' i guess, because that's the only one, where there were documented ospf-code changes.
please confirm, that you don't have ospf stability problems with 6.44.5 long term, or which was the last well-known-working version?
 
bda
Member Candidate
Member Candidate
Posts: 184
Joined: Fri Sep 03, 2010 11:07 am
Location: Russia,Moscow

Re: v6.46.6 [stable] is released!

Thu Apr 30, 2020 5:57 pm

Why you don't fix OSPF ? :?
Possibly because they could not reproduce. Did you open a support ticket?
We have this strange OSPF problems too. Especially on large routers with many EPL circuits, with many Ethernet links and many GRE-links.
This problem rise up at random, but I do not know how to reproduce it... It is appear after large scale carrier takes downtime and many links goes down\up at once. I think so, but I may be wrong...
Several members here note this problem from 6.44.6 till now...
we are using ospf, and mt ospf was always a little bit 'sensitive', special when u have a lot of interface changes because you have 'dynamic' interfaces inside the ospf - than it just stops working sometimes.

currently i'm chasing an ospf bug, where just the presence of an ospf-out filter breaks ecmp / cost calculation, but i don't know if this happened already in previous versions..

you mentioned that 'your problems' started with 6.44.6 - you mean the 'long term build' i guess, because that's the only one, where there were documented ospf-code changes.
please confirm, that you don't have ospf stability problems with 6.44.5 long term, or which was the last well-known-working version?
We have no 6.44.5, but only 6.44.6 and older. All these verisons have up/down/init/extart problem. This problem solved only with full instance restart. Manual interface up/down does nothing.
God bless UNIX!
 
User avatar
nichky
Long time Member
Long time Member
Posts: 634
Joined: Tue Jun 23, 2015 2:35 pm

Re: v6.46.6 [stable] is released!

Fri May 01, 2020 6:28 am

about WOL it work until you unplug/plug the cable.
Once you do that WOL stops to work
RouterOS does not have a random function. Many has tried to make script to make random text, but all seems to be flawed.
viewtopic.php?f=9&t=160183

!) Safe Mode is your friend;
 
Zett
just joined
Posts: 2
Joined: Sun May 03, 2020 9:28 am

Re: v6.46.6 [stable] is released!

Sun May 03, 2020 9:42 am

hAP ac^2 occasional loss of IP address after upgrade.
08:16:04 interface,info ether1 link down 
08:16:04 dhcp,info dhcp-client on ether1 lost IP address 10.99.9.1 - lease stopped locally 
08:16:15 interface,info ether1 link up (speed 100M, full duplex) 
08:16:16 dhcp,info dhcp-client on ether1 got IP address 10.99.9.1 
.
08:20:45 interface,info ether1 link down 
08:20:45 dhcp,info dhcp-client on ether1 lost IP address 10.99.9.1 - lease stopped locally 
08:20:56 interface,info ether1 link up (speed 100M, full duplex) 
08:20:57 dhcp,info dhcp-client on ether1 got IP address 10.99.9.1 
.
08:32:49 interface,info ether1 link down 
08:32:49 dhcp,info dhcp-client on ether1 lost IP address 10.99.9.1 - lease stopped locally 
08:32:59 interface,info ether1 link up (speed 100M, full duplex) 
08:33:00 dhcp,info dhcp-client on ether1 got IP address 10.99.9.1 
Z.
 
mkx
Forum Guru
Forum Guru
Posts: 4771
Joined: Thu Mar 03, 2016 10:23 pm

Re: v6.46.6 [stable] is released!

Sun May 03, 2020 11:19 am

The problem is actually flapping of ether1 port ... now you only have to find out why is that happening.
BR,
Metod
 
tiran
newbie
Posts: 25
Joined: Fri Aug 07, 2015 2:53 pm

API Login fail

Mon May 04, 2020 7:16 am

6.46.6 i have issue with API login. that show error message as user name and password wrong. but i can use my api without any changes in v 6.43.16 or older.where can be the issue
 
sindy
Forum Guru
Forum Guru
Posts: 5991
Joined: Mon Dec 04, 2017 9:19 pm

Re: API Login fail

Mon May 04, 2020 7:57 am

i can use my api without any changes in v 6.43.16 or older.where can be the issue
https://wiki.mikrotik.com/wiki/Manual:API#Initial_login
A new way of API login has been implemented in association with the change of user credentials storage. Both methods could be used in 6.43 and 6.44, and since 6.45 only the new one is available.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
Zett
just joined
Posts: 2
Joined: Sun May 03, 2020 9:28 am

Re: v6.46.6 [stable] is released!

Tue May 05, 2020 8:32 am

hAP ac^2 occasional loss of IP address after upgrade.

Z.
I tested the long term version and the previous one and everything works without a problem. Only 6.46.6 makes problems.

Z.
 
IFV
just joined
Posts: 1
Joined: Fri May 01, 2020 3:08 pm

Re: v6.46.6 [stable] is released!

Tue May 05, 2020 11:08 am

Hello,

I am new user of a hap ac^2, could you please tell me what version of OS I should use: 6.46.6 stable or 6.45.8 long term ?
Thank you,

IF
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Tue May 05, 2020 2:29 pm

Does L2TP_IPSec now work? :?
I had to downgrade from 6.47.rc60 to 6.44.6 in order to find a version that would behave normally.
That problem is only in 6.47.rc60 all lower versions are OK
 
horuck
just joined
Posts: 13
Joined: Sat Nov 26, 2011 12:10 pm

Re: v6.46.6 [stable] is released!

Tue May 05, 2020 4:51 pm

Where can I get the ARM64 build for my brand new

CCR2004-1G-1S+2XS

???

Can not find anywhere please.
Thanks horuck
 
ofca
Member Candidate
Member Candidate
Posts: 202
Joined: Fri Aug 20, 2004 7:18 pm

Re: v6.46.6 [stable] is released!

Wed May 06, 2020 2:14 am

arm64 build is missing, and CCR2004 product page incorrectly links to arm build
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Wed May 06, 2020 12:04 pm

What happens when you use the built-in "system->packages->check for updates" on CCR2004?
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Wed May 06, 2020 7:45 pm

It appears that the "interface slideshow" (configured in the interfaces screen under the LCD menu) on devices like the CCR1009 has stopped working in this release...
Anyone else who can confirm that?
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 106
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.46.6 [stable] is released!

Wed May 06, 2020 11:05 pm

It appears that the "interface slideshow" (configured in the interfaces screen under the LCD menu) on devices like the CCR1009 has stopped working in this release...
Anyone else who can confirm that?
For me it's working fine. Tested with 2 interfaces, timeout 10 seconds.
 
horuck
just joined
Posts: 13
Joined: Sat Nov 26, 2011 12:10 pm

Re: v6.46.6 [stable] is released!

Thu May 07, 2020 3:12 pm

What happens when you use the built-in "system->packages->check for updates" on CCR2004?
The check for updates in winbox shows latest version 6.46.6 but in the lower left corner it says:

ERROR: missing routeros-arm64-6.46.6.npk

I can nowhere find a newer arm64 OS than on the CCR2004 delivered 6.46.3!

Please HELP mikrotik!
 
horuck
just joined
Posts: 13
Joined: Sat Nov 26, 2011 12:10 pm

Re: v6.46.6 [stable] is released!

Thu May 07, 2020 3:13 pm

arm64 build is missing, and CCR2004 product page incorrectly links to arm build
unfortuanelty very true, I tried via the product page myself too!
 
Grant
just joined
Posts: 15
Joined: Sat Oct 26, 2013 10:55 am
Location: Ukraine, Dnipro

Re: v6.46.6 [stable] is released!

Thu May 07, 2020 6:25 pm

What happens when you use the built-in "system->packages->check for updates" on CCR2004?
The check for updates in winbox shows latest version 6.46.6 but in the lower left corner it says:

ERROR: missing routeros-arm64-6.46.6.npk

I can nowhere find a newer arm64 OS than on the CCR2004 delivered 6.46.3!

Please HELP mikrotik!
RouterOS ARM64 does not exist
You need to download ARM version
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Thu May 07, 2020 7:24 pm

What happens when you use the built-in "system->packages->check for updates" on CCR2004?
The check for updates in winbox shows latest version 6.46.6 but in the lower left corner it says:

ERROR: missing routeros-arm64-6.46.6.npk

I can nowhere find a newer arm64 OS than on the CCR2004 delivered 6.46.3!

Please HELP mikrotik!
RouterOS ARM64 does not exist
You need to download ARM version
No, I think he needs to wait until MikroTik have resolved this issue... apparently the build- and downloadsite environment does not support arm64 yet.
That router is quite a new product.
 
Grant
just joined
Posts: 15
Joined: Sat Oct 26, 2013 10:55 am
Location: Ukraine, Dnipro

Re: v6.46.6 [stable] is released!

Thu May 07, 2020 7:58 pm

yes, really, the version ARM64 6.45.9 (Long-term) appeared on the site
 
ofca
Member Candidate
Member Candidate
Posts: 202
Joined: Fri Aug 20, 2004 7:18 pm

Re: v6.46.6 [stable] is released!

Fri May 08, 2020 3:00 am

arm64 build is still missing, and CCR2004 product page still incorrectly links to arm build, which may lead to pointless reboots and unnecessary frustration.
 
deanMKD1
Member
Member
Posts: 366
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: v6.46.6 [stable] is released!

Fri May 08, 2020 10:30 pm

Hello,

I am new user of a hap ac^2, could you please tell me what version of OS I should use: 6.46.6 stable or 6.45.8 long term ?
Thank you,

IF
I use 6.45.6 Stable for my hAP AC2 for months and works well.
 
User avatar
jp
Long time Member
Long time Member
Posts: 603
Joined: Wed Mar 02, 2005 5:06 am
Location: Maine
Contact:

Re: v6.46.6 [stable] is released!

Sun May 10, 2020 5:30 am

This version shows up as "testing" in IP neighbor instead of stable. Both in winbox and CLI.
Screenshot from 2020-05-09 22-29-24.png
You do not have the required permissions to view the files attached to this post.
 
easyspot
Frequent Visitor
Frequent Visitor
Posts: 76
Joined: Thu Jun 07, 2012 7:09 pm

Re: v6.46.6 [stable] is released!

Sun May 10, 2020 7:34 am

This version shows up as "testing" in IP neighbor instead of stable. Both in winbox and CLI.

Screenshot from 2020-05-09 22-29-24.png
Because they really know if this release not really stable lol
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Sun May 10, 2020 8:45 pm

It appears that the "interface slideshow" (configured in the interfaces screen under the LCD menu) on devices like the CCR1009 has stopped working in this release...
Anyone else who can confirm that?
For me it's working fine. Tested with 2 interfaces, timeout 10 seconds.
After disabling LCD and re-enabling it, it started to work again. Apparently a coincidental glitch.
(the usual diagnosis when something that is wrong happens for the first time... until it happens again :D )
 
webix
newbie
Posts: 32
Joined: Fri May 04, 2018 3:34 pm

Re: v6.46.6 [stable] is released!

Mon May 11, 2020 10:30 am

I noticed that these problems that were corrected on last version are back again:
*) system - improved system stability when forwarding traffic from switch chip to CPU (introduced in v6.43);
*) system - improved system stability when receiving/sending TCP traffic on multicore devices;
If i downgrade the router to 6.45.9, i don't notice the problems anymore.
 
User avatar
Chaosphere64
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Wed Aug 10, 2016 10:19 pm

Re: v6.46.6 [stable] is released!

Mon May 11, 2020 10:44 am

Downgraded to 6.46.5 after seeing RB4011iGS+RM reboots without any entry in the log file or any external cause. Never seen on this device before.
 
surinameclubcard
just joined
Posts: 11
Joined: Fri Mar 20, 2020 2:26 pm

Re: v6.46.6 [stable] is released!

Mon May 11, 2020 9:49 pm

Downgraded to 6.46.5 after seeing RB4011iGS+RM reboots without any entry in the log file or any external cause. Never seen on this device before.
There is a whole thread about RB4011iGS reboots. I solved it by disabling time management (SNTP + Cloud time). Check out this topic: viewtopic.php?f=2&t=158939&e=1.
 
theodore6W
just joined
Posts: 3
Joined: Wed May 13, 2020 12:54 pm

Re: v6.46.6 [stable] is released!

Wed May 13, 2020 12:59 pm

surinameclubcard, thanks for sharing.
 
User avatar
zapata
just joined
Posts: 5
Joined: Thu Dec 28, 2017 12:40 pm

Re: v6.46.6 [stable] is released!

Thu May 14, 2020 5:18 pm

Were v6.46.6 and 6.47beta53 re-released today? Why?
Run BSD! FreeBSD/NetBSD/OpenBSD
 
erlinden
Long time Member
Long time Member
Posts: 530
Joined: Wed Jun 12, 2013 1:59 pm

Re: v6.46.6 [stable] is released!

Thu May 14, 2020 5:21 pm

Were v6.46.6 and 6.47beta53 re-released today? Why?
For the v6.46.6 the date was "Tue Apr 28, 2020 1:03 pm", why re-released?
First the problem, then the solution
 
User avatar
grusu
Member Candidate
Member Candidate
Posts: 122
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: v6.46.6 [stable] is released!

Thu May 14, 2020 5:45 pm

Maybe it's a restored backup?
 
surinameclubcard
just joined
Posts: 11
Joined: Fri Mar 20, 2020 2:26 pm

Re: v6.46.6 [stable] is released!

Fri May 15, 2020 12:41 am

Maybe "testing" is renamed to "stable"?
 
camarguesol
just joined
Posts: 4
Joined: Wed Jun 16, 2010 2:01 pm

Re: v6.46.6 [stable] is released!

Fri May 15, 2020 8:25 am

ROS v6.46.6 descriptive label still shows (Testing).
Downgraded to Long Term and then selected Stable to upgrade back to Stable.
Change log error with 5.9 from 2011 entries displayed :
‐-------------------------------
New version is available
Channel
Installed Version 6.45.9
Latest Version 6.46.6
What's new in 5.9 (2011-Nov-29 14:32):

*) ssh - fix mempry leak when client uses public key authentication;
*) ppp - added support for new RADIUS attribute MT-Delegated-IPv6-Pool (#22);
*) ntp client - faster initial synchronization;
*) ppp - added support for dhcpv6 pd;
*) wireless - nv2 improvements for 11n cards;
*) hotspot - fixed login page to better handle big load;
*) wireless - change default rate-selection to advanced;
*) snmp - fix simple queue table;
*) webfig - ....

Upgraded to Stable 6.46.6 and changelog entries correct after rebooting.
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Fri May 15, 2020 10:21 am

Apparently something has gone completely wrong at the upgrade server...
When checking for upgrades it now displays a change notes list from the 4.x and 5.x age (see above)....
 
R1CH
Forum Veteran
Forum Veteran
Posts: 931
Joined: Sun Oct 01, 2006 11:44 pm

Re: v6.46.6 [stable] is released!

Fri May 15, 2020 8:48 pm

Just came to update some routers today and also seeing changelog from 2011, what is going on?!

Image
 
User avatar
Cha0s
Forum Guru
Forum Guru
Posts: 1025
Joined: Tue Oct 11, 2005 4:53 pm

Re: v6.46.6 [stable] is released!

Fri May 15, 2020 9:06 pm

 
CharlyBrown
just joined
Posts: 7
Joined: Tue Jul 17, 2018 7:12 pm

Re: v6.46.6 [stable] is released!

Sat May 16, 2020 6:24 am

Hi everyone.
I want to report a bug with the LLDP discovery protocol. After upgrade from 6.45.3 to 6.46.6, I cannot receive data from neighbors.

Thanks in advance
 
mpavlek
just joined
Posts: 2
Joined: Wed May 13, 2020 12:06 pm

Re: v6.46.6 [stable] is released!

Mon May 18, 2020 1:41 pm

There is a bridge configured on CCR1036-12G-4S MikroTik Router. There are 9 ethernet interfaces in that bridge and one root port (that leads to Internet).
The bridge is in 255.255.255.0 network. It is possible to sent WOL Magic packet from router using tool wol mac=... command and the computer wakes up.
Using WOL software it is possible to wake the computer if both computers are on the same switch (connected to same ethernet port on MikroTik router).
But it is not possible to wake the computer if one computer is connected to one port and another computer is connected to another ethernet port.
Both ports are in the same network and in the same bridge. RSTP is enabled. ARP is enabled. Edge port is chacked and Edge Port Discovery is checked.
What could be the problem? And what would be the solution? :)
Thank you
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 106
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.46.6 [stable] is released!

Mon May 18, 2020 5:20 pm

There is a bridge configured on CCR1036-12G-4S MikroTik Router. There are 9 ethernet interfaces in that bridge and one root port (that leads to Internet).
The bridge is in 255.255.255.0 network. It is possible to sent WOL Magic packet from router using tool wol mac=... command and the computer wakes up.
Using WOL software it is possible to wake the computer if both computers are on the same switch (connected to same ethernet port on MikroTik router).
But it is not possible to wake the computer if one computer is connected to one port and another computer is connected to another ethernet port.
Both ports are in the same network and in the same bridge. RSTP is enabled. ARP is enabled. Edge port is chacked and Edge Port Discovery is checked.
What could be the problem? And what would be the solution? :)
Thank you
Just tested this on a CCR1009 and it works fine. You may want to open up a new forum thread, providing configuration of the bridge and interfaces.
 
TheChad
just joined
Posts: 1
Joined: Thu May 21, 2020 9:20 pm

Re: v6.46.6 [stable] is released!

Thu May 21, 2020 9:29 pm

For anyone having issues with SIP traffic, we have found that 6.46.6 has an issue with SIP traffic at this time. I tested it on 3 of our MikroTik's and they both cannot register SIP traffic at 5060. Big problem for us on two of them we host two different PBX's. So we had to downgrade our Routerboards in order to fix are phone system's at this time. Anyone else having this issue on this stable update???
 
User avatar
osc86
Member Candidate
Member Candidate
Posts: 106
Joined: Wed Aug 09, 2017 1:15 pm

Re: v6.46.6 [stable] is released!

Fri May 22, 2020 9:32 am

@TheChad did you check the status of sip helper? (IP->Firewall->Service Ports->sip). Some people recommend to turn this off.
 
sindy
Forum Guru
Forum Guru
Posts: 5991
Joined: Mon Dec 04, 2017 9:19 pm

Re: v6.46.6 [stable] is released!

Fri May 22, 2020 11:37 am

Some people recommend to turn this the SIP helper off.
I am one of those people, under specific circumstances - the helper is useful when individual phones are connected at the LAN side and the exchange is unable to deal with CPE-side NAT on its own. If the exchange is at the LAN side, whether the helper helps or causes trouble depends on the behaviour of that particular exchange.

@TheChad, from what you wrote, the behaviour seems to have changed as a consequence of the upgrade, whereas "sip" has been last mentioned in the changelogs for 6.38.1 (2017). Hence the chances that the change was intentional are low, and without a more detailed description than just "it stopped working", chances that Mikrotik could fix it are zero. So if you don't want to get frozen forever with the last version where it works, create a dedicated topic with all the details where some analytic steps could be suggested to identify the particular issue. Most of the analytic steps do not require that the production router was running 6.46.6 - it is enough to map the behaviour of both PBXes and imitate the same behaviour using appropriate tools with a lab router running the 6.46.6.
Instead of writing novels, post /export hide-sensitive. Use find&replace in your favourite text editor to systematically replace all occurrences of each public IP address potentially identifying you by a distinctive pattern such as my.public.ip.1.
 
pe1chl
Forum Guru
Forum Guru
Posts: 6964
Joined: Mon Jun 08, 2015 12:09 pm

Re: v6.46.6 [stable] is released!

Fri May 22, 2020 11:49 am

I would say that hosting two PBXes behind a NAT router is just asking for big problems... you are just lucky when it works.
When you want to host a PBX on a public address (for outsiders to use), and even more when you want to host two of them, get some small subnet (like a /29) and use a routing that does not involve NAT (i.e., also don't put them on RFC1918 addresses and use a static NAT! just route the /29 which will give you 5 usable addresses on some DMZ network).
 
vpsrent
just joined
Posts: 1
Joined: Fri May 22, 2020 11:58 pm

Re: v6.46.6 [stable] is released!

Sat May 23, 2020 12:05 am

Please Give Advice how to i make solve this issue

when i make connect ip cloud ... local ok .. but remotley showing time out
You do not have the required permissions to view the files attached to this post.
 
User avatar
grusu
Member Candidate
Member Candidate
Posts: 122
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: v6.46.6 [stable] is released!

Sat May 23, 2020 8:00 am

Please Give Advice how to i make solve this issue

when i make connect ip cloud ... local ok .. but remotley showing time out
The answer is right in the picture: the router is behind a NAT.
 
hossain
just joined
Posts: 2
Joined: Sat May 30, 2020 6:14 am

Re: v6.46.6 [stable] is released!

Sat May 30, 2020 6:28 am

@easyspot

Could you kindly explain the wireless client association problme? I am running a problem where the wifi user frequently disassociated for 2 to 5 second. Is it problem with this 6.46.6? my device is rb1100.


"echo: system,error,critical login failure for user Administrator from 00.00.00.00 via ssh" how to stop this attack dynamically, I mean, if any ip hit frequently or 5 times, the block list update automatically.
 
hossain
just joined
Posts: 2
Joined: Sat May 30, 2020 6:14 am

Re: v6.46.6 [stable] is released!

Sat May 30, 2020 6:48 am

Upgraded from 6.46.5 to 6.46.6 n so far I didnt see any better. Maybe need to wait for 6.46.7 for stability.
Did it get worse than 6.46.5? Do you have problems with 6.46.5? All fixes are not for all, so it may be that there are changes that makes it better for others.
Some of my routers are HAP AC2. Not getting worse but not any better.
I can tell if 6.43.16 still faster n more stable than 6.44.6 to 6.46.6.
Problem? Yes.
1. Sometimes wireless G cant connect, while wireless N can always connect n working just fine. Mode bgn. 6.43.16 dont have this issue.
2. Some installation at office building with alot of noise, 6.43.16 perform better for 2.4ghz.
3. PPTP from android phone, will go disconnect in few mins. With 6.43.16, the same phone can connected for hours without any problem.
Most installation still with 6.43.16 n will stay at 6.43.16 until MT can make another real stable version.
Could you kindly explain the wireless client association problme? I am running a problem where the wifi user frequently disassociated for 2 to 5 second. Is it problem with this 6.46.6? my device is rb1100.
 
Kraken2k
Frequent Visitor
Frequent Visitor
Posts: 61
Joined: Wed Oct 01, 2014 1:50 pm
Location: Prague

Re: v6.46.6 [stable] is released!

Sun May 31, 2020 2:49 pm

I experience strange behavior with VLAN tied to Bonding interface (made of two eth ports; RB1100AHx4): When I change the bonding interface settings (this was Transmit Hash Policy from L2 to L2&L3), it restarts itself and also all tied elements went down (which is expected). The problem is that when bonding come back online, VLAN interface, that is tied to it, does not detect that bonding is back online and stays down forever. You need to manually disable and enable VLAN interface so it detects the parent bonding interface as online.
 
User avatar
emils
MikroTik Support
MikroTik Support
Topic Author
Posts: 659
Joined: Thu Dec 11, 2014 8:53 am

Re: v6.46.6 [stable] is released!

Tue Jun 02, 2020 2:30 pm

New version 6.47 has been released in stable RouterOS channel:

viewtopic.php?f=21&t=161887

Who is online

Users browsing this forum: No registered users and 13 guests