Community discussions

 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

6.23 released!

Fri Dec 05, 2014 10:56 am

What's new in 6.23 (2014-Dec-04 14:46):

*) pptp - fixed problem where tunnel stopped transmitting packets under heavy load;
*) web proxy - caching in RAM for boards with 32MB or less RAM will not cache any content;
*) leds - removed 'led' command and added support for 'on', 'off' types under 'system leds';
*) files - allow to move files between different disks in winbox;
*) dhcpv4 server - fix adding address lists from radius;
*) dhcpv4 server - make radius classless static route tag as dhcp vendor specific;
*) smb - fixed HDD used/free space reporting
*) made powerpc metarouters work again (were broken in v6.22);
*) disks - fixed fat32 formatting where some bogus files with strange names were created
(to delete existing files reformatting is needed);
*) disks - fixed problem where some of USB disks were not recognized;
*) fetch - allow checking certificate trust without crl checking;
*) userman - fix more web session problems when user uses
customer and administrator interfaces at the same time;
*) snmp - fix external storage info reporting;
*) snmp - fix bulk walk problem introduced in v6.20;
*) fix tunnels - keep keepalive disabled for existing tunnels when upgrading;
*) fix tunnels - mtu for eoip tunnels was not allowed
to be set less than 1280 since 6.20;
*) using routing-marks could lead to tunnel loop detection to turn off tunnels;
Click "Check for updates" in QuickSet or Packages menu to get the new version. It should also work for v5 routers, please report if your device found the new release and how the update went.
 
keema
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Thu Nov 06, 2014 12:54 pm

Re: 6.23 released!

Fri Dec 05, 2014 11:55 am

Upgraded 3 lab routers. RB 493G, X86 and RB411AR. Have RIP, OSPF, EOIP, PPPOE, PPTP services running. NO problems so far. I upgraded 411AR with autoupgrade feature, rest with manual file transfer. Sadly I don't have a spare micro SD card here to test whether the filesystem (pxe boot on it) on RB493G now recognizes it.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: 6.23 released!

Fri Dec 05, 2014 12:04 pm

Bug with SNMP not enabling without a reboot from ticket [Ticket#2014112666000541] is also fixed.

Why is it not in the change-log? :(
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 12:49 pm

I have used command
/led user-led=yes
in netwatch. Now it is not working. What is the new syntax?

EDIT: It seems like
/system leds set numbers=[find leds=user-led] type=on
should work, right?
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 1:09 pm

It seems like
/system leds set numbers=[find leds=user-led] type=on
should work, right?
I think there is a small bug here - that command is working only if user-led is defined. So I must use
 /system leds add leds=user-led type=off
first. This is missing in WinBox.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 6.23 released! :D

Fri Dec 05, 2014 1:48 pm

RB433UAH

6.23 (2014-Dec-03 14:50) one disk
6.23 (2014-Dec-04 14:46) dual disk :D bonus?
You do not have the required permissions to view the files attached to this post.
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: 6.23 released!

Fri Dec 05, 2014 1:54 pm

It seems like
/system leds set numbers=[find leds=user-led] type=on
should work, right?
I think there is a small bug here - that command is working only if user-led is defined. So I must use
 /system leds add leds=user-led type=off
first. This is missing in WinBox.
It will be fixed in Winbox, but from now on such preset has to be added first.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 6.23 released!

Fri Dec 05, 2014 2:12 pm

uptime 11 min crash :?

downgrade 6.23 (2014-Dec-03 14:50) crash :( before updating to 6.23 (2014-Dec-04 14:46) works !
You do not have the required permissions to view the files attached to this post.
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 2:18 pm

Ah-h-h, 6to4 tunnel's routes to he.net work again :) And again - it's not in changelog =)
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
napismizpravu
Member Candidate
Member Candidate
Posts: 135
Joined: Sat Apr 09, 2011 1:27 pm
Location: czech

Re: 6.23 released!

Fri Dec 05, 2014 2:54 pm

continuation

downgrade 6.19
upgrade 6.23 (2014-Dec-03 14:50)
winbox delete fake disk (disk1,disk3) ; rename disk4 > disk1; proxy disable, enable
reboot

6.23 (2014-Dec-04 14:46) bad build
You do not have the required permissions to view the files attached to this post.
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: 6.23 released!

Fri Dec 05, 2014 2:57 pm

cosmetic ..

Image
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 2:59 pm

If you experience any crash at 6.23. Please make support output file after the crash and send it to support (support@mikrotik.com).
It will help us very much!
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.23 released!

Fri Dec 05, 2014 3:39 pm

Hello MikroTik support team,

thank you for starting more active communication between releasing new version and after releasing it. I would like to ask you about one old topic (from 08/2012) - setting variable via SMS - what is the chance that this bug will be fixed? Is there any ETA for fixing of this bug, please?

Tickets opened for this issue:
Ticket#2012083066000462
Ticket#2013010766000731

Issue is discussed here:
http://forum.mikrotik.com/viewtopic.php?f=9&t=58934

Thank you
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 4:03 pm

There is something strange about SSTP client in this version:
  • if there is just one SSTP connection from router, no problem;
  • if there is one SSTP and one PPTP connection from router, no problem;
  • if I manually connect router to two SSTP connections, no problem;
  • if there are two SSTP connections, after reboot there is an error state.
As an error state I mean this:
  • IP addresses of all SSTP and PPTP connections are marked as invalid;
  • I can disable both SSTP connections, but after enabling back, still none is working, neither PPTP, I have to reboot.
Is somebody experiencing this problem too? It started in 6.21, I think. When I revert to 6.20, no problem...
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.23 released!

Fri Dec 05, 2014 4:11 pm

There is something strange about SSTP client in this version:
  • if there is just one SSTP connection from router, no problem;
  • if there is one SSTP and one PPTP connection from router, no problem;
  • if I manually connect router to two SSTP connections, no problem;
  • if there are two SSTP connections, after reboot there is an error state.
As an error state I mean this:
  • IP addresses of all SSTP and PPTP connections are marked as invalid;
  • I can disable both SSTP connections, but after enabling back, still none is working, neither PPTP, I have to reboot.
Is somebody experiencing this problem too? It started in 6.21, I think. When I revert to 6.20, no problem...
I'm facing the same issue - two sstp-clients, and after some random time the connections are up, but the IP addresses on client's side are marked as invalid, no communication is going through the tunnels. Only one solution is to disable both sstp-clients, reboot the router and then enable the sstp-client interfaces. Reboot without disabling interfaces is not working. I'm facing this issue in versions 6.13 - 6.19 (maybe also in earlier 6.x).

@MikroTik support team: Will be support.out files taken once there will be invalid IP addresses visible usefull in investigation, please?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.23 released!

Fri Dec 05, 2014 4:12 pm

There is something strange about SSTP client in this version:
  • if there is just one SSTP connection from router, no problem;
  • if there is one SSTP and one PPTP connection from router, no problem;
  • if I manually connect router to two SSTP connections, no problem;
  • if there are two SSTP connections, after reboot there is an error state.
As an error state I mean this:
  • IP addresses of all SSTP and PPTP connections are marked as invalid;
  • I can disable both SSTP connections, but after enabling back, still none is working, neither PPTP, I have to reboot.
Is somebody experiencing this problem too? It started in 6.21, I think. When I revert to 6.20, no problem...

Please run following command on your device "/system logging add topics=sstp,debug,packet". Then reconnect all your sstp tunnels and generate supout file. Send this file to our support e-mail.
http://www.mikrotik.com/support.html
 
User avatar
zervan
Member
Member
Posts: 324
Joined: Fri Aug 20, 2010 10:43 pm
Location: Slovakia
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 4:52 pm

Please run following command on your device "/system logging add topics=sstp,debug,packet". Then reconnect all your sstp tunnels and generate supout file. Send this file to our support e-mail.
Well, I have just done it - [Ticket#2014120566000721]. Thanks for taking care.
Dusan Zervan from Slovakia
MTCNA, MTCRE
 
martinp
just joined
Posts: 10
Joined: Tue Sep 18, 2012 8:11 pm

Re: 6.23 released!

Fri Dec 05, 2014 5:50 pm

6to4 tunnels working for me again (SixXS), finally able to upgrade from 6.19. :)
 
User avatar
antwal
just joined
Posts: 12
Joined: Sun Jul 08, 2012 4:07 pm
Contact:

Re: 6.23 released!

Fri Dec 05, 2014 6:03 pm

Hi,

ipv6 not working - [Ticket#2014120566000801]

I have downgrade all RB.

Thanks.
 
Petr42
just joined
Posts: 10
Joined: Thu May 08, 2014 7:23 pm

Re: 6.23 released!

Fri Dec 05, 2014 6:43 pm

Virtual APs in CAPsMAN v2 re not working, discussed in thread http://forum.mikrotik.com/viewtopic.php?f=1&t=91002. It was also in 6.22.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: 6.23 released! :D

Fri Dec 05, 2014 7:25 pm

6.23 (2014-Dec-03 14:50) one disk
6.23 (2014-Dec-04 14:46) dual disk :D bonus?
So...last-minute changes were made to the final version without having us test those changes? :shock:

-- Nathan
 
martinp
just joined
Posts: 10
Joined: Tue Sep 18, 2012 8:11 pm

Re: 6.23 released!

Fri Dec 05, 2014 8:34 pm

6to4 tunnels working for me again (SixXS), finally able to upgrade from 6.19. :)
I spoke too soon. The tunnel itself remains up, but assigned address becomes invalid after a while.

This configuration has worked fine years. Reverted to 6.19 (for the second time), which works fine.

Configuration:
[martin@gw] > /ipv6 address print
Flags: X - disabled, I - invalid, D - dynamic, G - global, L - link-local
 #    ADDRESS                                     FROM-POOL INTERFACE                                                                                                 ADVERTISE
 0  G 2001:xxxx:xxxx:x::2/64                                sixxs-tunnel                                                                                              yes
 1 IG 2001:xxxx:xxyy::/64                                   ether2-master-local                                                                                       yes
 2 DL fe80::4e5e:cff:feb1:76ef/64                           bridge-local                                                                                              no
 3 DL fe80::4e5e:cff:feb1:76ee/64                           ether1-gateway                                                                                            no
 4 DL fe80::4e5e:cff:feb1:76ef/64                           ether2-master-local                                                                                       no
[martin@gw] > /ipv6 route print
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, r - rip, o - ospf, b - bgp, U - unreachable
 #      DST-ADDRESS              GATEWAY                  DISTANCE
 0 A S  2000::/3                 2001:xxxx:xxxx:x::1             1
 1 ADC  2001:xxxx:xxxx:x::/64    sixxs-tunnel                    0
 2 A S  2001:xxxx:xxyy::/48      bridge-local                    1
[martin@gw] > /interface 6to4 print
Flags: X - disabled, R - running
 #    NAME                                              MTU ACTUAL-MTU LOCAL-ADDRESS   REMOTE-ADDRESS  KEEPALIVE                                                           DSCP
 0  R sixxs-tunnel                                     1280       1280 xxx.xxx.xx.xxx  yy.yyy.y.yy                                                                         inherit
Note the invalid address on ether2-master-local.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: 6.23 released!

Fri Dec 05, 2014 8:41 pm

IPv6 VRRP flapping also fixed and not in changelog ;-)
 
wrobli
just joined
Posts: 16
Joined: Fri Mar 21, 2014 8:39 pm

Re: 6.23 released!

Fri Dec 05, 2014 10:14 pm

Its new version I have 1-3% packet lost in my test link
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2294
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: 6.23 released!

Fri Dec 05, 2014 11:07 pm

Its new version I have 1-3% packet lost in my test link
with wireless-fp and TDMA auto?
LAN, FTTx, Wireless. ISP operator
 
User avatar
linkwave
Trainer
Trainer
Posts: 53
Joined: Fri May 25, 2007 9:13 pm
Location: Grosseto, Italy
Contact:

Re: 6.23 released!

Sat Dec 06, 2014 12:05 pm

If you experience any crash at 6.23. Please make support output file after the crash and send it to support (support@mikrotik.com).
It will help us very much!
Just did it. ;)
[Ticket#2014120666000121]

Lorenzo
MTCNEL
 
estdata
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

Re: 6.23 released!

Sat Dec 06, 2014 12:53 pm

Please test the igmp proxy multicast. I'm currently running the version 6.7. This is the procedure. But why does not work after the 6.7?
to fix this problem
don't forget to give me karma if got help
....
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.23 released!

Sat Dec 06, 2014 1:22 pm

Please test the igmp proxy multicast. I'm currently running the version 6.7. This is the procedure. But why does not work after the 6.7?
to fix this problem
IGMP proxy is working fine - one listener behind IGMP proxy, switching between mcast streams without any issues.
RB2011UAS-2HnD, ROS 6.23, firmware 3.19

I had issues with RB rebooting in versions 6.7 - (probably) 6.12, but I'm running IGMP proxy without issues in version 6.19 on the same RB.
 
estdata
Frequent Visitor
Frequent Visitor
Posts: 99
Joined: Mon Feb 20, 2012 9:05 pm
Contact:

Re: 6.23 released!

Sat Dec 06, 2014 1:56 pm

I have a problem with the TV pictures which had 6.22 crashes maybe lagg
I went back to work after the 6.7 and impeccably at the moment
don't forget to give me karma if got help
....
 
User avatar
Bergante
Member Candidate
Member Candidate
Posts: 131
Joined: Tue Feb 28, 2012 12:27 pm
Location: Bilbao, Spain

Re: 6.23 released!

Sat Dec 06, 2014 2:33 pm

This is really curious.

I updated a rb2011 from 6.23rc11 to 6.23 and it corrupted my configuration.

The bridge configuration was all destroyed, some bridges would get the wrong name and IP addresses assigned to bridges would be assigned to different interfaces.

Really curious. Wondering about updating a couple of Omnitiks, but hesitant because it's a bit of a chore to rebuild.

What may have changed between rc11 and 6.23?
 
lunchboxrts
Member Candidate
Member Candidate
Posts: 144
Joined: Sat Aug 19, 2006 6:40 am
Location: United States

Re: 6.23 released!

Sat Dec 06, 2014 8:31 pm

Virtual APs in CAPsMAN v2 re not working, discussed in thread http://forum.mikrotik.com/viewtopic.php?f=1&t=91002. It was also in 6.22.
Our Virtual AP's are working fine. 2 are local forwarding and 1 is capsman forwarding.
 
VDR
just joined
Posts: 7
Joined: Thu Sep 30, 2010 11:56 pm

Re: 6.23 released!

Sat Dec 06, 2014 9:32 pm

Hello,

since RouterOS version 6.18 is packet loss, 1- 3 %.

You do not know how to solve it ?
 
Bill
Frequent Visitor
Frequent Visitor
Posts: 70
Joined: Fri May 28, 2004 4:24 pm
Location: Nevada

Re: 6.23 released!

Sun Dec 07, 2014 6:05 am

I emailed a support output file. My 6 built-in Intel 10/100 ethernet ports all stopped working after upgrading from 6.22 to 6.23.
 
wrobli
just joined
Posts: 16
Joined: Fri Mar 21, 2014 8:39 pm

Re: 6.23 released!

Sun Dec 07, 2014 10:38 am

We have problem between rb600 and 2011 we have loss 15% in ether 1gb negotiation.
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: 6.23 released!

Mon Dec 08, 2014 1:02 am

lo there.. anyone else seeing ether1 on RB912UAG-5HPnD going from connect to disconnect and vice versa with r6.23?
 
fil
just joined
Posts: 11
Joined: Wed Nov 19, 2014 1:00 am

Re: 6.23 released!

Mon Dec 08, 2014 4:01 am

What is the CAPsMAN v2 status in 6.23, is it still an optional package - or is it released in replacement of v1?
 
nostradamus
just joined
Posts: 2
Joined: Sat Dec 17, 2011 4:14 pm

Re: 6.23 released!

Mon Dec 08, 2014 4:02 am

I emailed a support output file. My 6 built-in Intel 10/100 ethernet ports all stopped working after upgrading from 6.22 to 6.23.
exactly the same issue with you, 2 intel 559 cards not working, shows no connections and no irq
 
rzirzi
Member
Member
Posts: 378
Joined: Mon Oct 09, 2006 2:33 pm

Re: 6.23 released!

Mon Dec 08, 2014 8:13 am

I emailed a support output file. My 6 built-in Intel 10/100 ethernet ports all stopped working after upgrading from 6.22 to 6.23.
exactly the same issue with you, 2 intel 559 cards not working, shows no connections and no irq
Unfortunately I havet co CONFIRM that BUG !!!
Ethernet cards based on Intel 82559 - NOT WORKING. MikroTik system discovering/recognizint it, but cards NOT WORKING, there is no IRQ for that cards!!!
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 8:19 am

wrobli,
VDR

Please contact MikroTik support (support@mikrotik.com), we will need remote access to your devices too!

Lorenzo, thank you helping us!

Bergante, Do you have any idea about the steps how to repeath the problem?
Contact support@mikrotik.com with configuration you had before upgrade.

ffernandes, please contact MikroTik support (support@mikrotik.com) with support output file from your router.
 
VDR
just joined
Posts: 7
Joined: Thu Sep 30, 2010 11:56 pm

Re: 6.23 released!

Mon Dec 08, 2014 9:36 am

Hello sergejs,

I have already sent several supout files to Mr. Martin S.

Problem occurs from version 6.15 and above. If you do downgrade to 6.15 or 6.12 = no packet loss.

I tested various CCR , various cables and it is always the same.

My configuration is:
(CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server.

Look for a file in attachment .
You do not have the required permissions to view the files attached to this post.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 10:00 am

Thank you very much for the report about Intel cards. We have found the issue, it will be fixed in the next RouterOS version.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 10:08 am

VDR, what do you use for testing? bandwidth test?
Please provide us with full details of testing method.
 
keema
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Thu Nov 06, 2014 12:54 pm

Re: 6.23 released!

Mon Dec 08, 2014 10:13 am

Still can't see SD card in RB593G with PXE config on it.................................................................. i hope this post wont be deleted as my previous one was. You really need to use gloves when writing to Mikrotik.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 10:34 am

keema,

Please make sure your SD card works (try another disk), try to format disk and then make support output file (send it to support).

Perhaps post was deleted, as it was not related to 6.23 release!
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Mon Dec 08, 2014 10:41 am

After upgrade one of my SXT lite 5 had CPU to 100% caused by ipsec and wireless rate jumping like crazy from one to another (2 or 3 changes per second).
I solved downgrading to 6.15 and disabling security packege.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 10:42 am

ibm do you have any IPSec configuration on your SXT?
Have you tried to disable security package at 6.23?
Next time it would be great to get support output file from 6.23, when your router has problems.
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Mon Dec 08, 2014 10:48 am

ibm do you have any IPSec configuration on your SXT?
Have you tried to disable security package at 6.23?
Next time it would be great to get support output file from 6.23, when your router has problems.
I haven't any ipsec configuration but I didn't try to disable security package in 6.23 beacuse I thought that a downgrade would solve the problem.
 
VDR
just joined
Posts: 7
Joined: Thu Sep 30, 2010 11:56 pm

Re: 6.23 released!

Mon Dec 08, 2014 10:51 am

I had 4 labs:

1. Linux server ---------------- (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server.
Tested with iperf.

2. CCR1006 -------------------- (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036-2)
--------FTP Cat 6.E (0,3m) --------- Linux server
Tested with BT-TEST from CCR1006 to CCR1036-2.

3. (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server
Tested with BT-TEST from CCR1036 to CCR1036-2

4. (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server (real traffic about 500 / 500 Mbit/s)
RouterOS v6.12:
--- 10.200.0.1 ping statistics ---
20000 packets transmitted, 20000 received, 0% packet loss, time 64966ms
rtt min/avg/max/mdev = 2.784/2.828/12.616/0.084 ms, pipe 2, ipg/ewma 3.248/2.855 ms


RouterOS v6.22:
--- 10.200.0.1 ping statistics ---
20000 packets transmitted, 19860 received, 0% packet loss, time 67536ms
rtt min/avg/max/mdev = 2.689/2.873/5.706/0.139 ms, ipg/ewma 3.377/2.825 ms





Packet loss occurs equally and according Router OS versions.
Last edited by VDR on Mon Dec 08, 2014 2:02 pm, edited 2 times in total.
 
keema
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Thu Nov 06, 2014 12:54 pm

Re: 6.23 released!

Mon Dec 08, 2014 11:19 am

keema,

Please make sure your SD card works (try another disk), try to format disk and then make support output file (send it to support).

Perhaps post was deleted, as it was not related to 6.23 release!
1. The SD card is working with SD adapter in PC.
2. My post was deleted because I said you should do the test yourselves instead of outsourcing test labs to users with no pay I may add.
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 11:36 am

keema, have you tried to format your disk and make support output file?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Mon Dec 08, 2014 11:39 am

What is the CAPsMAN v2 status in 6.23, is it still an optional package - or is it released in replacement of v1?
Currently this is a separate package and not included in the RouterOS bundle package. Currently it is working stable. If you are planning to develop a new CAPsMAN system I would suggest to use v2. Before deploying it check if the configuration is working ok. If you see some problems please email to support@mikrotik.com
 
User avatar
bax
Member Candidate
Member Candidate
Posts: 269
Joined: Mon Dec 20, 2004 8:45 pm
Location: Croatia

Re: 6.23 released!

Mon Dec 08, 2014 11:49 am

Sergej
Is there any chance to fix problems with proxy cache ... like discribed here :
http://forum.mikrotik.com/viewtopic.php?f=2&t=86304
looks that proxy didnt mark cached files as dscp=4 ?
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.23 released!

Mon Dec 08, 2014 3:20 pm

I had 4 labs:

1. Linux server ---------------- (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server.
Tested with iperf.

2. CCR1006 -------------------- (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036-2)
--------FTP Cat 6.E (0,3m) --------- Linux server
Tested with BT-TEST from CCR1006 to CCR1036-2.

3. (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server
Tested with BT-TEST from CCR1036 to CCR1036-2

4. (CCR1036) -------FTP Cat 6.E (0,3m) -------- (CCR1036) --------- FTP Cat 6.E (0,3m) ----------- Linux server (real traffic about 500 / 500 Mbit/s)
RouterOS v6.12:
--- 10.200.0.1 ping statistics ---
20000 packets transmitted, 20000 received, 0% packet loss, time 64966ms
rtt min/avg/max/mdev = 2.784/2.828/12.616/0.084 ms, pipe 2, ipg/ewma 3.248/2.855 ms


RouterOS v6.22:
--- 10.200.0.1 ping statistics ---
20000 packets transmitted, 19860 received, 0% packet loss, time 67536ms
rtt min/avg/max/mdev = 2.689/2.873/5.706/0.139 ms, ipg/ewma 3.377/2.825 ms





Packet loss occurs equally and according Router OS versions.


We have tested same kind of ping between two CCR devices in our lab and 20000 packets were exchanged without any problems.

In version 6.15 ethernet hardware queue was reduced and this might cause dropped packets while ping is not the only traffic going through device.

When you send icmp packets with size 65000, then 44 fragments are being sent to destination address and if one of them is lost then whole packet is being dropped.

Also when you send ping reply to source address and if there is no place in queue for 44 reply fragments, then packet will be dropped.
 
User avatar
mishaM
Frequent Visitor
Frequent Visitor
Posts: 84
Joined: Sun Oct 25, 2009 1:48 pm
Location: Georgia

Re: 6.23 released!

Mon Dec 08, 2014 3:34 pm

Hi dear Mikrotik team ,

When you are implement custom channel width on AC products ?
 
VDR
just joined
Posts: 7
Joined: Thu Sep 30, 2010 11:56 pm

Re: 6.23 released!

Mon Dec 08, 2014 4:05 pm

We have tested same kind of ping between two CCR devices in our lab and 20000 packets were exchanged without any problems.

In version 6.15 ethernet hardware queue was reduced and this might cause dropped packets while ping is not the only traffic going through device.

When you send icmp packets with size 65000, then 44 fragments are being sent to destination address and if one of them is lost then whole packet is being dropped.

Also when you send ping reply to source address and if there is no place in queue for 44 reply fragments, then packet will be dropped.
With this response, I can not satisfy. If I use the ping size of 45000, so the result is exactly the same !!!

Other test:
Ping from my linux server ---- 0,3 m CAT6 ----- CCR 1036 (NAT) -----0,3 m CAT6 -------- CCR 1036 (BGP) --------fiber ------- GW Linux.

Command:
ping -i 0,1 -s 45000 XXX.XXX.47.129 -c 1000

Traffic through CCR router:
rx-packets-per-second: 31 359
rx-bits-per-second: 314.9Mbps
tx-bits-per-second: 35.1Mbps

Result:
--- XXX.XXX.47.129 ping statistics ---
1000 packets transmitted, 957 received, 4% packet loss, time 6321ms
rtt min/avg/max/mdev = 4.994/5.668/17.363/0.817 ms, pipe 2, ipg/ewma 6.327/5.651 ms
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Mon Dec 08, 2014 5:39 pm

Bill, nostradamus.

To solve the issue with Intel cards, please install the version from the link on your router,
http://www.mikrotik.com/download/share/ ... 6.23.1.npk
Let us know about the results.



bax,
Thank you very much for the report!
We will try to fix the cache-hit DSCP issue in the next RouterOS version 6.24!
 
User avatar
bax
Member Candidate
Member Candidate
Posts: 269
Joined: Mon Dec 20, 2004 8:45 pm
Location: Croatia

Re: 6.23 released!

Mon Dec 08, 2014 7:13 pm

Bill, nostradamus.

To solve the issue with Intel cards, please install the version from the link on your router,
http://www.mikrotik.com/download/share/ ... 6.23.1.npk
Let us know about the results.



bax,
Thank you very much for the report!
We will try to fix the cache-hit DSCP issue in the next RouterOS version 6.24!
Liked :D
Can you also check this ? http://forum.mikrotik.com/viewtopic.php?f=10&t=91976
 
lemosh
just joined
Posts: 5
Joined: Tue Dec 09, 2014 8:23 am

Re: 6.23 released!

Tue Dec 09, 2014 8:28 am

Broadcom NetXtreme II BCM5708S Gigabit Ethernet didn't work in RouterOS 6.23. But in RouterOS 6.22 works fine. Why?
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Tue Dec 09, 2014 9:22 am

lemosh,
we are sorry for the incovenience caused by the following problem.

Please install MikroTik RouterOS 6.23.1 on your router,
http://forum.mikrotik.com/viewtopic.php?f=2&t=92007
Let us know about the results!
 
marcof
just joined
Posts: 16
Joined: Thu Dec 22, 2011 5:50 pm

Re: 6.23 released!

Tue Dec 09, 2014 12:24 pm

IPv6 VRRP flapping also fixed and not in changelog ;-)
maybe because it's actually still NOT working as it should in 6.23 (and 6.23.1). I opened ticket 2014120966000348:

I've configured VRRP IPv6 on 2 routers in my lab on same ipv6 network with a global scope address on VRRP interface and it works in the first place but then after some interface down / up or disable / enable I get both VRRP nodes in MASTER and some log messages like this:

Router1# vrrp,warning vrrp1 received packet from fe80::d6ca:6dff:fe0e:9ae4 misconfigured IP addresses [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202, fe80::200:5eff:fe00:202](my) != [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202](received)

Router2# vrrp,warning vrrp1 received packet from fe80::4e5e:cff:fe4e:684 misconfigured IP addresses [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202](my) != [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202, fe80::200:5eff:fe00:202](received)

Also this "misconfigured IP addresses" message is then displayed on the VRRP interface in winbox and there is no way to clear this error, even disable / enable of the interface does not clear it and the interfaces stay in MASTER or sometimes the "backup" router is flapping between BACKUP and MASTER. only deleting the VRRP interface or rebooting both routers clears the error.

Looks like there is something totally wrong with link local address handling in VRRP as the link local is 2 times or even 3 times in the announcement, as far I can tell from that log message. or maybe it's still some keepalive issue and the "misconfigured IP addresses" is only a side effect.

really, they said it's fixed in 6.23 and I mean it's somehow working slightly better, but still totally unusable. I really wonder if they tested this at all after "fixing" it. :(
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: 6.23 released!

Tue Dec 09, 2014 3:12 pm

In our setup, the bug was fixed after upgrading.
 
marcof
just joined
Posts: 16
Joined: Thu Dec 22, 2011 5:50 pm

Re: 6.23 released!

Tue Dec 09, 2014 4:25 pm

IPv6 VRRP flapping also fixed and not in changelog ;-)
maybe because it's actually still NOT working as it should in 6.23 (and 6.23.1). I opened ticket 2014120966000348:

I've configured VRRP IPv6 on 2 routers in my lab on same ipv6 network with a global scope address on VRRP interface and it works in the first place but then after some interface down / up or disable / enable I get both VRRP nodes in MASTER and some log messages like this:

Router1# vrrp,warning vrrp1 received packet from fe80::d6ca:6dff:fe0e:9ae4 misconfigured IP addresses [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202, fe80::200:5eff:fe00:202](my) != [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202](received)

Router2# vrrp,warning vrrp1 received packet from fe80::4e5e:cff:fe4e:684 misconfigured IP addresses [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202](my) != [2a00:f8c0:1000:9::190, fe80::200:5eff:fe00:202, fe80::200:5eff:fe00:202](received)

Also this "misconfigured IP addresses" message is then displayed on the VRRP interface in winbox and there is no way to clear this error, even disable / enable of the interface does not clear it and the interfaces stay in MASTER or sometimes the "backup" router is flapping between BACKUP and MASTER. only deleting the VRRP interface or rebooting both routers clears the error.

Looks like there is something totally wrong with link local address handling in VRRP as the link local is 2 times or even 3 times in the announcement, as far I can tell from that log message. or maybe it's still some keepalive issue and the "misconfigured IP addresses" is only a side effect.

really, they said it's fixed in 6.23 and I mean it's somehow working slightly better, but still totally unusable. I really wonder if they tested this at all after "fixing" it. :(
I got answer from support:
Thank you about great explanation.
This issue will be fixed in version 6.24rc2.
 
rado3105
Member
Member
Posts: 480
Joined: Sat Jan 12, 2008 11:45 pm

Re: 6.23 released!

Tue Dec 09, 2014 9:19 pm

bandwitch test is not working correctly, very unstable and 2x slower than in 6.19...propably problem with optimization....
the last version where btest is working correctly je 6.19....did anybody notice it?
Mikrotik why did you mess bandwitch test?
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8319
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: 6.23 released!

Tue Dec 09, 2014 10:47 pm

Mikrotik why did you mess bandwitch test?
wel, at least because they have much better tool - Traffic Generator =)
http://wiki.mikrotik.com/wiki/Manual:Pe ... _Generator
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
keithy
newbie
Posts: 25
Joined: Sat Aug 07, 2010 7:00 pm

Re: 6.23 released!

Wed Dec 10, 2014 12:47 am

Mikrotik why did you mess bandwitch test?

Dunno, its all voodoo to me :o
 
lemosh
just joined
Posts: 5
Joined: Tue Dec 09, 2014 8:23 am

Re: 6.23 released!

Wed Dec 10, 2014 8:02 am

lemosh,
we are sorry for the incovenience caused by the following problem.

Please install MikroTik RouterOS 6.23.1 on your router,
http://forum.mikrotik.com/viewtopic.php?f=2&t=92007
Let us know about the results!
Thank you! Work fine!
 
counterfeit
just joined
Posts: 2
Joined: Wed Nov 24, 2010 10:46 pm

Re: 6.23 released!

Wed Dec 10, 2014 3:14 pm

Hi!

Make static button is missing in IP ->DHCP Leases, only shows Check Status button, is it possible to make static leases for example 100 hosts with one click as it was before?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Wed Dec 10, 2014 3:17 pm

Hi!

Make static button is missing in IP ->DHCP Leases, only shows Check Status button, is it possible to make static leases for example 100 hosts with one click as it was before?
select these, right click, choose "make static" from menu
No answer to your question? How to write posts
 
counterfeit
just joined
Posts: 2
Joined: Wed Nov 24, 2010 10:46 pm

Re: 6.23 released!

Wed Dec 10, 2014 3:44 pm

Hi!

Make static button is missing in IP ->DHCP Leases, only shows Check Status button, is it possible to make static leases for example 100 hosts with one click as it was before?
select these, right click, choose "make static" from menu

Already tried to do that way, but only one host from selected list gets static, all others selected don't change!
 
sunshines
just joined
Posts: 2
Joined: Thu Nov 20, 2014 4:24 am

Re: 6.23 released!

Wed Dec 10, 2014 6:25 pm

The download link of 6.23.1 x86 is wrong

when click, it turns to http://download2.mikrotik.com/routeros/ ... 23.1.1.npk
but the true link is http://download2.mikrotik.com/routeros/ ... 6.23.1.npk

the first link can't be downloaded
 
ddejager
Member Candidate
Member Candidate
Posts: 109
Joined: Tue Oct 18, 2011 5:13 am

HDD free space report incorrect

Wed Dec 10, 2014 10:56 pm

I have two RBmAP2n devices where I've loaded 6.23. On both devices the amount of internal HDD space that is reported is incorrect. Both devices have 16 MB of HDD space. The file list in Winbox shows 10.9 MB used. The Resources window reports 5.1 available. This is incorrect there is nothing on the drive other than two empty directories: flash and flash/skins. I'm able to drag and drop the 10 MB 6.23 npk file to the drive successfully and the amount of space used or available does not change. This did not happen on 6.18 or 6.19. I'm reluctant to load this release on my other devices until this is fixed.
 
zipiju
just joined
Posts: 9
Joined: Fri Jun 13, 2014 4:34 pm

Re: HDD free space report incorrect

Thu Dec 11, 2014 12:46 am

I have two RBmAP2n devices where I've loaded 6.23. On both devices the amount of internal HDD space that is reported is incorrect. Both devices have 16 MB of HDD space. The file list in Winbox shows 10.9 MB used. The Resources window reports 5.1 available. This is incorrect there is nothing on the drive other than two empty directories: flash and flash/skins. I'm able to drag and drop the 10 MB 6.23 npk file to the drive successfully and the amount of space used or available does not change. This did not happen on 6.18 or 6.19. I'm reluctant to load this release on my other devices until this is fixed.
You have RouterOS on that NAND, that is those 10.9MB of used space.
When you are copying files into the Files directories other than "flash", you're using RAM drive (the files are stored in the RAM).
So nothing wrong with that at all.
The Files were slightly changed in last few versions I think, thus it might look to you as a bug, but it isn't.
 
savage
Forum Guru
Forum Guru
Posts: 1213
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: 6.23 released!

Thu Dec 11, 2014 2:17 am

[cknipe@RTD-CN01-CR01] > /ip address print 
Flags: X - disabled, I - invalid, D - dynamic 
 #   ADDRESS            NETWORK         INTERFACE                                                                                                                                                                    
...
26 X 198.19.253.194/26  198.19.253.192  ether2 - Private Servers
...

[cknipe@RTD-CN01-CR01] > /ping 198.19.253.194 count=5
  SEQ HOST                                     SIZE TTL TIME  STATUS              
    0 198.19.253.194                             56  62 168ms
    1 198.19.253.194                             56  62 168ms
    2 198.19.253.194                             56  62 167ms
    3 198.19.253.194                             56  62 164ms
    4 198.19.253.194                             56  62 164ms
    sent=5 received=5 packet-loss=0% min-rtt=164ms avg-rtt=166ms max-rtt=168ms 

[cknipe@RTD-CN01-CR01] > 
Not only is disabled IP addresses not disabled, but horrendous pings as well considering the IP's are locally on the MT!

Also, *none* of my Ethernet (copper) interfaces works (6.22 nor in 6.23). SPF+ interfaces seems to be fine.

RB CCR1036-8G-2S+
Regards,
Chris
 
savage
Forum Guru
Forum Guru
Posts: 1213
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: 6.23 released!

Thu Dec 11, 2014 2:54 am

Change a setting on one single ethernet port, and *all* ports flap... :(
Regards,
Chris
 
User avatar
sergejs
MikroTik Support
MikroTik Support
Topic Author
Posts: 6616
Joined: Thu Mar 31, 2005 3:33 pm
Location: Riga, Latvia
Contact:

Re: 6.23 released!

Thu Dec 11, 2014 10:31 am

counterfeit,
please, make sure that you have Winboxv3, such procedure works fine for me!

ddejager,
as mAP does not have too big disk. RouterOS upgrade package is stored in RAM, that’s why disk space does not change. Please send support output file with different available size to support@mikrotik.com (include screenshot from your files list).


savage,
Is it possible to make support output file from your router?
We do not have any active report about Ethernet port problems, neither in 6.23 nor in 6.22
 
Neilson
Member Candidate
Member Candidate
Posts: 174
Joined: Tue Nov 06, 2012 10:42 pm
Location: Auckland, New Zealand

Re: 6.23 released!

Thu Dec 11, 2014 11:00 am

@savage

I am seeing this same behaviour on my NNI Box (Running 6.19)

I have provided Mikrotik with a supout from this router right after it happens however if you can provide a 6.23 supout that would probably help a lot.

My ticket is number: [Ticket#2014121166000085]

I can also confirm it happens on 6.23 (another box)

Both incidents happen on CCR1036-12G-4S

I am making a supout from this box as well to update the ticket and I can provide access to Mikrotik if they want to take a look at the box.

Regards
Alexander
 
savage
Forum Guru
Forum Guru
Posts: 1213
Joined: Mon Oct 18, 2004 12:07 am
Location: Cape Town, South Africa
Contact:

Re: 6.23 released!

Thu Dec 11, 2014 12:25 pm

savage,
Is it possible to make support output file from your router?
We do not have any active report about Ethernet port problems, neither in 6.23 nor in 6.22
Ticket#2014121166000049 & 2014121166000021

I was kind of actually hoping for a response to those tickets already. It's quite ironic that you build routers, but you can't even get something as simple as a Ethernet port right. Right now, I have a USD 1K door stop, completely unusable. I'm not impressed :-x Even more so considering that I've upgraded to a CCR on Mikrotik's advise due to driver issues on x86 platforms.
Regards,
Chris
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Thu Dec 11, 2014 12:51 pm

savage,
Is it possible to make support output file from your router?
We do not have any active report about Ethernet port problems, neither in 6.23 nor in 6.22
Ticket#2014121166000049 & 2014121166000021

I was kind of actually hoping for a response to those tickets already. It's quite ironic that you build routers, but you can't even get something as simple as a Ethernet port right. Right now, I have a USD 1K door stop, completely unusable. I'm not impressed :-x Even more so considering that I've upgraded to a CCR on Mikrotik's advise due to driver issues on x86 platforms.
Those are less than a day old. We will get to them, thanks!
No answer to your question? How to write posts
 
Kencomp
just joined
Posts: 12
Joined: Fri Jul 16, 2010 11:28 am

Re: 6.23 released!

Thu Dec 11, 2014 3:13 pm

Actually V6.23.1 was released immediately afterwards

Since upgrade to V6.23.1 no current TX power values show in the table. This occurs on RB951G-5HpACd unit. Have tried 802.11, Nstream and NV2 all do the same. The wireless however is working as clients connect as expected.
 
travisnj
just joined
Posts: 13
Joined: Wed Nov 25, 2009 10:30 pm

Re: 6.23 released!

Thu Dec 11, 2014 9:25 pm

I would like to try the suggestion that Uldis gave.

http://forum.mikrotik.com/viewtopic.php ... 00#p457454

However, I cannot locate 3.19 anywhere... I need a link to 3.19 mipsbe upgrade, it is not found on the site anywhere (have looked).

METAL 2SHPN 6.23 still stops broadcasting SSID and stops passing traffic once a day minimum. I would like to roll back to something that is stable. 6.xx has been non-stop issues... At one point it was only running 30mins before SSID/traffic stops.
 
Ljubo
just joined
Posts: 19
Joined: Thu Apr 24, 2014 10:57 am

Re: 6.23 released!

Thu Dec 11, 2014 10:54 pm

console> system routerboard upgrade

winbox> system/routerboard/upgrade
You do not have the required permissions to view the files attached to this post.
 
ddejager
Member Candidate
Member Candidate
Posts: 109
Joined: Tue Oct 18, 2011 5:13 am

Winbox missing ability to view/change ntp client server-dns-

Fri Dec 12, 2014 4:26 am

Any chance that winbox can be enhanced to allow one to see and change the ntp client server-dns-names field?

This field is actually quite useful if you put something like us.pool.ntp.org in it.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Fri Dec 12, 2014 8:26 am

Actually V6.23.1 was released immediately afterwards

Since upgrade to V6.23.1 no current TX power values show in the table. This occurs on RB951G-5HpACd unit. Have tried 802.11, Nstream and NV2 all do the same. The wireless however is working as clients connect as expected.
Maybe you ment the RB911G-5HPacD? Currently it is not possible to get the current tx power values from the AC chips. When we will able to make it we will show those values.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: Winbox missing ability to view/change ntp client server-

Fri Dec 12, 2014 8:28 am

Any chance that winbox can be enhanced to allow one to see and change the ntp client server-dns-names field?

This field is actually quite useful if you put something like us.pool.ntp.org in it.
You can also try to use the Server-DNS-Names setting to specify the dns name of the ntp server:
/system ntp client set server-dns-names=us.pool.ntp.org
 
rajo
newbie
Posts: 36
Joined: Tue Aug 16, 2011 11:12 pm

Re: 6.23 released!

Fri Dec 12, 2014 11:28 am

There's been a significant decrease in the performance of simple queues on the RB450G since RouterOS v6.20. The performance degradation has been on the orders of about 16 percent when compared to RouterOS v6.19.

I notice that with v6.21, the following is in the changelog:
*) fixed queues - could have huge latencies and smaller throughput than specified;

However, that obviously did not resolve the regression, because every build after v6.19 has lower simple queues throughput. Was the v6.21 fix made only for multicore? Note that the RB450G is single core.
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: 6.23 released!

Fri Dec 12, 2014 3:15 pm

There's been a significant decrease in the performance of simple queues on the RB450G since RouterOS v6.20. The performance degradation has been on the orders of about 16 percent when compared to RouterOS v6.19.

I notice that with v6.21, the following is in the changelog:
*) fixed queues - could have huge latencies and smaller throughput than specified;

However, that obviously did not resolve the regression, because every build after v6.19 has lower simple queues throughput. Was the v6.21 fix made only for multicore? Note that the RB450G is single core.
Please send us supout.rif file from your device. We will check what is going on there.
http://www.mikrotik.com/support.html
 
ddejager
Member Candidate
Member Candidate
Posts: 109
Joined: Tue Oct 18, 2011 5:13 am

Re: Winbox missing ability to view/change ntp client server-

Fri Dec 12, 2014 4:10 pm

Any chance that winbox can be enhanced to allow one to see and change the ntp client server-dns-names field?

This field is actually quite useful if you put something like us.pool.ntp.org in it.
You can also try to use the Server-DNS-Names setting to specify the dns name of the ntp server:
/system ntp client set server-dns-names=us.pool.ntp.org
I do this now. I was wondering if it will be added to Winbox.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Fri Dec 12, 2014 5:00 pm

ddejager, we will add that in one of the next RouterOS releases.
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: 6.23 released!

Fri Dec 12, 2014 10:04 pm

Is anybody else noticing a drop in TCP throuput in ptmp nv2+fp especially in noisy enviroment. I have what appears perfect client connection 98% Ccr TX/Rx 54/54 max throuput 4 - 6 megs 5.26 gives 18-20megs same client.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 6.23 released!

Sat Dec 13, 2014 11:23 am

Hello Folks!

All our network is now updated to RoS6.23 no visible problems, it actually solved two problems for us, we constantly got DNS down and Disk down all over our network from the dude using RoS6.22, after RoS6.23 it disappeared. Nice!
 
DjM
Member Candidate
Member Candidate
Posts: 111
Joined: Sun Dec 27, 2009 2:44 pm

Re: 6.23 released!

Sun Dec 14, 2014 11:51 am

I can also report all devices are running fine with 6.23 (multiple RB4xx, RB951xxx, RB2011xxx).

@MikroTik support team:
Have you overlooked my question related to setting variable via SMS bug?
http://forum.mikrotik.com/viewtopic.php ... 01#p459282

Thank you
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 778
Joined: Mon May 14, 2012 9:30 pm

Re: 6.23 released!

Sun Dec 14, 2014 2:30 pm

Moved to hardware...

Was installing a Cloud Core 1009 the other day.

As i was doing the updates to 6.23 everything seemed fine.
Once I updated the Firmware to 3.20, I noticed that the DHCP Client didn't release/renew like it used too.
I see rebinding for up to an hour if I toggle the port on and off or reboot the modem it is attached too.
If i hit Renew nothing happens. If I hit release it comes right back with the new IP address.

I rely on a web power switch to reboot the MODEM when the internet is unreachable. I do not reboot the Mikrotik Routerboard.
In Prior releases... as soon as the modem comes back on. The DHCP client release/renews.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
User avatar
mikrostart
newbie
Posts: 36
Joined: Fri Aug 30, 2013 10:31 am

Re: 6.23 released!

Sun Dec 14, 2014 9:30 pm

Can you, please, make the SMB shares to be able to be accessed with android os apps again!
Before I had no problems to share the CF card of my board, and to access it via ES file axplorer e.g.
Now I can see the shares, but when try to copy / download something there's only failed errors.
I haven't changed the settings on both RB and ES.
I can confirm it worked on 6.22 (I was able to transfer files to & from the CF, using the "guest" SMB account).
If you can't I'll have to downgrade.

Thanks in advance!
 
danletkeman
Member Candidate
Member Candidate
Posts: 108
Joined: Mon Oct 18, 2004 5:42 pm

Re: 6.23 released!

Mon Dec 15, 2014 1:02 am

Is anybody else noticing a drop in TCP throughput in ptmp nv2+fp especially in noisy environment. I have what appears perfect client connection 98% Ccr TX/Rx 54/54 max throughput 4 - 6 megs 5.26 gives 18-20megs same client.
Yes!

I agree with the wireless performance issues. I see this as well on my PTP links. I recently replaced a bunch of my RB411AH boards using R5H cards with the new NetMetal 5 systems. Using the same channel, the same band size, and same antenna setup, I would get half of what the old setup would do. My only solution for now is to use "non standard" channels to hide from the noisy environment.

I understand there have been many wireless additions and changes in version 6 due to 802.11ac, and changes to NV2.

I await some fixes / enhancements to this area of Router OS, as I think it should perform much better than it does.
 
rajo
newbie
Posts: 36
Joined: Tue Aug 16, 2011 11:12 pm

Re: 6.23 released!

Mon Dec 15, 2014 10:07 am

There's been a significant decrease in the performance of simple queues on the RB450G since RouterOS v6.20. The performance degradation has been on the orders of about 16 percent when compared to RouterOS v6.19.

I notice that with v6.21, the following is in the changelog:
*) fixed queues - could have huge latencies and smaller throughput than specified;

However, that obviously did not resolve the regression, because every build after v6.19 has lower simple queues throughput. Was the v6.21 fix made only for multicore? Note that the RB450G is single core.
Please send us supout.rif file from your device. We will check what is going on there.
http://www.mikrotik.com/support.html
The router configuration contains corporate VPN/tunneling connectivity information and credentials. Is it OK if I just send an export of the relevant configurations?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Mon Dec 15, 2014 10:46 am

Is anybody else noticing a drop in TCP throuput in ptmp nv2+fp especially in noisy enviroment. I have what appears perfect client connection 98% Ccr TX/Rx 54/54 max throuput 4 - 6 megs 5.26 gives 18-20megs same client.
If you use the regular wireless package in v6.23 (not the -fp package) you still see the same performance issue?

Could you tell us what boards and what distance you have for this link? And also the configuration of the boards.
How are you testing the throughput?
Maybe you could send support output files to support@mikrotik.com so we could check the configuration and the debug logs?
 
Lupin
Member Candidate
Member Candidate
Posts: 265
Joined: Mon Feb 16, 2009 10:22 pm
Location: Italy

Re: 6.23 released!

Mon Dec 15, 2014 9:31 pm

Is anybody else noticing a drop in TCP throuput in ptmp nv2+fp especially in noisy enviroment. I have what appears perfect client connection 98% Ccr TX/Rx 54/54 max throuput 4 - 6 megs 5.26 gives 18-20megs same client.
Yes,
now I'm testing a cell with many clients with RouterOS 6.22+fp.
Good CCQ but bad TCP results

See
http://forum.mikrotik.com/viewtopic.php?f=7&t=92033
 
jvkassar
just joined
Posts: 7
Joined: Sat Sep 06, 2014 1:02 am

Re: 6.23 released!

Tue Dec 16, 2014 2:26 am

I have the same problem in several PTP link using 6.23. When I downgrade to 6:20, ptp stabilizes and go double or triple band. Equipments: NetMetal 922, SXT N, 911 QRT, Basebox (rb912).
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: 6.23 released! *** CAUTION OVERHEAT ***

Tue Dec 16, 2014 4:00 am

I just ordered a RB 2011UiAS-2HnD-IN. I t had version 6.5 on it and the first thing I did was upgrade it to 6.23. this is the ONLY thing I did, other then specifying an IP address for the bridge-local interface on the default config.

Started to watch TV, I smell something odd, like burning microchips, I look over at the RB2011, it was still on, powered by the 24 Adaptor that came with it. I go to pick it up and it was so HOT that I had to put it down again. I unplugged it right away and waited a bit, about 2 minutes, and the powered it up again, the temp in /system/health was at 55c. But holding it now I could hold the case for 5 seconds before it became uncomfortable, and had t put it down. so before the power off it had to be well over 75 Deg C.

After the power cycle, the temp has started to drop and is now at 38 C after about 15 minutes. Think it is slowly going down.

Literally nothing has been done in the way of config, just the IP address change.


Ouch!
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Tue Dec 16, 2014 12:43 pm

BobcatGuy,
What part of the RB2011 case was hot? Does it get hot now as well (what temp you see in the system health)?
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Tue Dec 16, 2014 12:46 pm

jvkassar,
You have Point to Point or Point to Multi Point links using v6.23?
What speed you are getting with v6.20 and v6.23?
Could you provide support output files from both versions and send to support@mikrotik.com
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: 6.23 released!

Tue Dec 16, 2014 1:15 pm

Uldis,

When looking at the Ethernet ports, the right hand side. It was hot enough that I had to let it go. it was as hot or hotter then a cup of coffee. The Temp on the system/health after letting it sit for a bit was 55Deg, this was after I let it cool for a bit when I powered it off.

Its been on for hours now and the temp is 32 Deg so its normal.

Just looking through the vent holes, I would say the hottest part of the case was on the right side when looking at the Ethernet ports. Inside there is a heatsink cose to the LCD screen, I'm guessing this is the CPU? To put it in perspective better, the HOTTEST part was the right side of the case, but the other side (Left) was also hot but I could hold it from that side.

I do recall that I tested a speedtest from this device to another MikroTik CRS 24 port just to see the max speeds I could get over the Ethernet. The speedtest said at one point " Could not continue, no such test"

This test was from a CRS125-24G-1S-2HnD. The test stopped on the RB2011, and the data rate showed a few K of data, where as on the CRS it showedsome number, 400+ Mbit or something. I then relized that the RB2011 was assigning IP's so I had to unplug the network cable from the CRS, but I left the RB2011 powered on, just sitting on the desk. I left it probably for 30-45 minutes when I started to smell the "fried electronics" smell, that's hen I picked it up and I actually dropped it because it was that hot, and said a few profanities.... something like " holy F___ that's hot" I relized pretty quick that this wasn't normal, that's why I unplugged it.

Just thinking about it now, I cannot recall if I had the Ethernet cable unplugged for that 45 minutes or if it was plugged in, on ether 2 on the RB2011. I checked the graph for the port that it was connected to on my CRS125-24G-1S-2HnD and that port only has a very short duration on the graph no higher then 50 Mbit, not any where near 30 - 40 minutes, so I can rule out that the speedtest was running that whole time, even if it was, the temp should not of got that hot.

I also just remembered that I seen that port 10 had POE out, so I plugged in a UBNT Rocket M5 with a short 3 foot cable, and had it plugged in for a couple minutes, and just looked at the POE stuff on that interface, it said powered on, and didn't show any current draw level in winbox for the port 10 POE. I did a power cycle from within winbox for 5 seconds which is the default. But the RM5 wasn't hooked up longer then 2 minutes.

Seems ok now, not hot, just a warm 32 Deg :-)


** EDIT, While posting the above, I did the exact same things as when I first did them, other then the upgrade from 6.5 to 6.23, and the board temp has maintained the 32 or 33 deg. Well for at least 10 minutes while typing the above.

I should also point out, this RB2011 is NEW, I just got it and upgraded from 6.5 to 6.23 right away, so I do not know if the overheat would of happened on ver 6.5....
 
jvkassar
just joined
Posts: 7
Joined: Sat Sep 06, 2014 1:02 am

Re: 6.23 released!

Tue Dec 16, 2014 3:14 pm

jvkassar,
You have Point to Point or Point to Multi Point links using v6.23?
What speed you are getting with v6.20 and v6.23?
Could you provide support output files from both versions and send to support@mikrotik.com
Uldis, I sent the email as requested.
Tested in Point To Point ...
Thank you.
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Tue Dec 16, 2014 7:23 pm

After 6.23 update I have port flapping on SXT lite 5.
 
travisnj
just joined
Posts: 13
Joined: Wed Nov 25, 2009 10:30 pm

Re: 6.23 released!

Tue Dec 16, 2014 7:49 pm

I am running 3.19 Firmware and 6.23OS...

SSID will stop broadcasting. RB will respond, what debugging can be done to track this down?

I do not see resources that would explain it, I do not see anything in debugging that sticks out... It will stop SSID until a reboot. I can soft reboot and will work for a few minutes, takes a hard reboot to operate for a while. There is NOTHING other than bridged traffic.
 
Neilson
Member Candidate
Member Candidate
Posts: 174
Joined: Tue Nov 06, 2012 10:42 pm
Location: Auckland, New Zealand

Re: 6.23 released!

Tue Dec 16, 2014 10:31 pm

Just to update the community on my CCR Port Flapping issue reported here.

According to Mikrotik any changes to the L2MTU of any interface on a CCR (they didn't explicitly talk about normal MTU so I will do some testing on this) requires the system to allocate "new space for certain interface in the internal buffer" and they report this is a hardware specific requirement for the CCR and they do not consider it a bug.

So a warning for permanent record.

Any change to L2MTU on any interface of a CCR will result in all interfaces flapping to implement buffer changes.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3426
Joined: Mon May 31, 2004 2:55 pm

Re: 6.23 released!

Wed Dec 17, 2014 12:32 pm

travisnj,
what board you are using?
Please make a support output file when the problem is happening and send it to support@mikrotik.com
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: 6.23 released!

Wed Dec 17, 2014 12:41 pm

After 6.23 update I have port flapping on SXT lite 5.
Please send the supout.rif file to MikroTIk support for inspection.
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Wed Dec 17, 2014 2:13 pm

After 6.23 update I have port flapping on SXT lite 5.
Please send the supout.rif file to MikroTIk support for inspection.
Supout just sent.
 
Ccmikrotik
just joined
Posts: 2
Joined: Wed Dec 17, 2014 5:48 pm

Re: 6.23 released!

Wed Dec 17, 2014 5:56 pm

hello everyone,
does anyone know of any issues related to IPSEC VPN tunneling using this release.
i upgrade my RB450 to the latest firmware and OS but i cannot connect via IPSEC now :? .
it works using pptp :o .
I am new in here, so if anyone can direct me to right place or send me the info on how i can fix it it would be great.

thanx for reading.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5942
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: 6.23 released!

Wed Dec 17, 2014 6:36 pm

Depends from which version you upgraded. Could be that previously you had disabled default policy template or maybe default policy group is not set in peer settngs.
Enable ipsec debug logs for more output.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: 6.23 released!

Thu Dec 18, 2014 1:07 am

Any change to L2MTU on any interface of a CCR will result in all interfaces flapping to implement buffer changes.
Not necessarily taking sides here, but realistically, how often do you change the L2MTU on an interface?? Shouldn't that mostly be a set-it-and-forget-it setting? (Of course, if you ever do need to change it, it is good to be aware of this, though IMO you shouldn't be making changes to settings like that outside of a scheduled maintenance window anyway.)

-- Nathan
 
Neilson
Member Candidate
Member Candidate
Posts: 174
Joined: Tue Nov 06, 2012 10:42 pm
Location: Auckland, New Zealand

Re: 6.23 released!

Thu Dec 18, 2014 3:53 am

When I bring in a new ethernet service from a provider I configure the MTU and L2MTU on that port for the new service (we have providers who provide a range of MTU's to us so one standard doesn't protect everything.

This normally is not an issue as there will be no customer traffic on that link yet (its just being prepared for configuration).

However unlike boxes like the 1100's etc the CCR will flap all ports (not just the port that is being changed) and therefore any building of a new port requires an outage window because services will flap and if this box happens to also be our primary NNI box with another provider (thus dropping hundreds of customer connections) or is a device that provides a critical service we can no longer make these changes without that window.

Just to be clear, I expect the port I change to flap, however a change to one port that causes flapping on every active port on the box (especially when each port supposedly is independent (not switch chip etc)) then I would be expecting to be able to change an inactive port without having to open up a maintenance window.

Also I wanted to but down in writing this behaviour as its not on the MTU page in the wiki.

Regards
Alexander
 
vano
just joined
Posts: 1
Joined: Thu Dec 18, 2014 1:57 pm

Re: 6.23 released!

Thu Dec 18, 2014 2:01 pm

Hello! I update to this FW, and have a problem!
apple (iphone, macbook) device then pptp disconnects after precisely 2 minutes and 30 seconds. on the previous version , this problem was not.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Thu Dec 18, 2014 2:25 pm

Hello! I update to this FW, and have a problem!
apple (iphone, macbook) device then pptp disconnects after precisely 2 minutes and 30 seconds. on the previous version , this problem was not.
I am connected for a long time now, from an iPhone to RouterOS v6.24 PPTP server, no disconnections. Have you tried looking in the Log? What is the stated reason for disconnection?
No answer to your question? How to write posts
 
Soundmaker
just joined
Posts: 3
Joined: Thu Dec 18, 2014 3:44 pm

Re: 6.23 released!

Thu Dec 18, 2014 3:52 pm

Hello All!
Does anyone know of any issues related to IPSEC VPN tunneling using this release.
i upgrade my RB2011UiAS from 6.21 to the latest firmware and OS but i cannot connect via IPSEC now . :-\
Everything worked before the upgrade.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Thu Dec 18, 2014 4:02 pm

Hello All!
Does anyone know of any issues related to IPSEC VPN tunneling using this release.
i upgrade my RB2011UiAS from 6.21 to the latest firmware and OS but i cannot connect via IPSEC now . :-\
Everything worked before the upgrade.
Have you tried looking in the Log? What is the stated reason for disconnection?
No answer to your question? How to write posts
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Thu Dec 18, 2014 4:10 pm

Hello All!
Does anyone know of any issues related to IPSEC VPN tunneling using this release.
i upgrade my RB2011UiAS from 6.21 to the latest firmware and OS but i cannot connect via IPSEC now . :-\
Everything worked before the upgrade.
Have you tried looking in the Log? What is the stated reason for disconnection?
Normis in your other post you said "from an iPhone to RouterOS v6.24 PPTP server".
Are you talking about the RC version?
I think that in 6.23 there are some issue with the security package because in one SXT I have CPU always at 100% after upgrade and disabling security it returned to 5-6%.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Thu Dec 18, 2014 4:10 pm

Hello All!
Does anyone know of any issues related to IPSEC VPN tunneling using this release.
i upgrade my RB2011UiAS from 6.21 to the latest firmware and OS but i cannot connect via IPSEC now . :-\
Everything worked before the upgrade.
Have you tried looking in the Log? What is the stated reason for disconnection?
Normis in your other post you said "from an iPhone to RouterOS v6.24 PPTP server".
Are you talking about the RC version?
I think that in 6.23 there are some issue with the security package because in one SXT I have CPU always at 100% after upgrade and disabling security it returned to 5-6%.

Try the RC, it is on our regular download page
No answer to your question? How to write posts
 
Soundmaker
just joined
Posts: 3
Joined: Thu Dec 18, 2014 3:44 pm

Re: 6.23 released!

Thu Dec 18, 2014 4:18 pm


Have you tried looking in the Log? What is the stated reason for disconnection?
Attached log.
You do not have the required permissions to view the files attached to this post.
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Thu Dec 18, 2014 4:21 pm

Try the RC, it is on our regular download page
I can't because I want to wait for a stable version, I downgraded all the SXT to 6.19 because I have also port flapping (I sent the supout for this problem) but between the 4 am and 4.30 am the ether 1 now flap also with 6.19 and 3.18 firmware. Before upgrade I have no port flapping and no problem with security package (this happen only on 1 of 3 SXT upgraded and continue on that SXT despite downgrade).
Last edited by ibm on Thu Dec 18, 2014 4:23 pm, edited 1 time in total.
 
Soundmaker
just joined
Posts: 3
Joined: Thu Dec 18, 2014 3:44 pm

Re: 6.23 released!

Thu Dec 18, 2014 4:22 pm


Have you tried looking in the Log? What is the stated reason for disconnection?
Attached log
You do not have the required permissions to view the files attached to this post.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 6.23 released!

Thu Dec 18, 2014 6:47 pm

ntp client CCR not working anymore on 6.23. Anybody has the same issue? Both ntp packages (system standard or ntp) same result. One CCR worked for a year with previous versions but since 6.23 no more.
Other, new CCR without any firewall rules, only srce-nat masquerade connected to new provider wont get its clock updated. But have internet access....

Anybody with the same issue?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 6.23 released! src-nat not working on CCR....

Thu Dec 18, 2014 6:52 pm

src nat an attached PC's IP to a public IP (have some set on WAN connected interface, gateway is on other side of cable=provider)
when I use 'masquerade' all works fine. change the rule in src-nat to, and give it any IP residing on the WAN port, no traffic.

I can set any public IP (class C range) on the WAN interface and masquerade works, But not a single src-nat to seems to work... traffic is not passing.....

All other firewall rules are empty (yet)

Any ideas/same experiences?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
WirelessRudy
Forum Guru
Forum Guru
Posts: 3089
Joined: Tue Aug 08, 2006 5:54 pm
Location: Spain

Re: 6.23 released!

Thu Dec 18, 2014 6:55 pm

In relation with previous 2 posts;

Can't downgrade a CCR1016 to a previous version..... how's that!

We were hoping by a downgrade to restore the ntp issue and make srce-nat work but now I can't downgrade! (to 6.19 that worked stable)


How do I downgrade? Upload the previous version packages in the file folder. select "downgrade" and router ask confirmation with the reboot warning and I press 'enter'.
Router reboots, but still comes up in 6.23 and the files are still in the folder.....

Anybody with same experiences?
Show your appreciation of this post by giving me Karma! Thanks.

Rudy R. Puister

WISP operator based on MT routerboard & ROS.
 
mperdue
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Jun 30, 2004 8:18 pm

Re: 6.23 released!

Thu Dec 18, 2014 8:29 pm

I used to keep all of our equipment on the same version but for the past year I stopped after having several unit failures or issues after upgrading. Several times I have had to try to downgrade and have the unit 'brick' on us and I have to send someone to the tower to replace a unit. That got very frustrating and expensive.

I would really like to see mikrotik work out the bugs and release a 'stable' version for those of us that do not wish to beta test / debug software. Most linux distro's have a release that should be pretty stable and is supported long term.

I just pulled the latest versions and was about to start upgrading some units then had second thoughts and decided to read through the 6.23 release topic, and now I'm very nervious about upgrading anything. I have versions 5.6 to 6.19 deployed and it would be nice to get everyting on a stable version.

Ealier this year I upgraded some older rb112's to 6.19 and had them brick on me and was told those no longer are supported in 6.x. But stragely I have a single unit that I upgraded this morning that seems stable on 6.23. So is it or is it not supported?

Regards,
Michael Perdue
 
mperdue
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Jun 30, 2004 8:18 pm

Re: 6.23 released!

Thu Dec 18, 2014 8:44 pm

Just found a differnt topic about the rb112 etc etc. http://forum.mikrotik.com/viewtopic.php ... 12#p454958 so guess that answers my question about that.
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: 6.23 released!

Fri Dec 19, 2014 12:06 am

Design Skin problems on 6.23 and 6.22 (6.20 and 6.19 not affected)

http://forum.mikrotik.com/viewtopic.php?f=2&t=92305
 
ibm
Member
Member
Posts: 301
Joined: Mon May 12, 2014 5:16 pm

Re: 6.23 released!

Fri Dec 19, 2014 11:40 am

Port flapping on SXT that began after upgrade to 6.23 this night from midnight to 3 AM several time.
Despite downgrade from 6.23 to 6.19 the situation is very very very annoying.

Image
 
LexaKnyazev
just joined
Posts: 2
Joined: Fri Dec 19, 2014 4:53 pm

Re: 6.23 released!

Fri Dec 19, 2014 5:02 pm

Hello.
There is no MetaROUTER config in WebFig after upgrade from 6.22 to 6.23, though WinBox still has it.
RB2011UiAS, firmware 3.19.
 
ndbjorne
just joined
Posts: 22
Joined: Sat Dec 15, 2012 5:06 pm
Location: Italy

Re: Winbox missing ability to view/change ntp client server-

Sat Dec 20, 2014 12:25 pm

Any chance that winbox can be enhanced to allow one to see and change the ntp client server-dns-names field?

This field is actually quite useful if you put something like us.pool.ntp.org in it.
You can also try to use the Server-DNS-Names setting to specify the dns name of the ntp server:
/system ntp client set server-dns-names=us.pool.ntp.org
or (resolution errors catch):
# Script by RouterOS
# Required: ROS v6.2 or later (catch run-time errors)
# Tested on ROS v6.23 (Tile)
# Last-Update: 2014-12-20 11:20 CET
{
#// Change following according to your 
:local NTP0 "0.it.pool.ntp.org"
:local NTP1 "1.it.pool.ntp.org"
#// get current
:local NTPPrimary [/system ntp client get primary-ntp ]
:local NTPSecondary [/system ntp client get secondary-ntp ]
#// following used to store updated IPs
:local newNTP0
:local newNTP1

 :do {
  :set newNTP0 [:resolve $NTP0 ];
 } on-error={
#// FYK
 :log error message="Primary NTP server hostname resolution failed."
 };
 :if ( $NTP0 != $NTPPrimary ) do={
#  :put ( "Changing  primary NTP server (" . $NTPPrimary . ") to " . $newNTP0 )
  /system ntp client set primary-ntp=$newNTP0
 }
 
 :do {
  :set newNTP1 [:resolve $NTP1 ];
 } on-error={
#// FYK
  :log error message="Secondary NTP server hostname resolution failed."
 };
 :if ( $NTP1 != $NTPSecondary ) do={
#  :put ( "Changing  secondary NTP server (" . $NTPSecondary . ") to " . $newNTP1 )
  /system ntp client set secondary-ntp=$newNTP1
 }
}
Andrea
 
abugadeer
just joined
Posts: 2
Joined: Mon Dec 22, 2014 6:04 pm

Re: 6.23 released!

Mon Dec 22, 2014 6:15 pm

مساءالخير ممكن مساعده انا اريد ان ادخل الى السيفر من مكان بعيد
 
abugadeer
just joined
Posts: 2
Joined: Mon Dec 22, 2014 6:04 pm

Re: 6.23 released!

Mon Dec 22, 2014 6:23 pm

مساءالخير ممكن مساعده انا ان ادخل الى السيفر من مكان بعيد
 
marizo
newbie
Posts: 33
Joined: Sun May 04, 2014 8:41 pm

Re: 6.23 released!

Tue Dec 23, 2014 10:48 am

I didnt have much time for testing, but I think there is some problem:
Android phones and Planshets can't connect to VirtualAP. There wasn't such a problem in 6.19 and 6.22
Maybe anyone can confirm and give a solution?
 
keema
Frequent Visitor
Frequent Visitor
Posts: 62
Joined: Thu Nov 06, 2014 12:54 pm

Re: 6.23 released!

Tue Dec 23, 2014 11:12 am

I just tested this in my lab. I can connect to RB493G with RoS 6.23 installed with wlan1 as physical port and wlan2 as virtual ap. I connected with my Samsung S2 running Androrid, no problems detected. I don't think this is a general issue.
 
marizo
newbie
Posts: 33
Joined: Sun May 04, 2014 8:41 pm

Re: 6.23 released!

Tue Dec 23, 2014 12:34 pm

Thanks! I'll try to test again further.
 
PastuhMedvedey
newbie
Posts: 40
Joined: Fri Jan 13, 2012 1:42 pm
Location: Ukraine

Re: 6.23 released!

Tue Dec 23, 2014 2:48 pm

Remote CAP upgrade does not work.
In this case, the update manually, is operating normally.
You do not have the required permissions to view the files attached to this post.
RB751U-2HnD, RB2011LS, RB1100AH, RB433, RB411GL, RBSXT, CCR1016
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24277
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: 6.23 released!

Tue Dec 23, 2014 2:57 pm

Remote CAP upgrade does not work.
In this case, the update manually, is operating normally.
As you can see in the log, security package is missing.
No answer to your question? How to write posts
 
PastuhMedvedey
newbie
Posts: 40
Joined: Fri Jan 13, 2012 1:42 pm
Location: Ukraine

Re: 6.23 released!

Tue Dec 23, 2014 3:01 pm

As you can see in the log, security package is missing.
Sorry, and thank you Normis.
RB751U-2HnD, RB2011LS, RB1100AH, RB433, RB411GL, RBSXT, CCR1016
 
Robox
just joined
Posts: 9
Joined: Tue Nov 26, 2013 5:48 pm

Re: 6.23 released!

Thu Dec 25, 2014 7:42 am

20141225083654893.png
new day not stamp in log. only hour
You do not have the required permissions to view the files attached to this post.
 
BobcatGuy
Member Candidate
Member Candidate
Posts: 224
Joined: Thu Apr 19, 2007 7:41 am

Re: 6.23 released!

Fri Dec 26, 2014 2:14 pm

OK I am TIRED OF THIS!!!!

I have been trying to track down a problem with routing.. SIMPLE STATIC ROUTES.

I have wasted 3 days on this. You will be surprised to find out what it is.... its version 6.23. And every time I reboot the CRS125-24G-1S-2HnD I get a different result.

From a WIRED PC I cannot ping some devices, other MT products, NetMEtal5 also running 6.23. Yet from a tablet on wifi I can ping that same device.
Ironically, I could not ping the other end of that ptp link, which is in WDS bridge. I also could not ping the IP assigned to the Ethernet port on the RB 2011 that connects to another Netmetal5 ( The far end of the link )

This RB1100 is used at another location on a different subnet, it has the dynamic route vreated for the subnet that is assigned to the ether 2 interface, which is the subnet for the network at my place.

The messed up part is, that I cannot ping the two Netmetal 5's, and not that Ethernet interface at the far end, BUT I can ping the Bridge - lan interface for the LAN on the far side. I can also ping any other device.

From the far side, I cannot ping some of the devices over here at my local side, either from a desktop pc or from the RB 2011. reports unreachable.

What I am PISSED about is that I did nothing different, this set up has been the same for about.. I cant remember...
What pisses me off more, is that all I do is reboot the CRS that is at my place and it works, even pinging the NAS at my place from the desktop at the other end of this link on the other subnet.

I bet, if I reboot it again, something else will not be reachable.

Further more, after upgrading the RB2011 on the far end I cannot get more then 25-30 Mbit TCP data across the wireless link, where normally I was getting 60 - 100 mbit TCP data. Yet, the bandwidth test I run from one router to the other across the wireless link I still get that 60 - 100 Mbit tcp data. But for some reason the same server that does nightly back ups can no longer get that higher data rate.
I will test with direct Ethernet, bypassing the RB 2011 and see if I get the speeds back to what they are supposed to be.

So 6.23 SUCKS!

I should point out that I could use winbox to MAC address, or telnet to MAC address for the two Netmetal 5's from the desktop that was wired to the CRS 24 port. I also looked to see that there was an ARP entry, ip/arp for the IP addresses of the Netmetal5's and they were present, so WHY cant it work with IP connectivity?
 
User avatar
mousa1983
Frequent Visitor
Frequent Visitor
Posts: 79
Joined: Mon Apr 21, 2014 2:36 pm
Location: ilam-iran

Re: 6.23 released!

Fri Dec 26, 2014 8:33 pm

What's new in 6.23 (2014-Dec-04 14:46):

...
*) userman - fix more web session problems when user uses
...

Dear MikroTik support team,really userman problem not solves.
after upgrade even database is not accessable!
please solve this problem.
 
steen
Member
Member
Posts: 469
Joined: Sat Oct 23, 2010 2:15 am
Location: Sweden
Contact:

Re: 6.23 released!

Sat Dec 27, 2014 10:02 am

Hello Folks!

NTP problems has arrived.
We syncronize all RB against two NTP servers, that has been working for years.
Suddeny some time ago, RB backups started to arrive at different days and so on, hmmm..
Investigating that, we found that the clock was very much off in them and even they were days behind.

Looking at the SNTP Client, they got som strange Lat bad package from: <ip address of ntp server> and last bad package 00:00:17 ago, Last bad packet reason: kod-\0a\1e\00\06

Majority of the RB devices do no thave this issue, only a few has, the affected sit in different places in the network among with other RB devices in same LAN that do not have the problem.

Anyone who knows what this is about and how to fix/mitigate it ?
 
izytech
just joined
Posts: 6
Joined: Fri Dec 09, 2011 10:51 am

Re: 6.23 released!

Sat Dec 27, 2014 8:12 pm

Upgraded a CCR1009 to 6.23 with a not so good result...
loading kernel from nand partition 0... OK
setting up elf image... OK
jumping to kernel code
Starting...
failed to open /dev/flash: No such file or directory
Generating SSH DSA key...
Starting services...

Demo license expired!
Please reinstall the router.

connect failed (errno=2)
connect failed (errno=2)
connect failed (errno=2)
connect failed (errno=2)
Client requested halt.
Is this related to 6.23 or is it a hardware failure, uptime before upgrade was aprox. 70 days. Tried netinstall 6.23 with no luck.

Best regards
Thomas

Who is online

Users browsing this forum: No registered users and 10 guests