Community discussions

 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2286
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: RouterOS v6.28 released

Thu May 14, 2015 4:08 pm

Issue with sector writes rising will be fixed in version 6.29. If you want to test it, then fix for it will be included in RouterOS starting from 6.29rc13 version when it comes out.
Which boards have this problem? Only mipsbe?
It is real problem or only "cosmetics" ?
Thanks
LAN, FTTx, Wireless. ISP operator
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: RouterOS v6.28 released

Thu May 14, 2015 4:19 pm

It was problem for all devices. Simply all the time something was written in memory. It did not cause any problems. Only additional process was running while Firewall menu was opened.
 
User avatar
bclewl1ns
Frequent Visitor
Frequent Visitor
Posts: 60
Joined: Sat Jul 06, 2013 7:38 am
Contact:

Re: RouterOS v6.28 released

Fri May 15, 2015 3:25 am

I am well aware of the increased self-interference . We plan sites very carefully to avoid this as much as possible. I also agree Nstream is allot better for PTP however it has proven to be almost useless when it comes to the new AC radios.
Have yet to test, does this apply also if set in N mode?
I have set to only N mode however if the radio is and AC radio the problem persists.
Brett

What is understood need not be discussed.
 
dmi3
just joined
Posts: 8
Joined: Fri May 08, 2015 10:30 pm

Re: RouterOS v6.28 released

Fri May 15, 2015 10:00 am

Hi guys! Updating to 6.29rc20 an have some questions:
1. i found capsmanv2 on direct link http://www.mikrotik.com/download/share/ ... mipsbe.npk , but where can i find NTP packet for RC releases? Maybe someone have user-friendly web page where we can download all rc packets we need? it would be nice
2. whether fasttrask added to the list of IPV6-FIREWALL?
3. i added and configured 6to4 interface through 192.88.99.1 but cant get good score on tests because MT blocks ICMPv6 to local bridge, i added some rules based on https://gist.github.com/tiernano/4344701
computer pinged good from MT and MT from Internet
Image
4. MT cant ping ipv6 adresses with "invalid value" error, all clients can (look terminal @ screenshot above)
5. When i try SYSTEM-AUTO APGRADE while updating from RC18 to RC20 i got "there is now newer alpha/beta/rc version" but i know they exist :)

thx for help and any information!
 
User avatar
bajodel
Long time Member
Long time Member
Posts: 545
Joined: Sun Nov 24, 2013 8:30 am
Location: Italy

Re: RouterOS v6.28 released

Fri May 15, 2015 12:33 pm

Problems on bridges interfaces, input traffic is not counted !!

Tested on platforms: CRS125-24G-1S and RB2011
RouterOS affected versions: 6.29rc14 6.29rc18 and 6.29rc20 (last one screenshot attached ..scroll down to view all)
You do not have the required permissions to view the files attached to this post.
 
Sob
Forum Guru
Forum Guru
Posts: 4538
Joined: Mon Apr 20, 2009 9:11 pm

Re: RouterOS v6.28 released

Fri May 15, 2015 10:00 pm

3. i added and configured 6to4 interface through 192.88.99.1 but cant get good score on tests because MT blocks ICMPv6 to local bridge, ...
If you have 6to4 with 2002::/16 address derived from IPv4, unspecified remote address for 6to4 interface and 192.88.99.1 as default gateway, you're running into "my" 6to4 bug (broken since 6.20, in current state since 6.24). The problem is that default gateway specified as ::192.88.99.1%6to4 does not work at all. So you can only access 2002::/16 and that's it. And if someone tries to connect to you from production (non-2002::/16) range, packets get to your router, but replies don't get out.

Current workaround recommended by MikroTik support is to use two 6to4 interfaces:
/interface 6to4
add local-address=<your IPv4 address> mtu=1480 name=6to4
add local-address=<your IPv4 address> mtu=1480 name=6to4gw remote-address=192.88.99.1
/ipv6 address
add address=2002:<your IPv4 address>::1/16 advertise=no interface=6to4
/ipv6 route
add distance=1 gateway=6to4gw
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
dmi3
just joined
Posts: 8
Joined: Fri May 08, 2015 10:30 pm

Re: RouterOS v6.28 released

Mon May 18, 2015 9:04 am

Current workaround recommended by MikroTik support is to use two 6to4 interfaces:
I did as suggested, and now http://www.ipv6-test.com/ tells me there is no ipv6 :)
Image
some other services tell there is.. in fact clients got addresses, can go ipv6, can ping, download etc
but ping still didn't reach clients after MT
suppose its wright?:Image
 
Sob
Forum Guru
Forum Guru
Posts: 4538
Joined: Mon Apr 20, 2009 9:11 pm

Re: RouterOS v6.28 released

Mon May 18, 2015 3:15 pm

I did as suggested, and now http://www.ipv6-test.com/ tells me there is no ipv6 :)
Ok, that does not sound like improvement. I'd suggest to create new topic and post more details, config export, etc..
People who quote full posts should be spanked with ethernet cable. Some exceptions for multi-topic threads may apply.
 
jondavy
Member Candidate
Member Candidate
Posts: 125
Joined: Tue May 12, 2009 11:14 pm
Location: Brasil

Re: RouterOS v6.28 released

Mon May 18, 2015 3:32 pm

the package all_packages-ppc-6.28.zip this damaged after installation and check
and also another bug:
he reappears the WebBox interface (which does not work) in RB1100AH
 
TomosRider
Member Candidate
Member Candidate
Posts: 202
Joined: Thu Nov 20, 2014 1:51 pm

Re: RouterOS v6.28 released

Tue May 19, 2015 11:31 am

One thing that happened yesterday, but i saw earlier posts about this....after power loss, Mtik lost all static DHCP leases....running ROS 6.27, will do update to .28.....any ideas why is this happening? No bad blocks....
 
TomosRider
Member Candidate
Member Candidate
Posts: 202
Joined: Thu Nov 20, 2014 1:51 pm

Re: RouterOS v6.28 released

Tue May 19, 2015 5:22 pm

After upgrade, same thing...also, cant create backup anymore. When i try to create backup file, i get message:critical error creating backup file:could not read all configuration files.
RB is 1200, running smoothly for months. Mtik staff, have any idea how to solve this problem?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: RouterOS v6.28 released

Thu May 21, 2015 8:36 pm

Today are one month after I install 6.28 on all my production devices.
No one single problem on 5GHz ac or n, BGP, VRRP, EoIP, PPtP, PPPoE, user-manager, DHCP server, DNS server & big lists of static entry, firewall & big address-list, Routing, etc., etc., etc.

(I do not use VLAN, IPv6, MPLS or OSFP)

Thanks MikroTik, finally one stable MRRU+EoIP version of the RouterOS
I'm Italian, not English. Sorry for my imperfect grammar.
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Thu May 21, 2015 10:44 pm

... and the excessive flash writings?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re:

Fri May 22, 2015 11:19 am

... and the excessive flash writings?
I do not have this problem, on production I do not have any mipsbe devices.

The only mipsbe devices are AP or PTP and no one of these have any firewall rule.
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 890
Joined: Tue Oct 11, 2005 4:53 pm

Re: RouterOS v6.28 released

Fri May 22, 2015 2:21 pm

So just because -you- are not affected by the bug, does not mean that 6.28 was all colors and rainbows.
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: RouterOS v6.28 released

Fri May 22, 2015 2:42 pm

This is it. I decided to skip 6.28. Hope the 6.29 will be at least without major bugs. I know that there will not be corrections I am waiting for, so maybe I will wait till 6.30 before I start my own update tests. Keeping 6.27 in production so far.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: RouterOS v6.28 released

Sat May 23, 2015 10:00 am

So just because -you- are not affected by the bug, does not mean that 6.28 was all colors and rainbows.
And this provocative phrase that means?
And where I have writed "6.28 is all colors and rainbows"?
If you do not like positive recensions, simply do not read, or comment, those.

If you have time and patience to ignore english errors, read that:
http://forum.mikrotik.com/viewtopic.php ... 00#p479732
I think that explain some bugs...
I'm Italian, not English. Sorry for my imperfect grammar.
 
james
just joined
Posts: 8
Joined: Wed Jun 12, 2013 11:50 pm

Re: RouterOS v6.28 released

Sat May 23, 2015 11:23 am

Since upgrading my home box seems very unstable, lots of spontaneous reboots and enough bad connections that I have power cycled it a few times.

[admin@catbus_home] /system> /system routerboard print
routerboard: yes
model: 751G-2HnD
serial-number: 2F8701252CD1
current-firmware: 3.17
upgrade-firmware: 3.22
[admin@catbus_home] /system> /system resource print
uptime: 58m57s
version: 6.28
build-time: Apr/15/2015 15:18:31
free-memory: 26.1MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 250MHz
cpu-load: 4%
free-hdd-space: 21.4MiB
total-hdd-space: 64.0MiB
write-sect-since-reboot: 3132
write-sect-total: 12762707
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB751G-2HnD
platform: MikroTik
[admin@catbus_home] /system>

From the log

may/18 23:14:53 system,error,critical System rebooted because of kernel failure
may/18 23:14:54 system,error,critical Out of memory condition was detected
may/18 23:14:54 system,error,critical router was rebooted without proper shutdown
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 890
Joined: Tue Oct 11, 2005 4:53 pm

Re: RouterOS v6.28 released

Sat May 23, 2015 2:59 pm

So just because -you- are not affected by the bug, does not mean that 6.28 was all colors and rainbows.
And this provocative phrase that means?
It means that Mikrotik 6.28 (or any other 6.x version) is FAR from stable.

I may have been a bit offensive to you but that was not my intention. I just used your comment to point out that Mikrotik is far from stable in a sarcastic way (hence the colors and rainbows).
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: RouterOS v6.28 released

Sat May 23, 2015 3:09 pm

I may have been a bit offensive to you but that was not my intention.
:D
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: RouterOS v6.28 released

Sat May 23, 2015 3:43 pm

Since upgrading my home box seems very unstable, lots of spontaneous reboots and enough bad connections that I have power cycled it a few times.

[admin@catbus_home] /system> /system routerboard print
routerboard: yes
model: 751G-2HnD
serial-number: 2F8701252CD1
current-firmware: 3.17
upgrade-firmware: 3.22
[admin@catbus_home] /system> /system resource print
uptime: 58m57s
version: 6.28
build-time: Apr/15/2015 15:18:31
free-memory: 26.1MiB
total-memory: 64.0MiB
cpu: MIPS 24Kc V7.4
cpu-count: 1
cpu-frequency: 250MHz
cpu-load: 4%
free-hdd-space: 21.4MiB
total-hdd-space: 64.0MiB
write-sect-since-reboot: 3132
write-sect-total: 12762707
bad-blocks: 0%
architecture-name: mipsbe
board-name: RB751G-2HnD
platform: MikroTik
[admin@catbus_home] /system>

From the log

may/18 23:14:53 system,error,critical System rebooted because of kernel failure
may/18 23:14:54 system,error,critical Out of memory condition was detected
may/18 23:14:54 system,error,critical router was rebooted without proper shutdown
1) Update the bios (/sys rou up)
reboot
2) Download winbox from the gateway ip of routerboard
3) Export the config (/export file=config)
4) Save the config from routerboard to your pc
5) Reset the config of your routerboard (/system reset-configuration keep-users=no no-defaults=yes)
reboot
6) Do this command: /romon port remove [find]
7) open config.rsc with notepad and paste block by block on new terminal inside winbox untill you done.
I'm Italian, not English. Sorry for my imperfect grammar.
 
AlexVB
just joined
Posts: 22
Joined: Sun Jan 21, 2007 10:52 am

Re: RouterOS v6.28 released

Mon May 25, 2015 8:11 am

After upgrade from 6.7 to 6.28 we now get spontaneous hangs every few days on CCR1036-12G-4S.
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: RouterOS v6.28 released

Mon May 25, 2015 8:32 pm

After upgrade from 6.7 to 6.28 we now get spontaneous hangs every few days on CCR1036-12G-4S.
What method you use for install 6.7 (or the previous and what method use to go to 6.7)?

What method you use to upgrade to 6.28?

BIOS version of the router?

What package you have installed and what date and time have the packages?
I'm Italian, not English. Sorry for my imperfect grammar.
 
AlexVB
just joined
Posts: 22
Joined: Sun Jan 21, 2007 10:52 am

Re: RouterOS v6.28 released

Tue May 26, 2015 9:05 am

> What method you use for install 6.7 (or the previous and what method use to go to 6.7)?
Upgrade from prevoius, preinstalled version

> What method you use to upgrade to 6.28?
Upgrade package

> BIOS version of the router?
routerboard: yes
model: CCR1036-12G-4S
serial-number: ...
current-firmware: 3.10
upgrade-firmware: 3.22
What package you have installed and what date and time have the packages?
See attached image.
You do not have the required permissions to view the files attached to this post.
Last edited by AlexVB on Tue May 26, 2015 9:07 am, edited 1 time in total.
 
AlexVB
just joined
Posts: 22
Joined: Sun Jan 21, 2007 10:52 am

Re: RouterOS v6.28 released

Tue May 26, 2015 9:06 am

I not mentioned that integrated watchdog does not detects the hangs, but If it is set to ping address then it detects hang but does not reboots router.
 
SCare
just joined
Posts: 2
Joined: Tue May 26, 2015 12:41 pm
Contact:

Re: RouterOS v6.28 released

Tue May 26, 2015 1:06 pm

Problems with CAPsMAN with the hAP lite as APs, I've differents APs with the same configuration working together (mAP and RB751) and working ok with 6.28, hAP lite not working
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: RouterOS v6.28 released

Thu May 28, 2015 11:22 am

bajodel - Unfortunately on bridge interface you can only see traffic where bridge itself is in/out interface. Bridged traffic will not be visible on this interface.
 
elurex
just joined
Posts: 4
Joined: Mon Jun 01, 2015 10:27 pm

Re: RouterOS v6.28 released

Thu Jun 25, 2015 5:52 am

can wireless bridge and virtual ap working on sxt SA5 ac?
 
hrehm
just joined
Posts: 11
Joined: Mon Jan 10, 2011 8:12 am

Re: RouterOS v6.28 released

Mon Jul 06, 2015 7:19 pm

nmaton,

please contact MikroTik support (support@mikrotik.com) with attached support output files from one of your routers.
We will try to find out what is the reason for your issues. We are sorry for any inconvenience.

I do have EXACTLY the same issue with v6.28.
CCR1036 running a Hotspot, Etherrnet "crashes" after a few days, while ROS is still accessible on seial.

trying to disable Ether1 (the only connected port) brings:

[admin@Wifi-Master] /interface> disable ether1
(5,0) WARNING: waiting for reply message: timed out
(5,0) Now cycle 220085031284627, timeout 40000000000 cycles
(5,0) Caller 0xfffffffc00042c58 with ICS 0
(5,0) Message type 0x10f, dest 0x3
(5,0) chan 4: 271
(5,0) chan 5: 271
(5,0) chan 19: 271
(5,0) chan 20: 271
(5,0) chan 21: 271
(5,0) chan 35: 271
(5,0) chan 36: 271
(5,0) chan 37: 271
(5,0) chan 51: 271
(5,0) chan 52: 271
(5,0) chan 53: 271
(5,0) chan 67: 271
(5,0) chan 68: 271
(5,0) chan 69: 271
(5,0) chan 83: 271
(5,0) chan 84: 271
(5,0) chan 85: 271
(3,1) WARNING: waiting for reply message: timed out
(3,1) Now cycle 220371650555530, timeout 40000000000 cycles
(3,1) Caller 0xfffffffc00037860 with ICS 0
(3,1) Message type 0x405, dest 0x3
(4,4) WARNING: waiting for reply message: timed out
(4,4) Now cycle 220440770250348, timeout 40000000000 cycles
(4,4) Caller 0xfffffffc00037860 with ICS 0
(4,4) Message type 0x405, dest 0x3
 
CherryNOD
just joined
Posts: 4
Joined: Thu Jul 23, 2015 8:42 am
Contact:

Re: RouterOS v6.28 released

Thu Jul 30, 2015 8:38 am

Tools -> RoMON, then check ENABLE, finally click OK

Who is online

Users browsing this forum: No registered users and 6 guests