Community discussions

 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

FastTrack - New feature in 6.29

Tue Apr 28, 2015 9:58 am

Starting from v6.29rc9, we introduced new and existing feature - FastTrack. Easy way to make your Firewall/NAT router up to 5x faster.

*) ipv4 fasttrack fastpath - accelerates connection tracking and nat for marked connections (more than 5x performance improvement compared to regular slow path conntrack/nat) - currently limited to TCP/UDP only;
*) added ~fasttrack-connection~ firewall action in filter/mangle tables for marking connections as fasttrack;
*) added fastpath support for bridge interfaces - packets received and transmitted on bridge interface can go fastpath (previously only bridge forwarded packets could go fastpath);
*) packets now can go half-fastpath - if input interface supports fastpath and packet gets forwarded in fastpath but output interface does not support fastpath or has interface queue other than only-hw-queue packet gets converted to slow path only at the dst interface transmit time;
*) trafflow: add natted addrs/ports to ipv4 flow info.

http://www.mikrotik.com/download/share/FastTrack.pdf

FastTrack documentation,
http://wiki.mikrotik.com/wiki/Manual:Wi ... escription
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 10:05 am

Can we get some bigger pictures. I can not see the firewall examples. Also if possible show examples in text version.
If I understand this correctly I have to make a mangle rule to mark packets as fasttrack. But then I guess I need to make another rule to make some processing with them ?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 11:00 am

As far as i understood, in case of regular home router, you should have these 3 rules in beginning of firewall filter forward, to use Fasttrack.
/ip firewall filter
add chain=forward action=fasttrack-connection connection-state=established,related
add chain=forward action=accept connection-state=established,related
add chain=forward action=drop connection-state=invalid
Note, that all packets that goes fasttrack, will not be visible in firewall and you will not be able to limit them in queue global.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Nov 10, 2014 7:02 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 12:03 pm

I added this rule to the top.
[admin@RB850Gx2] > /ip firewall filter print 
Flags: X - disabled, I - invalid, D - dynamic 
 0    chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix="" 
 1    chain=forward action=accept connection-state=established,related log=no log-prefix=""
There were no changes in CPU Load. And:
/ip settings print
           [......]
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
:(

Still need some kind of action to get it working?

PS v6.29rc11
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 12:26 pm

I will wait for 6.29 final before trying this, but in your rules you add a fasttrack rule and then an accept rule. What happens if there is no accept rule. Doesn't the fasttrack rule here do exactly this - passthrough all packets matched by it ?
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 12:35 pm

I will wait for 6.29 final before trying this, but in your rules you add a fasttrack rule and then an accept rule. What happens if there is no accept rule. Doesn't the fasttrack rule here do exactly this - passthrough all packets matched by it ?
Yes, but accept is also needed - it was mentioned in the presentation that a few packets (10%) will still need to be processed outside of fast-track, because of connection integrity checking, out of order delivery, security, etc.

If you didnt have the normal allow, those would be dropped.

Check the MikroTik presentation from the US MUM.
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 1:59 pm

For the first moment it looked very exciting and promising.

But now I am not sure that adding additional rules, especially if they break other commonly used features like statistics and queues, will help significantly. Moreover when it is applicable only in some cases.

I would rather see some real improvement then such half-way things. There are surely reserves in packets processing and in memory usage that could be addressed...

If there are some conditions that would allow fasttrack, why I have to create additional user rules for it? Why packets that could be processed in fasttrack mode are not processed so transparently in the background?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24066
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:04 pm

The idea is to "fasttrack" some specific machine without slowing it's traffic for processing. Let's say you have a network of users, you have firewall and queues for them. But then you have a VIP customer (or your own PC) that you will not filter or slow down, and you want the best available speed for it. This is the situation for fasttrack.
No answer to your question? How to write posts
 
User avatar
boen_robot
Forum Guru
Forum Guru
Posts: 2411
Joined: Thu Aug 31, 2006 4:43 pm
Location: europe://Bulgaria/Plovdiv

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:08 pm

Yeah, but even in those cases, you still want the best available speed... That would not completely block out the rest of the network, so even "VIP" customers need SOME restrictions imposed on them.

I think this feature will be most useful when the MikroTik router is used as a CPE device - in those cases, you don't want to impose any restrictions onto the device itself, but you want to impose them upstream, at your central router(s). So if both routers are MikroTik routers, you can use fastpath, and fasttrack to get the best inner-network performance, and still apply statistics and queues on the "edge" routers.
PEAR2_Net_RouterOS(1.0.0b6) - My API client in PHP
(Rate my posts? If you want... no pressure...)
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24066
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:10 pm

My home devices also don't need any filtering or queuing. The AP is only there for wireless access. Why not make the internet faster with a few rules?
No answer to your question? How to write posts
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:14 pm

Normis, that should be said before.
Boen_robot, agree with you.

We will see how it will be effective in real traffic situations. But I still would rather see some general improvements like I wrote before.
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:50 pm

KBV - Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1110
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 2:56 pm

Question - if I have no rules in forward chain - only in input chain (typical transit router) - will FastTrack be active?

IMO, if there are no rules in a default chain, that chain should automatically be FastTracked (so I dont have to add rules now to tons of transit routers to take advantage of FastTrack).
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 3:43 pm

It is not about filter rules, it is also about NAT. Basically it is fastpath solution when connection tracking is necessary.
You obviously need to process some packets normal way through the connection tracking to put all local/public IPs in order, so i do not think that automatic fasttrack is possible. Nut i think it should be in all board default config that also have NAT.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Nov 10, 2014 7:02 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 4:40 pm

It is not about filter rules, it is also about NAT. Basically it is fastpath solution when connection tracking is necessary
Connection tracking can operate without NAT, It is rather a function of the "Full State Firewall"
If the FS firewall and NAT is not necessary, tracking is better forcibly disable :)
 
User avatar
tron
just joined
Posts: 19
Joined: Thu Nov 01, 2012 9:20 am
Location: EU

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 7:29 pm

FastTrack
great improvement, thanks... just tested a bit :)
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 8:33 pm

Wow simply adding the filter to accept fasttrack and away it goes...

ip settings print
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 268210
ipv4-fasttrack-bytes: 307676029

I went 6.29rc13 due to the fix of the excessive sector-rewrites. I had a new router go from 1000 to over a million in its total sector-rewrite count due to 6.28 in yes 4 days uptime....
 
visalink
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Thu Oct 03, 2013 1:42 am

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 9:26 pm

ip settings prin
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0

:(
0 bytes
 
User avatar
tron
just joined
Posts: 19
Joined: Thu Nov 01, 2012 9:20 am
Location: EU

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 9:36 pm

visalink: How does/do your firewall rule/rules look like?

or

Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version.
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Nov 10, 2014 7:02 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 10:06 pm

KBV - Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version
Oh, no. I did not know that it only works on CCR
I tried to run on 850gx2
 
User avatar
tron
just joined
Posts: 19
Joined: Thu Nov 01, 2012 9:20 am
Location: EU

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 10:15 pm

I run it on RB2011UAS-2HnD and it works.
fasttrack-works.png
You do not have the required permissions to view the files attached to this post.
 
visalink
Frequent Visitor
Frequent Visitor
Posts: 69
Joined: Thu Oct 03, 2013 1:42 am

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 10:30 pm

visalink: How does/do your firewall rule/rules look like?

or

Did you use CCR device? FastTrack will work properly on CCR devices starting from 6.29rc14 version.
ip/firewall/filter
chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix=""
chain=forward action=accept connection-state=established,related log=no log-prefix=""

Only a test in RB750g, no result...
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Nov 10, 2014 7:02 pm

Re: FastTrack - New feature in 6.29

Tue Apr 28, 2015 10:33 pm

I feel there is some kind of trick :D
 
Ulypka
Frequent Visitor
Frequent Visitor
Posts: 51
Joined: Wed Jan 09, 2013 8:26 am

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 12:01 am

On rb333 don't work.
ip fi filter print stats
1 forward fasttrack-connection 282 362 923 317 144
2 input accept 6 086 144 43 102
ip settings pr
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
 
105547111
Member Candidate
Member Candidate
Posts: 131
Joined: Fri Jun 22, 2012 9:46 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 3:41 am

It won't work unless there is some NAT, Bridges involved in your traffic, plus 6.29B13 upwards, plus of course accepting the fast-track in the filter rules..

For example Ive got 4 more MTs downstream in my network, but its only the one using NAT that it works on as its masquerading.

Ive not put in a single mangle rule for this, I have mangle rules for other routing, but merely putting in the filter rule to accept fast-track and its gone nuts - this in a great way. Yes I have noticed a throughput increase and BIG CPU drop in high use.
 
kez
newbie
Posts: 39
Joined: Tue Jul 05, 2005 4:13 am

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 6:46 am

Tested on my old and good RB333, but it seens it is not working.
I have a PPPoE client connection, so a dynamic mangle rule to "change MSS" to 1452.
Does it matter?
And yes, the counters are running for all filter rules.
[admin@RB333] > ip fi fi pri
Flags: X - disabled, I - invalid, D - dynamic 
 0    chain=forward action=fasttrack-connection connection-state=established,related log=no log-prefix="" 
 1    chain=forward action=accept connection-state=established,related log=no log-prefix="" 
 2    chain=forward action=drop connection-state=invalid log=no log-prefix="" 
 [admin@NALTECSAT] > ip set pri  
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 0
ipv4-fasttrack-bytes: 0
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 8:20 am

It is not about filter rules, it is also about NAT. Basically it is fastpath solution when connection tracking is necessary
Connection tracking can operate without NAT, It is rather a function of the "Full State Firewall"
If the FS firewall and NAT is not necessary, tracking is better forcibly disable :)
i think you misunderstood me - RB75x, RB95x, RB2011, hAP, mAP, cAP - most common setups on these boards includes masquerade rule and some firewall filters. So with this FastTrack feature you "magically" make them much faster. So i expect that default configuration (from factory), will have it enabled by default.

I did some testing, on FastTrack, I have 500Mbps connection at the office, sitting on CCR1009, for a test purpose i replaced it with RB2011, and run some "linux distribution" torrent download this morning.

Without FastTrack - 220-240Mbps download with CPU 100%
With FastTrack - 460-500Mbps (full pipe) download with CPU 56-84%

As i need queues and IPsec i switched back to CCR1009, but this opens lots of possibilities..
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 8:49 am

Tested on my old and good RB333, but it seens it is not working.
I have a PPPoE client connection, so a dynamic mangle rule to "change MSS" to 1452.
Does it matter?
And yes, the counters are running for all filter rules.
This is just a theory..
1) FastTrack is a Conntrack extension of FastPath,
2) FastPath requires in and out interface support to work
3) pppoe-client doesn't have FastPath support

Result:
fasttrack doesn't work on pppoe-clients
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
CyberTod
Long time Member
Long time Member
Posts: 511
Joined: Wed Jan 25, 2012 10:23 am

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 8:53 am

These results sound very promising. But can only be used in some configurations. The typical home router can benefit a lot.
But for example I want to somehow use this on ptp wireless connections, because i have a mangle rule to set nv2 priority from dscp for QoS. And as this changes header of all packets I guess fasttrack is not possible in this scenario ?
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 9:03 am

These results sound very promising. But can only be used in some configurations. The typical home router can benefit a lot.
But for example I want to somehow use this on ptp wireless connections, because i have a mangle rule to set nv2 priority from dscp for QoS. And as this changes header of all packets I guess fasttrack is not possible in this scenario ?
I do not think it is possible, only changes made by ConnTrack is supported, in your case those are custom changes.

But it is a firewall action, so you can basically use it in any place where you have "accept everything else" logic just add "fasttrack everything else" rule before the accept.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
fposavec
newbie
Posts: 39
Joined: Thu Apr 21, 2011 12:59 pm
Location: Čakovec
Contact:

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 9:48 am

I tryed 6.29rc14 today, no joy :)
RB951G, cpu on 100%, routing take all cpu .
fast-track counting packages, but on ip settings no counter

I use VPLS/MPLS on this router
 
User avatar
strods
MikroTik Support
MikroTik Support
Topic Author
Posts: 1406
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 12:38 pm

At this moment FastTrack is not working on PowerPC devices, but with latest rc14 version it works on other platforms.
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 2:38 pm

These results sound very promising. But can only be used in some configurations. The typical home router can benefit a lot.
But for example I want to somehow use this on ptp wireless connections, because i have a mangle rule to set nv2 priority from dscp for QoS. And as this changes header of all packets I guess fasttrack is not possible in this scenario ?
I do not think it is possible, only changes made by ConnTrack is supported, in your case those are custom changes.

But it is a firewall action, so you can basically use it in any place where you have "accept everything else" logic just add "fasttrack everything else" rule before the accept.
Unfortunately I am dropping everything else, not accepting that...
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Wed Apr 29, 2015 2:43 pm

But at least established and related could be fasttracked, hopefully. Had not time to make own tests so far...
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 6:17 pm

playing with new feature with an rb411ar :)
had to enable wireless-fp to work?!?!
ip-forward: yes
send-redirects: yes
accept-source-route: no
accept-redirects: no
secure-redirects: yes
rp-filter: no
tcp-syncookies: no
max-arp-entries: 8192
arp-timeout: 30s
icmp-rate-limit: 10
icmp-rate-mask: 0x1818
allow-fast-path: yes
ipv4-fast-path-active: no
ipv4-fast-path-packets: 0
ipv4-fast-path-bytes: 0
ipv4-fasttrack-active: yes
ipv4-fasttrack-packets: 189561
ipv4-fasttrack-bytes: 14324143
 
InoX
Forum Guru
Forum Guru
Posts: 1962
Joined: Tue Jan 09, 2007 6:44 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 8:23 pm

Is working for me with these rules:
/ip firewall filter
add chain=forward action=fasttrack-connection connection-state=established,related
add chain=forward action=accept connection-state=established,related
add chain=forward action=drop connection-state=invalid
 
buckthis
just joined
Posts: 5
Joined: Wed Apr 29, 2015 9:01 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 9:12 pm

Any chance RCs could include the 'wireless-cm2' package?
At least for mipsbe...

Thanks
 
vortex
Forum Veteran
Forum Veteran
Posts: 712
Joined: Sat Feb 16, 2013 6:10 pm

Re: FastTrack - New feature in 6.29

Wed Apr 29, 2015 9:30 pm

It is the first time I want to upgrade RouterOS to get some feature.

I might not need to upgrade my RB2011 to take full advantage of my new pipe after all.
 
cheeze
Member Candidate
Member Candidate
Posts: 146
Joined: Tue Jul 31, 2012 7:44 am

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 12:38 am

Mikrotik, please PLEASE take your time. I don't think most of us care if you take 3 months. Take the time to perfect 6.29, or at least make it as good as possible.

Also, awesome :) :) :)
 
User avatar
Chupaka
Forum Guru
Forum Guru
Posts: 8292
Joined: Mon Jun 19, 2006 11:15 pm
Location: Minsk, Belarus
Contact:

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 1:07 am

Note, that all packets that goes fasttrack, will not be visible in firewall and you will not be able to limit them in queue global.
I wonder whether those packets will be accounted by Traffic Flow...
Russian-speaking forum: https://forum.mikrotik.by/. Welcome!

For every complex problem, there is a solution that is simple, neat, and wrong.

MikroTik. Your life. Your routing.
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1810
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 5:15 am

Note, that all packets that goes fasttrack, will not be visible in firewall and you will not be able to limit them in queue global.
I wonder whether those packets will be accounted by Traffic Flow...
That is a question I have too.

Mikrotik, can you shine a torch on this ? ;)
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
becs
MikroTik Support
MikroTik Support
Posts: 477
Joined: Thu Jul 07, 2011 8:26 am

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 8:07 am

In current implementation (6.29rc15) FastTracked (and FastPathed) packets will not be accounted in Traffic Flow.
But.. there are possibilities to extend FastPath/FastTrack feature set in the future.

At the moment, please, test basic FastTrack functionality, and report back if you encounter any issues.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24066
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 8:54 am

Any chance RCs could include the 'wireless-cm2' package?
At least for mipsbe...

Thanks
you can just guess the link:
http://www.mikrotik.com/download/share/ ... mipsbe.npk

the files are there
No answer to your question? How to write posts
 
ronniee
Member Candidate
Member Candidate
Posts: 121
Joined: Sun Jan 15, 2006 9:32 pm

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 11:59 am

If this is something like "NAT Accelerator" or I don't know how is called by other manufacture, it's a very good job.
congratulation Mikrotik, I hope will be released soooooon.
There are some cheap brands like tpl.nk etc, at half price and do +2x faster pppoe/NAT like a MikroTik.
 
jarda
Forum Guru
Forum Guru
Posts: 7601
Joined: Mon Oct 22, 2012 4:46 pm

Thu Apr 30, 2015 12:05 pm

Looking like this will not work with pppoe. At least for now.
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2278
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 2:20 pm

All supported all platforms, including mipsle?
LAN, FTTx, Wireless. ISP operator
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1717
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 3:55 pm

Looks like currently it is implemented only in MIPSBE, i was not able to get other architectures working.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 72
Joined: Mon Nov 10, 2014 7:02 pm

Re: FastTrack - New feature in 6.29

Thu Apr 30, 2015 7:06 pm

Yes, it seems so.
I also tried it on MIPSBE. There are small oddities, but generally works well :)
On my other platforms it has not yet happened.
 
peeter123
just joined
Posts: 5
Joined: Tue Jul 22, 2014 8:58 pm

Re: FastTrack - New feature in 6.29

Fri May 01, 2015 12:11 am

I tried it on RB2011UiAS-2HnD with a VLAN for internet on my WAN port, this is in a bridge called bridge-wan with another VLAN for IPTV(needs different VLAN MAC). Added the firewall rules but internet stops working unless torch is active on the VLAN port(which stops fasttrack I guess).

Maybe some need to investigate?
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: FastTrack - New feature in 6.29

Fri May 01, 2015 7:27 am

What about IPv6?

Is the rule with "action=accept" after the "action=fasttrack.." really required?

Who is online

Users browsing this forum: No registered users and 4 guests