Community discussions

MUM Europe 2020
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

v6.30.x bugfix release

Wed Jul 15, 2015 12:00 pm

We have published v6.30.1 bugfix only release. The only changes here are verified fixes, no new features have been added. Since the current v6.29 version does not yet have the branch support, 6.30.1 will be offered as the regular next upgrade. The "Branch" selector will become available in v6.31
What's new in 6.30.1 (2015-Jul-14 11:22):

*) quickset - fixed HomeAP mode;
*) lte - Fixes bug that causes Sierra Wireless modems with LTE interface to change interface name;
*) trafflow: fix in-interface reporting in flow;
*) ipsec - disallow changing dynamic peer;
*) quickset - crashes introduced in 6.30 fixed
*) fixed :execute file=
*) bonding: fix arp monitoring in active backup mode
To clarify how the new release system will work, we made an image
Screenshot 2015-07-15 11.58.18.png
A small addendum: the Bugfix only will only contain verified fixes, and no new features. The Current release contains the same fixes but also new features and other improvements, sometimes also less critical fixes than in Bugfix. And finally the Release Candidate is more likely to a nightly build. We will not to intensive testing before publishing these, only quick check if upgrade can be done and if most features work fine.
You do not have the required permissions to view the files attached to this post.
No answer to your question? How to write posts
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 12:14 pm

WARNING: "/tool user-manager user export" DO NOT EXPORT USERNAMEs
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 12:17 pm

WARNING: "/tool user-manager user export" DO NOT EXPORT USERNAMEs
Yes, curently not fixed, but known.
No answer to your question? How to write posts
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1722
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 12:34 pm

somebody wake me... it can't be really happening..

when will we get RC versions the same way? it will make my life so much more easier
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 12:38 pm

We have to make support for multiple independent Changelog files, then we will also release RC this way, and remove the RC section that is currently below the download boxes. It will go into the dropdown menu on the Download page and in your routers.
No answer to your question? How to write posts
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 1:41 pm

Awesome job on the new release system!

Thank you for doing it!
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
User avatar
omega-00
Forum Guru
Forum Guru
Posts: 1167
Joined: Sat Jun 06, 2009 4:54 am
Location: Australia
Contact:

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 1:45 pm

Awesome work guys, can't wait to give it a try :-)
brightwifi.com | mikrotik-routeros.com | MTCNA,MTCWE.MTCTCE | Give karma where due
 
User avatar
nz_monkey
Forum Guru
Forum Guru
Posts: 1825
Joined: Mon Jan 14, 2008 1:53 pm
Location: Straya
Contact:

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 1:47 pm

THANK YOU !!!

This is easy to understand, and will hopefully result in better RouterOS stability and lower load on Mikrotik support.
http://thebrotherswisp.com/ | Mikrotik MTCNA, MTCRE, MTCINE | Fortinet FTCNA, FCNSP, FCT | Extreme Networks ENA
 
User avatar
docmarius
Forum Guru
Forum Guru
Posts: 1220
Joined: Sat Nov 06, 2010 12:04 pm
Location: Timisoara, Romania
Contact:

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 4:06 pm

Great approach, way to go Mikrotik team!
Torturing CCR1009-7G-1C-1S+, RB450G, RB750GL, RB951G-2HnD, RB960PGS, RB260GSP, OmniTIK 5HnD and NetMetal 922UAGS-5HPacD + R11e-5HnD in my home network.
 
KBV
Frequent Visitor
Frequent Visitor
Posts: 78
Joined: Mon Nov 10, 2014 7:02 pm

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 4:08 pm

you are somewhere lost x86 "Extra packages" in 6.30(x) :)
link on the download page is not available, but the package can be downloaded if you enter a direct link
 
gius64
Member Candidate
Member Candidate
Posts: 204
Joined: Tue Jan 14, 2014 3:43 pm

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 4:15 pm

WARNING: "/tool user-manager user export" DO NOT EXPORT USERNAMEs
Yes, curently not fixed, but known.
Also print (and print via API) doesn't print username.

When will it be fixed? MikroTik support says 6.31, I hope it will be released soon. This is a critical bug for who use API with user-manager, so I expected it fixed in a short time.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 4:20 pm

WARNING: "/tool user-manager user export" DO NOT EXPORT USERNAMEs
Yes, curently not fixed, but known.
Also print (and print via API) doesn't print username.

When will it be fixed? MikroTik support says 6.31, I hope it will be released soon. This is a critical bug for who use API with user-manager, so I expected it fixed in a short time.
Both issues will be fixed in v6.31rc7
No answer to your question? How to write posts
 
ANZO
just joined
Posts: 1
Joined: Wed Jul 15, 2015 4:40 pm

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 4:44 pm

PPP connections dead after update =\
1. connecting
2. auth
3. terminated
without any detail log.

EDIT:
After update in all PPP connections Profile changed from "default" to "default-encryption".
I changed this back to "default", but router didn't share internet from PPP to internet (masq action exist).
Resetring all configs and reconfiguration fixed this issue.
Last edited by ANZO on Wed Jul 15, 2015 9:17 pm, edited 1 time in total.
 
arturrenato
just joined
Posts: 7
Joined: Fri Oct 29, 2010 3:44 am

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 7:02 pm

It's not working to use "0.0.0.0" (dynamic IP address) as the "S.A. Src. Address" on IPsec Police.
 
tvrebac
Trainer
Trainer
Posts: 8
Joined: Wed Feb 11, 2015 6:58 pm

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 10:15 pm

Please tell me what is changed with SSL certificates, since 6.30 when I import my ca.crt it is being recognised as plain certificate, not CA. In versions prior to 6.30 the same ca.crt file is recognised as CA.

Also, something is messed with "/tool fetch" which I use in dyndns updater script, I get an error "failure: closing connection: <400 Bad Request> 204.13.248.114:80".
The script works fine in 6.29.1 and earlier.

Here is the script:
# DynDNS update script
# using http://checkip.dyndns.com/index.html
# response should be:
#	<html><head><title>Current IP Check</title></head><body>Current IP Address: aaa.bbb.ccc.ddd</body></html>
:local mDebugging "true";
:local mCheckIPURL "http://checkip.dyndns.com/index.html";
:local mFileName "dyndns.checkip.html";
:local mUsername "test";
:local mPassword "test";
:local mHostname "test.dyndns.org";
:local mDynDNSURL "members.dyndns.com";
:local mStartStr ": ";
:local mEndStr "</body>";

#:global mForceUpdate;
:global mPreviousIP;

# log some data, disable this while not debugging
:if ($mDebugging = true) do={
    :log info ("UpdateDynDNS: username = $mUsername");
    :log info ("UpdateDynDNS: password = $mPassword");
    :log info ("UpdateDynDNS: hostname = $mHostname");
}

# get the current IP address
/tool fetch mode=http url="$mCheckIPURL" dst-path="$mFileName";
:delay 1;
:local mCheckIPResponse [ /file get "$mFileName" contents ];
/file remove "$mFileName";

# parse HTTP response
:local mIPStart [ :find "$mCheckIPResponse" "$mStartStr" -1 ];
:set mIPStart ($mIPStart+2);
:local mIPEnd [ :find "$mCheckIPResponse" "$mEndStr" -1 ];
:local mCurrentIP [ :pick "$mCheckIPResponse" "$mIPStart" "$mIPEnd" ];

# log some data, disable this while not debugging
:if ($mDebugging = true) do={
    :log info ("UpdateDynDNS: mCheckIPResponse = $mCheckIPResponse");
    :log info ("UpdateDynDNS: mIPStart = $mIPStart");
    :log info ("UpdateDynDNS: mIPEnd = $mIPEnd");
    :log info ("UpdateDynDNS: mCurrentIP = $mCurrentIP");
}
:if ($mPreviousIP != $mCurrentIP) do={
    :local mUpdateURL "/nic/update\?hostname=$mHostname&myip=$mCurrentIP&wildcard=NOCHG&mx=NOCHG&backmx=NOCHG";
    :local mFileName ("dyndns.".$mHostname);
    /tool fetch address="$mDynDNSURL" src-path="$mUpdateURL" mode=http user="$mUsername" password="$mPassword" dst-path="$mFileName";
    :delay 1;
    :local mTmp [ /file get "$mFileName" contents ];
    :if ($mDebugging = true) do={
        :log info ("UpdateDynDNS: mUpdateURL = $mUpdateURL");
        :log info ("UpdateDynDNS: mFileName = $mFileName");
        :log info ("UpdateDynDNS: mDynDNSURL $mDynDNSURL");
        :log info ("UpdateDynDNS: mTmp=$mTmp");
    }
    /file remove "$mFileName";
    :set $mPreviousIP $mCurrentIP
}
 
User avatar
honzam
Forum Guru
Forum Guru
Posts: 2297
Joined: Wed Feb 27, 2008 10:27 pm
Location: Czech Republic

Re: v6.30.1 bugfix release

Wed Jul 15, 2015 10:56 pm

Awesome job on the new release system!

Thank you for doing it!
Yes, this is the best change in recent years!
Thanks
LAN, FTTx, Wireless. ISP operator
 
shifto
just joined
Posts: 13
Joined: Wed Jul 15, 2015 1:58 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:08 am

Really like this change!
 
dadoremix
Member Candidate
Member Candidate
Posts: 119
Joined: Sat May 14, 2011 11:31 am

v6.30.1 bugfix release

Thu Jul 16, 2015 1:41 am

+1 for dyndns script, 6.29.1!working and 6.30 broken
 
User avatar
ufm
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:38 am

Hi!

net flow still broken (see Ticket#2015071166000057)

WBR,
Fyodor.
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 3:34 am

We have to make support for multiple independent Changelog files, then we will also release RC this way, and remove the RC section that is currently below the download boxes. It will go into the dropdown menu on the Download page and in your routers.
I see that in the dropdown menu, there are the following versions:

Bugfix: V6.30.1
Current: V6.30
Legacy: V5.26


If V6.30.1 is exactly as the V6.30 with bugfixes and no new features, what's the point for listing v6.30?

It is useless to download a version of the software that does the same things but includes old bugs. Am I missing something?
 
Hyperus
just joined
Posts: 2
Joined: Thu Jul 16, 2015 3:55 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:03 am

Hi, I upgraded to 6.30.1 last night from 6.29.1 and also in turn to bootrom firmware 3.24 from 3.22.
I always install upgrade + new ntpd and thenupgrade bootrom firmware in a second reboot.

6.30.1 broke my VoIP to my second PABX server.

Running Bria 3.xx on latest OSX connecting to 2 different SIP servers via Mikrotik UDP/1701 L2TP VPN's
Server 1 : 10.1.100.253 (via VPN1)
Server 2 : 192.168.14.76 (via VPN2)

Server 1 login ok, Server 2 would not connect - SIP error 408.
The second server does also have a public IP which is for external handsets in other countries (ACL'ed of course).
Tried Server 2 connection via its public ip - also failed with SIP error 408
Rebooted OSX
Same errors still.

I need these both for my business so did not stop to take packet captures.
I reverted to 6.29.1 and ntdp 6.29.1 as I needed access urgently
All SIP issues resolved after reverting to 6.29.1
I would note firmware is still 3.24 offering upgraded firmware of 3.22

Thoughts anyone ?
Concurrent ALG issue ?

Hyp
 
pants6000
Frequent Visitor
Frequent Visitor
Posts: 67
Joined: Fri Sep 26, 2014 5:30 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:42 am

Does "bug fixes" include security issues? If so, how long will a given release be supported?
 
User avatar
dimi
just joined
Posts: 9
Joined: Thu Feb 05, 2015 1:32 am
Location: Ukraine

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:43 am

ISSUE with WiFi hide password checkbox.

Quickset section:
WiFi Password - Hide >> CHECKBOX issue. When checkbox is checked and settings are applied, after the next enter to winbox it's already unchecked.

Devices: 2011UAS-2HnD, Groove A-52HPn, RB951G-2HnD
Firmware: 3.24
RouterOS: 6.30

Please fix that issue in the new ROS release.

Thamks.
 
barkas
Member Candidate
Member Candidate
Posts: 260
Joined: Sun Sep 25, 2011 10:51 pm

v6.30.1 bugfix release

Thu Jul 16, 2015 8:47 am

Still kills my rb450g, last working os is 6.29.1.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 9:24 am

We have to make support for multiple independent Changelog files, then we will also release RC this way, and remove the RC section that is currently below the download boxes. It will go into the dropdown menu on the Download page and in your routers.
I see that in the dropdown menu, there are the following versions:

Bugfix: V6.30.1
Current: V6.30
Legacy: V5.26


If V6.30.1 is exactly as the V6.30 with bugfixes and no new features, what's the point for listing v6.30?

It is useless to download a version of the software that does the same things but includes old bugs. Am I missing something?
When we release v6.31, it will take this place. Currently we included 6.30 for those, who don't want to risk any other version and need some packages for their current install
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 9:30 am

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 9:30 am

Still kills my rb450g, last working os is 6.29.1.
Please describe "kills"
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 9:32 am

Does "bug fixes" include security issues? If so, how long will a given release be supported?
Initially we plan to maintain X.YY.Z for 4-6 weeks, then it will be replaced by X.YZ.Z and X.YY.Z will not be updated anymore.

Otherwise, in two years we would have to backport a security fix to 24 different versions.
No answer to your question? How to write posts
 
User avatar
eworm
Member
Member
Posts: 419
Joined: Wed Oct 22, 2014 9:23 am
Location: Oberhausen, Germany
Contact:

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 11:09 am

Does "bug fixes" include security issues? If so, how long will a given release be supported?
Initially we plan to maintain X.YY.Z for 4-6 weeks, then it will be replaced by X.YZ.Z and X.YY.Z will not be updated anymore.

Otherwise, in two years we would have to backport a security fix to 24 different versions.
You could think about picking LTS versions. Make 6.30 an LTS release and support it for two years. 6.31.x will receive updates for some weeks only, same for 6.32.x, ...
Any time in future you would pick a new LTS version and support that for two years.
Manage RouterOS scripts and extend your devices' functionality: RouterOS Scripts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 11:15 am

We will see how this new plan goes, and will think about LTS in future. Thanks for the suggestion.
No answer to your question? How to write posts
 
florentrivoire
newbie
Posts: 44
Joined: Wed Feb 25, 2015 12:02 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 12:14 pm

We will see how this new plan goes, and will think about LTS in future. Thanks for the suggestion.
I've been following the new "feature" for "release branchs", and even if I think the new plan is better than the current situation, I do believe that LTS versions would be a much better idea (without too much work or complexity) !
Because, with the process that you have described now, each version will only be "supported" for 1 or 2 months, which is very short !

So I'd prefer to have some LTS versions (for example starting with 6.31) that will receive bugfix+security updates for something like 1 year. During that time, you release "standard" versions (6.32, 6.33, 6.34, 6.35). And those standard versions will only be supported until next version (a few weeks later) and that will be forgotten as that.

Example (in chronological order) :
  1. 6.31 is out, it's a LTS version, it will be supported until next LTS version is released (~ 1 year later).
  2. Then 6.31.1 (bugfix LTS) is released
  3. Then 6.31.2 (bugfix LTS) is released
  4. A few weeks later, 6.32 (standard version) is out
  5. Then 6.32.1 (bugfix std) is released
  6. Then 6.32.2 (bugfix std) is released
  7. A few weeks later, 6.33 (standard version) is out ==> 6.32 (previous standard) is forgotten
  8. Then 6.33.1 (bugfix std) is released
  9. Then 6.31.3 (bugfix LTS) is released
  10. A few weeks later, 6.34 (standard version) is out ==> 6.33 (previous standard) is forgotten
  11. Then 6.31.4 (bugfix LTS) is released
  12. Then 6.34.1 (bugfix std) is released
  13. Then 6.31.5 (bugfix LTS) is released
  14. A few weeks later, 6.35 (standard version) is out ==> 6.34 (previous standard) is forgotten
  15. Then 6.31.6 (bugfix LTS) is released
  16. Then 6.35.1 (bugfix std) is released
  17. A few weeks later, 6.36 (LTS version) is out ==> 6.31 (previous LTS) and 6.35 (previous standard) are forgotten
  18. Then 6.36.1 (bugfix LTS) is released
  19. ...
And at any given time, only 2 versions needs to be supported :
[*] the latest LTS version
[*] the latest standard version
So, no need to backport every fix to many versions ==> so probably doable for Mikrotik without major dev ressources.

And users need to choose between :
[*] LTS : missing some really-new features, but got continuous bugfix for 1 year WITHOUT MAJOR CHANGES ==> focus on stability
[*] Standard : all new features, but no update after a few weeks without upgrading to next release (which will include new features, so potential breaking configs) ==> focus on new features
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 12:35 pm

Good description, florentrivoire. Thanks. I had already understood what you all request, we simply need to take one step at a time. When the current new "metro" plan (as in the original image) is stremalined and working, we will consider expanding it like you describe.
No answer to your question? How to write posts
 
florentrivoire
newbie
Posts: 44
Joined: Wed Feb 25, 2015 12:02 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 12:39 pm

OK, keep working :D
We are going to the right direction !
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1722
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 12:43 pm

I was expecting proposal like that :) Lets not jump too far ahead, to implement version policy like that you need system in place in development process. Current change is already a huge step forwards, and i can imagine MT is still adjusting and will continue to adjust for this system for some time until it is perfected.

also you need to note that differentiation in releases comes at the cost of new feature development speed - you need to test much more with different releases etc. And we all love new features and the speed they are implemented.
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:06 pm

You must not forget the previous standard version the moment a new current version is released. That is the whole point of the bugfix stream, not trusting new current versions.
 
florentrivoire
newbie
Posts: 44
Joined: Wed Feb 25, 2015 12:02 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:09 pm

You must not forget the previous standard version the moment a new current version is released. That is the whole point of the bugfix stream, not trusting new current versions.
If you're responding to me and my message of this morning : remember that the philosophy "dont trust new version, want bugfix" match the LTS versions that I described, and not the versions that I called "standard".
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:16 pm

Bugfix stream should be available for a reasonable time for all versions, not only LTS.

And an upgrade should not take you automatically to the latest version in the stream, it should be possible to upgrade along the stream one step at a time.

Of course, versions with massive problems should be forgotten.
 
florentrivoire
newbie
Posts: 44
Joined: Wed Feb 25, 2015 12:02 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:23 pm

Bugfix stream should be available for a reasonable time for all versions, not only LTS.
I don't think this is reasonable, because of the work this would require for Mikrotik team (you're requesting them to maintain : 1 LTS + several "standard" versions).
 
Zwodka
Frequent Visitor
Frequent Visitor
Posts: 74
Joined: Fri Sep 19, 2014 9:41 pm
Location: Hungary

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:33 pm

+1 for florentrivoire LTS plant
 
User avatar
paoloaga
Member Candidate
Member Candidate
Posts: 222
Joined: Tue Mar 08, 2011 2:52 am
Location: Vaprio d'Agogna (NO) - Italy
Contact:

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:37 pm

Bugfix stream should be available for a reasonable time for all versions, not only LTS.
I don't think this is reasonable, because of the work this would require for Mikrotik team (you're requesting them to maintain : 1 LTS + several "standard" versions).
I think that LTS should be granted maintenance for a known length of time. For example:

6.30 is picked to be LTS, it should be maintained for at least X months (suppose 24). A year later, 6.50 is picked as LTS. For the next year both 6.30 and 6.50 will be maintained, after which 6.30 may be not maintained anymore.

if you maintain only one LTS release each time, you are pushing a forced/unplanned update.
 
Hyperus
just joined
Posts: 2
Joined: Thu Jul 16, 2015 3:55 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 1:53 pm

Maintaining LTS = Price goes up.... -1 from me for LTS

Hyp
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:15 pm

Please, put back "all architecture" single zip file download link on the download page. Thank you.
 
User avatar
ufm
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:17 pm

\
I've been following the new "feature" for "release branchs", and even if I think the new plan is better than the current situation, I do believe that LTS versions would be a much better idea (without too much work or complexity) !
Because, with the process that you have described now, each version will only be "supported" for 1 or 2 months, which is very short !
Semi mythical 7.0 - break this chain.
 
User avatar
mandrade
Member Candidate
Member Candidate
Posts: 106
Joined: Fri Sep 08, 2006 12:35 pm
Location: Brazil
Contact:

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:21 pm

 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:51 pm

Bugfix stream should be available for a reasonable time for all versions, not only LTS.
I don't think this is reasonable, because of the work this would require for Mikrotik team (you're requesting them to maintain : 1 LTS + several "standard" versions).
I did not say that they should maintain a bug fix stream for a long time after new current versions have been released, but that it should be selectable for download.

So, for example:

Release timeline:

6.31
6.31.1
6.31.2
6.32
6.31.3
6.32.1
6.33
<6.31 work stops but still selectable for install>
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 2:53 pm

Notice the Brown "Archive" in the image on the top.
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 3:11 pm

Actually, I did not know what Archive meant in the diagram.
 
dadoremix
Member Candidate
Member Candidate
Posts: 119
Joined: Sat May 14, 2011 11:31 am

v6.30.1 bugfix release

Thu Jul 16, 2015 3:16 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Yes yes script is broken
The same script isnworking from 3.x version till 6.29.1
Now in 6.30 broken, maybe you can fix it? Im not at that level expert for scripting, or mikrotik company can make addon for dyndns update? Every modem, router have it.
So i stuck on 6.29.1 version right now
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 3:24 pm

There's another obvious clarification about the diagram:

Given the timeline I wrote above, you would get just that if you are on Current, but if you are on Bugfix and 6.31*, your updates stop at 6.31.3

I haven't see the RC but then there should be a button for "Upgrade to next minor version" to jump to 6.32 then.

And when 7.0 releases and you are at the end of 6.x, "upgrade to next minor" should not take you to 7.x, there should be an explicit "Upgrade to next major version" button.

What about if you are on Current, but don't want to upgrade to the next major by mistake? I think Current should stick to the current major version, and you should use the latter button to jump.

These buttons need a good confirmation screen.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 3:25 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Yes yes script is broken
The same script isnworking from 3.x version till 6.29.1
Now in 6.30 broken, maybe you can fix it? Im not at that level expert for scripting, or mikrotik company can make addon for dyndns update? Every modem, router have it.
So i stuck on 6.29.1 version right now
Maybe you can check what is not working in your script and correct it. I am using dnsexit and not dyndns, but my script works fine in 6.30...
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 3:32 pm

There's another obvious clarification about the diagram:

Given the timeline I wrote above, you would get just that if you are on Current, but if you are on Bugfix and 6.31*, your updates stop at 6.31.3

I haven't see the RC but then there should be a button for "Upgrade to next minor version" to jump to 6.32 then.

And when 7.0 releases and you are at the end of 6.x, "upgrade to next minor" should not take you to 7.x, there should be an explicit "Upgrade to next major version" button.

What about if you are on Current, but don't want to upgrade to the next major by mistake? I think Current should stick to the current major version, and you should use the latter button to jump.

These buttons need a good confirmation screen.
I think the UX needs to be studied carefully:

"Upgrade to next major" would take you to the first available release from the next major if you're on Bugfix, but to the latest release of the next major if you're on Current. There's potential for people to make mistakes.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:00 pm

If you are on bugfix v6.30.3, then you will have no more updates until we release v6.31.1
No answer to your question? How to write posts
 
2400baud
newbie
Posts: 28
Joined: Tue Nov 15, 2011 1:04 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:11 pm

I upgrade an RB751U from 6.30 to 6.30.1 and it no longer acts as an NTP server.

Were there changes in the 6.30.1 NTP server package that might not show up in the changelog since it's optional??
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:25 pm

If you are on bugfix v6.30.3, then you will have no more updates until we release v6.31.1
That makes no sense. It is similar to moving you from 6.30.3 to 6.31.0

This is the first thing I noticed where the graph seemed misleading, but as it makes no sense I assumed it was just a drawing issue.
 
apathy
just joined
Posts: 6
Joined: Tue Apr 15, 2014 12:16 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:28 pm

What about Changelog 6.31rc6 on site?
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:43 pm

If you are on bugfix v6.30.3, then you will have no more updates until we release v6.31.1
That makes no sense. It is similar to moving you from 6.30.3 to 6.31.0

This is the first thing I noticed where the graph seemed misleading, but as it makes no sense I assumed it was just a drawing issue.
And again we come to the issue of when you decide to upgrade minor version how do you choose which patch level.

Not only there's the .0 and the last patch level, but you may also want to move to the patch level that fixes all the bugs that were fixed in your current minor patch level.

You may want to move to an earlier patch level because those fixes are not important to you, while one of the patches introduced new bugs that you do care about.
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 4:54 pm

And you need to think how you will push emergency security fixes to everybody (which may imply minor and major version jumps).
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 5:02 pm

You are complicating things too much. Bugfix and Current both contains same fixes. You can then choose which one you want, newest bugfix or newest feature (current).

If you are waaay behind on your updates (which we have never suggested to do), you will get new features either way, but Bugfix is still a safe upgrade, because it is much more polished (especially if it is .3 not .1)
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 5:09 pm

I understand 6.29.1 was still pretty broken for some people, for example.
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 5:30 pm

When I click Check for Updates on 6.30 RB2011 it tells me that the system is up to date.
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 5:34 pm

The same for me. But anyway, even I am modifying the download links as I can, I am not able to hit the 6.30.1 all files / all architecture complete zip file.
 
TheRealJLH
just joined
Posts: 13
Joined: Wed Feb 20, 2013 2:23 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 5:59 pm

interface TX traffic in Torch is still not visible. on the CRS platform at least.
 
2400baud
newbie
Posts: 28
Joined: Tue Nov 15, 2011 1:04 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 6:39 pm

I upgrade an RB751U from 6.30 to 6.30.1 and it no longer acts as an NTP server.

Were there changes in the 6.30.1 NTP server package that might not show up in the changelog since it's optional??
Perhaps it's an install issue?? I went from 6.30 to 6.30.1 by:

/system packages update

Every package appeared to go to 6.30.1. I had "/system ntp server", "NTP Server" option in WinBox, etc. I had it enabled. Yet it wasn't behaving as an NTP server. You could turn it off and off and it wouldn't make a difference.

So, I grabbed the 6.30.1 "all packages" zip, copied the ntp package over manually, rebooted, and now it works.
 
solaoxo
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Sun Oct 20, 2013 8:38 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 8:03 pm

'execute' in not running scheduler.
The problem is still in 6.30.1 did not even repair.
 
barkas
Member Candidate
Member Candidate
Posts: 260
Joined: Sun Sep 25, 2011 10:51 pm

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 9:23 pm

Still kills my rb450g, last working os is 6.29.1.
Please describe "kills"
All ports stay down. I sent a mail to Mikrotik support, no answer yet.
 
mediana
just joined
Posts: 10
Joined: Tue Feb 04, 2014 9:03 am

Re: v6.30.1 bugfix release

Thu Jul 16, 2015 10:33 pm

It's not working to use "0.0.0.0" (dynamic IP address) as the "S.A. Src. Address" on IPsec Police.
+1, since v6.30.
v6.30.IPsec.Problem.png
You do not have the required permissions to view the files attached to this post.
 
ffernandes
Member Candidate
Member Candidate
Posts: 146
Joined: Mon Jun 23, 2008 11:20 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 1:55 am


is it just me or torrent stopped at 93.4%?
 
jebz
Member Candidate
Member Candidate
Posts: 240
Joined: Sun May 01, 2011 12:03 pm
Location: Australia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 2:48 am


is it just me or torrent stopped at 93.4%?
Stopped at the same point for me too.
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 3:15 am

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Yes yes script is broken
The same script isnworking from 3.x version till 6.29.1
Now in 6.30 broken, maybe you can fix it? Im not at that level expert for scripting, or mikrotik company can make addon for dyndns update? Every modem, router have it.
So i stuck on 6.29.1 version right now
Jarda:
Maybe you can check what is not working in your script and correct it. I am using dnsexit and not dyndns, but my script works fine in 6.30...[/quote]


And if you are not very comfortable with scripting yourself, you could also have a look at Mikrotiks built in DDNS service that you find in RouterOS menu: IP - Cloud.
Maybe it will serve your needs without the hassle of having to run a script?!

Just a suggestion! :)
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 3:28 am

I understand 6.29.1 was still pretty broken for some people, for example.

6.29.1 wasnt a part of this new way of releasing ROS Versions (Althou my guess is thats where the idea for the new release-system emerged to Mikrotik devs! ;) ).

If you look at the thread where Mikrotik asked community for input on the idea of new release system, you see it starts with 6.30 and 6.30.1 version! It shows they are listening to the community!

I personally think this new system is a MAJOR IMPROVEMENT! And I sure see the reasoning behind the idea aired here in forum on LTS versions, but I think we should give Mikrotik and ourselves a little bit of time now to get used to the new system and see how it works! And then as they have said, maybe they could implement such LTS versions on a later stage!

Keep up the good work Mikrotik! :)
 
dadoremix
Member Candidate
Member Candidate
Posts: 119
Joined: Sat May 14, 2011 11:31 am

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 8:49 am

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Jarda:
Maybe you can check what is not working in your script and correct it. I am using dnsexit and not dyndns, but my script works fine in 6.30...

And if you are not very comfortable with scripting yourself, you could also have a look at Mikrotiks built in DDNS service that you find in RouterOS menu: IP - Cloud.
Maybe it will serve your needs without the hassle of having to run a script?!

Just a suggestion! :)[/quote]

did you check ip - Cloud, yes mikotik have some dyndns, but own name, i have payed my dyndns acc and my own name, but i cant there anything change, its fixed. (all modems, routers have standard support for dyndns, only mikrotik not )

here is script that working in 6.29.1 and lower till 2.9.x.x, all other version 6.30+ not working
# Set needed variables
:local username dadoremix2
:local password xxxxx
:local hostname dyyyy.dyndns.tv

:global dyndnsForce
:global previousIP 

# print some debug info
:log info ("UpdateDynDNS: username = $username")
:log info ("UpdateDynDNS: password = $password")
:log info ("UpdateDynDNS: hostname = $hostname")
:log info ("UpdateDynDNS: previousIP = $previousIP")

# get the current IP address from the internet (in case of double-nat)
/tool fetch mode=http address="checkip.dyndns.org" src-path="/" dst-path="/dyndns.checkip.html"
:delay 1
:local result [/file get dyndns.checkip.html contents]

# parse the current IP result
:local resultLen [:len $result]
:local startLoc [:find $result ": " -1]
:set startLoc ($startLoc + 2)
:local endLoc [:find $result "</body>" -1]
:local currentIP [:pick $result $startLoc $endLoc]
:log info "UpdateDynDNS: currentIP = $currentIP"

# Remove the # on next line to force an update every single time - useful for debugging,
# but you could end up getting blacklisted by DynDNS!

#:set dyndnsForce true

# Determine if dyndns update is needed
# more dyndns updater request details http://www.dyndns.com/developers/specs/syntax.html

:if (($currentIP != $previousIP) || ($dyndnsForce = true)) do={
   :set dyndnsForce false
   :set previousIP $currentIP
   :log info "$currentIP or $previousIP"
   /tool fetch user=$username password=$password mode=http address="members.dyndns.org" \
      src-path="nic/update?system=dyndns&hostname=$hostname&myip=$currentIP&wildcard=no" \
      dst-path="/dyndns.txt"
   :delay 1
   :local result [/file get dyndns.txt contents]
   :log info ("UpdateDynDNS: Dyndns update needed")
   :log info ("UpdateDynDNS: Dyndns Update Result: ".$result)
   :put ("Dyndns Update Result: ".$result)
} else={
   :log info ("UpdateDynDNS: No dyndns update needed")
}
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 9:20 am

I understand 6.29.1 was still pretty broken for some people, for example.

6.29.1 wasnt a part of this new way of releasing ROS Versions (Althou my guess is thats where the idea for the new release-system emerged to Mikrotik devs! ;) ).

If you look at the thread where Mikrotik asked community for input on the idea of new release system, you see it starts with 6.30 and 6.30.1 version! It shows they are listening to the community!

I personally think this new system is a MAJOR IMPROVEMENT! And I sure see the reasoning behind the idea aired here in forum on LTS versions, but I think we should give Mikrotik and ourselves a little bit of time now to get used to the new system and see how it works! And then as they have said, maybe they could implement such LTS versions on a later stage!

Keep up the good work Mikrotik! :)
6.29.1 was a bugfix release. I think it happened after I asked for release streams in another thread.
 
ShiAiLang
just joined
Posts: 2
Joined: Fri Jul 17, 2015 9:17 am

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 9:25 am

Hi, does this update fix a problem with DHCP? After upgrading to 6.30 I have strange issue - DHCP-server stops working after reboot. The only fix that I found is to delete old server and create new one, exactly the same
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 9:31 am

I understand 6.29.1 was still pretty broken for some people, for example.
6.29.1 doesn't mean "all bugs fixed". Some issues are discovered only later.
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 9:43 am

I understand 6.29.1 was still pretty broken for some people, for example.
6.29.1 doesn't mean "all bugs fixed". Some issues are discovered only later.
That is the point. You should not push the bugs introduced in 6.29 to the people on the 6.28 bugfix stream.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 10:15 am

I don't understand you, sorry. I don't believe you understand me either. Carefully examine the picture in the first post. And remember that it applies only to v6.30 and newer.
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 10:32 am

You said you would present 6.31.1 as the next bugfix upgrade to someone on 6.30.3, and I say this is wrong because it does not guarantee that all the bugs introduced in 6.31.0 are fixed.

Going up the minor version is a feature upgrade, even to a bugfix release.
 
slvnet
just joined
Posts: 13
Joined: Wed Feb 12, 2014 4:23 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 10:49 am

@normis

First of all, it's perfect regarding new way of software relase. Really good. I was plan do write on the forum to ask You to think about it. It's done, so perfect, I'm really happy. This first.
Sec:
I love MT solutions. But, regarding software relases, You could look at Debian team, pls. They made this kind of realases long long loong time ago, so they remove all bugs in procedure of relases. If You could, don't reinvent the whell :) They have LTS too.

So. I keep cross fingers, really big step in stable solutions form Mikrotik. Look at proven solutions like Debian have. They practise it loooong years

All the best
Sylwester
 
onnoossendrijver
Member
Member
Posts: 418
Joined: Mon Jul 14, 2008 11:10 am
Location: The Netherlands

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 11:38 am

You said you would present 6.31.1 as the next bugfix upgrade to someone on 6.30.3, and I say this is wrong because it does not guarantee that all the bugs introduced in 6.31.0 are fixed.

Going up the minor version is a feature upgrade, even to a bugfix release.
They will not endlessly provide bugfix releases. At one point you have to make a bump to a newer major or minor release.
Linux/network engineer: ITIL, LPI1, CCNA R+S, CCNP R+S, JNCIA, JNCIS-SEC
 
gytisb
just joined
Posts: 6
Joined: Wed Jun 03, 2009 2:02 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 11:40 am

in a first place thank you for a really good solution :) but I can not find "Extra packages" in x86.
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 11:51 am

You said you would present 6.31.1 as the next bugfix upgrade to someone on 6.30.3, and I say this is wrong because it does not guarantee that all the bugs introduced in 6.31.0 are fixed.

Going up the minor version is a feature upgrade, even to a bugfix release.
They will not endlessly provide bugfix releases. At one point you have to make a bump to a newer major or minor release.
Yes, and this should be done explicitly by "upgrade to next feature" or "upgrade to next major", not be camouflaged in "upgrade to next" when in Bugfix.

When in Current, one should explicitly request "upgrade to next major", not be camouflaged in "upgrade to next".
 
Beone
Member Candidate
Member Candidate
Posts: 243
Joined: Fri Feb 11, 2011 1:11 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 12:07 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
+1 here; /tool fetch has changed something as it works perfectly on =< 6.29.1 but not anymore in 6.30
 
TomosRider
Member Candidate
Member Candidate
Posts: 202
Joined: Thu Nov 20, 2014 1:51 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 12:20 pm

Nice work guys!
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 12:26 pm

You said you would present 6.31.1 as the next bugfix upgrade to someone on 6.30.3, and I say this is wrong because it does not guarantee that all the bugs introduced in 6.31.0 are fixed.

Going up the minor version is a feature upgrade, even to a bugfix release.
All you have to do, it wait until v6.31.7 or whatever you think is best for you. Upgrades are not forced.
No answer to your question? How to write posts
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Fri Jul 17, 2015 12:28 pm

To everyone who cannot read fetched files immediately after it is saved to disk by scripts: add 2 seconds delay after each fetch command to ensure the file was correctly saved before you try to read it.
 
thegreatone
newbie
Posts: 25
Joined: Fri Jan 18, 2013 11:19 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 12:43 pm

Question for Mikrotik team,

I am really interested how is your development process going. Basically, in every new release you break up something that was working fine, i really can't understand how this can be happen? Do you make some typo errors or multiple developers are working on the same thing with not synchronized system? This is never ending problem that need to be fixed.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 12:45 pm

Basically, in every new release you break up something
really? has this happened to you, or you read the forums? because this is not true.
sometimes old issue gets discovered by specific config situation, sometimes a new feature is added that affects another.
No answer to your question? How to write posts
 
thegreatone
newbie
Posts: 25
Joined: Fri Jan 18, 2013 11:19 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 1:25 pm

Basically, in every new release you break up something
really? has this happened to you, or you read the forums? because this is not true.
sometimes old issue gets discovered by specific config situation, sometimes a new feature is added that affects another.
This happened to me and I am very carefully with updating the routers because I was in troubles few times just because something went wrong with the update and had to go 100+ km to flash the router. I am not updating my routers with the every new release because the uptime for my clients is very important so I do this when I see a release that is less buggy.

And yes, I am reading the forums and changelogs. I know that most of the bugfixes are specific config related but I see basic features broken in the changelogs or reported by users and confirmed by you.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 1:27 pm

I'm sorry that this happened, but Once is not always.
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 1:39 pm

You said you would present 6.31.1 as the next bugfix upgrade to someone on 6.30.3, and I say this is wrong because it does not guarantee that all the bugs introduced in 6.31.0 are fixed.

Going up the minor version is a feature upgrade, even to a bugfix release.
All you have to do, it wait until v6.31.7 or whatever you think is best for you. Upgrades are not forced.
I know they are not forced. But someone might make a feature upgrade by mistake if you mix up stuff like that.
 
patrick7
Member Candidate
Member Candidate
Posts: 298
Joined: Sat Jul 20, 2013 2:40 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 1:56 pm

I use several routers of MikroTik (one is about 418km from my home, in another country). I never had problems upgrading MikroTik devices.
 
UMarcus
Frequent Visitor
Frequent Visitor
Posts: 91
Joined: Wed Jan 21, 2015 10:11 am
Location: Europe

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 2:17 pm

About release strategy:

From my point of view short term support are no great advantage in face of effort for mikrotik to handle it.

Maybe another practicable path is :
Define a feature milestone package, if all features implemented than make a feature freeze of this release and provide LTS. Than go on with next feature milestone package.

regards
Marcus
 
solaoxo
Frequent Visitor
Frequent Visitor
Posts: 94
Joined: Sun Oct 20, 2013 8:38 pm

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 3:57 pm

'execute' in not running scheduler.
The problem is still in 6.30.1 did not even repair.
 
padrecc
just joined
Posts: 8
Joined: Mon Jan 14, 2013 2:07 am

Re: v6.30.1 bugfix release

Fri Jul 17, 2015 10:55 pm

Something wrong with PPP for Android clients:
connecting >>> authenticated >>> terminated

I tried PPTP and L2TP/IPSEC and behavior is the same. Windows/Linux clients work flawlessly.
 
User avatar
Cha0s
Forum Veteran
Forum Veteran
Posts: 913
Joined: Tue Oct 11, 2005 4:53 pm

Re: v6.30.1 bugfix release

Sat Jul 18, 2015 4:34 pm

Upgrading 2 SXT 5HPnD from 6.16 to 6.30.1 causes 100% CPU from process IPSec.
While IPSec is not used AT ALL on those boards.

After disabling/enabling security package and doing a few downgrades/upgrades it finally worked ok on one of the boards, while the other refuses to work ok with security package enabled.

But that was short lived. After about 10 minutes the board that seemed ok just hit 100% cpu usage again. So disabling the security package seems the only way to avoid 100% cpu usage.

Downgrading to 6.29.1 does not solve the issue. Exact same behavior persists.

So at this point I either have to use a way older version or not use the security package (which is stupid, who wants to login to a router using the equivalent of clear-text telnet? :roll: )

Both boards have identical configuration. BGP Routing, no firewall rules at all, no connection tracking, no PPP enabled, NO IPsec, no tunnels, no bridges.
Simple routing between ether1 & wlan1 using BGP. Nothing more, nothing less.
Only System, Security, Routing and Wireless-fp packages are enabled on both boards.

Normis you where saying something about not being true that on every release you break something? :lol: (sorry it's just so funny reading that line :D )
Not to burst your bubble, but everyone that uses Mikrotik long enough and/or professionally (ie: multiple boards, multiple installations, multiple configurations, not just a home router) knows for a fact that upgrading almost always will cause problems somewhere. Especially on version 6.x.
This is not an opinion. It's a fact.

I've been using Mikrotik for 10 years and I have experienced the pattern of broken stuff myself again and again. I don't need to read it on some forums as you put it.

And almost always the affected stuff are not even remotely mentioned in the changelog. So either your code is a mess of spaghetti that by changing one thing another 100 get affected or you change stuff that you never mention on your changelog.

Out of curiosity, which one is it?

Since version 6.x you pretty much broke everything one way or another.

For serious production workloads I still use v5.26. By FAR the most stable version of Mikrotik yet (even though it's missing tons of new features of v6). Too bad v5.x doesn't work on CCRs. It would have been awesome to have a really stable router with that horsepower!
 
User avatar
dgnevans
Member
Member
Posts: 463
Joined: Fri Mar 08, 2013 11:24 am
Location: Zimbabwe
Contact:

Re: v6.30.1 bugfix release

Sat Jul 18, 2015 9:10 pm

Not sure if this started with bugfix or previous versions. When Fast track is enabled traffic bypasses the simple queues and traffic does not appear in IP accounting. You can see the traffic on Interface.
 
User avatar
dimi
just joined
Posts: 9
Joined: Thu Feb 05, 2015 1:32 am
Location: Ukraine

Re: v6.30.1 bugfix release

Sun Jul 19, 2015 4:22 am

Important ISSUE:

iphone (latest iOS) doesn't work at all with new ROS 6.30.1 after waking up.

------------------------
Very disappointed with a few latest Mikrotik ROS updates... Very poor quality and too much seriously bugs. I guess there is no way to implement a new features which follows to the situation like now.
 
finalcutroot
newbie
Posts: 45
Joined: Sun Mar 09, 2014 9:36 pm

Re: v6.30.1 bugfix release

Sun Jul 19, 2015 5:22 pm

when i try to upgrade CCR1036-8G-2S+
Error Missing : wireless-6.30.1-tile.npk
 
jarda
Forum Guru
Forum Guru
Posts: 7604
Joined: Mon Oct 22, 2012 4:46 pm

Re: v6.30.1 bugfix release

Sun Jul 19, 2015 7:10 pm

Not sure if this started with bugfix or previous versions. When Fast track is enabled traffic bypasses the simple queues and traffic does not appear in IP accounting. You can see the traffic on Interface.
This is not error. This is the way how the fasttrack works.
 
ddejager
Member Candidate
Member Candidate
Posts: 109
Joined: Tue Oct 18, 2011 5:13 am

Re: v6.30.1 bugfix release

Sun Jul 19, 2015 8:22 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
+1 here; /tool fetch has changed something as it works perfectly on =< 6.29.1 but not anymore in 6.30
+1 /tool fetch is broken in 6.30

This might be a helpful workaround:

http://forum.mikrotik.com/viewtopic.php ... 6a#p489204

But, Mikrotik, why is it needed?
 
frankie
Member Candidate
Member Candidate
Posts: 116
Joined: Thu May 08, 2008 9:45 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 1:03 am

Link for x86 ROS 6.30.1 disk image broken:
http://download2.mikrotik.com/routeros/ ... 6.30.1.zip
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 4:48 am

So any major issues with CCR?
 
infused
Member
Member
Posts: 305
Joined: Fri Dec 28, 2012 2:33 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 4:54 am

Also, I think you guys should really just have a stable branch, and not stable... would be far easier and nicer for us as end users. The new system still does not address this. It's pretty much Russian roulette when upgrading, even if you lab it first.
 
User avatar
macgaiver
Forum Guru
Forum Guru
Posts: 1722
Joined: Wed May 18, 2005 5:57 pm
Location: Sol III, Sol system, Sector 001, Alpha Quadrant

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 8:21 am

Also, I think you guys should really just have a stable branch, and not stable... would be far easier and nicer for us as end users. The new system still does not address this. It's pretty much Russian roulette when upgrading, even if you lab it first.
Starting from v6.21 almost every version was "stable" - 99,9% of features was working just fine, only selected few had problems.
You need to realize that this forum doesn't reflect real situation, forum is place to complain :).
With great knowledge comes great responsibility, because of ability to recognize id... incompetent people much faster.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 8:59 am

when i try to upgrade CCR1036-8G-2S+
Error Missing : wireless-6.30.1-tile.npk
CCR doesn't have wireless interfaces. Remove the wireless package.
No answer to your question? How to write posts
 
IntrusDave
Forum Guru
Forum Guru
Posts: 1290
Joined: Fri May 09, 2014 4:36 am
Location: Rancho Cucamonga, CA

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 9:13 am

wireless-fp-6.30.1-tile.npk
I've often wondered why this package exists.
David Joyce
Network & Security Engineer
Intrus Technologies, LLC.
Rancho Cucamonga, CA, USA
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 9:18 am

wireless-cm2 can be used to manage wireless devices via the CAPsMAN feature. To manage other APs you don't need wireless cards. But this is only in the cm2 package, not wireless old one.
No answer to your question? How to write posts
 
ShiAiLang
just joined
Posts: 2
Joined: Fri Jul 17, 2015 9:17 am

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 10:00 am

Can anybody answer on my question about DHCP?
Hi, does this update fix a problem with DHCP? After upgrading to 6.30 I have strange issue - DHCP-server stops working after reboot. The only fix that I found is to delete old server and create new one, exactly the same
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 11:04 am

Can anybody answer on my question about DHCP?
Hi, does this update fix a problem with DHCP? After upgrading to 6.30 I have strange issue - DHCP-server stops working after reboot. The only fix that I found is to delete old server and create new one, exactly the same
have you contacted support@mikrotik.com? please make a supout.rif file when this happens, email it to support
No answer to your question? How to write posts
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 11:20 am

vortex, I really have no idea what you are asking. You really expect a release where "all bugs are fixed, 100% guarantee forever"?
No answer to your question? How to write posts
 
becs
MikroTik Support
MikroTik Support
Posts: 479
Joined: Thu Jul 07, 2011 8:26 am

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 12:31 pm

interface TX traffic in Torch is still not visible. on the CRS platform at least.
Torch tool does not work on CRS ports which are in a switched port group because packets between these ports are processed by switch-chip instead of CPU of the device. Switch-chip does not support Torch.
 
User avatar
ufm
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 1:23 pm

vortex, I really have no idea what you are asking. You really expect a release where "all bugs are fixed, 100% guarantee forever"?
I'm not vortex, but I think I can say what he wants. And I also want to just that:
LTS bugfix only release.
Yes. "all bugs are fixed, 100% guarantee forever" - can not be. But "version, which does not add new features, so there are fewer errors" - can.

LTS - may be not year long. But half-year. Please.
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 1:27 pm

I already wrote that v6.30.x will be maintained for more than a month. If we stretch it for 6 months, it will be exactly what you, ufm, described. So I don't understand the difference
No answer to your question? How to write posts
 
User avatar
ufm
Frequent Visitor
Frequent Visitor
Posts: 97
Joined: Fri Nov 15, 2013 12:02 pm
Location: Ukraine

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 1:39 pm

I already wrote that v6.30.x will be maintained for more than a month. If we stretch it for 6 months, it will be exactly what you, ufm, described. So I don't understand the difference
Difference - 5 month :)

BTW, Mikrotik say - "7 version will be released in this year". "This year" - 5 months left. May be throw all the forces to release 7 version and say "6.x version - 1 year LTS without new features"?
 
vortex
Forum Veteran
Forum Veteran
Posts: 714
Joined: Sat Feb 16, 2013 6:10 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 1:49 pm

I am just saying the UX should not be the same to go from 6.30.2 to 6.30.3 as to go from 6.30.3 to 6.31.x
 
finalcutroot
newbie
Posts: 45
Joined: Sun Mar 09, 2014 9:36 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 3:48 pm

when i try to upgrade CCR1036-8G-2S+
Error Missing : wireless-6.30.1-tile.npk
CCR doesn't have wireless interfaces. Remove the wireless package.
Thank You ,, :D :D :D

Any new updates on HOTSPOT , after mac-cookies almost nothing new
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 3:50 pm

I am just saying the UX should not be the same to go from 6.30.2 to 6.30.3 as to go from 6.30.3 to 6.31.x
Understand. OK, will think how to solve.
No answer to your question? How to write posts
 
User avatar
erickbrito
just joined
Posts: 3
Joined: Mon Jul 20, 2015 6:41 pm

Re: v6.30.1 bugfix release

Mon Jul 20, 2015 6:53 pm

Depois q atualizei as rb pra 6.30.1? aqui esta dando problema nos clientes pppoe fia sumindo e voltando uso rb1100, rb750gl todos estão a sim como faço para resolver esse problema ?
 
User avatar
rextended
Forum Guru
Forum Guru
Posts: 2946
Joined: Tue Feb 25, 2014 12:49 pm
Location: Capalbio, Tuscany, Italy

Re: v6.30.1 bugfix release

Tue Jul 21, 2015 12:47 pm

Run 6.30.1 from the date of the exit, 3/4 of my network use that without any problem
(CPE still at 6.20 for management reason, all the CPE must have same RouterOS, and I actually do not have time to upgrade it all)
I'm Italian, not English. Sorry for my imperfect grammar.
 
User avatar
guilhermeramires
Trainer
Trainer
Posts: 56
Joined: Fri Jan 22, 2010 9:06 pm

Re: v6.30.1 bugfix release

Tue Jul 21, 2015 3:53 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Or try IP -> Cloud and be happy! :D
Mikrotik Training Partner
MPLS for the Masses
 
bommi
just joined
Posts: 24
Joined: Fri Jan 24, 2014 9:13 am
Location: Germany
Contact:

Re: v6.30.1 bugfix release

Tue Jul 21, 2015 4:49 pm

+1 for dyndns script, 6.29.1!working and 6.30 broken
more likely that your script is broken. scripting language improves over time, the scripts need to be updated. MikroTik did not make th DynDNS script, you have to ask the person who wrote it, or maybe post this question in the "Scripting" section, someone could update it.
Or try IP -> Cloud and be happy! :D
Doesnt work on DS-Lite where you only get an public ipv6 and an private ipv4 address.
 
User avatar
IPANetEngineer
Trainer
Trainer
Posts: 1053
Joined: Fri Aug 10, 2012 6:46 am
Location: Jackson, MS, USA
Contact:

Re: v6.30.1 bugfix release

Tue Jul 21, 2015 5:33 pm

Well done MikroTik team! Really liking the new plan for code development and download options for bugfix only. We have received positive feedback from our customers on this change as well :-)
Global - MikroTik Support & Consulting - English | Francais | Español | Portuguese +1 855-645-7684
https://iparchitechs.com/services/mikro ... l-support/ mikrotiksupport@iparchitechs.com
 
sdv
just joined
Posts: 13
Joined: Tue Oct 01, 2013 9:30 am

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 9:27 am

Mikrotik, please backport "snmp - fix system scripts table" from release candidate (works on 6.31rc8) to bugfix branch, let us say to 6.30.2.
This bug completly broke my CPE managment system.
 
akelsey
just joined
Posts: 4
Joined: Wed Jul 22, 2015 9:37 am

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 9:39 am

Winbox ignores tick "IP - UPnP - Show Dummy Rule" - they always are in NAT tab. Could you fix it? (Or please give an advice how to report this annoying thing?)
Thanks.
 
User avatar
tomaskir
Trainer
Trainer
Posts: 1122
Joined: Sat Sep 24, 2011 2:32 pm
Location: Slovakia

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 9:57 am

Winbox ignores tick "IP - UPnP - Show Dummy Rule" - they always are in NAT tab. Could you fix it? (Or please give an advice how to report this annoying thing?)
Thanks.
Send the report to support@mikrotik.com
Unimus - configuration management, automation and backup solution
Mass Config Push, network-wide RouterOS upgrades, and more!
 
prawira
Trainer
Trainer
Posts: 281
Joined: Fri Feb 10, 2006 5:11 am

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 11:15 am

dear mikrotik team,

please add the zoom-in and zoom-out facilities on webfig and user-manager.
it's really difficult for user who wanna open the webfig and or user-manager using smartphone.

tq

Paul
 
User avatar
strods
MikroTik Support
MikroTik Support
Posts: 1409
Joined: Wed Jul 16, 2014 7:22 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 11:21 am

prawira, tomaskir - both of these issues should be fixed in next version of RouterOS (6.30.2 and 6.31rc9).
 
alexha
just joined
Posts: 9
Joined: Mon Feb 11, 2013 1:17 pm

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 5:47 pm

Something wrong with PPP for Android clients:
connecting >>> authenticated >>> terminated

I tried PPTP and L2TP/IPSEC and behavior is the same. Windows/Linux clients work flawlessly.
Confirm the problem with the connection to the pptp from android clients for 6.30 and 6.30.1. Downgrade to version 6.29 solves the problem.
 
kristaps
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Jan 27, 2014 1:37 pm

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 6:25 pm

could you please try latest 6.31rc it should be fixed android and ppp there
 
dawg
just joined
Posts: 15
Joined: Thu Apr 25, 2013 7:31 pm

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 8:35 pm

I have a CCR1036-12G-4S that somehow ended up on 6.30 (not entirely sure how/why - the sister router was on 6.28 and they're upgraded simultaneously). In any case, this installation positively refuses to upgrade to 6.30.1 or downgrade to 6.28 and PPP connections have become extremely unstable, with very high packet loss.

Any clue why it wouldn't upgrade or downgrade properly?
 
petrisimo
just joined
Posts: 14
Joined: Sat Apr 06, 2013 8:15 pm

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 8:54 pm

I think the great idea to improve software quality will be broken quet fast
why?
because maintainance window is too short, even if mikrotik start it now by pickingup LTS, it will take around 2 years to fix most of the bugs.
I think 3 years would be optimal for LTS, by picking up LTS each 2 years
And in the end - look at Canonical and Ubuntu.
 
mediana
just joined
Posts: 10
Joined: Tue Feb 04, 2014 9:03 am

Re: v6.30.1 bugfix release

Wed Jul 22, 2015 11:57 pm

It's not working to use "0.0.0.0" (dynamic IP address) as the "S.A. Src. Address" on IPsec Police.
+1, since v6.30.
v6.30.IPsec.Problem.png
So, anyone can tell it's a feature or a bug?
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.1 bugfix release

Thu Jul 23, 2015 9:18 am

It's not working to use "0.0.0.0" (dynamic IP address) as the "S.A. Src. Address" on IPsec Police.
+1, since v6.30.
v6.30.IPsec.Problem.png
So, anyone can tell it's a feature or a bug?
We can't repeat it. Could be misconfiguration that no longer gets accepted in new version? Did you all email support@mikrotik.com ?
No answer to your question? How to write posts
 
alexha
just joined
Posts: 9
Joined: Mon Feb 11, 2013 1:17 pm

Re: v6.30.1 bugfix release

Thu Jul 23, 2015 9:30 am

could you please try latest 6.31rc it should be fixed android and ppp there
yes, in the version v6.31rc8 problem with pptp missing. thanks
 
ste
Forum Guru
Forum Guru
Posts: 1815
Joined: Sun Feb 13, 2005 11:21 pm

Re: v6.30.1 bugfix release

Thu Jul 23, 2015 11:56 am

Also, I think you guys should really just have a stable branch, and not stable... would be far easier and nicer for us as end users. The new system still does not address this. It's pretty much Russian roulette when upgrading, even if you lab it first.
Starting from v6.21 almost every version was "stable" - 99,9% of features was working just fine, only selected few had problems.
You need to realize that this forum doesn't reflect real situation, forum is place to complain :).
We had a VPLS Problem with 6.29.1 which was a deal breaker for us.
6.30 does not show a single problem to us so far. Looks like a very good release.
 
Basdno
Member Candidate
Member Candidate
Posts: 118
Joined: Wed Feb 17, 2010 10:11 pm

Re: v6.30.x bugfix release

Thu Jul 23, 2015 2:28 pm

So any1 tested ROS 6.30.2 yet?

I see its awaileble on download page now! :)
 
User avatar
normis
MikroTik Support
MikroTik Support
Topic Author
Posts: 24317
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: v6.30.x bugfix release

Thu Jul 23, 2015 2:49 pm

No answer to your question? How to write posts

Who is online

Users browsing this forum: No registered users and 12 guests