Page 1 of 1

v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 2:49 pm
by normis
What's new in 6.30.2 (2015-Jul-22 11:17):

*) pptp & l2tp - fixed problem where android client could not connect if
both dns names were not provided (was broken since v6.30);
*) lcd - fix crash (and 100% cpu usage) when interface gets removed from "stats-all" screen
*) tool fetch - fix incomplete ftp download
*) ipsec - fixed crash in when gcm encryption was used
*) certificate manager - fixed memory leak
*) traffic flow - fixed dynamic input/output interface reporting
*) user-manager - fixed username was not shown in /tool user-manager user
*) user-manager - fixed zoom for user-manager homepage when mobile devices used
*) winbox - restrict reversed ranges in dst-port under firewall
*) snmp - fix system scripts table

known issue:
*) Dynamic DNS servers can disappear when "allow-remote-requests" are not enabled

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 4:10 pm
by ddejager
I believe that Changelog for 6.30.1 included "quickset - fixed HomeAP mode". This is missing from the changelog for 6.30.2. Is the fix there or not?

Minor Nit: the title bar for the changelogs for 6.30.2 and 6.31rc9 says "MD5 info" not "Changelog"

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 4:26 pm
by erickbrito
Olá !! aqui nas minhas rbs 1100 450g 750gl está dando problema, os cliente em pppoe fica desconectando e sumindo la em simple queues , esse problema só ocorre nas versões 6.29 , 6.30 , 6.30.1 6.30... em diante.

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 5:48 pm
by Campano
I love this way of work :D

focus on bugfix. Nice job! Mikrotik Team.

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 6:54 pm
by jdog
Finally! Yes!

This is how things should progress!

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 7:43 pm
by ufm
Finally! Yes!

This is how things should progress!
After upgrade:Image

Re: v6.30.2 bugfix release

Posted: Thu Jul 23, 2015 8:02 pm
by solaoxo
'execute' in not running scheduler.
The problem is still in 6.30.2 did not even repair.
He said several times, even official replies are not, really disappointing.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 1:39 am
by cheeze
YES, this is what we love to see Mikrotik.

Please please just release one more bugfix for 6.30 and we should finally have a really good starting point for version 6 stability.

Thank you again for all the very hard work that is done. Thank you Mikrotik peeps.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 1:42 am
by 3bs
+1 sheduler not work

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 2:53 am
by G2Dolphin
Tools - Traffic Monitor isn't working.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 10:15 am
by normis
Tools - Traffic Monitor isn't working.
did it work in previous version?

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 10:16 am
by normis
'execute' in not running scheduler.
The problem is still in 6.30.2 did not even repair.
He said several times, even official replies are not, really disappointing.
+1 sheduler not work
solaoxo, 3bs

how are you testing it? post full example please

it is working for me

there have been many changes to execute, please clarify what is not working specifically
*) console - ':execute' command now accepts 'file=' parameter and
    writes script output to scpecified file;
*) console - ':execute' command now accepts script source in "{}" braces,
    like '/system scripts add source=' does;
*) console - ':execute' command now returns internal number of running job,
    that can be used to check and stop execution. For example:
      :local j [:execute {/interface print follow where [:log info "$name"]}]
      :delay 10s
      :do { /system script job remove $j } on-error={}
      

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:05 pm
by ufm
Hi!

After upgrade to 6.30.2
"hAP lite" say "latest firmware is 3.24"
"CCR" say "latest firmware is 3.27"

It's correct?

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:29 pm
by elechero
could not upgrade my CCR1036 to this version.
From system---packages >>>> it shows a message. "ERROR missing wireless-6.30.2-tile.npk"

I download Extra files from the site and put it in the files and did reboot... it did not work.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:30 pm
by elechero
usermanager problem from 6.30 release...
In hotspot alogin page remain-bytes-total-nice is not working while it was working will.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:34 pm
by normis
Hi!

After upgrade to 6.30.2
"hAP lite" say "latest firmware is 3.24"
"CCR" say "latest firmware is 3.27"

It's correct?
yes, different systems have different firmwares. ccr had more updates

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:34 pm
by normis
could not upgrade my CCR1036 to this version.
From system---packages >>>> it shows a message. "ERROR missing wireless-6.30.2-tile.npk"

I download Extra files from the site and put it in the files and did reboot... it did not work.
remove wireless package from current install. CCR doesn't have wireless interfaces

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:48 pm
by ufm
Hi!

After upgrade to 6.30.2
"hAP lite" say "latest firmware is 3.24"
"CCR" say "latest firmware is 3.27"

It's correct?
yes, different systems have different firmwares. ccr had more updates
Hmm... I think it was better, to have all the same version number.
I agree, it's not a bug, but watch out for the fact that my engineers did not forget to update firmware easier.

Perhaps it makes sense to make the setting "allow firmware autoupgrade when upgrade ROS"?

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 12:58 pm
by normis
It has never been the same number, since first RouterBOARD.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 1:01 pm
by evince
Perhaps it makes sense to make the setting "allow firmware autoupgrade when upgrade ROS"?

+1

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 1:53 pm
by tapsin
Traffic on the bridge
It shows the same in all entries

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 2:19 pm
by prawira
the zoom-in is working on webfig, but not on user manager.

P

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 3:30 pm
by solaoxo
'execute' in not running scheduler.
The problem is still in 6.30.2 did not even repair.
He said several times, even official replies are not, really disappointing.
+1 sheduler not work
solaoxo, 3bs

how are you testing it? post full example please

it is working for me

there have been many changes to execute, please clarify what is not working specifically
*) console - ':execute' command now accepts 'file=' parameter and
    writes script output to scpecified file;
*) console - ':execute' command now accepts script source in "{}" braces,
    like '/system scripts add source=' does;
*) console - ':execute' command now returns internal number of running job,
    that can be used to check and stop execution. For example:
      :local j [:execute {/interface print follow where [:log info "$name"]}]
      :delay 10s
      :do { /system script job remove $j } on-error={}
      
dfggr.png
As shown, this is just a simple example, 'execute' is not normally performed in scheduler, in the 6.29.1 version, there is no problem.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 3:41 pm
by normis
:execute has two parameters, actual script and file.

you should write not the name, but the script, like in the changelog example
this works:
Screenshot 2015-07-24 15.41.07.png

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 3:56 pm
by solaoxo
:execute has two parameters, actual script and file.

you should write not the name, but the script, like in the changelog example
this works:
Screenshot 2015-07-24 15.41.07.png
Give me a specific script can be executed in the name of the scheduler in the script is DDNS.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:10 pm
by elechero
could not upgrade my CCR1036 to this version.
From system---packages >>>> it shows a message. "ERROR missing wireless-6.30.2-tile.npk"

I download Extra files from the site and put it in the files and did reboot... it did not work.
remove wireless package from current install. CCR doesn't have wireless interfaces
It worked. Thanks.
Anything about remain-bytes-nice which shows the total remain bytes in webpage. Is it a firmware update problem. or the problem only with me.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:13 pm
by normis
:execute has two parameters, actual script and file.

you should write not the name, but the script, like in the changelog example
this works:
Screenshot 2015-07-24 15.41.07.png
Give me a specific script can be executed in the name of the scheduler in the script is DDNS.
why do you need the ":execute" at all? just post the script in the scripts section, and in scheduler run the script by name.

:execute is not needed at all for you

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:13 pm
by solaoxo
:execute has two parameters, actual script and file.

you should write not the name, but the script, like in the changelog example
this works:
Screenshot 2015-07-24 15.41.07.png
sagege.png
Red Frames of how to write to execute.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:14 pm
by normis
Like I said, you are not using it correctly.

1) your start time is "startup". this is not correct
2) remove "Execute" from scheduler, you don't need it

This is how you need to set it up:
Screenshot 2015-07-24 16.15.19.png

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:26 pm
by elechero
could not upgrade my CCR1036 to this version.
From system---packages >>>> it shows a message. "ERROR missing wireless-6.30.2-tile.npk"

I download Extra files from the site and put it in the files and did reboot... it did not work.
remove wireless package from current install. CCR doesn't have wireless interfaces
It worked.
Anything about remain-bytes-total-nice??

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 4:30 pm
by solaoxo
Like I said, you are not using it correctly.

1) your start time is "startup". this is not correct
2) remove "Execute" from scheduler, you don't need it

This is how you need to set it up:
Screenshot 2015-07-24 16.15.19.png
I know, but had previously been so used up, so relatively simple, sometimes there are several scripts to be called to the same. It is not after 6.29.1 can not be so used.

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 5:26 pm
by Chupaka
*) winbox - restrict reversed ranges in dst-port under firewall
it's still allowed, at least on CCR:
reverse-port.gif

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 7:29 pm
by G2Dolphin
Tools - Traffic Monitor isn't working.
did it work in previous version?
Personally I can't answer this question, because I found how it can be useful just yesterday... but regarding to this post http://forum.mikrotik.com/viewtopic.php ... or#p490761 — no...

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 7:35 pm
by ahteran
Hi guys
I think there are two bug, version 5.26 of the system works as gigabit and in the 6.30.2 version works Fast Ethernet
see picture please
Image
Another problem an with wireless tx power issue Unex CM10HP wireless card available on RB800
as in the picture below
Image
Image

Re: v6.30.2 bugfix release

Posted: Fri Jul 24, 2015 11:57 pm
by zervan
certificate manager - fixed memory leak
Is it solving a strange issue which I have mostly on RB750G with only 32 MiB of memory - log is full of 'CRL sice exceeds free memory, aborting update'? Then the router is acting strange - sometimes web interface is not available, other time CPU is 100%, sometimes reset is necessary. I came here to forum to ask other people with 6.30.1 (or 6.30) if they have the same problem and I saw this 6.30.2 topic...

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 9:42 am
by zervan
Is it solving a strange issue which I have mostly on RB750G with only 32 MiB of memory - log is full of 'CRL sice exceeds free memory, aborting update'?
15 hours after update to 6.30.2 everything seems to be working fine...

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 3:39 pm
by docmarius
IPv6 ND still broken on my RB1100AHx2 with 6.30.2.

Issues:
- on IPv6 change (DHCP client), some old IP allocations are not deleted from the address list (this is a pre-6.27 issue, getting more visible after 6.28).
Image
- Address is correctly assigned from pool (pool and allocation is /64 - correct in 6.29.1 and 6.30.2)
(::1/64 set gives correctly e.g. 2a02:2f09:3344:7000::1/64)
- Clients don't get correct allocations via RA (only link local IP present - win7, can not check for other OS at the moment - 6.30 - 6.30.2)

Reverting to 6.29.1 fixes the ND allocation issue.

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 4:02 pm
by DjM
Please get fixed:

[Ticket#2015032266000169] Unable to set comment on dhcp-server alert via CLI
[Ticket#2015062266000743] Double slashes in tool fetch URL

Thank you

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 4:28 pm
by khaleday12
hi guys i have problem with lollipop phone they connect to the server but without internet and they don't open sign in page for hotspot pleaz help my clintes start to be mad
forgive my english it's not that good
if i upgrade to v6.30.2 bugfix release could be the problem go away ?
and how to upgrade

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 4:35 pm
by mbuckholdt
I just upgraded our company's CCR1036-8G from 6.3 to 6.30.2 and then upgraded the Firmware from 3.10 to 3.27.

Since upgrading our PPTP VPN connections are dropping randomly with an error "CCP lost compression got our of sync: disabling compression" then the next message is "terminating... - Encryption got out of sync"

Is there anything I can do to resolve this?

I see this was resolved in v6.30 release notes but we never had this error when we were on v6.3.

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 4:39 pm
by Cha0s
IPv6 ND still broken on my RB1100AHx2 with 6.30.2.

Issues:
- on IPv6 change (DHCP client), some old IP allocations are not deleted from the address list (this is a pre-6.27 issue, getting more visible after 6.28).
Image
- Address is correctly assigned from pool (pool and allocation is /64 - correct in 6.29.1 and 6.30.2)
(::1/64 set gives correctly e.g. 2a02:2f09:3344:7000::1/64)
- Clients don't get correct allocations via RA (only link local IP present - win7, can not check for other OS at the moment - 6.30 - 6.30.2)

Reverting to 6.29.1 fixes the ND allocation issue.
I too have strange issues with IPv6 on 6.30.2 (I haven't used any other version - its freshly installed on 2 new CCRs).

In general, IPv6 support in Mikrotik is not very good. Not everything you see in Winbox seem to be what's actually going on bellow the hood.
I had a case where all ipv6 firewall rules where disabled and it would still block BFD protocol. The only way I was able to overcome that was by removing all rules, rebooting, and readding all from scratch. Something really unacceptable in any production environment!

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 6:44 pm
by hkjimmy
Dear MikroTik Support,

ip route pref-src is not working correctly since version 6.30 and later (6.29 and previous version is working fine )

Downgrade to Version 6.29. everything is working correctly.

support.rif and details was submitted by Ticket#2015071966000051 a week ago, but only auto reply from system.

Please follow up, i believe it is small bug and easy to be fixed.

Thank you !

Re: v6.30.2 bugfix release

Posted: Sat Jul 25, 2015 8:45 pm
by tomaskir
I just upgraded our company's CCR1036-8G from 6.3 to 6.30.2 and then upgraded the Firmware from 3.10 to 3.27.

Since upgrading our PPTP VPN connections are dropping randomly with an error "CCP lost compression got our of sync: disabling compression" then the next message is "terminating... - Encryption got out of sync"

Is there anything I can do to resolve this?

I see this was resolved in v6.30 release notes but we never had this error when we were on v6.3.
Disable all compression in the ppp profile.

The compression is useless, and actually hurts performance. (feel free to read up on it to verify)

Re: v6.30.2 bugfix release

Posted: Sun Jul 26, 2015 12:20 am
by mbuckholdt
I just upgraded our company's CCR1036-8G from 6.3 to 6.30.2 and then upgraded the Firmware from 3.10 to 3.27.

Since upgrading our PPTP VPN connections are dropping randomly with an error "CCP lost compression got our of sync: disabling compression" then the next message is "terminating... - Encryption got out of sync"

Is there anything I can do to resolve this?

I see this was resolved in v6.30 release notes but we never had this error when we were on v6.3.
Disable all compression in the ppp profile.

The compression is useless, and actually hurts performance. (feel free to read up on it to verify)
Thanks for the reply!

I disabled all compression in the PPP profile on the main router running the VPN server and it seems that the Windows clients are staying connected OK but I get the same error with our 2 other offsite MikroTik's with a PPTP Client connection. I went into the client MikroTik's and disabled all compression in the PPP profile but still getting the same error even though both compression settings are set to No.

Is there another setting that could be forcing compression?

What's really odd is we didn't have connection issues with the offsite MikroTik's until I upgraded our main MikroTik that runs the VPN server to v6.30.2.

Re: v6.30.2 bugfix release

Posted: Sun Jul 26, 2015 12:30 am
by tapsin
Fasttrack connection Add Rule Firewall But very very slow Hotspot user.

Re: v6.30.2 bugfix release

Posted: Sun Jul 26, 2015 2:23 pm
by steen
Hello Folks!

Where do I find latest stable, RoS v6.30, should that not be available no the download page ?

Re: v6.30.2 bugfix release

Posted: Sun Jul 26, 2015 3:16 pm
by Cha0s
Just upgraded 2 RB2011 from 6.29 to 6.30.2.

Both RBs have identical configuration (active/standby setup).

The standby RB2011 got upgraded ok, no issues so far.
The active RB2011 never came back online after the upgrade.

I need to travel 40kms to the Datacenter now...

As always, great work Mikrotik!

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 3:24 am
by ddejager
Hello Folks!

Where do I find latest stable, RoS v6.30, should that not be available no the download page ?
6.30.2 is the latest version that has only bug fixes applied to 6.30.

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 9:24 am
by jarda
Is this what should happen when updating to 6.30.2?
RB532A-Version.jpg
I did just system-packages check for update and download and upgrade from 6.30.1.

The result:
No system version reported, no packages reported, no ip address, no dhcp, nothing. Just able to connect via mac. Needed to run istallation again manually, then it finished correctly.

I warn everyone, be careful when updating. Do not update if you do not have real reason for it. Make test in your lab first and follow the forum before you decide to update.

PS: The described situation was from laboratory device, of course. I am not a kamikaze.

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 9:32 am
by honzam
Is this what should happen when updating to 6.30.2?
I tried it in lab and it works for me

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 9:44 am
by jarda
The dummy rules (in firewall filter and in firewall mangle) are not dynamically removed when fasttracking rule is removed:
dummy rules.jpg
[Ticket#2015072766000161]

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 2:30 pm
by paulsa
*) traffic flow - fixed dynamic input/output interface reporting

What does this fix compared to the traffic flow fix in 6.30.1?

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 2:42 pm
by stephenpatrick
Torrent download of 6.30.2 seems stuck on 335 / 356MB, 93.09 %

Direct downloads seem fine though.

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 3:17 pm
by macgaiver
The dummy rules (in firewall filter and in firewall mangle) are not dynamically removed when fasttracking rule is removed: [Ticket#2015072766000161]
That is the way it works, dummy rules, are based on fasttrack-connection flag in connection tracking. if you remove the rule, there are still fasttracked packets from flaged connections.

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 5:20 pm
by yuanmayi
Downgrade 6.30.2 to 6.24 can't Upgrade Firmware to 3.19, I Click on the Upgrade and reboot system,it can't Upgrade Firmware to 3.19
dsdsds.png

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 5:24 pm
by stephenpatrick
Torrent download of 6.30.2 seems stuck on 335 / 356MB, 93.09 %

Direct downloads seem fine though.
Update to that, it now seems to have completed the download.
Guess there weren't enough seeders -

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 5:31 pm
by alexusss
Hi!

Is there any plans to fix this problem http://forum.mikrotik.com/viewtopic.php?f=2&t=82980 ??

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 6:02 pm
by realdreams
pptp server is still broken in 6.30.2
ppp,error,critical 16: Encryption got out of sync - disabling

Is it a MTU related issue?

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 11:26 pm
by barracuda
I am update hap lite from _6.31rc6 to 6.30.2 and the script which one is worked fine in 6.31rc6 not work anymore!
Please understand that we do not all know how to rewrite the code, which will work correctly ,so please fix this.

Re: v6.30.2 bugfix release

Posted: Mon Jul 27, 2015 11:49 pm
by Chupaka
so please fix this.
fix what? "I have some error, I won't tell you anything about it, but please fix it - aren't you a telepathists?"

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 12:06 am
by Thalid
I am update hap lite from _6.31rc6 to 6.30.2 and the script which one is worked fine in 6.31rc6 not work anymore!
Technical thats an downgrade

Post script whitout moore info we cant help

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 12:23 am
by R00tKit
Hello, any plans to fix IPSEC VPN with dynamic public IP on an upcoming release ?

(Related topic:) http://forum.mikrotik.com/viewtopic.php?f=2&t=98863

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 12:29 am
by barracuda
@Chupaka

I do not know how to write differently.Like you can see on this link
http://forum.mikrotik.com/viewtopic.php?f=9&t=98959

I gave the example scripts that works fine with version RC6 but with this latest version the script is not working .Can you explain why it is so because you have plenty of knowledge which I can unfortunately do not have, Thank you for your help and friendly reply!

@Thalid

Thank you, I understand now !

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 8:46 am
by zervan
pptp server is still broken in 6.30.2
ppp,error,critical 16: Encryption got out of sync - disabling

Is it a MTU related issue?
I am using SSTP, but I also have one temporary PPTP and no issues here - nor 6.30.2 neither the previous:
/ppp profile
add change-tcp-mss=no dns-server=192.168.254.1 local-address=192.168.254.1 name=sstp-server only-one=no remote-address=pool-VPN use-compression=no use-encryption=no use-mpls=no
add change-tcp-mss=no dns-server=192.168.254.1 local-address=192.168.254.1 name=pptp-server only-one=no remote-address=pool-VPN use-compression=no use-encryption=yes use-mpls=no
add name=only-one only-one=yes
/interface pptp-server server
set authentication=mschap2 default-profile=pptp-server

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 1:03 pm
by benzieb
This might be something I've come across recently which is more an Android 5.x thing. The device will try to load http://clients3.google.com/generate_204, and if it can't, figures its in a walled garden and decides it won't connect to the wifi automatically...

https://www.chromium.org/chromium-os/ch ... -detection
hi guys i have problem with lollipop phone they connect to the server but without internet and they don't open sign in page for hotspot pleaz help my clintes start to be mad
forgive my english it's not that good
if i upgrade to v6.30.2 bugfix release could be the problem go away ?
and how to upgrade

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 1:49 pm
by jebz
Torrent download of 6.30.2 seems stuck on 335 / 356MB, 93.09 %

Direct downloads seem fine though.
Update to that, it now seems to have completed the download.
Guess there weren't enough seeders -
Maybe the URL is the problem -
http://www.mikrotik.com/download/router ... .2.torrent
More seeders will join if the URL is published.

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 2:02 pm
by Cha0s
Torrent download of 6.30.2 seems stuck on 335 / 356MB, 93.09 %

Direct downloads seem fine though.
Update to that, it now seems to have completed the download.
Guess there weren't enough seeders -
Maybe the URL is the problem -
http://www.mikrotik.com/download/router ... .2.torrent
More seeders will join if the URL is published.
If Mikrotik doesn't do the initial seeding in the first place then no matter how many people try to download, or if the link is publicly published, it will never complete.

Both torrents (6.30.1 & 6.30.2) got stuck at about ~90% because there was no initial seeder for us to complete them.

I honestly still don't get the rationale behind stopping supporting torrents. Especially since they still create them apparently!

I understand that a home user that has one RB as an internet gateway won't ever need the torrent to get the latest version.

But for professionals that manage tens of different arch RBs, the torrent is the best choice out there.
When a new version comes out you simply download the torrent and you have everything ready for whenever you need them.
Beats the alternative of manually downloading a bunch of stuff or running some lame scripts to do this automatically when the previous procedure (a single click download) is way more efficient than anything else.

Re: v6.30.2 bugfix release

Posted: Tue Jul 28, 2015 6:42 pm
by krisjanis
This might be something I've come across recently which is more an Android 5.x thing. The device will try to load http://clients3.google.com/generate_204, and if it can't, figures its in a walled garden and decides it won't connect to the wifi automatically...

https://www.chromium.org/chromium-os/ch ... -detection
hi guys i have problem with lollipop phone they connect to the server but without internet and they don't open sign in page for hotspot pleaz help my clintes start to be mad
forgive my english it's not that good
if i upgrade to v6.30.2 bugfix release could be the problem go away ?
and how to upgrade
Android I think uses a bit different link for captive portal checking: "http://connectivitycheck.android.com/generate_204" at least the one I have.

/ip hotspot walled-garden
add dst-host=connectivitycheck.android.com method=GET path=/generate_204

Anyhow at moment with android v5.0.2 I haven't had problems with hotspot login check. Also android that Samsung provides on their phones does not seem to disconnect when captive portal auto-detect login ain't used.

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 1:44 am
by khaleday12
This might be something I've come across recently which is more an Android 5.x thing. The device will try to load http://clients3.google.com/generate_204, and if it can't, figures its in a walled garden and decides it won't connect to the wifi automatically...

https://www.chromium.org/chromium-os/ch ... -detection
hi guys i have problem with lollipop phone they connect to the server but without internet and they don't open sign in page for hotspot pleaz help my clintes start to be mad
forgive my english it's not that good
if i upgrade to v6.30.2 bugfix release could be the problem go away ?
and how to upgrade
Android I think uses a bit different link for captive portal checking: "http://connectivitycheck.android.com/generate_204" at least the one I have.

/ip hotspot walled-garden
add dst-host=connectivitycheck.android.com method=GET path=/generate_204

Anyhow at moment with android v5.0.2 I haven't had problems with hotspot login check. Also android that Samsung provides on their phones does not seem to disconnect when captive portal auto-detect login ain't used.
thanx but it did not work any more ideas ???

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 3:40 am
by prawira
*) user-manager - fixed zoom for user-manager homepage when mobile devices used
the zoom is working fine on webfig but not on user-manager.

P

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 4:16 am
by 0ldman
I upgraded another test device, RB433AH, to 6.30.2. I figured I'd see what it does.

Android could not connect to 2.4GHz, worked okay with 5GHz. Laptop had random disconnects. I downgraded to 6.20, bricked it. Netinstall wouldn't bring it back up, formatted NAND, netinstalled again, restored settings and it worked.

I'm a little concerned about this. Anyone know why downgrading from 6.29 or above bricks the device?

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 9:33 am
by zervan
Does somebody experienced problem with time after reboot? See the screenshot from log. There was reboot at 6:12, but the router had back time 14:10 from the previous day.

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 11:10 am
by mikruser
after upgrade to 6.30.2 ipsec problem has not been fixed!!
upgrade6302.png
its very critical issue!

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 1:17 pm
by normis
Like I said, you are not using it correctly.

1) your start time is "startup". this is not correct
2) remove "Execute" from scheduler, you don't need it

This is how you need to set it up:
Screenshot 2015-07-24 16.15.19.png
I know, but had previously been so used up, so relatively simple, sometimes there are several scripts to be called to the same. It is not after 6.29.1 can not be so used.
you must use it like this:
:execute "script-name" 
in quotes

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 1:20 pm
by Genkun
Once it works on 6.29.1 i'll start testing it on 6.30.2

I am attempting to create a trigger ROS upgrade+downgrade system... so far it is only upgrading and still under construction.

Please view my topic here http://forum.mikrotik.com/viewtopic.php?f=9&t=99046

Any help will be much appreciated in making this a success.

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 1:59 pm
by mrz
after upgrade to 6.30.2 ipsec problem has not been fixed!!
upgrade6302.png
its very critical issue!
What problem?

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 2:04 pm
by mikruser

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 4:52 pm
by sdv
Hmmm... snmp system script table still not fixed in 6.30.2 :( (RB750GL)
Snmpwalk returns first script name & index.

Re: v6.30.2 bugfix release

Posted: Wed Jul 29, 2015 8:03 pm
by khaleday12
about ipv6 touters how to block it from making loop on my board ?

Re: v6.30.2 bugfix release

Posted: Thu Jul 30, 2015 2:59 pm
by aleprolit
What's new in 6.30.2 (2015-Jul-22 11:17):

*) user-manager - fixed username was not shown in /tool user-manager user
in version 6.29 parameter 'username' not used. Used parameter 'name' . So we must to rewrite all scripts to change 'name' to 'username'

Re: v6.30.2 bugfix release

Posted: Thu Jul 30, 2015 3:04 pm
by normis
What's new in 6.30.2 (2015-Jul-22 11:17):

*) user-manager - fixed username was not shown in /tool user-manager user
in version 6.29 parameter 'username' not used. Used parameter 'name' . So we must to rewrite all scripts to change 'name' to 'username'
yes, name was always only an alias for username, which was the normal field to use. We removed the alias, leaving only username, because it is more clear.

Re: v6.30.2 bugfix release

Posted: Fri Jul 31, 2015 4:56 pm
by Cha0s
I noticed that sometimes logs get messed up.

I don't know on which version this started, but in general the log window keeps doing stuff when nothing is happening (it seems that it refreshes itself at random times messing up the entries shown to the user).
mikrotik logs.png
The last 3 entries are repeated twice. I am not sure if Mikrotik has invented Time travel just yet? :D

Re: v6.30.2 bugfix release

Posted: Fri Jul 31, 2015 5:53 pm
by Cha0s
I noticed that sometimes logs get messed up.

I don't know on which version this started, but in general the log window keeps doing stuff when nothing is happening (it seems that it refreshes itself at random times messing up the entries shown to the user).
mikrotik logs.png
The last 3 entries are repeated twice. I am not sure if Mikrotik has invented Time travel just yet? :D
Update:

This appears to be a winbox problem since logging out and logging back in show the correct entries in the log window.

Re: v6.30.2 bugfix release

Posted: Fri Jul 31, 2015 11:19 pm
by Jeanluck
Upgrade 6.27 to 6.30.2 in hEX Lite = dead....
All leds off, and is not more accesible even with a power off/on

Re: v6.30.2 bugfix release

Posted: Sat Aug 01, 2015 11:00 am
by steen
Hello Folks!

Whilst upgrading CRS125 used as a pure switch with no radio boards at all in it, with all packages disabled except the necessary ones for logging in and manage it, we noticed that wireless-fp was enabled and some new wireless-cm2 package has arrived.

I have two questions, why did wireless-fp become enabled ?
What is wireless-cm2, is that something I generally needed in my access points and wireless clients, does that trumph out wireless-fp ?

Posted: Sat Aug 01, 2015 1:55 pm
by jarda
Don't use combined package and install individually selected packages only. Then you will not be surprised by this.

Re: v6.30.2 bugfix release

Posted: Sat Aug 01, 2015 5:23 pm
by Cha0s
Updating from v5.26 to 6.30.2 removed all configured IPsec peers.

Re: v6.30.2 bugfix release

Posted: Sat Aug 01, 2015 6:03 pm
by Cha0s
Another bug:

Selecting multiple routing filters and trying to move them up or down, will only move one random rule of those selected instead of all of them.

This works perfectly fine on v5.26.

Re:

Posted: Sat Aug 01, 2015 6:09 pm
by zervan
Don't use combined package and install individually selected packages only. Then you will not be surprised by this.
I think most of us are using very comfortable update from WinBox (System -> Packages). But this time it is really enabling wireless package on all RouterBoards, also if the do not have any wireless interface.

Re: v6.30.2 bugfix release

Posted: Sat Aug 01, 2015 6:11 pm
by jarda
You can use that "comfort" udate feature further, even if you install manually selected packages only instead the combined package. It is your choice, of course...

Re: v6.30.2 bugfix release

Posted: Sat Aug 01, 2015 6:34 pm
by zervan
You can use that "comfort" udate feature further, even if you install manually selected packages only instead the combined package. It is your choice, of course...
I am talking about automatic update (System -> Packages -> Check For Updates) - not about uploading any packages manually. System is updating installed packages only. But here in 6.30.2 (and maybe also previous) is a bug enabling wireless-fp when it was disabled before.

Posted: Sat Aug 01, 2015 7:04 pm
by jarda
And you were updating combined package or single packages installation?

Re:

Posted: Sun Aug 02, 2015 12:33 am
by zervan
And you were updating combined package or single packages installation?
The main package (I think it is mandatory, isn't it?) + some extra packages (not all), see screenshot from one of the routers.

Posted: Sun Aug 02, 2015 1:31 am
by jarda
You have combined package. Just manually install individually selected packages you need instead it. Then you will not have problems when combined package will be changed by mikrotik in the future again.

Re: v6.30.2 bugfix release

Posted: Sun Aug 02, 2015 12:33 pm
by andriys
I have two questions, why did wireless-fp become enabled ?
I can not tell why it's being enable by default, but I can explain to you why it may be useful to enable it on devices without any wireless hardware at all. It is because even if you don't have any wireless hardware installed on the device itself, you can still use CAPsMAN (i.e. Controlled Access Point system Manager) on this device to centrally manage your other access point devices, if any. Feel free to disable the package if you don't need CAPsMAN.
What is wireless-cm2, is that something I generally needed in my access points and wireless clients, does that trumph out wireless-fp ?
The wireless-cm2 package implements CAPsMAN v2, as opposed to CAPsMAN v1 that wireless-fp implements.

Re: v6.30.2 bugfix release

Posted: Sun Aug 02, 2015 8:30 pm
by apathy
traffic flow - not fixed in 6.30.2. Our company uses billing that takes into account the traffic protocol NetFlow. After the upgrade to 6.27 to 6.30.2 missing incoming traffic . Please fix it.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 1:50 am
by docmarius
It seems there is an error in the certificate handling in 6.30.2. Importing an (exported) CA certificate will not set the authority attribute.
This worked correctly up to 6.29.1 (the newest version I checked, at least). If the CA certificate is installed on 6.29.1 before upgrading to 6.30.2, after upgrade it will be correctly identified as authority certificate in 6.30.2.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 10:03 am
by steen
I have two questions, why did wireless-fp become enabled ?
I can not tell why it's being enable by default, but I can explain to you why it may be useful to enable it on devices without any wireless hardware at all. It is because even if you don't have any wireless hardware installed on the device itself, you can still use CAPsMAN (i.e. Controlled Access Point system Manager) on this device to centrally manage your other access point devices, if any. Feel free to disable the package if you don't need CAPsMAN.
What is wireless-cm2, is that something I generally needed in my access points and wireless clients, does that trumph out wireless-fp ?
The wireless-cm2 package implements CAPsMAN v2, as opposed to CAPsMAN v1 that wireless-fp implements.

Ok, thanks! Thats make sense to me, however I do not use CAPsMAN, all our wireless system is links between towers and permanent small and big customers, except in one place were we have usermon and some hotspots.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 11:12 am
by mitjax
Traffic on the bridge
It shows the same in all entries
Same here, downgraded to 6.29.1 same problem (on RB2011UiAS). Looks like a broadcast storm. Could you please open torch on bridge or on any of the ports in bridge? The traffic disappears on my router. Is it same with yours?

Br,
Mitja

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 11:24 am
by kitit
Finally! Yes!

This is how things should progress!
After upgrade:Image
After update my Mirkotik HAP light to 6.30.2 ping low: 21000

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 11:26 am
by normis
How about traceroute? You sure this from the hAP?

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 12:06 pm
by infused
Any reason why when upgrading it does not update the firmware automatically?

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 12:44 pm
by mysz0n
How can i disable 60+ firewall rules from terminal?
With "fasttrack dummy rule" I can't perform disable [find] because i can't disable dynamic rule.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 1:43 pm
by ufm
traffic flow - not fixed in 6.30.2. Our company uses billing that takes into account the traffic protocol NetFlow. After the upgrade to 6.27 to 6.30.2 missing incoming traffic . Please fix it.
In 6.30 (or 6.29) added additional info into netflow packet. If your billing use "poor" netflow packet parsing - you get error.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 1:54 pm
by apathy
traffic flow - not fixed in 6.30.2. Our company uses billing that takes into account the traffic protocol NetFlow. After the upgrade to 6.27 to 6.30.2 missing incoming traffic . Please fix it.
In 6.30 (or 6.29) added additional info into netflow packet. If your billing use "poor" netflow packet parsing - you get error.
Then, from where the outbound traffic and pirng that are considered normal?

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 2:02 pm
by igorvukotic
PPtP is broken in 6.30.2 ( 6.29.1 ) works fine

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 3:44 pm
by Ansy
New device from spare parts, fresh 6.30.2 with 3.24 firmware, old config.

Bridge - Settings - Use IP Firewall still broken:
NewRB750UPoldIssue.png
Frozen interface to configure or just monitor something.
Empty fields/lisits (console too), can't control anything.
Periodically reboots by watchdog, weird log messages.

Well... Trying supout.rif... got crash:
NewRB750UPafterReboot.png
Now continue using RB750UP as dumb PoE bridge again -- no NAT, Firewall, Queues.
Waiting for fix... [Ticket#2015080366000534]­

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 5:16 pm
by paoloaga
Another bug:
Selecting multiple routing filters and trying to move them up or down, will only move one random rule of those selected instead of all of them.
Confirmed, it happens to me too, tested on 6.24 through 6.30.2.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 5:35 pm
by ufm
traffic flow - not fixed in 6.30.2. Our company uses billing that takes into account the traffic protocol NetFlow. After the upgrade to 6.27 to 6.30.2 missing incoming traffic . Please fix it.
In 6.30 (or 6.29) added additional info into netflow packet. If your billing use "poor" netflow packet parsing - you get error.
Then, from where the outbound traffic and pirng that are considered normal?
At least 6.30 and 6.30.1 ROS have bug in netflow - wrong interface number.
In 6.30.2 _this_ bug it has been fixed (at least in my configuration).
I think you need sniff netflow traffic and start dialog with support.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 7:59 pm
by kitit
How about traceroute? You sure this from the hAP?
I'm sure, then i update to 6.31 RC12 , ping stay normal and then i'm downgrade to 6.27 ping cool.

Re: v6.30.2 bugfix release

Posted: Mon Aug 03, 2015 11:31 pm
by Cha0s
Just upgraded 2 RB2011 from 6.29 to 6.30.2.

Both RBs have identical configuration (active/standby setup).

The standby RB2011 got upgraded ok, no issues so far.
The active RB2011 never came back online after the upgrade.
I just got the same problem today with two CCRs.

It turns out that something has changed with the RouterBOOT in the latest versions causing it to halt on boot.

Let me explain my situation a little bit better.

I have 2 RB2011 and 2 Cisco 3750E (stacked).
Both Cisco are connected with serial to both RB2011 so in case of an emergency I would still be able to manage both switches (if one is down and stack is down).

This setup has worked for well over a year without any problems whatsoever when rebooting the RBs.

In the latest versions of RouterBOOT it seems that when the serial port is connected to the Cisco switch it will get stuck there (I don't know where or why exactly).

Today I installed 2 CCRs with another 2 3750's the same way (cisco's console port to ccr's console port) and after a reboot both CCRs would not boot.
The LCD would show the boot screen and nothing else. Also I noticed that the ports were flapping after a minute or two when it was 'stuck' at boot (I guess it would auto reboot and then get stuck over and over? )

I don't recall anything related to this on any changelog (I may be wrong - please correct me).

How can we revert the behavior to how it worked pre-v6.30?

Re: v6.30.2 bugfix release

Posted: Tue Aug 04, 2015 1:21 am
by myke1124
Is this a new feature in 6.30.2?

/ip firewall connection remove [find]
action timed out - try again, if error continues contact MikroTik support and send a supout file (13)

Re: v6.30.2 bugfix release

Posted: Tue Aug 04, 2015 2:33 am
by pcunite
Connection-Rate does not work in 6.30.2
add action=mark-connection chain=prerouting  
connection-bytes=500000-0 connection-rate=200k-100M new-connection-mark=HTTP_BIG protocol=tcp

Re: v6.30.2 bugfix release - webfig now called webbox drops me an "error 501: not implemented"

Posted: Tue Aug 04, 2015 10:50 am
by paltherr
i tried turning to operate a friends rb450g which came with routeros 3.25. a direct upgrade to 6.30.2 did not work out. next step was upgrading to 4.17 and then the router accepted the 6.30.2 upgrade. there is one strange thing i was not able to resolve so far. it seems that the configuration can be done using winbox.exe but the webinterface gives me an "error 501: not implemented" as soon as i try to login with username: admin and no password set. this is not browser dependent as i tried chrome and firefox.

in the files menu i noticed an empty folder "skins". maybe it has something to do with the problem but i don't know.

any suggestions are welcome.

Re: v6.30.2 bugfix release - webfig now called webbox drops me an "error 501: not implemented"

Posted: Tue Aug 04, 2015 4:37 pm
by pcunite
any suggestions are welcome.
You might try the "netinstall" approach.

Re: v6.30.2 bugfix release

Posted: Tue Aug 04, 2015 4:39 pm
by jheward
With /ip cloud disabled, the router still attempts to resolve cloud.mikrotik.com and sends UDP traffic to 81.198.87.240:15252.

Re: v6.30.2 bugfix release

Posted: Tue Aug 04, 2015 6:18 pm
by IPANetEngineer
Comments and info on the new MikroTik release cycle with bugfix

http://www.stubarea51.net/2015/08/04/mi ... ent-cycle/

Re: v6.30.2 bugfix release

Posted: Wed Aug 05, 2015 12:13 am
by steen
Hello Folks!

We just upgraded whole our environment to this level, no visible problem at any place.

We got one suppout from one RB411 which disappeared from network after that incident and has not been visible since, don't know if it was the upgrade or something else as simple as customer switched off the device.

Another RB333 used as core router :-) started to log relatively many RX errors on it's vlan trunked and none vlan trunked ports, both connected to Cisco 2960 switches. We suspect the device to have some problems so it will be replaced later this week.

Re: v6.30.2 bugfix release

Posted: Wed Aug 05, 2015 1:53 am
by Muzaki
I upgrade my PPPOE-servers to ver 6.30.2 (Using RB 1100x2)

I had to downgrade because my PowerBeams P2P just stopped working for some reason. I did have the time to do any research. I did see a lot of traffic going to the PowerBeams even when the client wasnt connected.

Downgraded to 6.27 and everything went back to normal.

Re: v6.30.2 bugfix release - webfig now called webbox drops me an "error 501: not implemented"

Posted: Wed Aug 05, 2015 11:40 am
by paltherr
any suggestions are welcome.
You might try the "netinstall" approach.
thanks a lot! that did the trick. during upgrade process i noticed some repartitioning/reformating of the internal memory which all the other upgrade methods did not do.

Re: v6.30.2 bugfix release

Posted: Wed Aug 05, 2015 12:38 pm
by Rapesco
Dear MikroTik Support,

ip route pref-src is not working correctly since version 6.30 and later (6.29 and previous version is working fine )

Downgrade to Version 6.29. everything is working correctly.

support.rif and details was submitted by Ticket#2015071966000051 a week ago, but only auto reply from system.

Please follow up, i believe it is small bug and easy to be fixed.

Thank you !

Same problem here, upgraded from 6.27 on two CCR's 1036 ... pref source on route 0.0.0.0/0 doesn't work
Active packages: advanced-tools, mpls, routing, security, system
Firmware: 3.27


Tried to delete/recreate the route ... no effect.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 10:23 am
by mercury13
After upgrade from 6.29.1 to 6.30.2 ROS x86 broken EoIP. Interface is on, state Running (if choose option keep alive, state not running) , but traffic is broken. On all another devices is OK.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 11:20 am
by Kraken2k
I had problems since upgrade from 6.25 to newest version (at last incident it was 6.30.2) on RB1100AHx2 - after few days, the router stopped to respond - still running, reacts to cable connect/disconnect but no response on ethernet ports.

Yesterday I was able to connect to connect using serial port and found everything running as expected, but just no response to network traffic. When attempted to ping local addresses or even 127.0.0.1 I got the error message "No buffer space available" - later I found that an issue with the same symptoms existed in the past and was already fixed (route cache overflow).

Interesting thing is, that we have two RB1100AHx2 routers with the same config (just few different IP addresses), but the second one is just backup with a little traffic and deactivated IPsec tunnels - that one works without any issue so far.

I downgraded from 6.30.2 back to 6.25 which (according to the old thread about this issue) was claimed to fix this issue. We'll see in about 4 days.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 12:15 pm
by keema
+1

Scheduller does not always work. i have a startup script which is sometimes run and sometimes not. it does nothing but get the routerboard data and send it to email. I can see that the script doesn't even start, not that there was a problem with sending an email. But like I said, randomly, sometimes it starts. No clue.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 1:06 pm
by HWTest
Today I tried to switch the SSTP VPN client to "Dial On Demand" but that acts strange and connects and disconnects in cca 1 second pace.
When I disable Dial On Demand the connection works normally.
No session timeout set, idle timeout set to 1 minute.
Tested on RB532 and RB2011UiAS.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 1:08 pm
by andriys
I downgraded from 6.30.2 back to 6.25
I wonder if you managed to make a supout.rif before downgrading. There are so many of us complaining about bug here, and so little actually supplying Mikrotik engineers with enough information to reproduce and fix those bugs...

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 3:10 pm
by avenn
I downgraded from 6.30.2 back to 6.25
I wonder if you managed to make a supout.rif before downgrading. There are so many of us complaining about bug here, and so little actually supplying Mikrotik engineers with enough information to reproduce and fix those bugs...
+1

This is a very important point. IF you can do a BEFORE and AFTER support file where possible. This can greatly aid engineers at Mikrotik and hopefully get to fix quicker.

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 4:28 pm
by Kraken2k
I downgraded from 6.30.2 back to 6.25
I wonder if you managed to make a supout.rif before downgrading. There are so many of us complaining about bug here, and so little actually supplying Mikrotik engineers with enough information to reproduce and fix those bugs...
+1

This is a very important point. IF you can do a BEFORE and AFTER support file where possible. This can greatly aid engineers at Mikrotik and hopefully get to fix quicker.
Not by my own hands - I have just two "autosupout.rif" files (one about 8 hours before the issue and one after downgrade - about 14 hour after the issue), not sure if those will be any good to MikroTik support. If yes, no problem to provide them (everything is for the first time).

Okay, I will be smarter next time - it's hard to think about generating the support file when you sit in front of the console in server room, trying to figure out the issue, knowing that the whole company is in stopped state and everybody is waiting for you to repair the issue as soon as possible (not mentioning people still asking and demand immediate report about the situation, solution and "when it will be operational again, I'm just missing <something important>" talks). When it's the best time to generate the supout file anyway? During the issue (if possible) or after it, in order to provide the best possible information for support (I checked the wiki but found nothing about this)

Re: v6.30.2 bugfix release

Posted: Thu Aug 06, 2015 6:09 pm
by buckthis
I upgraded from v6.31rc12 to v6.31rc14 on a 2011UiAS-2HnD.

Not sure if it's noise....
Logs are showing "tx loop on interface ", wasn't seen on any other version.

Time: Aug/06/2015 10:02:54
Buffer: memory
Topics: interface warning
Message: (unknown): tx loop on interface (1)

----
Maybe this has something to do with my wireless.

I have two cAP 2n devices, controlled via CAPsMAN and with the same SID. The tx loop messages appears right after my phone shifts between CAPs.

See attached.

--- Update ---
Disconnected one of the CAPs and still seeing the warnings. It appears after a wireless device disconnects.

Example of a disconnect: [xxx:94:5E@HomeNet-CAP2 disconnected, received disassoc: sending station leaving (8]

Re: v6.30.2 bugfix release

Posted: Fri Aug 07, 2015 12:21 pm
by andriys
When it's the best time to generate the supout file anyway?
If you see a problem and still have any kind of management access to your router- try making supout.rif immediately before reboot/downgrade/configuration reset/whatever. It may become an invaluable source of information, and you can always just delete it later if it proves to be unnecessary in the end.

Re: v6.30.2 bugfix release

Posted: Fri Aug 07, 2015 7:19 pm
by Chupaka
How can i disable 60+ firewall rules from terminal?
With "fasttrack dummy rule" I can't perform disable [find] because i can't disable dynamic rule.
disable [find dynamic=no]

Re: v6.30.2 bugfix release

Posted: Sun Aug 09, 2015 11:33 pm
by spacemind
6.30.1 and 6.30.2
L2TP client vpn freeze every day and after a restar it works again.

on 6.24 and 6.28 works good.

Re: v6.30.2 bugfix release

Posted: Mon Aug 10, 2015 12:56 pm
by adyb76
Has something changed within OSPF - we've had major issues upgrading and all OSPF related. The upgraded router did not communicate with the lower version router, all our interfaces are nbma.

Had to dive back to 6.7 which is the version I find most stable :(

Re: v6.30.2 bugfix release

Posted: Tue Aug 11, 2015 2:50 am
by zizobaddy
What's new in 6.30.2 (2015-Jul-22 11:17):

*) pptp & l2tp - fixed problem where android client could not connect if
both dns names were not provided (was broken since v6.30);
*) lcd - fix crash (and 100% cpu usage) when interface gets removed from "stats-all" screen
*) tool fetch - fix incomplete ftp download
*) ipsec - fixed crash in when gcm encryption was used
*) certificate manager - fixed memory leak
*) traffic flow - fixed dynamic input/output interface reporting
*) user-manager - fixed username was not shown in /tool user-manager user
*) user-manager - fixed zoom for user-manager homepage when mobile devices used
*) winbox - restrict reversed ranges in dst-port under firewall
*) snmp - fix system scripts table

known issue:
*) Dynamic DNS servers can disappear when "allow-remote-requests" are not enabled
Hi Normis

I keep getting broken package when trying to install 6.30.2 mipsbe additional packages

The system has been upgraded to 6.30.2 already?

zizobaddy

Re: v6.30.2 bugfix release

Posted: Tue Aug 11, 2015 9:45 am
by johnsilver
What's new in 6.30.2 (2015-Jul-22 11:17):

*) pptp & l2tp - fixed problem where android client could not connect if
both dns names were not provided (was broken since v6.30);
nah cool, found this bug too :(
http://forum.mikrotik.com/viewtopic.php ... 20#p494520

Re: v6.30.2 bugfix release

Posted: Tue Aug 11, 2015 10:03 am
by HWTest
I just upgraded our company's CCR1036-8G from 6.3 to 6.30.2 and then upgraded the Firmware from 3.10 to 3.27.

Since upgrading our PPTP VPN connections are dropping randomly with an error "CCP lost compression got our of sync: disabling compression" then the next message is "terminating... - Encryption got out of sync"

Is there anything I can do to resolve this?

I see this was resolved in v6.30 release notes but we never had this error when we were on v6.3.
Disable all compression in the ppp profile.

The compression is useless, and actually hurts performance. (feel free to read up on it to verify)
Yesterday I got the same error on a L2TP/IPsec client.
VPN.jpg
The compression is disabled in ppp profile.
/ppp profile
set *FFFFFFFE idle-timeout=55s use-compression=no use-encryption=required

Re: v6.30.2 bugfix release

Posted: Wed Aug 12, 2015 12:10 am
by amandler
Tools - Traffic Monitor isn't working.
did it work in previous version?
Traffic Flow worked until 6.29. It has been broken since. We are very anxious to see this remedied -- it's an important billing tool for us. Thanks.

Re: v6.30.2 bugfix release

Posted: Wed Aug 12, 2015 1:03 am
by marrold
Is this a new feature in 6.30.2?

/ip firewall connection remove [find]
action timed out - try again, if error continues contact MikroTik support and send a supout file (13)
I have the exact same issue on 6.30.2 running on x86.

Any comment Mikrotik? Shall I send a supout?

Re: v6.30.2 bugfix release

Posted: Wed Aug 12, 2015 9:30 am
by yuanmayi
Connection-Rate does not work in 6.30.2,on 6.24 and 6.28 works good.
 chain=prerouting action=mark-connection new-connection-mark=web-video passthrough=yes protocol=tcp dst-port=80,443,8000,8080 connection-bytes=500000-0 connection-rate=60k-12M log=no log-prefix=""

Re: v6.30.2 bugfix release

Posted: Wed Aug 12, 2015 11:46 pm
by steen
Hello Follks!

All our system is updated to v6.30.2 plus the new wireless cm2 package, without any visible problems, all systems normal.
We have almost all flavors, RB411, RB333, RB433, CRS125, CCR, SXT, SEXTANT RB2011 RB750..

Re: v6.30.2 bugfix release

Posted: Thu Aug 13, 2015 9:00 am
by Genkun
Thanks for the wonderful update. Have had a few snags which we fixed internally but there is one error that is quite prevalent.
/interface wireless channels
add band=5ghz-a/n frequency=5180 list=superchannel2 name=5180 width=20
add band=5ghz-a/n frequency=5190 list=superchannel2 name=5190 width=20
add band=5ghz-a/n frequency=5200 list=superchannel2 name=5200 width=20
add band=5ghz-a/n frequency=5210 list=superchannel2 name=5210 width=20
add band=5ghz-a/n frequency=5220 list=superchannel2 name=5220 width=20
add band=5ghz-a/n frequency=5230 list=superchannel2 name=5230 width=20
add band=5ghz-a/n frequency=5240 list=superchannel2 name=5240 width=20
add band=5ghz-a/n frequency=5250 list=superchannel2 name=5250 width=20
add band=5ghz-a/n frequency=5260 list=superchannel2 name=5260 width=20
add band=5ghz-a/n frequency=5270 list=superchannel2 name=5270 width=20
add band=5ghz-a/n frequency=5280 list=superchannel2 name=5280 width=20
add band=5ghz-a/n frequency=5290 list=superchannel2 name=5290 width=20
add band=5ghz-a/n frequency=5300 list=superchannel2 name=5300 width=20
add band=5ghz-a/n frequency=5310 list=superchannel2 name=5310 width=20
add band=5ghz-a/n frequency=5320 list=superchannel2 name=5320 width=20
add band=5ghz-a/n frequency=5330 list=superchannel2 name=5330 width=20
add band=5ghz-a/n frequency=5340 list=superchannel2 name=5340 width=20
add band=5ghz-a/n frequency=5350 list=superchannel2 name=5350 width=20
add band=5ghz-a/n frequency=5360 list=superchannel2 name=5360 width=20
add band=5ghz-a/n frequency=5370 list=superchannel2 name=5370 width=20
add band=5ghz-a/n frequency=5530 list=superchannel2 name=5530 width=20
add band=5ghz-a/n frequency=5540 list=superchannel2 name=5540 width=20
add band=5ghz-a/n frequency=5550 list=superchannel2 name=5550 width=20
add band=5ghz-a/n frequency=5560 list=superchannel2 name=5560 width=20
add band=5ghz-a/n frequency=5570 list=superchannel2 name=5570 width=20
add band=5ghz-a/n frequency=5580 list=superchannel2 name=5580 width=20
add band=5ghz-a/n frequency=5590 list=superchannel2 name=5590 width=20
add band=5ghz-a/n frequency=5600 list=superchannel2 name=5600 width=20
add band=5ghz-a/n frequency=5610 list=superchannel2 name=5610 width=20
add band=5ghz-a/n frequency=5620 list=superchannel2 name=5620 width=20
add band=5ghz-a/n frequency=5630 list=superchannel2 name=5630 width=20
add band=5ghz-a/n frequency=5640 list=superchannel2 name=5640 width=20
add band=5ghz-a/n frequency=5650 list=superchannel2 name=5650 width=20
add band=5ghz-a/n frequency=5660 list=superchannel2 name=5660 width=20
add band=5ghz-a/n frequency=5670 list=superchannel2 name=5670 width=20
add band=5ghz-a/n frequency=5680 list=superchannel2 name=5680 width=20
add band=5ghz-a/n frequency=5690 list=superchannel2 name=5690 width=20
add band=5ghz-a/n frequency=5700 list=superchannel2 name=5700 width=20
add band=5ghz-a/n frequency=5710 list=superchannel2 name=5710 width=20
add band=5ghz-a/n frequency=5720 list=superchannel2 name=5720 width=20
add band=5ghz-a/n frequency=5730 list=superchannel2 name=5730 width=20
add band=5ghz-a/n frequency=5740 list=superchannel2 name=5740 width=20
add band=5ghz-a/n frequency=5750 list=superchannel2 name=5750 width=20
add band=5ghz-a/n frequency=5760 list=superchannel2 name=5760 width=20
add band=5ghz-a/n frequency=5770 list=superchannel2 name=5770 width=20
add band=5ghz-a/n frequency=5780 list=superchannel2 name=5780 width=20
add band=5ghz-a/n frequency=5790 list=superchannel2 name=5790 width=20
add band=5ghz-a/n frequency=5800 list=superchannel2 name=5800 width=20
add band=5ghz-a/n frequency=5810 list=superchannel2 name=5810 width=20
add band=5ghz-a/n frequency=5820 list=superchannel2 name=5820 width=20
add band=5ghz-a/n frequency=5830 list=superchannel2 name=5830 width=20
add band=5ghz-a/n frequency=5840 list=superchannel2 name=5840 width=20
add band=5ghz-a/n frequency=5850 list=superchannel2 name=5850 width=20
add band=5ghz-a/n frequency=5860 list=superchannel2 name=5860 width=20
add band=5ghz-a/n frequency=5870 list=superchannel2 name=5870 width=20

y
We have the following channels loaded onto some of our units and and specifically we are having an issue with the a/n band on 433 dual interface boards. When upgrading from 6.29.1 to 6.30.2 the channels kick out of the wlan interface and I get an error that states channels not supported which appears on the wlan interface display.

Re: v6.30.2 bugfix release

Posted: Thu Aug 13, 2015 11:50 am
by hailnora
Hey guys,

just updated my RB-800 from 6.27 to 6.30.2 and firmware from 3.22 to latest. Device works as access point with sector antenna.
Looks like everything works well for me.
Cheers

Re: v6.30.2 bugfix release

Posted: Fri Aug 14, 2015 3:18 pm
by Kraken2k
I had problems since upgrade from 6.25 to newest version (at last incident it was 6.30.2) on RB1100AHx2 - after few days, the router stopped to respond - still running, reacts to cable connect/disconnect but no response on ethernet ports.

Yesterday I was able to connect to connect using serial port and found everything running as expected, but just no response to network traffic. When attempted to ping local addresses or even 127.0.0.1 I got the error message "No buffer space available" - later I found that an issue with the same symptoms existed in the past and was already fixed (route cache overflow).

Interesting thing is, that we have two RB1100AHx2 routers with the same config (just few different IP addresses), but the second one is just backup with a little traffic and deactivated IPsec tunnels - that one works without any issue so far.

I downgraded from 6.30.2 back to 6.25 which (according to the old thread about this issue) was claimed to fix this issue. We'll see in about 4 days.
So downgrade did not help - it happened again. When the cache size exceeded the maximum sice, router stopped to respond. We are now running on the 6.30.2 and the cache is growing again: 83% and still growing :( so I bet there will be another crash soon (we have a lot of traffic through IPsec tunnels nowdays).

I have supout.rif from the last incident before reboot (the one from 6.25 version) - sent it via https://www.mikrotik.com/client/?ecom=support together with report, but got no response so far. Is that actually correct way how to report?

Re: v6.30.2 bugfix release

Posted: Fri Aug 14, 2015 3:21 pm
by normis
Kraken2k did you get a ticket number as a response? Normally you would just email support@mikrotik.com, the form is just a shortcut to the same. Sent it from your email and see if you get a ticket number.

Re: v6.30.2 bugfix release

Posted: Sun Aug 16, 2015 8:56 pm
by _saik0
I'm still having constant router reboots, whenever my PPPoE connection is reset.

A week or so ago (ROS x86 6.28) i had almost daily reboots, ALWAYS
exactly when my ISP PPPoE connection gets reset (24hrs mandatory
reconnect). I'm suspecting this has to do either with PPPoE or more
likely IPsec as the SAs towards my VPN endpoints have to be renewed
and i know for a fact this hasn't been very reliable in the past.

Then i upgraded to 6.30.2 and was pleasantly surprised as my uptime
went beyond 7 days. Sadly today after 10 days the same issue happened.

Wrote a ticket, hoping for the best..

This is happening only on my main x86 ROS.
rb2011 on remote locations don't suffer from this (more or less similar config, ipsec/l2tp vpn p2p links with ospf).

Re: v6.30.2 bugfix release

Posted: Mon Aug 17, 2015 7:31 am
by chechito
firewall rule CONNECTION RATE option not working

http://wiki.mikrotik.com/wiki/Manual:Connection_Rate

Re: v6.30.2 bugfix release

Posted: Wed Aug 19, 2015 5:58 am
by fifapuissan
sorry , I dont know

Re: v6.30.2 bugfix release

Posted: Tue Aug 25, 2015 12:23 pm
by Kraken2k
Kraken2k did you get a ticket number as a response? Normally you would just email support@mikrotik.com, the form is just a shortcut to the same. Sent it from your email and see if you get a ticket number.
Hi, yes - I sent an e-mail with and got the ticket number #2015081766000633

As advised, I disabled the route-cache in /ip settings but it did not help. We had another cache overflow yesterday (with this setting already active) and since then the cache is constantly growing again.

Re: v6.30.2 bugfix release

Posted: Wed Aug 26, 2015 10:55 am
by strods