Community discussions

MikroTik App
 
jimmyz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 02, 2014 10:10 pm

Turn off LEDs using the MODE button

Sat Feb 08, 2020 11:06 am

Well, Hello everyone!

I've been looking the wiki for the nesseccery commands I need to activate the dark-mode (turn off LEDs using the MODE button) on a RBcAPGi-5acD2nD, that I had just reset to no defaults. I couldn't find anything, so I had to reset again to defaults to get it.
So, just in case if anyone ever needs it again, I will put it here.
/system script
add comment=defconf dont-require-permissions=no name=dark-mode owner=jimmyz policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\r\
    \n   :if ([system leds settings get all-leds-off] = \"never\") do={\r\
    \n     /system leds settings set all-leds-off=immediate \r\
    \n   } else={\r\
    \n     /system leds settings set all-leds-off=never \r\
    \n   }\r\
    \n "
/system routerboard mode-button
set enabled=yes on-event="system script run dark-mode"
If it is correct, maybe someone of the admins can publish it under Device Information
Thank you :)!
 
SnkB
just joined
Posts: 11
Joined: Sun Apr 12, 2020 8:19 pm

Re: Turn off LEDs using the MODE button

Tue Apr 14, 2020 11:11 pm

Well, Hello everyone!

I've been looking the wiki for the nesseccery commands I need to activate the dark-mode (turn off LEDs using the MODE button) on a RBcAPGi-5acD2nD, that I had just reset to no defaults. I couldn't find anything, so I had to reset again to defaults to get it.
So, just in case if anyone ever needs it again, I will put it here.
/system script
add comment=defconf dont-require-permissions=no name=dark-mode owner=jimmyz policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\r\
    \n   :if ([system leds settings get all-leds-off] = \"never\") do={\r\
    \n     /system leds settings set all-leds-off=immediate \r\
    \n   } else={\r\
    \n     /system leds settings set all-leds-off=never \r\
    \n   }\r\
    \n "
/system routerboard mode-button
set enabled=yes on-event="system script run dark-mode"
If it is correct, maybe someone of the admins can publish it under Device Information
Thank you :)!
Hello Friend!
That was exactly what I was needing, but in my RB it didn't work (760iGS)
It only deactivates the blue power led, the activity LEDs on the ether ports remain on, as well as the PoE Out.
Do you have any idea what I can modify?
 
jimmyz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 02, 2014 10:10 pm

Re: Turn off LEDs using the MODE button

Fri Apr 17, 2020 10:33 pm

Hello,
I read in wiki.mikrotik.com/wiki/Manual:System/LEDS:

RouterBoard LED description
RB760iGS (hEX S) Turns off Power LED and SFP LED


So I think it is hardware restriction.

The new help page is maybe wrong.
 
msatter
Forum Guru
Forum Guru
Posts: 2012
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Turn off LEDs using the MODE button

Sat Apr 18, 2020 2:41 am

The wiki page is correct and Becs corrected it from all to only the Power LED and SFP leds.

https://wiki.mikrotik.com/index.php?tit ... ldid=33661
Loving my freedom and so, no Twitter, no Facebook/Instagram/WhatsApp, no Apple and no Google/Alphabet.

Running:
RouterOS 6.48 / Winbox 3.27 64bits
 
jimmyz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 02, 2014 10:10 pm

Re: Turn off LEDs using the MODE button

Sat Apr 18, 2020 12:05 pm

Hi,
it really is not important, but the wiki page was correct, what did becks corrected?
Help page is still wrong.
 
msatter
Forum Guru
Forum Guru
Posts: 2012
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Turn off LEDs using the MODE button

Sat Apr 18, 2020 1:03 pm

By helppage you mean the Manual inside Winbox. That is displaying the Wiki and states:

RB760iGS (hEX S) Turns off Power LED and SFP LED


On the RB760iGS you can only control the Power and SFP LED.
Loving my freedom and so, no Twitter, no Facebook/Instagram/WhatsApp, no Apple and no Google/Alphabet.

Running:
RouterOS 6.48 / Winbox 3.27 64bits
 
jimmyz
Frequent Visitor
Frequent Visitor
Topic Author
Posts: 53
Joined: Wed Jul 02, 2014 10:10 pm

Re: Turn off LEDs using the MODE button

Sat Apr 18, 2020 6:04 pm

Thank you, have a nice time!
 
msatter
Forum Guru
Forum Guru
Posts: 2012
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: Turn off LEDs using the MODE button

Sat Apr 18, 2020 11:20 pm

I just noticed the the new docs is not updated on this.

https://help.mikrotik.com/docs/display/ ... ion-Health
Loving my freedom and so, no Twitter, no Facebook/Instagram/WhatsApp, no Apple and no Google/Alphabet.

Running:
RouterOS 6.48 / Winbox 3.27 64bits

Who is online

Users browsing this forum: No registered users and 49 guests