Community discussions

 
Atlantis
just joined
Topic Author
Posts: 13
Joined: Wed Dec 17, 2014 9:01 pm

hAP ac - USB modem reboots RB - bad power supply design?

Thu Mar 24, 2016 2:10 pm

Hello, I recently upgraded RB951G to hAP AC. But unpleasant problem showed up - when I connect some devices to USB - in my case LTE modem ZTE MF823, the hAP AC reboots. I have 2 units, both do the same. The same thing happens when I do USB power reset from terminal. I investigated more and it looks like the +5V power supply for whole RB is overloaded by charging some capacitors inside USB device (in my case the modem). And also I don't know the topology inside, but it looks like there is not much voltage tolerance for the +5V. I tried testing it more and I tried just 100uF ceramic capacitor (had it laying around, probably the issue will express even with smaller one) with 1k resistor (parallel to discharge) connected to USB will reboot whole RB! And it stays in boot-loop - because when it reboots it disconnects USB power, capacitor discharges and connects it after booting. And it causes it to reboot and again, again, again...With the modem insted my test-setup it just reboots, not end up in boot-loop like with my test setup. Probably because the modem will not discharge the internal capacitors down to 0V so it is softer on the power supply on next connection.

After connecting the USB load, the voltage on main 5V capacitor dropped about 0.4V and then some watchdog shut down the power supply and then restarted it again.
See attached image. USB connection caused the small drop right when the oscilloscope triggered, the rest is some shutdown watchdog followed by some off-delay and then startup.

Personally for me it was quite problem because I sometimes need to reset the LTE modem from script and doing this restarts whole RB!

I figured solution - I connected 2200uF capacitor (probably unnecessary big one, but I had it in my drawer :D ) parallel to +5V rail and now it works fine. Maybe your HW guys should look into it because the older RB951 worked fine.
You do not have the required permissions to view the files attached to this post.
 
psurmont
just joined
Posts: 17
Joined: Wed Dec 28, 2016 3:15 am

Re: hAP ac - USB modem reboots RB - bad power supply design?

Wed Dec 28, 2016 3:19 am

Hi,

Seems i m experiencing the same problem. Can sent me a blue print of your solution, i m french and i dont really get your explanations.

Thanks in advance


best regards
 
kristaps
Member Candidate
Member Candidate
Posts: 272
Joined: Mon Jan 27, 2014 1:37 pm

Re: hAP ac - USB modem reboots RB - bad power supply design?

Thu Dec 29, 2016 1:35 pm

Hello could you both please send supout.rif to support@mikrotik.com ?

This issue should be fixed in newer revision model hAP ac,
 
psurmont
just joined
Posts: 17
Joined: Wed Dec 28, 2016 3:15 am

Re: hAP ac - USB modem reboots RB - bad power supply design?

Thu Dec 29, 2016 11:16 pm

HI,
You will have to wait until i get a new one ... Taking off and on the Alcatel USB Key, the rb 951 exploded. I will have a new one around the 3rd of January so i can test if i m experiencing the same issue.

Best regards
 
psurmont
just joined
Posts: 17
Joined: Wed Dec 28, 2016 3:15 am

Re: hAP ac - USB modem reboots RB - bad power supply design?

Wed Jan 04, 2017 4:09 am

OK, i got my new RB951 and the first time i used it, it worked fine except that when i was trying to see the package, the files and the ressources nothing was displayed. I couldn't neither use the reboot button nor use the shutdown menu. I had to restart it manually and this time i had all the info displayed on each options. after 1 minute of use, the RB rebooted and the log entry: system, error, critical: router was rebooted without proper shutdown by watchdog timer. it did it a second time few seconds after with the same message. Since this second reboot it seems to work fine. Info are displayed on command windows. I send you the supout.rtf file i generated after this second reboot.

PS: when i wanted to send you this post, i realized i didn't have internet anymore. and most of the fonctions of my rb951 were stucked. I had to restart it manually. It happened again after 1 minutes it rebooted with the critical error. i will regenerate the supout and will send u both.

best regards.

Pierre
 
psurmont
just joined
Posts: 17
Joined: Wed Dec 28, 2016 3:15 am

Re: hAP ac - USB modem reboots RB - bad power supply design?

Thu Jan 05, 2017 3:26 am

Hello

I dont know if i had the same problem after all but i definitely had the same symptoms. The support just told me to install the 6.38 package. Thats what i did and now everythings seems to be fine and my router does not reboot continuously.


Thanks to the support.


BRGDS

Pierre
 
raidu
just joined
Posts: 5
Joined: Sun Jun 12, 2016 3:29 pm

Re: hAP ac - USB modem reboots RB - bad power supply design?

Tue Mar 21, 2017 6:50 pm

It seems that the newer batch of hAP lite (classics) come with bad power supplies.

I have 2 from newer batches where the PSU is 1A. (Older ones have 0.5A PSUs)
The microUSB connectors are such a bad quality that with slight movement the power is gone.
No problems with the "old" PSUs
 
User avatar
karina
Member
Member
Posts: 446
Joined: Sat Feb 06, 2010 2:18 am
Location: Spain

Re: hAP ac - USB modem reboots RB - bad power supply design?

Thu Apr 27, 2017 5:26 pm

It seems that the newer batch of hAP lite (classics) come with bad power supplies.

I have 2 from newer batches where the PSU is 1A. (Older ones have 0.5A PSUs)
The microUSB connectors are such a bad quality that with slight movement the power is gone.
No problems with the "old" PSUs
I have just received a batch with the same problem. Hate Micro usb at best of times let alone on a device like this. Will report this to MT

Who is online

Users browsing this forum: No registered users and 14 guests