Community discussions

 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Mar 24, 2016 2:26 pm

Hi,

we got 6 RB962UiGS-5HacT2HnT but the performance in our network is horrible. So we tried to play with it a little bit and compared it to Ruckus which has steady results around 150 Mbit/sec. We tried the default settings with 6.34.3 and we got following results on iperf:
0.00-10.00 sec 48.0 MBytes 40.3 Mbits/sec sender
which is not really good. So we played with it a lot ..

today, we tried 6.35 RC41 with wireless-rep and latest firmware
The results were following:
0.00-10.00 sec 3.50 MBytes 2.94 Mbits/sec sender
Which is really horrible.
But then, desperatelly clicking around we disabled under IP settings to uncheck Allow Fast Path and uncheck Allow Fast Path under Bridge Settings... then we got this result:
0.00-10.00 sec 119 MBytes 99.6 Mbits/sec sender
Which is useful, on receiving side we got around 200Mbit/sec even after reboot

So I want to ask what can be wrong? Why is fast path doing this? We tried to uncheck this on 6.34.3, but it had effect until the device was rebooted and then no matter what you check its doing crappy.

The config that was loaded on that worst result is following:
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
/interface bridge
add admin-mac=E4:8D:8C:49:1E:94 auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce \
    distance=indoors frequency=auto mode=ap-bridge ssid=MikroTik-491E9A \
    wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-Ce \
    disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=\
    MikroTik-491E99 wireless-protocol=802.11
/ip neighbor discovery
set ether1 discover=no
set bridge comment=defconf
/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa2-psk eap-methods="" mode=\
    dynamic-keys wpa2-pre-shared-key=PASS
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf interface=sfp1
add bridge=bridge comment=defconf interface=wlan1
add bridge=bridge comment=defconf interface=wlan2
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=\
    192.168.88.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=\
    ether1
/ip dhcp-server network
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=input comment="defconf: drop all from WAN" \
    in-interface=ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add chain=forward comment="defconf: accept established,related" \
    connection-state=established,related
add action=drop chain=forward comment="defconf: drop invalid" \
    connection-state=invalid
add action=drop chain=forward comment=\
    "defconf:  drop all from WAN not DSTNATed" connection-nat-state=!dstnat \
    connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" \
    out-interface=ether1
/system leds
set 1 interface=wlan2
/system routerboard settings
set cpu-frequency=720MHz protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge
I know my firend is having the same AP, with 6.34.2 with much better performance in almost default config. So I think this series might be faulty? Should we return all of them? The iperf is showing over 800Mbit/s when we try this over one of the ethernet ports on HAP AC (EDIT: just one way as we found out later on). LAN is connected to ether1.
Last edited by aa007 on Tue Mar 29, 2016 7:22 pm, edited 4 times in total.
 
Naurislv
newbie
Posts: 47
Joined: Tue May 06, 2014 11:29 am

Re: HAP AC faulty seriers - very poor wireless performance?

Thu Mar 24, 2016 2:48 pm

Thank you for report.

This definitely is not ok and we'd like help you to resolve this issue. Please write to support@mikrotik.com and add this forum link as reference and attach supout file of hAP ac board.
 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

Re: HAP AC faulty seriers - very poor wireless performance?

Tue Mar 29, 2016 4:19 pm

So after some more testing we decided to get SFP S-RJ01 - and guess what - everything is running very smooth and fast - over 500Mbit/s with wireless-rep symetric

So we tested some more and we suspect that the switch might be the source of problems, because when we tested on wired connection with SFP for WAN and ETHER1 for LAN we get following: When we run iperf with -R option, we get 838 Mbits/sec but, without -R option we get only 68.5 Mbits/sec!

When we switch from SFP to ETHER1 for WAN and ETHER2 for LAN we get 34.8 Mbits/sec upload and 18.5 Mbits/sec download with iperf.

Just to be sure, we tried older RB951G - we wiped all settings, then we just briged ether1 and ether2 and ran iperf - it was around 900Mbit/s both ways.

So ... changing wireless package to wireless-rep fixes part of the problem, but it seems the switch is source of the problem also - is anybody else experiencing this? I tested two HAP AC with the same result. Both have qca-8337 switch installed, RB951G has Atheros 8327

Unfortunately we need PoE to run the APs, so its unusable like this for us. So I guess we should return all of them...
 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue Mar 29, 2016 6:35 pm

So we got one more HAP AC and it is working correctly. So its definitely a faulty series.
The one that is OK has SN: 6737055FAF54
Two APs tested today, that have this poor result have SN:
6737051BD37F
673705E06641
I will test the rest tomorrow.

Too bad, that support is not responding at all - so I guess there is no other choice than to return all of them. Really disappointing - I would recommend to all customers who want to buy HAP AC to wait some time until this is somehow resolved or to choose different product.
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Mar 30, 2016 9:14 am

Did you email support? What is your ticket number (you got one in the auto reply)?
No answer to your question? How to write posts
 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Mar 30, 2016 11:29 am

Hi, so we have found the source of the problem - its temperature. We cooled down the unit to 15°C and started testing.

The results were following with iperf and System/Health temp:
15 °C
0.00-10.00 sec 924 MBytes 776 Mbits/sec sender
0.00-10.00 sec 848 MBytes 711 Mbits/sec receiver

23 °C
0.00-10.00 sec 796 MBytes 668 Mbits/sec sender
0.00-10.00 sec 675 MBytes 566 Mbits/sec receiver

26 °C
0.00-10.00 sec 592 MBytes 497 Mbits/sec sender
0.00-10.00 sec 495 MBytes 415 Mbits/sec receiver

30 °C
0.00-10.00 sec 243 MBytes 204 Mbits/sec sender
0.00-10.00 sec 324 MBytes 272 Mbits/sec receiver

34 °C
0.00-10.00 sec 140 MBytes 118 Mbits/sec sender
0.00-10.00 sec 82.4 MBytes 69.1 Mbits/sec receiver

36 °C
0.00-10.00 sec 50.1 MBytes 42.0 Mbits/sec sender
0.00-10.00 sec 48.2 MBytes 40.5 Mbits/sec receiver

43 °C
0.00-10.00 sec 10.9 MBytes 9.12 Mbits/sec sender
0.00-10.00 sec 8.75 MBytes 7.34 Mbits/sec receiver

The ticket number is 2016032466000618 and it seems there is already more people having this issue with HAP AC: http://forum.mikrotik.com/viewtopic.php?f=13&t=105764
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 01, 2016 12:03 am

is this repeatable across all 6 routers?
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 01, 2016 11:36 am

Please send the units for warranty repair, so we can inspect them and run the same tests.
No answer to your question? How to write posts
 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 01, 2016 1:10 pm

It is reproducible on 2 units. For the rest it was enough to use wireless-rep package with 6.35RC ROS - problem was occurring with some Intel wireless cards (eg. Intel Dual Band Wireless-AC 8260 in Lenovo Yoga 900), but using wireless-rep is fixing that.
So after we get some kind of replacement for those heat affected units we will send those back to you.
 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Mon May 27, 2013 3:05 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Apr 06, 2016 5:17 am

I have been experiencing the same issue on the excellent hAP ac and have found:
- the low bandwith (17-57Mb/s) varies with temperature
- it occurs with certain ethernet phys and not others
- when it occurs, I see receive issues, suggesting the root cause is the transmit from the QCA8337 switch chip
- the temperature of the heatsinks on the QCA8337 are fine, suggesting there is sufficient PCB thermal coupling (ie there isn't an PCB error with thermal relief for soldering)

This all points to an issue with QCA8337 phy programming, so is highly likely fixable in software; this makes sense since it is newly introduced and has new mac and phy power-saving features which may cause compatibility issues with some equipment.

I can't reproduce the issue against Intel ethernet macs and phys, but I can with an Asix AX88179 USB3 to ethernet adapter, which shows a low rate of receive errors. The QCA8337 side shows no errors in the stats.

@Mikrotik, let me know if you need more data/info/testing. I can hook up my 200MHz scope if needed.

Daniel
 
brosky
Frequent Visitor
Frequent Visitor
Posts: 71
Joined: Fri Mar 27, 2009 3:43 pm
Contact:

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 07, 2016 8:41 pm

hah, it seems that I have the same problem.

SN: 673705914040 / 603

After unboxing I tested and got constant 250mbps in AC in the first day but afterwards I can't get over 30Mbps , even at close distance.

I can post videos of this, hopefully we'll get a fix for this.
 
User avatar
DanielJB
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Mon May 27, 2013 3:05 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 15, 2016 9:20 am

Using another USB to Ethernet adapter with the Realtek RTL8153 chip (Dell "USB-C to Ethernet adapter"), I see wire-speed in both directions.

This correlates that the issue is a phy setup/programming issue.
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Sat Apr 16, 2016 2:13 am

This correlates that the issue is a phy setup/programming issue.
Good news.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue Apr 19, 2016 8:14 pm

Hi,

I also have a weird problem with ethernet performance of HAP AC (6.35). Here is the summary:

The good:
1. The Speedtest.net over both wireless (ac) and ethernet gives the same result on the same server;
2. Ethernet performance in local network is also good. Copied a file from one PC to another, almost got a gigabit.

The bad:
1. The actual internet speed on ethernet is awful. On wireless it's ok (so it's not an ISP issue). I get normal speeds when downloading a file over wireless and I get very poor performance on wired. So speedtest.net is ok, every other thing I try is not ok. For example on whatbox.ca/speedtest over wireless I get > 5 MiB/s and over wired I get < 300 KiB/s!

UPDATE. Seems that speed drop over ethernet appears only when downloading files from relatively distant servers. Again, the wireless is good.
UPDATE2. I bought the HAP AC as a replacement to RB951G-2HnD and the latter works as expected.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 739
Joined: Mon May 14, 2012 9:30 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Apr 20, 2016 1:00 am

The one I am testing has horrible wlan performance. Pings are long. Downloads seem to top out around 11-15Megs on 2.4. 56 on 5 gig.

I unplugged it and put the 951G back in and get closer to 65 on 2.4. Pings are much faster too.

Tried hard wiring into the unit and got the full bandwidth from my isp of 122.

So this is fully a wireless issue on my bench.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Apr 20, 2016 7:27 am

The one I am testing has horrible wlan performance. Pings are long. Downloads seem to top out around 11-15Megs on 2.4. 56 on 5 gig.

I think I had a similar issue with 2.4 band. It seems there is a bug in current software and the workaround for me was setting the 2.4 wireless channel to auto. Any other value was drastically dropping the 2.4 wireless speeds. If this doesn't work, try to reset the configuration.
 
gotsprings
Forum Veteran
Forum Veteran
Posts: 739
Joined: Mon May 14, 2012 9:30 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Apr 20, 2016 7:51 pm

The one I am testing has horrible wlan performance. Pings are long. Downloads seem to top out around 11-15Megs on 2.4. 56 on 5 gig.

I think I had a similar issue with 2.4 band. It seems there is a bug in current software and the workaround for me was setting the 2.4 wireless channel to auto. Any other value was drastically dropping the 2.4 wireless speeds. If this doesn't work, try to reset the configuration.
I am running it off CapsMan if that makes any difference.

But let us not forget that the 5G Speeds Suck Too.
"It ain't what you don't know that gets you into trouble. It's what you know for sure that just ain't so."
Mark Twain
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 21, 2016 5:44 pm

Hi,

I also have a weird problem with ethernet performance of HAP AC (6.35). Here is the summary:

The good:
1. The Speedtest.net over both wireless (ac) and ethernet gives the same result on the same server;
2. Ethernet performance in local network is also good. Copied a file from one PC to another, almost got a gigabit.

The bad:
1. The actual internet speed on ethernet is awful. On wireless it's ok (so it's not an ISP issue). I get normal speeds when downloading a file over wireless and I get very poor performance on wired. So speedtest.net is ok, every other thing I try is not ok. For example on whatbox.ca/speedtest over wireless I get > 5 MiB/s and over wired I get < 300 KiB/s!

UPDATE. Seems that speed drop over ethernet appears only when downloading files from relatively distant servers. Again, the wireless is good.
UPDATE2. I bought the HAP AC as a replacement to RB951G-2HnD and the latter works as expected.
UPDATE3. I've done some additional testing, plugged off the router from power source, after an hour plugged in. Guess what? Speeds were ok, this means that the other guys here are right: temperature is what causes the speed drop. After some playing the speeds went down again. Quick re-plugging didn't help. However when touching the device in normal use (when speeds are low) I don't feel like it's too hot.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Sun Apr 24, 2016 9:08 pm

UPDATE4. Indeed, cooling down the router in a refrigerator a bit fixes all the symptoms.
UPDATE5.

The customer support has suggested a test: to put the ethernet interfaces into a bridge (after setting master-port=none). I think, the intention of this was to check whether the problem comes from the switch chip. I was pretty sure it was... Because the wireless works, and wireless is in a bridge mode. However, the symptoms were the same even after putting all the ports into a bridge.

To sum up:
- Wireless seems to work normal in every condition;
- Wired works normal when in a local network (gigabit download/ upload); when the download server is near (e.g. in same country); when testing through Speedtest.net (regardless of the server location - this is the strangest part)...;
- Wired works terrible when the download server is relatively far from you. However, this also doesn't happen when the router is cool. In normal working temperatures (system-health) of 55C I get less than 2Mbps (yes, megabits). It seems that the speed drop (e.g. 2Mbps when the temperature is 55C) occurs on every single connection: when using torrents I get the same speed drop on each connection; the total download speed may still be high;
- The good-old 951G seems to work ok on the same ISP;
- Bridging the ethernet ports doesn't improve anything: this may suggest that the problem is not in the switch chip itself;
- Support says that they never had a faulty HAP AC unit of this kind: this means either 1. there is only a batch of faulty HAP AC's; 2. all the HAP AC's are the same: there are conditions, which were not been covered by Mikrotik's testing, at which the problems appear.

In my opinion there is no faulty batch of these units. I think the issue we experience appears as a coincidence of a software (maybe driver) bug in RouterOS somehow related to temperature (kind of cpu throttling) + some ISP's non-standard infrastructure configuration. This can explain why:
1. Only fraction of users experience this kind of problems on HAP AC: those may have ISP's with different infrastructure;
2. Mikrotik testing didn't detect anything: in local networks + in local area (like in same region) these units work fine. Also Speedtest.net globally works fine. Also maybe (?) their ISP (ISPs) have "normal" infrastructure.
3. The older boards work fine for us: those are cooler. Those don't have 2 different wireless chips, POE output...

What I'm going to do is checking my old 951G router speed correlation with the temperature. Maybe I just wasn't noticing that (because it was cooler, thus faster). Unfortunately this is not going to be in near days: I've already spent to much time with these things...

Doesn't anybody from Mikrotik want to respond here?
 
kenyloveg
Frequent Visitor
Frequent Visitor
Posts: 75
Joined: Tue Jul 14, 2009 3:25 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue Apr 26, 2016 4:24 am

Thanks @TaurusThree for your test.
Can anybody else own a HAP AC confirm this issue?
How long would it take Mikrotik guys to confirm this and release a firmware/software fix? I'm holding to buy some HAP AC while this faulty is not acceptable for me.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue Apr 26, 2016 10:12 pm

this sucks, i bought one of these as well, is there a way to force the issue for testing?
 
User avatar
pcunite
Forum Veteran
Forum Veteran
Posts: 945
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Apr 27, 2016 4:21 pm

this sucks, i bought one of these as well, is there a way to force the issue for testing?
Point a blow dryer at it and make sure it only goes up to 55C (/system health print).

To the OP, please try down-clocking the CPU to 600Mhz (/system routerboard settings print)
 
marekm
Member Candidate
Member Candidate
Posts: 195
Joined: Tue Feb 01, 2011 11:27 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 28, 2016 10:29 am

Low speeds from distant servers can be explained by packet loss.
See the formula for throughput of a TCP connection:
http://en.wikipedia.org/wiki/TCP_tuning#Packet_loss

Even small packet loss like 0.1%, combined with typical RTT over the Internet, is significant. TCP just works that way, remember it was invented when speeds were much lower than they are today. Multiple parallel TCP connections will give better results.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 28, 2016 10:31 am

Low speeds from distant servers can be explained by packet loss.
See the formula for throughput of a TCP connection:
http://en.wikipedia.org/wiki/TCP_tuning#Packet_loss

Even small packet loss like 0.1%, combined with typical RTT over the Internet, is significant. TCP just works that way, remember it was invented when speeds were much lower than they are today. Multiple parallel TCP connections will give better results.
But why it is correlated with Mikrotik's temperature? When it's relatively cool, I have 0 problem. When it's relatively hot I have problems only with distant servers. EDIT. ok, silly question. The unit itself may be the packet loss source. Esp. when the temperature is high.

But, how does the Speedtest.net show better results even with distant servers in that case? EDIT. another silly question: Speedtest.net uses multiple connections.

Well... This sucks!
 
marekm
Member Candidate
Member Candidate
Posts: 195
Joined: Tue Feb 01, 2011 11:27 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 28, 2016 12:40 pm

Packet loss increasing with temperature looks very much like a hardware issue - marginal Ethernet PHY, not likely to be fixable by software. Could be bad chips, bad capacitors (more likely ceramic ones, as electrolytics are worse when cold) etc. See if you could get more stable throughput by changing from 1G to 100M link.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Apr 28, 2016 3:26 pm

Packet loss increasing with temperature looks very much like a hardware issue - marginal Ethernet PHY, not likely to be fixable by software.
What rate of packet loss is considered as acceptable? From the router's terminal I've done ping test to the server of my ISP and got approx 0.05% packet loss (out of 25000 packets of size 1460 Bytes; the average ping was 1ms; the board temperature was 54C).

The average ping to European servers (I have an FTP server in Netherlands; and I am from Armenia) is 68ms.
After entering these values (MSS 1460; RTT 68; Loss 0.05%) in this calculator (http://www.switch.ch/network/tools/tcp_throughput/) I get network limit: 7.68 Mbit/sec. Which more or less matches with the speed drop I get at that temperature.

So the question is: is this a warranty case?
Also, do the previous boards also suffer from this? Probably less emphasized because those were little bit cooler?
 
marekm
Member Candidate
Member Candidate
Posts: 195
Joined: Tue Feb 01, 2011 11:27 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 29, 2016 12:34 pm

Ethernet, if done properly and not congested, should have practically zero packet loss (OK, nothing is perfect so let's say 0.0001% or one in a million). The square root in the formula means for 10 times more speed, you need 100 times lower loss. Yes, I'd suggest to RMA it. I'll have to test my own hAP-ac too to see if it's affected. Temperatures in this range should have no effect on properly working electronics, something is seriously wrong with just these boards.

I've just found an interesting article about one possible cause (which may or may not be the case here, it's just an example of possible caveats that can affect any modern electronic devices):

http://www.edn.com/design/analog/440204 ... -capacitor
 
R1CH
Forum Veteran
Forum Veteran
Posts: 879
Joined: Sun Oct 01, 2006 11:44 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Apr 29, 2016 6:36 pm

Just to clarify, does this only affect ethernet <-> ethernet connectivity? Eg if using the hAP AC solely as an access point bridged onto ether1, there won't be any issues?
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue May 03, 2016 5:22 am

received my unit, its a EU model, i changed nothing outside of the default config, short of wireless width settings and ssid names,

upgrade to 6.35.1 3.31 with no issue


ran iperf with timer for 600 seconds with 11 parallel streams started at 44C ambient temp. eth port3,4 in switch mode. test ran at 940mbit for the duration of the test, while reaching a total temperature of 58C with 0 issues

then i ran it again over wireless 7260 intel card 2x2 866 link, and it was stable around 250mbit/32MB for the entire test as well all the way up to 57C with no loss.

outside of my voltage indicating 16v when in reality its 23, and a changing color led for wireless. i don't seem to be affected

if there is anything else to test lmk
 
shovon
just joined
Posts: 24
Joined: Sat May 07, 2011 9:31 am
Location: Dhaka, Bangladesh
Contact:

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri May 06, 2016 8:24 am

received my unit, its a EU model, i changed nothing outside of the default config, short of wireless width settings and ssid names,

upgrade to 6.35.1 3.31 with no issue


ran iperf with timer for 600 seconds with 11 parallel streams started at 44C ambient temp. eth port3,4 in switch mode. test ran at 940mbit for the duration of the test, while reaching a total temperature of 58C with 0 issues

then i ran it again over wireless 7260 intel card 2x2 866 link, and it was stable around 250mbit/32MB for the entire test as well all the way up to 57C with no loss.

outside of my voltage indicating 16v when in reality its 23, and a changing color led for wireless. i don't seem to be affected

if there is anything else to test lmk

* connect through any ethernet port using Winbox, see if it disconnects you in every few minutes.
 
littlebill
Member Candidate
Member Candidate
Posts: 231
Joined: Sat Apr 30, 2011 3:11 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri May 06, 2016 6:05 pm

i do not have winbox disconnect problems, winbox has been open well over a hour with 0 issues, its generally all i use for configuration
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 793
Joined: Tue Aug 03, 2004 9:01 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed May 11, 2016 3:34 pm

Just to clarify, does this only affect ethernet <-> ethernet connectivity? Eg if using the hAP AC solely as an access point bridged onto ether1, there won't be any issues?
This is what it is sounding like to me, which probably means it is an issue just with transmitting on ethernet port, not receiving. RX from WAN -> TX to WLAN == good speed, RX from WAN -> TX to LAN == bad speed.

If this is the case, then it could also be that download from the internet is very fast, but upload is being constrained. But you might not notice a problem unless you have a very fast symmetric internet connection from your provider.

I just got my hAP and have not gone through testing yet, but you can be sure that I will try to be very thorough after reading through this thread...

-- Nathan
 
User avatar
normis
MikroTik Support
MikroTik Support
Posts: 24059
Joined: Fri May 28, 2004 11:04 am
Location: Riga, Latvia

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed May 11, 2016 3:55 pm

If you experience this kind of problem, please return the unit to the seller for RMA processing. We are looking into this issue and it would help if we could have some of these devices back for more testing.
No answer to your question? How to write posts
 
vortex
Forum Veteran
Forum Veteran
Posts: 712
Joined: Sat Feb 16, 2013 6:10 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu May 12, 2016 11:01 pm

I think this might explain the low stock levels. I was hoping for an upcoming flash upgrade.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 879
Joined: Sun Oct 01, 2006 11:44 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Mon May 30, 2016 6:53 pm

Any news on this? Was this a problem batch or a manufacturing defect or something else? I'm hoping to deploy more hAP ACs very soon and some of the environments can get quite warm in the summer.
 
Quindor
Member
Member
Posts: 347
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Mon May 30, 2016 8:46 pm

I was just thinking about this problem.

Could people whom are seeing this problem try to turn on flow-control on all ports (Auto should be enough). I wondering if that makes a difference. I always turn flow-control on to auto on all ports per default, so that might change something?
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
LSV
just joined
Posts: 3
Joined: Mon Mar 02, 2015 7:05 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Jun 16, 2016 2:48 am

Is there any news on fixing of this problem?. I am planning to WiFi cover a building with 65 APs for different uses connecting Internet users, corporate connections and machine conections. I have been successfully using RB951G for this kind of projects but for new investments now  AC is a must and natural evolution should be hAP ac. These performance problems mixed with the supply shortage make me doubt if these is a stable product. I could not find any reference of successful deployments around Spain.

I would thank you to provide information on current stability, successful projects deployed and/or plans to evolve the product to a more stable release. 
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Jun 16, 2016 10:55 am

Hi LSV,

why not thinking to use  wAP AC ( http://routerboard.com/RBwAPG-5HacT2HnD) instead of hAP AC ?
The wAP AC It's more suitable for APs.
Best Regards,

Daniel
 
LSV
just joined
Posts: 3
Joined: Mon Mar 02, 2015 7:05 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Jun 16, 2016 7:04 pm

Hi pateutz
I just ordered one to make some tests.
 
pateutz
Frequent Visitor
Frequent Visitor
Posts: 52
Joined: Wed Jan 11, 2012 5:55 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Tue Jun 21, 2016 2:25 pm

Hi LSV,

so have you test the product ? It's ok ?

Best Regards,

Daniel
 
davidbakerjr
just joined
Posts: 2
Joined: Fri Apr 29, 2016 9:28 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Jun 22, 2016 1:05 am

Is there any updates on this or do I need to RMA all 5 of these HAP AC?
 
LSV
just joined
Posts: 3
Joined: Mon Mar 02, 2015 7:05 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Jun 22, 2016 5:29 pm

Hi LSV,

so have you test the product ? It's ok ?

Best Regards,

Daniel
We received it yesterday installed installed it on our network and seems to work fine for our use in both bands.
We didn't stress it or do further tests yet.
 
Laurens
just joined
Posts: 7
Joined: Sat Jul 02, 2016 1:53 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Wed Jul 06, 2016 11:25 am

I'm suffering from the same problems; WAN to WLAN is okay, WAN to LAN is terrible. Tried newest rc routeros didn't fix it. Putting interfaces on 100Mbit didn't fix it, disabling fast path on bridge and ip-settings didn't fix it. Cooling it down helps for a bit but is no usable solution.

I guess the only thing to do is to return the unit so Mikrotik has some test material... too bad, need to postpone client delivery now. Still hoping for software fix of some kind!
 
aa007
just joined
Topic Author
Posts: 20
Joined: Tue Apr 06, 2010 3:51 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Jul 08, 2016 3:50 pm

We have RMA-ed all of the units - two different shops. One of them gave us a new unit, the other one returned the unit with statement, that upgrading fixed the problem - I tested it today ... and guess what - it didn't - so even we would like to send those units back for inspection to Mikrotik, we have to somehow "force" the seller to do it.
Luckily we have replaced all of our Mikrotik devices with Ubiquiti equipment and the difference is amazing. I hope the next generation of Mikrotik devices will get closer to 21st century.
Last edited by aa007 on Fri Jul 08, 2016 4:03 pm, edited 2 times in total.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Jul 08, 2016 3:53 pm

I've also RMA-ed mine. The seller sent a new one from a newer batch. Going to receive it today. Will test in next few days...
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Fri Jul 08, 2016 10:26 pm

The replacement unit - S/N 673706478C5D seems good!
 
deanMKD1
Member
Member
Posts: 345
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Sat Jul 09, 2016 1:35 am

The replacement unit - S/N 673706478C5D seems good!
WAN to WLAN ok ?
WAN to LAN ok ?
No droping of speed?

Faulty series have this SN:

673705 1BD37F
673705 E06641
673705 914040

your looks that is from newer series

673706 478C5D

you see last 5 in faulty series, and you have 6 on last number position.
 
TaurusThree
just joined
Posts: 11
Joined: Tue Apr 19, 2016 8:00 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Sat Jul 09, 2016 1:50 am

Yeah no speed drop in all scenarios regardless of temperature.
 
Laurens
just joined
Posts: 7
Joined: Sat Jul 02, 2016 1:53 pm

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Sat Jul 09, 2016 3:23 pm

Hmz that would make sense. Our faulty returned unit also has a 5 in the s/n: 673705 0CB2D3.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 793
Joined: Tue Aug 03, 2004 9:01 am

Re: HAP AC faulty seriers - very poor LAN performance? (switch problem)

Thu Jul 14, 2016 3:42 am

So I commented on this thread earlier before I had tested, and had not taken the time to come back and report on any findings.  I am happy to report that I have been unable to reproduce this problem at all on my unit, for which I am thankful, because given the past (and ongoing) relative scarcity of hAP AC units in the supply chain here in the US, I imported my single unit, and I wasn't looking forward to organizing an international return...

In my tests, I let the unit stand for several hours.  It felt quite warm to the touch.  I ran throughput tests immediately after booting it up and also after letting it remain powered on for a while, and the numbers did not change.  I was able to easily pull and sustain ~500Mbit/s of a single-stream TCP session through it, from the WAN to one of the LAN ports.  This was with a bone-stock-default configuration, running the software that it shipped with (which I believe was 6.33.5; I later upgraded to 6.35.4 in order to use wireless-rep so that I could solve some throughput problems on the wireless side to an Intel 11ac WiFi client, and the change to wireless-rep did indeed fix the problems I was seeing).

My serial # also starts with 673705, so it would seem not all units were affected.

Was it ever revealed what the exact problem was, and how many units were affected?  Am I missing anything in my testing, or misunderstanding the problem and not testing the correct thing/hitting the exact edge-case that everybody else experiencing the problem was hitting?

-- Nathan

Who is online

Users browsing this forum: No registered users and 14 guests