Community discussions

 
mehdiab
just joined
Topic Author
Posts: 10
Joined: Fri Jun 10, 2016 1:48 pm

Why Hotspot Servers and DHCP Server are in red text?

Sat Jun 11, 2016 5:05 pm

Hi,i want to create a hotspot with my router but when i config it with Hotspot Setup, it appear in red text ! Also when hotspot create a DHCP Server, it appear in red text,too. Hotspot does not work and all the client in my network access the internet without username and password .
Where is the problem? What mean the red text ?

/interface bridge
add admin-mac=E4:8D:8C:46:C7:0F auto-mac=no comment=defconf name=bridge
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce distance=indoors \
    frequency=auto mode=ap-bridge ssid=MikroTik-46C713 wireless-protocol=802.11
/interface ethernet
set [ find default-name=ether2 ] name=ether2-master
set [ find default-name=ether3 ] master-port=ether2-master
set [ find default-name=ether4 ] master-port=ether2-master
set [ find default-name=ether5 ] master-port=ether2-master
/ip neighbor discovery
set ether1 discover=no
set bridge comment=defconf
/ip hotspot profile
add dns-name=ssm.zzz hotspot-address=10.5.50.1 name=hsprof1 use-radius=yes
/ip pool
add name=default-dhcp ranges=192.168.88.10-192.168.88.254
add name=hs-pool-2 ranges=10.5.50.2-10.5.50.254
/ip dhcp-server
add address-pool=default-dhcp disabled=no interface=bridge name=defconf
# DHCP server can not run on slave interface!
add address-pool=hs-pool-2 disabled=no interface=ether2-master lease-time=1h name=dhcp1
/ip hotspot
add address-pool=hs-pool-2 disabled=no interface=ether2-master name=hotspot1 profile=\
    hsprof1
/queue interface
set ether2-master queue=default-small
/interface bridge port
add bridge=bridge comment=defconf interface=ether2-master
add bridge=bridge comment=defconf disabled=yes interface=wlan1
/ip address
add address=192.168.88.1/24 comment=defconf interface=bridge network=192.168.88.0
add address=192.168.1.101/24 disabled=yes interface=ether1 network=192.168.1.0
add address=10.5.50.1/24 comment="hotspot network" interface=ether2-master network=\
    10.5.50.0
/ip dhcp-client
add comment=defconf dhcp-options=hostname,clientid disabled=no interface=ether1
/ip dhcp-server network
add address=10.5.50.0/24 comment="hotspot network" gateway=10.5.50.1
add address=192.168.88.0/24 comment=defconf gateway=192.168.88.1
/ip dns
set allow-remote-requests=yes servers=4.2.2.4
/ip dns static
add address=192.168.88.1 name=router
/ip firewall filter
add chain=input comment="defconf: accept ICMP" protocol=icmp
add chain=input comment="defconf: accept established,related" connection-state=\
    established,related
add action=drop chain=input comment="defconf: drop all from WAN" in-interface=ether1
add action=fasttrack-connection chain=forward comment="defconf: fasttrack" \
    connection-state=established,related
add chain=forward comment="defconf: accept established,related" connection-state=\
    established,related
add action=drop chain=forward comment="defconf: drop invalid" connection-state=invalid
add action=drop chain=forward comment="defconf:  drop all from WAN not DSTNATed" \
    connection-nat-state=!dstnat connection-state=new in-interface=ether1
/ip firewall nat
add action=masquerade chain=srcnat comment="defconf: masquerade" out-interface=ether1
add action=masquerade chain=srcnat comment="masquerade hotspot network" src-address=\
    10.5.50.0/24
/ip hotspot user
add name=admin
/radius
add address=10.5.50.1 service=login,hotspot
/system clock
set time-zone-name=Asia/Tehran
/system leds
set 0 interface=wlan1
/system routerboard settings
set protected-routerboot=disabled
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=bridge
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=bridge
Last edited by mehdiab on Sun Jun 12, 2016 7:29 am, edited 1 time in total.
 
irghost
Member Candidate
Member Candidate
Posts: 282
Joined: Sun Feb 21, 2016 1:49 pm

Re: Why Hotspot Servers and DHCP Server are in red text?

Sat Jun 11, 2016 5:31 pm

set IP for interface it will be fix
MTCNA MTCRE MTCTCE MTCUME MTCWE MTCIPv6E MTCINE
 
mehdiab
just joined
Topic Author
Posts: 10
Joined: Fri Jun 10, 2016 1:48 pm

Re: Why Hotspot Servers and DHCP Server are in red text?

Sat Jun 11, 2016 5:42 pm

set IP for interface it will be fix
Not this work. I set the 192.168.77.1/24 for ether2-master , but not work. Although when i setup hotspot , it sets the ether2 for 10.5.50.1/24.

 #   ADDRESS            NETWORK         INTERFACE                                           
 0   ;;; defconf
     192.168.88.1/24    192.168.88.0    bridge                                              
 1 D 192.168.1.100/24   192.168.1.0     ether1                                              
 2   ;;; hotspot network
     10.5.50.1/24       10.5.50.0       ether2-master 

Who is online

Users browsing this forum: No registered users and 25 guests