Page 1 of 1

RB750Gr2 + RBGPOE + RB260GS <> 1000 Mbit

Posted: Sun Jun 12, 2016 12:30 am
by aqualx
Can't find reason why mentioned combination of router and switch with PoE adapter for RB260GS doesn't bring me 1000 Mbit connection, only 100 Mbit.
[ZZZ@router] /interface ethernet> monitor eth2-hub 
                      name: eth2-hub
                    status: link-ok
          auto-negotiation: done
                      rate: 100Mbps
               full-duplex: yes
           tx-flow-control: yes
           rx-flow-control: yes
               advertising: 10M-half,10M-full,100M-half,100M-full
  link-partner-advertising: 10M-half,10M-full,100M-half,100M-full
At the same time if I power switch via AC power adapter than connection is 1000 Mbit (even through RBGPOE that isn't powered).

Re: RB750Gr2 + RBGPOE + RB260GS <> 1000 Mbit

Posted: Wed Jun 15, 2016 11:04 pm
by Zorro
maybe its because its different kind of "PoE" perhaps? (in case of each ~device).
to have working 1Gb link you need appropriate PoE injector for.

Re: RB750Gr2 + RBGPOE + RB260GS <> 1000 Mbit

Posted: Thu Jun 16, 2016 12:35 am
by aqualx
All devices are made by Mikrotik, so I suppose they should be compatible. Mikrotik RBGPOE injector is made for 1Gbit connection and it works with Mikrotik wAP ac on 1Gbit...

Re: RB750Gr2 + RBGPOE + RB260GS <> 1000 Mbit

Posted: Sun Jun 19, 2016 9:49 pm
by Neilson
I see that both sides are reported as advertising only up to 100 Mbps as possible on this, have you tried to run a cable test from each device across the cable when its not connected at the other end to ensure there is no breakage or anything weird? Have you tried another RBGPOE? Also have you checked the interface configuration to ensure the port isn't set to only negotiate up to 100Mbps?

Never rule out that a cable or adapter could have gone bad, never rule out an accidental button click. So many things could contribute to this.

Also check that you have updated routerOS to the latest version (any of the latest chain releases) and also check that you have updated to the latest routerBoot. There are a number of changelog entries in routerBoot changelog that talk about ethernet interface funny things and newer firmware often mentions improvements to link auto negotiate.

I know you mention it works through unpowered RBGPOE, I would test an alternative one of those and also try a different power supply plugged into it to ensure the power supply isn't noisy or shielding failure on the POE injector.


Re: RB750Gr2 + RBGPOE + RB260GS <> 1000 Mbit

Posted: Sun Jun 19, 2016 9:58 pm
by aqualx
Replaced all wiring, also got rid of RBGPOE and replaced it with RB260GSP(two wAP ac and RB260GS powered by it). Problem somehow solved and now all connection is at 1000 Mbit.