Community discussions

MikroTik App
 
User avatar
YazzY
Member Candidate
Member Candidate
Topic Author
Posts: 140
Joined: Fri May 28, 2004 3:26 pm
Location: Norway, Østfold
Contact:

Bios options.

Fri May 28, 2004 3:47 pm

system routerboard bios set pci-backoff=disabled/enabled.

What does this option do in details ?
I know it's suppose to make wlan nics play more nicely with the routerboards, but how exactly?
The CHANGELOG is as usually very spare on details.
 
tully
MikroTik Support
MikroTik Support
Posts: 505
Joined: Fri May 28, 2004 11:07 am

manual

Fri May 28, 2004 4:24 pm

This is from the current manual:

pci back-off – When enabled, external PCI masters can access system memory even when a CPU cycle
has been retried (enabled | disabled; enabled by default). When you are experiencing uncommon problems
with PCI bus (including RouterBOARD is rebooting or hanging up once in a while), try to disable this.

See:
http://www.routerboard.com/PDF/RouterBO ... A4-2-4.pdf
 
nenadr
just joined
Posts: 5
Joined: Sat May 29, 2004 2:33 pm

Re: manual

Sun May 30, 2004 11:18 pm

This is from the current manual:

pci back-off – When enabled, external PCI masters can access system memory even when a CPU cycle
has been retried (enabled | disabled; enabled by default). When you are experiencing uncommon problems
with PCI bus (including RouterBOARD is rebooting or hanging up once in a while), try to disable this.

See:
http://www.routerboard.com/PDF/RouterBO ... A4-2-4.pdf

In BIOSes PRIOR TO 1.2.7 there was NO such option and multiply Atheros cards in Routerboard made them freeze (or reboot if watchdog is off) on every couple of minutes (RouterOS 2.8.3 and 2.8.4).

Then came RouterOS 2.8.5 with 1.2.7 BIOS with PCI Backoff option set to Enable by default, and multiply atheroses (5212) started to work fine but routerboard still reboots on 24-96 hours (which is, lets say, acceptable).

My question is should I set this PCI Backoff to disable in the configurations with multiply 5212 cards (and sometimes there are one or two Prisms in Routerboard as well) ?
 
tully
MikroTik Support
MikroTik Support
Posts: 505
Joined: Fri May 28, 2004 11:07 am

Mon May 31, 2004 9:08 am

Versions of the RouterBOARD that are clocked at 266MHz have other hardware changes that allow the use of the RB14 and multiple 5212 cards (we will not give details on our design). Back-off has always been enabled -- now you have the option to turn it off.

You should not be having reboots. Probably this is an issue with the power. The RB51 power injector can sometimes hit its max when you have four cards. You can use the new RB53 or soon RB52 -- which allows higher power to the board.

John
 
nenadr
just joined
Posts: 5
Joined: Sat May 29, 2004 2:33 pm

Mon May 31, 2004 9:52 am

Versions of the RouterBOARD that are clocked at 266MHz have other hardware changes that allow the use of the RB14 and multiple 5212 cards (we will not give details on our design). Back-off has always been enabled -- now you have the option to turn it off.

You should not be having reboots. Probably this is an issue with the power. The RB51 power injector can sometimes hit its max when you have four cards. You can use the new RB53 or soon RB52 -- which allows higher power to the board.
John
I don't think that this is power option because it happens on ALL setups with multiply cards (from 2 Atheroses only in RB, up to 2 Atheroses and 3 prisms in RB (2 PCMCIA + 1 MiniPCI), and power supplies are diferent (some use PoE and some not, and on almost all instalations I have a diferent power suply (from first routerboard shipments up now).

I'll try with PCI Backoff disabled and I'll let you know is there any improvement.

Nenad
 
tully
MikroTik Support
MikroTik Support
Posts: 505
Joined: Fri May 28, 2004 11:07 am

Mon May 31, 2004 12:19 pm

I suggest using our current version 2.8.10, RB53 POE or power to jack, and a 266MHz version of the RouterBOARD only with Atheros 5212 chips. There should be no reboots or issues with this configuration. It has been extensively tested here and with many customers.

John
 
nenadr
just joined
Posts: 5
Joined: Sat May 29, 2004 2:33 pm

Mon May 31, 2004 12:27 pm

I suggest using our current version 2.8.10, RB53 POE or power to jack, and a 266MHz version of the RouterBOARD only with Atheros 5212 chips. There should be no reboots or issues with this configuration. It has been extensively tested here and with many customers.

John
OK. Since RBs are already 266 Mhz models and Atheroses are 5212 , I'll swith all power adapters to a RB53 I have received with last shipment, and upgrade all instalations from 2.86 and up to 2.8.10, and i'll post the presults.
 
nenadr
just joined
Posts: 5
Joined: Sat May 29, 2004 2:33 pm

Mon May 31, 2004 5:19 pm

I'll try with PCI Backoff disabled and I'll let you know is there any improvement.

Nenad
Tried with PCI Backoff and made a mess out of my day :cry: !!!

When I changed sys routerboard bios pci-backoff=disable everything countinued to work fine until the first reboot. After that first reboot RBs just keeps on rebooting on every couple of seconds after the login prompt is shown.

I have tried on 2 RB 266 configurations: one is 2 x Atheros 2512 as APs and that one just kept on rebooting until I managed to turn pci-backoff to ENABLE, and the other one is 2511 + Prism (both cards on RB - not on adapter card) which is also fixed the same way (PCI-Backoff to enable), and in that case I have found out that PRISM configuration is lost . OSs are 2.8.6 on both devices, BIOSes are 1.2.7 on both devices.
 
tully
MikroTik Support
MikroTik Support
Posts: 505
Joined: Fri May 28, 2004 11:07 am

Mon May 31, 2004 5:42 pm

I suggest that you upgrade both bios and RouterOS and send a supout file to support if you have this rebooting issue.

John

Who is online

Users browsing this forum: No registered users and 32 guests