Community discussions

MUM Europe 2020
 
Jeroen1000
Member Candidate
Member Candidate
Topic Author
Posts: 195
Joined: Fri Feb 18, 2011 2:05 pm

RB 850Gx2 vs RB750Gr3 performance

Sun Oct 23, 2016 1:22 pm

This topic was bound to show up sooner or later:-)

So the 850Gx2 has a power pc processor running at 533 MHz. RB750Gr3 has a MIPS processor at 880 Mhz.
Both are dual core devices. Both offer HW-acceleration although I have the 850Gx2 rev. 1 which doesn't so buyer beware. The 750Gr3 uses the EIP- 93 crypto engine. Don't know what the 850Gx2 uses (perhaps anyone here does?).

Just looking at routing and CPU performance for NON HW accelerated use cases, like SSTP for instance, which device would be faster? I am aware that you normally just can't compare the clock speeds between different achitectures. Going from the Mikrotik product positioning 850 > 750 but a 300 Mhz bump in frequency most mean something?
 
compuguy
just joined
Posts: 4
Joined: Sun Oct 23, 2016 2:34 am
Location: USA

Re: RB 850Gx2 vs RB750Gr3 performance

Sun Oct 23, 2016 9:58 pm

I don't have a 850Gx2, but I'm trying to work out performance issues between mikrotik devices with hardware acceleration (RB750Gr3 to RB1100AHx2), ipsec/l2tp.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5950
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 12:24 am

This topic was bound to show up sooner or later:-)

So the 850Gx2 has a power pc processor running at 533 MHz. RB750Gr3 has a MIPS processor at 880 Mhz.
Both are dual core devices. Both offer HW-acceleration although I have the 850Gx2 rev. 1 which doesn't so buyer beware. The 750Gr3 uses the EIP- 93 crypto engine. Don't know what the 850Gx2 uses (perhaps anyone here does?).

Just looking at routing and CPU performance for NON HW accelerated use cases, like SSTP for instance, which device would be faster? I am aware that you normally just can't compare the clock speeds between different achitectures. Going from the Mikrotik product positioning 850 > 750 but a 300 Mhz bump in frequency most mean something?
Different architectures. PPC will be faster than mips even if CPU frequency is lower. On RB805 w/o HW encryption you can easily get around 150Mbps, on mips not so much (more like twice as slow).
 
bedior
newbie
Posts: 39
Joined: Sat Jan 31, 2015 5:09 pm

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 10:42 am

CPU power does not figure, because Mikrotik has not optimized firmware, and don't want accept problems and fix its. See my topic as sample of speed degradation on same device: http://forum.mikrotik.com/viewtopic.php?t=110714
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 11:36 am

ROS-wise 1004chip in 750Gr3 sounds more meaningful.
and it also cheaper both itself and to implement device atop it :=)
more direct comparisons for 850gx2 and 750gr3 would be ERL, ERX from competing company and some of SOHO routers, perhaps.
Different architectures. PPC will be faster than mips even if CPU frequency is lower. On RB805 w/o HW encryption you can easily get around 150Mbps, on mips not so much (more like twice as slow).
its not more about "different level of implementation" that comparing Architecture benefits itself.
in Each arch - there was extremely stripped-down, crippled, slow chips and fat, fast, superscalar devices.
comparing say (even not many-core)Pezy superscalar MIPS64 chips with out-of-order exce, fat cache and fast memory controllers(or similar things built atop A73 ARM forks for example)with say e550 crippled PPC chips - isn't fair.
another thing - there was different Generations of them so comparing e6500 cores with 7yr old PPC cores with Power8 or Power9 chips - isn't make sense either.
 
User avatar
mrz
MikroTik Support
MikroTik Support
Posts: 5950
Joined: Wed Feb 07, 2007 12:45 pm
Location: Latvia
Contact:

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 12:12 pm

Well I was referring to CPUs of each architecture that we actually use in our products.
 
Zorro
Long time Member
Long time Member
Posts: 676
Joined: Wed Apr 16, 2014 2:43 pm

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 12:30 pm

Well I was referring to CPUs of each architecture that we actually use in our products.
74k and even 1004k was in slightly different league from e550 PPC cores, then.
not "classic" cores, but -Aptiv cores and Warror cores would be more interesting PPC alternative in perspective. if Imagination Inc survie, of course.
eg those https://imgtec.com/mips/aptiv/proaptiv/ (and for ultra Low-power deives https://imgtec.com/mips/aptiv/interaptiv/ are) and those https://imgtec.com/mips/warrior/m-class ... re-family/ meant.
its only partially because Arch -dependent limitations. usually its more about die size budget or power dissipation limitations or so.
within similar budget and similar tech process they ~ relatively alike with different benefits for each.
personally i like Arm bit more, generally for more Balanced between input-output, crunching of botch kind and etc, architecture and PPC was quite solid for heavy computing with high-load, under complex math(especally if you not power or heat -restricted and/or use advanced factory to made chips with smaller transistors in)
freescale did fancy choice of SoC on PPC arch, including e5500 and e6500 64-bit PPC chips, but apparently they shifted(as well as Cavium, Tilera, Broadcom, Marvel and etc vendors that used MIPS or PPC before from time to time)to ARM in their products.
just saw router on 4908 in shop. i hate broadcom SDK and their chips, generally, but general trend was ~ common all vendors.

personally i never big fan of MIPS(both arch and their marketing practice. especially in past), but they had strong sides as other companies are
generally recent MIPS release6 - introduce SEVERAL arch improvements, eventually introduced into some of updated legacy products of most vendors, building their SoC atop of it.
Last edited by Zorro on Mon Oct 24, 2016 12:47 pm, edited 4 times in total.
 
User avatar
колбаскин
newbie
Posts: 37
Joined: Tue Mar 29, 2016 6:36 pm
Location: Ukraine Zaporozhye
Contact:

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 12:38 pm

On RB805 w/o HW encryption you can easily get around 150Mbps, on mips not so much (more like twice as slow).
I have this model.
Im couldn't receive higher than 25 megabits of l2tp+ipsec on upload.
Кое что для Mikrotik | hd.zp.ua - Запорожье ITшное.
 
picacho100
just joined
Posts: 4
Joined: Tue Oct 18, 2016 2:17 pm

Re: RB 850Gx2 vs RB750Gr3 performance

Mon Oct 24, 2016 12:55 pm

I'll recomend to focus more on real benchmarks results and less about speculations: benchmarks about overall system performance, so software plus hardware, and under real conditions.
- Mikrotik has some hardware platforms optimized and others (the most) not to use silicone encryption capabilities.
- RouterOS 7 is used often as the knife army tool to solve a lot of these pending optimizations (and not only). but until an official statement about the overall roadmap of RouterOS 7 would be available this is, at least for me, vaporware or marketing stuff.

In my case, I decided to use only MK for pure routing and basic firewalling (ah...and also for software based NAT...) and because I have already invested in MK hardware...
 
ingtegration
just joined
Posts: 23
Joined: Fri Sep 11, 2015 6:52 am
Location: Montreal, Quebec , CANADA
Contact:

Re: RB 850Gx2 vs RB750Gr3 performance

Wed Nov 16, 2016 5:59 pm

CentOS 7 (FX8320E / Gigabit) (172.16.1.120) <--> RB750Gr3-A (172.16.2.1) <--> (172.16.2.3) RB750Gr2-B <--> (192.168.89.224) Ubuntu 16.04 (HP Zbook i7 / Gigabit)

root@IngTegration:~$ iperf3 -p 5201 -c 172.16.1.120
Connecting to host 172.16.1.120, port 5201
[ 4] local 192.168.89.224 port 38574 connected to 172.16.1.120 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 20.4 MBytes 171 Mbits/sec 24 306 KBytes
[ 4] 1.00-2.00 sec 19.7 MBytes 165 Mbits/sec 0 351 KBytes
[ 4] 2.00-3.00 sec 19.6 MBytes 164 Mbits/sec 0 388 KBytes
[ 4] 3.00-4.00 sec 20.3 MBytes 171 Mbits/sec 13 314 KBytes
[ 4] 4.00-5.00 sec 19.6 MBytes 164 Mbits/sec 0 355 KBytes
[ 4] 5.00-6.00 sec 19.6 MBytes 164 Mbits/sec 0 392 KBytes
[ 4] 6.00-7.00 sec 19.6 MBytes 164 Mbits/sec 4 317 KBytes
[ 4] 7.00-8.00 sec 19.7 MBytes 165 Mbits/sec 0 360 KBytes
[ 4] 8.00-9.00 sec 20.3 MBytes 170 Mbits/sec 1 289 KBytes
[ 4] 9.00-10.00 sec 19.6 MBytes 164 Mbits/sec 0 333 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 198 MBytes 166 Mbits/sec 42 sender
[ 4] 0.00-10.00 sec 197 MBytes 165 Mbits/sec receiver


RB750Gr3-A Config:
=================
/interface gre
add !keepalive local-address=172.16.2.1 name=gre-tunnel1 remote-address=172.16.2.3

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des

/ip ipsec peer
add address=172.16.2.3/32 enc-algorithm=3des nat-traversal=no secret=password

/ip ipsec policy
set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0
add dst-address=172.16.2.3/32 sa-dst-address=172.16.2.3 sa-src-address=172.16.2.1 src-address=172.16.2.1/32 tunnel=yes

/ip route
add distance=1 gateway=gre-tunnel1
add distance=1 dst-address=192.168.89.0/24 gateway=gre-tunnel1


RB750Gr3-A Config:
=================
/interface gre
add !keepalive local-address=172.16.2.3 name=gre-tunnel1 remote-address=172.16.2.1

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
add auth-algorithms=md5 enc-algorithms=3des lifetime=1h name=Site2Site

/ip ipsec peer
add address=172.16.2.1/32 enc-algorithm=3des nat-traversal=no secret=password

/ip ipsec policy
set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0
add dst-address=172.16.2.1/32 sa-dst-address=172.16.2.1 sa-src-address=172.16.2.3 src-address=172.16.2.3/32 tunnel=yes

/ip route
add distance=1 gateway=gre-tunnel1
add distance=1 dst-address=172.16.1.0/24 gateway=gre-tunnel1


2 firewall rules (first on top): accept input and accept forward

GRE alone perf: 292 Mbps
L2TP/MPPE128: 108 Mbps
GRE/SHA1/AES128cbc: 142 Mbps
GRE/SHA1/AES256cbc: 142 Mbps
GRE/SHA1/3DES: 165 Mbps

CPU max on RB750Gr3 was 50%
/tools profile always 100% unclassified
Guy Boisvert, ing.
MTCRE
IngTegration inc. - Montréal, Canada
http://www.ingtegration.com
 
tarikin
newbie
Posts: 33
Joined: Sat Sep 24, 2016 11:55 pm
Location: Russia, Moscow

Re: RB 850Gx2 vs RB750Gr3 performance

Fri Nov 25, 2016 10:41 pm

CentOS 7 (FX8320E / Gigabit) (172.16.1.120) <--> RB750Gr3-A (172.16.2.1) <--> (172.16.2.3) RB750Gr2-B <--> (192.168.89.224) Ubuntu 16.04 (HP Zbook i7 / Gigabit)

root@IngTegration:~$ iperf3 -p 5201 -c 172.16.1.120
Connecting to host 172.16.1.120, port 5201
[ 4] local 192.168.89.224 port 38574 connected to 172.16.1.120 port 5201
[ ID] Interval Transfer Bandwidth Retr Cwnd
[ 4] 0.00-1.00 sec 20.4 MBytes 171 Mbits/sec 24 306 KBytes
[ 4] 1.00-2.00 sec 19.7 MBytes 165 Mbits/sec 0 351 KBytes
[ 4] 2.00-3.00 sec 19.6 MBytes 164 Mbits/sec 0 388 KBytes
[ 4] 3.00-4.00 sec 20.3 MBytes 171 Mbits/sec 13 314 KBytes
[ 4] 4.00-5.00 sec 19.6 MBytes 164 Mbits/sec 0 355 KBytes
[ 4] 5.00-6.00 sec 19.6 MBytes 164 Mbits/sec 0 392 KBytes
[ 4] 6.00-7.00 sec 19.6 MBytes 164 Mbits/sec 4 317 KBytes
[ 4] 7.00-8.00 sec 19.7 MBytes 165 Mbits/sec 0 360 KBytes
[ 4] 8.00-9.00 sec 20.3 MBytes 170 Mbits/sec 1 289 KBytes
[ 4] 9.00-10.00 sec 19.6 MBytes 164 Mbits/sec 0 333 KBytes
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval Transfer Bandwidth Retr
[ 4] 0.00-10.00 sec 198 MBytes 166 Mbits/sec 42 sender
[ 4] 0.00-10.00 sec 197 MBytes 165 Mbits/sec receiver


RB750Gr3-A Config:
=================
/interface gre
add !keepalive local-address=172.16.2.1 name=gre-tunnel1 remote-address=172.16.2.3

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des

/ip ipsec peer
add address=172.16.2.3/32 enc-algorithm=3des nat-traversal=no secret=password

/ip ipsec policy
set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0
add dst-address=172.16.2.3/32 sa-dst-address=172.16.2.3 sa-src-address=172.16.2.1 src-address=172.16.2.1/32 tunnel=yes

/ip route
add distance=1 gateway=gre-tunnel1
add distance=1 dst-address=192.168.89.0/24 gateway=gre-tunnel1


RB750Gr3-A Config:
=================
/interface gre
add !keepalive local-address=172.16.2.3 name=gre-tunnel1 remote-address=172.16.2.1

/ip ipsec proposal
set [ find default=yes ] enc-algorithms=3des
add auth-algorithms=md5 enc-algorithms=3des lifetime=1h name=Site2Site

/ip ipsec peer
add address=172.16.2.1/32 enc-algorithm=3des nat-traversal=no secret=password

/ip ipsec policy
set 0 dst-address=0.0.0.0/0 src-address=0.0.0.0/0
add dst-address=172.16.2.1/32 sa-dst-address=172.16.2.1 sa-src-address=172.16.2.3 src-address=172.16.2.3/32 tunnel=yes

/ip route
add distance=1 gateway=gre-tunnel1
add distance=1 dst-address=172.16.1.0/24 gateway=gre-tunnel1


2 firewall rules (first on top): accept input and accept forward

GRE alone perf: 292 Mbps
L2TP/MPPE128: 108 Mbps
GRE/SHA1/AES128cbc: 142 Mbps
GRE/SHA1/AES256cbc: 142 Mbps
GRE/SHA1/3DES: 165 Mbps

CPU max on RB750Gr3 was 50%
/tools profile always 100% unclassified
Respect for this job! It saved my weekend =)
MTCNA MTCRE MTCTCE MTCWE MTCUME MTCSE MTCIPv6E
Mikrotik Consultant status since September 2016

Who is online

Users browsing this forum: No registered users and 30 guests