Community discussions

MUM Europe 2020
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Fri Mar 10, 2017 9:17 am

I tried upgrading my RB433UAH with the latest available firmware.
I think it's 6.37.5.

After the upgrade the router was rebooted but now it does not boot.
It only beeps once. There is no second beep.
Tried resetting it to defaults. The beep is now like a prolonged beep (crackling sound) but there is still no second beep.

Any idea how to recover the router?
 
User avatar
yo1frenchtoast
just joined
Posts: 8
Joined: Thu Jul 09, 2015 3:48 pm
Location: Brittany, France

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Fri Mar 10, 2017 9:47 am

Hello,

Try recover it by using Netinstall => https://wiki.mikrotik.com/wiki/Manual:Netinstall
 
User avatar
mikrostart
newbie
Posts: 36
Joined: Fri Aug 30, 2013 10:31 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Fri Mar 10, 2017 11:48 pm

Two days ago I posted same symptoms:

viewtopic.php?f=3&t=119335

Tried netinstall with no luck, the device starts the netinstall procedure ( says "farmating and partitioning"), then starts transfering the OS, and after 20% of the transfer the device reboots, and then again in the boot loop.

The only thing I did not try is the format NAND command, but that will destroy the license information.

The board is going slowly to the garbage can :)

I really hope that the problem is not in the latest RtOS updates.
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sat Mar 11, 2017 12:56 pm

Tried recovering the router using netinstall but was not successful

RouterBOOT booter 3.24

RouterBoard 433UAH

CPU frequency: 680 MHz
Memory size: 128 MiB
NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol............... failed
kernel loading failed

loading kernel from nand... OK
setting up elf image...


Firewall is disabled on the PC that is running Netinstall.
Tried several versions of netinstall.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sat Mar 11, 2017 1:43 pm

The only thing I did not try is the format NAND command, but that will destroy the license information.
Have you contacted support? If they advise it (most probably, if current state for the board it's unusable) they can provide you the license afterwards.

@morph: There's something preventing the router to communicate with netinstall.

Are you using a laptop? try disabling wireless and any other interfaces, leaving only the one connected to the RB enabled.

Did you follow netinstall instructions? Is Boot Server Enabled?

Image

Did you run netinstall as administrator?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sat Mar 11, 2017 2:11 pm

Hi,
I tried on two different computers. Laptop and desktop.
Run as administrator. Firewall disabled.
Boot server enabled.
Nothing happens. I boot the router while holding a metal on the reset "button". Also tried without this but nothing happens as well.
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sat Mar 11, 2017 4:29 pm

Looks like hardware is either damaged or the reset PCB pad may be rusty or failing to shorting properly.

However, if you have access to the console, you can try forcing booting from the network (bootp) to reach out to netinstall, I've answered your other post: it would be p) following by 1 option (1 - boot Ethernet once, then NAND).

Reboot after that is set, it shoud try to connect to netinstall.

which ether port are you using on the 433UAH?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sat Mar 11, 2017 7:57 pm

sorry, is this still happening?
Press any key within 2 seconds to enter setup..
trying bootp protocol............... failed
If so, the problem lies on 433 <-> netinstall communication.

The bootp failed message indicates ether1 (which should be the port used) is being used already, otherwise you would see a Please, check ethernet cable... message, at least that's the behaviour on latest 3.24 firmware contained on 6.37.5

Try this:

1.- Set it up to boot from network. ( o) option, then 1)
2.- reboot
3.- do not launch netinstall yet
4.- keep an eye on the console, once you see the trying bootp protocol..... message, launch netinstall.

I've just upgraded a RB433 and a RB433AH to 6.37.5 using netinstall w/o problems.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 1:23 am

I managed to get the netinstall running but I'm seeing the same simptoms as explained by mikrostart.
It keeps restarting the cycle.
On several occasions I was able to start "Install" but it didn't finish. It started booting again.
trying bootp protocol.... OK
Got IP address: 192.168.88.100
resolved mac address 98:E7:F4:EA:1A:20
transfer started ........................... transfer ok, time=4.39s
setting up elf image... OK
jumping to kernel code
Welcome to MikroTik Router Software remote installation 6.38.5
Press Ctrl-Alt-Delete to abort

mac-address: 00:0C:42:41:66:70
mac-address: 00:0C:42:41:66:6F
mac-address: 00:0C:42:41:66:6E

software-id: 8XNY-**** key:
E8xMw3LzMLt5B61JzsekqqMQuntcodk/sal8z8LW0asJBFWMsqN****************************************== (I changed this to * - not sure if secret)

Waiting for installation server...
Found server at 00:50:56:C0:00:01

Formatting disk......

installing routeros-mipsbe-6.38.5 [                     installing routeros-mipsbe-6.38.5 [#                    installing routeros-mipsbe-6.38.5 [##                   installing routeros-mipsbe-6.38.5 [###                  installing routeros-mipsbe-6.38.5 [####                 installing routeros-mipsbe-6.38.5 [#####                installing routeros-mipsbe-6.38.5 [######               installing routeros-mipsbe-6.38.5 [#######              installing routeros-mipsbe-6.38.5 [########             installing routeros-mipsbe-6.38.5 [#########            installing routeros-mipsbe-6.38.5 [##########           installing routeros-mipÿ

RouterBOOT booter 3.24

RouterBoard 433UAH

CPU frequency: 680 MHz
  Memory size: 128 MiB
    NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol.... OK
Got IP address: 192.168.88.100
resolved mac address 98:E7:F4:EA:1A:20
transfer started ........................... transfer ok, time=3.12s
setting up elf image... OK
jumping to kernel code
Welcome to MikroTik Router Software remote installation 6.38.5
Press Ctrl-Alt-Delete to abort

mac-address: 00:0C:42:41:66:70
mac-address: 00:0C:42:41:66:6F
mac-address: 00:0C:42:41:66:6E

software-id: 8XNY-**** key:
E8xMw3LzMLt5B61JzsekqqMQuntcodk/sal8z8LW0asJBFWMs**********************************==

Waiting for installation server...
Found server at 00:50:56:C0:00:01

Formatting disk......

installing routeros-mipsbe-6.38.5 [                     installing routeros-mipsbe-6.38.5 [#                    installing routeros-mipsbe-6.38.5 [##                   installing routeros-mipsbe-6.38.5 [###                  installing routeros-mipsbe-6.38.5 [####                                     ]

RouterBOOT booter 3.24

RouterBoard 433UAH

CPU frequency: 680 MHz
  Memory size: 128 MiB
    NAND size: 512 MiB

Press any key within 2 seconds to enter setup..
trying bootp protocol.... OK
Got IP address: 192.168.88.100
resolved mac address 98:E7:F4:EA:1A:20
transfer started .............

RouterBOOT booter 3.24

RouterBoard 433UAH

CPU frequency: 680 MHz
  Memory size: 128 MiB
    NAND size: 512 MiB
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 1:13 pm

Are you 100% sure your power supply is fine? Have you tried with a known working one?

If so, write to support, attaching a supout if you can generate it, they may ask you to format NAND as it looks yours is either corrupted or damaged.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 1:21 pm

Tried with several different power supplies. It was the same. On several occasions it would almost finish installing the firmware but it would reboot before finishing.
Are older versions smaller? Perhaps it might succeed with a smaller firmware?
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 2:01 pm

It may succeed with smaller ros version, but looks like your NAND is corrupted, so you'll end up having problems sooner or later.

What's the board firmware? I mean routerboard routerboot firmware, not RouterOS itself.

I doubt upgrading it would make a difference, but just in case... you could do it from the serial console, see https://wiki.mikrotik.com/wiki/Manual:RouterBOOT.

Standalone firmware for the RB433UAH
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 2:07 pm

I upgraded the firmware very recently so it's probably the latest one.
Is this perhaps it: RouterBOOT booter 3.24 ?
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Sun Mar 12, 2017 2:12 pm

Yes, that's the last one.

Contact support and refer to this post, I'm afraid a NAND format is your last resort.

Get approval from mikrotik first as you'll lose the license.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Tue Mar 14, 2017 11:52 pm

I managed to get the router working. It was a hardware failure after all.
I contacted support and was told that the router is out of warranty.
Looking at the board I noticed that 5 of the capacitors were swollen at the top (the router is old after all).
Image

So I decided to replace the capacitors. They were all 560uF / 6.3V.
After replacing the capacitors the router stopped rebooting uncontrollably and is now working fine :)
 
User avatar
pukkita
Trainer
Trainer
Posts: 2986
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Wed Mar 15, 2017 11:47 am

Congrats! Happy to hear it's back to its duty. :D
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
morph
just joined
Topic Author
Posts: 22
Joined: Fri Mar 16, 2012 10:52 am

Re: RB433UAH not bootig after upgrade to latest firmware (6.37.5)

Wed Mar 15, 2017 1:40 pm

Thank you for your support @pukkita.

Regards.

Who is online

Users browsing this forum: No registered users and 16 guests