Community discussions

MikroTik App
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Mon Mar 20, 2017 11:09 am

Hi All,

We have been experiencing extensive Wireless drops from any Apple device connecting on 2Ghz or 5Ghz.
We have changed frequencies, changed channel width, changed group key update timeout, we even made the DHCP server lease 72Hours.

Mikrotik Details:
routerboard: yes
model: RouterBOARD 952Ui-5ac2nD
serial-number: **********
firmware-type: qca9531L
factory-firmware: 3.27
current-firmware: 3.36
upgrade-firmware: 3.36
Package 6.38.5


Mikrotik Wireless Configuration:

/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country="south africa" disabled=no distance=indoors frequency=auto mode=ap-bridge radio-name="" ssid=****** wireless-protocol=802.11
set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-eC country="south africa" disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=****** wireless-protocol=802.11

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=****** wpa2-pre-shared-key=******

Mikrotik Log
10:00:57 wireless,info 78:7E:61:75:4F:98@wlan2: connected
10:01:14 dhcp,info default deassigned 192.168.88.135 from 78:7E:61:75:4F:98
10:01:15 dhcp,info default assigned 192.168.88.135 to 78:7E:61:75:4F:98
10:02:00 wireless,info A0:D7:95:30:58:D9@wlan1: disconnected, extensive data loss
10:02:19 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, extensive data loss
10:04:29 wireless,info 5C:A3:9D:57:8E:0E@wlan1: disconnected, received disassoc: sending station leaving (8)
10:06:09 wireless,info A0:18:28:02:AC:35@wlan2: connected
10:06:09 wireless,info A0:18:28:02:AC:35@wlan1: disconnected, registered to other interface
10:07:55 wireless,info D0:7E:35:63:A4:2A@wlan1: disconnected, received deauth: unspecified (1)
10:11:45 wireless,info 78:7E:61:75:4F:98@wlan2: connected
10:12:11 wireless,info A0:D7:95:30:58:D9@wlan1: connected
10:12:15 wireless,info A0:D7:95:30:58:D9@wlan2: connected
10:12:15 wireless,info A0:D7:95:30:58:D9@wlan1: disconnected, registered to other interface
10:15:16 wireless,info A0:18:28:02:AC:35@wlan1: connected
10:15:16 wireless,info A0:18:28:02:AC:35@wlan2: disconnected, registered to other interface
10:18:21 wireless,info A0:18:28:02:AC:35@wlan2: connected
10:18:21 wireless,info A0:18:28:02:AC:35@wlan1: disconnected, registered to other interface
10:26:11 wireless,info A0:D7:95:30:58:D9@wlan1: connected
10:26:11 wireless,info A0:D7:95:30:58:D9@wlan2: disconnected, registered to other interface

We have also noticed, browsing is fine for a few minutes, but as disassoc error happens the client just disconnects.

Any help will really be appreciated !!

Kind regards

P
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Mon Mar 20, 2017 1:10 pm

Does the same happens if using 6.37.5?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
mmv
Trainer
Trainer
Posts: 65
Joined: Wed Feb 24, 2010 5:03 pm
Location: Moscow, Russia
Contact:

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Wed Mar 22, 2017 12:15 am

Try set WMM=enabled
It must be in n and ac by standard and very liked by Apple. May be because of some power saving functions.
Mikhail Moskalev
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Wed Mar 22, 2017 9:00 am

Thanks for feedback,

Will be applying the above mentioned today.

Will keep you in the loop.

Regards
 
User avatar
null31
Member Candidate
Member Candidate
Posts: 180
Joined: Fri Dec 23, 2016 6:07 pm
Location: Brazil

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Thu Mar 23, 2017 6:03 am

Also, you can try change the preamble-mode to long.
> https://wiki.mikrotik.com/wiki/Manual:W ... devices.3F
/interface wireless 
	set preamble-mode=long numbers=0,1
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Thu Mar 23, 2017 2:11 pm

Thanks all for this feedback,

I have applied these changes to two different Mikrotiks. Will be running tests on both of them.

Update - The RouterOS 6.37.5 the problem is seem to be occurring less, but still seem to have the problem.

Will keep everyone updated.

Thanks !!
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Fri Mar 24, 2017 8:12 am

Hi All,

Update on the above mentioned. Unfortunately the problem still seems to persist.

Applied Fix
/interface wireless
set preamble-mode=long numbers=0,1

Export
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n channel-width=20/40mhz-Ce country="south africa" disabled=no distance=indoors frequency=auto mode=ap-bridge preamble-mode=long radio-name="" ssid=***** wireless-protocol=802.11

set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-eC country="south africa" disabled=no distance=indoors frequency=auto mode=ap-bridge preamble-mode=long ssid=***** wireless-protocol=802.11

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=***** wpa2-pre-shared-key=*****

Log
mar/23 14:44:26 system,info,account user admin logged out from 41.79.92.45 via winbox
mar/23 14:53:56 wireless,info 20:02:AF:9F:26:89@wlan1: reassociating
mar/23 14:53:56 wireless,info 20:02:AF:9F:26:89@wlan1: disconnected, ok
mar/23 14:53:56 wireless,info 20:02:AF:9F:26:89@wlan1: connected
mar/23 15:07:45 wireless,info B0:70:2D:DE:28:F5@wlan1: connected
mar/23 15:07:47 wireless,info 6C:70:9F:25:91:B7@wlan1: connected
mar/23 15:07:50 wireless,info B0:70:2D:DE:28:F5@wlan2: connected
mar/23 15:07:50 wireless,info B0:70:2D:DE:28:F5@wlan1: disconnected, registered to other interface
mar/23 15:07:52 wireless,info 6C:70:9F:25:91:B7@wlan2: connected
mar/23 15:07:52 wireless,info 6C:70:9F:25:91:B7@wlan1: disconnected, registered to other interface
mar/23 15:08:14 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 15:08:45 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 15:08:45 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 15:13:15 wireless,info C8:E0:EB:2B:FB:75@wlan2: connected
mar/23 15:13:17 wireless,info A8:66:7F:10:77:1E@wlan2: connected
mar/23 15:13:17 dhcp,info default deassigned 192.168.88.131 from A8:66:7F:10:77:1E
mar/23 15:13:21 dhcp,info default assigned 192.168.88.131 to A8:66:7F:10:77:1E
mar/23 15:20:05 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 15:20:05 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 15:20:34 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 15:20:34 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 15:33:42 wireless,info 6C:70:9F:25:91:B7@wlan1: connected
mar/23 15:33:42 wireless,info 6C:70:9F:25:91:B7@wlan2: disconnected, registered to other interface
mar/23 15:34:11 wireless,info B0:70:2D:DE:28:F5@wlan2: disconnected, extensive data loss
mar/23 15:34:21 wireless,info 6C:70:9F:25:91:B7@wlan1: disconnected, extensive data loss
mar/23 15:36:48 wireless,info B0:70:2D:DE:28:F5@wlan2: connected
mar/23 15:37:16 wireless,info 6C:70:9F:25:91:B7@wlan2: connected
mar/23 15:43:17 wireless,info B0:70:2D:DE:28:F5@wlan1: connected
mar/23 15:43:17 wireless,info B0:70:2D:DE:28:F5@wlan2: disconnected, registered to other interface
mar/23 15:43:41 wireless,info 6C:70:9F:25:91:B7@wlan2: disconnected, extensive data loss
mar/23 15:44:38 wireless,info B0:70:2D:DE:28:F5@wlan1: disconnected, extensive data loss
mar/23 16:29:35 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 16:29:35 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 16:35:34 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 16:35:34 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 16:49:11 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 16:49:11 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 16:49:37 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 16:49:37 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 16:50:17 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 16:50:17 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 16:51:22 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 16:51:22 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 16:56:58 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 16:56:58 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 16:57:45 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 16:57:45 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 17:56:44 wireless,info B0:70:2D:DE:28:F5@wlan1: connected
mar/23 17:56:48 wireless,info 6C:70:9F:25:91:B7@wlan2: connected
mar/23 17:56:48 wireless,info B0:70:2D:DE:28:F5@wlan2: connected
mar/23 17:56:48 wireless,info B0:70:2D:DE:28:F5@wlan1: disconnected, registered to other interface
mar/23 18:10:04 wireless,info 6C:70:9F:25:91:B7@wlan1: connected
mar/23 18:10:04 wireless,info 6C:70:9F:25:91:B7@wlan2: disconnected, registered to other interface
mar/23 18:10:04 wireless,info B0:70:2D:DE:28:F5@wlan1: connected
mar/23 18:10:04 wireless,info B0:70:2D:DE:28:F5@wlan2: disconnected, registered to other interface
mar/23 18:10:48 wireless,info 5C:A3:9D:57:8E:0E@wlan1: connected
mar/23 18:10:49 dhcp,info default deassigned 192.168.88.133 from 5C:A3:9D:57:8E:0E
mar/23 18:10:49 dhcp,info default assigned 192.168.88.133 to 5C:A3:9D:57:8E:0E
mar/23 18:42:27 wireless,info 6C:70:9F:25:91:B7@wlan2: connected
mar/23 18:42:27 wireless,info 6C:70:9F:25:91:B7@wlan1: disconnected, registered to other interface
mar/23 18:42:42 wireless,info 6C:70:9F:25:91:B7@wlan1: connected
mar/23 18:42:42 wireless,info 6C:70:9F:25:91:B7@wlan2: disconnected, registered to other interface
mar/23 18:46:08 wireless,info A0:18:28:02:AC:35@wlan1: connected
mar/23 18:46:14 wireless,info A0:18:28:02:AC:35@wlan2: connected
mar/23 18:46:14 wireless,info A0:18:28:02:AC:35@wlan1: disconnected, registered to other interface
mar/23 18:49:54 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 18:49:54 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 18:51:38 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 18:51:38 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 19:04:14 wireless,info C0:D9:62:92:A4:EE@wlan1: connected
mar/23 20:26:59 wireless,info 14:99:E2:B7:90:42@wlan2: connected
mar/23 20:46:55 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 20:46:55 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 21:14:39 wireless,info 78:7E:61:75:4F:98@wlan1: connected
mar/23 21:14:39 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, registered to other interface
mar/23 21:24:03 wireless,info 78:7E:61:75:4F:98@wlan2: connected
mar/23 21:24:03 wireless,info 78:7E:61:75:4F:98@wlan1: disconnected, registered to other interface
mar/23 21:24:05 wireless,info 78:7E:61:75:4F:98@wlan2: disconnected, received disassoc: sending station leaving (8)
mar/23 21:51:29 wireless,info 5C:A3:9D:57:8E:0E@wlan1: disconnected, received disassoc: sending station leaving (8)
mar/23 21:55:32 wireless,info C0:D9:62:92:A4:EE@wlan1: disconnected, received disassoc: sending station leaving (8)
mar/23 21:57:31 wireless,info 14:99:E2:B7:90:42@wlan1: connected
mar/23 21:57:32 wireless,info 14:99:E2:B7:90:42@wlan2: disconnected, registered to other interface
mar/23 21:57:37 wireless,info A0:18:28:02:AC:35@wlan1: connected
mar/23 21:57:37 wireless,info A0:18:28:02:AC:35@wlan2: disconnected, registered to other interface
mar/23 23:25:05 wireless,info 6C:70:9F:25:91:B7@wlan2: connected
mar/23 23:25:05 wireless,info 6C:70:9F:25:91:B7@wlan1: disconnected, registered to other interface
mar/23 23:25:39 wireless,info 6C:70:9F:25:91:B7@wlan1: connected
mar/23 23:25:39 wireless,info 6C:70:9F:25:91:B7@wlan2: disconnected, registered to other interface

Any help would be appreciated as we have several clients using these as AP's

Thanks !
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Fri Mar 24, 2017 10:44 am

Never had to set preamble to long for Apple devices to work fine, as long as "both" was set (default settings are perfectly fine too) it worked flawlessly.

I suspect your problem is crowded spectrum.

First thing I would do is setting 2.4GHz to 20Mhz. Unless that AP is placed in the middle of the Desert, you can forget any device connecting at 40MHz.

I'd do a spectrum scan, and hardcode an specific channel for 2.4GHz.

If you have a non AC routerboard ap around, issue
/interface wireless spectral-history 0
then attach a screenshot here.

BTW your device is a hAP ac Lite, not hAP Lite.
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Fri Mar 24, 2017 1:47 pm

Hi

Unfortunately we do not have a non AC routerboard on-site to do a spectrum test. I did however do one with the AC Lite.
I also hard-coded the frequency as well as change preamble mode to both.

Export
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country="south africa" disabled=no distance=indoors frequency=2437 mode=ap-bridge radio-name="" ssid=****** wireless-protocol=802.11

set [ find default-name=wlan2 ] band=5ghz-a/n/ac channel-width=20/40mhz-eC country="south africa" disabled=no distance=indoors frequency=auto mode=ap-bridge ssid=***** wireless-protocol=802.11

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk eap-methods="" mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=******** wpa2-pre-shared-key=*******

Spectrum scan from HAP AC LITE
Selection_045.png
You do not have the required permissions to view the files attached to this post.
 
Marino
Frequent Visitor
Frequent Visitor
Posts: 53
Joined: Sun Jun 14, 2015 7:26 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Fri Mar 24, 2017 4:51 pm

Try using wpa2-psk with ciphers aes ccm only.
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Sat Mar 25, 2017 1:57 pm

What?!?! is spectral-history working on AC chipsets?????

Tested on a hAP ac and it rebooted (6.37.5), but this is GREAT news!

However cannot find any mention on the changelogs apart from
*) wireless - fixed full "spectral-history" header print on AP modes; (6.38)
Are you in the middle of the desert? can you spot other wireless networks on you phone?? Your spectrum looks abnormally clear...
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Thu Mar 30, 2017 10:14 am

Hi All,

Apologies for the delayed response, work pilling up.

Our Spectrum is open, as we manage the building and have 100's of client with this setup and need to get a fix soonest.

Again thanks guys for the feedback !!

Regards
 
User avatar
pukkita
Trainer
Trainer
Posts: 3037
Joined: Wed Dec 04, 2013 11:09 am
Location: Spain

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Thu Mar 30, 2017 9:51 pm

This is odd, never had any problems with iOS devices as long as the preamble mode is set as default (both).

Have you tried a different unit? a different power supply? How is it placed? Is it connected to a power strip shared with more equipment?
Simplicity is the Ultimate Sophistication - Da Vinci
Getting the most out of this forum
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Fri Mar 31, 2017 2:22 pm

Our setup is pretty basic. Each unit (flat) has a AP powered by default AD/DC power supply.
There is patch panel in each unit (wall-socket with 2 Eth ports) which in turn runs to our infrastructure switches and gets routed into our network.

We have dis on several AP units at different locations, so I highly doubt this could be a single unit problem. Maybe a batch with the wrong processor
chipset ?
 
PierreM
just joined
Topic Author
Posts: 13
Joined: Fri Jan 06, 2017 4:06 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Wed Apr 05, 2017 10:51 am

Hi All,

I tested this configuration on a HAP AC lite running version 6.37.5 bugfix and we are still experiencing this problem.

[admin@wem402a] /system package> pr
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-mipsbe 6.37.5
1 system 6.37.5
2 ipv6 6.37.5
3 wireless 6.37.5
4 hotspot 6.37.5
5 dhcp 6.37.5
6 mpls 6.37.5
7 routing 6.37.5
8 ppp 6.37.5
9 security 6.37.5
10 advanced-tools 6.37.5

[admin@wem402a] /system package> /system routerboard pr
routerboard: yes
model: RouterBOARD 952Ui-5ac2nD
serial-number: *******
firmware-type: qca9531L
factory-firmware: 3.33
current-firmware: 3.36
upgrade-firmware: 3.36

[admin@wem402a] /system package> /interface wireless export
# apr/05/2017 09:56:51 by RouterOS 6.37.5
# software id = M9M8-QX07
#
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-b/g/n country="south africa" \
disabled=no frequency=auto mode=ap-bridge wireless-protocol=802.11

set [ find default-name=wlan2 ] band=5ghz-a/n/ac country="south africa" \
disabled=no frequency=auto mode=ap-bridge wireless-protocol=802.11

/interface wireless security-profiles
set [ find default=yes ] authentication-types=wpa-psk,wpa2-psk mode=\
dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=******* \
wpa2-pre-shared-key=*******

/log pr
08:48:10 system,error,critical login failure for user root from 114.95.242.179 via ssh
08:49:26 wireless,info DC:41:5F:CD:C6:63@wlan2: disconnected, extensive data loss
08:53:14 dhcp,info dhcp1 deassigned 192.168.88.250 from 00:6D:52:1C:EA:B4
08:53:24 wireless,info 00:6D:52:1C:EA:B4@wlan1: connected
08:53:29 dhcp,info dhcp1 assigned 192.168.88.250 to 00:6D:52:1C:EA:B4
08:53:29 wireless,info 00:6D:52:1C:EA:B4@wlan1: disconnected, received disassoc: sending station leaving (8)
08:54:30 dhcp,info dhcp1 deassigned 192.168.88.249 from DC:41:5F:CD:C6:63
08:58:48 wireless,info 00:6D:52:1C:EA:B4@wlan1: connected
08:58:53 dhcp,info dhcp1 deassigned 192.168.88.250 from 00:6D:52:1C:EA:B4
08:58:54 dhcp,info dhcp1 assigned 192.168.88.250 to 00:6D:52:1C:EA:B4
09:06:41 wireless,info 00:6D:52:1C:EA:B4@wlan1: disconnected, received disassoc: sending station leaving (8)
09:06:41 wireless,info wlan1: data from unknown device 00:6D:52:1C:EA:B4, sent deauth
09:07:04 wireless,info 00:6D:52:1C:EA:B4@wlan1: connected
09:11:09 wireless,info 00:6D:52:1C:EA:B4@wlan1: disconnected, received disassoc: sending station leaving (8)
09:11:09 wireless,info wlan1: data from unknown device 00:6D:52:1C:EA:B4, sent deauth
09:14:43 wireless,info 28:CF:DA:F2:78:CA@wlan1: connected
09:14:48 wireless,info 28:CF:DA:F2:78:CA@wlan1: disconnected, unicast key exchange timeout
09:14:53 wireless,info 28:CF:DA:F2:78:CA@wlan1: connected
09:14:53 wireless,info 28:CF:DA:F2:78:CA@wlan2: disconnected, registered to other interface
09:17:08 dhcp,info dhcp1 deassigned 192.168.88.250 from 00:6D:52:1C:EA:B4
09:27:18 wireless,info 28:CF:DA:F2:78:CA@wlan1: disconnected, group key exchange timeout
09:27:18 wireless,info wlan1: data from unknown device 28:CF:DA:F2:78:CA, sent deauth
09:27:18 wireless,info wlan1: data from unknown device 28:CF:DA:F2:78:CA, sent deauth
09:27:20 wireless,info wlan1: data from unknown device 28:CF:DA:F2:78:CA, sent deauth

Regards
 
terencefaul
just joined
Posts: 2
Joined: Wed Jul 08, 2015 8:54 am

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Sun Sep 17, 2017 8:19 pm

Hi

Wondering if there was ever a solution to this problem, I have the same issue
 
User avatar
nicktc
just joined
Posts: 13
Joined: Mon Mar 28, 2016 9:52 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Tue Sep 26, 2017 7:03 pm

We have this problem on all (approx 400+) HAP AC (962UiGS-5HacT2HnT) devices. It seems the WiFi chip is not able to handle any interference. Devices work great out in the wilderness at camp sites and such but perform horribly in a crowded environment. Access points from other vendors seem to perform much better (unfortunately).

Hoping there will be a solution; but at this point we are looking at replacing them all.
 
matyxcz
just joined
Posts: 1
Joined: Mon Jan 22, 2018 1:21 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Mon Jan 22, 2018 1:34 pm

Hi all!
I've been having similar troubles, not only on Mac, but also PC, having wifi connection drop out and connect straight back in, which wasn't noticeable when working, but it did disrupt watching movies online (in case of larger files, TV over internet was fine due to buffering) and got to solve this problem when tried to play games online (usually do that on desktop via ethernet and ok, but from laptop over wifi the problem appeared).
And so far the problem dissapeared. My setup>
Mikrotik HAP Lite, firmware 6.40.5
several wifi devices (5 phones, 1 tablet, 3 laptops, printer ...)
ISP router is on 172.x.x.x range, and I have a DHCP running for 192.168.1.x, in AP BRIDGE mode (so just a regular AP)

What I've changed in my setup, all in the wireless iface (generally left the default, with only basic IP and security settings change on beginning on the HAP)>
Channel Width from 20/40 MHz Ce to 20/40 MHz eC
Band from 2GHz B/G/N to -only-N
disabled WPS mode
disabled Bridge Mode
and on top of that, I've ensured all devices having trouble have bluetooth disabled (like my Aspire S13 for example showed wifi signal increase when I've disabled BT)

Not sure this will help, but perhaps it's worth trying?
 
llubik
just joined
Posts: 21
Joined: Mon Mar 04, 2019 7:33 pm

Re: Mikrotik HAP Lite - Iphone/Ipad/Macbook disconnects - received disassoc error

Sun Feb 23, 2020 11:07 pm

Everything tested, with Apple products are the same mikrotik wifi the same problems. For a few years, no solution.

Who is online

Users browsing this forum: Bing [Bot] and 27 guests