Community discussions

 
tigerek
just joined
Topic Author
Posts: 1
Joined: Mon Jan 27, 2014 7:15 pm

wAP LTE KIT - not connecting to GSM network

Mon Dec 04, 2017 4:13 pm

Hi

I bought wAP LTE KIT, and I want to use it as home router with LTE/GSM as source of internet. Unfortunately I can't connect to LTE/GSM network (but I can see them on scanner).

I set MT with Quick Set. My config is:

[admin@MikroTik] > export file=
# jan/02/1970 00:05:02 by RouterOS 6.40.5
# software id = 21QE-DQB3
#
# model = RouterBOARD wAP R-2nD
# serial number = 7B7007B19FA0
/interface lte
set [ find ] apn=lteisp.pl mac-address=AC:FF:FF:00:00:00 name=lte1
/interface bridge
add name=bridge1
/interface wireless
set [ find default-name=wlan1 ] disabled=no mode=ap-bridge ssid=MikroTik wireless-protocol=802.11
/ip neighbor discovery
set lte1 discover=no
/interface wireless security-profiles
set [ find default=yes ] supplicant-identity=MikroTik
/ip pool
add name=dhcp ranges=192.168.99.100-192.168.99.254
/ip dhcp-server
add address-pool=dhcp disabled=no interface=bridge1 name=dhcp1
/interface bridge port
add bridge=bridge1 interface=ether1
add bridge=bridge1 interface=wlan1
/ip address
add address=192.168.99.1/24 interface=ether1 network=192.168.99.0
/ip dhcp-client
add dhcp-options=hostname,clientid interface=lte1
/ip dhcp-server network
add address=192.168.99.0/24 gateway=192.168.99.1 netmask=24
/ip firewall filter
add action=accept chain=input protocol=icmp
add action=accept chain=input connection-state=established
add action=accept chain=input connection-state=related
add action=drop chain=input in-interface=lte1
/ip firewall nat
add action=masquerade chain=srcnat out-interface=lte1
/ip upnp
set enabled=yes
/ip upnp interfaces
add interface=bridge1 type=internal
add interface=lte1 type=external
/system logging
add topics=lte
/tool mac-server
set [ find default=yes ] disabled=yes
add interface=ether1
add interface=wlan1
/tool mac-server mac-winbox
set [ find default=yes ] disabled=yes
add interface=ether1
add interface=wlan1

in log I can see:

00:09:22 lte,async lte1: rcvd OK
00:09:22 lte,async lte1: sent AT+CFUN=4
00:09:22 lte,async lte1: rcvd OK
00:09:22 lte,async lte1: sent AT+CMEE=1
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CREG=2
00:09:27 lte,async,event ^SIMST: 0
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CGREG=2
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CEREG=2
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CGEREP=2,0
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CMGF=0
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+CNMI=1,1,0,1,0
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT+EEMOPT=1
00:09:27 lte,async lte1: rcvd OK
00:09:27 lte,async lte1: sent AT*MRD_SN?
00:09:27 lte,async lte1: rcvd *MRD_SN:723C031137ED
00:09:27 lte,debug lte serial: *MRD_SN:723C031137ED
00:09:27 lte,async lte1: sent AT+CFUN=4
00:09:28 lte,async,event +CPIN: READY
00:09:28 lte,async,event ^SIMST: 1
00:09:28 lte,async lte1: rcvd OK
00:09:28 lte,async lte1: sent AT*CGDFLT=0,"IP","lteisp.pl",,,,,,,,,,,,,,,,,,1
00:09:28 lte,async lte1: rcvd OK
00:09:28 lte,async lte1: sent AT+CPIN?
00:09:28 lte,async lte1: rcvd +CPIN: READY
00:09:30 lte,async,event +MMSG: 2, 0
00:09:30 lte,async,event +MMSG: 3, 0
00:09:30 lte,async,event +MMSG: 0, 0
00:09:30 lte,async,event +MPBK: 1
00:09:31 lte,async lte1: sent AT+CPMS="SM","SM","SM"
00:09:31 lte,async lte1: rcvd +CPMS: 0,20,0,20,0,0
00:09:31 lte,async lte1: sent AT+CFUN?
00:09:31 lte,async lte1: rcvd +CFUN: 4
00:09:31 lte,async lte1: sent AT+CNUM
00:09:31 lte,async lte1: rcvd
00:09:31 lte,async lte1: sent AT+CIMI
00:09:31 lte,async lte1: rcvd 260011600754654
00:09:31 lte,async lte1: sent AT+CPIN?
00:09:31 lte,async lte1: rcvd +CPIN: READY
00:09:31 lte,async lte1: sent AT*BAND=15,79,147,480,589829,0,2,0
00:09:31 lte,async lte1: rcvd OK
00:09:32 lte,async lte1: sent AT+CFUN=1
00:09:32 lte,async,event +CREG: 2
00:09:32 lte,async,event +CEREG: 2
00:09:32 lte,async lte1: rcvd OK
00:09:32 lte,debug lte1: config ok
00:09:32 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:32 lte,async,raw lte1: rcvd +EEMGINFO : 0, 2
00:09:32 lte,async,raw lte1: sent AT+CSQ
00:09:32 lte,async,raw lte1: rcvd +CSQ: 99,99
00:09:33 lte,async,event +CREG: 3, 8cab, 7fd401, 7
00:09:33 lte,async,event +CEREG: 3,"8cab","007fd401",7
00:09:35 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:35 lte,async,raw lte1: rcvd +EEMGINFO : 3, 2
00:09:35 lte,async,raw lte1: sent AT+CSQ
00:09:35 lte,async,raw lte1: rcvd +CSQ: 99,99
00:09:38 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:38 lte,async,raw lte1: rcvd +EEMGINFO : 3, 2
00:09:38 lte,async,raw lte1: sent AT+CSQ
00:09:38 lte,async,raw lte1: rcvd +CSQ: 99,99
00:09:41 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:41 lte,async,raw lte1: rcvd +EEMGINFO : 3, 2
00:09:41 lte,async,raw lte1: sent AT+CSQ
00:09:41 lte,async,raw lte1: rcvd +CSQ: 99,99
00:09:44 lte,async,event +CREG: 11, 8cab, c1c8fdf, 2
00:09:44 lte,async,event +CGREG: 11,"8cab","0c1c8fdf",2,110
00:09:44 lte,async,event +CEREG: 0
00:09:44 lte,async,event +CREG: 3, 8cab, c1c8fdf, 2
00:09:44 lte,async,event +CGREG: 3,"8cab","0c1c8fdf",2,110
00:09:44 lte,async,event +CPIN: READY
00:09:44 lte,async,event ^SIMST: 4
00:09:44 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:44 lte,async,raw lte1: rcvd +EEMGINFO : 0, 1
00:09:44 lte,async,raw lte1: sent AT+CSQ
00:09:44 lte,async,raw lte1: rcvd +CSQ: 25,99
00:09:47 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:47 lte,async,raw lte1: rcvd +EEMGINFO : 0, 1
00:09:47 lte,async,raw lte1: sent AT+CSQ
00:09:47 lte,async,raw lte1: rcvd +CSQ: 25,99
00:09:49 lte,async,event +CREG: 11, 8cab, c1c8fdf, 2
00:09:49 lte,async,event +CGREG: 11,"8cab","0c1c8fdf",2,110
00:09:50 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:50 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:09:50 lte,async,raw lte1: sent AT+CSQ
00:09:50 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:09:50 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:09:50 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:09:50 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:09:50 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:09:50 lte,async,raw lte1: rcvd +CSQ: 22,99
00:09:53 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:53 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:09:53 lte,async,raw lte1: sent AT+CSQ
00:09:53 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:09:53 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:09:53 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:09:53 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:09:53 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:09:53 lte,async,raw lte1: rcvd +CSQ: 22,99
00:09:56 lte,async,raw lte1: sent AT+EEMGINFO?
00:09:56 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:09:56 lte,async,raw lte1: sent AT+CSQ
00:09:57 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:09:57 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:09:57 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:09:57 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:09:57 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:09:57 lte,async,raw lte1: rcvd +CSQ: 22,99
00:10:00 lte,async,raw lte1: sent AT+EEMGINFO?
00:10:00 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:10:00 lte,async,raw lte1: sent AT+CSQ
00:10:00 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:10:00 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:10:00 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:10:00 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:10:00 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:10:00 lte,async,raw lte1: rcvd +CSQ: 22,99
00:10:03 lte,async,raw lte1: sent AT+EEMGINFO?
00:10:03 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:10:03 lte,async,raw lte1: sent AT+CSQ
00:10:03 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:10:03 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:10:03 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:10:03 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:10:03 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:10:03 lte,async,raw lte1: rcvd +CSQ: 22,99
00:10:06 lte,async,raw lte1: sent AT+EEMGINFO?
00:10:06 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:10:06 lte,async,raw lte1: sent AT+CSQ
00:10:06 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:10:06 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:10:06 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:10:06 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:10:06 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:10:06 lte,async,raw lte1: rcvd +CSQ: 24,99
00:10:06 system,info,account user admin logged in from 192.168.99.23 via telnet
00:10:09 lte,async,raw lte1: sent AT+EEMGINFO?
00:10:09 lte,async,raw lte1: rcvd +EEMGINFO : 3, 1
00:10:09 lte,async,raw lte1: sent AT+CSQ
00:10:09 lte,async,event +EEMUMTSINTER: 0, -32768, 0, -115, 0, 0, 65534, 0, 2963, 222
00:10:09 lte,async,event +EEMUMTSINTER: 1, -32768, 0, -115, 0, 0, 65534, 1, 10762, 305
00:10:09 lte,async,event +EEMUMTSINTER: 2, -32768, 0, -115, 0, 0, 65534, 2, 10762, 304
00:10:09 lte,async,event +EEMUMTSINTER: 3, -32768, 0, -115, 0, 0, 65534, 3, 10762, 303
00:10:09 lte,async,event +EEMUMTSINTER: 4, -32768, 0, -115, 0, 0, 65534, 4, 10762, 136
00:10:09 lte,async,raw lte1: rcvd +CSQ: 24,99

[admin@MikroTik] > /interface lte info lte1 once
pin-status: no password required
functionality: full
manufacturer: "MikroTik"
model: "R11e-LTE"
revision: "MikroTik_CP_2.160.000_v001"
imei: 356..........
imsi: 260.......
Please, help me solve this problem :-(
 
Redmor
Member Candidate
Member Candidate
Posts: 250
Joined: Wed May 31, 2017 7:40 pm
Location: Italy

Re: wAP LTE KIT - not connecting to GSM network

Sun Dec 24, 2017 11:24 pm

Good evening,
I have got the same issue with 6.40.5 stable and I've asked to support for help.
Now with 6.41 everything should work, even if you're using custom APN and login that are not directly provided by your mobile carrier.
Things you have to do are:
1. Upgrade wAP to 6.41 stable
2. Upgrade firmware under System > Routerboard to the latest version.

I don't know if the latest RB version includes the new LTE firmware, I'm still waiting for new wAPs to try on, but if this doesn't solve the problem write to Mikrotik support and ask for the guide to upgrade LTE firmware.
I can send it to you, but I don't now if I'm allowed to, maybe it was a beta firmware.
I'm also interested to know if there's another way to upgrade LTE firmware without ATDT commands.
ImageImage
 
darkprocess
Member Candidate
Member Candidate
Posts: 253
Joined: Fri Mar 20, 2015 1:16 pm

Re: wAP LTE KIT - not connecting to GSM network

Mon Dec 25, 2017 1:19 am

Is your Sim working fine on an another device?
 
thepianist
just joined
Posts: 3
Joined: Mon Nov 07, 2016 12:34 pm

Re: wAP LTE KIT - not connecting to GSM network

Sat Dec 30, 2017 4:20 pm

Hello,

I have the same problem, could you please post info / file to upgrade the firmware of R11-LTE ?

Thanks a lot in advance
 
telepro
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Sun Apr 03, 2011 7:50 pm

Re: wAP LTE KIT - not connecting to GSM network

Mon Feb 26, 2018 11:04 pm

Has anyone successfully connected the RouterBOARD wAP R-2nD with the Mikrotik included R11e0LTE-US cellular interface card to a Verizon LTE network here in the US? if so, wereLTE card or Mikrotik ROS updates required?
SIM card was pulled from a working cellular interface from another operational device (Encore EN-400),
Verizon rep indicates that the device/interface card may have to go through an “Open Development Initiative” process - between Mikrotik (the manufacturer) and Verizon - before it is officially acceptable, but he also indicates that is probably not necessary to test operation if the sim card has already been registered with another acceptable cellular device on their network.

Thanks in advance.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: wAP LTE KIT - not connecting to GSM network

Tue Feb 27, 2018 12:56 pm

Has anyone successfully connected the RouterBOARD wAP R-2nD with the Mikrotik included R11e0LTE-US cellular interface card to a Verizon LTE network here in the US? if so, wereLTE card or Mikrotik ROS updates required?
SIM card was pulled from a working cellular interface from another operational device (Encore EN-400),
Verizon rep indicates that the device/interface card may have to go through an “Open Development Initiative” process - between Mikrotik (the manufacturer) and Verizon - before it is officially acceptable, but he also indicates that is probably not necessary to test operation if the sim card has already been registered with another acceptable cellular device on their network.

Thanks in advance.
What error message you see with the card when it tries to register to the network?
 
telepro
Frequent Visitor
Frequent Visitor
Posts: 63
Joined: Sun Apr 03, 2011 7:50 pm

Re: wAP LTE KIT - not connecting to GSM network

Tue Feb 27, 2018 5:52 pm

Uldis,

Sorry for any confusion.

We do have the wAP R-2nD LTE card communicating over the Verizon network. We used the device as delivered (ROS 40.4) but saw earlier comments about needing to update ROS and the LTE firmware. Perhaps this was to result in better reliability.

We were also told by our Verizon corporate rep that the Mikrotik unit was not "ODI certified by Verizon". Is this something Mikrotik is currently pursuing? For now, it seems to be a non-issue. When registering our SIM card we selected another device that we have used in the past and know to be Verizon certified. Used that SIM for a short interval on the selected hardware to verify it was set up properly. Then installed the SIM in the wAP R-2nD LTE Kit. Not sure what the lack of certification will result in the future, but for now we are continuing to test prior to widespread installation.

If you still want a log file or configuration information, let me know.
 
uldis
MikroTik Support
MikroTik Support
Posts: 3425
Joined: Mon May 31, 2004 2:55 pm

Re: wAP LTE KIT - not connecting to GSM network

Wed Feb 28, 2018 8:39 am

LTE firmware upgrade is for the International version and not for the US version.
For now we would suggest to upgrade the RouterOS.
 
syadnom
Member
Member
Posts: 403
Joined: Thu Jan 27, 2011 7:29 am

Re: wAP LTE KIT - not connecting to GSM network

Sat Sep 08, 2018 8:23 pm

telepro, just ran across this thread. Verizon sims work in the US version but you have to add an APN for vzwinternet and select that in the interface. You can enable or disable the default route, you can setup a different routing table and send out the lte interface too so you can more easily configure redundancy without having to script out finding the gateway (if dynamically addressed)

Who is online

Users browsing this forum: No registered users and 16 guests