Page 1 of 1

S+RJ10 10Gb SFP module: Do they even work?

Posted: Fri Mar 30, 2018 4:28 pm
by cohprog
Subject says it all: are those modules actually working at all?
I tested 6 of them in two different switch:
- CSS326-24G-2S+ running SwOS 2.7
- CRS317-1G-16S+ running RouterOS 6.41.3

1) The interfaces are always listed as up. They always shows that they did auto negotiation at 10G... whatever there is a cable pluged or not!
This would be annoying enough if it was just cosmetic but as the interfaces never go down/up whenever you unplug or replug a cable, this can make connectivity impossible when you move a cable from one port to another (probably because MAC addresses are never cleared from cache or something like that). Only way is to manually disable the interfaces or reboot the switch

2) There is connectivity problem (very large amount of packets lost) with many (all?) 100M devices, including some small office CISCO switch as well as some Catalyst CISCO switch and network cards from various brand. To be fair, I have the same problem with the 1G port of the CRS317 and the 1G SFP modules. I had to put a 1G switch from another brand between those devices.

3) It doesn't seem to be possible to know the actual speed and duplex of the link: As stated above, it always says "10G full duplex" even if there is nothing connected. Obviously, they are running at 1G when connected to a 1G device (that's about the only thing that work) but when connected to a 1G/2.5G/5G/10G device, there is no way to know the actual link speed.

4) I tried a connection between the CSS326 and the CRS317 over 35 meter of Cat 5e cable but nothing, not even ping, could go through it. Those modules are supposed to be able to do 1G/2.5G/5G/10G so even if they can't to 10G over Cat 5e, they should be able to do 2.5 or 5G. Worse case, they should at least negotiate 1G.

5) It doesn't seems to be possible to set manually the link speed/duplex. In SwOS, disabling auto-negotiation and setting 1G resulted in a not working connection (even if it was connected to a 1G module on the other side)

6) Replacing 1 of the Switch (over the 35m Cat 5e cable) with a Netgear XS508M "dumb" switch resulted in a partially working connection: The Netgear is showing 10G link speed and the link is usable but stop working from time to time. Probably because 10G is not really supposed to work over 5e cable. But they should have negotiated 2.5 or 5G link speed! Sadely, the Netgear is a dumb switch and it's not possible at all to manually set the speed of the interfaces.

At that point, I am giving-up. I replaced both Mikrotik with a Netgear XS508M and a Netgear GS110EMX: They work fine at 5G over 35m of Cat 5e cable. They also don't have problem with the various 100M devices.

Is it only a problem of software/driver (in both SwOS and RouterOS) with those SFP modules? Are they really able to work at 2.5 and 5G or only 1G and 10G? Do anyone had some success with them and if so with which version of RouterOS/SwOS?

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Mon Apr 09, 2018 12:34 am
by cvbkf

hope my answer does not come too late. i have three CRS326 installed, one per floor, with six S+RJ10 modules. the cables between the floors are duplex CAT5e F/UTP with ~50m length, so i put one CRS326 on the first floor. cellar to first floor are now ~20m, first floor to second floor ~30m cable length. at the cellar is my NAS, at the second floor my workstation. both systems use the ASUS XG-C100C NIC to get 10G ethernet. So, all your points are valid regarding wrong reporting of the SFP modules state. currently, 10G is running just fine:
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-60.00  sec  32.9 GBytes  4.71 Gbits/sec  2606             sender
[  4]   0.00-60.00  sec  32.9 GBytes  4.70 Gbits/sec                  receiver
[  6]   0.00-60.00  sec  32.5 GBytes  4.65 Gbits/sec  2521             sender
[  6]   0.00-60.00  sec  32.5 GBytes  4.65 Gbits/sec                  receiver
[SUM]   0.00-60.00  sec  65.3 GBytes  9.35 Gbits/sec  5127             sender
[SUM]   0.00-60.00  sec  65.3 GBytes  9.35 Gbits/sec                  receiver
But, at first i had some problems: while every single SFP module reported 10G connection speed, i was only able to achieve 2.3 GBit/s per second with iperf3. the problem was the cable between first and second floor, after switching to the second cable of the pair i got the full 10G. So, 2,5 and 5 should be working, but they will not be reported anywhere...

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Mon Apr 09, 2018 10:13 am
by cohprog
Thanks for your feedback!

My problem is that I am not even getting 1Gb: the link between the two Mikrotik with S+RJ10 over 35 meters of Cat 5e is just not working: It's possible to ping over it but any serious traffic just result in far too many packets lost.

If I replace one of the Mikrotik by a Netgear 10G (that can do 1G, 2.5G and 5G too) switch, it reports that the link is up at 10G. When trying to use the link, it works correctly (at 10G) for some minutes, then it stops working for some minutes, then it works again and so on.

When I replace both Mikrotik by Netgear 1/2.5/5/10G swtch, the link is negotiated at 10G and is fully workable (at 10G speed)

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Mon Apr 09, 2018 1:08 pm
by cvbkf
That is very strange, i think at least 1Gb has to work. While 35m may be too long for 10Gb, the lesser rates should work. Mikrotik states 30m as maximum length for a CAT6 cable, so a CAT5e cable is possibly worse.

I just tried it with my setup after patching both Cat5e cables together (total length now 45-50m), i can still achieve 9.41 GBit/s in both directions without any packet errors (iperf3 for 10 minutes). That's just my experience, but it proves that the modules are able to work with such lengths. Maybe the problem is with the cable itself ?

When using the Netgear Switches, did you try to induce heavy load on the cables (like iperf, netperf, ...) ?
Is it a FTP or an UTP cable ?
Does it work with the 1Gb Ports on the mikrotik switches without errors?

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Mon Apr 09, 2018 6:36 pm
by cohprog
Yes, with the 2 Netgear, I get 10G and can transfer data continuously at that speed without any problem (I got about 9 to 9.6Gbps transfering 10GB+ files between 2 servers) .

Using 1 Mikrotik with 10G port on one side and the other Mikrotik with a 1G port, on the other side, works without problem. So obviously, they negotiate 1G.

My guess is that the Netgear transceiver is more powerful and don't have problem over that length of Cat 5e cable.
Also, it seems that the Mikrotik doesn't try to negotiate a lower speed (whatever 1, 2.5 or 5G) when the device on the other side can handle 10G even if the connection in unreliable. And it's not possible to manually set the speed of the SFP in RouterOS or SwOS. SwOS offers 100M, 1G and 10G but if I remember correctly, trying to set 1G with a 10G module doesn't work. And that's not really the goal: I never expected 10G on that cable (so I am really pleased that the Netgear does it) but I was expecting 2.5 or 5G.

PS: Cable between the 2 switch is SFTP Cat 5e AWG24

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Thu Apr 12, 2018 5:53 am
by Ablesonebell
Maybe this is the reason why this 10GBASE-T copper SFP+ transceiver is cheaper than many other vendors.
I search on the Internet, prices vary enormously from vendor to vendor. For example: US$ 280.00 ... SFP10GBTST US$738.99
Thus, before buying this copper sfp+, you'd better ask for the sale rep about the specification in details.

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Thu Apr 19, 2018 2:17 am
by phil89

I can confirm these problems. I am using some of the S+RJ10 in my ICX 7150 switch (SFPs are working but I have exactly the same problems). Is it possible that the SFP choose the port speed by itself? Because my NAS is running on 10 Gbit and my Client PC on 5 Gbit. On the switch I can just see the port is up (also when no cable is plugged in) and the port speed is 10 GB, which is not correct.

Any ideas or can somebody tell me which SFP is the best for the ICX 7150 (10 GBe Copper)?

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Sun Oct 21, 2018 5:22 pm
by luckylinux

Sorry to bump this old thread but I thought I'd share my experience. By default these S+RJ10 modules work (I am on latest RouterOS 6.43.4).

However when running an iperf3 between 2 linux machines I was topping out at 1gbit / s. Something was wrong ...

My test setup is as following for those interested:
1st LINUX MACHINE (MELLANOX CONNECT-X 2 EN) <---> 1st CRS317-1G-16S+ <--> S+RJ10 <--> 8m CAT 5e cable (?) up to patch panel <--> 0.5m CAT 6 cable between patch panel ports <--> 15m CAT 5e cable (?) up to other side of the apartment <--> S+RJ10 module <--> 2nd CRS317-1G-16S+ <--> 2nd LINUX MACHINE (MELLANOX CONNECT-X 2 EN)

(So about 20-30m CAT 5e (probably UTP) cable)

Then I started digging around ... I tried setting link manually to 10gbps on both sides. That made the link very unstable. Then I put it back to "Link auto-negotiation" but I saw that the setting "Advertise" in Interfaces -> sfp-sfpplus1 had all the speed modes between 2.5G and 10G disabled !!!

I tried then fiddling around: I unchecked everything "Advertise" from 10M to 1000M. I checked 2.5G, 5G and 10G. Now I could run iperf3 at about 2.2 gbit / s. Next step: I also unchecked 2.5, leaving only 5G and 10G. It seems that this module will auto-negotiate to the lowest possible speed (well gigabit or more) between those selected :? .

(Note: I did this on both switches. Furthermore I also set "Tx Flow Control" and "Rx Flow Control" to "auto", not sure if that helped).

I am now running a stable link and can run consistent iperf3 tests between the 2 linux machines at 4.7 gbit / s. Not bad considering the crap quality of the cable in the walls ...

Hope this can help somebody :D

Re: S+RJ10 10Gb SFP module: Do they even work?

Posted: Mon Oct 29, 2018 3:47 am
by lapsio
This module is a joke. Unfortunately I bought one. The only excuse for its crappyness is price which is like half of normal, properly working 10GBase-T SFP+ module. But well I guess it's good that such hardware exists for those who desperately need 10G copper and are broke af. Still it's terrible device that barely works.