Page 1 of 1

LtAP Mini GPS useless without antenna

Posted: Wed Jul 04, 2018 3:30 pm
by kalamaja
Hello.

Is it an intended behaviour that LtAP Mini's internal GPS feature is useless without adding external antenna (= ACGPSA+ACSMAUFL)? I see GPS data running in the logs but have not been able to get any position lock. As USB port is for power only I'm also unable to add USB GPS module.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 04, 2018 4:27 pm
by normis
Most likely you have not disabled "/system console" and set the GPS menu to use serial0. Please do these things and only then GPS will work.
External antenna is optional, but will work much better.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 04, 2018 10:08 pm
by kalamaja
Software and firmware 6.42.5, fresh default configuration. What I do:
/system console disable 0
/system gps set port=serial0 enabled=yes
Resulting in:
/port
set 0 baud-rate=auto data-bits=8 flow-control=none name=serial0 parity=none stop-bits=1
/port firmware
set directory=firmware ignore-directip-modem=no
/system gps
set channel=0 enabled=yes gps-antenna-select=internal init-string="" port=serial0 set-system-time=no
If I set GPS logging, I see GPS data running. The only change I see is that date changes from Nov/30/1999 00:00:00 to Jan/06/1980 00:02:30 (GPS start era).

Jul/04/2018 21:47:25 gps,raw GPS:: $GPGGA,001014.020,,,,,0,0,,,M,,M,,*4E
Jul/04/2018 21:47:25 gps,raw GPS:: $GPGLL,,,,,001014.020,V,N*7C
Jul/04/2018 21:47:25 gps,raw GPS:: $GPGSA,A,1,,,,,,,,,,,,,,,*1E
Jul/04/2018 21:47:25 gps,raw GPS:: $GPGSV,1,1,00*79
Jul/04/2018 21:47:25 gps,raw GPS:: $GPRMC,001014.020,V,,,,,0.00,0.00,060180,,,N*44
Jul/04/2018 21:47:25 gps,raw GPS:: $GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
Jul/04/2018 21:47:26 gps,raw GPS:: $GPGGA,001015.020,,,,,0,0,,,M,,M,,*4F
Jul/04/2018 21:47:26 gps,raw GPS:: $GPGLL,,,,,001015.020,V,N*7D
Jul/04/2018 21:47:26 gps,raw GPS:: $GPGSA,A,1,,,,,,,,,,,,,,,*1E
Jul/04/2018 21:47:26 gps,raw GPS:: $GPGSV,1,1,00*79
Jul/04/2018 21:47:26 gps,raw GPS:: $GPRMC,001015.020,V,,,,,0.00,0.00,060180,,,N*45
Jul/04/2018 21:47:26 gps,raw GPS:: $GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
Jul/04/2018 21:47:27 gps,raw GPS:: $GPGGA,001016.020,,,,,0,0,,,M,,M,,*4C
Jul/04/2018 21:47:27 gps,raw GPS:: $GPGLL,,,,,001016.020,V,N*7E
Jul/04/2018 21:47:27 gps,raw GPS:: $GPGSA,A,1,,,,,,,,,,,,,,,*1E
Jul/04/2018 21:47:27 gps,raw GPS:: $GPGSV,1,1,00*79
Jul/04/2018 21:47:27 gps,raw GPS:: $GPRMC,001016.020,V,,,,,0.00,0.00,060180,,,N*46
Jul/04/2018 21:47:27 gps,raw GPS:: $GPVTG,0.00,T,,M,0.00,N,0.00,K,N*32
....

Am I missing smth?

With mAP 2nd + BU-353S4 USB GPS module I'm able to get location fixed literary in seconds.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Jul 05, 2018 5:07 pm
by jebz

Am I missing smth?

With mAP 2nd + BU-353S4 USB GPS module I'm able to get location fixed literary in seconds.
.
Patients, please wait. A new GPS can take up to half an hour the first time. Many GPS have small batteries to assist in regaining their values more quickly after a restart.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Jul 05, 2018 6:16 pm
by mgisbers
I've got same problem here. Console is disabled and serial0 is assigned to gps.

After enable of gps I can see gps,raw messages within the logfile. Even after 6 hours - which should be enough time to sync - it shows that there is not even a single satellite found.

I even tried two ltap mini, one of them with stock configuration. Both with 6.42.5 packages.

And, of course, both testet outside with free sky view.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Jul 08, 2018 6:53 pm
by korniza
same here. I was lucky and bought an external antenna.
In real life there is no internal antenna for gps connected.
Also GPS led it stays off when there is no satellite connected. This led can not be used for any other function.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 13, 2018 7:00 pm
by nemke
Same problem. Put LtAP on roof of the house in clear sky.
GPS enabled. Wait 2h and nothing, no GPS data. In logs there are gps traffic
Used with internet antena, didn't buy and attach external one. Will external antena correct problem ?
LTE work normaly.

Nemanja

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 13, 2018 10:25 pm
by nemke
And, is it possibe to use other external GPS antenas with SMA, not only MT (ACGPSA) ?
https://www.amazon.de/Teltonika-GPS-GNS ... B077C66RTK
Like this, for example

Re: LtAP Mini GPS useless without antenna

Posted: Mon Jul 16, 2018 10:13 am
by normis
Same problem. Put LtAP on roof of the house in clear sky.
GPS enabled. Wait 2h and nothing, no GPS data. In logs there are gps traffic
Used with internet antena, didn't buy and attach external one. Will external antena correct problem ?
LTE work normaly.

Nemanja
It means GPS data goes to console, see my previous responses. Turn off serial console in RouterOS, then set GPS menu to use Serial0

Re: LtAP Mini GPS useless without antenna

Posted: Mon Jul 16, 2018 9:29 pm
by nemke
Same problem. Put LtAP on roof of the house in clear sky.
GPS enabled. Wait 2h and nothing, no GPS data. In logs there are gps traffic
Used with internet antena, didn't buy and attach external one. Will external antena correct problem ?
LTE work normaly.

Nemanja
It means GPS data goes to console, see my previous responses. Turn off serial console in RouterOS, then set GPS menu to use Serial0
Done that. I read all post, especialy reply from MT support...

[admin@Brod Pozerveac 6] > system console disable 0
[admin@Brod Pozerveac 6] > system console print
Flags: X - disabled, U - used, F - free
# PORT TERM
0 X serial0 vt102
[admin@xxxxxxxxxx] > system console set disabled=yes 0
[admin@xxxxxxxxxx] > system gps print
enabled: yes
port: serial0
channel: 0
init-string:
set-system-time: no
gps-antenna-select: internal
[admin@xxxxxxxxxx] > system console print
Flags: X - disabled, U - used, F - free
# PORT TERM
0 X serial0 vt102
[admin@xxxxxxxxxx] > system gps
[admin@xxxxxxxxxx] /system gps> monitor
date-and-time: jan/06/1980 00:13:34
latitude: none
longitude: none
altitude: 0.000000m
speed: 0.000000 km/h
destination-bearing: none
true-bearing: 0.000000 deg. True
magnetic-bearing: 0.000000 deg. Mag
valid: no
satellites: 0
fix-quality: 0
horizontal-dilution: 0
-- [Q quit|D dump|C-z pause]
[admin@xxxxxxxxxx] > system package print
Flags: X - disabled
# NAME VERSION SCHEDULED
0 routeros-mipsbe 6.42.6
1 system 6.42.6
2 X ipv6 6.42.6
3 wireless 6.42.6
4 hotspot 6.42.6
5 dhcp 6.42.6
6 mpls 6.42.6
7 routing 6.42.6
8 ppp 6.42.6
9 security 6.42.6
10 advanced-tools 6.42.6
11 gps 6.42.6
[admin@xxxxxxxxxx] > system routerboard print
routerboard: yes
board-name: LtAP mini
model: RB912R-2nD
serial-number: 8F00099D99FB
firmware-type: qca9531L
factory-firmware: 6.42.1
current-firmware: 6.42.6
upgrade-firmware: 6.42.6


LtAP is on roof for 3h and stil no fix.

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 1:45 am
by HenryChinaski
Hi!

I think i got the same issue, any solution?

Ltap Mini, no external antenna. No GPS data

Thanks, henry

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 7:49 am
by normis
Try external antenna, does it get a fix then? How soon? Are you guys using the LTE modem?

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 9:40 am
by mgisbers
Try external antenna, does it get a fix then? How soon? Are you guys using the LTE modem?
Hi, just bought an external antenna. Will report after check.

With one of my LtAPs I tried to use GPS in addition to LTE with the other one I used GPS only with disabled LTE. Both of them showed the same result: no satellites found.

I will now start drilling a hole and put an antenna to one of them.

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 9:51 am
by kalamaja
Try external antenna, does it get a fix then? How soon? Are you guys using the LTE modem?
GPS-data in the log is self-generated (GPGGA, GPGLL, GPGSA, GPGSV etc) so no actual traffic from sattellites. I've run it on internal antenna for tens of hours in open air, powered from USB while driving, submitting coordinates over LTE using demo application, and for all that time only ONCE it has been able to send non-zero coordinates.

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 7:51 pm
by rzirzi
I have the same problem wit my brand new LtAP mini LTE kit - no GPS signal receiving :(
I have configured like in that example: https://wiki.mikrotik.com/wiki/Manual:System/GPS
GPS module is not receiving coordinations:(((( Should I send it to RMA?

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 8:06 pm
by nemke
Hello
Problem iz with internal antena. I buy externat, plug it, and imediatly GPS show cordinate.
[admin@xxxxxxxxxxx] > system gps monitor
date-and-time: jul/17/2018 16:59:06
latitude: N 44 50' 40.98''
longitude: E 20 24' 35.142''
altitude: 107.400002m
speed: 0.018520 km/h
destination-bearing: none
true-bearing: 157.399994 deg. True
magnetic-bearing: 0.000000 deg. Mag
valid: yes
satellites: 10
fix-quality: 1
horizontal-dilution: 1.04

I try with GPS antena internal or externel in settup, it work in any case, WITH EXTERNAL GPS antena connected to LtAP. LtAP is IN SAME PLACE like in previsus tests when there is no GPS data.
So, I think that internal antena is bud desine, OR LTE antena make interfirance or block GPS signal.
I will try to remove cover from LtAP and/or disable LTE.

I will post answer

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 8:32 pm
by nemke
Spend some time testing this. Have device in front of me so I can easy make tests.

I try to:
1. reset LtAP to default, and start from 0
2. remove cover, LTE and WIFI enabled - no GPS,
3. removed cover, LTE and WIFI disabled - no GPS
4. Cover on, disable LTE and WIFI - no GSP
and so on ......

So I try any of combination with cover, LTE and WIFI, and IN ANY CASE GPS DON'T WORK WITHOUT EXTERNAL ANTENNA in my case.

For me that is not problem to have antenna, but will be much easy if MT sell GPS antenna WITH device, in same box, not like separate accessory so You can buy it or not.
For 10$ more, you have complete thing. It will save time and testing and garantie good service.
LTE work OK, with integrated antenna,no problem for now. Only GPS have problem.
For test didn't buy and use MT GPS antena, I use ARKNAV A-130 external antenna with 5m cable


GPS realy work now, so for me this is solved

Thank you
Nemanja

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 17, 2018 10:29 pm
by HenryChinaski
Ok,

So it seems for GPS working on Ltap Mini Antenna is mandatory?

Could Mikrotik Support confirm this? I bought my ltap mini abroad, no mikrotik Antenna in my country. What kind of antenna and pigtail i have to look for?

Thanks.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 18, 2018 12:14 am
by nemke
Ok,

So it seems for GPS working on Ltap Mini Antenna is mandatory?

Could Mikrotik Support confirm this? I bought my ltap mini abroad, no mikrotik Antenna in my country. What kind of antenna and pigtail i have to look for?

Thanks.
https://mikrotik.com/product/acsmaufl this one for GPS and for LTE (if yuo need external antenna) I buy 3 peaces of this pigtail, two are for external LTE antena and one for GPS antena
My GPS antenna has SMA connector so it fits to this pigtail.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 18, 2018 2:01 pm
by rzirzi
MikroTik team - could You answer to this topic? Where is a problem with LtAP and GPS?

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 18, 2018 2:04 pm
by normis
We are seeing that the internal antenna becomes compromised when LTE is used, so for the time being, MikroTik recommends using an external antenna with these devices, if accuracy and speed of acquisition are paramount. We will try to resolve the issue, or adjust the product information, depending on our findings.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Jul 18, 2018 6:03 pm
by HenryChinaski
Normis.

Hi.

When you say "LTE Is used" you mean, LTE card present? Service active ? Or interface up?

Im not using LTE service in my tests so this should not be an issue.

I Will try to buy an antenna for further testing.

Is GPS service more accurate while using LTE?

Sorry if this questions are so basic. Im new to this GPS/LTE World

I found ltap device amazing hardware. I Will continue with this tests and post results

Henry

Re: LtAP Mini GPS useless without antenna

Posted: Thu Jul 19, 2018 9:21 am
by normis
In that case, remove the LTE card, and also try to mount it differently, with serial port pointing up

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 20, 2018 8:41 pm
by kalamaja
In that case, remove the LTE card, and also try to mount it differently, with serial port pointing up
I see no difference from disabling or removing LTE card: no luck. Tested with external MT GPS module: gets fix in seconds and 6-8 sattellites always visible. What I see on 6.43rc44 is that when external antenna is connected then there's no difference of switching antenna parameter to external or internal, always the same result as with external antenna.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Aug 05, 2018 6:01 pm
by CuninganReset
Hello.

I have seen the same, the internal antenna is useless at all.
Also, I have upgraded to 6.53rc51 and now my GPS disappear from the device.
I tried to downgrade to 6.42.6 to test if it comes back but no, it is still lost.
And as last resort, I tried with NetInstall but the same result, I have now a Ltap mini without GPS.

And LTE speed is around 10 to 15 Mbps.

Re: LtAP Mini GPS useless without antenna

Posted: Mon Aug 06, 2018 8:21 pm
by CuninganReset
Ok, the GPS must be installed from extra packages but it still does not fix any position with internal antenna.

I am waiting for the external one and the pigtail.

My biggest issue now is that device reboot every couple of minutes, it appears to have some issue and reboot by itself.
Hello.

I have seen the same, the internal antenna is useless at all.
Also, I have upgraded to 6.53rc51 and now my GPS disappear from the device.
I tried to downgrade to 6.42.6 to test if it comes back but no, it is still lost.
And as last resort, I tried with NetInstall but the same result, I have now a Ltap mini without GPS.

And LTE speed is around 10 to 15 Mbps.

Re: LtAP Mini GPS useless without antenna

Posted: Mon Aug 06, 2018 9:30 pm
by CuninganReset
I have some idea of what is happening with the ltAP mini and the reboots.

I was powering it up using USB and a 2.0A power adapter and I was connecting using Wifi (ltAP as AP) and when I connected it reboots.

To me, it appears to be a USB power issue, with LTE, GPS and Wifi working at the same time it appears that USB is not enough and it reboots suddenly.

Now I am powering it up using the power plug and it is stable for 1 hour.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Aug 16, 2018 1:54 pm
by vanyo
I've spent a lot of time to get the GPS going. I found one thing, which caused the problems:
In the MT wiki https://wiki.mikrotik.com/wiki/Manual:System/GPS they recommend setting the port:
[admin@MikroTik] /port> set 0 baud-rate=4800 parity=odd
[admin@MikroTik] /port> print detail 
Flags: I - inactive 
 0   name="usb1" used-by="" channels=1 baud-rate=4800 data-bits=8 parity=odd stop-bits=1 flow-control=none
In our case it should be parity=none:
[admin@MikroTik] /port> set 0 baud-rate=auto parity=none
[admin@MikroTik] /port> print detail 
Flags: I - inactive 
 0   name="serial0" used-by="" channels=1 baud-rate=auto data-bits=8 parity=none stop-bits=1 flow-control=none

Re: LtAP Mini GPS useless without antenna

Posted: Sat Aug 18, 2018 1:05 am
by jdillig
I spent hours screwing around with the GPS on this unit until finally finding the polarity setting mentioned. The Wiki article needs to be updated to reflect the actual configuration settings required to get this to work. Also it requires the external antenna, which frankly is just poor design. Why not include the $10 part/cable with the unit if it doesn't work without it. I had to source both the RP-SMA to u.FL and the external antenna separately.

I am also a little skeptical of the waterproof of this unit; it seems more like water resistant.

However this is far cheaper then cradle point and kinda cool if it works.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Aug 23, 2018 12:58 am
by sophitus
Hello,

why is GPS support still advertised by Mikrotik? Can it be fixed by firmware update? Should the devices be recalled and exchanged? First time disappointed by Mikrotik's QA.....

Thanks for a reply!

Re: LtAP Mini GPS useless without antenna

Posted: Thu Aug 23, 2018 10:02 am
by normis
If you use the antenna, GPS works fine. We will clarify this in the brochure.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Aug 23, 2018 2:28 pm
by sophitus
The device is too big for my purpose with external antenna. I bought it because you (Mikrotik) claimed it supports GPS out of the box with internal antenna initially! My mobile phone has LTE and GPS working both together with no interference.

Is this really Mikrotik's support policy?

1) Changing the specs after design problems have been detected by customers after a product launch
2) Not stopping instantly false advertisements on the local web site
3) Not informing customer nor distributors whether the issue is hardware based or it can and will be fixed by firmware update
4) Not recalling a defective product

It's a shame. You make really nice products otherwise.... I cannot understand how lenient some of your customers are, especially those posting to this forum

Re: LtAP Mini GPS useless without antenna

Posted: Sat Aug 25, 2018 7:10 am
by ubntuser
6.43rc64 fixed Internal GPS issue! Port settings are default and I switched from External to Internal and immediately picked up 4 satellites, in the middle of my house.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Aug 26, 2018 12:26 am
by sophitus
Can anybody from MikroTik confirm that? Release notes?

Re: LtAP Mini GPS useless without antenna

Posted: Sun Aug 26, 2018 7:33 am
by ubntuser
+1 for confirmation from support. In other news, Ubiquiti GPS units from the Rockets M GPS series will work with this unit. I also attached a screenshot of my current GPS settings.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Aug 26, 2018 6:36 pm
by sophitus
Did you remove the external GPS antenna before changing to internal one? Some people claim once external GPS antenna is attached you can switch to internal or external and it always works, i.e. it always takes external even if displayed internal.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Aug 26, 2018 7:30 pm
by ubntuser
I had external GPS connected, when I switched over to internal. Once I saw that internal GPS was connecting I then removed the external GPS while the device was still powered on. I did some more configuring and rebooted the unit multiple times and Internal GPS always came back on. You got me thinking, so I shutdown and removed power from the device....waited a bit and reconnected power and now Internal GPS has yet to lock on. Dang....sorry for the false hope!

Re: LtAP Mini GPS useless without antenna

Posted: Mon Aug 27, 2018 9:39 am
by CuninganReset
to me, it works with the external antenna and it works pretty good, with HDOP of less than 0.9

But with the internal antenna, it is impossible at all.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Aug 29, 2018 3:53 pm
by CuninganReset
To me, it works with an external antenna.

It is very precise but sometimes it jumps to the side by some meters and comes back.
I don't know if it is produced by the LTE card because I am using LTE and GPS.
Imagen1.jpg
You can see it in the trace here, i am plotting every second but every couple of seconds it "jumps" and come back.

Re: LtAP Mini GPS useless without antenna

Posted: Wed Aug 29, 2018 4:39 pm
by mkx
... every couple of seconds it "jumps" and come back.
So better don't rely on it for autonomous vehicle driving. :wink:

Re: LtAP Mini GPS useless without antenna

Posted: Mon Sep 03, 2018 3:06 pm
by CuninganReset
not, better not to rely on it for autonomous vehicles.
... every couple of seconds it "jumps" and come back.
So better don't rely on it for autonomous vehicle driving. :wink:

Re: LtAP Mini GPS useless without antenna

Posted: Mon Sep 10, 2018 5:15 pm
by cstrobl
hi,

is there any solution possible?

my config:
ROS 6.43
ltap mini w activated LTE (RB912R-2nD)

MikroTik ACSMAUFL - U.fl-SMA (male)-Pigtail
MikroTik ACGPSA - GPS-Antenne mit SMA-Stecker

[admin@MikroTik] > /system gps print
enabled: yes
port: serial0
channel: 0
init-string:
set-system-time: no
gps-antenna-select: internal
[admin@MikroTik] >

[admin@MikroTik] > /port print
Flags: I - inactive
# DEVICE NAME CHANNELS USED-BY BAUD-RATE
0 serial0 1 GPS auto

Re: LtAP Mini GPS useless without antenna

Posted: Wed Sep 12, 2018 12:40 pm
by CuninganReset
Hi guys.

Please have a look to this post I wrote about LtAP Mini with LTE kit and external antennas.

viewtopic.php?f=3&t=139088

Re: LtAP Mini GPS useless without antenna

Posted: Wed Nov 14, 2018 1:14 pm
by AndrewM
Hi!
Yesterday I tested my brand new LtAP mini Kit.
Conditions: clear sunny sky (parking), no any high buildings or trees, device is on the roof of the car. Select internal antena - /System gps. And I have no GPS connection (waiting about 30 min). OK. Connection external GPS antena ... device booting up and I see coordinates :). /System shutdown, disconnect from PSU, disconnect GPS antenna, booting up, change from external to internal antenna - /System gps. No GPS signal.
Does LtAP mini Kit has real internal GPS antena? If yes, what condition I need to do to see coordinates? ROS 6.43.4 with Extra packages version.
Please help.

Re: LtAP Mini GPS useless without antenna

Posted: Sun Nov 18, 2018 7:39 pm
by CTSsean
My question is how did this get past QA? How did so many devices who cannot lock on to GPS without an external antenna get shipped?

This is probably as paramount for a recall from Mikrotik as I've ever seen. A core feature which is advertised (STILL) on the device but doesn't state the external antenna is REQUIRED. Just states its 'available'.

Re: LtAP Mini GPS useless without antenna

Posted: Tue Nov 20, 2018 10:17 am
by normis
Screenshot 2018-11-20 at 10.17.43.png

Re: LtAP Mini GPS useless without antenna

Posted: Tue Nov 20, 2018 5:22 pm
by nimbo78
@normis lol, good job! :))

Re: LtAP Mini GPS useless without antenna

Posted: Thu Nov 22, 2018 8:24 pm
by CuninganReset
@normis lol, good job! :))
Now it's clear, it's fail and better change the datasheet... LoL

Re: LtAP Mini GPS useless without antenna

Posted: Fri Dec 14, 2018 1:14 pm
by gelzi
Hi all,

for me it's the same situation: ltap mini with external GPS antenna doesn't find any satellites and signal for more than 24h, same for internal.

Console is disabled, I followed the wiki to activate GPS.

[admin@MikroTik] > export hide-sensitive

# dec/14/2018 12:07:41 by RouterOS 6.43.7
# software id = PVNX-XKR5
# model = RB912R-2nD
# serial number = 8F0009604674
/system clock
set time-zone-name=Europe/Berlin
/system gps
set enabled=yes gps-antenna-select=external init-string="" port=serial0
[admin@MikroTik] /port> print detail
Flags: I - inactive
0 name="serial0" used-by="GPS" device="" channels=1 baud-rate=auto data-bits=8 parity=none stop-bits=1 flow-control=none

Any idea how to fix this problem?

Thanks,
Joerg

Re: LtAP Mini GPS useless without antenna

Posted: Wed Dec 19, 2018 3:16 pm
by WirelessRudy
Screenshot 2018-11-20 at 10.17.43.png
Normis, your post is misleading....
LtAP mini manual shot.JPG
The manual and sales info are clearly stating "Build in GPS" and the info on the website actually states: "Use the built in GPS module to track the location of your vehicle in real time, we have even provided a simple tracking application example ... etc."

Now the words "GPS module" might implicate only the receiver unit, but in not explicit stating you need an external antenna any buyer will understand this as a unit that can be used like it comes without the need to fit an external antenna. Websites of dealers also state that all you need is to fit and with any GPS tracking application you can follow your device. External antenna is sold 'as extra' to get 'better result'. Nowhere info is given without external antenna unit will not work!

I wan't the internal antenna to work. If not I can basically sue Mikrotik for giving false information. I am not looking for that. But the least I want them to sort out the non working internal antenna or change all info on manuals, website and inform dealers since they also sell the unit as "works out of the box after inserting sim with credentials"... it is simply not true....

Re: LtAP Mini GPS useless without antenna

Posted: Wed Dec 19, 2018 3:40 pm
by normis
Internal antenna exists and works if you have no miniPCIe module inside or if mounted with ports pointing up.
Surely, most cases will have a module, this is why we mention recommendation for external antenna.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 1:59 am
by WirelessRudy
Internal antenna exists and works if you have no miniPCIe module inside or if mounted with ports pointing up.
Surely, most cases will have a module, this is why we mention recommendation for external antenna.
You must be kidding. This answer is not good enough...

People buy this device to have a small LTE connected device that can be tracked after fitting in a car, bus, taxi, ship or whatever, without any hassle due its internal GPS option. That's the main reason to buy this device. Because it's small and needs no external stuff.
Sales info tells buyer that it has internal antenna and if device comes fit with miniPCe card. Buyer can expect it to work that way, especial as its said that an external antena is an 'option' to "improve the signal"!

If now it seems the device would only work with external antenna than it should come in the package and not as an 'option' that needs to be ordered separate. It's plain false information and I don't know, but in a country like the US (or probably even in EU countries) that is a piece of cake for lawyers to make a nice lawsuit. When buyer can proof he has damage due this false information Mikrotik is going to bleed and will have to take back devices or will be punished.

The bottom line is this device is sold under false promises, shame on you guys.....
I think this is one of the biggest deceptions I've seen in Mikrotik in the 12 years I use them now.....

Actually I am tempted to ask my lawyer to see how we can file a complaint at the EU standards and trade commission if your are not coming up with an more satisfactory solution.

After all, if my mobile can have all 3 functions (Wifi hotspot, G4 (LTE) connectivity and GPS tracking performing at the same time I don't see why you guys cannot manage to have this unit do the same.....

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 7:48 am
by normis
The brochure and webpage does say that external antenna is required.
We actually sell a lot of products without included antennas. Assumption is not good enough for any product. Always check environment before installing something. Netmetal also works poorly without antennas. For that one, we don't even suggest any antennas, it's somehow common sense.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 11:37 am
by WirelessRudy
The brochure and webpage does say that external antenna is required.
We actually sell a lot of products without included antennas. Assumption is not good enough for any product. Always check environment before installing something. Netmetal also works poorly without antennas. For that one, we don't even suggest any antennas, it's somehow common sense.
Can you please explain what the difference is in the two highlighted wordings? The first means "included and fully funcional" and indeed it is working. The second according you means "included but needs additional device".
LtAP mini manual shot.JPG
And see the difference in the NetMetal manual;
NetMetal manual shot.JPG

In LtAP manual it is stated; "External GPS antenna is available for ordering separately (not included, product code ACGPSA)". By mentioning is means it is a option.
NetMetal manual doesn't say that external antenna can be ordered. Because it is clear from the start the device is radio/router only and peripherals need to be ordered to make it work.

LtAP brochure states that LTE modem is included in the purchase but you state that in using the internal GPS this modem has to be removed! Why is it sold included?
NetMetal brochure states that miniPCe slot is provided for ยท3G/4G so it is option to buy.

I am amazed you are defending this any further. Many in this tread already claimed the same as I do.
Also, nobody in this tread actually showed the internal antenna worked under any circumstance. As I also just found out. Even with your suggestion of removing the LTE modem and put the unit up side down (or in any other position) after many hours the device still sees no satellites.....

It would be nice to admit the brochure/manual should be revised. Internal antenna is just not available as you already showed some posts ago... Period. We are not stupid, don't sell us lies. Re-phrase the brochure and manual and inform your sales channels accordingly.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 11:48 am
by normis
I know that you will nitpick this ad infinitum, but I agree, I will make sure the brochure is more clear about this, so everyone can understand it.
Screenshot 2018-12-20 at 11.46.59.png

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 11:51 am
by WirelessRudy
I know that you will nitpick this ad infinitum, but I agree, I will make sure the brochure is more clear about this, so everyone can understand it.

Screenshot 2018-12-20 at 11.46.59.png
Thanks. :D

Re: LtAP Mini GPS useless without antenna

Posted: Thu Dec 20, 2018 11:53 am
by normis
BTW that screenshot is from the old brochure. I mean later today we will add some more stuff for you.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Dec 21, 2018 3:48 pm
by WirelessRudy
BTW that screenshot is from the old brochure. I mean later today we will add some more stuff for you.
I made the screenshot straight from the mikrotik website, grabbed it and put it on the post. So the post was showing an up to date screenshot no more then 5 mins old.......

Merry X-Mas! :D

Re: LtAP Mini GPS useless without antenna

Posted: Fri Dec 21, 2018 3:54 pm
by normis
BTW that screenshot is from the old brochure. I mean later today we will add some more stuff for you.
I made the screenshot straight from the mikrotik website, grabbed it and put it on the post. So the post was showing an up to date screenshot no more then 5 mins old.......

Merry X-Mas! :D
Rudy, that text has been there for months :D

Re: LtAP Mini GPS useless without antenna

Posted: Sun Dec 30, 2018 5:45 pm
by mihajloomozaik
Same here, I tried with and without an external antenna but no success...
I have followed every step mentioned here in the forum and in the wiki
Coordinates are 0...

New firmware and RouterOS.
The external antenna under the clear sky on a car roof top
LTE works fine

Any solution anyone?

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jan 11, 2019 4:34 pm
by kalamaja
Any solution anyone?
External antenna is mandatory with LTE card. You can add 1 GPS antenna and 1-2 LTE antennas, so external GPS-only (GPSANT) or GPS+LTE combined antenna is needed. You also need 1-3 U.fl Female / SMA Female pigtails to connect them.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Jan 17, 2019 3:06 pm
by mihajloomozaik
It simply doesn't work
i run this commands:
/system console disable 0
/system gps set port=serial0 enabled=yes gps-antenna-select=external
/port set 0 baud-rate=auto data-bits=8 flow-control=none name=serial0 parity=none stop-bits=1
/port firmware set directory=firmware ignore-directip-modem=no

and I get this:
Image
I have original mikrotik external anntena and this female adapter.
Someone help I will pay if someone make me this work..
My private email: mihajloomozaik@gmail.com

Re: LtAP Mini GPS useless without antenna

Posted: Thu Jan 17, 2019 3:10 pm
by normis
Just make sure you have not damaged the device by plugging/unplugging the GPS antenna, while the device is on. The GPS antennas are active antennas (3.3V), so touching the connector in wrong way, can damage it. Check with multimeter if the uFL connector on the board gives out 3.3V (center pin / outside )

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jan 18, 2019 12:26 am
by mihajloomozaik
I was testing with 3 new lap mini devices...
It's really strange and weird

I just have this:
https://prnt.sc/m8n6kd

Can you give us quick tutorial how to set this up?
My antenna is outside the window on the open sky for hours.

When I touch with uFL connector with one part and with other the metal of external gps antenna, I'm getting signals...

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jan 18, 2019 10:58 am
by normis
enable gps logging like this:
Screenshot 2019-01-18 at 10.57.33.png
don't want to scare you, but it theoretically is possible to burn 3 devices, just as well as one :D

please be careful and do not plug/unplug the antenna when unit is turned on.

Re: LtAP Mini GPS useless without antenna

Posted: Sat Jan 19, 2019 4:50 am
by mihajloomozaik
Thanks for that, but I still get the same: https://prnt.sc/m96514

lat and long are none

I tested ext GPS adapter and it gives me 2,9 v, so it's not burned
I'm using the original MikroTik antenna which is outside.

I think I will give up on this
If someone can help please contact me at mihajloomozaik@gmail.com or +436764900674

Re: LtAP Mini GPS useless without antenna

Posted: Sun Jan 27, 2019 3:34 am
by GioBar
Hi All,

so disappointed with Mikrotik, after those years and ...
why even this problem is still actual, I also wasted my time to figure our something, and why Mikrotik Support thinks we are stupid, looks like a real good case for good lawyer to teach something how to do busyness, but MK is not a MS or APPLE and etc..
please just fix problem or change add and help with some solution with owners of those devices.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Feb 07, 2019 5:19 pm
by CuninganReset
Thanks for that, but I still get the same: https://prnt.sc/m96514

lat and long are none

I tested ext GPS adapter and it gives me 2,9 v, so it's not burned
I'm using the original MikroTik antenna which is outside.

I think I will give up on this
If someone can help please contact me at mihajloomozaik@gmail.com or +436764900674
Here you were obtaining correct values, you have trashed something, first fix can take very long depending your antenna and the placement.

With direct sky view, it can take as long as 10 minutes to fix first position.

Re: LtAP Mini GPS useless without antenna

Posted: Thu Feb 07, 2019 5:20 pm
by CuninganReset
Hi All,

so disappointed with Mikrotik, after those years and ...
why even this problem is still actual, I also wasted my time to figure our something, and why Mikrotik Support thinks we are stupid, looks like a real good case for good lawyer to teach something how to do busyness, but MK is not a MS or APPLE and etc..
please just fix problem or change add and help with some solution with owners of those devices.
I have more than 100 hundred LtAP working, all without issues.

It is clearly not the best device but, you can not find any device with this price and power.

It seems that you trashed your GPS chip or something.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Feb 08, 2019 9:57 am
by normis
You have to be very careful with the GPS antenna connector. GPS uses an active antenna (3.3V), so you must be very careful when touching the connector. I actually suggest to plug the antenna (or open the lid) only when unit is completely powered off.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Feb 08, 2019 10:14 am
by antonsb
Hi All,

so disappointed with Mikrotik, after those years and ...
Looks like wrong baud rate.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Feb 08, 2019 11:06 pm
by GioBar
Imageits auto as advertised,

tell me and I will change and put results here

Re: LtAP Mini GPS useless without antenna

Posted: Mon Feb 11, 2019 9:11 am
by CuninganReset
Imageits auto as advertised,

tell me and I will change and put results here
Hello.

You are not using a LtAP Mini, this is another GPS, in this case, I would select 9600 Bauds, 8,N,1 and in GPS antenna "external" rather than "internal".

Re: LtAP Mini GPS useless without antenna

Posted: Mon Feb 11, 2019 9:12 am
by CuninganReset
And also, it depends on the GPS you are using, for example, if it is a Ublox it will be using Ublox native language rather than standard NMEA0183 messages.

Re: LtAP Mini GPS useless without antenna

Posted: Sat Feb 16, 2019 4:49 pm
by neutronlaser
Why do you want GPS? What is wrong with NTP from internet?

Re: LtAP Mini GPS useless without antenna

Posted: Sat Feb 16, 2019 8:48 pm
by mkx
Why do you want GPS? What is wrong with NTP from internet?
How does NTP help with positioning?

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 05, 2019 12:46 am
by Thor187
Internal antenna exists and works if you have no miniPCIe module inside or if mounted with ports pointing up.
Surely, most cases will have a module, this is why we mention recommendation for external antenna.
2019-07-04_23-43-29.png

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 05, 2019 9:21 am
by normis
GPS device is built in. Antenna needs to be connected externally. I mean, it says that right in your image. Read it please, outside the yellow marked words.

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 05, 2019 11:12 am
by mkx
GPS device is built in. Antenna needs to be connected externally. I mean, it says that right in your image. Read it please, outside the yellow marked words.
The wording in the pamphlet is unfortunate:
... and integrated GPS support ... External GPS antenna is available for ordering separately (not included, product code GPSANT).
The highlited text, together with the leading excerpt, leads to conclusion that everything necessary for GPS reception is already included, but for some special deployment (e.g. mounting the LtAP mini under some metal roof which blocks reception of GPS signal by the LtAP device itself) the optional external GPS antenna might be needed.

If use of external GPS antenna is mandatory, the last phrase should be reworded, for example
Use of external GPS antenna is mandatory, but none is included. Suitable external GPS antenna is available for ordering separately (product code GPSANT).

Re: LtAP Mini GPS useless without antenna

Posted: Fri Jul 05, 2019 11:14 am
by GioBar
GPS device is built in. Antenna needs to be connected externally. I mean, it says that right in your image. Read it please, outside the yellow marked words.
The wording in the pamphlet is unfortunate:
... and integrated GPS support ... External GPS antenna is available for ordering separately (not included, product code GPSANT).
The highlited text, together with the leading excerpt, leads to conclusion that everything necessary for GPS reception is already included, but for some special deployment (e.g. mounting the LtAP mini under some metal roof which blocks reception of GPS signal by the LtAP device itself) the optional external GPS antenna might be needed.

If use of external GPS antenna is mandatory, the last phrase should be reworded, for example
Use of external GPS antenna is mandatory, but it's not included. Suitable external GPS antenna is available for ordering separately (product code GPSANT).
100%

Re: LtAP Mini GPS useless without antenna

Posted: Mon Jul 08, 2019 8:30 pm
by Thor187
GPS device is built in. Antenna needs to be connected externally. I mean, it says that right in your image. Read it please, outside the yellow marked words.
Fix your product description and refund me for misleading marketing.
Thanks.

Re: LtAP Mini GPS useless without antenna

Posted: Tue Jul 09, 2019 9:53 am
by normis
Fix your product description
I'm sorry you understood the device has fully functional GPS without the use of external antennas. We did try to make it clear in the description of the device. It's already there in several places.

Sorry for misunderstanding.
refund me
If you purchased the device from me, I will refund you, of course.
Otherwise, please contact the seller / shop where you bought it.