Community discussions

 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

bricked RB435G netinstall stop at Formatting Harddrive

Wed Aug 15, 2018 2:01 pm

Hi, everyone,
I have a routerboard RB435GUAH. i used it for about 1 year, it was fine.
last week I soft reboot it by click the "reboot" button in the winbox. and it never comes back.
No sound after boot. (before, when it works fine, it play two sounds after boot. )
when plug the power, it keeps rebooting every about 180seconds.
I don't have a PC with RS232 port so I bought a USB to RS232(DB9) with a chip CH340, but it seems didn't work.
I have two notebook computers. I tried netinstall, by holding the reset button and plug the power, about 30 seconds after, my routerboard shows in the netinstaller.
I click it, in the router/drives frame, and the packages frame turns to blank. no package there.
So I thought I maybe downloaded the wrong npk file. I opened the website and downloaded all the packages for all the platforms.
this time the netinstaller shows a package, the routeros-smips.
well, maybe my RB435G is a fake board, otherwise why it only shows the smips package in the netinstaller?
so I click the routeros-smips and click install, it stop at Formatting Harddrive...
I tried Netinstall v6.42 v6.40, all same, only shows the smips packages.
If use Netinstall v5.27 or v4.17, after clicked the rb435g, the application shows the MIPSBE packages, which I think is correct. but after choose one and click install, it stop at Formatting Harddrive.
I use only the cat6 cable to connect the routerboard and my computer, without a rs232 cable. I am not sure if the rs232 is the key?
any help would be appreciate.
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Fri Aug 17, 2018 5:00 am

Hi,
is that, I need a rs232 cable, to do the netinstall on the RB435G?
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Fri Aug 17, 2018 11:14 am

No, you don't need a serial cable to do Netinstall. Having one just makes it easier to debug things when you run into problems.

RB435G should definitely be mipsbe and not smips. I am wondering if the NAND flash chip on your board is bad? smips and mipsbe might be similar enough to each other that maybe the only way that Netinstall distinguishes between them is if a big-endian MIPS board has a flash chip under 32MiB in size?

When your 435G shows up in Netinstall, what does it say in the "Label" column?

-- Nathan
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Fri Aug 17, 2018 7:03 pm

No, you don't need a serial cable to do Netinstall. Having one just makes it easier to debug things when you run into problems.

RB435G should definitely be mipsbe and not smips. I am wondering if the NAND flash chip on your board is bad? smips and mipsbe might be similar enough to each other that maybe the only way that Netinstall distinguishes between them is if a big-endian MIPS board has a flash chip under 32MiB in size?

When your 435G shows up in Netinstall, what does it say in the "Label" column?

-- Nathan
Thanks for the answer.
The label shows RB435G and the Mac address is correct.
When I used the net install v5.xx or v4.17, the Packages frame shows mipsbe packages which I think is correct.
I went to a XP computer and same thing happened.
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sat Aug 18, 2018 6:04 am

I used a different computer with windows 10. and using a switch between the computer and the board.
running the Netinstall on windows 10 and then power the rb435g, after a beep, it shows in the Netinstall. (just like what had happened before in others computer)
and this time I used Netinstall v6.0 and it shows the software ID and the correct package (mipsbe packages).
but no further progress, after clicked install, stop at "partition and formatting harddrive".

after I tested so many versions of Netinstall, I found that only the v6.0 and v6.1 can show the software ID and correct packages in the sametime.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sat Aug 18, 2018 8:07 am

I suspect that you are going to need to figure out how to get your serial port working, so that you can see what RouterBOOT is printing on the console. It may provide a clue about what the problem is.

-- Nathan
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sat Aug 18, 2018 9:41 am

I suspect that you are going to need to figure out how to get your serial port working, so that you can see what RouterBOOT is printing on the console. It may provide a clue about what the problem is.

-- Nathan
Thank you, Nathan.
I will buy a null modem rs232 cable and a rs232 pci-e card.
BTW, what console software should I use in windows 10?
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sun Aug 19, 2018 9:10 pm

I suspect that you are going to need to figure out how to get your serial port working, so that you can see what RouterBOOT is printing on the console. It may provide a clue about what the problem is.

-- Nathan
Thank you, Nathan.
I used the null modem rs232 cable to connect the board and my computer.
Here is the code displayed in the console:

Code: Select all

RouterBOOT backup booter 3.22

RouterBoard 435G

CPU frequency: 680 MHz
Memory size: 256 MiB
NAND size: 2048 MiB

Press any key within 2 seconds to enter setup..

loading kernel from nand... kernel not found
trying bootp protocol... OK
Got IP address: 192.168.88.199
resolved mac address 4C:CC:6A:0F:8D:XX
transfer started ........................... transfer ok, time=1.33s
setting up elf image... OK
jumping to kernel code
Welcome to MikroTik Router Software remote installation
Press Ctrl-Alt-Delete to abort

mac-address: 4C:5E:0C:8E:XX:B7
mac-address: 4C:5E:0C:8E:XX:B6
mac-address: 4C:5E:0C:8E:XX:B5

software-id: 7T0U-XXXX key:
W2yjYNmuj6kxXXBv/gn1HJBz1TXXhdwrhyDDtflHD+GL0AAll58lXXYb+0Dvqa8XDSCpgogl5ogpQNu0qLXyHA==

Waiting for installation server...
Found server at 4C:CC:6A:0F:8D:XX

Formatting disk...
ERROR: could not format partitions
Press ENTER to reboot
Restarting system.

And I had tried e-format nand, tried g-upgrade firmware to fwf 3.41, both shows done but no effect.
tried many versions of Netinstall and got same message in the console, "ERROR: could not format partitions".
I used a fresh installed windows 10 and I for sure closed the firewall. I tried all three ether ports and only the PoE port can connect to Netinstall.

And, in console, it says my Nand size is 2GB???
RouterBoard 435G

CPU frequency: 680 MHz
  Memory size: 256 MiB
    NAND size: 2048 MiB
This is strange, cause I know the RB435G has only 64MB, right?
what else can I try? I want my routerboard works.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Mon Aug 20, 2018 3:53 am

Yeah, this is what I suspected. The NAND is defective. It isn't even detecting the right size. It probably failed while the router was still running, but it kept on running because it was already booted. When you told it to reboot after the NAND had failed, it never came back.

Probably the only way to fix the board is to swap new NAND chip in place of the defective one. Working with surface-mount components is difficult and you will probably need a professional to help you do it if it's not a procedure you are familiar with or if you don't have the proper tools, so the board is likely not worth repairing. If it is less than a year old, you could contact the distributor you bought it from and have them swap it for you under warranty.

Sorry for the bad news,

-- Nathan
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Mon Aug 20, 2018 4:19 am

Yeah, this is what I suspected. The NAND is defective. It isn't even detecting the right size. It probably failed while the router was still running, but it kept on running because it was already booted. When you told it to reboot after the NAND had failed, it never came back.

Probably the only way to fix the board is to swap new NAND chip in place of the defective one. Working with surface-mount components is difficult and you will probably need a professional to help you do it if it's not a procedure you are familiar with or if you don't have the proper tools, so the board is likely not worth repairing. If it is less than a year old, you could contact the distributor you bought it from and have them swap it for you under warranty.

Sorry for the bad news,

-- Nathan
Thanks, Nathan.
That is bad news.
I will just throw it into the trash can.
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Tue Aug 28, 2018 2:28 pm

Yeah, this is what I suspected. The NAND is defective. It isn't even detecting the right size. It probably failed while the router was still running, but it kept on running because it was already booted. When you told it to reboot after the NAND had failed, it never came back.

Probably the only way to fix the board is to swap new NAND chip in place of the defective one. Working with surface-mount components is difficult and you will probably need a professional to help you do it if it's not a procedure you are familiar with or if you don't have the proper tools, so the board is likely not worth repairing. If it is less than a year old, you could contact the distributor you bought it from and have them swap it for you under warranty.

Sorry for the bad news,

-- Nathan
Nathan, sorry to bother you again.
I was wondering, if I swap a new NAND chip in place of the defective one, after I do that, can I use Netinstall to install the RouterOS?
If not, what should I do after I swap that NAND chip. Is that the booter will gone after I replace the NAND chip? if it's gone, is it possible for me to make it installed on the new chip?
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Fri Sep 07, 2018 4:00 pm

I was wondering, if I swap a new NAND chip in place of the defective one, after I do that, can I use Netinstall to install the RouterOS?
If not, what should I do after I swap that NAND chip. Is that the booter will gone after I replace the NAND chip? if it's gone, is it possible for me to make it installed on the new chip?
`
Sorry, I saw this and then forgot to respond to it. My understanding is that RouterBOOT (bootloader) actually lives on a separate (and much smaller) SPI flash chip. I also believe that the RouterOS Software-ID and license key are both also stored on the same flash NOR with RouterBOOT, so you shouldn't lose those either. If you have access to the tools necessary to swap the surface-mount NAND chip as well as the skills to do it, RouterBOOT should still be intact, as should your RouterOS license. In theory, you should be able to just perform Netinstall again and have it work.

If you actually manage to succeed at replacing the NAND and resurrecting your board, I would love to hear about it! It would confirm a lot of my theories and perhaps also give others with failed NANDs hope!

Good luck,

-- Nathan
 
jebz
Member Candidate
Member Candidate
Posts: 238
Joined: Sun May 01, 2011 12:03 pm
Location: Australia

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sun Sep 09, 2018 10:51 am


RouterBoard 435G

CPU frequency: 680 MHz
Memory size: 256 MiB
NAND size: 2048 MiB[/code]
This is strange, cause I know the RB435G has only 64MB, right?
what else can I try? I want my routerboard works.
.
Do you have a micro SD card in the board? 2048MB seems suspiciously like a card may be present. I'd bring the board back to bare with nothing extra plugged in.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Mon Sep 10, 2018 9:57 am

Do you have a micro SD card in the board? 2048MB seems suspiciously like a card may be present.
`
NAND specifically refers to on-board NAND. If the microSD slot is populated, RouterBOOT will not mention it. The number that is shown for NAND size by the bootloader should never change from what it showed on the first day use fresh from the factory, and should certainly never *increase*.

-- Nathan
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Mon Sep 10, 2018 12:14 pm

I was wondering, if I swap a new NAND chip in place of the defective one, after I do that, can I use Netinstall to install the RouterOS?
If not, what should I do after I swap that NAND chip. Is that the booter will gone after I replace the NAND chip? if it's gone, is it possible for me to make it installed on the new chip?
`
Sorry, I saw this and then forgot to respond to it. My understanding is that RouterBOOT (bootloader) actually lives on a separate (and much smaller) SPI flash chip. I also believe that the RouterOS Software-ID and license key are both also stored on the same flash NOR with RouterBOOT, so you shouldn't lose those either. If you have access to the tools necessary to swap the surface-mount NAND chip as well as the skills to do it, RouterBOOT should still be intact, as should your RouterOS license. In theory, you should be able to just perform Netinstall again and have it work.

If you actually manage to succeed at replacing the NAND and resurrecting your board, I would love to hear about it! It would confirm a lot of my theories and perhaps also give others with failed NANDs hope!

Good luck,

-- Nathan
Thanks again, Nathan.
Is it possible to boot from network server, I mean if I have a UBUNTU server in the same network, can I use this bricked RB435G to boot a RouterOS from the server.
Did you mean the license will be lost if I replace the NAND chip.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Mon Sep 10, 2018 3:34 pm

Did you mean the license will be lost if I replace the NAND chip.
`
I am sorry if I did not explain this clearly before. If my understanding of where the license is stored is correct, then in theory, you will NOT lose the license by replacing the NAND chip. NAND chip only stores your copy of RouterOS, but the license is located on a separate NOR chip (where RouterBOOT lives). MikroTik has never confirmed this publicly (to my knowledge), though, so I could be wrong. If you decide to try and swap the NAND, it would be a very interesting and educational experiment!
`
Is it possible to boot from network server, I mean if I have a UBUNTU server in the same network, can I use this bricked RB435G to boot a RouterOS from the server.
`
Sorry, unfortunately not. RouterOS assumes local storage is available to hold config, logs, etc. and it would have no idea what to do or where to look for config in a netboot scenario. MikroTik has not engineered RouterOS to support this.

(You could netboot a RouterOS kernel, but that would not do you any good, because the RouterOS kernel's "initramfs" would try to mount local NAND to access the RouterOS userland. The SquashFS filesystem is not part of the kernel/ELF payload.)

-- Nathan
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Tue Sep 11, 2018 8:50 pm

Did you mean the license will be lost if I replace the NAND chip.
`
I am sorry if I did not explain this clearly before. If my understanding of where the license is stored is correct, then in theory, you will NOT lose the license by replacing the NAND chip. NAND chip only stores your copy of RouterOS, but the license is located on a separate NOR chip (where RouterBOOT lives). MikroTik has never confirmed this publicly (to my knowledge), though, so I could be wrong. If you decide to try and swap the NAND, it would be a very interesting and educational experiment!
`
Is it possible to boot from network server, I mean if I have a UBUNTU server in the same network, can I use this bricked RB435G to boot a RouterOS from the server.
`
Sorry, unfortunately not. RouterOS assumes local storage is available to hold config, logs, etc. and it would have no idea what to do or where to look for config in a netboot scenario. MikroTik has not engineered RouterOS to support this.

(You could netboot a RouterOS kernel, but that would not do you any good, because the RouterOS kernel's "initramfs" would try to mount local NAND to access the RouterOS userland. The SquashFS filesystem is not part of the kernel/ELF payload.)

-- Nathan
Hi, Nathan.
I have a master here, he have been doing this job for more than 20 years, and he helped me replaced the nand chip. excellent work.
so I had the SAME samsung NAND chip replaced in the SAME place and i am pretty sure that the new NAND chip is good.
But, when using Netinstall, all things happened just like before i replaced the NAND.
Things displayed in the console, just like before. nothing changed, just like i didn't replace the NAND. it shows 2048Mib.
ALL THINGS Just like I wrote above this post.
So I guess the original NAND was not defective, it was good. there must be something wrong on anywhere else.
oh, you were right about the booter and the key, they are in the SPI flash seperate from the NAND.
 
User avatar
NathanA
Forum Veteran
Forum Veteran
Posts: 801
Joined: Tue Aug 03, 2004 9:01 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Wed Sep 12, 2018 5:58 pm

Wow, that is crazy! If the NAND wasn't defective, the only theory I can come up with is that there is something else physically wrong with the board. Maybe one of the PCB traces between the CPU/SoC and the flash chip is faulty or broken? If your friend is as good with electronics repair as he sounds like, he might be able to test for proper continuity between each NAND chip pin and where the trace for it is supposed to terminate on the board (a long and difficult troubleshooting process for sure!).

-- Nathan
 
Denmmx
just joined
Posts: 1
Joined: Sat Oct 20, 2018 3:45 pm

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sat Oct 20, 2018 3:52 pm

Did you mean the license will be lost if I replace the NAND chip.
`
I am sorry if I did not explain this clearly before. If my understanding of where the license is stored is correct, then in theory, you will NOT lose the license by replacing the NAND chip. NAND chip only stores your copy of RouterOS, but the license is located on a separate NOR chip (where RouterBOOT lives). MikroTik has never confirmed this publicly (to my knowledge), though, so I could be wrong. If you decide to try and swap the NAND, it would be a very interesting and educational experiment!
`
Is it possible to boot from network server, I mean if I have a UBUNTU server in the same network, can I use this bricked RB435G to boot a RouterOS from the server.
`
Sorry, unfortunately not. RouterOS assumes local storage is available to hold config, logs, etc. and it would have no idea what to do or where to look for config in a netboot scenario. MikroTik has not engineered RouterOS to support this.

(You could netboot a RouterOS kernel, but that would not do you any good, because the RouterOS kernel's "initramfs" would try to mount local NAND to access the RouterOS userland. The SquashFS filesystem is not part of the kernel/ELF payload.)

-- Nathan
Hi, Nathan.
I have a master here, he have been doing this job for more than 20 years, and he helped me replaced the nand chip. excellent work.
so I had the SAME samsung NAND chip replaced in the SAME place and i am pretty sure that the new NAND chip is good.
But, when using Netinstall, all things happened just like before i replaced the NAND.
Things displayed in the console, just like before. nothing changed, just like i didn't replace the NAND. it shows 2048Mib.
ALL THINGS Just like I wrote above this post.
So I guess the original NAND was not defective, it was good. there must be something wrong on anywhere else.
oh, you were right about the booter and the key, they are in the SPI flash seperate from the NAND.
Hi, liaobamboo!
Did you solved your problem? I have same issue with Mikrotik CCR1036-12G-4S. After upgrade to latest ROS it does not boot, other symptoms are exactly the same as yours... I also want to replace the NAND chip. Is it worth it?
 
liaobamboo
just joined
Topic Author
Posts: 12
Joined: Sat Aug 11, 2018 11:42 am

Re: bricked RB435G netinstall stop at Formatting Harddrive

Sat Oct 27, 2018 10:19 am


Hi, liaobamboo!
Did you solved your problem? I have same issue with Mikrotik CCR1036-12G-4S. After upgrade to latest ROS it does not boot, other symptoms are exactly the same as yours... I also want to replace the NAND chip. Is it worth it?
hi, Denmmx,
I didn't solve my problem. the problem was still there before I gave it out to a recycle man.
Sorry.

Who is online

Users browsing this forum: No registered users and 15 guests