Community discussions

  • 1
  • 3
  • 4
  • 5
  • 6
  • 7
 
deanMKD1
Member
Member
Posts: 321
Joined: Fri Dec 12, 2014 12:06 am
Location: Macedonia
Contact:

Re: RB4011

Thu Nov 15, 2018 10:51 am

Someone to share test from wireless version or not come yet to anyone?
 
User avatar
pcunite
Long time Member
Long time Member
Posts: 634
Joined: Sat May 25, 2013 5:13 am
Location: USA

Re: RB4011

Thu Nov 15, 2018 4:45 pm

Someone to share test from wireless version or not come yet to anyone?
I've not seen stock anywhere. No one has one to test yet.
 
kamillo
Member Candidate
Member Candidate
Posts: 143
Joined: Tue Jul 15, 2014 5:44 pm

Re: RB4011

Thu Nov 15, 2018 9:44 pm

https://linitx.com/search.php?keywords=rb4011 says:
Stock expected 7-Dec-2018
 
Pranja
just joined
Posts: 11
Joined: Mon Dec 12, 2016 10:09 am

Re: RB4011

Fri Nov 16, 2018 2:43 pm

Did anyone dissasemble rackmount version? I am curious to know if mpcie slot is present and usable.
 
grusu
Frequent Visitor
Frequent Visitor
Posts: 85
Joined: Tue Aug 13, 2013 7:35 am
Location: Bucharest, Romania

Re: RB4011

Fri Nov 16, 2018 4:59 pm

You do not need to open it to see that mpcie slot connectors are missing.
 
bd0g
just joined
Posts: 3
Joined: Tue May 23, 2017 11:54 am

Re: RB4011

Wed Nov 21, 2018 12:29 pm

Too bad the 4011 lacks LCD & USB... it won't replace my 3011LCD
 
Pranja
just joined
Posts: 11
Joined: Mon Dec 12, 2016 10:09 am

Re: RB4011

Wed Nov 21, 2018 1:17 pm

 
kos
just joined
Posts: 14
Joined: Mon Oct 31, 2016 11:51 am

Re: RB4011

Fri Nov 23, 2018 9:06 am

A problem with flapping 1G optical SFP interfaces. Two different vendors tested (not Mikrotik). There is no issue when using 10G interfaces.
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: RB4011

Fri Nov 23, 2018 10:14 am

Disable auto negotiation and 1Gb SFP will work correctly.

https://wiki.mikrotik.com/wiki/MikroTik ... ansceivers
For MikroTik devices with SFP+ interface that support both 10G and 1G link rate following settings are needed to be set on both linked devices for required interfaces. These settings only relate when optical SFP transceivers are used. In order to get them working in 1G link rate, use the following configuration:
  • auto-negotiation disabled
  • port speed 1G
  • FD
Devices which SFP+ ports support 1G links:
  • RB4011 series - SFP+1 interface can be used in 1G mode if required.
 
kos
just joined
Posts: 14
Joined: Mon Oct 31, 2016 11:51 am

Re: RB4011

Fri Nov 23, 2018 11:36 am

The problem persist with disabled auto negotiation, even between two RB4011 devices.
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: RB4011

Fri Nov 23, 2018 12:21 pm

I haven't tested between two RB4011s, but between RB2011 and RB4011 the flapping will stop if you disable autoneg on both the RB4011 and RB2011, not just the RB4011.
 
kos
just joined
Posts: 14
Joined: Mon Oct 31, 2016 11:51 am

Re: RB4011

Fri Nov 23, 2018 1:54 pm

If you try to disconnect/connect them a few times, I think that the problem will appear.
 
ziustag
just joined
Posts: 1
Joined: Thu Nov 29, 2018 12:49 am

Re: RB4011

Thu Nov 29, 2018 1:10 am

I'm pretty interested in this device, since it seems a good successor to the already pretty cool RB2011 series, which my internet provider is kinda recommending.

However I'm very confused about SFP(+) and the compatibility of those modules to this specific device. My provider requires the following specs: 10 km, TX1310 / RX1490nm

I don't seem to find something with those specs from Mikrotik and I'm not sure if some third party interface like the Flexoptix 1G SFP Wideband BiDi LX LC Simplex will be supported. Has anybody any recommendations on this? People in this thread seem to already have problems with the SFP module.

Sorry if it's a stupid question, but I have absolutely no clue about SFP and what all those numbers mean exactly. This seems way more complicated than necessary.
 
codruts
just joined
Posts: 4
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011

Thu Nov 29, 2018 8:43 pm

first quick opinion - it's running hot. really hot, without any serious load.
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Thu Nov 29, 2018 8:57 pm

first quick opinion - it's running hot. really hot, without any serious load.
No wonder - it's beefy yet passive. CCR1009-PC can give you actual burns if you touch heatsink while it's powered on. Even if idling (there's actually not that huge difference in thermals between idle and stress)
 
r00t
newbie
Posts: 39
Joined: Tue Nov 28, 2017 2:14 am

Re: RB4011

Thu Nov 29, 2018 11:43 pm

This SFP mess is really annoying! Why can't it just work? If I connect cheap TP-Link switch to Cisco, auto negotiation on SFP works. Same with even cheaper Realtek cards, various Dell servers and other equipment. But no, for Mikrotik, you have to manually set the speeds on both ends.
Where's the problem? Some hardware issue on used chipset/cpu on Mikrotik side? Bad implementation? Incompatibility of some SFPs? Or just laziness to do it right?
And "Just disable auto negotiation and set rate manually" is NOT the solution. What if you can't set other side of the link? Often any administrative change of parameters of upstream link costs extra money. This needs to be either fixed or have warning written on all Mikrotik product pages that SFP port doesn't support auto negotiation. It's 2018 and you expect these things to just work. If there was a list of verified SFPs that do work, that would be fine. But so far it seems auto negotiation on SFP port just doesn't work, no matter what SFP or DAC you use.
Fix it or say clearly it's not supported and will never work!
 
djdrastic
Member Candidate
Member Candidate
Posts: 288
Joined: Wed Aug 01, 2012 2:14 pm

Re: RB4011

Fri Nov 30, 2018 12:04 am

Any EOIP / EOIP+IPSEC or VPLS tests ?

Would like to know how it goes against a CCR-1009
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Fri Nov 30, 2018 12:17 am

This SFP mess is really annoying! Why can't it just work? If I connect cheap TP-Link switch to Cisco, auto negotiation on SFP works. Same with even cheaper Realtek cards, various Dell servers and other equipment. But no, for Mikrotik, you have to manually set the speeds on both ends.
Where's the problem? Some hardware issue on used chipset/cpu on Mikrotik side? Bad implementation? Incompatibility of some SFPs? Or just laziness to do it right?
And "Just disable auto negotiation and set rate manually" is NOT the solution. What if you can't set other side of the link? Often any administrative change of parameters of upstream link costs extra money. This needs to be either fixed or have warning written on all Mikrotik product pages that SFP port doesn't support auto negotiation. It's 2018 and you expect these things to just work. If there was a list of verified SFPs that do work, that would be fine. But so far it seems auto negotiation on SFP port just doesn't work, no matter what SFP or DAC you use.
Fix it or say clearly it's not supported and will never work!

I have some machines that don't allow disabling auto negotiation on onboard NICs and they improperly negotiate link with S+RJ10 to 10G even though servers have gigabit link. With disabled autonegotiation link doesn't establish at all.

Yes those are shitty machines - deal with it. What to expect, if they weren't I could probably afford Cisco in the first place.
 
overflowed
just joined
Posts: 5
Joined: Thu Nov 14, 2013 3:14 am

Re: RB4011

Sat Dec 01, 2018 12:37 am

Personally I am replacing a rb2011uias-2hnd-in, I never used LCD, USB or speaker, so this is not a big deal for me with the cpu power available. The upgrade on the wireless side is much more a thing for me.
Ordered today the wifi version, found exactly one distributor who has like 40 on stock according their website so seems they are finally in stock. Not sure if I could post which, but it’s one from Latvia with inernational shipping that was in the first results when doing a google search after the full device name.
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Sat Dec 01, 2018 1:08 am

Personally I am replacing a rb2011uias-2hnd-in, I never used LCD, USB or speaker, so this is not a big deal for me with the cpu power available. The upgrade on the wireless side is much more a thing for me.
Ordered today the wifi version, found exactly one distributor who has like 40 on stock according their website so seems they are finally in stock. Not sure if I could post which, but it’s one from Latvia with inernational shipping that was in the first results when doing a google search after the full device name.
I don't think it's "secret" anymore. More and more distributors have wifi version available. Eg. CDR in Poland already has them. I randomly checked few days ago. Probably plenty of distributors already have them.
 
codruts
just joined
Posts: 4
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011

Sun Dec 02, 2018 2:09 pm

is the 20/24/80/160mhz setting working? tried to use it (default channels or not, various countries or debug, various combinations of main channel and extensions) but wireless adapter (intel ac7260) stopped to see it. on 20/40/80 it works normally (even in the meantime i did a complete reset on 4011, because playing with these various settings made the 5ghz interface inoperable :) )
 
User avatar
AKSN74
just joined
Posts: 9
Joined: Sun Apr 26, 2015 5:06 pm
Location: Taichung, Taiwan.

Re: RB4011

Mon Dec 03, 2018 11:31 am

Hi there,

Few weeks ago, I got my own RB4011 with wireless version.
Let me share few points about this device:
1. The CPU has very well performance, I tested performance with pure NAT, and it only got about 27~30% CPU usage with 1Gb full speed.
螢幕快照 2018-11-26 下午2.48.24.png
2. Tested performance with my iPhone Xr, using iPerf to test can got about 380~420Mb/s, and sometimes can got over 500Mb/s when iPhone sending packet during test.
3. The case is close to full-metal design (I know the bottom half case is plastic), the CPU is directly using thermal pad to touch metal case to cooling. The CPU temperature is not over 45C since started using.

In summary, this one is a beast, and the price is very well, too. Now decided to use as backup router in my office if main is down (the main is SRX240)

(P.S 160MHz in 5G WIFI is not working on many normal clients, need to set up to 80MHz only.)
You do not have the required permissions to view the files attached to this post.
 
codruts
just joined
Posts: 4
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011

Mon Dec 03, 2018 6:20 pm

some tests made with RB4011iGS+5HacQ2HnD and CCR1009-7G-1C-1S+, using bandwidth server, default mtu.
1. i managed to use a 3m direct attach cable between the two sfp+ ports; 10gbps link is negotiated, but is somewhat asymmetrical:
*RB client, CCR server
send, udp - 1650mbps
send, tcp - 740 mbps
receive, udp - 1500kbps
receive, tcp - 500kbps
*CCR client, RB server
send, udp - 2mbps
send, tcp - 500kbps
receive, udp - 1550mbps
receive, tcp - 740mbps
2. after this, i used S+RJ10 and a 2m cat6 patchcord
*RB client, CCR server
send, udp - 1620mbps
send, tcp - 770mbps
receive, udp - 2048mbps
receive, tcp - 900mbps
*CCR client, RB server
send, udp - 2048mbps
send, tcp - 900mbps
receive, udp - 1550mbps
receive, tcp - 740mbps
These 2gbps values are completely stable, not even a spike. cpu un rb is max 25%, on ccr 12%
I'm asking myself... is RB SFP+ link to cpu limited to 2gbps, like these two switches inside, by pcie 1.0 x1?
my first verdict: could be a router offered by providers for future implementations of 2gbps pppoe. or usable as AP, with some smaller wired clients, maybe one with lacp.
 
Quindor
Member
Member
Posts: 337
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB4011

Mon Dec 03, 2018 9:31 pm

some tests made with RB4011iGS+5HacQ2HnD and CCR1009-7G-1C-1S+, using bandwidth server, default mtu.
Just to be sure, during these tests, you didn't use bandwidth server or testing tools on the Routerboards themselves correct? Only using clients (PC's) that are in front and behind the routers mentioned? If not, and your results seem to suggest this, you are only testing the CPU's in the Routerboards in how well they can generate traffic, not how much traffic they can handle while it's running through the boards, like in a real-world scenario.

The built-in testing tools are only intended to be used to test line bandwidth from one routerboard to another, if you have above a few hundred Mbit's of bandwidth, other factors become the limiting factor and they are useless.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
codruts
just joined
Posts: 4
Joined: Thu Nov 01, 2018 10:38 am

Re: RB4011

Mon Dec 03, 2018 10:34 pm

The built-in testing tools are only intended to be used to test line bandwidth from one routerboard to another, if you have above a few hundred Mbit's of bandwidth, other factors become the limiting factor and they are useless.
this is what i intended to do. ccr will do better, for sure, but i was intrigued about that fixed line on 2gbps. again, 2.5gbps = pcie 1.0 x.1
i'll do some more tests these days, in a live 10gbps enviroment
 
Quindor
Member
Member
Posts: 337
Joined: Tue Aug 14, 2012 2:57 am
Location: Noord-Brabant, The Netherlands
Contact:

Re: RB4011

Tue Dec 04, 2018 11:55 am

The built-in testing tools are only intended to be used to test line bandwidth from one routerboard to another, if you have above a few hundred Mbit's of bandwidth, other factors become the limiting factor and they are useless.
this is what i intended to do. ccr will do better, for sure, but i was intrigued about that fixed line on 2gbps. again, 2.5gbps = pcie 1.0 x.1
i'll do some more tests these days, in a live 10gbps enviroment
Sorry, but I don't think you quite understand. What you have tested is CPU performance, not bandwidth. And in that regard, the RB4011 would actually preform better then a CCR because of higher single threaded performance (The newest newest beta version introduces some multi-threaded performance testing).

If you can test in a live 10Gbit environment and have 2 test boxes (PC's) which can generate and receive the traffic running through the devices, that will be a great test! :D

Testing the 2.5Gbit limit for switch ports is interesting though. Maybe you could also setup a test with multiple clients and then testing 2 switch groups and also in between them.
http://www.campzone.nl World's Largest Outdoor LANParty, http://intermit.tech Intermittend Technology blog, My blog about the ESP8266, IP Camera's and other tech related subjects!
 
Dejan
newbie
Posts: 30
Joined: Wed Apr 22, 2015 8:28 am

Re: RB4011

Tue Dec 04, 2018 11:46 pm

Today Im receive my RB4011iGS+5HacQ2HnD to replace current hAP ac(RB962UiGS-5HacT2HnT). After configuring it to same settings as hAP ac and connecting fibre module to sfp+ I get no link and spf+ interface start flapping:
mikrotik_sfp.jpg
Same configuration work normaly with same fibre module in sfp+ port on CRS326-24G-2S+RM(RouterOS mode)...

After researching and testing and setting different options it start working, then Im figure out that Im disable and enable sfp+ interface and after that it start working normaly... Im retest if this is true(only after reboot sfp+ have problems) and make workaround fix... Because I have on sfp+ pppoe client(and some vlans) Im made script which check if pppoe is connected and if not it disable and enable sfp+ port. Im also make scheduler after reboot and then every 15 seconds which run this script. Im try few reboots and shutdowns and it work without problems. I know that this solution will not work for users which don't have pppoe but maybe help someone also help fix flapping issue using different checking(some remote ip...)
You do not have the required permissions to view the files attached to this post.
 
rb9999
just joined
Posts: 2
Joined: Thu Dec 06, 2018 3:09 pm

Re: RB4011

Thu Dec 06, 2018 3:36 pm

So... got RB4011 (wifi edition) couple of days ago... It replaced my hapAC as well :) I just love it has encryption offloading (cpu usage stays under 10% pretty much no matter what - even wen using aes256-sha512). I am however missing USB port, LCD would be nice although not mandatory... And... Is it just me or is SPF+ port mounted upside down? I had couple of issues conntecting it to a switch using LR fiber optics cable, but disabling autonegotiation and setting 10G-full on both sides did the trick.
 
Dejan
newbie
Posts: 30
Joined: Wed Apr 22, 2015 8:28 am

Re: RB4011

Fri Dec 07, 2018 2:28 pm

In my configuration disabling autonegotiation is not availible option because Im replace ISP Iskratel Innbox V60-U modem with mikrotik and put fibre and SFP module direct on mikrotik, that I don't need 2 devices, can send IPTV&VOIP&INTERNET on same UTP cable(Instead runing each cable for each device) and in this case I don't have access to ISP side to disable autonegotiation.
But Im happy that Im find solution to fix flaping link after reboot(Disabling sfp+ & pppoe client wait 5 seconds and enable both back - if do not help repeat procedure after 20 seconds)...
 
saper2
just joined
Posts: 12
Joined: Sun Jun 14, 2015 2:00 pm

Re: RB4011

Fri Dec 07, 2018 6:15 pm

And... Is it just me or is SPF+ port mounted upside down?
Yes, it is :D , seems the board is mounted upside-down too (the SFP+ cage and LAN ports are aligned to up side), the LAN ports are upside-down too, "release handle" (don't know how to name it in english :lol: ) on rj45 plug is up too, not down - this also indicating that the PCB is upside-down :) .
Also AKSN74 describing the case materials :)
3. The case is close to full-metal design (I know the bottom half case is plastic), the CPU is directly using thermal pad to touch metal case to cooling. The CPU temperature is not over 45C since started using.
So yes, main board is flipped over (or the CPU is only on top side, connectors, leds, etc. are on bottom side) so the CPU can touch a metal top cover which work as heat sink for CPU.

Would be nice to see HQ photos of what is inside RB4011 :D (both pcb sides :D and with removed thermal pads ).

I'm getting convinced more and more to RB4011 - I wanted to buy rb3011 as my home router, but I'm still hesitating because of the switch chip in rb4011 which is a bit worse than in RB3011, and the SFP+ port which I know won't work with 1G media converters build on Qualcomm chip (like MT RBFTC (yes!) or those cheap RJ45 10/100/1000M to 1G SFP) - Realtek chip based MC works fine (but those are very hard to get in reasonable prices)...
But looking at tests seems the CPU is pretty good match with this castrated-switch-chip, so I have to think really good about the SFP+ port issue and decide which to pick :)
 
pe1chl
Forum Guru
Forum Guru
Posts: 4867
Joined: Mon Jun 08, 2015 12:09 pm

Re: RB4011

Fri Dec 07, 2018 6:52 pm

In my configuration disabling autonegotiation is not availible option because Im replace ISP Iskratel Innbox V60-U modem with mikrotik and put fibre and SFP module direct on mikrotik, that I don't need 2 devices, can send IPTV&VOIP&INTERNET on same UTP cable(Instead runing each cable for each device) and in this case I don't have access to ISP side to disable autonegotiation.
It appears that having autonegotiation on one end and not the other is not a problem on SFP.
Of course on copper ethernet this is a definite no-no as it will end up in one side halfduplex and the other fullduplex.
But on SFP it appears to work different.
Did you actually try setting autonegotiation off and the correct speed and fullduplex, and what happens then?
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Fri Dec 07, 2018 7:42 pm

It appears that having autonegotiation on one end and not the other is not a problem on SFP.
Of course on copper ethernet this is a definite no-no as it will end up in one side halfduplex and the other fullduplex.
But on SFP it appears to work different.
Did you actually try setting autonegotiation off and the correct speed and fullduplex, and what happens then?
Well... I didn't have such experience. For me disabling autoneg on S+RJ10 and connecting it to onboard NIC of device that doesn't support disabling autoneg simply resulted in "no-link" reported by that device and no connectivity at all. Lack of connectivity whatsoever is quite serious issue in network :P
 
pe1chl
Forum Guru
Forum Guru
Posts: 4867
Joined: Mon Jun 08, 2015 12:09 pm

Re: RB4011

Fri Dec 07, 2018 8:01 pm

You should not do it with copper ethernet, as I already wrote.
But with fiber it appears to work OK.
Maybe because it cannot work in halfduplex anyway and the speed can be selected to match.
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Fri Dec 07, 2018 8:16 pm

You should not do it with copper ethernet, as I already wrote.
But with fiber it appears to work OK.
Maybe because it cannot work in halfduplex anyway and the speed can be selected to match.
Yeah it really sucks because S+RJ10 doesn't autoneg to gigabit. Even if there's 1G on the other end it still autonegs to 10G. It's terrible module like I said bilion times. Objectively. The only thing that saves its name is price.
 
Dejan
newbie
Posts: 30
Joined: Wed Apr 22, 2015 8:28 am

Re: RB4011

Fri Dec 07, 2018 8:34 pm

In my configuration disabling autonegotiation is not availible option because Im replace ISP Iskratel Innbox V60-U modem with mikrotik and put fibre and SFP module direct on mikrotik, that I don't need 2 devices, can send IPTV&VOIP&INTERNET on same UTP cable(Instead runing each cable for each device) and in this case I don't have access to ISP side to disable autonegotiation.
It appears that having autonegotiation on one end and not the other is not a problem on SFP.
Of course on copper ethernet this is a definite no-no as it will end up in one side halfduplex and the other fullduplex.
But on SFP it appears to work different.
Did you actually try setting autonegotiation off and the correct speed and fullduplex, and what happens then?
Im not shure. When Im uncheck "Auto Negotation" I think Im together with checking "1000M full" also check "1000M half"(My mistake) and didn't work. It is on remote location and can't test this weekend... I will try again next week...
 
mc713
just joined
Posts: 1
Joined: Sat Dec 08, 2018 1:12 am

Re: RB4011

Sat Dec 08, 2018 1:22 am

Hello,

I confirm the SFP flaping problem on the RB4011.
I'm using it with this 1G optical interface of my FTTH ISP (1gbps up/down access): https://www.flexoptix.net/en/sfp-bidi-t ... 3095=42306

I tried to disable autonegociation trying the different options, enable/disable, reboot, perform firmware update but it still doesn't work.
My access and optic has no problem and work perfectly on my RB2011 with SFP os this is really a problem with this router.
The optic is recognised in the RB4011 (see dump below) and doesn't indicate problems.

My question is : is it a hardware problem that cannot be fixed by firmware update ?
If this is the case then I will give up this router and look for another solution (maybe use a RB3011).

Thank you for your help,

Mc

The optic is recognised in the RB4011 , here's a partial dump of a /interface ethernet monitor... :
sfp-module-present: yes

sfp-rx-loss: no

sfp-tx-fault: no

sfp-type: SFP-or-SFP+

sfp-connector-type: LC

sfp-link-length-9um: 10000m

sfp-vendor-name: FLEXOPTIX

sfp-vendor-part-number: S.B1312.10.DL

sfp-vendor-revision: A

sfp-vendor-serial: F789HH6

sfp-manufacturing-date: 15-10-14

sfp-wavelength: 1310nm

sfp-temperature: 54C

sfp-supply-voltage: 3.257V

sfp-tx-bias-current: 26mA

sfp-tx-power: -5.699dBm

sfp-rx-power: -3.867dBm

eeprom-checksum: good
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: RB4011

Sat Dec 08, 2018 2:16 pm

You'll have to disable autonegotiation on both ends of the link for SFP to work correctly.

https://wiki.mikrotik.com/wiki/MikroTik ... ansceivers

If you cannot control the setting on the remote end, the scenario is not supported.
 
pe1chl
Forum Guru
Forum Guru
Posts: 4867
Joined: Mon Jun 08, 2015 12:09 pm

Re: RB4011

Sat Dec 08, 2018 4:23 pm

We have a link between an RB2011 and an RB260 using two Net Insight NPA0022-LJ11 SFP fiber modules and it works
fine no matter if it is configured for autonegotiation or fixed 1G/Fulldup at either end...
(before it was configured for autoneg but I have disabled it because we plan to change to a bidir SFP which works only
without autoneg and wanted to prepare the config for that. so first disabled it at one end, expecting a link failure, but no.
and it was transporting traffic at that time!)
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: RB4011

Sat Dec 08, 2018 4:32 pm

Yes, but both RB2011 and RB260GSP have SFP ports, not SFP+
 
Paternot
Member
Member
Posts: 444
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: RB4011

Sun Dec 09, 2018 2:18 am

We have a link between an RB2011 and an RB260 using two Net Insight NPA0022-LJ11 SFP fiber modules and it works
fine no matter if it is configured for autonegotiation or fixed 1G/Fulldup at either end...
(before it was configured for autoneg but I have disabled it because we plan to change to a bidir SFP which works only
without autoneg and wanted to prepare the config for that. so first disabled it at one end, expecting a link failure, but no.
and it was transporting traffic at that time!)
The autonegotiation problem only affects SFP+ ports, with 1 Gbit modules - the SFP ones are ok.
 
Dejan
newbie
Posts: 30
Joined: Wed Apr 22, 2015 8:28 am

Re: RB4011

Sun Dec 09, 2018 7:08 pm

We have a link between an RB2011 and an RB260 using two Net Insight NPA0022-LJ11 SFP fiber modules and it works
fine no matter if it is configured for autonegotiation or fixed 1G/Fulldup at either end...
(before it was configured for autoneg but I have disabled it because we plan to change to a bidir SFP which works only
without autoneg and wanted to prepare the config for that. so first disabled it at one end, expecting a link failure, but no.
and it was transporting traffic at that time!)
The autonegotiation problem only affects SFP+ ports, with 1 Gbit modules - the SFP ones are ok.
Yes but problem is only on RB4011 model. On CRS326-24G-2S+RM(RouterOS mode) same 1Gbit module in SFP+ port work without problem...
 
Paternot
Member
Member
Posts: 444
Joined: Thu Jun 02, 2016 4:01 am
Location: Niterói / Brazil

Re: RB4011

Sun Dec 09, 2018 10:58 pm

We have a link between an RB2011 and an RB260 using two Net Insight NPA0022-LJ11 SFP fiber modules and it works
fine no matter if it is configured for autonegotiation or fixed 1G/Fulldup at either end...
(before it was configured for autoneg but I have disabled it because we plan to change to a bidir SFP which works only
without autoneg and wanted to prepare the config for that. so first disabled it at one end, expecting a link failure, but no.
and it was transporting traffic at that time!)
The autonegotiation problem only affects SFP+ ports, with 1 Gbit modules - the SFP ones are ok.
Yes but problem is only on RB4011 model. On CRS326-24G-2S+RM(RouterOS mode) same 1Gbit module in SFP+ port work without problem...
Not quite
https://wiki.mikrotik.com/wiki/MikroTik ... ansceivers
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Mon Dec 10, 2018 6:28 am

We have a link between an RB2011 and an RB260 using two Net Insight NPA0022-LJ11 SFP fiber modules and it works
fine no matter if it is configured for autonegotiation or fixed 1G/Fulldup at either end...
(before it was configured for autoneg but I have disabled it because we plan to change to a bidir SFP which works only
without autoneg and wanted to prepare the config for that. so first disabled it at one end, expecting a link failure, but no.
and it was transporting traffic at that time!)
The autonegotiation problem only affects SFP+ ports, with 1 Gbit modules - the SFP ones are ok.
Yes but problem is only on RB4011 model. On CRS326-24G-2S+RM(RouterOS mode) same 1Gbit module in SFP+ port work without problem...
Not quite
https://wiki.mikrotik.com/wiki/MikroTik ... ansceivers
I can confirm 1G in SFP+ on 3xx series switches requires disabling autoneg. My 1G copper doesn't even detect link until autoneg is disabled.
 
R1CH
Forum Veteran
Forum Veteran
Posts: 723
Joined: Sun Oct 01, 2006 11:44 pm

Re: RB4011

Mon Dec 10, 2018 7:57 pm

Really happy with the performance on this device, replaced an aging RB951G that had to used fasttrack and the 4011 handles our 500mbps internet with traffic shaping and IPv6 tunnels with only 25% CPU usage. Only thing I want now is root to install DNSCrypt proxy - anyone found a nice way to root this yet? The RouterOS version it ships with has CVE-2018-14847 patched so I can't use the winbox exploit to create devel login, and no USB port :(. Hoping to avoid pulling it out of production too long, but netbooting might be the only way it seems.
 
rb9999
just joined
Posts: 2
Joined: Thu Dec 06, 2018 3:09 pm

Re: RB4011

Mon Dec 10, 2018 9:05 pm

Fun fact... According to https://wiki.mikrotik.com/wiki/MikroTik ... lity_table S+DA0001/S+DA0003 aren't supported but... Just tested S+DA0001 (SFP+DAC1M) with a Zyxel XGS 2210 the other side and using autoneg off, 10g fdx, and it seems to work (link up, data flow ok)
 
User avatar
lapsio
Member
Member
Topic Author
Posts: 378
Joined: Wed Feb 24, 2016 5:19 pm

Re: RB4011

Tue Dec 11, 2018 7:49 am

Fun fact... According to https://wiki.mikrotik.com/wiki/MikroTik ... lity_table S+DA0001/S+DA0003 aren't supported but... Just tested S+DA0001 (SFP+DAC1M) with a Zyxel XGS 2210 the other side and using autoneg off, 10g fdx, and it seems to work (link up, data flow ok)
iirc MikroTik said that some kind of error correction that is technically required for passive DACs is not supported on 4011 but I guess if you don't have much of em noise in your environment and cable is short (like MikroTik ones) then probably it's not big deal thus "usually" it will work. In average environment.
 
uncleVALERA
just joined
Posts: 3
Joined: Fri Jan 07, 2011 10:31 pm

Re: RB4011

Thu Dec 13, 2018 12:01 pm

Hello!
I have the following router
model: RB4011iGS+
factory-firmware: 6.43
current-firmware: 6.43.4
pgrade-firmware: 6.43.4

I have instaled SFP module S-53LC20D in SFP+ port of the router. The port has the following settings:
auto-negotiation disabled
port speed 1G
FD
A SFP module S-35LC20D has installed in a switch on the provider's side with auto-negotiation disabled
I think the distance is about 2-5 km

But i have seen as SFP+ interface flapping more times
dec/12 20:54:36 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:37 interface,info sfp-sfpplus1 link down 
dec/12 20:54:39 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:40 interface,info sfp-sfpplus1 link down 
dec/12 20:54:42 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:43 interface,info sfp-sfpplus1 link down 
dec/12 20:54:45 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:46 interface,info sfp-sfpplus1 link down 
dec/12 20:54:48 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:49 interface,info sfp-sfpplus1 link down 
dec/12 20:54:51 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:52 interface,info sfp-sfpplus1 link down 
dec/12 20:54:54 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:55 interface,info sfp-sfpplus1 link down 
dec/12 20:54:57 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:54:58 interface,info sfp-sfpplus1 link down 
dec/12 20:55:00 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:55:01 interface,info sfp-sfpplus1 link down 
dec/12 20:55:03 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
dec/12 20:55:04 interface,info sfp-sfpplus1 link down 
dec/12 20:55:06 interface,info sfp-sfpplus1 link up (speed 1G, half duplex) 
But i see as SFP+ interface flapping a lot of times.
That transceiver work as normal in a switch CSS106-5G-1S from my side. So the link has not issues.
I looked URLs https://wiki.mikrotik.com/wiki/MikroTik ... ansceivers and https://wiki.mikrotik.com/wiki/MikroTik ... lity_table
and i was sure that SFP+ port can work with SFP 1G trancivers.

Where is issue?
Last edited by uncleVALERA on Thu Dec 13, 2018 6:08 pm, edited 1 time in total.
 
wolfktl
just joined
Posts: 18
Joined: Thu Jun 27, 2013 6:07 pm

Re: RB4011

Thu Dec 13, 2018 12:30 pm

same problem with SFP 1G . Auto-negotiation is off. Module GL-OT-SG06SC1-1310-1550-B peremeshano works with RB2011
Mikrotik HELP!!!! All users have a problem with SFP 1G
 
nescafe2002
Member
Member
Posts: 486
Joined: Tue Aug 11, 2015 12:46 pm
Location: Netherlands

Re: RB4011

Thu Dec 13, 2018 12:32 pm

Are you sure the sfp is configured full duplex on the other side? Then it seems a supported configuration. Have you contacted support?
 
psannz
Frequent Visitor
Frequent Visitor
Posts: 54
Joined: Mon Nov 09, 2015 3:52 pm
Location: Renningen, Germany

Re: RB4011

Thu Dec 13, 2018 12:57 pm

I have instaled SFP module S-53LC20D in SFP+ port of the router. The port has the following settings:
.............
Where is issue?
What's the cable length between those SingleMode transceivers? Rough estimate works. 500m? 1km? 2km? 5km? 10km? 15? 20km?
I'm pretty sure we're looking at a dampening issue here.
  • 1
  • 3
  • 4
  • 5
  • 6
  • 7

Who is online

Users browsing this forum: Guntis, Pranja and 16 guests