Community discussions

 
tkrjasek
just joined
Topic Author
Posts: 8
Joined: Mon Feb 25, 2013 11:12 am

RB760iGS (hEX S) SFP compatibility issues

Thu Sep 06, 2018 12:56 pm

After cold reboot (power off, power on) occasionally SFP doesn't get link up.
SFP diagnostic works normal, even values shown are the same as when it has link.

I tested SingleMode (1550/1310 nm) SFP brands: Optokon, GigaLight and 2 other Cisco compatible, I read on czech forum Maxlink SFP has the same problem (and someone wrote that even Mikrotik SFP doesn't work reliably). Those SFP work without problem on all our other devices, even on other Routerboards (RB2011) it works fine.

Devices on the other side: Edge-Core switches (ECS4120-28T, ECS4210-28T), Routeboards (RB760iGS, RB960PGS).

It happens 1-4 times out of 10, I couldn't find any relation.

Only cold reboot(s) helps, warm reboot (/system reboot) doesn't help (also warm reboot doesn't cause such problem).

I tried turning autonegotiation off and setting speed to 1Gbit on both sides - that didn't help.

It happens both on stable (6.42.7) and RC (6.43rc66) SW versions.

Nothing Mikrotik support suggested helped:
* disabling the interface on both ends
* setting the /system routerboard settings set boot-delay value (higher/lower than 2s)

And their conclusion "It seems to be a compatibility issue, we will try to improve it in the future, but for now it seems they are not compatible with our devices." doesn't help much.

If anyone found SFP that 100% work, please share. I have yet to (purchase and) test S-3553LC20D.
 
msatter
Forum Guru
Forum Guru
Posts: 1229
Joined: Tue Feb 18, 2014 12:56 am
Location: Netherlands / Nīderlande

Re: RB760iGS (hEX S) SFP compatibility issues

Thu Sep 06, 2018 2:24 pm

Two RB760iGS (hEX S) in series. One does PPPoE and both do IKEv2.
Running:
RouterOS 6.46Beta / Winbox 3.20 / MikroTik APP 1.3.4
Having an Android device, use https://github.com/M66B/NetGuard/releases (no root required)
 
tkrjasek
just joined
Topic Author
Posts: 8
Joined: Mon Feb 25, 2013 11:12 am

Re: RB760iGS (hEX S) SFP compatibility issues

Mon Sep 10, 2018 11:35 am

thanks, I missed that...will continue there

Who is online

Users browsing this forum: No registered users and 21 guests