Community discussions

MikroTik App
 
User avatar
LEA
newbie
Topic Author
Posts: 29
Joined: Tue Dec 12, 2017 5:02 pm
Location: Russian Federation, Novosibirsk
Contact:

RB3011UiAS-RM does not detect devices connected to the USB port

Thu Sep 13, 2018 9:26 pm

Hi, I need help in solving the problem I have with RB3011UiAS-RM.
I have been using this model RB3011UiAS-RM for almost a year and a half.
Recently, I decided to finally transfer The Dude Server from PC version to RB3011UiAS-RM. Pre-connect the USB flash drive to your RB3011UiAS-RM.
I created the ext3 file system on the flash disk by formatting the disk on the RB3011UiAS-RM device
After the transfer, everything worked perfectly on RB3011UiAS-RM, until one day there was a problem connecting to the database from the size of 64 MB dude stored on the flash drive.
I immediately realized that the problem is in the flash disk.
Before removing the flash disk from the device, a procedure was performed:
winbox
System ---> Disk List ---> Eject Drive
The diagnostics of the flash drive via a personal computer gave the following results that some of the memory cells of the flash disk are read with errors.

When connecting a new and working flash drive to the USB port on the RB3011UiAS-RM device, it does not give any results for its definition.

The execution of the command in the device terminal produces the following result:

/system resource usb print

# DEVICE VENDOR NAME SPEED
0 1-0 Linux 3.3.5 xhci-hcd xHCI Host Controller 480
1 2-0 Linux 3.3.5 xhci-hcd xHCI Host Controller 5000
2 3-0 Linux 3.3.5 xhci-hcd xHCI Host Controller 480
3 4-0 Linux 3.3.5 xhci-hcd xHCI Host Controller 5000

The power supply of the USB port is working properly. The constant current of + 5V is present.
I tried to connect various USB (standard 2.0 and 3.0) devices. The result is the same, connected to USB devices are not defined in RB3011UiAS-RM.

In this situation there can be two versions:
1.The problem is at the logical level in RouterOS;
2.The problem is at the hardware level, a malfunction of the USB interface.

Technical data of the device status

RouterOS v6.43;
System Health----> Voltage 23.9V (together with the flash drive (16Gb USB 2.0 Qumo nanoDrive (QM16GUD-NANO-B)) connected to the usb port);


What could be the reason? help me please.
 
User avatar
LEA
newbie
Topic Author
Posts: 29
Joined: Tue Dec 12, 2017 5:02 pm
Location: Russian Federation, Novosibirsk
Contact:

Re: RB3011UiAS-RM does not detect devices connected to the USB port

Sat Sep 15, 2018 8:30 pm

Today, I made the device diagnostics.

Step one, I tried to reset the settings on the device - the result remained unchanged.

Step two, replacing the power supply with a similar one - the result is unchanged.

Step three, measurement of temperature on the radio components inside the device - the temperature is within the limits of the norm.

Step Four, diagnostics of the logical state of the logical signals of the USB at the time of reboot of the device.
The result turned out to be quite interesting.

During the verification it was found out. If you use flash drive USB 2.0, after connecting it to the device. Then we get the following result.
- Reboot - reset all controllers and start the kernel load RouterOS, there is a power failure of the usb port, then power on.

After loading the router, the flash disk is recognized by the operating system. And also the stored files on the disk are displayed.
This works all until the physical removal of the flash drive from the USB port jack.
When reconnecting the flash drive to the USB port, it can no longer detect the flash drive.
This procedure with the definition of a flash drive only works by rebooting the device.

Works only with the version of USB 2.0. The version of USB 3.0 flash drive is not recognized!

I made a simple diagnosis using the passive USB of the hub (USB 2.0) which has a light indication of the connection status of the device.
The status of the power supply + 5V is always OK. Except for the reboot mode of the RB3011UiAS-RM device, when the power supply to the USB port is interrupted, the reset and loading of the device is required.
The LED indicator of the connection mode of the USB port of the communication port can display the following modes:
Step 1
- lit constantly - this is the normal operating mode, when the USB port RB3011UiAS-RM is in working order. You can connect and change flash drives. And everything will work.

Step 2
We pull out the connector of the USB-hub from the USB of the port 3011UiAS-RM, then reconnect it
If the LED indicator on the USB hub starts impulsively with the subsequent dimming in brightness - this means that the work of the USB port will become inaccessible.
If the hub is connected to the RB3011UiAS-RM USB port, the connection status LED will not light up.
Operation is possible only provided after restarting device RB3011UiAS-RM.

In this case, the reason for the strange operation of the USB port is not quite clear:
Logical error?
Hardware error?
 
wanton
just joined
Posts: 16
Joined: Wed Nov 21, 2018 6:06 pm

Re: RB3011UiAS-RM does not detect devices connected to the USB port

Fri Mar 29, 2019 11:10 am

Bumping this !

I have the same problem.

RB3011UiAS-RM does not detect USB device.

USB 3.0
32 Gb pendrive.

How can I test the USB ports health ? Apart from connecting a simple LED powered USB ???
 
User avatar
GreySer
just joined
Posts: 19
Joined: Thu Apr 21, 2016 9:38 am
Location: Cheboksary

Re: RB3011UiAS-RM does not detect devices connected to the USB port

Fri Mar 29, 2019 12:22 pm

Same trouble!
Works only usb 2.0 mode.
Malfunction of the first batch of devices.
Maybe the mikrotik will tell us, how to fix it.
Will the soldering of the connector help?

Who is online

Users browsing this forum: jebz and 31 guests